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Welcome to QADirector

QADirector is a test management solution designed to help testers, developers, and managers deliver
thoroughly tested applications on time and on budget.

Testing is a major undertaking that requires the coordination of many steps, many testers, large suites of
test scripts, and multiple versions of different applications. QADirector supplies a framework for managing
the entire testing process—from design, to execution, to analysis.

Plan and execute tests, analyze tests and track defects -- all from a single point of control.

The QADirector online documentation has been designed to help you learn and use every aspect of the
product.

This online help system has been organized as follows:

Administrating and Look here for information on assigning user passwords and
Configuring permissions, and maintaining the QADirector database.

Look here for information on creating and editing projects,
Creating and Managing assigning users to specific projects, and specifying start dates
Projects and end dates for projects.

Managing Test Scripts Look here for information on accessing test scripts, creating
categories for the scripts, and copying them to the Test Library.

Designing and Look here for information on creating and managing tests and
Organizing Tests suites, as well as using the Test Library.

Executing Tests in the Look here for information on viewing scheduled jobs (tests),
Suite jobs in progress, and performing further test execution tasks.
Analyzing Tests Look here for information on viewing job results, and

analyzing and comparing them.

Tracking Defects Look here for information on submitting defects and using
QADirector in conjunction with TrackRecord to track failed
scripts in a test application.
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Getting Started
Starting QADirector

The QADirector administrator should configure a database, team environment, and user roles, permissions,
and passwords before a user can open QADirector.

To start QADirector:

1. Open QADirector from the Windows Start menu. Click Start>Program Files>Compuware>QADirector.

2. When prompted, enter user name and password. User names and passwords are assigned by the QADirector
administrator in the System Administration Center. Consult with the QADirector administrator to obtain an ID and

password.
3. If necessary, select a data Source or server from the Data Source or Server list. If no data Source or server appear
in the list follow these steps:
a. Click the Configure button. The Select a Database dialog box appears. The information in this
dialog box must be entered correctly.
b. Select either the SQL Server/MSDE option or the Oracle option to select a data Source type.
C. Select a data Source name from the Data Source Name list.
d. Type the database name in the Database Name field. If using SQL Server, this should be Default.
e. Type a schema or owner name in the Schema/Owner Name field. If using SQL Server, this
should be Default.
f. Type a valid user name in the User Name field.
g. Type a valid password in the Password field.
h. Click Test to ensure the connection works.

i Click Ok to save the connection information and return to the Login screen.

If a message appears stating that the Test Management Server is not running:
1. Continue logging in to QADirector.

2. Before running tests, start the Test Management Server.

Starting QADirector

The QADirector administrator should configure a database, team environment, and user roles, permissions,
and passwords before a user can open QADirector.

To start QADirector:

1. Open QADirector from the Windows Start menu. Click Start>Program Files>Compuware>QADirector.

2. When prompted, enter user name and password. User names and passwords are assigned by the QADirector
administrator in the System Administration Center. Consult with the QADirector administrator to obtain an ID and
password.

3. If necessary, select a data Source or server from the Data Source or Server list. If no data Source or
server appear in the list follow these steps:



a.

QADirector Help

Click the Configure button. The Select a Database dialog box appears. The information in this

dialog box must be entered correctly.

b. Select either the SQL Server/MSDE option or the Oracle option to select a data Source type.

C. Select a data Source name from the Data Source Name list.

d. Type the database name in the Database Name field. If using SQL Server, this should be Default.
e Type a schema or owner hame in the Schema/Owner Name field. If using SQL Server, this

f.

g.
h.

should be Default.

Type a valid user name in the User Name field.
Type a valid password in the Password field.
Click Test to ensure the connection works.

Click Ok to save the connection information and return to the Login screen.

If a message appears stating that the Test Management Server is not running:

1. Continue logging in to QADirector.

2. Before running tests, start the Test Management Server.

About the Centers and Test Library

The QADirector interface lets you easily access the test management functions. QADirector's workspace is
center-oriented and is designed for both novices and experienced users:

Center Description

Defect Use the Defect Information Center to view and edit defects associated

Information with tests in the project. These defects are submitted through the Job

Center Information Center.

Job The QADirector Job Information Center lists all scheduled jobs, jobs in

Information progress, and results. From within this center, perform job execution

Center tasks. The Jobs panel is divided into two sections: result folders and the
job related tabs.

Project Use the Project Information Center to create or edit projects, assign

Information users to specific projects, and specity dates for projects. Since the tasks

Center performed in the Project Information Center are administrative, only
users with Administrative, Team Lead, and QA Manager roles can access
this center.

Suite Use the Suite Information Center to create and manage test suites. Test

Information suites are groups of tests applied to one application or one component of

Center an application. Test suites create order and control by defining which
tests are needed, grouping the tests logically, and designating the order in
which the tests should be run.

System The QADirector System Administration Center enables designated

Administration = QADirector administrators to perform a variety of tasks such as assigning

Center user passwords and permissions and maintaining the QADirector
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database.

Use the Script Information Center to access test scripts after they have

Script been created in third party tools. Additionally, use the Script
Information Information Center to create and organize user defined and manual
Center tests. Create categories to group scripts together. These categories can be

copied to the Test Library for easy access.

Test Library The Test Library is a repository for all available tests within a project. It
contains test classes, class templates, test procedures, and test scripts. The
Test Library makes it possible to use these tests in different suites within
a project. As tests are used across suites, changes are saved to the Test
Library and all suites.

Setting User Options

QADirector allows you to set personal preferences that control how QADirector appears and behaves while
you are using it. You can choose options that affect the appearance of the QADirector main window,
default test permissions, and type of information displayed during test execution.

To set user options:

1. Click Tools>User options. The User Options Dialog Box appears.
2. Click the various tabs to view and set options.

3. Click Apply to apply the options and select another tab.

4. Click OK to save the options and exit the dialog box.

The User Interface

About the User Interface

QADirector’s main window is the starting point for all test management activities. The Menu bar across the
top of QADirector provides access to many of the functions and features necessary for testing.

The items on the Tool bar below the menu are enabled in various centers and also provide an efficient way
to access these functions and features.

When clicking an icon from the Centers bar, the Center opens in the workspace. From this single toolbar,
navigate from center to center without disrupting work. QADirector retains the session information and
state in each center.

When opening QADirector for the first time, the Test Library will appear on the right side of the
workspace. The Test Library contains classes, procedures, and scripts for each project.

Using the QADirector Main Window

QADirector’s main window is the starting point for all test management activities. The window is divided
as follows:
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Centers Toolbar: This toolbar accesses all QADirector centers. From this single toolbar, navigate from
center to center without disrupting workflow. This is accomplished not only from the convenience of the
Centers toolbar, but also from QADirector retaining the session information and state in each center. For
example, while working in the Project Information Center, click the Suite Information Center to perform
another task, and then return to the Project Information Center. The Project Information Center opens to
the last task performed.

Workspace: When clicking an icon from the Centers toolbar, the Center opens in the workspace. Most
work is performed within the panels of each center in the workspace. Additionally, the workspace hosts
both windows and web forms.

Test Library: The test library contains classes, procedures, and scripts for each project. The Test Library
offers a way to reuse tests from suite to suite. To copy scripts, classes, or procedures from the Test Library
into the Suite, drag the test from the library to the Suite in the Suite Information Center. There is only one
Test Library per project.

When opening QADirector for the first time, the Test Library will appear on the right side of the
workspace.

Panels: Panels provide at-a-glance information. Perform tasks from each panel’s Actions menu or the right-
click shortcut menu. Panels will vary depending upon the center.

Status Bar: The status bar displays menu and toolbar icon descriptions and the status of any process. It also
displays current server or database, user, and role information.

Menus and Icons: Throughout QADirector's centers, there are Action menus and icons. These tools offer
flexibility when accessing different functions. For example, access the Filters Manager dialog box from the
Action menu of the Suite Center, Script Information Center, or Job Information Center panels. It is also
possible to access the Filters Manager dialog box from the right-click menu on the Test Library, the Tools
menu on the main menu bar, the filter icon on the toolbar, and the Filter icon on the Suite Information
Center's Suite panel.

Using the Centers Bar

This toolbar accesses all QADirector centers. From this single toolbar, navigate from center to center
without disrupting workflow.
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System Administration Center: Opens the System Administration Center panel

Project Information Center: Opens the Project Information Center panel

Script Information Center: Opens the Script Information Center panel

Suite Information Center: Opens the Suite Information Center panel

Job Information Center: Opens the Job Information Center panel

Defect Information Center: Opens the Defect Information Center panel

Using the Menu Bar

The menu bar is located at the top of the QADirector screen:

ﬂ QADirector

File Edit Miew Tools Centers

The following describes the sub-menu items available from the menu items.

Sub Menu

Description

File New

Open...
Close Project

Import

Suite

Class
Procedure
Script

User

Manual Test
Tool Domain
TM Server
Testing Tool
Filter

Project

04.05.01 Suite

Exchange File...

Creates a new Suite

Creates a new Class
Creates a new Procedure
Creates a new Script
Creates a new user

Creates a new Manual Test

Creates a new Tool Domain
Creates a new TM Server
Creates a new Testing Tool
Creates a new Filter

Creates a new Project
Opens a Project

Closes a Project

Imports 04.05.01 Suite Exchange
File
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Edit

View

2 Note: This feature is not

available if using QADirector with
CARS Workbench.

05.00 or greater
versions of Project
Exchange File...

MS Word/Excel
Import Wizard for
Suites...

Export...

2l Note: This feature is not available if using QADirector with
CARS Workbench.

Recent Projects

Exit

Properties...

Cut
Copy
Paste

Paste Multiple...
Duplicate
Delete

Rename
Test Library
Centers bar
Status bar
Collapse
Collapse All
Expand
Expand All

Refresh

Imports 05.00 Project Exchange File

Opens the MS Word/Excel Import
Wizard for Suites

Opens the Export Project
Information dialog box to save the
project as an Exchange file

Displays a sub-menu of recent
projects

Exits QADirector

Displays the User Properties Dialog
Box

Removes a selected item
Copies a selected item
Pastes a selected item

Pastes multiple versions of a
selected item

Duplicates a selected item, retaining
its parents' settings

Permanently removes a selected
item

Allows an item to be renamed
Displays or hides the Test Library
Displays or hides the Centers bar
Displays or hides the Status bar
Collapses a selected item on a tree
Collapses the entire tree

Expands a selected item on a tree
Expands the entire tree

Updates information on the current
screen
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Tools

Centers

User Options...

Change Password...

Manage Custom Menus...

Manage Filters...

Manage Template Attributes...

QACenter

Manage Product Integrations...

Export Attributes to Text File...

3 Note: This feature is not available if using QADirector with

CARS Workbench.

System Administration
Center

Project Information Center

Script Information Center

Suite Information Center

Go to System
Administration
Center

Launch ODBC
Manager...

Change
Datasource/Server...

Role Permissions...
Shut Down TE
Server

Go to Project
Information Center

Manage Users...

Go to Script
Information Center

Go to Suite
Information Center

Displays the User Options Dialog
Box

Displays the Change Password
Dialog Box

Displays the Customize Custom
Menu Dialog Box

Displays the Manage Filters Dialog
Box

Displays the Template Attributes
Dialog Box

Displays a list of QACenter
products. Installed products are
enabled on the toolbar.

Displays the Manage Product
Integrations Dialog Box

Displays a Browse Dialog Box

Changes the panel to System
Administration Center

Displays the ODBC Data Source
Administrator Dialog Box

Displays the Select a Database
Dialog box

Displays the Manage Role
Permissions Dialog Box

Shuts down the Test Execution
Server

Changes the panel to Project
Information Center

Displays the Manage Users Dialog
Box

Changes the panel to Script

Information Center

Changes the panel to Suite
Information Center
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Reports

Help

Suite Permissions...

Manage Change
Logs...

Manage Locks...

Job Information Center Go to Job
Information Center

Manage Job
Folders...

Defect Information Center Go to Defect
Information Center

Launch QACenter Portal

2l Note: This feature is not available if using QADirector with
CARS Workbench.

Tutorial Install
Help

Contents

Index

Search

About QADirector

Displays the Suite Permissions
Dialog Box

Displays the Managing Logs Dialog
Box

Displays the Managing Locks Dialog
Box

Changes the panel to Job
Information Center

Displays the Manage Job Folders
Dialog Box

Changes the panel to Defect
Information Center

Accesses the QACenter Portal

Installs the tutorial application
Opens the help for the tutorial
Opens the online help Contents
Opens the online help Index
Opens the online help Search

Displays product About
information

Using the Toolbar

The toolbar is located at the top of the QADirector screen just under the Menu Bar:

a(]h (= |

5 | |88 | L B Ad

= B8

& |

The following describes the items available from this toolbar.

Toolbar Name Description

New

Suite Creates a new Suite
Class Creates a new Class
Procedure Creates a new Procedure
Script Creates a new Script
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Properties

Refresh Current View

Save

Save All

Publish
Publish All
Cut

Copy
Paste

Delete

Manage Filters

Expand
Expand All
Collapse
Collapse All
Manage Users

Launch ODBC Manager

10

User

Manual Test

Tool Domain
TM Server
Testing Tool
Filter

Project

Creates a new User

Creates a new Manual Test

Creates a new Tool Domain
Creates a new TM Server

Creates a new Testing Tool
Creates a new Filter

Creates a new Project

Displays the Properties Dialog Box

Updates information on the current
screen

Saves the changes made to the panel

Saves all changes made to
QADirector

Publishes a specific test
Publishes all tests
Removes a selected item
Copies a selected item
Pastes a selected item

Permanently removes a selected tool
or test

Displays the Manage Filters Dialog
Box

Expands a selected item on a tree
Expands the entire tree

Collapses a selected item on a tree
Collapses the entire tree

Displays Manage Users Dialog Box

Displays the ODBC Data Source
Administrator Dialog Box

2 Note: This feature is not available




Change Datasource

Manage Role Permissions

Show All Scripts
Hide Selected Group / Category
Run Selected Test

Manage Change Logs

Manage Test Locks

Manage Job Folders

Edit Schedule
Run Now
View Result
Abort Job

View Test Result Detail

View Defect

Edit Defect

if using QADirector with CARS
Workbench..

Displays the Select a Database Dialog
Box

2 Note: This feature is not available
if using QADirector with CARS
Workbench.

Displays the Manage Role
Permissions Dialog Box

Shows all scripts for a project
Hides a selected group or category
Runs a selected test in the project

Displays the Managing Logs Dialog
Box

Displays the Manage Locks Dialog
Box

Displays the Manage Job Folders
Dialog Box

Displays Scheduler Dialog Box

Runs the job

Displays the results for a current job
Aborts current job

Displays the Test Properties dialog
box for the specific test

Displays the QADirector View Defect
window

2 Note: This feature is not available
if using QADirector with CARS
Workbench.

Opens and displays the actual
TrackRecord defect

I Note: This feature is not available
if using QADirector with CARS
Workbench.

QADirector Help

11
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Delete Defect Association Deletes the defect association from
the selected test, but the defect still
remains in the database.

I Note: This feature is not available
if using QADirector with CARS
Workbench.

Adding Custom Menus

To use third-party tools with QADirector, add custom menu commands for specific actions. For example, if
integrating a defect tracking tool with QADirector, create menu commands for submitting and viewing
defects. If no other custom commands exist, the Custom menu is not visible in QADirector's menu. Once
the first command is created, the Custom menu will appear.

Using Keyboard Shortcuts
The following table contains all QADirector keyboard shortcuts.

Keyboard Shortcut Description

Ctrl+C Copies selected suite, class,
procedure, script, or text.

Ctrl+V Pastes copied or cut suite, class,
procedure, script, or text to selected
location.

Ctrl+X Cuts selected suite, class, procedure,

script, or text.

F1 Launches the dialog level help for
the active dialog box.

Using Mouse Keys

The standard Window's Mouse Keys function enables users to use the keyboard's number pad to navigate
the mouse.

To Enable Mouse Keys:

From the Window's Control Panel, click Accessibility Options.
Click the Mouse tab.

Click the Use Mouse Keys checkbox.

To change the settings, click the Settings button.

o 0D

Click Ok and then click Apply. The Mouse Keys icon will appear in the system task tray .The following table
describes the actions of the number pad when Use Mouse Keys is enabled.

Direction

Down and left

12
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2 Down

3 Down and right

4 Left

5 Enter button

6 Right

7 Up and left

8 Up

9 Up and right

0 Left mouse button click
+ Right mouse button click

Understanding QADirector Objects

Project

Suite

Classes

il
—

Procedures

Scripts

Projects are the highest level in the test hierarchy. Projects contain requirements, test suites, defects,
product integration information, user information, and the test library.

Suites contain all the test assets (classes and procedures) necessary to run scripts and complete a test. Test
suites create order and control by defining which tests are needed, grouping the tests logically, and
designating the order in which the tests should be run.

13
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Classes are logical groupings of test procedures and other test classes in the test suite. Create test classes to
group tests based on features, functions, or structure of an application, or by any other useful criteria. A
test suite can have as many levels of test classes as is necessary.

Procedures contain the scripts that run against test applications. Thus, test procedures are the part of the
test suite that check the behavior of the test application and report on the result.

Scripts are commands in test procedures that run a test of an application.

QADirector Processes

The following diagram illustrates how QADirector works various servers, databases and test machines.

N S o=

Test Execution 128t Driver/
Server Test Engine

o @ ,%@4@ 4

Test Execution Test Driver/
Test Management Server Server Tast Enging

-

Tast Execution  Test Drivar!
Server Test Engine

Test Machine 2
QADirector

Test Machine 3

QADirector uses a database repository to store suites, tests, and job results. This database is use
automatically unless the user connects to a different database. For more information on creating and
configuring databases refer to the QADirector Installation and Configuration Guide.

The Test Management Server (TM) reads job submissions from the database, manages jobs, tracks the
machines available for test execution, and manages the licenses used for manual test Web execution. It also
reports on the status of jobs in progress.

The Test Execution Server allows jobs to run on a computer. When requested by the Test Management
Server, the Test Execution Server starts the test driver, which subsequently starts the test engine. The Test
Execution Server also stores information about who is permitted to execute jobs on the computer.

QACenter Testing Process Outline

Whether you use Compuware's QualityPoint methodology, risk-based testing, or another testing
methodology, the QACenter suite of products can automate all aspects of the testing process. The
following outline provides an overview of the QACenter testing process.

14
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1. Manage business requirements in Reconcile.
Refer to the Reconcile Help system for detailed information about managing business requirements.

2. Import business requirements into QACenter for risk-based test planning in QACenter Portal.
Refer to the topic Importing Requirements into QACenter Portal in the QACenter Portal Help system.

3. Create Functional Test Requirement (FTR) from business/imported requirement in QACenter Portal.
Refer to the topic About Functional Test Requirements in the QACenter Portal Help system.

a. Assign risk (0-10). Refer to the following topics in the QACenter Portal Help system: Creating
Requirements, Test Requirement Percentile Values, and Functional Test Requirement Weights.
4. Decompose Test Requirements (TR) and assign risk in QACenter Portal.
a. Create Testing Requirement (TR) from FTRs. Refer to the topic Creating Requirements in the QACenter
Portal Help system.
b. Assign risk to TR (0-10). Refer to the following topics in the QACenter Portal Help system: Creating
Requirements, Test Requirement Percentile Values, and Functional Test Requirement Weights.
C. Determine cycle. Refer to the topic Test Planning Cycles in the QACenter Portal Help system.
5. Create test assets from Test Planning in QACenter Portal.

Refer to the following topics in the QACenter Portal Help system: Asset Generation and Generating Suites from
QACenter Portal.

a. Create test assets based on risk/cycle. Refer to the following topics in the QACenter Portal Help
system: Asset Generation and Run-Time Attributes.

6. Create test scripts and assign to procedures in QADirector.

a. Create Manual Test Scripts.

b. Create User-defined Test Scripts.

C. Create Automated Test Scripts.

7. Schedule test execution.

8. Execute the test.
a. Run Manual tests or Web Tests.
b. Run the Automated Testing Tools.

9. Review and analyze project data.

a. View detailed results.
b. Manage defects from QACenter Portal or QADirector. Refer to the topic Defect Tracking in the

QACenter Portal Help system.

QACenter Testing Process Diagram

The following diagram illustrates the testing process using the QACenter suite of products.
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About Risk-Based Testing

QACenter uses risk-based testing methodology. Risk-based testing is a testing methodology that reduces the
risk of distributing an application that doesn't meet business requirements and that does not function
reliably. It helps test organizations determine what things to test and prioritize testing based on the cost of
failure. The greater the probability of expensive failure, the more important it is to test that feature.

Adopting risk-based testing greatly improves the quality of applications, maximizes the utilization of
resources, and supports an on-time distribution. This is accomplished by:

aligning business requirements with testing efforts
using risk to prioritize the amount and kind of testing that's required

16
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identifying and quickly responding to changing business requirements
tracing the results back to the business requirements to measure risk in business terms
make necessary go/no-go decisions

Risk-based testing is a critical part of an overall testing methodology that aligns with the software
development life cycle. Risk-based testing, when used with a comprehensive testing methodology, provides
a repeatable process that facilitates continuous quality improvement.

Basic Risk-Based Testing Steps

The five basic steps to risk-based testing are:

Identify time-critical business issues.
Perform risk assessment.
Establish baseline.

Execute tests.

o~ DN E

Validate and document test results.

QACenter and Risk-Based Testing

Compuware's risk-based testing solution provides organizations with an objective mechanism to weigh and
prioritize what to test. It provides management visibility into their organization's testing efforts and the
knowledge to make informed go/no go decisions. Compuware's approach links testing to business
requirements by defining functional test requirements.

Assign risk to Functional Test requirements based on various business, technical and historical factors.
Create Test Cases to prove the requirements and executed based on their assigned priorities.
Summarize quality statistics by business requirement and priority.

Should requirements change, Compuware's risk-based testing solution automates the creation of a revised
testing plan. The solution allows reuse of testing assets throughout iterative testing cycles to expedite on-
time delivery.

QACenter risk-based testing provides an approach to prioritizing testing that relies on the quality assurance
users to assign risk and priority to tests. It provides management visibility into their organization's testing
efforts on a project-by-project basis and the knowledge to make informed go/no go decisions.
Compuware’s QACenter products make this process accurate, repeatable, and easy. QACenter walks
organizations through the entire testing process.

Benefits of Risk-Based Testing

The benefits of risk-based testing are numerous. A few are:
Defined process for improvement

Measure quality in business terms

17
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Quickly realign testing efforts
Repeatability

Effective use of resources

Reduction in customer reported problems
Reduction in maintenance cost
Reduction in test phase length

Find faults

Plan for the future
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Tutorial

Tutorial Overview

The QADirector Tutorial will guide you through each of the Centers used to Plan and execute tests, from
the System Administration Center to the Defect Information Center.

The QADirector Tutorial uses a sample test project, a sample suite, sample test classes, sample TestPartner
scripts, and a demonstration application called the Millennium International Bank (MIB) to introduce you
to the basic concepts of QADirector. By executing the sample TestPartner scripts against the MIB
demonstration application, you will learn the basic functions of QADirector.

You will not access the MIB demonstration application directly. The work you will perform for this
tutorial is performed in QADirector and TestPartner.

Requirements
Current version of QADirector
TestPartner version 5.2.1 or later and all its requirements including MS Access
Valid license for TestPartner
TrackRecord version 06.02
Components of the Tutorial
To support the tutorial, the following components are installed on your computer:
Demo Application

A demo application named Millennium International Bank (MIB) is installed with QADirector. The MIB
demo application is a simple banking application with seven main functions:

Create Customer Account
Inquire on Account
Deposit Funds
Withdraw Funds
Transfer Funds
Close Account
Exit
Tutorial Project

The Tutorial - {Username} project is created when the tutorial is selected from Help>Install Tutorial. This
is a project created to test the demo application. You will be required to add six test classes and six test
procedures. To each test procedure, you will add a test script.

TestPartner Scripts

TestPartner scripts are in a database named QAD4.MDB. Add the scripts to the test procedures in the
MIBTest suite in order to test the demo application.

Terminology

Before beginning the tutorial lessons, you may find it helpful to review some QADirector terminology:
Test Suite
Test Class
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Test Procedure

Test Script

Test

Tool Domain
Exploring the Main Window

The project for this tutorial is already created in QADirector when the tutorial is selected from Help>Install
Tutorial. It resides in the Project Information Center. Take a minute to study the main window.
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For more information see About the GUI.

Where to go next: Tutorial Setup Tasks

Tutorial Overview

The QADirector Tutorial will guide you through each of the Centers used to Plan and execute tests, from
the System Administration Center to the Defect Information Center.

The QADirector Tutorial uses a sample test project, a sample suite, sample test classes, sample TestPartner
scripts, and a demonstration application called the Millennium International Bank (MIB) to introduce you
to the basic concepts of QADirector. By executing the sample TestPartner scripts against the MIB
demonstration application, you will learn the basic functions of QADirector.

You will not access the MIB demonstration application directly. The work you will perform for this
tutorial is performed in QADirector and TestPartner.

Requirements

Current version of QADirector

TestPartner version 5.2.1 or later and all its requirements including MS Access
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Valid license for TestPartner

TrackRecord version 06.02
Components of the Tutorial
To support the tutorial, the following components are installed on your computer:
Demo Application

A demo application named Millennium International Bank (MIB) is installed with QADirector. The MIB
demo application is a simple banking application with seven main functions:

Create Customer Account
Inquire on Account
Deposit Funds
Withdraw Funds
Transfer Funds
Close Account
Exit
Tutorial Project

The Tutorial - {Username} project is created when the tutorial is selected from Help>Install Tutorial. This
is a project created to test the demo application. You will be required to add six test classes and six test
procedures. To each test procedure, you will add a test script.

TestPartner Scripts

TestPartner scripts are in a database named QAD4.MDB. Add the scripts to the test procedures in the
MIBTest suite in order to test the demo application.

Terminology
Before beginning the tutorial lessons, you may find it helpful to review some QADirector terminology:
Test Suite
Test Class
Test Procedure
Test Script
Test
Tool Domain
Exploring the Main Window

The project for this tutorial is already created in QADirector when the tutorial is selected from Help>Install
Tutorial. It resides in the Project Information Center. Take a minute to study the main window.
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For more information see About the GUI.

Where to go next: Tutorial Setup Tasks

Tutorial Setup Tasks

The following describes setup tasks to be completed before beginning the tutorial. These tasks are normally
completed by a user with administrator privileges to perform user and database maintenance.

Configure the User Names and Passwords

Both QADirector and TestPartner use a database, which allows team members to easily share project suites,
tests, and scripts. To ensure database security, both QADirector and TestPartner employ a combination of
user passwords and permissions to designate who has access to the databases.

Make sure that the User Name and Password used for QADirector are the same User Name and Password
used for TestPartner.

In QADirector, user maintenance is performed in the System Administration Center.
Establish a TrackRecord / QADirector Integration

To complete the section of this tutorial that uses TrackRecord, you must establish a TrackRecord /
QADirector integration before starting the tutorial. For integration information see Creating a Product
Integration.

In order to complete this tutorial, the administrator must give the user privileges to view and edit the tool
domain. For information on setting up a tool domain see Creating Tool Domains.

Create an ODBC Datasource and Add Scripts
Create an Access ODBC datasource and add scripts to use with TestPartner:

1. From the System Administration Center Datasource panel, click Actions>Launch ODBC
Manager. The ODBC Data Source Administrator dialog box appears.
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Click System DSN>Add. The Create New Data Source dialog box appears.

Select Microsoft Access Driver and click Finish. The ODBC Microsoft Access Setup dialog box

appears.

4. In the Data Source Name and Description fields type QAD Tutorial.

Click Select and navigate to the \Program Files\Compuware\QADirector\Tutorial \Mibgadb

directory.

6. Double click the file QAD4.mdb. This is the TestPartner database that contains the sample scripts

for testing the MIB application.

7. Click OK.
Open the Tutorial

Open the QADirector Tutorial by clicking Help>Tutorial>Install. The Tutorial Project opens in the Project

Information Center.
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Where to go next: Lesson One: System Administration Center

Tutorial Lessons

Lesson One: The System Administration Center

In the System Administration Center, you will create a TestPartner tool Domain. A tool domain is a set of
information that you enter about the testing tool that allows you to browse, select, and create scripts right
from QADirector. For example, a TestPartner tool domain includes the name and location of the
TestPartner script database, the database type, whether or not the database is public (can be used by
others), and so on. Make sure a Test Management Server and Test Execution Server are available.
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1. In the Tool Domains Pane click Actions>New Tool Domain. The Add Tool Domain dialog box
appears. Fill in this dialog box with the information below:
Name Field: Type MIBTest TestPartner Scripts.
Description Field: Type MIBTest TestPartner Scripts.

Type list: Choose TestPartner
Public: Select
Testing Tool Database field: Click the Browse button and select QAD Tutorial.
User Name field: Type Admin.
Password field: Type Admin.
2. Click Apply
3. Click OK

Where to go next: Lesson Two: The Project Center

Lesson One: The System Administration Center

In the System Administration Center, you will create a TestPartner tool Domain. A tool domain is a set of
information that you enter about the testing tool that allows you to browse, select, and create scripts right
from QADirector. For example, a TestPartner tool domain includes the name and location of the
TestPartner script database, the database type, whether or not the database is public (can be used by
others), and so on. Make sure a Test Management Server and Test Execution Server are available.
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1. In the Tool Domains Pane click Actions>New Tool Domain. The Add Tool Domain dialog box
appears. Fill in this dialog box with the information below:
Name Field: Type MIBTest TestPartner Scripts.

Description Field: Type MIBTest TestPartner Scripts.

Type list: Choose TestPartner
Public: Select
Testing Tool Database field: Click the Browse button and select QAD Tutorial.
User Name field: Type Admin.
Password field: Type Admin.
2. Click Apply
3. Click OK

Where to go next: Lesson Two: The Project Center
Lesson Two: Project Information Center

From the Project Information Center, you will set up an integration to TrackRecord. TrackRecord is
Compuware’s defect-tracking tool for distributed applications.

In the Project Pane of the Project Information Center you will see that the Tutorial Project is displayed.
1. Choose the TrackRecord checkbox.

2. From the Name list choose the TrackRecord Integration. This should have been established before
starting the Tutorial lessons. See Tutorial Setup Tasks.

Where to go next: Lesson Three: The Script Information Center
Lesson Three: Script Information Center/ Test Library

From the Script Information Center, add the scripts that you will use in the project to the Test Library. This
is a repository for all available tests within a project. It contains test classes, test procedures, and test
scripts. The Test Library makes it possible to use these tests in several different suites within a project. As
tests are used across several suites, changes are saved to the Test Library and all suites. For more
information see About the Script Information Center.

1. From the Test Tool list choose TestPartner. The TestPartner tool domain appears.
2. Select all the MIB TestPartner scripts:

CloseAccount
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3. Do one of the following to move the scripts into the Test Library:
Right click each script and choose Add to Library.
Drag the scripts to the library and drop them in.

The scripts are now in the library. If you go back into the Project Center, you will notice in the Project
Statistics pane that the Automated Test Scripts category is now populated with the number of scripts you
moved to the library.

Where to go next: Lesson Four: The Suite Information Center

Lesson Four
Lesson Four: Suite Information Center

The Suite Information Center contains all of the test assets (classes and procedures) necessary to run
scripts and complete a test. In QADirector, tests are organized in test suites. Typically, a test suite contains
all the tests needed that cover one application or one component of an application. Test suites create order
and control by defining which tests are needed, grouping the tests logically, and designating the order in
which the tests should be run.

A test suite is comprised of test classes and test procedures, all of which descend from a single test class
called the root class. The root class has the same name as the test suite and cannot be deleted. All other test
classes and test procedures descend from the root class.
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Test classes help maintain order within a suite. The MIBTest suite is designed to include seven test classes,
one for each of the six main components in the MIB demo application. You will create these seven test
classes, procedures and scripts using the identical process.
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Where to go next: Step 1: Create Customer Account test class and Associated Procedure and Script

Step 1: Create Customer Account Test Class and Associated Procedure and Script

Create a Suite, Test Class, Procedure and Script. You will create the Suite only once, in this step. In the
subsequent steps you will only add the class, procedure and script to this suite.

1. Click Actions>New Suite
2. Name the suite MIBTest
3. In the center pane, right click the MIBTest suite and choose New Test Class.
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4. Name the test class Create Customer Account.
5. Right click this test class and choose New Test Procedure.
6. Name the test procedure Add New Customer.
Now add the script to the procedure.
1. Double click the test procedure you have just created.
2. Click the Scripts tab.
3. Click Insert. The Add Test Scripts from Library dialog box appears.

4. Choose the TestPartner script CreateNewAccount, and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.

Where to go next: Step 2: Inquire on Account Test Class and Associate Procedure and Script

Step 2: Inquire on Account Test Class and Associated Procedure and Script
1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Inquire on Account.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Verify Customer Exists.
Now add the script to the procedure.
Double click the test procedure you have just created.
Click the Scripts tab.
Click Insert. The Add Test Scripts from Library dialog box appears.

Ll

Choose the TestPartner script CustomerVerification, and click Add. If the script is not there, go back
to Lesson 3 and add it.
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5. Click OK.
Where to go next: Step 3: Deposit Funds Test Class and Associated Procedure and Script

Step 3: Deposit Funds Test Class and Associated Procedure and Script

1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Deposit Funds.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Deposit Money.
Now add the script to the procedure.

1. Double click the test procedure you have just created.

2. Click the Scripts tab.

3. Click Insert. The Add Test Scripts from Library dialog box appeatrs.
4

Choose the TestPartner script DepositMoney and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.
Where to go next: Step 4: Withdraw Funds Test Class and Associated Procedure and Script
Step 4: Withdraw Funds Test Class and Associated Procedure and Script
1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Withdraw Funds.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Withdraw Money.
Now add the script to the procedure.
1. Double click the test procedure you have just created.
2. Click the Scripts tab.
3. Click Insert. The Add Test Scripts from Library dialog box appears.
4

Choose the TestPartner script WithdrawMoney and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.
Where to go next: Step 5: Transfer Funds Test Class and Associated Procedure and Script
Step 5: Transfer Funds Test Class and Associated Procedure and Script
1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Transfer Funds.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Transfer Money.
Now add the script to the procedure.
1. Double click the test procedure you have just created.
2. Click the Scripts tab.
3. Click Insert. The Add Test Scripts from Library dialog box appears.
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4. Choose the TestPartner script TransferMoney and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.
Where to go next: Step 6: Close Account Test Class and Associated Procedure and Script
Step 6: Close Account Test Class and Associated Procedure and Script
1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Close Account.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Close a Non-Existent Account.
Now add the script to the procedure.
1. Double click the test procedure you have just created.
2. Click the Scripts tab.
3. Click Insert. The Add Test Scripts from Library dialog box appears.
4

Choose the TestPartner script CloseAccount and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.
Where to go next: Step 7: Close MIB Application
Step 7: Close MIB Application Test Class and Associated Procedure
1. In the center pane, right click the MIBTest suite and choose New Test Class.
2. Name the test class Close Application.
3. Right click this class and choose New Test Procedure.
4. Name the test procedure Closing MIB Application.
Now add the script to the procedure.
Double click the test procedure you have just created.
Click the Scripts tab.
Click Insert. The Add Test Scripts from Library dialog box appears.

Ll

Choose the TestPartner script ExitApplication and click Add. If the script is not there, go back to
Lesson 3 and add it.

5. Click OK.
Where to go next: Step 8: Add Rules
Step 8: Add Rules

A rule is a command that prepares a script for execution, collects information during an execution,
determines if a script failed, or cleans up after the execution. Rules can be defined and applied to test
classes, test procedures, and jobs. For this task, you will add an environment variable rule and a setup rule.
The environment variable will point to the MIB demo application path, and the setup rule will start the
MIB demo application.

After the Suite has been set up and all the classes, procedures and scripts are added, follow these steps:
1. In the center pane, double click the Suite MIBTest. The Test Class dialog box appears.
2. Click the Execution tab
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Click the Rules button. The Rules dialog box appears.
The path will be appended to your existing path environment variable.
Click the Add button. The Rule dialog box appears.

Click Environmental Variable.

N ke Ww

Set the remaining fields to the following values:
Name: Type Path

Value: Type C:\PROGRA~1\COMPUW-~1\QADIRE~1\TUTORIAL\MIBApp;%PATH%. The
path will be appended to your existing path environment variable.

Click OK.
9. Click the Add button again. The Rule dialog box appears.

10. Click Setup. Setup rules run commands that prepare for test execution, such as starting processes or
copying files. You will add a setup rule that will start the MIB demo application. Note that the
execution of the MIB demo application could be performed via a TestPartner script, but for this
lesson it is performed via a setup rule.

11. In the Command field, type: Start MIB.EXE . You must precede the command with the word
“start.”

12. Set the remaining fields to the following values:
Bind to Machine: Leave this blank
Apply To: Choose Locally
Time Out: Default
Exit Status: Default
13. Click OK. The Rules dialog box appears. The value is added to Rules for this Test field.
14. Click Close
Where to go next: Step 9: Run a Job
Step 9: Run a Job

The first step in running a job is to select the tests to run. You can choose to run an entire test suite, which
means all the test classes and test procedures will run, or you can run specific test classes or test procedures.
For this task, you will run the entire tutorial test suite. The first step in running a job is to select the tests to
run. Then, describe how and when the tests will run. This is called the job description. After submitting the
job, it normally runs as soon as a Test Execution Server is available on a computer.

Right click on the MIBTest Suite and click Run. The Job Description dialog box appears.
1. Click Submit. A message appears verifying that the job was submitted.
2. Click OK.

The job should take a few minutes to run, during which time you will see the TestPartner scripts perform
tests on the MIB application. Remember, the MIB application is started via the environment and setup
rules that you defined.

ZlNote: The demo runs automatically. Do not perform any other actions on your computer while the job
is running.

Where to go next: Lesson Five: Job Information Center
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Lesson Five: Job Information Center

The QADirector Job Information Center lists all scheduled jobs, jobs in progress, and results. From within
this center, perform job execution tasks. The Jobs panel is divided into two sections: result folders and the
job related tabs. The job related tabs are Schedule, Execution, and Results. The Schedule tab displays jobs
that are in queue to execute The Execution tab displays jobs that are currently running. The Results tab
displays the results of jobs that have executed.

1. Click the Results tab in the main Job Information Center pane.

2. Right click the MIBTest result and choose View Results. The Job Results window appears with
detailed information.

3. Note that the Transfer Money test failed. Right click the Transfer Money test and choose View
Details. The Test Procedure dialog box appears and includes logs from the test.

4. Double click TP-view. The information in the log view states that the script failed due to the failure
of a TestPartner check.

5. After reading the TestPartner Logview, click File>Exit from the TestPartner menu.
6. Click OK to close the Test Procedure dialog box.

Where to go next: Lesson Six: Creating a Manual Test
Lesson Six: Create a Manual Test

A manual test is a test that requires interaction from the tester, whether it be answering questions or
performing some action. It is possible to use manual tests when automated testing is impractical or not yet
implemented. Even an automated test plan is likely to include tasks that cannot be easily automated. In
that case, use manual tests to complete these tasks. Manual tests also provide a way for Quality Assurance
testers to comment on software interface and usability.

To create a manual test, you design a series of steps that the tester reads and responds to when the test
script is executed. For this task, you will use the Manual Test Manager to create a manual test, which you
will later add to a test procedure.

1. From the Script Information Center, choose Manual from the Testing Tool list.
Click Action>New Script. The Manual Test Editor appears.
In the Name field, type CheckAppStartup.

W N

In the Description field, type: Manual test to verify that the MIB application
executed correctly

In the Step Type list, choose Question (Yes/No).
In the Text field, type the question: Did the MIB application start correctly?
"Yes, No" appear in the Choices field.

In the Correct Answer field, choose Yes from the list.

 ® N o w

If necessary, add more steps to the test, but this is not required for the tutorial.
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10. Click File>Save or the Save icon.

11.

Click File>Close.

12. Add the script to the Test Library.

Where to go next: Step 1: Insert the Manual Test into a Test Procedure

Step 1:Insert a Manual Test Into a Manual Procedure

1. From the Suite Center, double click the Add New Customer test procedure dialog box.

2. On the Scripts tab, click Insert to open the Add Test Scripts from Library dialog box.

3. From the Testing Tool list, choose Manual Test.

4. Choose the CheckAppStartup manual test.

5. Click Add.

6. Click OK.

7. Choose the CheckAppStartup test in the Test Scripts list. Click the up arrow to the right of the Test
Scripts list to change the order of execution for the tests. You must run the manual test before the
QARun script to verify that the MIB application ran successfully.

Click Apply.
Click OK. In the Tree View, you should see that the CheckAppStartup manual test has been added
to the Add new customer test procedure.

10. Right click MIBTest in the middle pane and choose Run. The Job Description dialog box appears.

11. Choose the Manual Test checkbox.

12. Click Submit. A confirmation dialog box appears. Click OK. The box disappears within five
seconds if OK is not clicked. The Manual Test Execution screen appears.

13. Choose Pass from the Actions list.

14. Click Finish Job.

Where to go next: Step 2: Submitting a Defect
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Step 2: Submit a Defect
1. From the Job Information Center, right click the MIBTest.
2. Choose View Results. The Job Results window appears.
3. Click Transfer Money Procedure.
4

Right click Submit Defect. If this is not available, make sure you have configured TrackRecord. The
Submit Defect dialog box appears.

Click Close.

Click Close on the Job Results window.

(@)

Where to go next: Lesson Seven: Defect Information Center.
Lesson Seven: Defect Information Center

TrackRecord is Compuware’s defect-tracking tool for client/server and mainframe applications. To
complete this lesson, you must have TrackRecord installed on the same machine as QADirector or on an
accessible network drive.

In previous lessons, you found that the Transfer Money test procedure failed, due to a failed TestPartner
check. You will now log a defect in TrackRecord for the failed test procedure.

1. Open the Defect Information Center.

2. Click the MIBTest job in the pane to the left. All the defects associated with this job appear in the
pane to the right.

Choose the defect you submitted.

4. Click Actions>View Defect. The View Defect window appears with all the pertinent information
for the defect, including the ID number, status, and the test name. From here you can edit the
defect by clicking Edit Defect.

5. Click Close to close the View Defect window.
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Administrating and Configuring in the System Administration Center

About Administrating and Configuring the System

After installing QADirector, open the System Administration Center to perform a variety of tasks such as
assigning user passwords and permissions and maintaining the QADirector database. A designated
QADirector administrator must perform tasks associated with passwords and permissions.

Also, use the System Administration Center to connect to databases and add testing tools.

Refer to the QADirector Installation and Configuration Guide for more information on administering and
configuring QADirector.

About Administrating and Configuring the System

After installing QADirector, open the System Administration Center to perform a variety of tasks such as
assigning user passwords and permissions and maintaining the QADirector database. A designated
QADirector administrator must perform tasks associated with passwords and permissions.

Also, use the System Administration Center to connect to databases and add testing tools.

Refer to the QADirector Installation and Configuration Guide for more information on administering and
configuring QADirector.

Passwords and Permissions

Only QADirector administrators and users with User Management permissions can perform user
maintenance. A QADirector administrator is a team member who is assigned all permissions. Administrator
privileges are granted from the Administrator checkbox located in the user’s properties. When QADirector
is first installed, administrators can use the default Admin ID to log on to QADirector and to begin creating
other User Names. Also, Administrators and users with User Management permissions must have Windows
Administrator privileges.

QADirector’s architecture is based on a multi-user repository, or database. This database allows teams to
work together, sharing tests and test results. The QADirector administrator, controls access to the database
by specifying the following:

IDs and passwords: Set up a user name and password for each person who must have access the database.

Access permissions: Set the access permissions for each user. Access permissions specify what actions the user
can perform in the database—create or delete tests, add tool domains, etc.

Users have unique passwords and are assigned permissions for working in QADirector. Use the same user
name and password among QADirector, QARun, and TestPartner. By having the same ID and password
throughout these products, the user will not be prompted for logon information whenever they access
QARun, and TestPartner while editing and creating tests in QADirector. Remember that, during execution,
QADirector uses the Tool Domain user name and password.

Do not use spaces in a user name. If used, spaces will automatically be replaced with underscores.
Passwords must be more than five characters. Passwords with less than five characters will be replaced with
the word "QADirector." User names with more than 50 characters will be truncated.
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Compuware recommends that you change the default password for the Admin user so that unauthorized
users cannot access user maintenance.

To assign user passwords and permissions:

1. Click Start and open QADirector.
2. When prompted, type a user name and password.

3. For an administrator installing QADirector for the first time, type admin in both the ID and Password fields. This is a
default user name with administrator privileges.

4. From the Centers toolbar, choose System Administration.
Note: If the System Administration icon is disabled, your user name does not have administrator or
sufficient privileges.

Because user information is stored in the database, you must be connected to the appropriate
database before adding users: To view your current database connection, review the data within the
Data Source panel. To connect to a different database, refer to Connecting to a Database.

5. From the Users panel Action menu, click New. The Add User dialog box appears.

6. In the Login Information area, type the user name and password. Type the password again in the
Confirm Password field.

7. Select a role from the Role list.

8. To give the user administrator privileges, select the Administrator check box. Administrator and sufficient privileges
allow users to assign user names and perform database maintenance. When assigning administrative privileges to a user, all
of the access permissions are automatically assigned to them as well.

Required: All users with QADirector Administrative, User Management, or DB Management privileges
must have Windows Administrative privileges.

9. In the User Information section, type the user's name, department, e-mail address, and phone number in
the appropriate fields. These fields are optional.
10. Click OK.

Available Access Permissions

The following is a list of all available access permissions in QADirector. The permissions are organized by
management function. For more information about roles, management functions, passwords, and
permissions. See Assigning user passwords and permissions.

'ﬂTip: In QADirector, there are three levels of user access permissions: global, project, and suite.

Global permissions are set by the administrator on the system level, and they control a user’s ability to create, to
delete, or to modify projects, tools, tool domains, users, TM servers, TE servers, and scripts throughout QADirector.

Project permissions are set by users with administration rights or appropriate permissions, and they control actions
on the project level. They control the user's ability to create, to delete, or to modify suites, library test assets, and
template attributes for the specific project in which the permissions were set.

Suite permissions are controlled on the suite level, and they are assigned by the user who creates a suite. They
determine if users can do the following:

Add or delete suite test assets
View and delete results
Execute tests

Change default folder options
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Management Function Permissions

Project Management

Manage Projects—create, delete, and modify projects.

Manage Suites—create, delete, and modify suites, classes, and
procedures.

Create Suite—create new suites.

Change Non-Owner Suite Default Folder—reassign default
folders of other users.

Change Non-Owner Suite Permissions—modify suite
permissions of other users.

Create/Delete/Modify Suite—create, delete, or modify their own
suites.

Delete/Modify Non-Owner Suite—delete or modify suites of
other users.

Execute Tests—run tests.

Manage Results—delete or view results.
Delete Results—delete their test results.
Delete Non-Owner Result—delete results from other user tests.

View Non-Owner Result—view results of other user tests.

Manage Test Assets — create, delete, and modify

Create/Delete/Modify Test Assets—create, delete, and change
test assets.

Delete/Modify Non-Owner Test Assets—delete or change test
assets created by other users.

Manage Filters—create, delete, modify, and view filters depending
upon selected subpermissions. This permission is subdivided into:

Create/Delete/Modify Filter—create, delete, and modify filters.

View Filters—view filters.

Manage Template Attributes—create, modify, and delete
template attributes, which are custom fields on the Test Procedure
dialog box. This permission are subdivided as follows:

Create/Delete/Modify Template Attributes—create, modify, and
delete template attributes

View Template Attributes—view template attributes.

Manage Locks and Logs—break locks and delete and view log
files.
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User Management

QA Reports

DB Management

Product Integrations

Integrations Management

Test Machine Management

Test Script Management
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Break Locks—break a test lock that was set by another user.

View Log Files—view logs.

Manage Users— add, modify, or delete project users.

Manage Role Permissions—modify permissions within roles.

Manage Default Report Configurations— modify the input
parameters, display, and layout of QACenter Portal reports.

Project Content Management— Add project specific external
content, such as a static HTML report, or dynamic content
identified by a URL.

Manage Logos— Add, edit, or delete logos to display in report
headers or footers.

Launch ODBC Manager—open the ODBC Manager.
Upgrade DB—upgrade the database.

Manage Product Integrations— create, modify, or delete
QACenter Portal project integrations with TrackRecord and
Reconcile.

Create/Delete/Modify Tools—create, delete, or modify tools.

Create/Delete/Modify ToolDomains—create, delete, or modify
tool domains.

View Tools—view available tools.

View Tool Domains—view available tool domains.

Add TM Servers— create a prioritized list of where to run the Test
Management Server.

Change Execution Ports—open and change specified ports for all
executables.

Change TM Server Priority—choose priority of Test Management
machines.

Delete TM Servers—remove Test Management machines from the
priority list.

View TE Servers—view Test Execution Machines from the System
Administration Center.

View TM Servers—view Test Management Machines from the
System Administration Center.

Create/Delete/Modify Test Scripts—create, delete, or modify a
test scripts.

Delete/Modify Non-Owner Test Scripts—delete or modify tests of
other users.

View Test Scripts—view test scripts.
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Changing the Administrator Password

When QADirector is first installed, use the default Admin ID to log on to QADirector. Compuware
recommends changing the default password for the Admin user so that unauthorized users cannot access
higher level permissions.

To change the default password for the Admin user:

Start QADirector and open the System Administration Center.

Select the Admin user.

From the Users panel Action menu, choose Properties. The User Properties dialog box appears.
In the Password field, delete the old password and type the new password.

In the Verify Password field, type the new password again.

Click OK.

I O

Managing Role Permissions

To add flexibility to permissions, add or remove permissions to specified roles throughout QADirector.
Test-specific roles customized at the System Administration Center level will set the default role for all
projects. To bypass the default settings, change user roles for a project in the Project Administration
Center.

Note: After migrating from 04.05.01 or 05.00.00 to 05.00.01, new Teamleader and QAManager roles are
not added as default users. Manually add these to the system when migrating. These roles are added by
default only with a new installation of 05.00.01.

To customize role permissions:

1. From the System Administration Center, select User Actions>Manage Role Permissions. The Manage Role
Permissions dialog box displays.

2. Select arole from the Role list.
Select or clear the check boxes according to the desired customized permissions.
4 Click OK.

‘ﬂTip: Anything the user has not been given permission to access will be disabled on the menus in
QADirector. This means the menu item or field will appear gray.

Datasources and Databases

Configuring a Datasource or Server at Login

A datasource configures QADirector as a stand-alone installation or connection. Datasources are only
available for Win32. Datasources do not offer single sign-on capabilities. This means that a user must log
on to each application separately.

A server configures QADirector as an Enterprise installation or connection. Select a server if using QACenter
Portal. This feature provides single sign-on capabilities. This means that a user logs on once to access all
applications.
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To configure a datasource or server:

1. Click Start>Programs>Compuware>QADirector to log on to QADirector. The Login screen appears.

2. Click Configure. The Select a Database Dialog Box appears.

Refer to the QADirector Installation and Configuration guide for more information.

B

Connecting to a Database

QADirector’s architecture is based on a multi-user database. This database makes it possible for colleagues
to work together to do such things as sharing suites, tests, and job results. The default QADirector database
is an MSDE database and will be used if a different data source name is not used. However, you may want
to connect to a different database. For example, if working with a team, you may need to connect to a
database residing on a server machine.

To connect to a database:

1. Close QADirector, the test management server, and the test execution server if they are running.
2. Click the System Administrator Center icon on the Centers bar.
3. Click Data Source Actions>Change Data Source. The Select a Database dialog box appears.

This dialog box displays the data source name of the database currently in use. When first installing
QADirector, the default data source is QADirector.

At this point, connect to either a data source or a QADirector server.

If selecting a data source, QADirector will act as a stand-alone installation or connection. Data source is
only available for Win32 clients. This makes it possible to log into QADirector, and within a project, define
integration information for TrackRecord and Reconcile.

Connecting to a QADirector data source requires users to log in multiple times for each application.

Creating a New Database

QADirector’s architecture is based on a database. This multi-user database offers centralized control of
system access rights and facilitates the sharing of test data. The default QADirector database is a sample
MSDE database named QADirector. However, you can configure and use an Oracle or SQL Server database
if desired. Refer to the QADirector Installation and Configuration Guide for more information.
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Creating and Managing Projects in the Project Information Center

Projects are the highest level in the test hierarchy. Projects contain requirements, test suites, defects,
product integration information, user information, and the test library. Manage projects in the Project
Information Center.

The Project Information Center is divided into three sections:
The Project pane lets you create a project.
The Project Statistics pane lists statistics unique to the open project.
The Project Users pane lists names and roles for users unique to the open project.

Use the Project Information Center to create or edit projects, assign users to specific projects, and specify
start date and end date for projects.

Since the tasks performed in the Project Information Center are administrative, only users with
Administrative, Team Lead, and QA Manager roles can access this center.

Also, use the Project Information Center to integrate with TrackRecord, Request Management, or
Reconcile.

About Creating and Managing Projects

Projects are the highest level in the test hierarchy. Projects contain requirements, test suites, defects,
product integration information, user information, and the test library. Manage projects in the Project
Information Center.

The Project Information Center is divided into three sections:
The Project pane lets you create a project.
The Project Statistics pane lists statistics unique to the open project.
The Project Users pane lists names and roles for users unique to the open project.

Use the Project Information Center to create or edit projects, assign users to specific projects, and specify
start date and end date for projects.

Since the tasks performed in the Project Information Center are administrative, only users with
Administrative, Team Lead, and QA Manager roles can access this center.

Also, use the Project Information Center to integrate with TrackRecord, Request Management, or
Reconcile.

Creating a Project

Projects house testing information. Only project administrators (Team Leads, QA Managers), and anyone
with Manage Projects permission can create a project.

To create a new project:

1. Click the Project Information icon on the Centers bar.
2. Click Actions>New. The New Project dialog box appears.

Note: If another project is open, QADirector prompts you to save it, then opens the New Project dialog
box.
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3. Type the project name in the Project Name field.

4, Select the standard template or a project on which to base the new project from the Based on the following
Project list. When the standard template is selected a set of global templates is copied to the new project. When a current
project is selected, the libraries, suites job results, users, and template attributes are copied to the new project.

5. Click Create.

6. In the Project panel, type a description in the Description field.

7. Click Start Date Calendar. The Calendar dialog box appears.

8. Select a date by clicking the forward or back arrows to the desired month, then clicking the date. After the date is
selected, the window automatically closes and the date is saved to the Start Date field.

9. Click End Date Calendar. The Calendar dialog box appears.

10. Select a date by clicking the forward or back arrows to the desired month, then clicking the date. Once the date is

selected, the window automatically closes and the date is saved to the End Date field.

11. Select the Active check box to make the project available to project users. If the project is not currently active, clear
the check box. When not selected, only project administrators (Team Leads, QA Managers), and anyone with Manage
Projects permission can access the project.

12. If using Reconcile with this project, select the Reconcile check box.

13. Select the Reconcile Integration name from the Name list, or click Configuration (...) to configuring a new
integration. The server and database will populate.

14. Type the Reconcile project name in the Project field.

15. Click Defect Management , if using this feature and select TrackRecord or Request Managment.

16. Select the TrackRecord or Request Management Integration name from the Name list, or click Configuration (...) to

configure new integration. The server and database will populate. If the integration uses the Web Server, this field will
populate.

17. Type the Defect Management project name in the Project field for TrackRecord if TrackRecord is selected.

Opening a Project

Open a project to access requirements, test suites, defects, product integration information, user
information, and the test library.

To open a project:

1. Click the Project Information icon on the Centers toolbar.

E| Tip: QADirector stores session information and state. If you close QADirector and then reopen it,
it will open to where you were when you closed the application.

2. Click File>Open>Project or if you already have a project open and wish to open a new one, click Actions>Open.
The Open Project dialog box appears.

LI Note: Only projects for which permissions are granted are viewable. All other projects are hidden.
3. Select a project from the Project list.
4, Click Open.
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Deleting a Project

To delete a project:

1. From the Project Information Center, open the project to delete.
2. Click Action>Delete. A deletion confirmation message appears.
Note: Deleting the project will delete all the project-related information such as the Test Library.
3. Click OK.

Importing and Exporting Projects

As a test application moves from one release to the next, the associated project is likely to change as well.
You may need to add, remove, or re-structure projects for each release of the application. Before making
changes to the project, save a version of the project as it stands. By periodically saving versions of the
project, it is possible to track the changes made to the project for each stage in the test application's
development. If you need to reference the old information or return to a previous version of the project,
the information can be easily retrieved.

To save a version of your project, export the project as a QADirector Exchange file. The file can reside on a
local or network drive. Then, use any standard version-control software to manage the QADirector
Exchange file. At any time, you can import the QADirector Exchange file back into QADirector to display
the project. If the project already exists in QADirector (which is possible if you saved a version of the
project and continued to work on it), QADirector creates a new project with the same name but appends a
number to it. For example, if you import the QADirector Exchange file for a project named Demo and a
Demo project already exists, QADirector creates a Demo_1 project.

Ll Note: This feature is not available if using QADirector with CARS Workbench.

Creating a Product Integration

While creating or editing a project within the Project Information Center, integrate a project with
TrackRecord or Reconcile:

To create a project integration:

1. Onthe Project panel, select either the TrackRecord or Reconcile checkbox.

n

Click Configuration (...), or click Tools>Manage Product Integrations. The Manage Product Integrations dialog
box appears.

Choose a product with which to integrate.

Click the New icon on the toolbar. The integration details field on the right are enabled.
Type an integration name in the Name field.

Type a server path in the Server field.

Type a database name in the Database field.

For informational purposes, type a user name and password in the Username and Password fields.

© © N o g M w

Optionally type a Web Server path in the Web Server field.
10. Click the Save icon in the toolbar.
11. Click OK to close the dialog box.
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Creating a Single Sign-On Environment

Single sign-on capabilities within a project provide ease of use among applications such as TrackRecord and
Reconcile. With a single sign-on environment, open applications without logging on to each one.

To simulate a single sign on environment:

Open the Project Information Center or the System Administration Center.
Right-click a user in the Project Users panel and choose Properties. The User Properties dialog box appears.

Click the Single Sign On tab.

Type the user name for the specific application in the User ID field.

1
2
3
4. Select an integration from the Available Product Integrations list.
5
6. Type the password in the Password field.

7

Click OK.

Users and Permissions

After adding users to the project, customize their project permissions. Project permissions override the
system role permissions for the specified project only.

To customize a project role:

From the Project Users Actions menu, select Manage Users. The Manage Users dialog box appears.

Select a user from the Project Users list. If there are no users in the list, Add one at this time.

1
2
3. Click Permissions to assign a project permission. The Project Permissions dialog box appears.
4. Select the desired permissions. Click OK.

5

Click Apply on the Manage Users dialog box to apply the changes and manage another project user, or click OK to
save the changes and close the dialog box.

Managing Project Users

Users with Administrator or sufficient role permissions can manage QADirector users in a current project.
In addition, Administrators, QA Managers, and Team Leaders can add users, assign roles, and customize
permissions of a user.

Tip: Remember that there are three levels of permissions:
Project is set from the Project Information Center or the System Administration Center and affects only projects.
Global is set from the System Administration Center and affects all QADirector functions
Suite is set from the Suite Information Center and affects only suites.

To manage users in any capacity other than from within projects, refer to Assigning User Passwords and
Permissions.
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Managing Test Scripts in the Script Information Center

A test script can be an automated script that was captured using a record/playback testing tool such as
QARun, for example. A test script can also be, but is not limited to, a manual test, or an MVS batch job.
To run a test script, you must first add the script to the Test Library and to a test procedure, and then run
the test procedure.

Additionally, use QADirector to run a user defined test script. To run a User Defined QAD test script,
include a fully qualified path in the string used to launch the test application, or ensure that the test
application resides in the system path.

Use the Script Information Center to access test scripts after they have been created in third party tools.
Additionally, use the Script Information Center to create and organize user defined and manual tests.
Create categories to group scripts together. These categories can be copied to the Test Library for easy
access.

About Test Scripts

A test script can be an automated script that was captured using a record/playback testing tool such as
QARun, for example. A test script can also be, but is not limited to, a manual test, or an MVS batch job.
To run a test script, you must first add the script to the Test Library and to a test procedure, and then run
the test procedure.

Additionally, use QADirector to run a user defined test script. To run a User Defined QAD test script,
include a fully qualified path in the string used to launch the test application, or ensure that the test
application resides in the system path.

Use the Script Information Center to access test scripts after they have been created in third party tools.
Additionally, use the Script Information Center to create and organize user defined and manual tests.
Create categories to group scripts together. These categories can be copied to the Test Library for easy
access.

Creating Scripts

QADirector makes it possible to open the testing tool from within the Script Information Center to create
test scripts.

To create test scripts:

1. Click the Script Information Center icon in the Centers toolbar. The Script Information Center appears.
2. Select a testing tool from the Testing Tool field.

3. Click Action>New Script or select New Script from the Right-click menu. The selected testing tool script editor
opens.

Adding Test Scripts to Test Procedures

Each test procedure must contain at least one script. These scripts may be manual scripts, automated
scripts, or other types of scripts. When running the test procedure, the scripts execute in the order they
appear in the test procedure.
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To add a script to a test procedure:

1. From the Suite Information Center or the Test Library, double-click a test procedure to which to add the script.
The Test Procedure dialog box appears.

2. On the Scripts tab of the Test Procedure dialog box, click Insert. The Add Test Scripts From Library dialog
box appears.

3. Select the type of test from the Testing Tool list. Only scripts which have been added to the library appear.
4, Click Add to add the script to the list.

Viewing Scripts

View the test scripts that have been created for each tool domain, or category.

To view scripts for a selected testing tool:

1. On the Centers toolbar click the Script Information icon. The Script Information Center appears.

2. Select a testing tool from the Testing Tool list. The scripts display by tool domain for automated testing tool and by
category for manual tests and user defined scripts.

3. To change the view, either collapse unwanted tool domains and categories or select a filter from the Filter list.

‘ﬁTlp Right click on the top node and choose Show Hidden to display all items. Choose Hide to hide them.

About Manual Testing

A manual test is a test that requires interaction from the tester, whether it be answering questions or
performing some action. It is possible to use manual tests when automated testing is impractical or not yet
implemented. Even an automated test plan is likely to include tasks that cannot be easily automated. In
that case, use manual tests to complete these tasks. Manual tests also provide a way for Quality Assurance
testers to comment on software interface and usability. With QADirector, it is possible to perform
comprehensive manual testing to define the instructions and questions that the tester responds to during
test execution.

There are two ways to run manual tests:

Standard Windows execution: The job runs on a computer where QADirector is installed. The job begins
as soon as a computer is available.

Web Execution: The job is assigned to a specific tester who completes the job using a Web browser, not
QADirector. The job begins when the tester starts it.

Creating a Manual Test Script

To create a manual test, design a series of questions and instructions via the Manual Test Editor. Use this to
create a large number of tests at one time. Add these tests to procedures later if designing a test suite from
the bottom up or add manual tests as needed as test procedures are defined.

When creating a test script add images, files, URLs, etc. as attachments in Instruction text fields.

To create a manual test script:

1. Click the Script Information Center icon in the Centers toolbar. The Script Information Center appears.
46



QADirector Help

Click Testing Tool>Manual.

Click Action>New Script or select New Script from the Right-click menu. The Manual Test Editor appears.

Complete the applicable fields:

Name: Type a name for the new manual test. The name must be unique across all categories and
cannot contain the less than (<), greater than (>), at (@), pipe (|), dollar ($), ampersand (&), and
caret (*) symbols.

Category: Verify that the category is correct. If it is not correct, select another category in the list.

Description: Optionally type a description, such as the purpose or a synopsis of the test.

The first step defaults to an Instruction. In the Step Type field, select a type:

Instruction: Comments on the test or instructs the tester to perform some action. At
execution time, pass or fail the test.

Question(Yes/No): Asks a question and displays yes or no as possible answers. The test is
marked passed or failed depending on whether or not the tester selects the correct answer.

Question(True/False): Asks a question and displays true or false as possible answers. The test
is marked passed or failed depending on whether or not the tester selects the correct answer.

Question(Text Answer): Asks a question which does not have a defined list of responses. The
tester responds and chooses whether the test passed or failed.

Question(Multiple Choice): Asks a question and displays a list of possible answers, one of
which is the correct answer. The test is marked passed or failed depending on whether or not
the tester selects this answer.

Depending on the type of step selected, enter the appropriate information:

Question(Yes/No): In the Text field, type the question. Yes and No appear in the Choices
column. In the Correct Answer list, select the correct answer.

Question(True/False): In the Text field, type the question. True and False appear in the
Choices column. In the Correct Answer list, select the correct answer.

Question(Text Answer): In the Text field, type the question. When the test is run, the tester
responds to the question.

Question(Multiple Choice): In the Text field, type the question. Type the choices separated
by a delimiter. The default delimiter is a comma. See the Manual Test Editor Preferences
Dialog Box to change the default. In the Correct Answer list, select the correct answer.

Instruction: In the Text field, type the instructions or comments. This step requires no
response from the tester.

Click Insert New Step , or tab through the column, to add another step and repeat the process.

When finished adding steps, click Save.

Reserved Symbols and Characters

The following symbols cannot be used in the names or descriptions of test scripts:

pipe (|)
dollar ($)

ampersand ( &)

caret ()
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Adding Test Scripts to the Library From the Script Information Center

After scripts are created in the Script Information Center, add them to the Test Library for use in the a
project.

To add scripts to the library:

1. Click the Script Information Center icon in the Centers toolbar. The Script Information Center appears.

2. Select tool type from the Tool Type drop-down list.

3. Right-click on the script to add to the Test Library.

4. From the Right-click Script menu, select Add to Test Library. QADirector adds the selected scripts to the library.

0Tip: To select more than one script in consecutive order, click on the first script, hold down the
Shift key, then click the last script. To select several random scripts, click the first script, hold down
the CTRL key, then select each individual script.

Rules

A rule is a command that prepares a test script for test execution, collects information during a test
execution, determines if a test script failed, or cleans up after the test execution. Thus, rules enable
separation of the actual test from pre-test and post-test commands.

The command can be any executable, or it is possible to use the commands provided with QADirector.
These executables reside in \program files\Compuware\ QADirector.

Rules cannot be set up at the suite level. To use a rule throughout a suite, define rules at the project level.
This will apply the rule to all suites within a project.

Defining Rules for Tests

After creating a test, define rules for the tests to separate the actual test from pre-test and post-test
commands. These help prepare a test script for execution.

To define a rule for a test:

Choose the test class or test procedure to which to add the rule.

2. For example, add the rule to a test procedure if the rule is required by that specific test procedure only. Add the rule
to a test class if the rule is required by multiple tests within the test class.

3. Inthe Suite Organization Tree, double-click the test class or procedure. The Test Class or Test Procedure dialog box
appears.

4. Click the Execution tab and click Rules.
Click Add. The Rule dialog box appears.
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Select the type of rule: environment variable, setup command, pass/fail command, or cleanup command.

Depending on the type of rule, complete the appropriate fields:

Environment Variables Fields

Name: Enter the name of the environment variable.

Value: Enter the value of the environmental variable.

Setup, Pass/Fail, and Cleanup Fields

Command: Enter the path and name of the command to execute, along with any parameters
such as path and name of a file to create, open, copy etc. Remember to type Start before an
executable path and command.

Apply command to: This option is disabled for test procedures. For test classes, choose how to
apply the rule to descendants.

Bind to machine: To execute the command on a specific machine, enter the machine name.

Timeout: Enter the number of minutes for QADirector to wait after the command starts before
ending the process.

Exit status: Enter an exit status. This will require the command to have a specific exit status in
order to be successful. Also, select the Require Exit Status option.

Require exit status: Select this check box to require QADirector to mark that the command
failed unless it produced a specific exit status.

Click OK.
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Designing and Organizing Tests in the Suite Information Center and Test
Library

After a project is created in the Project Information Center, design and organize tests that will reside in
the project. A test is the combination of procedures, classes and scripts. This is done in the Suite
Information Center.

Typically, a test suite is created. A test suite contains all the tests applicable to one application or one
component of an application. A test suite is comprised of test classes and test procedures, otherwise known
as test assets. These descend from a single test class called the root class. The root class has the same name
as the test suite and cannot be deleted. All other test assets descend from the root class.

Test suites perform the following functions:
Define which tests are necessary
Group the tests logically
Designate the order in which the tests should be run

For example, you may create one test suite for the entire application, with separate unit testing and system
testing. To accomplish this create a single test suite that contains two high-level test classes, one for unit
tests and one for system tests.

To access test scripts after they have been created with third party tools, use the Script Information
Center. Use the Script Information Center also, to create and organize user defined and manual tests.

The Test Library is a repository for all available tests within a project. It contains test classes, class
templates, test procedures, and test scripts. The Test Library makes it possible to use these tests in different
suites within a project. As tests are used across suites, changes are saved to the Test Library and all suites.

About Designing and Organizing Tests

After a project is created in the Project Information Center, design and organize tests that will reside in
the project. A test is the combination of procedures, classes and scripts. This is done in the Suite
Information Center.

Typically, a test suite is created. A test suite contains all the tests applicable to one application or one
component of an application. A test suite is comprised of test classes and test procedures, otherwise known
as test assets. These descend from a single test class called the root class. The root class has the same name
as the test suite and cannot be deleted. All other test assets descend from the root class.

Test suites perform the following functions:
Define which tests are necessary
Group the tests logically
Designate the order in which the tests should be run

For example, you may create one test suite for the entire application, with separate unit testing and system
testing. To accomplish this create a single test suite that contains two high-level test classes, one for unit
tests and one for system tests.

To access test scripts after they have been created with third party tools, use the Script Information
Center. Use the Script Information Center also, to create and organize user defined and manual tests.

The Test Library is a repository for all available tests within a project. It contains test classes, class
templates, test procedures, and test scripts. The Test Library makes it possible to use these tests in different
suites within a project. As tests are used across suites, changes are saved to the Test Library and all suites.
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Copying, Duplicating, and Moving a Test

After tests are created move and copy them from one class to another within the same suite or from one
suite to another within the same project. It is also possible to copy from the Test Library to a suite.

When copying a class or procedure to a suite the entire hierarchy is included, but works independently of
the source. Whereas, when copying a Class Template to the suite, the hierarchy is bound to the Test
Library.

Duplicating is the same as copying, however, the test is pasted directly under the test that was duplicated.
The duplicate has the same parent as its source.

To copy, duplicate, or move tests, use the right-click menu or drag and drop.
Changing a Test Name

It may be necessary to change a test name if, for example, it was a duplicate test and you want it to have a
unique name.

To change the name of a test:

1. Right-click on a test class, test procedure, or test script and choose Rename from the menu.
2.  Type the new name.
3. Press Enter.

Note: It is not necessary to open the file to rename it.

Locking, Saving and Publishing a Test

QADirector’s architecture is based on a repository, or database. This multi-user database offers centralized
control of system access rights and facilitates the sharing of test data. To ensure data security in this multi-
user environment, QADirector employs an effective locking mechanism that prevents users from
overwriting each other’s work.

To allow users to design and modify tests before sharing their changes with others, QADirector provides
separate commands for saving and publishing tests in the database.

Viewing a Test Association

To view associations between tests (classes, procedures, scripts, and suites), right-click a test in the Test
Library and choose View Test Association from the menu. This displays all the tests one level above the
item selected, that use the item.

For example, if you right-click procedure "Abc," and click View Test Association from the menu, the dialog
box displays classes and suites associated with "Abc" since these items are one level or more above the
procedure level in the test hierarchy. Any scripts associated with "Abc" will not display since scripts are one
level below procedures.

To view test associations within a project:

1. Open the Test Library.
2. Right-click on a test procedure, test class, or test script.

3. Choose View Test Association from the menu. The Test Association dialog box appears.
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Associating a File with a Test

Some tests require additional files in order to execute properly. For example, suppose you have created a
simple user-defined script that opens a text file in Notepad. Because the text file resides on your computer,
you can successfully execute the test. The test, however, cannot be executed on another computer because
the text file does not exist on that computer. To solve this problem, associate the text file with the test
procedure so that the text file is saved in the database. When the test is executed by another user, the text
file is copied to that person’s computer.

Determine whether to associate the file with the test procedure or with the parent class. If several test
procedures in the same test class use the file, it is best to associate the file at the test class level.

Synchronizing an Associated File

QADirector provides a method for synchronizing the associated files saved in the database with the
associated files in the test’s working directory or other local directory. It is possible to update the file on the
database with a local file, or update the local file with the file on the database. It is good practice to
synchronize a test before modifying, executing, or closing it. This ensures that the most recent files are on
the hard drive and updated files are saved.

El Note: This feature is not available if using QADirector with CARS Workbench.

To synchronize an associated file:

1. Choose a suite.

2. Click Action Menu>Synchronize Associated Files. The Synchronize Associated Files dialog box
appears.

3. Choose the file to synchronize.

Click OK to synchronize the files according to these settings.

Accessing a Test Property
Two ways to access test properties are:
Double-click the test class, test procedure, or test script in the Suite Information Center or the Test Library.

Select the test class, test procedure, or test script from the suite or Test Library. In the Suite Information Center,
click Action>Properties. In the Test Library, choose Properties from the right-click menu. The Test Procedure
dialog box, or Properties dialog box appears.
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Test Suites

Tests are organized in test suites. Typically, a test suite contains all the tests applicable to one application
or one component of an application. Test suites create order and control by defining which tests are
needed, grouping the tests logically, and designating the order in which the tests should be run.

A test suite is comprised of test classes and test procedures, all of which descend from a single test class
called the root class. The root class has the same name as the test suite and cannot be deleted. All other test
classes and test procedures descend from the root class. The Suite Information Center contains all of the
test assets (classes and procedures) necessary to run scripts and complete a test. It contains four panels:

Suite Lists: Displays all suites available for the current project.
Suite Organization: Displays the organization tree.
Statistics: Displays test information and job statuses.

Properties: Displays filter information and a summary of the selected suite which is originally
typed in the Test Procedure Dialog Box.

It is possible to work with assets selected from the Suite Information Center or the Test Library as long as
the assets are attached to both the center and the library. Detached assets can only be accessed in the Suite
Information Center.

Creating a Suite

In QADirector, tests are organized in test suites. Typically, a test suite contains all the tests necessary for
one application or one component of an application. Test suites create order and control by defining
which tests are needed, grouping the tests logically, and designating the order in which the tests should be
run.

A test suite is comprised of test classes and test procedures, all of which descend from a single test class
called the root class. The root class has the same name as the test suite and cannot be deleted. All other test
classes and test procedures descend from the root class.

Enter information for the suite into the Test Class dialog box.

To create a test suite:

1. Open or create a project.

2. From the Centers toolbar, click the Suite Information icon.

3. Click Actions>New Suite. A new suite is created with a default name.

4. Click OK. The new test suite displays in the Suite List and the root class appears in the Suite Organization Tree.

Note: When creating a test suite, QADirector automatically creates a single root class and gives the root
class the same name as the new suite. All other test classes and test procedures descend from the root class.

5. Double-click the root class to open the Test Class dialog box.

6. Complete the applicable fields on the Test Class dialog box.

Copying a Test Suite

To save time, copy a test suite when using the same basic test suite structure or when using the same test
classes/procedures.

To copy a test suite:
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1. From the Suite Information Center choose the existing test suite to copy.

2. Click Action>Copy Suite.
3. Click OK.

Deleting a Test Suite

When a test suite is no longer necessary delete it.

To delete a test suite:

Open the Suite Information Center.

Select a suite in the Suite List.

Click Action>Delete Suite. Or click File>Edit>Delete. The Confirm Delete dialog box appears.
Click OK.

Eal A

Opening a Test Suite

The test suite contains all the tests for one application or one component of an application.

To open a test suite:

Open the Suite Information Center.
Select a test suite from the list. It appears in the Suite Organization pane.

With administrative privileges, view the entire suite by selecting the Administrative View check box.

P 0 bR

In the administrative view, unpublished and locked test icons appear in red. Also within the administrative view,
users with administrative privileges can delete tests that they do not own.

9. Click OK.

If the owner has not assigned this permission, a message will appear.

Exporting a Suite to a QAD Exchange File

Periodically saving versions of the test suite allows for tracking the changes made to the test suite for each
stage in the test application's development. To save a version of the test suite, simply export the test suite
as a QADExchange file.

|

To export a suite to a QADExchange file:

1. Open the Suite Information Center. In the Suite List, click on a suite.
2. From the Action menu, choose Export.

3. Inthe Export field, enter the folder and file to which you want to export the test suite. The file must have a .qad
extension.

4. Select the information to include in the export:
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Suite information: Exports the names, properties, and structure of all the tests in the test suite. Note that this option
does not export the actual scripts.

All results: Exports all job results for the test suite. This includes jobs run by all users, not just the current user.
Manual tests: Exports manual test scripts associated with the test suite.

Manual test results: Although the overall pass/fail result of manual tests are included when you select All Results,
this option goes further to export detailed manual test results such as the responses entered by the tester for each
step in the manual test.

5. Click OK.

6. After the export is complete, you can use any standard version-control software to manage the
QADExchange file.

Importing a QADExchange File

After exporting a test suite as a QADirector Exchange file, import the QADExchange file back into
QADirector to display the test suite.

Note: This feature is not available if using QADirector with CARS Workbench.

To import a QADExchange file:

1. In QADirector, close any project that may be open.

2. From the File menu, click Import>5.0 or greater versions of Project Exchange File, or click Actions>Import 5.0
or greater versions of Project Exchange File from the Project pane of the Project Information Center, and from
the Suite Information Center.

3. Select the .qad file you want to import.
4. Click Open.

When the import of a QAD 5.0 file is done, and a QAD 5.1 project of the same name exists, a number is
appended to the project name. The suite within the project retains the original name.

MSWord/Excel Import Wizard for Suites

The Import Wizard helps to import existing testing documents into QADirector. Supported document
types are Microsoft Excel spreadsheets and Word documents. The Import Wizard walks you through the
process of importing one of these document types. The following fields and buttons are available on this
wizard:

Select File Click the Browse button to find the file to be imported.
Create Suite Type the test suite name that will contain the imported document.
Select Class Choose a style tag (Word) or a column that contains the class (Excel)

to represent a Test Class in QADirector.

Select Procedure Choose a style tag (Word) or a column that contains the procedure
(Excel) to represent the test procedure.

Select Test Script Assign style tags to import manual test scripts.

Style Tag option Choose to assign a style tag from the list.
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Ignore option Choose to ignore style tags that are not applicable.

Select Attributes Assign any remaining style tags. These can be attributes or ignored.
Attribute option Choose to assign an attribute from the list.

Ignore option Choose to ignore attributes that are not applicable.

Finish Ends the information collecting process

Command Buttons

Help button Click to access dialog level help.

Cancel button Click to close the dialog box without saving any changes.
Back button Click to go to the previous step.

Next button Click to go to the next step.

Finish button Click to import the document.

<<Previous: Importing a QAD Exchange File | Next>>: Exporting a Suite to a QAD Exchange File

Renaming a Test Suite

To rename a test suite:

Open the Suite Information Center or the suite list.

Choose the test suite to rename.

1.

2.

3. Right click and choose Rename.

4. Type the new name for the test suite.
5.

Click OK.

Exporting Attributes into a Text File

Use this feature to export some or all of the test attributes in a suite into a text file. This information may
be useful for creating custom reports with third-party reporting tools.

Ll Note: This feature is not available if using QADirector with CARS Workbench.

To export test attributes to a text file:

1. Open the Suite Information Center.
2. Select the test suite.

3. Click File>Export attributes into Text File. The Save as dialog box appears.
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4. Navigate to the directory to save the text file, type a name for the file, and click Save.

On the Select Attributes to Export dialog box, select the test attributes to export. Click Select All to select all of the
attributes in the list.

6. Click OK.

Version Management

As the test application moves from one release to the next, the associated test suite is likely to change as
well. It may be necessary to add, to remove or to re-structure tests for each release of the application. Before
making changes to the test suite, save a current version of the test suite. Periodically saving versions of the
test suite allows for tracking the changes made to the test suite for each stage in the test application's
development. To reference the old information or return to a previous version of the test suite, the
information can be easily retrieved.

To save a version of the test suite, export the test suite as a QADirector Exchange file. The file can reside on
any local or network drive. Use any standard version-control software to manage the QADExchange file. At
any time, import the QADExchange file back into QADirector to display the test suite, if the test suite
already exists in QADirector (which is likely if the version of the suite was saved and work on it continued).
QADirector creates a new suite with the same name but appends a number to it. For example, if importing
the QADExchange file for a test suite named Demo and a Demo test suite already exists, QADirector creates
a Demo_1 test suite.

About Test Assets

A test suite is comprised of test classes and test procedures, otherwise known as test assets. These descend
from a single test class called the root class. The root class has the same name as the test suite and cannot
be deleted. All other test classes and test procedures descend from the root class.

Attaching an Asset

Attached and detached describe assets and their relationship to the Test Library. An asset (class or
procedure) is attached if it belongs to the Test Library. It is available for different projects, suites, etc. An
asset is detached if it does not belong to the test library. It is used only in one capacity. Tests can be
attached and detached at the root node level only. An attached parent can't have a detached child.

i

When an asset is attached, the following icon is associated with it:

To attach an asset:

1. Right-click the asset.
2. Select Attach to Library.
3. The asset appears in the Test Library panel.

Detaching an Asset

When an asset is detached, the original remains in the library, and a copy of the asset appears in the tree
followed by a number in parenthesis. For example, Asset A (1). If the detached asset is detached again, the
asset appears in the tree followed by a series of two numbers in parenthesis. For example, Asset A (1) (1)
and so on.
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r 1

When an asset is detached the icon changes from attached to detached: bt

Izl Note: Tests can be attached and detached at the root node level only. The detached asset cannot be
reattached to the original. An attached parent cannot have a detached child.

To detach an asset:

1.

Right-click the asset.

2. Select Detach from Library.

3. The following message appears:

4.

Separate test will be created with new name. Detached test cannot be attached
back to original test. Do you want to continue with detach?

Click Yes.

5. The detached asset appears followed by (1).

Modifying Attach and Detach Asset Default

QADirector attaches each asset by default. It is possible to change the default to detach (or vice versa).

To modify the Attach and Detach default:

A e

Click Tools>User options.

Select the Test Information tab.

Select or clear the Attach test to library check box.
Click Apply to apply the changes.

Click OK to save the changes.

Procedures

Test procedures contain the scripts that run against test applications. They check the behavior of the test
application and report on the result. When creating a procedure from the suite, QADirector adds the
procedure to the Test Library first, then adds it to the suite.

To create a test procedure:

1.
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From the Suite Information Center or the Test Library, right-click the parent of the new test procedure. This may
be the root if there are no other procedures.

From the right-click menu, choose New Procedure. A new procedure is created with a default name, if in-place
naming is selected from the User Options dialog box . If this option has not been selected, the New Test Procedure
dialog box appears.

Type a name for the new test procedure.

If using the New Test Procedure dialog box, click OK. The new test procedure appears in the Suite Organization
tree-view and the library. It is automatically attached or detached depending on the parent class and options
selected in the User Options dialog box. QADirector attaches the class by default.
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5. Double click the procedure. The Test Procedure Properties dialog box appears. Complete the appropriate fields.
Click OK.

6. To quickly move existing test procedures into the new test class, use Cut and Paste on the right-click menu.

Creating a Test Procedure

Test procedures contain the scripts that run against test applications. They check the behavior of the test
application and report on the result. When creating a procedure from the suite, QADirector adds the
procedure to the Test Library first, then adds it to the suite.

To create a test procedure:

1. From the Suite Information Center or the Test Library, right-click the parent of the new test procedure. This may
be the root if there are no other procedures.

2. From the right-click menu, choose New Procedure. A new procedure is created with a default name, if in-place
naming is selected from the User Options dialog box . If this option has not been selected, the New Test Procedure
dialog box appears.

Type a name for the new test procedure.

4. If using the New Test Procedure dialog box, click OK. The new test procedure appears in the Suite Organization
tree-view and the library. It is automatically attached or detached depending on the parent class and options
selected in the User Options dialog box. QADirector attaches the class by default.

5. Double click the procedure. The Test Procedure Properties dialog box appears. Complete the appropriate fields.
Click OK.

6. To quickly move existing test procedures into the new test class, use Cut and Paste on the right-click menu.

Adding Test Scripts to Test Procedures

Each test procedure must contain at least one script. These scripts may be manual scripts, automated
scripts, or other types of scripts. When running the test procedure, the scripts execute in the order they
appear in the test procedure.

To add a script to a test procedure:

1. From the Suite Information Center or the Test Library, double-click a test procedure to which to add the script.
The Test Procedure dialog box appears.

2. On the Scripts tab of the Test Procedure dialog box, click Insert. The Add Test Scripts From Library dialog box
appears.
3. Select the type of test from the Testing Tool list. Only scripts which have been added to the library appear.
4. Click Add to add the script to the list.
Classes
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Creating a Test Class

When creating a class in a suite, QADirector adds the class to the Test Library and the suite. It is possible to
detach the class from the library by selecting Detach from Library from the right-click menu.

To create a test class:

1. From the Suite Information Center or the Test Library, right-click the parent class of the new test class. This may
be the root class of the test suite if there are no other test classes.

2. From the right-click menu, choose New Class. A new class is created with a default name, if in-place naming is
selected from the User Options dialog box . If this option has not been selected, the New Test Class dialog box
appears.

Enter a name for the new test class.
4. If using the New Test Class dialog box, click OK.

6. The new test class appears in the Suite Organization tree view and the library. It is automatically attached
or detached depending on the parent class and options selected in the User Options dialog box. QADirector
attaches the class by default.

7. Complete the appropriate fields on the New Test Class dialog box.

8. Quickly move existing test procedures or classes into the new test class by dragging and dropping them into the new
test class. To add a new test procedure, see Creating a test procedure .

Creating a Test Class

When creating a class in a suite, QADirector adds the class to the Test Library and the suite. It is possible to
detach the class from the library by selecting Detach from Library from the right-click menu.

To create a test class:

1. From the Suite Information Center or the Test Library, right-click the parent class of the new test class. This may
be the root class of the test suite if there are no other test classes.

2. From the right-click menu, choose New Class. A new class is created with a default name, if in-place naming is
selected from the User Options dialog box . If this option has not been selected, the New Test Class dialog box
appears.

3. Enter a name for the new test class.
4. If using the New Test Class dialog box, click OK.

6. The new test class appears in the Suite Organization tree view and the library. It is automatically attached or
detached depending on the parent class and options selected in the User Options dialog box. QADirector attaches the class
by default.

7. Complete the appropriate fields on the New Test Class dialog box.

8. Quickly move existing test procedures or classes into the new test class by dragging and dropping them into the new
test class. To add a new test procedure, see Creating a test procedure .

Test Class Organization

A test class is a logical grouping of test procedures and other test classes within the test suite. You
determine the logic behind each test class grouping. To determine the necessary test classes, first consider
the preferred way to test the application:
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Testing function or structure: Will the testing be primarily functional from the point of view of the user or structural
from the point of view of the implementation or both? Do you want to separate functional from structural tests? If so,
create two test classes at the highest level of the test suite, corresponding to functional and structural tests.

Testing units or systems: Will the tests follow a progression from unit/component testing to system testing? If so,
do you want to separate unit/component from system tests? Create two test classes at the highest level of the test
suite, corresponding to unit and system tests.

Grouping features together: Does the application have many features that belong together or that depend on each
other? Do you want to organize tests according to these aspects of the application? Create classes at the highest
level of the test suite to cover the major features of the application and create child test classes to cover subfeatures.
Create as many levels of classes as needed.

About Class Templates

Class templates are classes arranged in a permanent structure. They retain class structures across suites.
Whereas, classes available from the classes folder in the Test Library are not confined to structures and can
be used independently of each other. Use class templates to enforce business rules. In addition, classes used
from the classes folder in the Test Library will act independently of the source. Conversely, class templates
enforce the hierarchy in the source and in each suite. In each suite, it is possible to combine both class
templates and independent classes.

When working with class templates, remember:
A class can exist only once as a root node in the Test Library. It can exist as a child in multiple locations.

Drag, drop, or copy the root node of the class template into the suite. It is not possible to drag, drop, or copy class
template children into a suite. However, it is possible to drag, drop, or copy any part of a class template to another
class template.

Adding a Class Template to the Test Library

Create a class structure in the Test Library by right-clicking on the class template folder and selecting New
Test Class from the menu. Repeat for each class and subclass to continue building the class structure or
perform the following steps.

To add a class template to the Test Library:

1. Open the Suite Information Center.

2. Create a suite or open an existing suite.

3. Create a class structure or select an existing class structure.

4. Right-click on the top class node and select Convert to Class Template.
Categories

Create categories to help organize manual and user-defined scripts.

To create a category for a manual test script and user defined script:

Click the Test Script Information icon on the Centers toolbar. The Script Information Center appears.
Click Testing Tool>Manual Test or Testing Tool>User Defined.

Click Action>Manage Categories. The Manage Categories dialog box appears.

Click New.

a &~ 0w nh e

In the Category Name field, type a unique name.
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6.
7.
8.

In the Description field, type a description.
Click OK.

To add existing scripts to the category, select scripts and drag and drop them into the desired category.

Note: To add existing manual tests to a category while creating new manual tests, select the category from
the Category list in the Manual Test Editor dialog box.

Editing a Category

Edit categories to help organize manual and user-defined scripts.

To edit a category for Manual and User-Defined tools:

I A

8.

Click the Test Script Information icon in the Centers toolbar. The Script Information Center appears.
Click Testing Tool>Manual or Testing Tool>User Defined.

Click Action> Manage Categories. The Manage Categories dialog box appears.

Choose the category to be edited.

Click Edit. The Edit Category Dialog Box appears.

Edit the name in the Category Name field.

Edit the description in the Description field.

Click OK.

Deleting a Category

Delete categories, if necessary, when they are no longer used.

To delete a category for a manual test script or a user-defined script:

o » 0w nh e

Click the Test Script Information icon on the Centers toolbar. The Script Information Center appears.
Click Testing Tool>Manual or Testing Tool>User Defined.

Click Action> Manage Categories. The Manage Categories dialog box appears.

Select category to delete.

Click Delete. If the category contains one or more scripts, click Yes to delete the scripts with the category. Click No
to delete the category and move the scripts to Not Categorized.

Click OK.

Attributes

Test attributes are name-value pairs that store information about each test class and test procedure in a test
suite. The value of a test attribute is specific to the test and cannot be passed down to descendants. Most
test attributes describe both test classes and procedures. Some, however, are unique to classes or procedures
to reflect the differences between classes and procedures.

Availability

All test attributes are available dynamically during execution with the qc_get_attr.exe command. Some
attributes are available as environment variables while the test is running because QADirector
automatically sets them to environment variables before execution. If an attribute is available as an
environment variable, it is noted in the Value column.
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QC_CHILDREN_IDS

QC_CLEANUPn

QC_CLEANUPn_APPLY

QC_CLEANUPn_TIMEOUT

QC_CREATED_BY

QC_CREATED_ON

QC_CYCLES

The QC_IDs of the descendants of the class. Set
automatically when you add/delete descendants of a
class. You cannot change the value of this attribute
directly.

Node: Classes

Available as environment variable while test runs
A cleanup rule, numbered in the order it appears in
the rule window, starting from 1. Set automatically

when you add/edit/delete cleanup commands in rule
window.

Command-line changes to clean up rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

Where the cleanup command numbered n is
applied: local, classes, procedures, all, as entered in
the cleanup rule definition dialog. Default is local.

Set automatically when you add/edit/delete cleanup
commands or change their scope.

Command-line changes to cleanup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes
Timeout of the cleanup command numbered n as
entered in the cleanup rule dialog. Set automatically

when you change timeout of cleanup command
numbered n.

Command-line changes to cleanup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

User who created the test. Set automatically at test
creation. Cannot be changed.

Node: Classes and Procedures

Available as an environment variable while test runs
Date and time the test was created. Set automatically
at test creation. Cannot be changed.

Node: Classes and Procedures

Available as an environment variable while test runs
Number of repetitions to run a test between 1 and
20. This is commonly used with QACenter Portal.

Node: Classes and Procedures
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QC_DEFECT_ID

QC_EXP_RESULT

QC_HAS_DIR

QC_ID

QC_IS_PROC

QC_IS_CLASS

QC_KEYWORDS

QC_LOCK_DIR

64

ZNote: Can not be deleted or modified

ID number of a defect in a defect bug tracking
system. Set automatically when you associate or
disassociate a defect number with a test.

Node: Classes and Procedures

Available as an environment variablel while test runs
The expected outcome when the test procedure
runs: pass, fail, or Not Executed. The default is pass.

Set automatically when you change the expected
test outcome.

Node: Procedures

Available as an environment variable while test runs
Specifies whether the test procedure has its own
directory: 1 if test procedure has its own directory; O

if test procedure does not have its own directory. Set
automatically at test creation. Cannot be changed.

Node: Procedures

Available as an environment variable while test runs
ID number of the test. Set automatically at test
creation. Cannot be changed.

Node: Classes and Procedures

Available as environment variable while test runs
Specifies whether the test is a procedure. Set

automatically at test creation. Cannot be changed. 1
if test is procedure; O if it is class.

Node: Classes and Procedures
Available as environment variable while test runs
Specifies whether the test is a class. 1 if test is class; O

if it is procedure. Set automatically at test creation.
Cannot be changed.

Node: Classes and Procedures

Available as environment variable while test runs
Keywords by which to find the test in searches. Set
automatically when you add/edit/delete keywords.
Node: Classes and Procedures

Available as environment variable while test runs
Specifies whether class directory and its descendant

directories are locked during execution to prevent
other users from running the class. 1 if locked; O if



QC_MANUAL

QC_NAME

QC_NCHILDREN

QC_NCLEANUPS

QC_NPASSFAILS

QC_NSETUPS

QC_PARENT_ID
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not locked. Default is O.

Set automatically when you specify directories to be
locked/unlocked during execution.

Node: Classes

Available as environment variable while test runs
Specifies whether the test procedure is manual or
automated. O if automated; 1 if manual. Default is O.

Set automatically when you specify that a procedure
is manual or automatic.

Node: Procedures

Available as environment variable while test runs
Name of test. Set automatically when you
create/rename a test.

Node: Classes and Procedures

Available as environment variable while test runs
Number of children the class has. Set automatically
when you add/delete descendants of a test class.
Node: Classes

Available as environment variable while test runs
Number of cleanup rules defined in the test. Set

automatically when you add/delete cleanup
commands.

Command-line changes to cleanup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures
Number of pass/fail rules defined in the test. Set

automatically when you add/delete pass/fail
commands.

Command-line changes to pass/fail rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures
Number of setup rules defined in the test. Set

automatically when you add/delete pass/fail
commands.

Command-line changes to setup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

ID number of the parent of the test. Set
automatically when you create/move test.
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QC_PASSFAILn

QC_PASSFAILn_APPLY

QC_PASSFAILn_TIMEOUT

QC_PATH

QC_PERMS_OWNER

QC_PERMS_PUBLIC

66

Node: Classes and Procedures

Available as environment variable while test runs

Pass/fail commands defined in the test numbered in
the order they appear in the pass/fail rule window,
starting from 1. Set automatically when you
add/edit/delete pass/fail commands in a test.

Command-line changes to pass/fail rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

Where the pass/fail commands are applied. In a
class, the value must be procedures. Set
automatically when you add/edit/delete pass/fail
commands.

Command-line changes to pass/fail rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes

Timeout of the pass/fail command numbered n, as
entered in the pass/fail rule dialog box. Set
automatically when you change the timeout of
pass/fail command numbered n.

Command-line changes to pass/fail rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

Absolute path to the test. Set automatically at test
creation. Cannot be changed.

Node: Classes and Procedures

Available as environment variable while test runs
Permissions of the test owner in the form rwx if
owner can read, write, and execute the test, or rw - if
owner can read and write the test but cannot
execute it. You cannot remove owner’s read and

write permissions. The default is to give the owner
read, write, and execute permissions at test creation.

Set automatically when the owner changes the
owner’s permission.

Node: Classes and Procedures

Available as environment variable while test runs
Permissions of users who are not the owner of the
test in the form rwx if the public can read, write, and

execute the test. The default is to give the public no
permissions.

Set automatically when you change the public’s



QC_PLATFORMS

QC_PURPOSE

QC_RECORDER

QC_REL_PATH

QC_REQUIREMENT

QC_RISKS

QC_RUN_IN_PARALLEL

QADirector Help

permissions.

Node: Classes and Procedures

Available as environment variable while test runs
Platforms you designate on which the test may run.
Set automatically when platform is changed.
Node: Procedures

Available as environment variable while test runs
Purpose of the test. Set automatically when you
add/edit/delete the purpose of the test.

Node: Classes and Procedures

Available as environment variable while test runs
UNIX record-playback tool used to record the test

procedure. Set automatically when you record the
script. Cannot be changed.

Node: UNIX Procedures
Available as environment variable while test runs
Relative path from the root node of the test suite to

the test. Set automatically at test creation. Cannot be
changed.

Node: Classes and Procedures

Available as environment variable while test runs
The requirement this test fulfills. May be a cross-
reference to a functional specification. Set

automatically when you associate/disassociate a
requirement with a test.

Node: Classes and Procedures

Available as environment variable while test runs
Specifies risk type of test: low, medium or high. This
is commonly used with QACenter Portal.

Node: Classes and Procedures

ZNote: Can not be deleted or modified

Specifies which child tests should run in parallel: all,

classes, procedures, or none (run children serially).
Default is classes.

Set automatically when you change the child tests
that should run in parallel.

Node: Classes

Available as environment variable while test runs
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QC_RUN_TIMEOUT Timeout of the script. Set automatically when you
change the timeout of the script.

Node: Procedures

QC_SCRIPT_ALL_INFO Names, descriptions, tool names, and command
lines of all scripts in a procedure. Set automatically
as you add/delete/change scripts.

Node: Procedures

Available as environment variable while test runs
QC_SCRIPT_ALL_NAMES Names of all scripts in a procedure. Set automatically

as you add/delete/change scripts.

Node: Procedures

Available as environment variable while test runs
QC_SETUPn Setup commands defined in the numbered test in

the order they appear in the setup rule definition

dialog, starting from 1. Set automatically when you
add/edit/delete setup commands in a test.

Command-line changes to setup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures

QC_SETUPn_APPLY Location where the setup command numbered n is
applied: local, classes, procedures, all, as entered in
the setup rule definition dialog. Default is local. Set
automatically when you add/edit/delete setup
commands or change their scope.

Command-line changes to setup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes
QC_SETUPn_TIMEOUT Timeout of the setup command numbered n as
entered in the cleanup rule dialog. Set automatically

when you change the timeout of setup command
numbered n.

Command-line changes to setup rules work
differently. See qc_ch_proc and qc_ch_class.

Node: Classes and Procedures
QC_STATE One of the following state-of-test values: Unwritten,
In Progress, Completed, or Broken. Default is

Unwritten. Set automatically when you change the
state of the test.

Node: Classes and Procedures

Available as environment variable while test runs
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QC_SUITE_DESCR
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ID number of the test suite.Set automatically.
Cannot be changed.

Node: Classes and Procedures

Available as environment variable while test runs
Name of the test suite. Set automatically when you
create/rename the test suite.

Node: Classes and Procedures

Available as environment variable while test runs
Absolute path to the test suite. Set automatically.
Cannot be changed.

Node: Classes and Procedures

Available as environment variable while test runs
Description of the test suite. Set automatically if you
add/edit/delete the test suite description.

Node: Classes and Procedures

The name of the project with which the test suite is

associated. Set automatically when you
add/edit/delete the name of a project.

Node: Classes and Procedures

Summary of the test. Set automatically when you
add/edit/delete a summary.

Node: Classes and Procedures

Available as environment variable while test runs

Use template attributes to organize tests by various kinds of data. Use an attribute on specific kinds of tests,
and filter on that attribute to find all tests with that attribute.

A number of template attributes are provided with QADirector, but you can also create your own custom

attributes.

To create a new template attribute:

Open a QADirector project by clicking File>Open and select a project from the project list.

From the Tools menu, choose Manage Template Attributes. The Template Attributes dialog box appears.

1.
2.
3. From the Assign Template Attributes to list select the project to which to assign attributes.
4

In the Attributes Details section, in the Name field, enter the new template attribute. Begin the name with QC__ for

consistency with other attribute names.

5. Inthe Display Name field enter the name which will appear on the Custom Attributes tab of the Test Class or Test

Procedure properties dialog box.

6. Inthe Type field select the attribute type from the list.
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10.
11.

12.
13.

In the Value field select the value from the list.

Select the Value can be edited check box to have the ability to change the value that appears in the field.
Select the Display multi-line field text check box for fields that require a lengthy value.

Click the Add button to add the new attribute to the Custom Attributes list.

If Global Attributes are selected in the Assign Template Attributes to field, click Synchronize to update all the
suites in the project.

Click Apply to apply the changes.
Click OK to close the dialog box.

Deleting Template Attributes

It is possible to delete template attributes when they are no longer necessary.

To delete a template attribute:

I O

Open a QADirector project by clicking File>Open. Select a project from the project list.
Click Tools>Manage Template Attributes. The Template Attributes dialog box appears.
In the Custom Attributes field, select the attribute to delete.

To delete the attribute click Delete.

A confirmation message appears. Click Yes.

Click OK to close the dialog box.

Updating Template Attributes

Using the Template Attribute dialog box, assign attributes to projects, list custom attributes, choose types
and values, and more.

To update a template attribute:

1
2
3.
4

o
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12.
13.
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Open a QADirector project by clicking File>Open and select a project from the project list.
Click Tools>Manage Template Attributes. The Template Attributes dialog box appears.
From the Assign Template Attributes to dropdown list select the project to which the attribute is assigned.

In the Attributes Details section, in the Name field, update the template attribute. Begin the name with QC_ for
consistency with other attribute names.

In the Display Name field update the display name which will appear on the Custom Attributes tab of the Test Class
or Test Procedure properties dialog box.

In the Type field select the attribute type from the dropdown list.
In the Value field select the value from the dropdown list.
Select the Value can be edited check box to have the ability to change the value that appears in the field.

Select the Display multi-line field text check box for fields that require a lengthy value.

. Click the Add button to add the new attribute to the Custom Attributes list.

. If Global Attributes are selected in the Assign Template Attributes to field, click Synchronize to update all the

suites in the project.
Click Apply to apply the changes.
Click OK to close the dialog box.
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Exporting attributes

It is possible to export test attributes to a text file.

To export attributes:

Click Tools>Export Attributes to Text File. The Save As dialog box appears.
Navigate to the directory in which to save the attributes.

Type a name in the Name field.

Click Open. The Select Attributes to Export dialog box appears.

Check the attributes to export.

Click OK.

2R S o

Run-Time Attributes

QADirector automatically gathers information about test execution while tests execute. It stores the
information in name-value pairs called run-time attributes.

QC_QADIRECTOR_HOME  Job Path to the Compuware installation running the
job.

QC_ARCH_NAME Job Name of the architecture on which the job is
running, such as: pa-hpux10.20.

QC_ARCH_OS Job Name of the Compuware directory containing the
QADirector binary for an architecture.

QC_CYCLES Test Cycle information based on Planning.
ZlNote: This attribute may not be deleted or
changed

QC_FAIL_DESC Test procedure Description of the failure of the procedure, if the
test procedure failed.

QC_JOB_ID Job ID number of the job.

QC_JOB_MACHINES Job List of machines designated in the job description.

QC_JOB_NAME Job Name of the job.

QC_JOB_TIME Job Time the job started.

QC_LICENSE_HOST Job Name of the machine on which a QADirector

license is running.
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QC_LICENSE_USER Job Name of the user of the QADirector license.
QC_MACHINE Test procedure Machine on which the test is running.
QC_OS_NAME Job Operating system of the machine on which the job
is running.
QC_RISK Test Risk information based on Planning.
S Note: This attribute may not be deleted or
changed
QC_RESULT_TOP Job Absolute path to the result directory.
QC_START_TIME Test Date and time the running test started running.
QC_START_TIME_GMT Test Date and time the running test started in
Greenwich mean time.
QC_RESULT_DIR Test Result directory of the running test.
QC_UNEXPECTED Test procedure Set if the outcome of the running procedure was
unexpected.

Importing Test Plans

QADirector's convenient Import Wizard helps import Microsoft Excel test plans into QADirector. The end
result is a new test suite based on the imported test plan.

Ll Note: This feature is not available if using QADirector with CARS Workbench.
Requirements
The document must be an Excel 97 or Excel 2000 file.
Excel 97 or 2000 must be installed on the computer performing the import.
The Excel spreadsheet cannot be a workbook with multiple sheets.
Overview

To create a test suite from an Excel document, the Import Wizard converts the document's columns to test
classes, test procedures, and attributes. The conversion is based on the column headings. During the
import process, choose which columns to map to test classes, test procedures, and attributes. For example,
choose that all items in a "Class" column be imported as test classes.

Example

This is an example of an Excel test plan that contains columns for test classes, test procedures, a
description attribute, and a test purpose attribute:

Class Proc Description Test Purpose

PO Module Purchase Orders
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PO1 vendor name accuracy of vendor name

P02 vendor address accuracy of vendor address

P03 vendor phone accuracy of vendor phone

PO4 vendor fax accuracy of vendor fax

PO5 vendor email accuracy of vendor email

PO6 vendor category accuracy of vendor
category

AR Module Accts Receivable

AR1 customer name accuracy of customer name

AR2 customer address accuracy of customer
address

AR3 customer phone accuracy of customer phone

AR4 customer fax accuracy of customer fax

AR5 customer email accuracy of customer email

ARG customer category accuracy of customer
category

Importing a Microsoft Excel document

To import a Microsoft Excel document:

© © N o g M 0 DN
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12.
13.

Click File>Import>MSWord/Excel Import Wizard for Suites.... The Import Wizard introduction dialog box appears.
Click Next. Step 1 appears.

Click Browse and select the Excel file to be imported.

Click Next. Step 2 appears.

In the Suite Name field, type the name to use for the new test suite.

Click Next. Step 3 appears.

Select a column that contains the test class.

Click Next. Step 4 appears.

Select a column that contains the test procedure.

. Click Next. Step 5 appears.

. Select a row to begin the import. This option is helpful if the first row or two of the spreadsheet

contains header or descriptive information that you don't want to import.
Click Next. Step 6 appears.

Assign any remaining style tags to attributes. Attributes are fields that are used to gather and store information about
the test. For example, the QC_Summary attribute corresponds to a field labeled "Summary" on the Test Class and
Test Procedure dialog boxes. If the test plan includes a column for a summary of each test, assign the column to the
QC_Summary attribute so that the Summary field is automatically completed for each test.
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If the document contains a column that should be ignored, select the column in the list and then select the Ignore
option. Information in this column will not be imported.

To map a column, select it in the list and then select the Attribute option. Map the column to one of QADirector's
default attributes (displayed in the drop-down list), or create a custom attribute by typing a name in the Attribute field.

Default attributes: Map the style tag to one of QADirector's default attributes:

QC_SUMMARY: Corresponds to the Summary field on the General tab of the Test Class and Test
Procedure dialog boxes. It is used to enter a short description of the test.

QC_PURPOSE: Corresponds to the Purpose field on the Custom Attributes tab of the Test Class and
Test Procedure dialog boxes. It is used to describe the test's goals or rationale.

QC_KEYWORDS: Corresponds to the Keywords field on the Custom Attributes tab of the Test Class and
Test Procedure dialog boxes. It is used to enter terms by which to find the test in searches.

QC_STATE: Corresponds to the State field on the Custom Attributes tab of the Test Class and Test
Procedure dialog boxes. It is used to describe the status of the test: Unwritten, In Progress, Completed, or
Broken.

QC_CYCLE: Corresponds to the Cycle field on the Custom Attributes tab of the Test Class and Test
Procedure dialog boxes. It is used to describe planned testing cycles.

QC_RISK: Corresponds to the Cycle field on the Custom Attributes tab of the Test Class and Test
Procedure dialog boxes. It is used to describe low, medium, and high risks.

Custom attributes: Create a custom attribute by typing a name in the Attribute field. For example, assume there is
a priority status for each test in the test plan. If the priority information is contained within a separate column, map
that column to a custom attribute named "Priority.” Simply select the column from the list and enter the word
Priority in the Attribute field. After the import is complete, look for the Priority field on the Description tab of the
Test Class or Test Procedure dialog box.

14. Click Next.
15. Click Finish.

After the import is complete, the new test suite appears in the Tree View of QADirector's main window.

Importing a Test Plan from Microsoft Word

QADirector's convenient Import Wizard helps import Microsoft Word test plans into QADirector. The end
result is a new test suite based on the imported test plan.

Note: This feature is not available if using QADirector with CARS Workbench.
Requirements
The document must be a Microsoft Word 97 or Word 2000 file.
Microsoft Word 97 or 2000 must be installed on the computer performing the import.
Overview

To create a test suite from a Word document, the Import Wizard converts the document's paragraphs to
test classes, test procedures, manual tests, and attributes. The conversion is based on the Microsoft Word
style applied to each paragraph. Paragraphs tagged with a certain style, such as Heading 1, will be
converted to test classes while paragraphs tagged with other styles are converted to test procedures, manual
tests, and attributes. During the import process, choose which styles to map to test classes, test procedures,
manual tests, and attributes.

The Import Wizard creates the test suite hierarchy based on the order that the test class, test procedure,
and manual test paragraphs are listed in the Word document. This means that all test classes are listed
under the root class, test procedures are listed under the preceding test class, and manual tests are assigned
to the preceding test procedure. If a manual test happens to follow a test class, rather than a test procedure,
then the manual test is imported but not assigned to a specific suite. In other words, the manual test will
be imported directly into the Manual Test Manager in QADirector but not displayed in the test suite. Add
the manual test to one or more test suites as desired.
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Applying styles in the document

A Microsoft Word paragraph style is a set of character and paragraph formats that are saved under a style
name. After creating a style, select a paragraph and use the style to apply a whole group of formats in one
step. As explained in the preceding Overview section, the Import Wizard creates the test classes, test
procedures, manual tests, and attributes based on the styles applied to the document's paragraphs. For
example, all paragraphs tagged with a certain style will be imported as test procedures. Therefore, it is
important to be consistent when tagging paragraphs.

Define and use any styles, but simplify the import process by using the default styles listed in this section.
During the import process, the wizard scans the document for these default styles and uses them if they
exist. To use these styles, create them in the document (define specific formatting for each style) and apply
the styles to the appropriate paragraphs.

Note: The style names are case sensitive. Use all upper case as shown.

Create this style: Apply it to this type of paragraph:

Heading 1 first level heading
QAD_TESTCLASS test classes

QAD_TESTPROCEDURE test procedures

Description test description

Purpose test purpose

Normal default style

QAD_MANUALTEST manual test names
QAD_MANUALDESC manual test description
QAD_MANUALINST manual test instructions
QAD_MANUALQUES manual test yes/no questions
QAD_MANUALMULT manual test multiple choice questions
QAD_CORRECTANS the correct answer for the multiple

choice question

QAD_POSSIBLEANS the possible answers for the multiple
choice question
Guidelines for manual tests

If the test plan contains manual tests with multiple choice questions, please note that the paragraph
containing the multiple choice question must be immediately followed by the two paragraphs containing
the correct answer and the possible answers, in that order. The possible answers must be separated with a
carat symbol (*). For example:

How many minutes did the transaction require? (the question)
Less than 1 minute (the correct answer)

Less than 1 minute”1-3 minutes*More than 3 minutes (all possible answers)
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Importing the Microsoft Word document

When finished formatting the Microsoft Word document, use the Import Wizard to import the document
into QADirector.

To import the document:

1
2
3
4.
5
6
7

14.

Click File>Import>MSWord/Excel Import Wizard for Suites.... The Import Wizard introduction screen appears.
Click Next. Step 1 appears.

Click Browse and select the Word file to be imported.

Click Next. Step 2 appears.

In the Suite Name field, enter the name to use for the new test suite.

Click Next. Step 3 appears.

Select a test class style tag.

9. Click Next. Step 4 appears.
10. Select a test procedure style tag.
11. Click Next. Step 5 appears.

This dialog box lists the various attributes of manual tests:

MT Name: The name of the manual test.

MT Description: A description of the manual test.

MT Instruction: A manual test step that is an instruction.

MT Question: A manual test step that is a question.

MT Multiple Choice: A manual test step that is a multiple choice question.
MT Correct Answer: The correct answer for a multiple choice question.
MT Possible Answer: A possible answer for a multiple choice question.

If the test plan contains manual tests, use this dialog box to map the appropriate style to each manual test attribute.
For example, select the MT Name attribute in the list, select the Style Tag option, and select the style assigned to
names of manual tests. Select the Ignore option for any manual test attributes that are not applicable.

ZINote: If the document was tagged using the default styles (listed above), the appropriate styles are
automatically selected for each attribute.

12. Select a script style tag.
13. Click Next. Step 6 appears.

Assign any remaining style tags to attributes. Attributes are fields that are used to gather and store information about

the test. For example, the QC_Summary attribute corresponds to a field labeled "Summary" on the Test Class and Test
Procedure dialog boxes. If the test plan includes paragraph for a summary of each test, assign the paragraph to the
QC_Summary attribute so that the Summary field is automatically completed for each test.
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If the document contains a paragraph that should be ignored, select the paragraph in the list and then select the
Ignore option. Information in this paragraph will not be imported.

To map a paragraph, select it in the list and then select the Attribute option. Map the paragraph to one of
QADirector's default attributes (displayed in the drop-down list), or create a custom attribute by entering a name in
the Attribute field.

Default attributes: Map the style tag to one of QADirector's default attributes:

=  QC_SUMMARY: Corresponds to the Summary field on the General tab of the Test Class and
Test Procedure dialog boxes. It is used to enter a short description of the test.

= QC_PURPOSE: Corresponds to the Purpose field on the Description tab of the Test Class and
Test Procedure dialog boxes. It is used to describe the test's goals or rationale.
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=  QC_KEYWORDS: Corresponds to the Keywords field on the Description tab of the Test Class
and Test Procedure dialog boxes. It is used to enter terms by which to find the test in searches.

=  QC_STATE: Corresponds to the State field on the Description tab of the Test Class and Test
Procedure dialog boxes. It is used to describe the status of the test: Unwritten, In Progress,
Completed, or Broken.

= QC_CYCLE: Corresponds to the Cycle field on the Description tab of the Test Class and Test
Procedure dialog boxes. It is used to describe planned testing cycles.

=  QC_RISK: Corresponds to the Cycle field on the Custom Attributes tab of the Test Class and
Test Procedure dialog boxes. It is used to describe low, medium, and high risks.

9. Custom attributes: Create a custom attribute by typing a name in the Attribute field. For example, assume there is
a priority status for each test in the test plan. If the priority information is contained within a separate paragraph, map that
paragraph to a custom attribute named "Priority." Simply select the paragraph from the list and type the word Priority in
the Attribute field. After the import is complete, look for the Priority field on the Description tab of the Test Class or Test
Procedure dialog box.

10. Click Next.
11. Click Finish.

After the import is complete, the new test suite appears in the Tree View of QADirector's main window.

Testing Tools

Use Compuware testing tools or third party testing tools with QADirector.
Note: This feature is not available if using QADirector with CARS Workbench.

Compuware Testing Tools

If using a Compuware testing tool such as QARun, QAHiperstation, File-AID/CS, or QALoad, set up a tool
domain for the testing tool. A tool domain is a set of information entered about the testing tool. This
information is used to browse, select, create, and execute scripts from within QADirector.

Third-Party Testing Tools

If using a third-party testing tool with QADirector, create a new integration for the tool. With this
integration, it is possible to:

create or select a script to include in a test procedure

run the tool with the selected script

analyze the result to determine if the script passed or failed
communicate the result back to QADirector.

Optionally, the integration can help with browsing results of failed tests and editing scripts that were
previously inserted.

Add the testing tool to be used first by clicking File>New>Testing Tool. The Add Tool Dialog Box appears.
Use this to enter information about the tool, such as executable files.

Adding a Testing Tool

If using a Compuware testing tool such as QARun, QAHiperstation, File-AID/CS, or QALoad, set up a tool
domain for the testing tool. A tool domain is a set of information entered about the testing tool. This
information is used to browse, select, create, and execute scripts from within QADirector. If using a third-
party testing tool with QADirector, create a new integration for the tool.

To add a testing tool:
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1. Open the System Administration Center.
2. From the Testing Tools panel Action menu, choose New. The Add Tool dialog box appears.
3. Type the name of the testing tool and enter the following executables, commands and statuses:
Browse information
Tool Start
Tool Edit
Tool Run
Tool Option
Tool Exit
Tool Help

Tool Start, Tool Edit and Tool Run are executables that require familiarity with the testing tool and
QADirector. See Test Tool Executables for a complete discussion.

4. Click Apply to apply the changes or click OK to save the changes and close the dialog box.

Testing Tool Executables
Ll Note: This feature is not available if using QADirector with CARS Workbench.

For the new integration, create or edit the executable files using the Add Testing Tool Dialog Box. Some
files are required while others are optional. The following table lists the directory, name, and purpose of
each file. When creating the files, replace XXX with the name of the testing tool.

Directory and Name Purpose

QADirector\bin \QCXXXRun.exe Required: The program used to run the script.

QADirector\bin \QCXXXStart.exe Optional: The program that starts the tool in order to
record a script or lets you choose an existing script to use.

QADirector\bin \QCXXXEdit.exe Optional: The program used to edit an existing script.

Write these programs in any language. Before beginning, become familiar with the files and file structure
of both the testing tool and QADirector. Remember that the programs created are called from the test
procedure directory. All directory movement, file movement, or permission changing will occur in this
directory. Use the %QC_RESULT_DIR% variable to move files to the corresponding test procedure result
directory.

QCXXXRun.exe

This program parses the command line and finds the name of the script file. It then starts the testing tool
with this configuration file and runs the tool in “batch” mode. The QCXXXRun.exe program should not
exit until the script/tool is finished. Before it exits, the program must communicate to QADirector whether
the test passed or failed and if it failed, why. The easiest way to indicate a pass is to return a O exit status.
To cause a script to fail with a specific error message, the program must shell off the following command:

qc_exec fail “your failure message here”

Instead of using the VB shell command, use the runproc utility defined in this document, as the VB
program must wait for the qc_exec program to finish before exiting.

The QCXXXRun.exe program must be able to examine a log file, or otherwise identify the criteria for a
passed or failed test, in order to know whether to call gc_exec or not. Often, this is done by looking at a
log file or examining the return code of a spawned application.
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If the QCXXXRun.exe program needs to store important files generated by the test run, the files can be
copied from their original location to the new, special result area. Because the location of this area changes
each time the test is run, it is referenced using the environment variable QC_RESULT_DIR. There are also
many other environment variables that are available to QCXXXRun.exe, such as the name of the test being
run, the name of the script, the purpose of the test, any other attributes defined in the
default_template_attrs file, and so on. All can be accessed through environment variables.

QCXXXStart.exe

This program parses the command line to find the name of the script to create and then starts the program
needed to create the script.

QCXXXEdit.exe

If a tooledit line is included in the XXX.tool file, the QCXXXEdit.exe program will be called when the
user clicks Edit on the Test Scripts Manager dialog box. The QCXXXEdit.exe program must open the tool
used to configure the script.

Advanced feature

If you call qc_exec fail -file filename “message”, the button named More Info... on the result
tab of a test procedure result will run the filename specified.

For example, if the call to qc_exec was as follows:
qc_exec fail -file log.txt “The test failed”

When the user clicks More Info... in the test procedure result pane, the file “log.txt” runs, and since .txt
files are associated with QADirector’s internal viewer, that file will be automatically opened in the viewer
when double clicked).

EINote: The log.txt file must be in the result directory as specified by the %QC_RESULT_DIR% environment
variable when the test is run. This is the directory where the test results are stored. If the file specified was
“log.doc”, then the file would automatically open in Microsoft Word (the associated program in Windows).

Tool Domains

If using a Compuware automated testing tool such as QARun, QAHiperstation, QALoad, TestPartner, MVS
Batch or File-AID/CS, set up at least one tool domain for each tool. A tool domain is a set of information
that is entered about the testing tool that allows for browsing, selecting, and creating scripts from within
QADirector. For example, a QARun tool domain includes the name and location of the script database, the
database type, whether or not the database is public (can be used by others), and so on.

[ZINote: The QADirector administrator assigns permissions. Specific permission must be assigned to view, to
add, to modify or to delete tool domains.

Copying Tool Domains

If working with a testing tool on separate projects, it may be necessary to create identical tool domains.

To copy a tool domain:

1. Open the System Administration Center.

2. Select a tool domain from the Tool Domain panel list.
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3. Click Action>Copy, or right-click and click Copy. A copy of the tool domain appears in the list preceded by Copy
(2). If another copy is made, the tool domain appears in the list preceded by Copy of Copy of.
Creating Tool Domains

Create a tool domain to use with an automated testing tool.

To create a tool domain:

1. Open the System Administration Center.

2. Click Action>New from the Tool Domains panel. The Add Tool Domain dialog box appears.

3. Inthe Type list, select the necessary application. The appropriate tool domain dialog box appears.
4. Enter the required information.

5. Click OK.

Deleting Tool Domains

To organize testing tools, delete a tool domain when work with it has finished. If a tool domain is deleted,
scripts will not run until the tool domain is recreated and points to the same database.

To delete a tool domain:

1. Openthe System Administration Center.
2. Select a tool domain from the Tool Domain list.
3. Click Action>Delete, or right-click and click Delete. A message appears asking for a confirmation.
4. Click Yes.
Sharing Tool Domains

To share a tool domain with other team members, select the Public checkbox on the Add Tool Domain
dialog box. If it is necessary to enter a path to a script database, use a mapped drive letter in the path. If the
database is located on a local drive, first map the local drive to a shared drive letter and specify the shared
drive letter when creating the tool domain. Other team members should map to the database location
using this same drive letter specified in the tool domain.

Compuware Tool Domain Properties
The following describes the properties of the File-AID/CS Compare tool domain:

General Tab
Name: Name of the tool domain.
Owner: User name for the tool domain creator.
Description: Description of the tool domain.
Type list: Testing tool type.
Version:
Before 3.2: Enables the Access database type.
3.2 and above: Enables the File-AID repository.
Database Type: Access or File-AID repository.

Public: Displays whether or not this tool is shared with other users.
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Testing Tool Database: Database name.
Browse: Click to select a database, repository or file.
User Name: Database user name.

Password: Database password name

Default Options Tab
Result Directory: Path of the directory to which the results are saved.

Status: Status depending on how QADirector will manage the pass/fail status of File-AID/CS Compare
scripts.

Help: Accesses dialog level help.

OK: Saves the changes and returns to the center.

Cancel: Returns to the center without saving changes.

Apply: Saves the changes without closing the dialog box.

File-AID/CS Compare Tool Domain Properties

The following describes the properties of the File-AID/CS Compare tool domain:

General Tab
Name: Name of the tool domain.
Owner: User name for the tool domain creator.
Description: Description of the tool domain.
Type list: Testing tool type.
Version:
Before 3.2: Enables the Access database type.
3.2 and above: Enables the File-AID repository.
Database Type: Access or File-AID repository.
Public: Displays whether or not this tool is shared with other users.
Testing Tool Database: Database name.
Browse: Click to select a database, repository or file.
User Name: Database user name.

Password: Database password name

Default Options Tab
Result Directory: Path of the directory to which the results are saved.

Status: Status depending on how QADirector will manage the pass/fail status of File-AID/CS Compare
scripts.

Help: Accesses dialog level help.
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OK: Saves the changes and returns to the center.

Cancel: Returns to the center without saving changes.

Apply: Saves the changes without closing the dialog box.

File-AID/CS Convert Tool Domain Properties

The following describes the properties of the File-Aide /CS Convert Tool Domain:

General Tab

Name: Displays the name of the tool domain.

Owner: Displays the user name for the tool domain creator.
Description: Displays a description of the tool domain.

Type list: Displays the testing tool type.

Database Type: Displays the database type.

Public: Displays whether or not this tool is shared with other users.

Testing Tool Database: Displays location and name of the database.

Help button: Accesses dialog level help.

OK button: Saves the changes and returns to the center.

Cancel button: Returns to the center without saving changes.

Apply button: Saves the changes without closing the dialog box.
MVS Batch Tool Domain Properties

The following describes the properties of the MVS Batch tool domain:

General Tab

Name: Name of the tool domain.

Owner: User name for the tool domain creator.

Description: Description of the tool domain.

Type: Testing tool.

Database Type: Database from the list if the testing tool requires a database.
Public: Displays whether or not this tool is shared with other users.

Testing Tool Database: Location and name of the database.

User Name: User name used for logging onto the MVS Batch database.

Password: Password used for logging onto the MVS Batch database.

Connect Using Tab

Emulator Session check box: Default emulator session to use when running scripts associated with this
tool domain. It is possible to change this default before running the scripts.

Logon Macro field: Macro for logging onto the emulator session.

Auto Logon check box: If selected, an automatic TSO logon is enabled for running unattended mainframe
jobs. This check box is disabled if no macro is selected in the Logon Macro field.
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Emulator Session Shortcut field: Information necessary to start the emulator session: The session path
and name, in addition to the executable path and name.

User ID field: The &tsouserid variable.
Password field: The &tsopassword variable.

Logoff Macro field: The logoff macro to log off the emulator session automatically.

Job Control Tab
Job Statement field: Displays the user-specific MVS job control information from User Options:
&jobname: Obtains job name from User Options.
&accounting: Obtains accounting information from User Options.
&name: Obtains user name or run name from User Options.
&class: Obtains job class from User Options.
&msgclass: Obtains job scheduler message output class from User Options.
Name of Job Control Dataset (Optional) field: Job Control Dataset
DSN field: RunLog dataset name
Unit: The unit. The default is SYSDA.
Volume: The volume.

Attach user's High Level Dataset Qualifier in front of the dataset name check box: If this is selected,
the user's high-level dataset qualifier will be attached to datasets such as the RunLog and the compare log.
The user's high-level dataset qualifier is defined in User Options. If everyone is using the same high level
dataset qualifier, type it on the Global Job Information tab in this dialog box.

Retention Period field: Displays the number of days the dataset should be retained. The data set cannot be
deleted during the retention period. Enter any number between 0 and 9999. This field is optional.

Global Job Information Tab
Release list: QAHiperstation release.
Command Line: The command line.

QAHiperstation Load Library field: The library. This information is common for everyone who uses this
tool domain.

High Level Dataset Qualifier: The high-level dataset qualifier. This information is common for everyone
who uses this tool domain.

Help: Accesses dialog level help.

OK: Saves the changes and returns to the center.

Cancel: Returns to the center without saving changes.
Apply: Saves the changes without closing the dialog box.
QAHiperstation Tool Domain Properties

The following describes the properties of the QAHiperstation tool domain:
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General Tab

Name: Name of the tool domain.

Owner: User name for the tool domain creator.

Description: Description of the tool domain.

Type: Testing tool type.

Database Type: Database type.

Public: Displays whether or not this tool is shared with other users.

QALoad Server Name: Name of the computer where QALoad is installed.

Connect Using Tab

Emulator Session check box: Displays the default emulator session to use when running scripts associated
with this tool domain. It is possible to change this default before running the scripts.

Logon Macro field: Displays the macro for logging on to the emulator session.

Auto Logon check box: If selected, an automatic TSO logon is enabled for running unattended mainframe
jobs. This check box is disabled if no ma