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Introduction

€ Who Should Read This Guide
& Related Publications

¢ World Wide Web Information
¢ Cetting Help

Who Should Read This Guide

This guide is intended for administrators who are installing or configur-
ing QACenter products; it does not contain reference or usage informa-
tion. You can find that information in the online Help for your product.

Compuware assumes that you are familiar with basic Microsoft Windows
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Related Publications

The Distributed License Management Installation Guide, which contains
instructions for licensing your QACenter product, is available in PDF
format. Access this guide from the Compuware FrontLine Customer
Support Web site at http://frontline.compuware.com. See “World Wide
Web Information” on page 6 for specific details.

Because PDF is based on PostScript, a PostScript printer is the most
reliable way to print online books. In most cases, you can also print PDF
files to PCL printers. If you cannot print the PDF files to your printer,
refer to Adobe’s Web site at http://www.adobe.com for troubleshooting
information.


http://frontline.compuware.com
http://www.adobe.com

World Wide Web Information

Getting Help

To access Compuware Corporation’s site on the World Wide Web, point
your browser at http://www.compuware.com. The Compuware site
provides a variety of product and support information.

FrontLine Support Web Site: You can access online customer support for
Compuware products via the FrontLine support Web site. FrontLine
provides fast access to critical information about your QACenter product.
You can read or download documentation, frequently asked questions,
and product fixes, or e-mail your questions or comments. To access
FrontLine, follow these steps:

1T Open a Web browser and go to: http://frontline.compuware.com
The Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and
click Login.

Note: If you are a first-time visitor, click Register to receive your free
password to access FrontLine. After you complete the registration
form, your login ID and password will be e-mailed to you and your
account will be activated.

3 From the list in the center of the page, select a product and click Go.
You will see the product’s FrontLine home page, where you can
access documentation, technical information, fixes, and other sup-
port items.

At Compuware, we strive to make our products and documentation the
best in the industry. Feedback from our customers helps us maintain our
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support
hotline:

¢ The name, release (version), and build number of the QACenter prod
uct. This information is displayed when you select the About com-
mand from your product’s Help menu. The name and release are also
on the covers of the product documentation.

¢ Installation information, including installed options, whether the
product uses local or network databases, whether it is installed in the
default directories, whether it is a client or server installation.

¢ Environment information, such as the operating system and release
on which the product is installed, memory, hardware/network speci-
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fications, and the names and releases of other applications that were
running.

The location of the problem in the QACenter product software, and
the actions taken before the problem occurred.

The exact product error message, if any.

The exact application, licensing, or operating system error messages,
if any.

Your Compuware client, office, or site number, if available.

Compuware Customer Support

Compuware Corporation
One Campus Martius
Detroit, MI 48226-5099
1-800-538-7822

Introduction

7



8  QADirector Installation and Configuration Guide



Chapter 1
Getting Started

& Overview

& Before You Install

¢ Viewing Online Books

& System Requirements

¢ Integrated Products Requirements

Overview

QACenter is a suite of automated software quality products for enterprise
and e-business applications. QACenter offers a comprehensive solution
for IT organizations concerned with assuring quality and performance,
while keeping pace with faster development cycles. QACenter includes:

QADirector: Coordinates the entire testing process by organizing, track-
ing, and executing automated and manual tests. QADirector integrates
with Compuware’s testing, program analysis, defect tracking, and
requirements management tools.

The QADirector Test Management Server reads job submissions
from the database, manages jobs, tracks available test execution
machines, and manages the licenses for manual test Web execution.
It also reports on the status of jobs in progress.

The QADirector Test Execution Server is installed on the local
machine. The Test Execution Server allows jobs to run on a computer.

TrackRecord: Records and reports information about products being
developed or supported. An object-oriented database contains recorded
information on team members, testers, schedules, and defect reports
retrievable using TrackRecord’s query and reporting features.
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Reconcile: Helps create and control project requirements. It stores the
project requirements in a relational database. You can view the require-
ments through Microsoft Word, a reporting view (grid), and the Web. Use
Reconcile to help you manage project development from conception
through delivery.

TestPartner: Tests Web- and Windows-based applications that use
Microsoft technologies. You can record user sessions with the applica-
tion, add validation functions, and replay the sessions later to ensure
that the application works as expected. TestPartner’s scripting language is
Visual Basic for Applications (VBA); it supports testing of Java, Visual
Basic, and Visual C++ applications; browser-based Web applications; and
COM components including both ActiveX controls and automation
objects.

QAHiperstation+: Works with mainframe QAHiperstation to test host-
based applications directly from your Windows desktop. This integrated,
workstation-based interface tool uses 32-bit code that provides improved
performance and better stability on 32-bit Windows platforms.

QARun: Tests enterprise client/server applications. QARun creates and
runs test scripts that support a wide variety of development tools and the
diverse components of today’s corporate environments. QARun couples
advanced verification facilities with error-recovery mechanisms to
reliably test local and remote applications.

Changepoint Request Management: Tracks defects managed using a built-
in report designer. Allows testers to submit a defect from QADirector into
Changepoint’s Request Management system. Relevant information from
QADirector is stored as a change request, while Changepoint’s request
management capability provides powerful workflow features allowing
you make sure the defect is correctly assigned.

QALoad: Load tests enterprise client/server systems and associated
networks. Can stress systems by simulating thousands of users simulta-
neously performing different operations. Creates and runs test scripts
that simulate application transactions on systems without involving end
users or their equipment.

QACenter Additional Installation Media Contents: In addition to the
QADirector suite of products, the installation media includes Adobe
Acrobat Reader, Microsoft Internet Explorer, Java 2 Development Kit, and
Microsoft Virtual Machine installation programs. To install one or more
of these products from the installation media, click Install 3rd Party
Software, then click on the product installation you would like to
perform.
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Before You Install

Installation Types

Release Notes

Review this section before you install QADirector.

The following installation options are available when you install
QADirector:

Basic Installation: Install QADirector on one machine from the installation
media using the default settings. See “Basic Installation” on page 17.In a
Basic Installation the MSDE database is installed along with all other
components on a single machine.

Enterprise Installation Including Integrated Products: Install QADirector in a
distributed environment and customize the install. See “Before You
Begin” on page 21. In an Enterprise Installation, the SQL or Oracle
database is usually installed on a separate machine which is set up as a
database server.

If you purchased an integrated product refer to that product’s Installation
and Configuration Guide for information. There are some products with
which QADirector integrates that require some configuration.

Review the Release Notes for information about new features, technical
notes, and known issues that may enhance or impact your product’s
performance. Release Notes contain recent changes that may not be
included in your QACenter product documentation.

View Release Notes from the installation media or on FrontLine, Compu-
ware’s product support Web site. The Release Notes on FrontLine are
periodically updated as new information becomes available.

Accessing the Release Notes from the Installation Media

1 From the installation media browser, click View QACenter Release
Notes. The Release Notes open in your default Web browser.

2 Read the Release Notes online, or print the document.

3 After reading or printing the Release Notes, close the document to
return to the installation media browser.

Getting Started 11



Accessing the Release Notes on FrontLine

1 Open a Web browser and go to http://frontline.compuware.com
where the Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and

click Login.

Note: If you are a first-time visitor, click Register to receive your free
password to access FrontLine. After you complete the registration
form, your login ID and password will be e-mailed to you and your
account will be activated.

3 From the list in the center of the page, select a product and click Go.
You will see the product’s FrontLine home page, where you can
access documentation, technical information, fixes, and other sup-
port items.

Installing the License

A trial license is supplied with your QACenter product. During this 30-
day trial period, you will be informed of how much evaluation time
remains.

Install a permanent license at any time during the evaluation period.
When the evaluation period expires, you must install a license to
successfully run this product. Information about permanent license
installation can be found in the Distributed License Management Installa-
tion Guide. Access this guide by clicking Start>Programs>Compu-
ware>QADirector>Documentation.

Viewing Online Books

Download Adobe Acrobat 6.0 or Acrobat Reader (provided on the instal-
lation media) to view the online books in PDF format.

System Requirements

System requirements exist for each QACenter component. Those require-
ments are listed below.
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QADirector Database Server

Hardware

¢ 1 GHz processor with 512 MB RAM (2 GHz with 1 GB RAM recom-
mended)

¢ Minimum 450 MB of free disk space

Operating System

Microsoft Windows 2000 Professional SP 4
Microsoft Windows 2000 Server SP 4

Microsoft Windows 2000 Advanced Server SP 4
Microsoft Windows XP Professional SP 1, 1a, or 2
Microsoft Windows Server 2003 Standard SP 1

® 6 6 O o o

Microsoft Windows Server 2003 Enterprise SP 1

Database Management System
¢ Microsoft SQL Server 2000 SP 3/2005/SQL Server Express
¢ Oracle 9i, 10g

QADirector Client and Test Execution and Test Management Servers

Hardware
¢ Mid-level Pentium III PC with 512 MB of RAM (minimum)
¢ Minimum 450 MB of free disk space

Operating System

Microsoft Windows 2000 Professional SP 4
Microsoft Windows 2000 Server SP 4

Microsoft Windows 2000 Advanced Server SP 4
Microsoft Windows XP Professional SP 1, 1a, or 2
Microsoft Windows Server 2003 Standard SP 1

* 6 6 6 o o

Microsoft Windows Server 2003 Enterprise

Getting Started
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Registry

Windows Directories

MDAC

Software

¢ Oracle Client 9i, 10g, if using an Oracle database

Network
¢ TCP/IP protocol installed on all computers

¢ Four ports within the range of ports 1024 through 5000 must remain
open. QADirector randomly selects four ports to use when executing
jobs.

Windows Environment

In order to use QADirector in a Windows environment, users must have
specific permission and rights.

Ensure that users have update access to the following registry keys:
¢ HKEY_CURRENT_USER\Software\
¢ HKEY_LOCAL_MACHINE\SOFTWARE\

Users must also have update access to the following directories:

¢ QADirector install directory (Example: \Program Files\Common
Files\ Compuware)

¢ System32

¢ SQLSRV32.DLL driver provided with the MDAC installation must be
installed and configured on workstation.

Browser

Microsoft Internet Explorer 6.0 SP 1 or 7.0

Integrated Products Requirements

14

QADirector integrates with many Compuware automated testing, analy-
sis, defect tracking, and requirements management tools. If you intend to
use QADirector with any of these tools, please note the minimum version
requirements:

¢ File-AID/CS (Compare, Converter) Release 03.02.00 SP12W
¢ QAHiperstation Release 07.04.00 or later

¢ QAHiperstation+ Release 02.00.00 or later

¢ QALoad Release 05.02.00 or later
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QARun Release 04.09.01 or later

Reconcile 02.00 or later

TestPartner 05.03.00 or later

TrackRecord Release 06.02.00 or later
Changepoint Request Management 11.00.28.000

Getting Started
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Chapter 2
Completing a Basic Installation

4 Basic Installation
¢ Installing QADirector
& Configuring QADirector

Basic Installation

The following example provides the basic installation sequence for
QADirector using the default database (MSDE) on one machine.

If you do not wish to install the MSDE database, then proceed with an
Enterprise Installation. An example of full or enterprise installation in a
distributed environment appears in “Completing an Installation” on
page 21.

Before You Begin

1 Exit all non-essential Windows programs. Some Windows programs
may interfere with the installation process.

2 Do one of the following:

¢ If you are migrating from an earlier version see “Upgrading and
Migrating Previous Versions of QADirector” on page 31.

<& If this is a new installation, continue.

Installing QADirector

Follow these steps to install QADirector:
1 From the installation media, click Install QACenter Products.

2 Click QADirector. The Welcome dialog box appears.

17



3 Click Next. The License Agreement dialog box appears.
4 Click Yes. The Customer Information dialog box appears.

5 Type your name and company in the User Name and Company
Name fields.

6 Click Next. The Choose Destination Location dialog box appears.

7 Choose the location in which to install QADirector.

By default, QADirector installs in the Windows folder in Program
Files\Compuware\QADirector. Click Browse to select an existing
folder or type the path name in the Path field. Click OK.

8 Click Next. The Select Components dialog box appears.
9 Clear the database server selection.
10 Click Next. The Select Program Folder dialog box appears.

11 Specify a location for the QADirector program shortcuts by typing a
new folder name or selecting one from the existing folders list.

12 Click Next. The Start Copying Files dialog box appears.
13 Click Next. The programs are installed.

14 (Optional) Select the Display Release Notes check box when the
Setup Complete dialog box appears.

15 Click Finish. The computer is restarted if necessary.

Configuring QADirector

18

Setting Up an ODBC Data Source

Create a Windows ODBC DSN. Use the following MSDE information,
which was installed previously:

< DSN Name: QADirector (recommended)

Server Name: <Machine Name>\QACenter

User Name: sa

Password: Enter the password you specified during installation,
(if you did not specify a password, leave blank)

< DB Name: QACenter

Note: When MSDE is initially installed, sa is the userid and the password is
empty. It is possible that you may see a different userid in the ODBC
applet in the control panel for this datasource. If so, please disregard,
as sa is the correct userid.

(ORI

For more information see Appendix B, “Setting Up a Net Service Name”.
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Configuring QADirector

1

Shut down the Test Management Server and the Test Execution
Server if they are running on the computer.

Open the database configuration utility by clicking Start>Pro-
grams>Compuware>QADirector>Database Configuration Utility.

The path to the software may vary slightly depending on your
operating system.

Select SQL Server\MSDE.

Select the DSN created in “Setting Up an ODBC Data Source” on page
18 and type the following in the appropriate locations:

¢ DB Name: QACenter

Schema: Default

User Name: sa

Password: Enter the password you specified during installation,
(if you did not specify a password, leave blank)

Click OK.

SO0

Verifying the Installation

1

Click Start>Programs>Compuware>QADirector>QADirector.

The path to the software may vary slightly depending on your
operating system.

Type admin for both the user name and password

Create a project (Example: Testl).

Completing a Basic Installation 19
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Chapter 3
Completing an Installation

& Before You Begin

¢ Installing the QACenter Database on the Database Server
Machine

Installing QADirector

Configuring QADirector

Configuring the Test Management and Execution Servers
Configuring the Windows XP SP2 Firewall for QADirector
Integrating With Other Compuware Products

L 2R R 2R N 2

Before You Begin

Exit all non-essential Windows programs before running this setup
program. Some Windows programs may interfere with the installation
process.

Do one of the following:

< If you are migrating from an earlier version see “Upgrading and
Migrating Previous Versions of QADirector” on page 31.

<& If this is a new installation, continue.
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Installing the QACenter Database on the Database Server

Machine

Create a QACenter database manually or using the installation media.
Manually creating and configuring a database consists of a series of
procedures. To manually create and configure the database, refer to
Appendix A, “Manually Creating and Configuring a Database”.

To simplify this process, Compuware provides a database installation
directly from the installation media. This section provides information
about installing a QACenter SQL Server or Oracle database using the
Database Install on the installation media.

Note: Compuware recommends using the database installation from the
installation media if you have no database administration experience.

Installing a SQL Server Database

Requirements

¢ An existing database server instance that runs a supported version of
SQL Server. See “System Requirements” on page 12.

¢ The following specifics used to configure the database instance:

<& The SQL Server must be case insensitive at the time of installa-
tion.

¢ If the database instance is defined, you must specify code page
1252 and sort order 52 (also known as ISO 8859-1).

¢ If you are using SQL Server 2000, specify the
SQL_Latinl_General_CP1_CI_AS collation.

¢ An SQL Server user ID and password to allow the administrator to set
up the database.

Installing the Database

1 Log on as a user with administrator permissions.

From the installation media, click Install QACenter Products.
Click Databases. The Welcome dialog box appears.

Click Next. The License Agreement dialog box appears.

Click Yes. The Database Management System dialog box appears.

N L A W N

Select Microsoft SQL Server 2000\2005 and click Next. The SQL
Server Login Information dialog box appears.
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7 Type the following information in the Server Login Information
dialog box fields:

¢ Server field: Database server name.

¢ Login field: Database user name (must have sufficient permis-
sions) Example: sa.

¢ Password field: User password.

8 Click Next. The Database Selection dialog box appears.

Select the QADirector database to install and clear the Reconcile
selection.

10 Click Next. The Database Information dialog box appears.
11 Type the following information in the Database Information dialog
box fields:

¢ Database: Database name.

¢ Login: Database User name for new database (optional). New
user account is created.

¢ Password: Password for new user (optional).

12 Click Next. The Review Settings dialog box appears displaying infor-
mation specified in the previous setup screens. To change any of the
settings, click Back.

13 Click Next to begin creating the database. This may take a few min-
utes. The Command Results dialog box appears.

At the end of the installation, this dialog box displays a log contain-
ing all commands executed during the database creation. To save the
log, select the text, copy and paste it into a text file, and save it.

14 Click Finish to complete the database installation.
Installing an Oracle Database

Requirements

¢ An existing database server instance that runs supported versions of
Oracle. Refer to “System Requirements” on page 12 for details.

¢ The following specifics used to configure the database instance:

¢ When the Oracle database instance is defined, you must specify
the Storage Character Set as iso 8859-1 West European.

< The NLS_LANGUAGE parameter should be set in the parameter file
as:

NLS_LANGUAGE = "AMERICAN'

Completing an Installation 23
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2

If you are using Windows 2000, set the NLS_LANGUAGE
parameter to AMERICAN_AMERICA.WE8IS08859P1 in the
following locations:

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\NLS_LANG
HKEY_LOCAL_MACHINE\SOFTWARE\NORACLE\NALL_HOMES\IDO\NLS_LANG
HKEY_LOCAL_MACHINE\SOFTWARE\NORACLE\HOME-\NLS_LANG

¢ You must know the Oracle user ID and password to allow the
QADirector administrator to set up the Oracle.

An Oracle Net Service created before installing an Oracle database.
For further information see Appendix B, “Setting Up a Net Service
Name”.

Installing the Oracle Database

To install the QACenter Oracle database:

1

A LW A W N

10

11

Log on as a user with administrator permissions.

From the installation media, click Install QACenter Products.
Click Databases. The Welcome dialog box appears.

Click Next. The License Agreement dialog box appears.

Click Yes. The Database Management System dialog box appears.

Select Oracle 9i1\10g and click Next. The Oracle Login Information
dialog box appeatrs.

Type the following information in the Oracle Login Information
dialog box fields:

<& Service: Service name.

¢ Login: User/schema name (must have sufficient permissions)
Example: sys.

¢ Password: User password.

Click Next. The Database Selection dialog box appears.
Select the QADirector database and clear the Reconcile selection.

Click Next. The Review Settings dialog box appears displaying infor-
mation specified in the previous setup screens. To change anything,
click Back.

Click Next to begin creating the database. The Command Results
dialog box appears.

At the end of the installation, this dialog box displays a log contain-
ing all commands that were executed during the database creation.
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To save the log, select the text, copy and paste it into a text file, and
save it.

12 Click Finish to complete the database installation.

Installing QADirector

Installing QADirector on a Client Machine

Use this process to install QADirector on a client machine and repeat the
process for every client in an Enterprise environment.

1 Log on as a user with administrator permissions.

2 From the installation media, click Install QACenter Products.

3 Click QADirector. The Welcome dialog box appears.

4 Click Next. The License Agreement dialog box appears.

5 Click Yes. The Customer Information dialog box appears.

6 Type your name and company in the User Name and Company
Name fields.

7 Click Next. The Choose Destination Location dialog box appears.

8 Choose the location in which to install QADirector.

By default, QADirector installs in the Windows folder in Program
Files\Compuware\QADirector. Click Browse to select an existing
folder or type the path name in the Path field.

9 Click OK and click Next. The Select Components dialog box
appears. Components to install appear as follows:
¢ Database Server: Do not select this component.

Note: To install MSDE, click Cancel and see “Completing a Basic
Installation” on page 17.

¢ Test Management Server: Installs the Test Management Server
on the local machine.

< Test Execution Server: Installs the Test Execution Server on the
local machine.

Note: Select these to install them on the same machine. To install
them on separate machines, deselect these options and see
“Installing the Test Management and Test Execution Servers”
on page 26.

< Windows Client: Installs QADirector on the local machine.
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< IBM $/390 Support: Includes the QA 3270 Emulator Server, a
utility program used to manage communications between your
3270 IBM mainframe emulator and QADirector. The QA 3270
Emulator Server includes the TN3270 Mainframe Emulator, a free
emulator you can use for mainframe testing. If you prefer to use
your own emulator, refer to the QA 3270 Emulator Server Readme
file for a list of supported emulators. After installing QADirector,
you can view the Readme file by clicking Start>Programs>Com-
puware>QADirector>QA 3270 Emulator Server>Readme.

10 Specify a location. Type a folder name, or select one from the existing
folders list. The Start Copying Files dialog box appears.

11 Click Next. The Setup Status dialog box appears.
12 Click Next. The components are installed.

13 (Optional) Select the Display Release Notes check box when the
Setup Complete dialog box appears.

14 Click Finish. The computer is restarted if necessary.

Installing the Test Management and Test Execution Servers

Installing the Test Management Server

To install a Test Management Server, follow steps 1-10 of Installing
QADirector. Select to install the Test Management Server only and
continue with the process.

Installing the Test Execution Server

To install a Test Execution Server, follow steps 1-10 of Installing QADirec-
tor. Select to install the Test Execution Server only and continue with the
process.

15

Configuring QADirector

26

To configure QADirector Client, first shut down the Test Execution Server
(TES) and the Test Management Server (TMS).

Database connection information can be changed from within QADirec-
tor in the System Administration Center (See “Connecting from Within
QADirector” on page 28.)
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Configuring QADirector for Oracle

To configure QADirector for Oracle, ensure that you have an Oracle Net
Service and that you create a Windows ODBC data source for the Oracle
database. For information see Appendix B, “Setting Up a Net Service
Name”.

Creating an ODBC Data Source

1 Create an Oracle Net Service name using the Oracle Net Configura-
tion Assistant.

2 Create a System DSN.

Completing the Configuration

1 Run the Database Configuration Utility located in Start>Pro-
grams>Compuware >QADirector>Database Configuration Utility.

2 Select Oracle.
3 Click the list and select the data source name you created previously.

4 Type the schema name and the Oracle database user name and pass-
word.

5 Click OK.

For more information see Appendix B, “Setting Up a Net Service Name”.

Configuring QADirector Client For SQL Server
To connect to the database before logging in to QADirector, create a data
source and SQL Server DSN. Follow these steps:
Creating an ODBC Data Source
Create an ODBC DSN. For more information see Appendix B, “Setting Up
a Net Service Name”.
Completing the Configuration

1 Click Start>Program Files>Compuware>QADirector>Database
Configuration Utility. The Select Database Connection dialog box
appears.

2 Select SQL Server / MSDE.

3 Click the list and select the data source name you created previously.
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4 Type the database name, schema name, and the SQL Server database
user name and password.

Configuring the Test Management and Execution Servers

Multiple Test Management Servers can be created and configured with
different priorities. The prioritized Test Management Server list appears
in the TM Server List panel in the System Administration Center. These
Test Management Servers will start according to priority.

Only one Test Management Server is the active Test Management Server
at any particular time even though other Test Management Servers may
be running. For example, if a Test Management Server with the priority
of 1 fails to start, the Test Management Server with the priority of 2 will
start in its place.

Completing the Configuration

Follow the steps for “Configuring QADirector for Oracle” on page 27 or
“Configuring QADirector Client For SQL Server” on page 27.

Connecting from Within QADirector
To connect to the database from within QADirector, follow these steps:
1 Navigate to the System Administration Center.

2 From the Datasource panel click Actions>Change. The Select Data-
base Connection dialog box appears.

3 Follow the steps for “Configuring QADirector for Oracle” on page 27
or “Configuring QADirector Client For SQL Server” on page 27.

Configuring the QA3270 Emulator Server

If you installed the optional IBM S/390 Support component, you may
need to configure the QA 3270 Emulator Server to work with your
mainframe emulator. To access the QA 3270 Emulator Server readme file,
click Start>Programs>Compuware>QADirector>QA 3270 Emulator
Server>Readme.

Using the QADirector Tutorial

To complete the QADirector tutorial, install TestPartner. The tutorial
database is located in Program Files\Compuware\QADirec-
tor\Tutorial\MIBQADB\QAD4.MDB. For detailed instructions on using the
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tutorial, refer to the QADirector Tutorial, which can be accessed through
online Help.

Configuring the Windows XP SP2 Firewall for QADirector

With the release of Windows XP, Microsoft introduced a set of security
technologies to improve the ability of Windows XP-based computers to
withstand malicious attacks from viruses and worms. The Windows
Firewall prevents unsolicited, inbound TCP/IP connections. Therefore,
the Test Management Server, Test Execution Server, and various other test
execution components may not communicate with each other while the
Windows Firewall is active.

Consider the following when configuring QADirector:

¢ Networking should be configured to use the TCP/IP protocol with a
static port of 1433.

By default, SQL Server allows network connections using port 1433.

The SQL Server machine should have the latest MS Data Access Com-
ponents (MDAC2.71a). These are available with SQL Server Service
Pack 3a or later. Without this version of MDAC, it is not possible to
connect to the SQL Server 2000 installed on a Windows XP with Ser-
vice Pack 2 operating system.

¢ By default the Web Server (IIS) Port 80 is blocked. Enable the port
using the Windows Firewall dialog box.

Use this process in conjunction with Microsoft Windows XP Service Pack
2 to ensure that QADirector 05.01.00 works properly when the Windows
Firewall is active:

1 Click Start>Control Panel>Windows Firewall. The Windows Fire-
wall dialog box appears.

Click the Exceptions tab.
Click Add Program. The Add a Program dialog box appears.

Browse to the directory where QADirector is installed.
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Select the following programs from the list of available programs:
"QC_TESRV.EXE, QC_TMSRV.EXE, TDRV.EXE
"TENG.EXE

If necessary, select the programs one at a time. [t may be necessary to go
back to the Exceptions tab each time a program is selected. Make sure
the check box is selected for each of the QADirector programs.
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Obtaining the Correct Port Number For the Firewall

The correct port number must be used for SQL Server to properly set up
the Firewall. After the port number is obtained, you will return to the
Exceptions tab to complete the setup.

1 Click Start>Programs>Microsoft SQL Server>Server Network Util-
ity. The SQL Server Network Utility dialog box appears:

2 Select TCP/IP and click Properties. The Properties dialog box
appears. The default port number is displayed in the Default port
field.

3 Click Start>Control Panel>Windows Firewall. The Windows Fire-
wall dialog box appears

4 Select the Exceptions tab.

5 Click Add Port. The Add a Port dialog box appears.

6 In the Port number field, type the port number from the SQL Server
Network Utility.

7 Select the TCP option.

8 In the Name field, type a meaningtul name.

9 Click OK. The Windows Firewall dialog box appears.

10 Click OK.

Integrating With Other Compuware Products

30

QADirector integrates with many Compuware automated testing, analy-
sis, defect tracking, and requirements management tools. If you
purchased an integrated product refer to that product’s Installation and
Configuration Guide for information.
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Chapter 4

Upgrading and Migrating
Previous Versions of QADirector

4 Upgrading QADirector

Upgrading QADirector

Install the latest version of QADirector directly over the previous version.
It is not necessary to uninstall the previous version. If you must uninstall
the previous version, refer to the Installation Guide for that version for
instructions on how to uninstall.

Upgrading the QADirector Database

1
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At the QADirector Log In screen, click the Configure button. The
Select a Database dialog appears.

From the Data Source Type options, select SQL Server/MSDE or
Oracle datasource.

In the Data Source Name field, select the exact name of the Data-
base/ODBC connection to be migrated. The Database Name, and
Schema/User Name/Password fields are filled in by default.

Click Test to verify that the information provided is correct. A test
confirmation dialog appears.

Click OK. The QADirector Log In screen appears.
At the QADirector Log In screen, type the User Name and Password.
Click OK.

If necessary, click Yes to upgrade the database schema to the required
schema level.
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9 Click Begin Upgrade. The Current Item Progress, Overall Progress,
and Upgrade Item indicators will display the ongoing progress of the
database migration.

10 When the upgrade is complete, click Close.
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Chapter 5
Maintaining the Installation

# Accessing Maintenance Mode

4 Modifying an Installation

4 Repairing an Installation

4 Uninstalling QADirector

¢ Uninstalling the QACenter MSDE Instance
4 Uninstalling the QACenter MSDE Instance

Accessing Maintenance Mode

To access maintenance mode for QACenter products, Compuware recom-
mends using the Windows Control Panel.

Required: Compuware recommends that you exit all non-essential Windows
programs before running this setup program. Some Windows
programs may interfere with the installation process.

Accessing Maintenance Mode from the Windows Control
Panel

1 Click the Windows Start button and select Settings>Control Panel.
The Control Panel dialog box appears.

2 Select the Add/Remove Programs icon. The Add/Remove Programs
dialog box appears.
3 Select the QACenter product to maintain and click Change/Remove.

Three maintenance mode options display: modify, repair, and
remove. For more information about these options, see the appropri-
ate section in this chapter.
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Modifying an Installation

For products with optional components, you may want to add or remove
a component. Rather than uninstall and re-install the product, you can
modify your installation.

Modifying Products With Optional Components
1 Access maintenance mode described at the beginning of this chapter.

2 Select the Modify option and click Next. The Select Components
dialog box appears allowing you to add or remove components.

3 Click Next. Setup will add or remove the appropriate components.

4 After modifying, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.

Repairing an Installation

There may be times when you will need to repair a damaged QACenter
product installation. This could be due to an inadvertent deletion or
corruption of the program. To repair your QACenter product, follow
these steps:

1 Access maintenance mode described at the beginning of this chapter.

2 Select the Repair option and click Next. Setup will repair the speci-
fied QACenter product.

3 After repairing, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

4 Click Finish to complete the maintenance.

Uninstalling QADirector
If you want to remove QADirector, follow these steps:

1 Access maintenance mode as described at the beginning of this chap-
ter.

2 Select the Remove option and click Next. The Confirm File Dele-
tion dialog box appears.
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3 Click OK. Setup will remove QADirector from your machine.

4 After uninstalling, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.

Uninstalling the QACenter MSDE Instance

To remove the QACenter MSDE instance, follow these steps:

Caution: All associated data will be lost when you uninstall the MSDE
instance.

1 Access maintenance mode as described at the beginning of this chap-
ter and remove the Microsoft SQL Server Desktop Engine
(QACENTER).

2 Delete any remaining files from the installation directory.
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Appendix A

Manually Creating and
Configuring a Database

4 Manually Creating and Configuring an Oracle Database
4 Manually Creating and Configuring a SQL Server Database

Manually Creating and Configuring an Oracle Database

This section provides information about configuring QADirector to use
an Oracle database.

Oracle Server Requirements

¢ An existing database server that runs the supported versions of Ora-
cle. Refer to “System Requirements” on page 12 for details.

¢ Oracle ODBC drivers for a supported version of Oracle. Refer to “Sys-
tem Requirements” on page 12 for details.

¢ A database instance set up on the Oracle database server to store
QADirector data. Use the following specifics to configure the data-
base instance:

¢ When the Oracle database instance is defined, you must specify
the Storage Character Setas iso 8859-1 West European.

< The NLS_LANGUAGE parameter should be set in the parameter file
as:
NLS_LANGUAGE = "AMERICAN'
If you are using Windows 2000, set the NLS_LANGUAGE
parameter to AMERICAN_AMERICA.WEBIS08859P1 in the
following locations:
HKEY_LOCAL_MACHINE\SOFTWARENORACLE\NLS_LANG

HKEY_LOCAL_MACHINE\SOFTWARE\NORACLENALL_HOMES\IDO\NLS_LAN
G
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HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME-\NLS_LANG

¢ Access to a valid owner name (also known as a schema) on the Oracle
database server for QADirector. This owner name is the user ID that
will be associated with each of the product databases.

Creating Database Tables

38

Before any client machines can connect to the Oracle database, you must
create the database and the database tables for QADirector. The SQL*Plus
utility allows you to create the database tables. To create QADirector
tables, perform the following for each database:

1 Do one of the following:

¢ On the Oracle server or client machine, open SQL*Plus Work-
sheet by clicking Start>Programs>OracleHome>Database
Administration>SQL*Plus Worksheet, where OracleHome indi-
cates the home directory where your Oracle database was origi-
nally installed.

¢ In Windows XP, click the Start menu and choose All Pro-
grams>OracleHome>Database Administration>SQL*Plus Work-
sheet, where OracleHome indicates the home directory where
your Oracle database was originally installed

2 Select Connect Directly to a Database.

3 Type a user name in the Username field. This will be the name of the
schema where the QADirector tables reside.

4 Type a password in the Password field.

5 Type the name of the service running the database in the Service
field.

6 On the database server from within SQL*Plus Worksheet, click Menu
Worksheet and then click Run Local Script. The Run Local Script
File dialog box appears.

7  Click the Look In list and navigate to
\Cpwr\database\sqlscripts\oracle
on the installation media.

8 Execute the following scripts in order:
<& 1_0rcl.sql
& 2_0rcl.sql
<& 3_0rcl.sql
<

4_Common.sql
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<& b5_0rcl.sql

Manually Creating and Configuring a SQL Server Database

This section provides information about configuring QADirector to use a
SQL Server database.

SQL Server Requirements

¢ An existing database server that runs a supported version of SQL

Server. Refer to “System Requirements” on page 12 for details.

A database instance on the SQL Server database server to store QADi-
rector data. Use the following specifics to configure the database
instance:

¢ If you are using SQL Server 2000, specify the
SQL_Latinl_General_CP1_C1_AS collation.

¢ An SQL Server user ID and password to allow the QADirector admin-

istrator to set up the database server.

Creating Database Tables using SQL Server 2000

Once you have created the database, you can create the QADirector
database tables. QADirector includes files that execute scripts and
automatically create the tables for you.

1

To start the SQL Server Query Analyzer, select SQL Server Query
Analyzer from the Tools menu in the SQL Server Enterprise Manager.

Select the database from the dropdown list.
Click File>Open. The Open Query File dialog box appears.

Click the Look In list and browse to <drive>:\cpwr\database\sql-
scripts\mssql on the installation media.

Select one script at a time, click Open, and click the Run (green
arrow) icon on the toolbar to run each script in the following order:
& 1_MsSql.sql

& 2_MsSql.sql

& 3_MsSql.sql

< 4_Common.sql

& 5_MsSql.sql
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Creating Database Tables using SQL Server 2005 and SQL Server Express

Once you have created the database, you can create the QADirector
database tables. QADirector includes files that execute scripts and
automatically create the tables for you.

1 Start the SQL Server Management Studio.
2 Select the database from the dropdown list.

3 Click on the New Query icon or click on File>New>Query with cur-
rent connection.

4  Click File>Open>File. The Open File dialog box appears.

5 Click the Look In list and browse to <drive>:\cpwr\database\sql-
scripts\mssql on the installation media.

6 Select one script at a time, click Open, and click the Run (green
arrow) icon on the toolbar to run each script in the following order:
& 1_MsSql.sql
& 2_MsSql.sql
& 3_MsSql.sql
< 4_Common.sql
& 5_MsSql.sql
If you use the SQL Server Express Utility to create the tables, you must
update each script file before executing them. You must add USE

<{Database Name> to the start of each file. Change <Database Name> to
the correct database name.

Adding User Rights to the Database (optional)

40

Once the database and tables have been built, add users and give them
access rights using SQL Server Enterprise Manager. Using SQL Server
authentication login, create a new login ID and password specifically for
SQL Server access. Use this option to create one convenient user name
and password to access the QADirector database and have each QADirec-
tor user use the same user name and password to connect to the
database. If preferred, create multiple SQL Server user names and
passwords.

Note: The user name and password used to connect to the SQL Server
database is not the same user name and password that is used to
connect to QADirector.

To create a SQL Server authentication, follow these steps:
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1 In the left pane of the SQL Server Enterprise Manager, expand the
SQL Server Group, and expand the server machine name.

2 Expand the Security group.

w

Select the Add New User icon from the menu. The SQL Server Login
Properties dialog box appears.

Select the General tab.

Type a user name in the Name field (for example, QATeam).
Select SQL Server Authentication.

Type the password in the Password field.

From the Database drop down menu, select the QADirector database.
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Select the Database Access tab and permit the user to access the cre-
ated database.

10 Set up roles and permissions for the Login account:
¢ Option A: Ensure the Login account has the db_owner role.
¢ Option B: Ensure all privileges on all QACenter database objects
are granted to the newly created Login account. The following is
a sample script for granting all privileges on all objects to a user.
Note: Compuware does not assume any responsibility for the use of this

script.

USE <Database Name>
Go

DECLARE @ExecSQL varchar(255)

Declare @User varchar(64)

Set @User = <Login Account>

DECLARE curGrants CURSOR FOR

SELECT ‘GRANT ALL ON’ + NAME + ‘TP’ + rtrim(@User)

From SYSOBJECTS
WHERE TYPE = ‘U’ or TYPE = “P”

OPEN curGrants

FETCH NEXT FROM curGrants INTO @ExecSQL

WHILE @@FETCH_STATUS = 0

BEGIN
Exec(@ExecSQL)
FETCH NEXT FROM curGrants INTO @ExecSQL

END

CLOSE curGrants

DEALLOCATE curGrants
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Appendix B
Setting Up a Net Service Name

& Setting up an ODBC Data Source for Oracle
& Setting up an ODBC Data Source for SQL Server

Setting up an ODBC Data Source for Oracle

Setting Up a Net Service

1 Open the Oracle Net Configuration Assistant and click Next.
Click Local Net Service Name Configuration and click Next.
Click Add and click Next.

Click Oracle 8i or later and click Next.
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Type the Service Name to which you are trying to connect. This may
be the database name.

Click Next.
7 Click TCP.

8 Type the Host Name. This may be the machine name on which the
Oracle server is installed.

9 Click Next.
10 Click Perform A Test and click Next.

11 Change the user name and password to the user ID you want to use
and test the connection.

12 Click Next.
13 Type the Service Name and click Finish.
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Creating a System DSN

1 Do one of the following:
In Windows 2000:

a Click the Start menu and select Settings>Control Panel>Data
Sources (ODBC). The ODBC Data Source Administrator opens.

b Click the Drivers tab and select Oracle ODBC Driver.
In Windows XP:

a Select Control Panel>Administrative Tools>Data Sources
(ODBC). The ODBC Data Source Administrator opens.

b Click the Drivers tab and select Oracle ODBC Driver.

Click the System DSN tab.

Click Add.

Select Oracle from the Driver list.

Click Finish. The Create a New Data Source dialog box appears.
Type a Data Source Name (DSN) in the Data Source Name field.

Type a description in the Description field.
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Type the database service name in the Service Name field. If the
database is not local to the computer, type the full name, such as
agw.qgaclab.

9 Type the user name in the UserID field.
10 Keep the default settings in the remaining fields and click OK.

Setting up an ODBC Data Source for SQL Server

44

At this point you have a database, tables, and users, but no connection to
the database. You must set up an ODBC data source on the QADirector
client machine:
1 Do one of the following:

In Windows 2000:

a Click the Start menu, and select Settings>Control Panel.

b Double click the Data Sources (ODBC) icon. The ODBC Data
Source Administrator opens.

In Windows XP:
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11
12
13
14
15
16
17
18
19
20

21
22
23

a Click the Start menu and select Control Panel>Administrative
Tools>Data Sources (ODBC).

b Skip to step 3.

Click the System DSN tab.

Click Add.

Select SQL Server from the Driver list.

Click Finish. The Create a New Data Source to SQL Server dialog
box appears.

Type an ODBC connection name in the Name field.

Type a description for the ODBC connection in the Description field.
Type the server name in the Server field.

Click Next.

Select the With SQL Server Authentication using a login ID and
password entered by a user option.

Type a user name in the Login field.

Type a password in the Password field.

Click Client Configure.

Verify that TCP/IP is selected under the network libraries.
Click OK.

Click Next.

Select the Change the Default Database to check box.
Select the QADirector database from the database menu.
Click Next.

Click Finish. The ODBC Microsoft SQL Server Setup dialog box
appears.

Click Test Datasource.
Click OK to exit the ODBC Microsoft SQL Server Setup dialog box.
Click OK to exit the ODBC Data Source Administrator.

Determining the Port Number

To find the port number from the Registry:
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2

Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft
SQL Server\<InstanceName>\MSSQLServer\SuperSocketNetLib\Tcp.

You should see a folder with the same name as the instance that was
created for MSDE. For example:
HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL
Server\QACenter\MSSQLServer\SuperSocketNetLib\Tcp

Remember the number for the Tcpport entry.

To find the port number using SQL Enterprise Manager:

1
2

3
4
5

Open SQL Enterprise Manager.

Connect to the instance for the MSDE installation. Example:
gacenter.

Right click on the instance and select Properties.
Click Network Configuration.

Select TCP/IP from the Enabled Protocols list and click Properties.

The port number is located in the Default Port field.

QADirector Installation and Configuration Guide



Index

A

access methods
maintenance 33
audience 5

basic installation 17

C

Compuware

FrontLine Web site 6

technical support 6

World Wide Web sites 6
configuring

Oracle 27

Windows XP SP2 Firewall 29
configuring a database 37
creating a database 37
customer support 6

D

database
MSDE 17
Oracle 37
SQL Server 39
determining a port number 45

F

FrontLine technical support
Web site 6

G

getting started 9

help 6

Installing 26
installing
basic installation 17
modify product components 34
QACenter prerequisites 9
repairing a product installation 34
TMS/TES 26
types 11
installing the test execution server 26
installing the test management server 26
introduction 5

L

license 5

maintaining the installation 33

47



maintenance
access methods 33
modify 34
remove 34
repair 34
migration 31
modify
maintenance 34

(0

Oracle
database schema 38
server requirements 37

P

prerequisites 9

Q

qa3270 emulator 28
QACenter
FrontLine Web site 6
help 6
product descriptions 9
technical support 6
QADirector
ODBC drivers 14
Oracle
NLS_LANGUAGE parameter 23, 37
storage character set 23, 37
SQL Server, ODBC driver 14
QAHiperstation+ 10
QARun 10

Reconcile 10
release notes 11
on FrontLine 12
on the QACenter CD 11
remove
maintenance 34
repair
maintenance 34

48  QADirector Installation and Configuration Guide

S

SQL Server
creating database tables 39, 40
creating the database 40
server requirements 39
setting up an ODBC data source 44
user rights 40

support
FrontLine Web site 6

system dsn 44

system requirements 12

T

technical support 6

FrontLine Web site 6
Test Management Server 28
TestPartner 10
TrackRecord 9

U

uninstalling
MSDE 35
QADirector 34
upgrading from a previous release 31

W

World Wide Web, Compuware sites 6



	Introduction
	Who Should Read This Guide
	Related Publications
	World Wide Web Information
	Getting Help

	Getting Started
	Overview
	Before You Install
	Installation Types
	Release Notes
	Installing the License

	Viewing Online Books
	System Requirements
	QADirector Database Server
	QADirector Client and Test Execution and Test Management Servers

	Integrated Products Requirements

	Completing a Basic Installation
	Basic Installation
	Before You Begin
	Installing QADirector
	Configuring QADirector


	Completing an Installation
	Before You Begin
	Installing the QACenter Database on the Database Server Machine
	Installing a SQL Server Database
	Installing an Oracle Database

	Installing QADirector
	Installing QADirector on a Client Machine
	Installing the Test Management and Test Execution Servers

	Configuring QADirector
	Configuring QADirector for Oracle
	Configuring QADirector Client For SQL Server
	Configuring the Test Management and Execution Servers
	Connecting from Within QADirector
	Configuring the QA3270 Emulator Server
	Using the QADirector Tutorial

	Configuring the Windows XP SP2 Firewall for QADirector
	Integrating With Other Compuware Products

	Upgrading and Migrating Previous Versions of QADirector
	Upgrading QADirector
	Upgrading the QADirector Database


	Maintaining the Installation
	Accessing Maintenance Mode
	Modifying an Installation
	Repairing an Installation
	Uninstalling QADirector
	Uninstalling the QACenter MSDE Instance

	Manually Creating and Configuring a Database
	Manually Creating and Configuring an Oracle Database
	Oracle Server Requirements
	Creating Database Tables

	Manually Creating and Configuring a SQL Server Database
	SQL Server Requirements
	Creating Database Tables using SQL Server 2000
	Creating Database Tables using SQL Server 2005 and SQL Server Express
	Adding User Rights to the Database (optional)


	Setting Up a Net Service Name
	Setting up an ODBC Data Source for Oracle
	Setting Up a Net Service
	Creating a System DSN

	Setting up an ODBC Data Source for SQL Server
	Determining the Port Number


	Index

