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1. About this Guide

This guide describes the following tools that you can use to assist in your development:

ChangeMan Edit

ChangeMan Diff. 

These tools use the Template Manager to control how your code is displayed.

ChangeMan Edit

ChangeMan Edit is a context sensitive editor that supports several programming languages and file

types.

ChangeMan Edit lets you edit any text-based file on your local computer, and it lets you edit

Mainframe data that you access through ChangeMan ZDD such as:

Sequential data sets

Partitioned data set members

ChangeMan components (text-based)

JES spool data sets

z/OS Unix files

ChangeMan Diff

ChangeMan Diff compares and merges the following files:

Files on your local computer.

Files and ChangeMan ZMF components on your z/OS server.

You can initiate the Compare and Merge functions in the following ways:

Select files/components in the Explorer window, right-click, and choose ZDD Network → 
Compare Files or ZDD Network → Merge Files from the popup menu. See the ChangeMan

ZDD User Guide for more information.

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 
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Select ChangeMan ZMF components from the Staging Versions dialog box and click the 

Compare or Merge buttons See the ChangeMan ZDD User Guide for more information.

Once you are within the ChangeMan Diff tool, you can alternate between comparing and merging

files, and initiate new compares/merges.

Template Manager

The Template Manager allows you to choose the template that controls how your code is

displayed. You can either choose from existing templates, or you can create your own.

• • 

Template Manager
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2. What's New

This section summarizes the what’s new in each release of ChangeMan ZDD.

Changes in 8.1.2

Changes in 8.1.1

Changes in 8.1

Changes in 7.1.2.1

Changes in 7.1.2

Changes in 7.1.1

Changes in 7.1

Changes in 8.1.2

Corrected problem in which data was formatted incorrectly when copying and pasting text from an

outside source.

Changes in 8.1.1

There are no changes to the functionality described in this manual in ChangeMan ZDD release

8.1.1.

Changes in 8.1

Unicode Support for ZDD Edit and ZDD Compare/ Merge
The ChangeMan ZDD text editor and the compare/merge tool now support Unicode (UTF-16),

UTF-8, and DBCS files, and thus, they can now be used with Asian languages. The Save As dialog

box has a new Encoding drop down list that allows you to override the default encoding when

saving a file.

2. What's New
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Navigation Pane for ZDD Edit
The ZDD text editor has a new navigation pane on the left side. The navigation pane allows you to

easily navigate folders and choose files to edit. The navigation bar also allows you to delete files,

rename files or folders, and to create folders.

Changes in 7.1.2.1

Submitting XML From ChangeMan Edit
You can now submit XML from inside the ChangeMan ZDD text editor. The File menu includes a

new Submit XML command. The Submit XML command is disabled (grayed out) unless the first

line of the file begins with “\<?xml”. You will be prompted to select the z/OS server and

ChangeMan ZMF instance.

The results of the XML request are then displayed inside the text editor.

Changes in 7.1.2

Text Editor Enhancements
Many new keyboard and mouse shortcuts have been added for performing common editing

operations and making the editor easier to use. Many keyboard functions can be configured by the

user.

New configuration option to allow the cursor to move beyond the end of line.

New reference card for the keyboard and mouse shortcuts.

Changes in 7.1.1

Submitting JCL From ChangeMan Edit
You can now submit JCL from inside the ChangeMan ZDD text editor. The File menu includes a

“Submit JCL” command. The “Submit JCL” command is disabled (grayed out) unless the first line

of the file begins with “//”. You will be prompted to select the z/OS server.

Navigation Pane for ZDD Edit
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Changes in 7.1

Enhanced ChangeMan Tools
The ChangeMan Edit and ChangeMan Compare tools, which are included with ChangeMan ZDD,

have been enhanced to support path names that exceed 259 characters in length (if you are using

Windows Vista or Windows 7).

The ChangeMan Edit tool has been enhanced to allow a value to be inserted in specified columns

whenever you update or add a line in the file you are editing. For example, you may specify a

change request number to be automatically inserted in columns 73-80 whenever you update or add

a line. This feature is available on the Advanced tab of the Template Manager.

Changes in 7.1
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3. Keyboard and Mouse

This section contains a summary of the keyboard and mouse operations in ChangeMan Edit.

Keyboard and mouse shortcuts provide a quick and easy way to perform many editing operations.

If you take the time to learn these shortcuts, you will save much time.

Using the Keyboard and Mouse

Cursor Movement

Keyboard / Mouse Action

Left arrow Cursor left

Right arrow Cursor right

Up arrow Cursor up

Down arrow Cursor down

Ctrl + Home Top of file

Ctrl + End Bottom of file

Alt + Home Top of window

Alt + End Bottom of window

Home Beginning of line

End End of line

PgUp Page up

PgDn Page down

Ctrl + PgUp Page left

Ctrl + PgDn Page right

Ctrl + Up Scroll up (one line)

Ctrl + Down Scroll down (one line)

Ctrl + Left Previous word

3. Keyboard and Mouse
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Selection

Keyboard / Mouse Action

Ctrl + Right Next word

Tab Next tab stop

Shift + Tab Previous tab stop
...

Keyboard / Mouse Action

Ctrl + K Start or end character selection

Ctrl + L Start or end line selection

Ctrl + B Start or end block selection

Ctrl + W Select word

Ctrl + A Select all

F5 Deselect

Backspace

Del Delete selection

Tab Indent selection

Shift + Tab Unindent selection

F7 Shift selection left

F8 Shift selection right

Shift + \<Cursor keys> Start or extend char/stream selection

Double-Click Select word

Triple-Click Select line

Click & Drag Start character selection (text window)

Start line selection (line number bar)

Right-Click & Drag Start block selection

Triple-Click & Drag Start line selection

Shift + Click Extend selection

Selection
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Inserting Text

Deleting Text

Clipboard

Keyboard / Mouse Action

Ctrl + Right-Click Move selection to cursor

Ctrl + Shift + Right-Click Copy selection to cursor
...

Keyboard / Mouse Action

Ins Insert/overwrite toggle

Enter Insert a line

Ctrl + Enter Insert blank line above

Ctrl + Shift + Enter Insert blank line below
...

Keyboard / Mouse Action

Del Delete char under cursor

Backspace Delete char before cursor

Ctrl + Shift + Del Delete word to left of cursor

Ctrl + Del Delete word to right of cursor

Alt + Del Delete to end of line

Ctrl + D Delete line
...

Keyboard / Mouse Action

Ctrl + C Copy selection to clipboard

Ctrl + Ins Copy line, if no selection

Ctrl + V and Shift + Ins Paste

Ctrl + X and Shift + Del Cut selection Cut line, if no selection
...

Inserting Text
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Searching

Bookmarks

Files

Windowing

Keyboard / Mouse Action

Ctrl + F Find

Ctrl + H Replace

F3 Find next occurrence

Shift + F3 Find previous occurrence
...

Keyboard / Mouse Action

Ctrl + F2 Toggle bookmark

Shift + F2 Previous bookmark

F2 Next bookmark
...

Keyboard / Mouse Action

Ctrl + S Save file

Ctrl + Alt + S Save file as another name

Ctrl + Shift + S Save all

Ctrl + O Open file
...

Keyboard / Mouse Action

Ctrl + Tab and Ctrl + F6 Next window

Ctrl + Shift + Tab Previous window

F6 Next split window pane

Shift + F6 Previous split window pane

Searching
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Miscellaneous

Keyboard / Mouse Action

Ctrl + F4 Close window

Ctrl + T Split window

Ctrl + G New vertical tab group

Ctrl + Shift + G New horizontal tab group

Ctrl + M Move to next tab group

Ctrl + Shift + M Move to previous tab group

Ctrl + Alt + Enter Toggle full screen mode
...

Keyboard / Mouse Action

F1 Help

Alt + F4 Exit

Ctrl + Z

Alt + Backspace Undo

Ctrl + Y

Alt + Shift + Backspace Redo

Ctrl + P Print

Ctrl + U Lower case

Ctrl + Shift + U Upper case

F7 Shift left

F8 Shift right

F4 Set change ID

Shift + F4 Set template
...

Miscellaneous
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4. Customizing the Keyboard

ChangeMan Edit has many keyboard shortcuts built into the editor. Most of the keyboard shortcuts

can be customized by the user. Generally, you can change any shortcuts, with the exception of

those defined for cursor movement operations.

Keyboard shortcuts are defined as a combination of any keyboard key in conjunction with the

Control, Alt, and Shift keys.

Adding or Removing Key Assignments

You can add or remove key assignments as follows:

Step Action

1 Select Tools > Customize from the menu.

2 Select the Keyboard tab of the Customize dialog box.

3 Select ChangeMan Edit in the Accelerator drop down list.

4 From the Category drop down list, select the category containing the commands

you want to work with. The All Commands category includes everything.

4. Customizing the Keyboard
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Resetting the Key Assignments
You can reset the keyboard back to the default state as follows:

Customizing Menus

Adding or Removing Commands

Step Action

5 In the Commands list box, select the command for which you want add or

remove a shortcut key.

6 To remove a shortcut, select the key assignment that you want to remove from

the Current Keys list box, and press the Remove button.

7 To add a shortcut, click on the New Shortcut Key edit box, and press the key

combination that you want to assign. Finally, press the Assign button. You will

only be allowed to assign key combinations that are not already in use. If the key

combination you enter is already assigned, it will display the current key

assignment below the edit box.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Keyboard tab of the Customize dialog box.

3 Select ChangeMan Edit in the Accelerator drop down list.

4 Press the Reset button.
...

Resetting the Key Assignments
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You can customize menus to add or remove commands as follows:

Resetting Menus
You can reset the menus back to the default state as follows:

Step Action

1 Select Tools > Customize from the menu.

2 Select the Menu tab of the Customize dialog box.

3 Press the Reset button.

4 To remove a command, drag it off of the menu.

5 To add a command, drag the desired toolbar button from the Commands tab

of the Customize dialog box and drop onto the desired location in the menu.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Menu tab of the Customize dialog box.

3 Press the Reset button.
...

Resetting Menus
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Customizing Toolbars

Showing or Hiding Toolbars

You can a show or hide toolbars as follows:

Creating a New Toolbar
You can create your own toolbars as follows:

Step Action

1 Select Tools > Customize from the menu.

2 Select the Toolbars tab of the Customize dialog box.

3 On the toolbars list, check or uncheck the toolbars that you wish to show

or hide.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Toolbars tab of the Customize dialog box.

3 Press the New button.

4 When prompted, enter the name for your new toolbar.

Customizing Toolbars
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Adding or Removing Buttons
You add or remove buttons from toolbars as follows:

Resetting a Toolbar
You can reset one of the built-in toolbars back to the default state as shown below. Userdefined

toolbars do not have a default state.:

Renaming or Deleting a Toolbar
You can rename or delete a toolbar as shown below. You can only rename or delete toolbars that

you created. The built in toolbars can be customized, but not renamed or deleted.

Step Action

5 Drag the empty toolbar and dock it at the top of the window.

6 Add buttons to the toolbar as described below.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Commands tab of the Customize dialog box.

3 To remove a command, drag it off of the toolbar.

4 To add a command, drag the desired toolbar button from the Commands tab

of the Customize dialog box and drop onto the desired location in the toolbar.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Toolbars tab of the Customize dialog box.

3 On the toolbars list, select the toolbar that you want to reset.

4 Press the Reset button to reset the selected toolbar or press the Reset All

button to reset all toolbars.
...

Step Action

1 Select Tools > Customize from the menu.

2 Select the Toolbars tab of the Customize dialog box.

3 On the toolbars list, select the toolbar that you want to rename or delete.

Adding or Removing Buttons
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Step Action

4 Press the Rename button or the Delete button.

5 If you are renaming the toolbar, you will be prompted for the new name.
...

Renaming or Deleting a Toolbar
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5. Editing Files Using ChangeMan Edit

The ChangeMan Edit utility is included with ChangeMan ZDD and supports path names that exceed

259 characters in length if you are using Windows Vista or Windows 7.

Overview

ChangeMan Edit is a context-sensitive editor that supports several programming languages and file

types. The following standard templates define settings specific to each language or file type:

ANSI C Source File

ANSI C Fortran

ANSI C Pascal

CL Code

COBOL

General Make File

Help

HTML Source File

Java Source File

MS C++ Source File

MS Visual Basic

Simple Text

You can modify the standard templates, or create your own custom templates.

You can edit the following types of data using ChangeMan Edit:

Any text-based file on your local computer

Mainframe data that you access through ChangeMan ZDD:

Sequential data sets

Partitioned data set members

Unix files (text-based)

ChangeMan components (text-based)

JES spool data sets

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• 

• • 

• • 

• • 

• • 

• • 

• • 

• • 
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ChangeMan Edit does not create temporary (intermediate) or backup files, so you are not required

to change any settings to use it with ChangeMan ZDD. Some other text editors require setting

changes to prevent temporary and backup files from being created.

Invoking the Editor

If ChangeMan Edit is your default editor, right-click any file in Windows Explorer and choose ZDD

Network -> Edit from the popup menu. Otherwise, choose All Programs -> ChangeMan ZDD -> ZDD

Edit from the Windows Start menu. The ChangeMan Edit window displays.

If the file you are attempting to edit has been migrated, the following message displays:

An unknown error occurred while accessing <file name> .

To recall the data set, right-click the file and choose ZDD Network -> Recall Data Set from the

popup menu.

You can customize some components of the display window by selecting or deselecting options on

the View menu. In the above example, the code window is bordered by a ruler bar on top and a line

number bar to the left.

Invoking the Editor
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Using the Navigation Bar

The following screen shot shows the navigation bar, which can be displayed on the left side of the

ChangeMan Edit window. You can show or hide the navigation bar by selecting Navigation Bar on

the View menu.

The navigation bar includes the following components:

Filter box

Toolbar

File list

Folder tree

• • 

• • 

• • 

• • 
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Filter Box
The filter box is displayed on the top left side of the navigation bar:

The filter box allows you to filter the list of files displayed using a pattern string with wild

characters. The pattern can contain include multiple names, separated by semicolons. For

example: “*.txt;*.src”.

Toolbar
The toolbar is displayed at the top of the navigation bar, next to the filter box:

The toolbar contains buttons to perform the following operations:

Refresh – Refresh file list

Parent folder – Go up to parent folder

Open – Open a file or folder

New folder – Create a new folder

Delete – Delete a file

Rename – Rename a file or folder

File List
The top half of the navigation pane contains a file list. You can double click on a file to open it in

the editor. Double clicking on a folder will open the folder in the navigation bar. You can also right

click on files in the file list to perform the operations listed in the Toolbar section.

Folder Tree
The bottom half of the navigation pane contains a folder tree. The folder tree allows you to

navigate between folders. Selecting a folder in the folder tree displays that folder in the file list.

• • 

• • 

• • 

• • 

• • 

• • 
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Modifying a File

You can use ChangeMan Edit to modify files in the same way you edit text in most Windows-based

word processing or development utilities.

Use the scroll bars to the right and bottom of the code window to scroll the editable area of the

window.

Use the mouse or keyboard to position the insertion point on a line of code.

To use the mouse, scroll the editable area using the scroll bars, position the cursor, then click the

left mouse button.

If you use the keyboard to position the insertion point, ChangeMan Edit automatically scrolls the

editable area to ensure that the new insertion point is always visible.

The current cursor position is always shown on the ruler bar and line number bar.

The following is a list of keyboard navigation commands available for a file opened in ChangeMan

Edit.

Press… To Move…

Ctrl + Right arrow One word to the right.

Ctrl + Left arrow One word to the left.

Left arrow One character to the left

Right arrow One character to the right

Up arrow To the previous line

Down arrow To the next line

Ctrl + Home To the start of the file

Ctrl + End To the end of the file

Alt + Home To top f window

Alt + End To bottom of window

Home To the start of the current line

End To the end of the current line

Page Up To the previous page

Page Down To the next page

Modifying a File
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Once you have identified the point at which you want to begin editing, and you have set the

insertion point, a flashing cursor is displayed.

When editing more than one character you must identify a selection.

To create a selection, place the insertion point at the start of the selection, hold the mouse

button down, and drag the insertion point to the end of the selection.

To remove an existing selection, click anywhere in the editable area, or press one of the arrow

keys.

To extend or restrict an existing selection, move the insertion point using either the mouse or

keyboard while keeping the Shift key pressed.

Selecting Text
A selection is a marked region of text. There are three types of selections:

Character selection: Any range of continuous text.

Line selection: Group of full lines

Block selection: Block of text within a range of columns

There is a selection indicator, located in the status bar along the bottom of the editor window that

displays the type of selection. This indicator will display None, Char, Line, or Block, allowing you to

see which type of selection that you have made.

Press… To Move…

Ctrl + Page Up Half screen width to the left

Ctrl + Page Down Half screen width to the right

Ctrl + Up arrow Scroll up one line

Ctrl + Down arrow Scroll down one line

Ctrl + Right arrow One word to the right.

Ctrl + Left arrow One word to the left.

Tab Next tab stop

Shift + Tab Previous tab stop
...

• • 

• • 

• • 

• • 

• • 

• • 
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Character selection
Character selections are used to select any contiguous range of text. The character selection

includes all text between the starting location and an ending location, and may be include parts of

lines, as well as full lines.

You can create a character selection using any of the following methods:

Click the left mouse button and drag.

Press Ctrl+K to start the selection, and then use the arrow keys to extend the selection. Press 

Ctrl+K again to end the selection.

Press the Shift key with any cursor movement keys, such as the arrow keys, Page Up, Page

Down, Home, End, etc.

You can select words of text as follows:

Press Ctrl+W to select the word at the cursor location.

Double click on the word with the left mouse button.

Line Selections
A line selection is used to select a range of complete lines.

Line selections are treated differently than character selections. A line selection is always inserted

before or after another line, and never inserted into the middle of another line. When performing

operations on complete lines, line selections are faster and easier to use than character selections.

You can create a line selection using any of the following methods:

Triple-click on a line with the left mouse button. You can then hold the left mouse button down

and drag to select multiple lines.

Click on a line number in the line number bar on the left side of the window with the left mouse

button. You can hold the left mouse button down and drag to select multiple lines.

Press Ctrl+L to start the selection, and then use the arrow keys to extend the selection. Press 

Ctrl+L again to end the selection.

Press Ctrl+A (or Select All from the Edit menu) to select the entire file. This is treated as a line

selection.

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 
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Block Selections
A block selection is used to select a block of text within a range of columns. The block may

consist of segments from multiple lines.

You can create a block selection using any of the following methods:

Right-click the using the mouse the mouse and drag.

Press Ctrl+B to start the selection, and then use the arrow keys to extend the selection. Press

Ctrl+B again to end the selection.

Moving and Copying Text
This section describes how to move, copy, and paste text.

Moving a Selection to a New Location Using Commands

Copying a Selection to a New Location Using Commands

The Copy command can be used to copy selections in the same file, in different files opened in the

Edit module, or between Edit and other Microsoft Windows programs.

ChangeMan Edit uses the clipboard for all text movements. The clipboard is a shared resource that

allows all Microsoft Windows applications to provide a temporary location for storing data that

needs to be moved/copied.

• • 

• • 

Step Action

1 Make a selection.

2 Click Cut or choose Cut from the Edit menu.

3 Bring the insertion point to a new location.

4 Click Paste or choose Paste from the Edit menu.
...

Step Action

1 Make a selection.

2 Click Copy or choose Copy from the Edit menu.

3 Bring the insertion point to a new location.

4 Click Paste or choose Paste from the Edit menu.

...

Block Selections
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To copy a selection, you can also use a shortcut key combination such as Ctrl + C or Ctrl + V for

the copy/paste commands.

Moving a Selection Using the Drag-and-Drop Method
The drag-and-drop method is a simple way to move or copy a limited selection a relatively short

distance.

Copying a Selection Using the Drag-and-Drop Method

Undo and Redo Commands

If you make a mistake in the code window, you can undo your last action or command. For

example, if you delete a selection you can easily restore it.

To undo the last action, click Undo from the Standard toolbar, or select Undo from the Edit menu.

As you make changes in the Code Window, ChangeMan Edit records all of your actions, and lets

you undo them if necessary. The number of actions that you can undo is based on the amount of

available RAM.

After you undo the last action, you may realize that you need it after all. In this case, you can use

the Redo command.

To redo the previously undone action, click Redo from the Standard toolbar, or select Redo from the

Edit menu.

Step Action

1 Make a selection.

2 Point to the selected text and hold down the left mouse button.

3 Drag the insertion point to the new location.

4 To move the text, release the mouse button.
...

Step Action

1 Make a selection.

2 Point to the selected text and hold down the left mouse button.

3 Drag the insertion point to the new location.

4 Press and hold CTRL while releasing the mouse button.
...

Moving a Selection Using the Drag-and-Drop Method
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Find and Replace Commands

You can use the Find and Replace commands to locate and change specific text in your document.

Finding Text
Use this procedure to find a text string:

To resume the Find search for the previously defined criteria, click Repeat.

Step Action

1 Click Find , or choose Find from the Edit menu. ChangeMan Edit displays the 

Find dialog box.

2 In the Find dialog box, enter the text to find.

3 You can customize your search by setting the following options:

Match whole words only- Select this option to find the whole words, not parts of

words, that match the text displayed in the Find what box.

Match case- Select this option to find the text with the same capitalization as

the text displayed in the Find what box.

4 Click Find Next to start the search process. ChangeMan Edit highlights the next

occurrence of the search text that matches the criteria. The Find dialog uses

your current selection as the initial criteria to be displayed in the Find what box.

...

Find and Replace Commands
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Replacing Text
Use this procedure to replace one text string with a different string:

Step Action

1 Choose Replace from the Edit menu. ChangeMan Edit displays the Replace

dialog.

2 In the Find what field, type the text to be replaced.

3 In the Replace with field, enter the replacement text.

4 Select the match search criteria (if necessary).

5 Determine how you want the search to proceed by choosing from the

following options:

Click… To…

Replace Replace the text and find the next occurrence.

Replace All Change all occurrences of your selection without confirmation.

Find Next Leave the text unchanged and search for the next occurrence.

Cancel (or press ESC) Cancel a search in progress or close the dialog box.

To undo the effects of the last replacement,choose Undo from the Edit menu.

This will reverse the last change made.

...

...

Replacing Text
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Bookmarks

Bookmarks provide a convenient way to mark specific lines in a file and enable you to quickly jump

to the next/previous bookmark or cycle through all of the bookmarks.

NOTE Bookmark functionality is identical for the ChangeMan Edit and ChangeMan Diff utilities.

Placing a Bookmark
Use this procedure to place a bookmark:

Removing a Bookmark
Use this procedure to remove a bookmark:

Navigating to Bookmarks
Use these actions to navigate bookmarks:

Step Action

1 Place the cursor in the text where you wish to insert a bookmark.

2 Either:

Click Toggle Bookmark

Choose Toggle Bookmark from the Edit menu.

ChangeMan Edit places the bookmark symbol on the Marker Bar for the

corresponding line.
...

Step Action

1 Place the cursor in the line containing the bookmark.

2 Click Toggle Bookmark , or choose Toggle Bookmark from the Edit menu.

ChangeMan Edit removes the bookmark symbol from the Marker Bar.
...

To… Do this…

Move to the next bookmark. Choose Next Bookmark from the Edit menu.

Move to the previous bookmark Choose Previous Bookmark from the Edit

menu.

Remove all bookmarks in the active

document

Choose Clear All Bookmarks from the Edit

menu.
...

Bookmarks
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Displaying Bars

ChangeMan Edit contains different visual bars that help you to easily edit your code.

The Ruler Bar and Line Number Bar help you track column and line positions. As the insertion point

is moved in the Code Window, the status bar displays the current line number and character

position, where the first number indicates the ruler position and the second the line number.

Displaying the Ruler
The Ruler Bar at the top of the code window provides a visual indication of the character position

relative to the first character of each line.

To display the ruler, click the Ruler button, or select Ruler from the View menu.

Displaying Line Numbers
To display line numbers, click Line Number button, or select Line Number from the View menu.

Displaying the Markers
The Marker Bar shows the location of your bookmarks.

To display the markers, click Marker button, or select Marker from the View menu.

Displaying the Dates
The Date Bar normally displays the date on which a line was changed. However, the template can

be configured to place a user-specified change ID in this area instead. See Configuring an

Automatic Date or Change ID for details.

To display the line change dates, click Date button, or select Date from the View menu.

Displaying the Status Bar
The Status Bar shows either a color key for your text or the location of your cursor.

To display the Status Bar, select Status Bar from the View menu.

Displaying Bars
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Window Management

Tab Groups
ChangeMan Edit displays the files being edited as tabbed windows. Normally, the editor displays

one file at a time, and you use the tab to select which file is currently displayed.

You can display more than one file at a time by creating multiple tab groups. Each tab group has its

own set of tabs, and each group displays one file at a time. There are two types of tab groups:

Vertical tab groups: The windows are aligned side-by-side.

Horizontal tab groups: The windows are aligned with one above the other.

You can only use one type of tab group at a time. It is not possible to have a combination of both

vertical and horizontal tab groups.

The picture below illustrates a frame window with two vertical tab groups.

To create a new tab group using the following commands from the Window menu:

• • 

• • 
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New Vertical Tab Group (or Ctrl + G)

New Horizontal Tab Group (or Ctrl + Shift + G)

Use the following commands from the Window menu to move a file from one tab group to another:

Move to Next Tab Group (or Ctrl + M)

Move to Previous Tab Group (or Ctrl + Shift + M)

You can also move a window from one tab group to another by clicking on its tab and dragging it to

a different tab. A tab group is removed when you close the last file in that group or move the last

file to a different tab group.

You can even view the same file in two different tab groups at the same time. To accomplish that,

first use the New Window command to create a second window for the file. Then move one of the

windows to a different tab group. However, split windows, described in the next section, provide a

more flexible way to have multiple views of the same file.

Split Windows
Split windows, allow you to split an edit window into multiple panes. Each pane can be scrolled

separately and this allows you to view different parts of the file at the same time.

The window can be split vertically, horizontally, or both. Thus, the window is divided into either two

or four panes.

To create a split window, use the Split Window command from the Window menu, or Ctrl + T from

the keyboard. A cross-hair is then displayed, which you move to the location at which you want the

window to be split. You can move the cross-hair either by dragging it with the mouse or by using

the arrow keys on the keyboard. To set the cross-hair location, either release the mouse button, or

press enter.

If you set the cross-hair in the center of the window, the window will be split into four panes. To

split the window into only two panes, move the cross-hair over to one of the window edges.

The picture below illustrates the cross-hair used to set the size and position of the split windows.

• • 

• • 

• • 

• • 
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The window panes are divided by a splitter bar. You can resize the window panes by dragging the

splitter bar. To remove a window pane, just move the splitter bar all the way to the edge of the

window.

The picture below illustrates a window that has been split into four panes.

Split Windows
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Full Screen Mode
Full screen mode provides the largest possible view of your edit windows. Full screen mode

expands the ChangeMan Edit frame window to fill the entire screen. During full screen mode the

tool bars are hidden in order to increase the viewing area.

Full screen mode can be very useful when editing very large files or when the frame window is

divided by tab groups or split windows.

You can toggle back and forth between full screen mode and normal screen mode using either of

the following methods:

Full Screen command from the View menu.

Ctrl + Alt + Enter from the keyboard

• • 

• • 
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Customizing the Editor

ChangeMan Edit allows you to configure settings that change the appearance and control the

behavior of editing features.

There are two types of editor settings:

Global editor settings – apply to all languages

Language specific settings – apply only to a specific language

Language specific settings are specified using templates, and these are set using the Template

Manager. See the section entitled Saving a File for details on language specific options.

Global editor settings are set using the Customize dialog, which can be displayed from by selecting

Customize from the Tools menu.

Global Editor Settings
To open the global editor settings, select Customize from the Tools menu. The Customize dialog

box has an Editor tab for the global editor settings.

Any boxes that are checked in the Editor tab will apply to all languages. If the box is checked it will

override the language-specific option in the templates. If the box is not checked, the setting from

the template will be used. This provides a quick way to set an option globally without having to

change every template.

• • 

• • 
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For files on a z/OS server, it is important to use spaces rather than tab characters. Tab characters

are generally not recognized by z/OS software. Using tab characters can result in compiler errors,

JCL errors, etc.

Inserting a Change ID

You can automatically insert a user-specified change ID at a specified position into each line that

you change. The template you are using must be configured to use a change ID. See Configuring an

Automatic Date or Change ID for information on configuring the template for this.

If the template is configured to use a change ID, you can set the change ID at any time by choosing 

Set Change ID from the Tools menu. The dialog box below will display allowing you to set or

disable the change ID.

If the Insert change ID box is not checked, the change ID insertion will be disabled.

Option Description

Remove trailing

spaces

Trims trailing spaces from the end of each line when loading or

saving a file.

Tab using spaces Uses spaces, rather than tab characters to indent text. When saving

a file, tab characters are converted to spaces.

Allow cursor past

end of line

Allows the cursor to be positioned past the end of line. This makes

some editing operations easier to perform.
...

...
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Saving a File

ChangeMan Edit provides Save and Save As options for saving files.

When you change a file, a date tag appears in the Modification Date Bar next to the changed line,

indicating that the file has been modified. The modification date tag disappears when you save the

file, and reappears when you make new changes to the file.

Saving with the Original Name
To save a file using the original name, click Save (or choose Save from the File menu). ChangeMan

Edit checks the file for changes since it was last loaded or saved; if no changes are detected, the

Save command is disabled.

If you have more than one file opened for editing, you can save changes to all files by selecting the 

Save All command.

Saving with a Different Name
Use this procedure to save files with a different name:

Creating a New File

ChangeMan Edit lets you create a new file directly from the Edit module.

Use this procedure to create the file:

When you finish editing a new file, save it with the Save As command.

Step Action

1 Choose Save As from the File menu.

2 Navigate to the folder into which the file is to be saved.

3 Enter the new name of the file in the File name box.

4 Click Save.
...

Step Action

1 From ChangeMan Edit, click New Document (or choose New from the File

menu). ChangeMan Edit displays a list of all the configured editor templates.

2 Select a template, then click OK. ChangeMan Edit opens a blank code window.
...
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Submitting JCL

When you are editing a file containing JCL, you can submit the JCL to run as a job on a z/ OS

server. To submit the JCL, select File → Submit JCL from the menu.

Since all valid JCL begins with "//", the Submit JCL command is disabled unless the first line of the

file begins with "//".

You will then be prompted with the dialog box below, on which you select the name of the z/OS

server.

You do not need to save the JCL file before submitting it. The JCL will be submitted as it currently

appears in the edit window.

Jobs submitted with the Submit JCL command run under the authority of the logged on user (the

owner ID is the same as the logged on user ID). If you are not already logged on, you will be

automatically prompted to log on.

Notify Messages
You can receive notify messages when jobs submitted from ChangeMan ZDD complete.

Notify messages are written to the Notify message log. At any time, you can view the last 64

messages written to this log by launching the Notify message viewer application that is installed

with ChangeMan ZDD: choose Start → Programs → ChangeMan ZDD → Notify.

You can also choose to have a message box pop up every time you receive a message.

These options can be configured using the Notify page of the ZDD Network properties.,
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Submitting JCL 40



Submitting XML

When you are editing a file containing XML request for XML Services, you can submit the XML

request to a server or ChangeMan ZMF. To submit the XML, select File →Submit XML from the

menu.

Since all valid XML begins with "\<?xml", the Submit XML command is disabled unless the first line

of the file begins with "\<?xml".

You will then be prompted with the dialog box below, on which you select the name of the z/OS

server and ChangeMan instance.

If no ChangeMan instance is specified, the XML file will be submitted to the server, rather than a

ChangeMan instance. This is only valid for SerNet services and not for ChangeMan ZMF services.

ChangeMan ZMF services must be directed to a ChangeMan instance.

You do not need to save the XML file before submitting it. The XML will be submitted as it currently

appears in the edit window.

If you are not already logged on, you will be automatically prompted to log on.

On completion, the results will be displayed in another edit window. The results window will have a

name such as "Result01.xml". You can then save the results, if you wish to do so.

...
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6. Comparing/Merging Files Using
ChangeMan Diff

The ChangeMan Diff utility is included with ChangeMan ZDD and supports path names that exceed

259 characters in length if you are using Windows Vista or Windows 7.

Using the ChangeMan Diff utility, you can compare and merge:

Files on your local computer.

Files and ChangeMan ZMF components on your z/OS server.

You can initiate the Compare and Merge functions in the following ways:

Select files/components in the Explorer window, right-click, and choose ZDD Network | 

Compare Files or ZDD Network | Merge Files from the popup menu (described in this chapter).

Select ChangeMan ZMF components from the Staging Versions dialog box and click the 

Compare or Merge buttons.

Once you are within the ChangeMan Diff utility, you can alternate between comparing and merging

files, and initiate new compares/merges.

Comparing Files

You can compare the contents of two text-based files using the ChangeMan Diff utility. The

resulting differences are displayed side-by-side.

The following types of data can be compared:

Any text-based file on your local computer

Sequential data sets

Partitioned data set members

Unix files (text-based)

ChangeMan ZMF components (text-based)

JES spool data sets

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 

• • 
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Files of different types can be compared with each other. For example, you can compare:

A ChangeMan ZMF SRC component with a TXT file on your local computer.

Components in two different ChangeMan ZMF instances.

Initiating the Compare

Select one or two files to be compared. Right-click and choose ZDD Network -> Compare Files

from the popup menu. The Compare Files dialog box displays.

The files you selected display in the File 1 and File 2 text boxes. You can change the path

names in the text boxes or click the browse button to select different files.

The following options can be selected.

Click OK to invoke the ChangeMan Diff utility. The following dialog box displays a side-by-side

comparison.

Word documents cannot be compared using this utility.

Note

• • 

• • 

1. 1. 

2. 2. 

3. 3. 

Option Description

Ignore case Differences in case are ignored.

Ignore space

change

Space differences within a line are ignored.

Ignore blank lines Blank lines are ignored.

Ignore comments Comments are ignored. A comment is determined by the file

type.

4. 4. 

...
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The two large panes display the compared files.

The file names display on the title bars.

Line numbers display on the left side of each pane.

The text lines are highlighted in different colors to represent different types of changes. In the

previous example, the highlighted section of code in the right pane was added; the highlighted

section in the left pane was deleted. When you place the cursor in the text of a file, the type of

change is indicated in the legend at the bottom right side of the screen.

The Map area on the left side of the screen gives a micro view of each file. Arrows indicate the

cursor position in the files; colors indicate the areas with differences.

The order in which files are selected determines if lines are considered added or deleted. If you

select the files so that the newest file is File 2, then the added lines appear as added; otherwise,

they appear as deleted.

...

• • 

• • 

• • 
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Using Templates
Templates define the properties for the text display. You can change the template by choosing 

Tools -> Set Template.

You can modify templates and create new ones with the Template Manager: choose Tools ->  

Template Manager. The ChangeMan Diff Template Manager is identical to the ChangeMan Edit

Template Manager: see Saving a File on page 47 for details on how to configure templates.

Altering the Display Mode
Change the display mode by choosing options on the View menu:

This

option...

Does this...

Toolbars Lets you show or hide the toolbars.

Status Bar Lets you show or hide the status bar.

Split Lets you split the window using your mouse. The split can be altered by

dragging the edge of the split. To remove the split, drag the edge out of the

window.

Map Toggles the display of the map. The map is an micro-view of the file.

Changes are marked in.

Compare

Mode

Displays a two window view of the comparison files.

Single

Window

Displays a one window view of a comparison file.

Merge

Mode

Displays the merge mode view.

Diff Output Displays changes in a text-based report form.

Auto Align Select this option to scroll the text panes in synchronization; deselect to

scroll separately.
...

Using Templates

Using Templates 45



Changing Compare Options
Change the compare options to ignore items such as blank lines, extra spaces, and case by

choosing Tools → Options, or by clicking the appropriate button on the Diff Parameters tool bar.

Changing Text Background Colors
You can change the background colors displayed by the ChangeMan Diff utility by choosing Tools

→ Options. The one exception is: identical lines have a white background and cannot be changed.

Changing Compare Options
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The default colors are as follows:

This category… Indicates… Default

color…

Inserted lines Added lines. Yellow

Deleted Deleted lines. Red

Merged lines (Used in Merge Mode.) A line that is:

different in the two files being merged

merged without conflict

selected as final merge result Green

Virtual lines Placeholders. It means the other file contains a line

here that this file doesn’t.

Gray

Changed lines Changed lines. Blue

Inserted from

common file

Lines found in the common ancestor file. This

appears only if each of the three files has a different

change for a common line.

Red

Inserted from

1st file

New lines added from the first file. Yellow

Changing Text Background Colors
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Using Bookmarks
To add bookmarks to the file, see Bookmarks on page 38.

Redoing the Comparison
Redo the comparison by choosing File -> Compare.

Performing a Merge
You can perform a merge on the files being compared by choosing File -> Merge. You are

prompted to select an ancestor (baseline) file. After choosing the ancestor file, the display

changes to Merge Mode and you can now perform an interactive merge, described in Interactive

Merge.

Merging Files

Using the ChangeMan Diff utility, you can merge the contents of two file versions with a baseline

version and create a new merged version. You can merge any files that can be compared using

ChangeMan Diff.

This category… Indicates… Default

color…

Inserted from

2nd file

New lines added from the second file. Green

Overlapped

block

Block of text that appears in both documents. Blue

Merge

Unselected

Deselected lines. Gray

...
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Initiating the Merge
If you are already within the ChangeMan Diff utility, choose File -> Merge. Skip the rest of this

section and go to Interactive Merge .

Otherwise, you can initiate the Merge function in one of the following ways:

Select one or two files/components in the Explorer window, right-click and choose ZDD

Network -> Merge Files from the popup menu.

or

Select one or two files in the Staging Versions dialog box and click the Merge button

The Merge Files dialog box displays:

If you selected one file/component, its path name will display in the Base File text box.

If you selected two files/components, the path names will display in the Revision 1 and 

Revision 2 text boxes.

Output file contains the path name for the resulting merge file.

Enter the path names for all of the files. You can type in the text boxes or click the browse button to

select files from the Explorer directory tree.

You can reconcile differences between the file versions either automatically or interactively:

Select Automatic merge to have changes between the versions applied based on default rules.

Deselect Automatic merge to perform an interactive merge and choose which changes are

incorporated.

• • 

• • 

• • 

• • 

• • 

• • 

• • 
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Automatic Merge

The automatic merge reconciles the differences between two files according to a set of defined

rules. A merged file is created automatically when there are no conflicting changes.

In the case of inserted lines, ChangeMan Diff accepts all inserted lines from both revised files.

In the case of deleted lines, ChangeMan Diff omits all deleted lines from both files.

A message is not returned on successful completion - you can check the results in the Output

file.

If there are conflicting changes, such as an update to the same line, ChangeMan Diff displays in

Merge mode, where you can do an interactive merge and choose the changes to apply (described

in the following section).

Interactive Merge
The interactive merge lets you reconcile disparate changes in the two files by choosing added,

deleted, or changed lines from the two versions. Once you have reconciled the differences and go

to save the merged file, the file name will depend on the following:

If you initiated the merge from the Merge Files dialog box, the merged file is the file name you

specified in Output file.

If you initiated the merge from within ChangeMan Diff (by choosing File  Merge), you specify

the merged file name in the Save As dialog box.

When you initiate an interactive merge, the ChangeMan Diff utility displays the files in Merge mode.

In the following example, the Base File is on top, Revision 1 and Revision 2 are in the middle, and

the resulting merged Output File is on the bottom.

You can only perform an automatic merge from the Merge Files dialog box. 

Note

• • 

• • 

• • 

• • 

• • 
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The Map on the left hand side gives a micro view of each file, with arrows indicating the

current positioning of the file, and colors indicating positions of where differences occur. The

different columns correspond to the different files: the left-most column is for the First File,

the middle column is for the Second File, and the right column is for the Ancestor File. To

display (or hide) the Map, choose View -> Show Map (or choose View -> Hide Map).

The text background is color coded to indicate which lines came from which file. Place your

cursor in a file, and the Status Bar at the bottom will display the meaning of the colors for that

file. To display (or hide) the Status Bar, choose View -> Show Status Bar (or choose View -> 

Hide Status Bar). See "Changing Text Background Colors for explanation of the different

colors.

The other features of the display are the same as for the Compare function Comparing Files.

• • 

• • 

• • 
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Interactive Merge Actions
The following actions are available during the interactive merge.

Navigating Changes in the File
Step through the changes in a file by placing the cursor in the file, then clicking either Next Change

or Previous Change.

Accepting/Rejecting Inserted Lines
For inserted lines, right-click on the line and the choose either Unselect Block (reject) or Select

Block (accept).

Accepting/Rejecting Changed Lines
For changed lines, you can right-click and Accept Changes or Reject Changes, or you can choose

the change from a particular file by choosing Accept from First File, Accept from Second File, or 

Accept from Common Ancestor.

Editing Merge File
You can edit any part of the merge file by placing your cursor in the line, then overtyping.

You can also cut code from File 1, File 2, or the Common Ancestor and paste it into the merge file.

Saving and Exiting the Merge
After you have completed the merge, save the merge file by either choosing File -> Save or clicking 

Save on the toolbar.

To exit and discard changes to the merged file, click the close button and reply No to the prompt.

Redoing the Merge
To discard changes and redo the merge file, choose either File -> Merge or Merge on the toolbar.

Performing a Compare
To perform a comparison of the files (and discard changes to the merge file), choose either File -> 

Compare or Compare on the toolbar, then change to the comparison view by choosing View -> 

Compare Mode.

See Comparing File for more information.
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7. Template Manager

Each programming language has unique requirements for content editing, syntax highlighting, line

numbering, and formatting. To support these variations, ChangeMan Edit uses Template Manager,

which defines the settings required for each language.

Some standard templates for programming languages are provided that supply most common

options for each language. Furthermore, you can create custom templates.

The Template Manager is used by both ChangeMan Edit and ChangeMan Diff.

Selecting a Template

Whenever you open a file to edit or compare ChangeMan Edit or ChangeMan Diff assign a template

to that file. The template defines the characteristics of that file, and its display and edit settings.

Each template defines which file extensions it is used for. If the file name ends in an extension that

has a template defined for it, ChangeMan Edit or ChangeMan Diff will automatically assign the

correct template when the file is opened.

If the file name ends in an extension that has no template defined, or if there are multiple templates

defined for the file extension, then the dialog box below displays, allowing you to choose the

template to use.

7. Template Manager
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Opening the Template Manager

To open the Template Manager, click the Template Manager button (or choose Template Manager

from the Tools menu).

The following dialog box displays:

The Template Manager window is divided into two panes.

The left pane displays a list of available templates.

The right pane displays settings for the currently selected template.

The following procedures describe operations you can perform at the template level.

Creating a New Template
Use this procedure to create a new template:

• 

• 

Step Action

1 Open the Template Manager.

2 Click Add Template

The following dialog box displays:

Opening the Template Manager
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To simplify the process of creating a new template, you have the option of copying an existing

template to a new one.

Copying a Template
Use this procedure to copy a template:

Step Action

.

3 Enter a template name and description.

4 Click OK. A new blank template is created. You must go through all of the

options to define characteristics of this template.
...

Step Action

1 Open the Template Manager, then select the template to copy.

2 Click Copy Template.

The following dialog box displays:

3 Enter the name and description of the new template.

4 Click OK. ChangeMan ZDD creates a new template with all the characteristics

of the template you copied.
...
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Deleting a Template
Use this procedure to delete a template:

Defining Options for the Template
The right pane of the main Template Manager window contains the following tabs to define the

options for the selected template:

General

Syntax

Keywords

Advanced

Colors

General Options
The General tab provides information on loading, displaying, and saving options.

For the template selected in the left pane, a description and a set of pre-defined file types for that

template are presented.

You can configure the template specifications by selecting or clearing the following options:

Step Action

1 Open the Template Manager, then select the template to delete.

2 Click Remove Template.
...

• • 

• • 

• • 

• • 

• • 
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In addition, you can configure:

Number of spaces for each tab

Line length 

Display font

Syntax Options
The Syntax tab allows you to define a set of syntax options for the selected template, which

include non-keywords, quoted string support, and comment styles.

The Syntax tab contains the following options:

Select… To…

Remove

trailing

spaces when

saving

Delete spaces at the end of the line while saving the file.

Save tabs as

spaces

Insert a variable number of spaces to simulate tab position formatting. It

is necessary to convert tabs to spaces in certain applications, notably

when using compilers that do not support the tab character. For

example, ANSI COBOL doesn’t recognize tabs. ChangeMan Edit replaces

the tab with four spaces.
...

• • 

• • 

• • 
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Keyword Options
The Keywords tab lists the various types of keywords for the programming language. This screen

also provides an option to determine if the language is case sensitive.

The Keywords type pull-down menu shows four sets of template keywords:

Standard - keywords such as commands for the selected language.

Compiler - keywords such as compiler directives and calls.

User defined keywords.

Other - keywords such as function names.

Modifying a List of Keywords

Use this procedure to modify the list of keywords:

Input Field Description

Word delimiters Symbols that define the end of the word.

String Literal

Tokens

Symbols that define a string of characters.

Token exception To use literal tokens inside a string, enter the token exception.

Block comments Define the way you start and end the block comments.

Single line

comments

You can configure two methods of defining the start symbol and

position of the single line comments.
...

• • 

• • 

• • 

• • 
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Advanced Options
The Advanced tab allows you to define options for automatic line numbering or automatic

insertion of a date or change ID.

Configuring Auto Line Numbering
Use this procedure to configure automatic line numbering:

Step Action

1 Define the set of keywords to modify.

2 Click inside the list.

3 Add, delete, or edit words.

4 Click Apply to implement the changes.
...

...

Step Action

1 Select the Auto Line Numbering box.

2 Type (or select) a Start number value.

3 Type (or select) Increment and Digits values.

4 Click Apply.
...
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Configuring an Automatic Date or Change ID
Use this procedure to have an automatic date or change ID inserted into the specified columns.

When the file is open for editing, ChangeMan Edit displays the date or change ID in the Marker Bar

for the added and modified lines.

Color Options
The Colors tab allows you to customize the Code Window color scheme.

Step Action

1 Select the Auto Date or Change ID box.

2 Type (or select) a Field length value.

3 The Field position and Preceding chars fields are mutually exclusive. Specify the

field starting position in one of the following ways:

To start in a fixed column, type (or select) a value in the Field position field.

To start right after a specified character string, clear out the Field position field

and enter a character string in the Preceding chars field.

4 Do one of the following to select the "Change ID" or "Date" option:

Select the Use change ID option to have a change ID automatically inserted

when you make a change to a file that uses this template. When you open the

file, a dialog box displays, prompting you to enter a string of the length you

specified in Field length. As you edit the file, the string is automatically inserted

into the columns you specified.

Deselect the Use change ID option and the Date format field is enabled.

Click the >\< button to display a list of date/time variables; select one or more

variables. As you edit the file, the date/time is automatically inserted into the

columns you specified.

5 Click Apply.
...

Color Options

Color Options 60



You can choose custom background and foreground colors for the Code Window categories, or use

the Automatic option.

Changing Colors
Use this procedure to change the background or foreground colors:

Resetting Colors
Use this procedure to reset the colors back to the default colors:

If you are using the ChangeMan Diff utility, the Merge Colors override the syntax colors of the

Template Manager.

Note

Step Action

1 Select the category.

2 Click the Background or Foreground button.

3 Click the color from the palette.

4 Click Apply or OK and view the sample text.
...

Step Action

1 Select the category.

2 Click the Reset or Reset All button. Reset All will reset the colors for all

categories.
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Step Action

3 Click Apply or OK and view the new colors.
...
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8. Legal Notice

For information about legal notices, trademarks, disclaimers, warranties, export and other use

restrictions, U.S. Government rights, patent policy, and FIPS compliance, see https://

www.microfocus.com/en-us/legal.

© Copyright 2023 Micro Focus or one of its affiliates.

The only warranties for products and services of Micro Focus and its affiliates and licensors

("Micro Focus") are set forth in the express warranty statements accompanying such products and

services. Nothing herein should be construed as constituting an additional warranty. Micro Focus

shall not be liable for technical or editorial errors or omissions contained herein. The information

contained herein is subject to change without notice.

Third-Party Notices

Additional third-party notices, including copyrights and software license texts, can be found in a

'thirdpartynotices' file in the root directory of the software.

Specific notices

In accordance with the GNU General Public License version 2 with Classpath Exception, you are

entitled to the complete OpenJDK source code that went into the JRE used by this product which

includes the source code for 3 subclasses of that standard OpenJDK; MultipleGradientPaint,

MultipleGradientPaintContext and TypeResolver. Please contact product support if you wish to

obtain the source code. This source code will be available for 3 years from the general availability

date for version 17.0 SP1.
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