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COBOL Analyzer Release Notes - Version 10.0 
These release notes contain a summary of the major features of COBOL Analyzer Version 10.0, as well as 

late-breaking information about the product. 

Before using COBOL Analyzer, please read the Getting Started manual in the online help to gain an 

understanding of the user interface and tool metaphor. For more detail on the behavior, usage and 

limitations of COBOL Analyzer, please refer to the online help. 

What's New 

Enterprise Analyzer Product Enhancements 

PostgreSQL Automatic Install 

The PostgreSQL database replaces the SQL Server Express option in the product installer.  PostgreSQL is 

a free open-source database that does not have database size limits.  Now you can start analyzing large 

workspaces right away without needing to purchase a separate commercial database license.  

Source Synchronization Comparison 

Source Synchronization can now compare the content of the files you want to update in the workspace 

in addition to just looking at the timestamp. This requires an additional staging folder into which you 

download the files you wish to refresh in the workspace. CA will than compare the content of the files 

and only update the registration folder (the folder that was registered in CA) with those files which have 

different content than those registered. This is a longer process than just comparing time stamps, but it 

is more efficient in cases where all sources are always pulled from the source management system since 

it will result in a much smaller set that will actually have to be updated in the Workspace. If you are only 

getting updated sources from your source control system then you should not modify anything in your 

process. 

Project Specific Dialect Options for COBOL 

When a Workspace contains more than one COBOL dialect, the COBOL sources can be split into projects 

by dialect and the specific dialect can be set at the project level overriding the one set for the 

Workspace level. 

Count Source Lines Before Verification 

By default, the number of source lines in a file is not known in the repository until the files have been 

verified.  Now with a new feature in the admin tool the Source Lines metric can be captured for 

registered files of all types without needing to be verified. This may be useful in cases where you have a 

large set of sources and need to scope the size of the project quickly before taking the time for full 

analysis. Note: This will increase the registration time and should be used only in cases where you are 

not planning to immediately analyze the sources that you registered. 



Usability 

Orphan Analysis Enhancements 

Several enhancements were added to the Orphan Analysis tool including, assign to project functionality, 

the ability to tag objects, and a tooltip that shows the number of highlighted objects.  These additions 

should make the tool more useful for projects like migrations and modernization. 

Other Enhancements and Changes 

• The workspace export/import feature has been improved for tags and the state of projects. 

• Impact analysis support for tracking data flow through SQL views and tables has been added. 

• The Micro Focus compiler compatibility level option for the Micro Focus COBOL dialect has been 

updated to the latest level MFLEVEL"23". 

Licensing Changes 
• The SafeNet Sentinel licensing system that was available with previous releases of this product 

has been deprecated and is no longer available in release 10.0. This product also uses the Micro 

Focus AutoPass licensing technology which was introduced in release 8.0. Starting with release 

10.0, AutoPass is the only licensing technology available in this product. 

• The SafeNet Sentinel licenses are no longer supported, and you need to use AutoPass licenses 

starting with release 10.0. Contact your account manager to replace your existing SafeNet 

Sentinel with AutoPass licenses. 

Upgrades from Previous Versions 
Attention:  We recommend that when you move your workspaces to version 10.0, you use the Export / 

Import option after installing 10.0.  This will allow you to have a fresh environment analyzed with 10.0 

with all your user content applied from the older environment.  Once you are happy with the 10.0 setup, 

you can simply remove the older environment.  The export / import would be required for workspaces 

from older product versions that are not supported for automatic upgrades to 10.0, such as 7.0 or 

earlier.  For more information see the “Export and Import from the Workspace” topic in the product 

documentation. 

For workspaces from versions that do support automatic upgrades, the export / import feature can be 

useful to avoid potential issues like an error in the automatic upgrade process for the workspace.  And it 

would be recommended to use the export / import feature if reverfication of the sources are needed 

due to some enhancement or fix to the source code analysis. 

Important: When not using the recommended export / import from workspace feature, all workspaces 

must be upgraded after installing CA 10.0. Before upgrading, we recommend you contact Support for 

the latest COBOL Analyzer updates and best practices for workspace upgrades.  Before performing the 

upgrade on important workspaces, be sure to backup the database and the workspace folder along with 

the .rwp file. If you experience any issues or errors with the workspace upgrade process, please 



contact Support with a description of the problem and include the contents of the Upgrade folder 

from the workspace as an attachment. 

COBOL Analyzer 10.0 supports upgrades of workspaces directly from these versions: 

• 9.0 GA and any HotFix 

• 8.0 GA and any HotFix 

Important: Apache Tomcat needs to be upgraded to version to 9.0.71.  If you have an earlier version 

from a previous COBOL Analyzer install you should uninstall the old Apache Tomcat version and install 

the 9.0.71 version found with the CA installer files in the Packages\ApacheTomcat folder.  The Apache 

Tomcat version will not be upgraded automatically by the CA installer. 

Updating the CA Web Client 
After installing COBOL Analyzer 10.0, follow these steps to continue using the CA Web client.  If COBOL 

Analyzer was installed with the Install Web Client option, steps 1 through 6 below can be skipped. 

1. Open the Windows Service manager, stop the Apache Tomcat service. 

2. Delete CAWeb.war and the CAWeb folder from C:\Program Files (x86)\Apache 

Software Foundation\Tomcat\webapps. 

3. Delete everything in the ...\Tomcat\temp folder. 

4. Delete everything in the …\Tomcat\work\Catalina\localhost folder. 

5. Copy the CAWeb.war file from [CA install directory]\Web Client into the 

…\Tomcat\webapps folder. 

6. Start the Apache Tomcat service. 

7. Right-click the Micro Focus COBOL Analyzer Web Service, click Properties and then click the Log 

On tab. Check This account and type the account of a user with access to CA and its workspace 

and then click OK. 

8. Restart the Micro Focus COBOL Analyzer Web Service. 

Note: You might need to refresh the CA Web browser page, press Ctrl+R. 

Note: When using CA Web in Internet Explorer, the compatibility mode must be disabled. 

Updating the Eclipse Plugins 

Follow these steps after installing CA 10.0 to continue using the Clipper View and Search Assistant 

plugins in the Eclipse IDE. 

Note:  The Mylyn software for Eclipse is required to install the CA Eclipse plugins. 

1. On the CA server, open the Windows Service manager. 

2. Right-click Micro Focus COBOL Analyzer Web Service and then click Properties. 

This opens the Micro Focus COBOL Analyzer Web Service Properties dialog box. 



3. Click on the Log On tab and then click This account and type the account of a user with access to 

CA and its workspace. 

4. Restart Micro Focus COBOL Analyzer Web Service. 

5. Open Eclipse or Enterprise Developer on the client machine. 

6. Click Help > About Eclipse. 

This opens the About Eclipse dialog box. 

7. Click Installation Details. 

This opens the Eclipse Installation Details dialog box. 

8. Click COBOL Analyzer Access and then click Uninstall. 

9. In the Uninstall dialog box, click Finish and when prompted, restart Eclipse. 

10. When Enterprise Developer or Eclipse opens again, click Help > Install New Software. 

This opens the Install dialog box. 

11. Click Add next to the Work with list. 

This opens the Add Repository dialog box. 

12. Click Archive and navigate to the EAIntegration.repository-1.0.0.1.zip file 

located in [CA installed directory]\Bin. Add the archive to the File name field and 

click Open. 

13. In the Install window, check COBOL Analyzer Access. Click Next. 

14. Click Next again. 

15. Accept the license agreement and when prompted, restart Eclipse. 

Silent Install 
The following command can be used to perform a silent install of the product.  This command will 

execute the installation to the default location with the default selections of PostgreSQL install enabled, 

Install Web Client disabled, and the Administration tool enabled: 

 start COBOLAnalyzer10.exe ShowConfig=0 /s /v"/qn" 

The following command will install with the default options plus the Install Web Client will be enabled: 

 start COBOLAnalyzer10.exe TomcatCheckbox=1 ShowConfig=0 /s /v"/qn" 

The parameters to disable the default selections are PostgreSQLCheckbox=0 and CAAdminCheckbox=0.  

These are shown in the following command as an example of how to disable these default selections 

and can be used along with the TomcatCheckbox parameter: 

 start COBOLAnalyzer10.exe PostgreSQLCheckbox=0 CAAdminCheckbox=0 ShowConfig=0 

/s /v"/qn" 

The install location can be changed with the InstallFolder parameter.  The following command shows an 

example of using the InstallFolder parameter to install to any location: 

 start COBOLAnalyzer10.exe InstallFolder="D:\Install\Micro Focus\Enterprise 

Analyzer" ShowConfig=0 /s /v"/qn" 



Silent Uninstall 
The following command can be used to perform a silent install of the product: 

 start /wait COBOLAnalyzer10.exe /uninstall /quiet 

Important Notes 
• After installing CA version 10.0 with the Install Web Client option selected, if the Apache 

Tomcat service does not start automatically, it can be started from the Services application.  

There you can also set the Startup Type to Automatic if it is set to Manual. 

• When installing a new version of CA with the Install Web Client option checked over a previous 

version, newer versions of the Adopt OpenJDK JRE may be installed, and older versions will be 

left untouched by the CA installer.  For Apache Tomcat, if an older JRE version is present Tomcat 

will continue to use the older version of the JRE.  Note that the latest version of the JRE will 

always be used by default for verification of Java files in a workspace. 

• When using CA on Windows Server 2019 it may be necessary, depending on the security 

settings, to do one of the following in order to access a workspace local to that machine: 

o Before creating a workspace share the folder or a parent folder that will contain the 

.rwp file and workspace folder. 

o Before creating a workspace add security permissions for the user account to the folder 

where the workspace will be created. 

o Add security permissions for the user account to the workspace folder that is on the 

same level as the .rwp file. 

Updates and Support 
Our website gives up-to-date information on contact numbers and addresses. 

Contacting Support 
Micro Focus is committed to providing world-class technical support and consulting services. Micro 

Focus provides worldwide support, delivering timely, reliable service to ensure every customer's 

business success. 

All customers who are under a maintenance and support contract, as well as prospective customers who 

are evaluating products, are eligible for customer support. Our highly trained staff respond to your 

requests as quickly and professionally as possible. 

Contact Support to resolve your issues by emailing supportline@microfocus.com. 

Visit Support at https://www.microfocus.com/support for up-to-date support news and access to other 

support information. First time users may be required to register to the site. 



Information Needed by Support 
When contacting Support, please include the following information if possible. The more information 

you can give, the better Support can help you. 

• The name and version number of all products that you think might be causing an issue. 

• Your computer make and model. 

• System information such as operating system name and version, processors, and memory 

details. 

• Any detailed description of the issue, including steps to reproduce the issue. 

• Exact wording of any error messages involved. 

• Your serial number or works order (WO) number. 

To find out these numbers, look in the subject line and body of your Electronic Product Delivery 

Notice email that you received from Micro Focus. 

 

For reporting issues with CA please provide the following information: 

• The version and HotFix. 

• The database and database version used for the workspace. 

• Is the database local or remote? 

• Is the workspace folder local or remote? 

• Was the workspace upgraded to the currently used version and if so from what base version. 

• Runtime environment – AWS machine; Windows 10; etc. 

 

• Inventory report for the Workspace. 

• User type – master / non master. 

• Configuration screenshot. 

• Plug-in Information. 

• The .rwp file of the workspace. 

• PrereqCheckerApp.exe reports/logs. 

• Zip file of the workspace Options folder. 

• Legacy.xml from the install folder and from the workspace if there is one. 

Resolved Issues 

Application Module Support Case Defect Readme information 

Administration 2297104 264081 
You can now navigate to the new workspace path 
using the Folder browser control. 



Administration 2788287 652015 

Previously when opening workspace that does not 
match the current configuration from the 
Configuration Manager in the admin tool, an 
informational message was displayed to the user 
saying that the configurations of the installation and 
the workspace did not match and an upgrade of the 
workspace was recommended. 
This message will no longer be displayed to avoid 
confusion in a common scenario when opening a 
remote workspace with a configuration that does 
not match that of the workspace. 
No other behavior has been changed. The 
configuration of the workspace is always used even 
when the configuration of the installation of the 
remote machine did not match. 

Analysis  517015 

The options for setting the COBOL verification 
dialect can now be set at the project level. Click 
Options > Project Options. This opens the Options – 
Project properties dialog box. Click Verification > 
COBOL File. Under Dialect Specific Options click 
COBOL. This opens the Details dialog box. Check Use 
project specific dialects option to override the 
workspace options settings for the project. 

Analysis 2659171 543058 

An issue with impact tracing through SQL 
statements within an EXEC SQL block has been 
fixed. 

Analysis - Diagrammer 2667632 551005 
An exception that intermittently occurred when 
closing the Diagrammer has been fixed. 

Analysis - Diagrammer 2855026 684012 
You can now expand relationships for a selected 
group of objects in the entity diagram. 

Analysis - Diagrammer 2842106 675063 
BRM elements are now displayed correctly in the 
Diagrammer. 

Analysis - HyperView - Impact  645040 

The parameters for the ImpactReport.bj batch script 
have changed. You must now specify the absolute 
path to the program in the Name parameter. See 
ImpactReport.bj in your product Help for more 
information. 

Backend 2760107 639084 
The batch job script unregister.bj failed to process 
all entities. This has been fixed. 

Backend - Analysis - Cobol 2827760 674003 
Verification failed after an error occurred. This has 
been fixed. 

Backend - Analysis - Cobol - Advanced 2806933 662008 

Changed Generic API pattern matching to enable 
matches on data items containing undefined bytes 
in cases where the undefined bytes are not 
referenced in the pattern. 

Backend - Analysis - Cobol - Advanced 2867475 690045 

The VarPool maximum size for variable allocation 
has been increased, to enable operations on larger 
group data items. 

Backend - Parsing - Cobol 2839742 672063 
An SQL statement UNION would error. This has 
been fixed. 



Backend - Parsing - Cobol 2554351 439056 

Control characters (unprintable hexadecimal values; 
such as, Shift-In, Shift-Out, Start-Of-Text) in alpha 
numeric data types in COBOL sources are now 
replaced with their escape sequences instead of the 
period symbol. 

Backend - Parsing - Cobol 2721874 627045 
The Batch Refresh Process (BRP) failed to verify all 
CSD files. This has been fixed. 

Backend - Parsing - Cobol 2618738 515083 
Missing compiler directives have been added to the 
repository. 

Backend - Parsing - EmbeddedSQL 2698817 587008 

Oracle datetime expressions failed to parse in some 
contexts. This has been fixed. In addition, UNIQUE 
was added as a synonym for DISTINCT in SELECT 
statements. 

Backend - Verification 

2827760, 
2877892 684165 

In COBOL, multiline copy statements that contained 
a debug line indicator were not processed correctly. 
This has been fixed. 

Backend - Verification 2848022 684059 

Parsing anonymous blocks inside EXEC SQL 
statements would generate errors. This has been 
fixed. 

Backend - Verification 2800074 651100 

Verification of control card files containing tab 
characters could result in a crash. This has been 
fixed. 

Batch Refresh Process 2580055 510023 

The Batch Refresh Process (BRP) failed to complete 
when run from a scheduled task. This has been 
fixed. 

Batch Refresh Process 2577460 499040 

The reporting of errors in the log when running the 
Batch Refresh Process (BRP) or .bj scripts with 
Brave.exe has been improved. When using 
unsupported or incorrect parameters, scripts will 
now display the correct error. Crashes in most 
cases, will now display meaningful errors instead of 
generic message or an empty log file. 

Batch Refresh Process 2746906 632038 
An error message from TAG.bj was not explanatory. 
This has been fixed. 

Batch Refresh Process 2859420 684046 

If update errors are detected, they will be logged in 
the Batch Refresh Process (BRP) log, and the 
execution will stop. 

Business Rules 2836183 665190 
I/O data elements are now detected when 
generating rules using Autodetect. 

Business Rules 2837251 670070 
Rule import now overrides the attributes of the Rule 
Set. 

Business Rules 2858202 684028 

A paragraph, that was executed as a fall-through, 
was not generated as a rule set during rules 
autodetect. This has been fixed. 

Business Rules 2833262 672015 
All lines of statements will now be included in the 
technical description for rules from autodetect. 

Business Rules 2836153 669012 

I/O data elements were not being fully cleared from 
the database when a rule was deleted. This has 
been fixed. 

Common 2787310 647025 

Exporting source files from a workspace now 
exports the full path rather than just the path under 
the registered folder. To export files from the 



workspace click Workspace > Export Sources from 
Workspace. 

Common 2892973 689128 
The Object Information pane in the main window 
now displays the descriptions of system programs. 

Diagrammer 2848943 673095 
Conditions on relationships are now preserved 
when exporting and importing Diagrammer scopes. 

Diagrammer 2676701 614068 
Diagram files created by the product could not be 
opened. This has been fixed. 

Diagrammer 2669829 543126 
An error could occur when loading Interactive 
Analysis. This has been fixed. 

CAWeb 2670722 551017 
A non-triggering rule was displayed with a triggering 
rule icon in the Web client. This has been fixed. 

CAWeb 2678551 559008 

The source view in the Web client now uses the 
encoding settings from the user preferences of the 
user running the service. 

ED/VC Integration 2556264 446018 

Refactoring a COBOL component could result in the 
PROGRAM-ID being lost in the original program. This 
has been fixed. 

ED/VC Integration 363234 28048 
Code after an EXEC SQL INCLUDE statement was 
incorrectly marked as dead. This has been fixed. 

HyperView 2596335 494022 

Object information was incorrectly being retained in 
the database after component deletion. This has 
been fixed. 

HyperView - Callie 2642998 528113 
When opening the Program Control Flow, an error 
message was displayed. This has been fixed. 

HyperView - Code Animator 2854226 680030 The Animator now follows GOTO statements. 

HyperView - Impact 2643120 542057 
Impact analysis support for tracking data flow 
through SQL views and tables has been added. 

IDE  92025 

You can now rename your project, to perform this, 
click Project > Rename Project. This opens the 
Rename Project dialog box. Type the new project 
name and then click OK. 

IDE - Options 2792488 648041 
The Program Entry Point type is now always listed as 
a Decisions Type in the Boundary Decisions options. 

IDE - Project Operations 2777484 652082 
The Apply Boundary Decisions menu item will now 
operate on C/C++, .NET and VB files. 

IDE - Project Operations  656120 
Project attributes are now included when exporting 
or importing a workspace. 

IDE - Repository Browser 2809002 657103 
Repository queries would crash when chart viewer 
was disabled. This has been fixed. 

IDE - Repository Browser 2793337 652025 
In the Repository browser, right-clicking on a folder 
now displays the context menu. 

IDE - Workspace Operations 2856135 684065 

An index out of bounds error would occur when 
trying to load source modules into a workspace 
which contained a blank entry for one of the 
registration source file extensions. This has been 
fixed. 



IDE - Workspace Operations 2793339 653015 

An issue where using the Search > Find feature on 
the Repository Browser would search files multiple 
times if they belonged to multiple projects has been 
fixed. 

Plugins 2826055 665004 
An issue with a plugin not loading all queries 
correctly into a workspace has been fixed. 

Reports 2820972 662049 
The charts in Code Search reports have been 
changed to display only the selected report. 

Reports 2747208 632043 

For the Code Search Reports, the dialog button 
labels have changed from Yes and No to OK and 
Cancel respectively. In addition, if Cancel is clicked 
then the full report run will be cancelled. 

Reports - CRUD Report 2587588 508057 

Some files in the Create, Read, Update, and Delete 
(CRUD) report were displayed as empty when 
resolved through a decision. This has been fixed. 

Reports - Inventory 2800096 651097 

Opening Inventory Report when there are multiple 
projects for different users would result in an error. 
This has been fixed. 

Reports - Inventory 2821040 663044 

The line counts for control cards were not displayed 
in the Inventory Report after using the Calculate 
LOC feature from the administration tool. This has 
been fixed. 

Reports - Portability Assessment 2856223 684181 

A PostgreSQL error would occur when the 
Portability Assessment report was executed during 
the Batch Refresh Process (BRP). This has been 
fixed. 

Reports - Verification Report 2603374 504092 

If a Verification report for Oracle workspaces 
contained a count of more than 1000 in the Files 
Affected column then it could result in an error. This 
has been fixed. 

Upgrade 2734759 630060 

Importing an exported workspace would fail if it 
contained unassigned project options. This has been 
fixed. 

Upgrade 2836143 666231 
The start menu shortcut would not be displayed 
after installing. This has been fixed. 

Upgrade 2836136 667230 

More informative messages will now be given when 
the upgrade procedure fails due to a missing 
configuration file. 

Upgrade 2753952 639027 

An issue when using the Export / Import from 
Workspace feature in the admin tool that reported 
errors when importing an export file into a 
workspace that did not match the configuration of 
the exported workspace has been fixed. The issue 
was due to having Diagrammer scopes in the export 
file with relationships that did not exist in the 
import workspace. 

Copyright and Disclaimer 
Copyright © Micro Focus 2024 or one of its affiliates. 



The only warranties for this product and any associated updates or services are those that may be 

described in express warranty statements accompanying the product or in an applicable license 

agreement you have entered into. Nothing in this document should be construed as creating any 

warranty for a product, updates, or services. The information contained in this document is subject to 

change without notice and is provided "AS IS" without any express or implied warranties or conditions. 

Micro Focus shall not be liable for any technical or other errors or omissions in this document. Please 

see the product's applicable end user license agreement for details regarding the license terms and 

conditions, warranties, and limitations of liability. 

Any links to third-party websites take you outside Micro Focus websites, and Micro Focus has no control 

over and is not responsible for information on third party sites. 

Appendix I: COBOL Analyzer Features per Client 
The web client provides a subset of the features available in the Windows desktop application.  The 

table below shows the features that are available in each client. Note that this is not a full feature list for 

the desktop application. 

Capability Desktop Application Web Interface 

System Level Objects 

     Repository Browser Yes Yes 

     Search Assistant Yes Yes 

     Repository Queries Yes Yes 

     Reference Reports Yes No 

     Diagrammer (project) Yes No 

     Diagrammer (object) Yes Yes 

     CRUD Report (project) Yes No 

     CRUD Report (object based) Yes Yes 

     Complexity Metrics Yes Overview charts only 

Syntactical Analysis 

     Code Search Yes Yes, execute only 

     Source pane with navigation Yes Yes 

     Program Control Flow Yes No 

     Code Search Reports Yes Yes, execute only 

     Migration Reports Yes Yes, execute only 

     Quality Reports Yes Yes, execute only 

     Business Rules Yes, licensed separately Yes, view and edit only 

Advanced Analysis Options 

     Change Analyzer (full) Yes No 

     Change Analyzer (single data item) Yes Yes 

     Impact Analysis Yes Yes 

     Execution Path Analysis Yes No 

 

 


