
Print out a
printer wh

DevPart
Use the lin
DevPartne

More Inf
Refer to th
informatio

Commo
The DevPa

• DevPart
• DevPart
• DevPart
• Comma

Toolbar
r menu or toolbar in Visual Studio.

To solve 

Detect pro

Diagnose r

Locate perf

Ensure cod

Determine 
reduce mem

lbar item To
Perform run-time error detection using 
BoundsChecker technology 

Perform run-time code coverage analysis

age Analysis Perform run-time error detection with code 
coverage analysis

Execute run-time performance analysis 

Execute run-time memory analysis

Execute run-time analysis with Performance 
Expert

Perform static code analysis

es Access code review rules management

Access error detection rules management, 
used to filter or suppress detected errors

tion Perform compile-time instrumentation for: 
Error detection, Error detection with 
coverage, Performance or coverage analysis 

anager Access the Instrumentation Manager

Correlate performance or coverage files

Merge coverage analysis sessions

Access DevPartner options
Choices include: Analysis, Code review, 
Error Detection
ll or portions of this document and keep it handy for quick reference (use a color 
en available).

ner Features
ks in the left column in the following table to locate reference information about 
r features.

ormation
e DevPartner online help or to the Understanding DevPartner manual for more 
n.

n Elements
rtner software provides these common elements, regardless of feature.

ner Toolbar
ner Menu
ner File Extensions
nd Line Instrumentation Options

DevPartner Menu and 
Accessed from the DevPartne

this problem Use this DevPartner 
feature

gramming problems and naming inconsistencies Code Review

un-time errors in the source code Error Detection

ormance bottlenecks in the application Coverage, Memory, and 
Performance Analysis

e base stability throughout development and testing phases Coverage Analysis Session Data

memory allocation in an application and get feedback to 
ory consumption

Memory Analysis

Choose this menu or too
 Error detection

 Coverage Analysis

 Error detection and Cover

 Performance Analysis

 Memory Analysis

 Performance Expert

 Perform Code Review

 Manage Code Review Rul

Error Detection Rules

 Native C/C++ Instrumenta

Native C/C++ Instrumentation M

Correlate

Merge Coverage Files

 Options
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Common Elements

DevPartne
File extension

Command

NMCL Opt
The following
(native) C++ 
code with De
not used with
language run

Note All NMC
hyphen, follo

ectory containing these utilities to your path. For example, if 
e default directory, add the following directory to your path: 

s\Micro Focus\NMShared 

ions of Windows, add the following directory to your path:

n Files\Micro Focus\NMShared 

Run this D
Code review

Code coverag

Code coverag

Error detection

Memory analy

Performance a

Performance E

Use...
/NMbcpath:b

/NMclpath:cl-

/NMhelp or /?

/NMignore:so
/NMignore:so

Specify a log file for NMCL messages (default: stdout)

Ignore the CL /Gm (minimal rebuild) option if it appears on 
the command line. You can use this option to avoid a 
known conflict between the NMAKE /A and CL /Gm 
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual 
command-line options, each on a separate line.

Specify pass-through mode, which instructs NMCL to call 
CL without intervention. In this case, no instrumentation 
takes place.

Stop NMCL if an error occurs during instrumentation. If this 
option is not specified, the default behavior is to fall back to 
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the 
default setting.

Specifies instrumentation for performance and coverage 
analysis.

Instruments methods that are marked as inlineable if inline 
optimizations are enabled (using the /O1, /O2, /Ob1, or 
/Ob2 option)

Instruct DevPartner not to collect line information. When 
you use this option, DevPartner does not display any line 
data in the Source tab. You can also use this to improve the 
time required to instrument and run your application.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
r File Extensions
s for session files.

 Line Instrumentation Options

ions
 table lists the NMCL options that you can use to instrument your unmanaged 
code from the command line. Use NMCL.EXE only to compile unmanaged C++ 
vPartner performance and coverage or error detection instrumentation. NMCL is 
 managed code, which DevPartner instruments as it is passed to the common 
time during execution.

L options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL, add the dir
you installed the product into th

C:\Program Files\Common File

Note: For installs on 64-bit vers

C:\Program Files (x86)\Commo

evPartner feature To create this session file (extension)
.dpmdb

e .dpcov

e merge files .dpmrg

.dpbcl

sis .dpmem

nalysis .dpprf

xpert .dppxp

To...
c-path Specify the directory location of bcinterf.lib if you do not 

have the directory that contains NMCL on your path.

path Specify the directory location of cl.exe. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

Display help text

urce-file or 
urce-file:method source-file

Specify a source file or a method in a source file that should 
not be instrumented

/NMlog:log-file

/NMnogm

/NMonly:source-file

/NMopt:option-file or 
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn

/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

Use...
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Common Elements

NMLINK O
The following
code) C++ ap

Note: All NM
hyphen, follo

K, add the directory containing these utilities to your path. For 
duct into the default directory, add the following directory to 

s\Micro Focus\NMShared

ions of Windows, add the following directory to your path:

n Files\Micro Focus\NMShared 

Use...
/NMbcOn

/NMbcpath:b

/NMhelp or /?

/NMlinkpath:l

Specify pass-through mode, which instructs NMLINK to call 
LINK without intervention.

Specifies instrumentation for coverage and performance 
analysis.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
ptions
 table lists the NMLINK options that you can use to link your unmanaged (native 
plication to DevPartner.

LINK options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL and NMLIN
example, if you installed the pro
your path:

C:\Program Files\Common File

Note: For installs on 64-bit vers

C:\Program Files (x86)\Commo

To...
Use DevPartner Error Detection instrumentation. This is the 
default setting.

c-path Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

Display help text

ink-path Specify the directory location of LINK.EXE. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

/NMpass

/NMtxOn

/NMtxpath:tx-path

Use...
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Code Review

Code Rev

Command
Use the follow

Command
CRBatch.exe 

Used in CRExport

Command
Ctrl+A

Ctrl+C

Ctrl+N

Ctrl+O

Ctrl+P

Ctrl+V

F5

Switch
/f configuratio

/v or /verbose

/vs “11.0”, /v
“8.0”

ys this list of the available command line interface arguments.

 session file path and name — Identifies the session database to use 
. (Mandatory)

 export file path and name — Identifies the XML file to receive the 
. (Mandatory)

sion data — Exports all data for the specified session, including the 
thods for call graph data. Inbound methods are not exported.

sion data with inbound methods — Exports all data for the specified 
ing inbound and outbound methods for call graph data.

ms data — Exports the problems data for the specified session.

s data — Exports the metrics data for the specified session.

g analysis data — Exports the naming analysis data for the specified 

ize data — Exports the code size data for the specified session.

aph data — Exports the outbound, or called, methods in the call graph 
ecified session.

aph data with inbound methods — Exports the call graph data, 
und and outbound methods, for the specified session.
iew

 Shortcuts for Rule Manager
ing keyboard shortcuts to enter Rule Manager commands:

-line Switches Used in CRBatch
/<switch>

Command-line Switches 
CRExport.exe /<switch>

Action
Rule > Select All Rules

Rule > Copy Selected Rules

Rule > New Rule

File > Open Rule Set

File > Print

Rule > Paste Rules

View > Refresh

Function
n file/file name Informs CRBatch what configuration file 

to use when reviewing a solution or 
project
This switch is mandatory.

Instructs CRBatch to report errors in a 
message box, and to set the exit code 
used by batch procedures
Although this switch is optional, it is 
useful if you want to physically debug 
configuration files.

s “10.0”, /vs "9.0" or /vs Indicates the Visual Studio environment 
where the batch review will be 
executed; choices include 11.0 (Visual 
Studio 2012), 10.0 (Visual Studio 
2010), 9.0 (Visual Studio 2008) or 8.0 
(Visual Studio 2005).
This switch is recommended if you have 
more than one version of Visual Studio 
on your system. If you do not include 
this switch, DevPartner defaults to the 
latest version.

Switch Function
/? Help — Displa

/f sessionfile Fully-qualified
for this export

/e xml exportfile Fully-qualified
exported data

/a Export all ses
outbound me

/a i Export all ses
session, includ

/p Export proble

/m Export metric

/n Export namin
session.

/s Export code s

/c Export call gr
data for the sp

/c i Export call gr
including inbo
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Code Review

Code Revie

Naming G

Category
Projects to be

Rule set

Naming analy

Collect metric

Collect call gr

Always genera

Always save re

Prompt for ses

Description
What to analy

Choose dictio

All identifiers selected

Default

Create and modify rules used during code reviews
Perform a review of the solution code

Filter Current View

r of levels
tyle

Suppress Rule
w Default Options (General Node)

uidelines

Code Review Toolbars

Settings
 reviewed All projects selected (C# and VB.NET projects only)

All Rules

sis to use Naming Guidelines (see below)

s On

aph data On

te a batch file On

view results On

sion file name Off

Default
ze All public or protected identifiers

nary American English

Include naming analysis for

Company name

Technology name

Description

Mark Item Fixed

Numbe
Node s
Scaling
Layout

Print <current code review results>
Hide/Show Solution Tree
Hide/Show Description
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Code Review

Code Revie
w Summaries
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Code Review

Code Revie

tions and offers suggestions

Metrics pane — provides code complexity statistics

Call Graph pane — graphically shows method call tree
w Results Panes 

Problems pane — displays rule-based programming problems

Naming pane — lists .NET naming viola
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Coverage, Memory, and Performance Analysis

Coverage
Determine ap
application p

General an
The following

ons for Coverage, Memory, and Performance

Property
Automatically

Collect inform

Collect COM 

Exclude Othe

Instrument in

Instrumentat

Track System

Performance Analysis
Performance Expert

Memory Analysis

Set DevPartner Options

age Analysis Session Toolbars

View Call Graph

Find method in source code
, Memory, and Performance Analysis
plication test coverage, analyze an application’s use of memory, and profile 
erformance.

d Data Collection Properties
 data collection properties apply to performance, coverage, and memory analysis. 

DevPartner toolbar butt

Default setting
 Merge Session Files Ask me if I would like to merge it

ation about .NET assemblies True

Information True

rs True

line functions True

ion Level Line

 Objects True

Select analysis preference
Coverage Analysis

Error Detection with Coverage

Native C/C++ Instrumentation
Enable/disable instrumentation

Choose instrumentation type

Performance and Cover

Performance Session toolbar

Compare sessions

Coverage Session toolbar
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Coverage Analysis

Coverage

Coverage 

Filter the data

e sessions and record merge history

View statistics for sessions or 
merge file

verage analysis in Visual Studio or in the Coverage Analysis 
 in tabbed format, including the following tabs: 
 Analysis

Analysis Session Data

 view View coverage metrics for methods

View execution data for 
lines of source code 

Merge coverag

Results Summaries
DevPartner displays results for co
Viewer. Session files present data

• Method List 
• Source Code
• Merge History
• Session or Merge Summary



DevPartner Studio Quick Reference - 10

Memory Analysis

Memory 

Session Co

Start and Stop 
potential memo

ged 

tes to show 

to type of memory

ntrols:

n controls:

Memory Leaks 

ss list sort order
Analysis

ntrol for memory analysis

Tracking
ry leaks

Take a memory leaks 
snapshot

Force a garbage 
collection

Pause real-time graph (data
collection continues) Choose process to profile

Graph shows state of mana
heap in real time

Class list dynamically upda
what is in memory

In leak analysis, monitor Tracked instance 
count for objects that were not collected as 
expected

Session controls tailored 
data collection

RAM Footprint session co

Temporary Objects sessio

Clear temporary object allocations 
tracked to this point

session controls

Dynamically change the cla
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Memory Analysis

Memory A

Object distribu
system objects
(RAM footprin

Object Reference Graph
Trace object references back 
to the garbage collection roots 
that prevent objects from 
being collected. Answers the 
question: Why is this object 
still in memory?

 from any 
ode

Drill down sequentially from any 
object in the list to examine
referenced objects 

Drill down from any method in the 
list to examine allocated objects, 
and the objects they reference 

Results tailor

• RAM Foot
• Memory L
• Temporar
• Click Show
nalysis Session Data

tion: user vs. 
 

t only)

Summary of most 
memory-intensive object
allocations

Summary of most memory-intensive methods

Analyze object
allocations in depth

Call Graph
Analyze the calling sequence of methods that 
allocated memory. Answers the question: 
Who allocated all that memory? 

Jump to the allocating source line
method or object to edit source c

ed to type data collection

print
eaks
y Objects

 Complete Details to view session data
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Performance Analysis

Performa

Performan

Filter the data v

Compare session data to 
assess impact of code changes

erformance analysis in Visual Studio or in the Performance 
sent data in tabbed format, including the following tabs: 
nce Analysis

ce Analysis Session Data

iew 

View performance metrics for methods View session statistics
Locate methods in source code

Explore calling 
sequence of methods 
and identify critical path

Results Summaries
DevPartner displays results for p
Analysis Viewer. Session files pre

• Method List 
• Source Code
• Session Summary
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Performance Expert

Performa

Results Su
DevPartner d
tabbed forma

• Call Graph
• Call Tree
• Methods t
• Source co
• Call stacks

ion Controls

Clear data collected earlier in 
this session

Window shows last 30 sec-
onds of application activity. 
Spikes in the graph indicate 
potential trouble spots.

application code analyzed 
nce Expert

mmaries
isplays results for Performance Expert in session files. Session files present data in 
t, including the following tabs:

able
de

Performance Expert Sess

Take a data snapshot

Percentage of 
during session
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Performance Expert

Performan

Click individua
(without childre

b highlights critical 
nsive child methods

Source tab shows 
most expensive 
line for selected 
metric

Choose metric

Select a method to 
update source and call 
stack tabs

Icons indicate type of activity in method: disk, 
network, or lock wait time

Bars show time in 
method vs. time in 
child methods

Methods table 
shows impact of 
disk, network I/O, 
and wait time

Select m
ce Expert Session Data

l method for Methods analysis 
n)

Call Graph ta
path and expe

Call Tree tab shows impact of 
disk, network I/O, and wait time

Click entry point method for Path analysis 
(with children)

ethod in stack to locate Double-click a line in a source display to edit in 
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Using DPAnalysis.exe

Using DP
Use DPAnalys
Performance 
switches or a

Command
Use this synta
the comman

DPAnalysis

DPAnalysis.ex

The following

Category
[a] Analysis T

{b} Data Colle

Specify the session file output directory and/or filename

ir] - Specify working directory for the process or service

ecify the target’s host machine

Do not wait for the process to exit, just wait for it to start

G - Set this switch to true to suppress UI error messages. The
lse.

le] - Run the process in its own command window

rces profiling for coverage or performance of applications written 
naged code or CTI.

TUM - Disables excluding time spent on other threads

OD_GRANULARITY - Sets data collection granularity to method-level 
 default)

SYSTEM_DLLS - Excludes data collection for system dlls (performance 
)

_INLINING - Enable run-time instrumentation of inline methods 
nd performance analysis only)

OKS- Disable collection of COM

_SYSTEM_OBJECTS - Track system object allocation (memory analysis 

rget that follows as either a process or service. Pick only one. All 
that follow the target name/path are considered arguments to the target

pecify a target process (followed by arguments to process)

pecify a target service (followed by arguments to service)

ath to configuration file
Analysis.exe
is.exe to run coverage analysis, memory analysis, performance analysis, or 
Expert sessions from the command line. DPAnalysis.exe accepts command line 
n XML configuration file.

 Line Operations
x to run coverage, memory, performance, or Performance Expert sessions from 

d line:

.exe [a] {b} {c} {d} [e] target {target args}

e requires Analysis Type and Target Type switches. Other switches are optional.

 table lists the switches used with DPAnalysis.exe:

Switches
ype /Cov[erage] - Sets analysis type to DevPartner coverage analysis

/Mem[ory] - Sets analysis type to DevPartner memory analysis

/Perf[ormance] - Sets analysis type to DevPartner performance analysis

/Exp[ert] - Sets analysis type to DevPartner Performance Expert

ction /E[nable] - Enables data collection for the specified process or service

/D[isable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use 
the /D switch to disable profiling.

{c} Other Options /O[utput] - 

/W[orkingD

/H[ost] - Sp

/NOWAIT - 

/NO_UI_MS
default is fa

/N[ewconso

/F[orce] - Fo
without ma

{d} Analysis Options /NO_QUAN

/NM_METH
(line-level is

/EXCLUDE_
analysis only

/NM_ALLOW
(coverage a

/NO_OLEHO

/NM_TRACK
only)

[e] Target Type Identifies ta
statements 

/P[ocess] - S

/S[ervice] - S

/C[onfig] - P

Category Switches
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Using DPAnalysis.exe

Configura
Use this synta
through a co

DPAnalysis.ex

The following
Understandin

Element
AnalysisOptio

Arguments

ExcludeImage

 each Process or Service, zero or one. No default if omitted. Sets the host 
e target process or service. No attributes.

for each service. Provides the name of the service as registered with the 
l manager. This is the same name you would use for the system's NET 
nd. No attributes.

for each process. Specify a fully qualified or relative path to the 
u can specify the executable name without the path if the executable 
rrent directory. No attributes.

tion file must contain at least one Process or one Service element. 
et executable.

lectData, Spawn, NoWaitForCompletion, NewConsole 

 only. Defines the type of analysis and maximum session time.

tion file must contain at least one Process or one Service element. 
et service.

lectData, Start, RestartIfRunning, RestartAtEndOfRun

 only. Begins a block of one or more Process or Service entries. Target 
 services are started in the order they are listed in the configuration file.
InParallel
tion File
x to run coverage, memory, performance, or Performance Expert sessions 

nfiguration file: 

e /config c:\temp\config.xml

 table briefly describes the XML elements. See the DevPartner online help or the 
g DevPartner manual for more information.

Description
ns (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 

specified target process or service. Attributes correspond to DevPartner properties 
accessible from the Properties Window in Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the 
specified target process or service. Attributes correspond to DevPartner Coverage, 
Memory and Performance Analysis properties accessible from the Properties Window in 
Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

s (Optional) For each Process or Service, zero or one. No default if omitted. Defines 
images (at least one, no maximum) which, if loaded by the target process or service, 
will not be profiled. No attributes.

Host (Optional) For
machine of th

Name One required 
service contro
START comma

Path One required 
executable. Yo
exists in the cu

Process The configura
Specifies a targ
Attributes: Col

RuntimeAnalysis Required; one

Service The configura
Specifies a targ
Attributes: Col

Targets Required. One
processes and
Attributes: Run

Element Description
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Error Detection

Error Det

File Extens

Default Op
or Setting

Extension
.dpbcl

.dpbcc

.dpbcd

.dpsup

.dpflt

.dprul

Category
General

Data Collectio

Enable API call reporting. All selections are unavailable until you select this 
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On

All modules (tree view). - Default when active: All selected 

Enable call validation. All selections unavailable until you select this item

Enable memory block checking - Default when active: Off

Fill output arguments before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active: 
On

API failure codes - Default when active: On

Check invalid parameter errors: API, COM - Default when active: both On

Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when 
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default 
when active: All items selected

Enable COM method call reporting on objects that are implemented in 
the selected modules

Report COM method calls on objects implemented outside of the listed 
modules - Default when active: On

All components tree view - Default when active: All selected 

Enable COM object tracking

Refresh from Registry - Default when active: (Enabled)

All COM classes tree view - Default when active: All selected

Enable deadlock analysis

Assume single process - Default when active: On

Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when 
active: Off

Generate errors when: A wait is requested on an owned mutex - Default 
when active: Off

Settings
ection

ions Used by Error Detection

tions (DevPartner Studio Professional and Enterprise Editions) 
s (Visual C++ BoundsChecker Suite)

File Type Description
Error Detection Session File This is the Error Detection log for the user's program 

execution.

Error Detection Settings File This file contains the various settings for Error 
Detection. The .dpbcd extension refers to the default 
settings file created, while .dpbcc refers to a custom 
settings file that has been saved separately.

Error Detection Suppressions File This file contains the various suppressions for the user's 
program.

Error Detection Filters File This file contains the various filters for the user's 
program.

Error Detection Rules File This is a database of the user's suppressions and filters.

Settings
On Log events

On Display error and pause

Off Prompt to save program results

Off Show memory and resource viewer when application exits

On Source file search path - based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

- Override symbol path - Default: empty

- Working directory (standalone only) based on the location of the .EXE 

- Command line arguments (standalone only) - Default: empty

n On Call parameter coding depth = 1

Off Use raw stack capture method

On Maximum call stack depth on allocation = 5

On Maximum call stack depth on error = 20

On NLB file directory is based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

API Call Reporting Off

-

-

-

-

Call Validation Off

-

-

-

-

-

-

-

-

-

COM Call Reporting Off

-

-

COM Object Tracking Off

-

Deadlock Analysis Off

-

-

-

-

Category
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Error Detection

in Visual Studio
Deadlock Ana
(continued)

Memory Track

.NET Analysis

.NET Call Rep

Resource Trac

Category

Set DevPartner Options

Start with Error Detection
Start with Coverage Analysis
Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis
Note: The arrows next to each button allow you to start with or without 
debugging, depending on the default action of the button.
Error Detection Toolbar 
lysis - Number of historical events per resource - Default when active: 10

- Report synchronization API timeouts - Default when active: Off

- Report wait limits or actual waits exceeding (seconds) - Default when 
active: 60

- Synchronization Naming Rules - Default when active: Don’t warn about 
resource naming

ing On Enable memory tracking

Off Enable Leak Analysis Only

Off Show leaked allocator blocks

On Enable FinalCheck

On Enforce strict reallocation semantics

On Enable guard bytes; Pattern: (0x) = FC; Count = 4 bytes

- Check heap blocks at runtime: On free

On Enable fill on allocation; Pattern: (0x) = FB

On Check uninitialized memory; Size = 2 bytes

On Enable poison on free; Pattern: (0x) = FD

Off Enable .NET analysis

- Exception monitoring - Default when active: On 

- Finalizer monitoring - Default when active: On

- COM interop monitoring - Default when active: On

- PInvoke interop monitoring - Default when active: On

- Interop reporting threshold - Default when active: 1

orting Off Enable .NET method call reporting

- All types (tree view node) - Default when active: Selected.

- .NET User Assemblies (tree view node) - Default when active: Selected

- .NET System Assemblies (tree view node) - Default when active: Not 
selected

king On Enable resource tracking

On Resources tree view. All listed resources are selected by default

Settings

Native C/C++ Instrumentation
Enable/disable instrumentation
Choose instrumentation type
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Error Detection

Error Dete  Pane

 Pane

Re
Su
Pe
ove

So

Dis
det

Appears in...
Summary, Memory Leaks, and Transcript tabs

Summary, Other Leaks, and Transcript tabs

Summary, Errors, and Transcript tabs

Summary, .NET Performance tabs

Summary, Modules, and Transcript tabs

Transcript tab

Event Transcript tab

Transcript tab

Transcript tab

Transcript tab

r data types

pes
ction Window Icons Used in the Results

Icons Used in the Details

Details Pane
Displays long description of detected 
error; call stack information; reference 
count graph (see inset below).

sults Pane
mmary, Memory Leaks, Other Leaks, Errors, .NET 
rformance, Modules, Transcript tabs provide 
rview and detail about detected errors.

urce Pane

plays source code for the 
ected error, if available.

Details Pane - Reference Count Graph
Displays Reference Count View and Object Identity 
View tabs when you select an Interface Leak in the 
Results pane.

Icon Description
Memory Leaks

Other Leaks

Errors

.NET Performance

Module Load Event

Subroutine call

Garbage Collection 

Event Begins

Event Resumes

Event Ends

Icon Description
Subroutine call

Entry Parameters

Exit Parameters

Return Value

Property (default) fo

Property for data ty
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Error Detection

Reference

Program E

ewer Dialog Box

Horizo
Horizo

Error de

Memory Contents Pane
e, and Summary tabs

e 

Stack Pane

Mark and Close
Click to mark existing allocations and close the 
dialog box. Marked items will not be shown when 
Memory and Resource viewer reappears. 
 Count Graph Toolbar

rror Detected Dialog Box

Memory and Resource Vi

Scale to Size
Select Viewing Area

Vertical Zoom Out
Vertical Zoom In 

ntal Zoom Out
ntal Zoom In

scription

Call stack information Source code for the detected error

Tabs for multiple call stacks

Results Pane
Displays Memory, Resourc

Source Pane
Displays source code for th
detected error, if available.
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Error Detection

ActiveChe

ActiveChe
ActiveCheck™
well as the dy
your program
detection.

 Instrumentation - Deepest Error Detection
umentation (CTI) enables Error Detection to find more errors 
ata corruption errors, and so on) as they occur in real time. 

errors, plus all errors found with ActiveCheck.

Deadlock-r
Deadlock

Potential dead

Thread deadlo

Critical section

Semaphore er

Resource usag

Suspicious or 

Handle errors

Event errors

Mutex errors

Windows even

.NET Errors
Finalizer errors

GC.Suppress f

Dispose attrib

Unhandled na
code

y block

Pointer and Leak Errors
Array index out of range

Assigning pointer out of range

Expression uses dangling pointer

Expression uses unrelated pointers

Function pointer is not a function

Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free

Memory leaked due to reassignment

Memory leaked leaving scope

Returning pointer to local variable
ck and FinalCheck Error Detection

ck
 analyzes your program and searches for errors in your program executable as 

namic-link libraries (DLLs), third-party modules, and COM components used by 
. The following tables list the types of errors found with ActiveCheck error 

FinalCheck Compile Time
FinalCheck™ compile time instr
(memory leaks, pointer errors, d
FinalCheck finds these types of 

elated Errors API and COM Errors
COM interface method failure

lock Invalid argument

cked Parameter range error

 errors Questionable use of thread

rors Windows function failed

e and naming errors Windows function not implemented

questionable resource usage Invalid COM interface method argument

t errors

Pointer and Leak Errors
Interface leak

inalize not called Memory leak

utes errors Resource leak

tive exception passed to managed 

Memory Errors
Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memor

Stack memory overrun

Static memory overrun

Memory Errors
Reading overflows buffer

Reading uninitialized memory

Writing overflows buffer
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Export DevPartner Data: Command Line Use

List of Ava ta: Command Line Use
.DataExport.exe from the command line to convert DevPartner 
rage analysis merge (.dpmrg), performance analysis (.dpprf), 

p) session file data to XML.

 data to XML:
ort.exe [sessionfilename|pathtodirectory] {options}

mand line options for DevPartner.Analysis.DataExport.exe.

on, or a space to separate an option from the value or values 

Command
Ctrl+Shift+O

Ctrl+Shift+N

Ctrl+S

Ctrl+Shift+S

Ctrl+Shift+F

Ctrl+Shift+H

Alt+F12

Ctrl+Alt+L

Ctrl+Shift+C

Ctrl+Alt+S

Ctrl+Shift+E

F4

Ctrl+Alt+X

Shift+Alt+Ente

Shift+F4

Ctrl+Shift+B

F5

Ctrl+F5

Ctrl+Alt+E

F11

F10

Ctrl+B

Ctrl+F1

Ctrl+Alt+F1

Ctrl+Alt+F2

Ctrl+Alt+F3

Shift+Alt+F2

Shift+Alt+F3

Description
Specify the local or remote output directory for exported XML files. 
Creates the directory if the directory does not exist

Search subdirectories for DevPartner Session Files. 

Specify the name of the XML output file. Appends .xml to the name 
specified.

Shows all performance and coverage session file data available in a 
performance or coverage session file.
For example, if you export a performance session file with this option, 
the resulting XML file contains both performance and coverage data 
fields.
This option is not available for Performance Expert session files. 

Wait for input before closing console window. 

Do not display the logo or copyright notice. 

Display help in the console window. 

Export Performance Expert summary data which includes a default 
maximum of the top ten callpaths and the top ten methods that use the 
most CPU resources. Use the /maxpaths and /maxmethods options to 
override the maximums.

Exports Performance Expert method data.

Export Performance Expert call tree data.

Used only with the Performance Expert /summary option. Exports the 
specified number of the top call paths that use the most CPU resources.

Used only with the Performance Expert /summary option. Exports the 
specified number of the top methods that use the most CPU resources.
ilable Keyboard Commands - Visual Studio Export DevPartner Da
You can use DevPartner.Analysis
coverage analysis (.dpcov), cove
and Performance Expert (.dppx

Use this syntax to export session
DevPartner.Analysis.DataExp

Options
The following table lists the com

You can use an equal sign, a col
you specify. 

Action
File > Open > Project

File > New > Project

File > Save Project

File > Save All

Edit > Find in Files

Edit > Replace in Files

Edit > Find Symbol

View > Solution Explorer

View > Class View

View > Server Explorer

View > Resource View

View > Properties Window

View > Toolbox

r View > Full Screen

View > Property Pages

Build > Build Solution

Debug > Start

Debug > Start Without Debugging

Debug > Exceptions

Debug > Step Into

Debug > Step Over

Debug > New Breakpoint

Help > Dynamic Help*

Help > Contents*

Help > Index*

Help > Search*

Help > Index results*

Help > Search results*

* Visual Studio 2005, 2008

Switch
/out[put]=<String>

/r[ecurse]

/f[ilename]=<String>

/showAll

/w[ait]

/nologo

/help or /? 

/summary

/method

/calltree

/maxpaths=<integer>

/maxmethods=<integer>



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Error
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /CMYK
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments true
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000410064006f006200650020005000440046002065876863900275284e8e9ad88d2891cf76845370524d53705237300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef69069752865bc9ad854c18cea76845370524d5370523786557406300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <FEFF9ad854c18cea306a30d730ea30d730ec30b951fa529b7528002000410064006f0062006500200050004400460020658766f8306e4f5c6210306b4f7f75283057307e305930023053306e8a2d5b9a30674f5c62103055308c305f0020005000440046002030d530a130a430eb306f3001004100630072006f0062006100740020304a30883073002000410064006f00620065002000520065006100640065007200200035002e003000204ee5964d3067958b304f30533068304c3067304d307e305930023053306e8a2d5b9a306b306f30d530a930f330c8306e57cb30818fbc307f304c5fc59808306730593002>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020ace0d488c9c80020c2dcd5d80020c778c1c4c5d00020ac00c7a50020c801d569d55c002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken die zijn geoptimaliseerd voor prepress-afdrukken van hoge kwaliteit. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents best suited for high-quality prepress printing.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /ConvertToCMYK
      /DestinationProfileName ()
      /DestinationProfileSelector /DocumentCMYK
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure false
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles false
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /DocumentCMYK
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /UseDocumentProfile
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


