
Print out a
printer wh

DevPart
Use the lin
DevPartne

More Inf
Refer to th
informatio

Commo
The DevPa

• DevPart
• DevPart
• DevPart
• Comma

Toolbar
r menu or toolbar in Visual Studio..

To solve 

Diagnose r

Locate perf

Ensure cod

lbar item To
Perform run-time error detection using 
BoundsChecker technology 

Perform run-time code coverage analysis

age Analysis Perform run-time error detection with code 
coverage analysis

Execute run-time performance analysis 

Access error detection rules management, 
used to filter or suppress detected errors

tion Perform compile-time instrumentation for: 
Error detection, Error detection with 
coverage, performance or coverage analysis 

anager Access the Instrumentation Manager

Correlate performance or coverage files

Merge coverage analysis sessions

Access DevPartner options
Choices include: Analysis, Code review, 
Error detection
ll or portions of this document and keep it handy for quick reference (use a color 
en available).

ner Features
ks in the left column in the following table to locate reference information about 
r features.

ormation
e DevPartner online help or to the Understanding DevPartner manual for more 
n.

n Elements
rtner software provides these common elements, regardless of feature.

ner Toolbar
ner Menu
ner File Extensions
nd Line Instrumentation Options

DevPartner Menu and 
Accessed from the DevPartne

this problem Use this DevPartner 
feature

un-time errors in the source code Error Detection

ormance bottlenecks in the application Coverage and Performance 
Analysis

e base stability throughout development and testing phases Coverage Analysis Session Data

Choose this menu or too
 Error detection

 Coverage Analysis

 Error detection and Cover

 Performance Analysis

Error Detection Rules

 Native C/C++ Instrumenta

Native C/C++ Instrumentation M

Correlate

Merge Coverage Files

 Options
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Common Elements

DevPartne
File extension

Command

NMCL Opt
The following
(native) C++ 
code with De
not used with
guage runtim

Note All NMC
hyphen, follo

ectory containing these utilities to your path. For example, if 
e default directory, add the following directory to your path: 

s\Micro Focus\NMShared 

ions of Windows, add the following directory to your path:

n Files\Micro Focus\NMShared 

Running th
Code coverag

Code coverag

Error detection

Performance a

Use...
/NMbcpath:b

/NMclpath:cl-

/NMhelp or /?

/NMignore:so
/NMignore:so

/NMlog:log-fi

/NMnogm

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual 
command-line options, each on a separate line)

Specify pass-through mode, which instructs NMCL to call 
CL without intervention. In this case, no instrumentation 
takes place.

Stop NMCL if an error occurs during instrumentation. If this 
option is not specified, the default behavior is to fall back to 
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the 
default setting.

Specifies instrumentation for performance and coverage 
analysis.

Instruments methods that are marked as inlineable if inline 
optimizations are enabled (using the /O1, /O2, /Ob1, or 
/Ob2 option)

Instruct DevPartner not to collect line information. When 
you use this option, DevPartner does not display any line 
data in the Source tab. You can also use this to improve the 
time required to instrument and run your application.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
r File Extensions
s for session files.

 Line Instrumentation Options

ions
 table lists the NMCL options that you can use to instrument your unmanaged 
code from the command line. Use NMCL.EXE only to compile unmanaged C++ 
vPartner performance and coverage or error detection instrumentation. NMCL is 
 managed code, which DevPartner instruments as it is passed to the common lan-
e during execution.

L options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL, add the dir
you installed the product into th

C:\Program Files\Common File

Note: For installs on 64-bit vers

C:\Program Files (x86)\Commo

is DevPartner feature Creates this session file (extension)
e .dpcov

e merge files .dpmrg

.dpbcl

nalysis .dpprf

To...
c-path Specify the directory location of bcinterf.lib if you do not 

have the directory that contains NMCL on your path.

path Specify the directory location of cl.exe. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

Display help text

urce-file or 
urce-file:method source-file

Specify a source file or a method in a source file that should 
not be instrumented

le Specify a log file for NMCL messages (default: stdout)

Ignore the CL /Gm (minimal rebuild) option if it appears on 
the command line. You can use this option to avoid a 
known conflict between the NMAKE /A and CL /Gm 
options.

/NMonly:source-file

/NMopt:option-file or 
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn

/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

Use...
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Common Elements

NMLINK O
The following
code) C++ ap

Note: All NM
hyphen, follo

K, add the directory containing these utilities to your path. For 
duct into the default directory, add the following directory to 

s\Micro Focus\NMShared

ions of Windows, add the following directory to your path:

n Files\Micro Focus\NMShared 

Use...
/NMbcOn

/NMbcpath:b

/NMhelp or /?

/NMlinkpath:l

Specify pass-through mode, which instructs NMLINK to call 
LINK without intervention.

Specifies instrumentation for performance and coverage 
analysis.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
ptions
 table lists the NMLINK options that you can use to link your unmanaged (native 
plication to DevPartner.

LINK options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL and NMLIN
example, if you installed the pro
your path:

C:\Program Files\Common File

Note: For installs on 64-bit vers

C:\Program Files (x86)\Commo

To...
Use DevPartner Error Detection instrumentation. This is the 
default setting.

c-path Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

Display help text

ink-path Specify the directory location of LINK.EXE. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

/NMpass

/NMtxOn

/NMtxpath:tx-path

Use...
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Coverage and Performance Analysis

Coverage
Determine ap

General an
The following

ons for Coverage and Performance

Property
Automatically

Collect inform

Collect COM 

Exclude Othe

Instrument in

Instrumentat

Track System

Performance Analysis

Set DevPartner Options

age Analysis Session Toolbars

View Call Graph

Find method in source code

Choose instrumentation type
 and Performance Analysis
plication test coverage and profile application performance.

d Data Collection Properties
 data collection properties apply to coverage and performance analysis. 

DevPartner toolbar butt

Default setting
 Merge Session Files Ask me if I would like to merge it

ation about .NET assemblies True

Information True

rs True

line functions True

ion Level Line

 Objects True

Select analysis preference
Coverage Analysis

Error Detection with Coverage

Native C/C++ Instrumentation
Enable/disable instrumentation

Performance and Cover

Performance Session toolbar

Compare sessions

Coverage Session toolbar
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Coverage Analysis

Coverage

Coverage 

Filter the data

e sessions and record merge history

View statistics for sessions or 
merge file

r coverage analysis in Visual Studio or in the Coverage Analysis 
ata in tabbed format, including the following tabs:

y

 Analysis

Analysis Session Data

 view View coverage metrics for methods

View execution data for 
lines of source code 

Merge coverag

Results Summaries
DevPartner displays results fo
Viewer. Session files present d

• Method List
• Source Code
• Merge History
• Session or Merge Summar
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Performance Analysis

Performa

Performan

Filter the data v

Compare session data to 
assess impact of code changes

performance analysis in Visual Studio or in the Performance 
esent data in tabbed format, including the following tabs:
nce Analysis

ce Analysis Session Data

iew 

View performance metrics for methods View session statistics
Locate methods in source code

Explore calling 
sequence of methods 
and identify critical path

Results Summaries
DevPartner displays results for 
Analysis Viewer. Session files pr

• Method List
• Source Code
• Session Summary
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Using DPAnalysis.exe

Using DP
Use DPAnalys
DPAnalysis.ex

Command
Use this synta

DPAnalysis

DPAnalysis.ex
optional.

The following

Category
[a] Analysis T

{b} Data Colle

Specify the session file output directory and/or filename

ir] - Specify working directory for the process or service

ecify the target’s host machine

Do not wait for the process to exit, just wait for it to start

G - Set this switch to true to suppress UI error messages. The
lse.

le] - Run the process in its own command window

rces profiling for coverage or performance of applications written 
naged code or CTI.

TUM - Disables excluding time spent on other threads

OD_GRANULARITY - Sets data collection granularity to method-level 
 default)

SYSTEM_DLLS - Excludes data collection for system dlls (performance 
)

_INLINING - Enable run-time instrumentation of inline methods 
nd performance analysis only)

OKS- Disable collection of COM

_SYSTEM_OBJECTS - Track system object allocation (memory analysis 

rget that follows as either a process or service. Pick only one. All 
that follow the target name/path are considered arguments to the target

pecify a target process (followed by arguments to process)

pecify a target service (followed by arguments to service)

ath to configuration file
Analysis.exe
is.exe to run coverage or performance analysis sessions from the command line. 
e accepts command line switches or an XML configuration file.

 Line Operations
x to run coverage or performance sessions from the command line:

.exe [a] {b} {c} {d} [e] target {target args}

e requires Analysis Type and Target Type switches. Use of other switches is 

 table lists the switches used with DPAnalysis.exe:

Switches
ype /Cov[erage] - Sets analysis type to DevPartner coverage analysis

/Perf[ormance] - Sets analysis type to DevPartner performance analysis

ction /E[nable] - Enables data collection for the specified process or service

/D[isable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use 
the /D switch to disable profiling.

{c} Other Options /O[utput] - 

/W[orkingD

/H[ost] - Sp

/NOWAIT - 

/NO_UI_MS
default is fa

/N[ewconso

/F[orce] - Fo
without ma

{d} Analysis Options /NO_QUAN

/NM_METH
(line-level is

/EXCLUDE_
analysis only

/NM_ALLOW
(coverage a

/NO_OLEHO

/NM_TRACK
only)

[e] Target Type Identifies ta
statements 

/P[ocess] - S

/S[ervice] - S

/C[onfig] - P

Category Switches
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Using DPAnalysis.exe

Configura
Use this synta

DPAnalysis.ex

The following
Understandin

Element
AnalysisOptio

Arguments

ExcludeImage

 each Process or Service, zero or one. No default if omitted. Sets the host 
e target process or service. No attributes.

for each service. Provides the name of the service as registered with the 
l manager. This is the same name you would use for the system's NET 
nd. No attributes.

for each process. Specify a fully qualified or relative path to the 
u can specify the executable name without the path if the executable 
rrent directory. No attributes.

tion file must contain at least one Process or one Service element. 
et executable.

lectData, Spawn, NoWaitForCompletion, NewConsole 

 only. Defines the type of analysis and maximum session time.

tion file must contain at least one Process or one Service element. 
et service.

lectData, Start, RestartIfRunning, RestartAtEndOfRun

 only. Begins a block of one or more Process or Service entries. Target 
 services are started in the order they are listed in the configuration file.
InParallel
tion File
x to run coverage or performance analysis sessions through a configuration file: 

e /config c:\temp\config.xml

 table briefly describes the XML elements. See the DevPartner online help or the 
g DevPartner manual for more information.

Description
ns (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 

specified target process or service. Attributes correspond to DevPartner properties 
accessible from the Properties Window in Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the 
specified target process or service. Attributes correspond to DevPartner Coverage, 
Memory and Performance Analysis properties accessible from the Properties Window in 
Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

s (Optional) For each Process or Service, zero or one. No default if omitted. Defines 
images (at least one, no maximum) which, if loaded by the target process or service, 
will not be profiled. No attributes.

Host (Optional) For
machine of th

Name One required 
service contro
START comma

Path One required 
executable. Yo
exists in the cu

Process The configura
Specifies a targ
Attributes: Col

RuntimeAnalysis Required; one

Service The configura
Specifies a targ
Attributes: Col

Targets Required. One
processes and
Attributes: Run

Element Description
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Error Detection

Error Det

File Extens

Default Op
or Setting

Extension
.dpbcl

.dpbcc

.dpbcd

.dpsup

.dpflt

.dprul

Category
General

Data Collectio

Enable API call reporting. All selections are unavailable until you select this 
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On

All modules (tree view). - Default when active: All selected 

Enable call validation. All selections unavailable until you select this item

Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active: 
On

API failure codes - Default when active: On

Check invalid parameter errors: API, COM - Default when active: both On

Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when 
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default 
when active: All items selected

Enable COM method call reporting on objects that are implemented in 
the selected modules

Report COM method calls on objects implemented outside of the listed 
modules - Default when active: On

All components tree view - Default when active: All selected 

Enable COM object tracking

All COM classes tree view - Default when active: All selected

Enable deadlock analysis

Assume single process - Default when active: On

Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when 
active: Off

Generate errors when: A wait is requested on an owned mutex - Default 
when active: Off

Settings
ection

ions Used by Error Detection

tions (DevPartner Studio Professional and Enterprise Editions) 
s (Visual C++ BoundsChecker Suite)

File Type Description
Error Detection Session File This is the Error Detection log for the user's program 

execution.

Error Detection Settings File This file contains the various settings for Error 
Detection. The .dpbcd extension refers to the default 
settings file created, while .dpbcc refers to a custom 
settings file that has been saved separately.

Error Detection Suppressions File This file contains the various suppressions for the user's 
program.

Error Detection Filters File This file contains the various filters for the user's 
program.

Error Detection Rules File This is a database of the user's suppressions and filters.

Settings
On Log events

On Display error and pause

Off Prompt to save program results

Off Show memory and resource viewer when application exits

On Source file search path - based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

- Override symbol path (standalone only) - Default: empty

- Working directory (standalone only) based on the location of the .EXE 

- Command line arguments (standalone only) - Default: empty

n On Call parameter coding depth = 1

Off Use raw stack capture method

On Maximum call stack depth on allocation = 5

On Maximum call stack depth on error = 20

On NLB file directory is based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

API Call Reporting Off

-

-

-

-

Call Validation Off

-

-

-

-

-

-

-

-

-

COM Call Reporting Off

-

-

COM Object Tracking Off

-

Deadlock Analysis Off

-

-

-

-

Category
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Error Detection

in Visual Studio
Deadlock Ana
(continued)

Memory Track

.NET Analysis

.NET Call Rep

Resource Trac

Category

Set DevPartner Options

Start with Error Detection
Start with Coverage Analysis
Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis
Note: The arrows next to each button allow you to start with or without 
debugging, depending on the default action of the button.
Error Detection Toolbar 
lysis - Number of historical events per resource - Default when active: 10

- Report synchronization API timeouts - Default when active: Off

- Report wait limits or actual waits exceeding (seconds) - Default when 
active: 60

- Synchronization Naming Rules - Default when active: Don’t warn about 
resource naming

ing On Enable memory tracking

Off Enable Leak Analysis Only

Off Show leaked allocation blocks

On Enforce strict reallocation semantics

On Enable FinalCheck

On Enable guard bytes; Pattern: (0x) = FC; Count = 4 bytes

- Check heap blocks at runtime: On free

On Enable fill on allocation; Pattern: (0x) = FB

On Check uninitialized memory; Size = 2 bytes

On Enable poison on free; Pattern: (0x) = FD

Off Enable .NET analysis

- Exception monitoring - Default when active: On 

- Finalizer monitoring - Default when active: On

- COM interop monitoring - Default when active: On

- PInvoke interop monitoring - Default when active: On

- Interop reporting threshold - Default when active: 1

orting Off Enable .NET method call reporting

- All types (tree view node) - Default when active: Selected.

- .NET User Assemblies (tree view node) - Default when active: Selected

- .NET System Assemblies (tree view node) - Default when active: Not 
selected

king On Enable resource tracking

On Resources tree view. All listed resources are selected by default

Settings

Native C/C++ Instrumentation
Enable/disable instrumentation
Choose instrumentation type
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Error Detection

Error Dete  Pane

 Pane

Re
Su
Pe
ove

So

Dis
det

Appears in...
Summary, Memory Leaks, and Transcript tabs

Summary, Other Leaks, and Transcript tabs

Summary, Errors, and Transcript tabs

Summary, .NET Performance tabs

Summary, Modules, and Transcript tabs

Transcript tab

Event Transcript tab

Transcript tab

Transcript tab

Transcript tab

r data types

pes
ction Window Icons Used in the Results

Icons Used in the Details

Details Pane
Displays long description of detected 
error; call stack information; reference 
count graph (see inset below).

sults Pane
mmary, Memory Leaks, Other Leaks, Errors, .NET 
rformance, Modules, Transcript tabs provide 
rview and detail about detected errors.

urce Pane

plays source code for the 
ected error, if available.

Details Pane - Reference Count Graph
Displays Reference Count View and Object Identity 
View tabs when you select an Interface Leak in the 
Results pane.

Icon Description
Memory Leaks

Other Leaks

Errors

.NET Performance

Module Load Event

Subroutine call

Garbage Collection 

Event Begins

Event Resumes

Event Ends

Icon Description
Subroutine call

Entry Parameters

Exit Parameters

Return Value

Property (default) fo

Property for data ty
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Error Detection

Reference

Program E

ewer Dialog Box

Horizo
Horizo

Error de

Memory Contents Pane
e, and Summary tabs

e 

Stack Pane

Mark and Close
Click to mark existing allocations and close the 
dialog box. Marked items will not be shown when 
Memory and Resource viewer reappears. 
 Count Graph Toolbar

rror Detected Dialog Box

Memory and Resource Vi

Scale to Size
Select Viewing Area

Vertical Zoom Out
Vertical Zoom In 

ntal Zoom Out
ntal Zoom In

scription

Call stack information Source code for the detected error

Tabs for multiple call stacks

Results Pane
Displays Memory, Resourc

Source Pane
Displays source code for th
detected error, if available.
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Error Detection

ActiveChe

ActiveChe
ActiveCheck™
well as the dy
your program
detection.

 Instrumentation - Deepest Error Detection
umentation (CTI) enables Error Detection to find more errors 
ata corruption errors, and so on) as they occur in real time. 

errors, plus all errors found with ActiveCheck.

Deadlock-r
Deadlock

Potential dead

Thread deadlo

Critical section

Semaphore er

Resource usag

Suspicious or 

Handle errors

Event errors

Mutex errors

Windows even

.NET Errors
Finalizer errors

GC.Suppress f

Dispose attrib

Unhandled na
code

y block

Pointer and Leak Errors
Array index out of range

Assigning pointer out of range

Expression uses dangling pointer

Expression uses unrelated pointers

Function pointer is not a function

Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free

Memory leaked due to reassignment

Memory leaked leaving scope

Returning pointer to local variable
ck and FinalCheck Error Detection

ck
 analyzes your program and searches for errors in your program executable as 

namic-link libraries (DLLs), third-party modules, and COM components used by 
. The following tables list the types of errors found with ActiveCheck error 

FinalCheck Compile Time
FinalCheck™ compile time instr
(memory leaks, pointer errors, d
FinalCheck finds these types of 

elated Errors API and COM Errors
COM interface method failure

lock Invalid argument

cked Parameter range error

 errors Questionable use of thread

rors Windows function failed

e and naming errors Windows function not implemented

questionable resource usage Invalid COM interface method argument

t errors

Pointer and Leak Errors
Interface leak

inalize not called Memory leak

utes errors Resource leak

tive exception passed to managed 

Memory Errors
Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memor

Stack memory overrun

Static memory overrun

Memory Errors
Reading overflows buffer

Reading uninitialized memory

Writing overflows buffer
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Export DevPartner Data: Command Line Use

List of Ava ta: Command Line Use
.DataExport.exe from the command line to convert DevPartner 
rage analysis merge (.dpmrg), and performance analysis 
. 

 data to XML:
ort.exe [sessionfilename|pathtodirectory] {options}

mand line options for DevPartner.Analysis.DataExport.exe.

on, or a space to separate an option from the value or values 

Command
Ctrl+Shift+O

Ctrl+Shift+N

Ctrl+S

Ctrl+Shift+S

Ctrl+Shift+F

Ctrl+Shift+H

Alt+F12

Ctrl+Alt+L

Ctrl+Shift+C

Ctrl+Alt+S

Ctrl+Shift+E

F4

Ctrl+Alt+X

Shift+Alt+Ente

Shift+F4

Ctrl+Shift+B

F5

Ctrl+F5

Ctrl+Alt+E

F11

F10

Ctrl+B

Ctrl+F1

Ctrl+Alt+F1

Ctrl+Alt+F2

Ctrl+Alt+F3

Shift+Alt+F2

Shift+Alt+F3

escription
ecify the output directory for exported XML files. Creates the directory 

the directory does not exist.

arch subdirectories for DevPartner session files. 

ecify the name of the XML output file. Appends .xml to the name 
ecified.

ows all performance and coverage session file data available in a 
rformance or coverage session file.
r example, if you export a performance session file with this option, 
e resulting XML file contains both performance and coverage data 
lds.

ait for input before closing console window. 

o not display the logo or copyright notice. 

isplay help in the console window. 
ilable Keyboard Commands - Visual Studio Export DevPartner Da
You can use DevPartner.Analysis
coverage analysis (.dpcov), cove
(.dpprf) session file data to XML

Use this syntax to export session
DevPartner.Analysis.DataExp

Options
The following table lists the com

You can use an equal sign, a col
you specify. 

Action
File > Open > Project

File > New > Project

File > Save Project

File > Save All

Edit > Find in Files

Edit > Replace in Files

Edit > Find Symbol

View > Solution Explorer

View > Class View

View > Server Explorer

View > Resource View

View > Properties Window

View > Toolbox

r View > Full Screen

View > Property Pages

Build > Build Solution

Debug > Start

Debug > Start Without Debugging

Debug > Exceptions

Debug > Step Into

Debug > Step Over

Debug > New Breakpoint

Help > Dynamic Help*

Help > Contents*

Help > Index*

Help > Search*

Help > Index results*

Help > Search results*

* Visual Studio 2005, 2008

Switch D
/out[put]=<String> Sp

if 

/r[ecurse] Se

/f[ilename]=<String> Sp
sp

/showAll Sh
pe
Fo
th
fie

/w[ait] W

/nologo D

/help or /? D
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