
Print 
printe

Dev
Use th
DevP

Mor
Use th
ner St

Com
The D

• De
• De
• De
• Co

r
l Studio toolbar.

l Studio Tools menu.

To s

Detec

Diagn

Locat

Ensur

Deter
reduc

Shortcut function for
Run-time error detection using BoundsChecker technology

Run-time code coverage analysis 

Run-time error detection with code coverage analysis 

Run-time performance analysis

Run-time memory analysis 

Run-time analysis with Performance Expert

Perform a review of the solution code

Create and modify rules used during code reviews

Compile-time instrumentation for error detection, coverage analysis, 
both error detection and coverage analysis, performance analysis 

DevPartner options for
Analysis, Code review, Error detection

em To
Perform run-time error detection using 
BoundsChecker technology 

Perform run-time code coverage analysis
out all or portions of this document and keep it handy for quick reference (use a color 
r when available).

Partner Features
e links in the left column in the following table to locate reference information about 

artner features.

e Information
e DevPartner online help to obtain “how to” information. See the Understanding DevPart-

udio manual for an overview of the DevPartner software.

mon Elements
evPartner software provides these common elements, regardless of feature.

vPartner Toolbar
vPartner Menu
vPartner File Extensions
mmand Line Instrumentation Options

DevPartner Toolba
Accessed from the Visua

DevPartner Menu
Accessed from the Visua

olve this problem Use this DevPartner 
feature

t programming problems and naming inconsistencies Code Review

ose run-time errors in the source code Error Detection

e performance bottlenecks in the application Coverage, Memory, and 
Performance Analysis

e code base stability throughout development and testing phases Coverage Analysis Session Data

mine memory allocation in an application and get feedback to 
e memory consumption

Memory Analysis

Toolbar button

 

 

 

 

 

 

 

 

 

 

Choose this menu it
 Error detection

 Coverage Analysis
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Common Elements

De
File

strumentation Options

ts the NMCL options that you can use to instrument your unmanaged 
de from the command line. Use NMCL.EXE only to compile unmanaged 
DevPartner error detection instrumentation. NMCL is not used with man-
vPartner instruments as it is passed to the common language runtime as it 

ns must begin with a forward slash (shown in the following list) or 
the letters NM. For example: /NMoption or –NMoption.

Err

Na

Co

M

N
in

Ru
Co

Co

Co

Ch
.dpbcl

.dpmem

.dpprf

.dppxp

To...
Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

Specify the directory location of cl.exe. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

Display help text

r 
ethod source-file

Specify a source file or a method in a source file that should 
not be instrumented

Specify a log file for NMCL messages (default: stdout)

Ignore the CL /Gm (minimal rebuild) option if it appears on 
the command line. You can use this option to avoid a 
known conflict between the NMAKE /A and CL /Gm 
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual 
command-line options, each on a separate line)

Specify pass-through mode, which instructs NMCL to call 
CL without intervention. In this case, no instrumentation 
takes place.

er feature To create this session file (extension)
vPartner File Extensions
 extensions for session files.

Command Line In

NMCL Options
The following table lis
(native) Visual C++ co
Visual C++ code with 
aged code, which De
executes.

Note All NMCL optio
hyphen, followed by 

 Error detection and Coverage Analysis Perform run-time error detection with code 
coverage analysis

 Performance Analysis Execute run-time performance analysis 

 Memory Analysis Execute run-time memory analysis

 Performance Expert Execute run-time analysis with Performance 
Expert

 Perform Code Review Perform static code analysis

 Manage Code Review Rules Access code review rules management

or Detection Rules Access error detection rules management, 
used to filter or suppress detected errors

 Native C/C++ Instrumentation Perform compile-time instrumentation for: 
Error detection, Coverage analysis, Error 
detection and coverage analysis , 
Performance analysis 

tive C/C++ Instrumentation Manager Access the Instrumentation Manager

rrelate Correlate performance or coverage files

erge Coverage Files Merge coverage analysis sessions

 Submit TrackRecord defect

Submit TrackRecord defect
See Note

ote: The Submit TrackRecord defect toolbar button is only available when TrackRecord is 
stalled.

 Options Access DevPartner options
Choices include: Analysis, Code review, 
Error detection

n this DevPartner feature To create this session file (extension)
de review .dpmdb

de coverage .dpcov

de coverage merge files .dpmrg

oose this menu item To
Error detection

Memory analysis

Performance analysis

Performance Expert

Use...
/NMbcpath:bc-path

/NMclpath:cl-path

/NMhelp or /?

/NMignore:source-file o
/NMignore:source-file:m

/NMlog:log-file

/NMnogm

/NMonly:source-file

/NMopt:option-file or 
/NM@option-file

/NMpass

Run this DevPartn
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Common Elements

No
ple
pat

C:\

ts the NMLINK options that you can use to link your unmanaged (native 
lication to DevPartner.

tions must begin with a forward slash (shown in the following list) or 
the letters NM. For example: /NMoption or –NMoption.

CL and NMLINK, add the directory containing these utilities to your 
you installed the product into the default directory, add the following 
:

mon Files\Compuware\NMShared

/N

/N

/N

/N

/N

/N

Us

To...
Use DevPartner Error Detection instrumentation. This is the 
default setting.

Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

Display help text

Specify the directory location of LINK.EXE. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

Specify pass-through mode, which instructs NMLINK to call 
LINK without intervention.

Specifies instrumentation for performance and coverage 
analysis.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.
te: When using NMCL, add the directory containing these utilities to your path. For exam-
, if you installed the product into the default directory, add the following directory to your 
h: 

Program Files\Common Files\Compuware\NMShared 

NMLINK Options
The following table lis
code) Visual C++ app

Note: All NMLINK op
hyphen, followed by 

Note: When using NM
path. For example, if 
directory to your path

C:\Program Files\Com

Mstoponerror Stop NMCL if an error occurs during instrumentation. If this 
option is not specified, the default behavior is to fall back to 
a standard CL compile.

MbcOn Use DevPartner Error Detection instrumentation. This is the 
default setting.

MtxOn Specifies instrumentation for performance and coverage 
analysis.

MtxInlines Instruments methods that are marked as inlineable if inline 
optimizations are enabled (using the /O1, /O2, /Ob1, or 
/Ob2 option)

MtxNoLines Instruct DevPartner not to collect line information. When 
you use this option, DevPartner does not display any line 
data in the Source tab. You can also use this to improve the 
time required to instrument and run your application.

Mtxpath:tx-path Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

e... To...

Use...
/NMbcOn

/NMbcpath:bc-path

/NMhelp or /?

/NMlinkpath:link-path

/NMpass

/NMtxOn

/NMtxpath:tx-path
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Code Review

Co

Co
Use

Co
CR

ault Options (General Node)

lbar

Co
Ct

Ct

Ct

Ct

Ct

Ct

F5

Sw
/f 

/v

/v

Settings
All projects selected (Visual C++ .NET projects do not apply)

All Rules

On

Off

Off

re a build Off

 file On

lts On

ame Off

Filter Current View

Suppress Rule

eview results>

how Solution Tree

ide/Show Description Mark Item Fixed

Create and modify rules used during code reviews

Perform a review of the solution code
de Review

mmand Shortcuts for Rule Manager
 the following keyboard shortcuts to enter Rule Manager commands:

mmand-line Switches Used in CRBatch
Batch /<switch>

Code Review Def

Code Review Too

mmand Action
rl+A Rule > Select All Rules

rl+C Rule > Copy Selected Rules

rl+N Rule > New Rule

rl+O File > Open Rule Set

rl+P File > Print

rl+V Rule > Paste Rules

View > Refresh

itch Function
configuration file/file name Informs CRBatch what configuration file 

to use when reviewing a solution or 
project
This switch is mandatory.

 or /verbose Instructs CRBatch to report errors in a 
message box, and to set the exit code 
used by batch procedures
Although this switch is optional, it is 
useful if you want to physically debug 
configuration files.

s "7.1" or /vs “8.0” Indicates the Visual Studio environment 
where the batch review will be 
executed; choices include 7.1 or 8.0.
It is recommended that you use this 
switch, most importantly if you have 
more than one version of Visual Studio 
on your system. If you do not include 
this switch, DevPartner will default to 
the latest version.

Category
Projects to be reviewed

Rule set

Naming analysis

Metrics analysis

Ignore compile errors

Exclude rules that requi

Always generate a batch

Always save review resu

Prompt for session file n

Print <current code r

Hide/S

H
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Code Review

Co
de Review Summaries
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Code Review

Co

 naming violations and offers suggestions

Metrics pane — provides code complexity statistics

Call Graph pane — graphically shows method call tree
de Review Results Panes 

Problems pane — displays rule-based programming problems

Naming pane — lists .NET
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Coverage, Memory, and Performance Analysis

Co
De
cat

Ge
Th
ana

ar buttons for Coverage, Memory, and Performance

Pr
Au

Co

Co

Ex

In

In

Tr

e

erage

Performance Analysis

Performance Expert

Memory

ation

tation

ype

Set DevPartner Options

d Coverage Analysis Session Toolbars

oolbar
View Call Graph

Find method in source code

ar
verage, Memory, and Performance Analysis
termine application test coverage, analyze an application’s use of memory, and profile appli-
ion performance.

neral and Data Collection Properties
e following data collection properties apply to Performance, Coverage, and Memory 
lysis. 

DevPartner toolb

operty Default setting
tomatically Merge Session Files Ask me if I would like to merge it

llect information about .NET assemblies True

llect COM Information True

clude Others True

strument inline functions True

strumentation Level Line

ack System Objects True

Select analysis preferenc

Coverage 

Error Detection with Cov

Native C/C++ Instrument

Enable/disable instrumen

Choose instrumentation t

Performance an

Performance Session t

Compare sessions

Coverage Session toolb
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Coverage Analysis

Co

Co

F

rge coverage sessions and record merge history

View statistics for sessions or merge file

es
sults for Coverage Analysis in session files. Session files present data in 
ing the following tabs: 

ummary
verage Analysis

verage Analysis Session Data

ilter the data view View coverage metrics for methods

View execution data for 
lines of source code 

Me

Results Summari
DevPartner displays re
tabbed format, includ

• Method List 
• Source Code
• Merge History
• Session or Merge S
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Memory Analysis

M

Se

Sta
tia

 to profile

tate of managed 
e

ically updates to show 
ry

rols tailored to type of memory data col-

nt session controls:

Objects session controls:

Me
emory Analysis

ssion Control for memory analysis

rt and Stop Tracking poten-
l memory leaks

Take a memory leaks 
snapshot

Force a garbage 
collection

Pause real-time graph (data col-
lection continues)

Choose process

Graph shows s
heap in real tim

Class list dynam
what is in memo

In leak analysis, monitor Tracked instance 
count for objects that were not collected as 
expected

Session cont
lection

RAM Footpri

Temporary 

Clear temporary object allocations 
tracked to this point

mory Leaks session controls
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Memory Analysis

Me

O
sy
pr

Object Reference Graph

Trace object references back 
to the garbage collection roots 
that prevent objects from 
being collected. Answers the 
question: Why is this object 
still in memory?g source line 

bject to edit 

Drill down sequentially from any 
object in the list to examine refer-
enced objects 

Drill down from any method in the 
list to examine allocated objects, 
and the objects they reference 

Re

•
•
•
•

mory Analysis Session Data

bject distribution: user vs. 
stem objects (RAM foot-
int only)

Summary of most mem-
ory-intensive object allo-
cations

Summary of most memory-intensive 
methods

Analyze object allo-
cations in depth

Call Graph

Analyze the calling sequence of methods that 
allocated memory. Answers the question: Who 
allocated all that memory? 

Jump to the allocatin
from any method or o
source code

sults tailored to type data collection

RAM Footprint
Memory Leaks
Temporary Objects
Click Show Complete Details to view session data
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Performance Analysis

Pe

Pe

Filte

Compare session data to 
assess impact of code 
changes

es
sults for Performance Analysis in session files. Session files present data in 
ing the following tabs: 
rformance Analysis

rformance Analysis Session Data

r the data view 

View performance metrics for methods View session statistics
Locate methods in source code

Explore calling 

sequence of methods 

and identify critical path

Results Summari
DevPartner displays re
tabbed format, includ

• Method List 
• Source Code
• Session Summary
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Performance Expert

Pe

Re
De
tab

•
•
•
•
•

ert Session Controls

Clear data collected earlier in 
this session

Window shows last 30 sec-
onds of application activity. 
Spikes in the graph indicate 
potential trouble spots.

rcentage of application code analyzed 

ring session
rformance Expert

sults Summaries
vPartner displays results for Performance Expert in session files. Session files present data in 
bed format, including the following tabs:

Call Graph
Call Tree
Methods table
Source code
Call stacks

Performance Exp

Take a data snapshot

Pe

du
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Performance Expert

Pe

Cl
(w

all Graph tab highlights critical 
ath and expensive child methods

Source tab shows 
most expensive 
line with metrics

Choose metric

Select a method to 
update source and call 
stack tabs

Icons indicate type of activity in method: disk, 
network, or lock wait time

Bars show time in 
method vs. time in 
child methods

Methods table 
shows impact of 
disk, network I/O, 
and wait time
rformance Expert Session Data

ick individual method for Methods analysis 
ithout children)

C
p

Call Tree tab shows impact of 
disk, network I/O, and wait time

Click entry point method for Path analysis 
(with children)

Select method in stack to locate 

source line that called child method
Double-click a line in a source display to edit in 

Visual Studio
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Using DPAnalysis.exe

Us
Use
lau
com

Co
Use
the

DP

DP
op

Th

Ca
[a]

{b

/WAIT - In batch files with multiple targets, launches the next process only after the 
current process exits.

/O[utput] - Specify the session file output directory and/or filename

/W[orkingDir] - Specify working directory for the process or service

/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start

/N[ewconsole] - Run the process in its own command window

/NO_MACH5 - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level 
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (Perf only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods

/NO_OLEHOOKS- Disable collection of COM

/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (Memory only)

Identifies target to follow as either a process or service. Pick only one. All arguments 
that follow the target name/path will be arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)

/S[ervice] - Specify a target service (followed by arguments to service)

/C[onfig] - Path to configuration file

Switches
ing DPAnalysis.exe
 DPAnalysis.exe to run Coverage, Memory, Performance, and Performance Expert sessions 
nched directly from the command line, or through a configuration file called through the 

mand line.

mmand Line Operations
 this syntax to run Coverage, Memory, Performance, or Performance Expert sessions from 
 command line:

Analysis [a] {b} {c} {d} [e] target {target args}

Analysis.exe requires Analysis Type and Target Type switches. Use of other switches is 
tional.

e following table lists the switches used with DPAnalysis.exe:

tegory Switches
 Analysis Type /Cov[erage] - Sets analysis type to DevPartner Coverage Analysis

/Mem[ory] - Sets analysis type to DevPartner Memory Analysis

/Perf[ormance] - Sets analysis type to DevPartner Performance Analysis

/Exp[ert] - Sets analysis type to DevPartner Performance Expert

} Data Collection /E[nable] - Enables data collection for the specified process or service

/D[isable] - Disables data collection for the specified process or service

{c} Other Options

{d} Analysis Options

[e] Target Type

Category
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Using DPAnalysis.exe

Co
Use
thr

DP

Th

El
An

Ar

Ex

ptional) For each Process or Service, zero or one. No default if omitted. Sets the host 
chine of the target process or service. No attributes.

e required for each service. Provides the name of the service as registered with the 
vice control manager. This is the same name you would use for the system's NET 
ART command. No attributes.

e required for each process. Specify a fully qualified or relative path to the 
ecutable. You can specify the executable name without the path if the executable 
ists in the current directory. No attributes.

e configuration file must contain at least one Process or one Service element. 
ecifies a target executable.
ributes: CollectData, Spawn, NoWaitForCompletion, NewConsole 

quired; one only. Defines the type of performance and maximum session time.

e configuration file must contain at least one Process or one Service element. 
ecifies a target service.
ributes: CollectData, Start, RestartIfRunning, RestartAtEndOfRun

quired. One only. Begins a block of one or more Process or Service entries. Target 
cesses and services are started in the order they are listed in the configuration file.
ributes: RunInParallel

scription
nfiguration File
 this syntax to run Coverage, Memory, Performance, or Performance Expert sessions 

ough a configuration file: 

Analysis /config c:\temp\config.xml

e following table briefly describes the XML elements. See the online help for more details.

ement Description
alysisOptions (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 

specified target process or service. Attributes correspond to DevPartner properties 
accessible from the Properties Window in Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

guments (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 
specified target process or service. Attributes correspond to DevPartner Coverage, 
Memory, and Performance properties accessible from the Properties Window in Visual 
Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

cludeImages (Optional) For each Process or Service, zero or one. No default if omitted. Defines 
images (at least one, no maximum) which, if loaded by the target process or service, 
will not be profiled. No attributes.

Host (O
ma

Name On
ser
ST

Path On
ex
ex

Process Th
Sp
Att

RuntimeAnalysis Re

Service Th
Sp
Att

Targets Re
pro
Att

Element De
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Error Detection

Er

Fil

De

Ex
.d

.d

.d

.d

.d

.d

Ca
Ge

Da

Off Enable API call reporting. All selections are unavailable until you select this 
item.

- Collect window messages - Default when active: Off

- Collect API method calls and returns. - Default when active: On

- View only modules needed by this application - Default when active: On

- All modules (tree view). - Default when active: All selected 

Off Enable call validation. All selections unavailable until you select this item

- Enable memory block checking - Default when active: Off

- Fill output argument before call - Default when active: Off

- COM failure codes - Default when active: On

- Check for COM “Not Implemented” return code - Default when active: 
On

- API failure codes - Default when active: On

- Check invalid parameter errors: API, COM - Default when active: both On

- Category: Handle and pointer arguments - Default when active: On

- Category: Flag, range and enumeration arguments - Default when 
active: On

- Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default 
when active: All items selected

Off Enable COM method call reporting on objects that are implemented in 
the selected modules

- Report COM method calls on objects implemented outside of the listed 
modules - Default when active: On

- All components tree view - Default when active: All selected 

Off Enable COM object tracking

- All COM classes tree view - Default when active: All selected

Settings
ror Detection

e Extensions Used by Error Detection

fault Options (Visual Studio) or Settings (Visual C++)

tension File Type Description
pbcl Error Detection Session File This is the Error Detection log for the user's program 

execution.

pbcc
pbcd

Error Detection Settings File This file contains the various settings for Error 
Detection. The .dpbcd extension refers to the default 
settings file created, while .dpbcc refers to a custom 
settings file that has been saved separately.

psup Error Detection Suppressions File This file contains the various suppressions for the user's 
program.

pflt Error Detection Filters File This file contains the various filters for the user's 
program.

prul Error Detection Rules File This is a database of the user's suppressions and filters.

tegory Settings
neral On Log events

On Display error and pause

Off Prompt to save program results

Off Show memory and resource viewer when application exits

On Source file search path - based on the location of the .EXE (standalone), 
.DSW (Visual C++), or .SLN (Visual Studio). 

- Override symbol path - Default: empty

- Working directory (standalone only) based on the location of the .EXE 

- Command line arguments (standalone only) - Default: empty

ta Collection On Call parameter coding depth = 1

On Maximum call stack depth on allocation = 5

On Maximum call stack depth on error = 20

On NLB file directory is based on the location of the .EXE (standalone), 
.DSW (Visual C++), or .SLN (Visual Studio). 

Off Generate NLB files dynamically

API Call Reporting

Call Validation

COM Call Reporting

COM Object Tracking

Category
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Error Detection

oolbar in Visual Studio

oolbar in Visual C++ 6.0

De

M

.N

.N

Re

Ca

Set DevPartner Options

Start with Error Detection

Start with Coverage Analysis

Start with Error Detection and Coverage Analysis

Start without debugging with Performance Analysis

Note: The arrows next to each button allow you to start with or without 
debugging, depending on the default action of the button.

mentation

mentation

ion type

Build with Performance

Build with Coverage

Build with Error Detection

DevPartner Integrated Error Detection

ause

ages
Error Detection T

Error Detection T

adlock Analysis Off Enable deadlock analysis

- Assume single process - Default when active: On

- Enable watcher thread - Default when active: Off

- Generate errors when: A critical section is re-entered - Default when 
active: Off

- Generate errors when: A wait is requested on an owned mutex - Default 
when active: Off

- Number of historical events per resource - Default when active: 10

- Report synchronization API timeouts - Default when active: Off

- Report wait limits or actual waits exceeding (seconds) - Default when 
active: 60

- Synchronization Naming Rules - Default when active: Don’t warn about 
resource naming

emory Tracking On Enable memory tracking

On Report leaks immediately

Off Show leaked allocation blocks

Off Enforce strict reallocation semantics

On Enable FinalCheck

On Enable guard bytes; Pattern = FC; Count = 4 bytes

- Check heap blocks at runtime: On free

On Enable fill on allocation; Pattern = FB

On Check uninitialized memory; Size = 2 bytes

On Enable poison on free; Pattern = FD

ET Analysis Off Enable .NET analysis

- Exception monitoring - Default when active: On 

- Finalizer monitoring - Default when active: On

- COM interop monitoring - Default when active: On

- PInvoke interop monitoring - Default when active: On

- Interop reporting threshold - Default when active: 1

ET Call Reporting Off Enable .NET method call reporting

- All types (tree view node) - Default when active: Selected.

- .NET User Assemblies (tree view node) - Default when active: Selected

- .NET System Assemblies (tree view node) - Default when active: Not 
selected

source Tracking On Enable resource tracking

On Resources tree view. All listed resources are selected by default

tegory Settings

Native C/C++ Instru

Enable/disable instru

Choose instrumentat

Log Events

Display Error and P

Show filtered mess



DevPartner Studio Quick Reference - 18

Error Detection

Er  Results Pane

 Details Pane

ption Appears in...
 Leaks Summary, Memory Leaks, and Transcript tabs

aks Summary, Other Leaks, and Transcript tabs

Summary, Errors, and Transcript tabs

rformance Summary, .NET Performance tabs

Load Event Summary, Modules, and Transcript tabs

ine call Transcript tab

 Collection Event Transcript tab

gins Transcript tab

sumes Transcript tab

ds Transcript tab

ption
ine call

rameters

meters

alue

 (default) for data types

 for data types
ror Detection Window Icons Used in the

Icons Used in the

Details Pane

Displays long description of detected 
error; call stack information; reference 
count graph (see inset below).

Results Pane

Summary, Memory Leaks, Other Leaks, Errors, .NET 
Performance, Modules, Transcript tabs provide 
overview and detail about detected errors.

Source Pane

Displays source code for the 

detected error, if available.

Details Pane - Reference Count Graph
Displays Reference Count View and Object Identity 

View tabs when you select an Interface Leak in the 

Results pane.

Icon Descri
Memory

Other Le

Errors

.NET Pe

Module 

Subrout

Garbage

Event Be

Event Re

Event En

Icon Descri
Subrout

Entry Pa

Exit Para

Return V

Property

Property
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Error Detection

Re

Pr

ource Viewer Dialog Box
Memory Contents Pane

ry, Resource, and Summary tabs

e code for the 
 if available.

Stack Pane

Mark and Close

Click to mark existing allocations and close the 
dialog box. Marked items will not be shown when 
Memory and Resource viewer reappears. 
ference Count Graph Toolbar

ogram Error Detected Dialog Box

Memory and Res

Scale to Size
Select Viewing Area

Vertical Zoom Out
Vertical Zoom In 

Horizontal Zoom Out
Horizontal Zoom In

Error description

Call stack information Source code for the detected error

Tabs for multiple call stacks

Results Pane

Displays Memo

Source Pane

Displays sourc
detected error,
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Error Detection

Ac

Ac
Act
we
you
det

ile Time Instrumentation - Deepest Error Detection
 time instrumentation (CTI) enables Error Detection to find more errors 
rce leaks, pointer errors, data corruption errors, and so on) as they occur 
ck finds these types of errors plus all found with ActiveCheck.

De
De

Po

Th

Cr

Se

Re

Su

Ha

Ev

M

W

.N
Fin

GC

Di

Un
co

un

ed

ked

flict

ked memory block

Pointer and Leak Errors
r Array index out of range

emory Assigning pointer out of range

r Expression uses dangling pointer

Expression uses unrelated pointers

Function pointer is not a function

Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free

Memory leaked due to reassignment

Memory leaked leaving scope

Returning pointer to local variable
tiveCheck and FinalCheck Error Detection

tiveCheck
iveCheck™ analyzes your program and searches for errors in your program executable as 
ll as the dynamic-link libraries (DLLs), third-party modules, and COM components used by 
r program. The following tables list the types of errors found with ActiveCheck error 
ection.

FinalCheck Comp
FinalCheck™ compile
(memory leaks, resou
in real time. FinalChe

adlock-related Errors API and COM Errors
adlock COM interface method failure

tential deadlock Invalid argument

read deadlocked Parameter range error

itical section errors Questionable use of thread

maphore errors Windows function failed

source usage and naming errors Windows function not implemented

spicious or questionable resource usage Invalid COM interface method argument

ndle errors

ent errors

utex errors

indows event errors

ET Errors Pointer and Leak Errors
alizer errors Interface leak

.Suppress finalize not called Memory leak

spose attributes errors Resource leak

handled native exception passed to managed 
de

Memory Errors
Dynamic memory overr

Freed handle is still lock

Handle is already unloc

Memory allocation con

Pointer references unloc

Stack memory overrun

Static memory overrun

Memory Errors
Reading overflows buffe

Reading uninitialized m

Writing overflows buffe
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Lis Keyboard Commands - Visual C++ 6.0

Co
Ct

Ct

Ct

Ct

Ct

Ct

Alt

Ct

Ct

Ct

Ct

F4

Ct

Sh

Sh

Ct

F5

Ct

Ct

F1

F1

Ct

Ct

Ct

Ct

Ct

Sh

Sh

Action
Edit > Find

Edit > Replace

Edit > Go To

Edit > Bookmarks

Edit > Breakpoints

Edit > List Members

Edit > Parameter Info

Edit > Complete Word

View > ClassWizard

View > Workspace

View > Output

View > Properties

Build > Compile filename

Build > Build application_name

Build > Start Debug > Go

Build > Start Debug > Step Into

Build > Start Debug > Run to Cursor

Tools > Source Browser

Tools > Record Quick Macro

Tools > Play Quick Macro
t of Available Keyboard Commands - Visual Studio List of Available 

mmand Action
rl+Shift+O File > Open > Project

rl+Shift+N File > New > Project

rl+S File > Save Project

rl+Shift+S File > Save All

rl+Shift+F Edit > Find in Files

rl+Shift+H Edit > Replace in Files

+F12 Edit > Find Symbol

rl+Alt+L View > Solution Explorer

rl+Shift+C View > Class View

rl+Alt+S View > Server Explorer

rl+Shift+E View > Resource View

View > Properties Window

rl+Alt+X View > Toolbox

ift+Alt+Enter View > Full Screen

ift+F4 View > Property Pages

rl+Shift+B Build > Build Solution

Debug > Start

rl+F5 Debug > Start Without Debugging

rl+Alt+E Debug > Exceptions

1 Debug > Step Into

0 Debug > Step Over

rl+B Debug > New Breakpoint

rl+F1 Help > Dynamic Help

rl+Alt+F1 Help > Contents

rl+Alt+F2 Help > Index

rl+Alt+F3 Help > Search

ift+Alt+F2 Help > Index results

ift+Alt+F3 Help > Search results

Command
Ctrl+F

Ctrl+H

Ctrl+G

Alt+F2

Alt+F9

Ctrl+Alt+T

Ctrl+Shift+space

Ctrl+Space

Ctrl+W

Alt+0

Alt+2

Alt+Enter

Ctrl+F7

F7

F5

F11

Ctrl+F10

Alt+F12

Ctrl+Shift+R

Ctrl+Shift+S


