DPVC Quick Reference

Print out all or portions of this document and keep it handy for quick reference (use a color
printer when available).

DevPartner Features

Use the links in the left column in the following table to locate reference information about
DevPartner features.

Use this DevPartner
feature

To solve this problem

Diagnose run-time errors in the source code Error Detection

Locate performance bottlenecks in the application Coverage and Performance
Analysis

Ensure code base stability throughout development and testing phases Coverage Analysis Session Data

More Information

Refer to the DevPartner online help or to the Understanding DevPartner manual for more
information.

Common Elements

The DevPartner software provides these common elements, regardless of feature.
e DevPartner Toolbar

¢ DevPartner Menu

e DevPartner File Extensions

e Command Line Instrumentation Options

DevPartner Menu and Toolbar

Accessed from the DevPartner menu or toolbar in Visual Studio.

Note: Options and icons vary slightly in Visual Studio 6.0.

Choose this menu or toolbar item

To

x Error detection

V. Coverage Analysis
A
% Error detection and Coverage Analysis

#-3 Performance Analysis
-

Error Detection Rules

. . Native C/C++ Instrumentation

Native C/C++ Instrumentation Manager
Correlate
Merge Coverage Files

& Options

Perform run-time error detection using
BoundsChecker technology

Perform run-time code coverage analysis

Perform run-time error detection with code
coverage analysis

Execute run-time performance analysis

Access error detection rules management,
used to filter or suppress detected errors

Perform compile-time instrumentation for:
Error detection, Error detection with
coverage, performance or coverage analysis

Access the Instrumentation Manager
Correlate performance or coverage files
Merge coverage analysis sessions

Access DevPartner options
Choices include: Analysis, Code review,
Error detection




DevPartner File Extensions
File extensions for session files.

Running this DevPartner feature

Creates this session file (extension)

Code coverage

Code coverage merge files
Error detection
Performance analysis

.dpcov
.dpmrg
.dpbcl
.dpprf

Command Line Instrumentation Options

NMCL Options

The following table lists the NMCL options that you can use to instrument your unmanaged

(native) Visual C++ code from the command line. Use NMCL.EXE only to compile unmanaged

Visual C++ code with DevPartner performance and coverage or error detection instrumenta-
tion. NMCL is not used with managed code, which DevPartner instruments as it is passed to
the common language runtime during execution.

Note All NMCL options must begin with a forward slash (shown in the following list) or
hyphen, followed by the letters NM. For example: /NMoption or -NMoption.

Use...

To...

/NMbcpath:bc-path

/NMclpath:cl-path

/NMhelp or /?

/NMignore:source-file or
/NMignore:source-file:method source-file

/NMilog:log-file

Specify the directory location of bcinterf.lib if you do not
have the directory that contains NMCL on your path.

Specify the directory location of cl.exe. You can use this
option to bypass the installed location of DEVENYV, or if
DEVENV is not installed.

Display help text

Specify a source file or a method in a source file that should
not be instrumented

Specify a log file for NMCL messages (default: stdout)

Use...

Common Elements

To...

/NMnogm

/NMonly:source-file

/NMopt:option-file or
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn
/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

Ignore the CL /Gm (minimal rebuild) option if it appears on
the command line. You can use this option to avoid a
known conflict between the NMAKE /A and CL /Gm
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual
command-line options, each on a separate line)

Specify pass-through mode, which instructs NMCL to call
CL without intervention. In this case, no instrumentation
takes place.

Stop NMCL if an error occurs during instrumentation. If this
option is not specified, the default behavior is to fall back to
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the
default setting.

Specifies instrumentation for performance and coverage
analysis.

Instruments methods that are marked as inlineable if inline
optimizations are enabled (using the /O1, /02, /Ob1, or
/Ob2 option)

Instruct DevPartner not to collect line information. When
you use this option, DevPartner does not display any line
data in the Source tab. You can also use this to improve the
time required to instrument and run your application.

Specify the directory location of the performance and
coverage analysis library files if you do not have the
directory that contains NMCL on your path.

Note: When using NMCL, add the directory containing these utilities to your path. For exam-
ple, if you installed the product into the default directory, add the following directory to your

path:

C:\Program Files\Common Files\Compuware\NMShared
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Common Elements

NMLINK Options Use... To...
The following table lists the NMLINK options that you can use to link your unmanaged (native /NMpass Specify pass-through mode, which instructs NMLINK to call
code) Visual C++ application to DevPartner. LINK without intervention.
Note: All NMLINK options must begin with a forward slash (shown in the following list) or /NMtxOn Spe;:iﬁ.es instrumentation for performance and coverage
hyphen, followed by the letters NM. For example: /NMoption or -NMoption. analysis.
/NMtxpath:tx-path Specify the directory location of the performance and
coverage analysis library files if you do not have the
Use... To... directory that contains NMCL on your path.
/NMbcOn Use DevPartner Error Detection instrumentation. This is the
de‘calflt setting. . . - Note: When using NMCL and NMLINK, add the directory containing these utilities to your
/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not path. For example, if you installed the product into the default directory, add the following
have the directory that contains NMCL on your path. directory to your path:
/NMhelp or /2 Display help text C:\Program Files\Common Files\Compuware\NMShared
/NMilinkpath:link-path Specify the directory location of LINK.EXE. You can use this

option to bypass the installed location of DEVENYV, or if
DEVENV is not installed.
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Coverage and Performance Analysis

Coverage and Performance Analysis DevPartner toolbar buttons for Coverage and Performance

Determine application test coverage and profile application performance.

Select analysis preference Performance Analysis

General and Data Collection Properties .
Coverage Analysis

The following data collection properties apply to coverage and performance analysis. \ /
Property Default setting /

Automatically Merge Session Files Ask me if | would like to merge it Error Detection with Coverage

Collect information about .NET assemblies True

Collect COM Information True Set DevPartner Options
Exclude Others True

Instrument inline functions True

Instrumentation Level Line

Track System Objects True

Native C/C++ Instrumentation —— [ =
Performance or Coverage da -

Enable/disable instrumentation
Choose instrumentation type

Performance and Coverage Analysis Session Toolbars
In Visual Studio 6.0, use the context menu to compare sessions and view a call graph.

View Call Graph
Performance Session toolbar

/@ ==y | SpeedBumnp.Driver.Forml, . ctor -
Compare sessions \

Find method in source code

Coverage Session toolbar

SpeedBump.Driver . Forml, .char -
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Coverage Analysis

Coverage Analysis Session Data

Coverage Analysis

Results Summaries

DevPartner displays results for coverage analysis in Visual Studio or in the Coverage Analysis
Viewer. Session files present data in tabbed format, including the following tabs:

e Method List

View statistics for sessions or merge file

DevPartner - Coverage Analysis Session Summary -

DevPartrier ETYBINYDriy

¢ Source Code
* Merge History
¢ Session or Merge Summary
Filter the data view View coverage metrics for methods
Driver_1.dpmrg | 4 bk x
= - Al 63,8% of 633 lines ) )
o= C108645mD1 - 0 (Criver Rl e i szt (54 2) Merge coverage sessions and record merge history
- %
FTVE ( 0.0% of 1t 34 of 55 methods called [B1.8%)
ManagedCPP f . 5
% CShaﬁ) ren D(°.f Method List | SourcelDriver.cs]| Merae History | Merge Summary |
R Method / # Lines -
& M D.rlver (o1.0% e s Covered | Called | st Bt —”
g Inactlve., Saurce (0 SpeedBump. ManagedCPP.Form1 .BubbleSortEtn_Click 0.0 DL TR
} ° [— o
T NativecPP.di { SpeedBump. ManagedCPR.Form1.Clear Timing 0.0 oF 537 lnes evecuted
~[E] Methads Mot Covered SpeedBump. VEdothet.Form? . .ckor 0.0 [— 34 of 55 mathods ol
- Methods Less Than 20% Co | SpeedBump. Edothet .Form1 Dispose 0.0
-[E] Ower 30 Lines, Less Than 1 | SpeedBump. vBdotiet Form1 InitializeComponent 0.0 Method List| SourcelDriver.cs] Merge Histe® | Merae Summar |
Remaoved Methaods SpeedBump. WEdothet .Formi . DoRandomize 0.0 100 % B % Lines Coversd
SpeedBump. Edothet.Formi, UpdateSlot 0.0 an ¥ M % Methads Covered
SpeedBump. WEdotMet .Formi . Updatedl 0.0 ~ M % Valatiity
Sream B rar, UBAobhisk Eovend B andereizeBtn_Click 0.0 z1]
— 125 of 142 nes executed (B8.0%) o4 — 125 of 142 nes executed
0.0 70
— 13 0 15 methods called [85:7%) tBtn_ Click 0.0 — 13 of 15 methods call
- B0
Method List SourcelSpeedBump. <] | Session Summary| pad gg Method List| SoucelSpesdBump.cs] Session Sudfary |
Count Source N — ' 50
1 3 rEBen_Click. 0.0
private void UpdateSlot (Int32 iSlot) ng 0.0 4 started: 5/23/2003 12:36:08 PM
{ a 0.0 Ended: 5/23[2003 12:36:26 PM
slate.Drayline < t, Elements Btn_cClick 0.0 0
2,174 if (Elements[i310t] < nunElems) - 0.0 Executable: CiiProgram Filesic
2,174 slate.Dravline (vhitePen, Elements[iSlot] + - ' o [Command Args:
3174 ) _Click, 0.0 Exit Code: 0
lick 0.0 0
private woid Updateill() e £0.0 Processor: Intel Pentium €47 Mhe
. - )
¢ 60.0 o v Mictosct Windows 2000
A or (Tme3z i - 05 dcmmElemss iee) Driverd.dpcov / Driver2.dpcov  Driver]. dpoay Driver. dpcay
200 Update®lot (i) ; J
1 bleedlUpdate = false:
1 ) . . All Images
View execution data for
private woid RendomizeBrn Click|chject sender, Syst lines of source code m;::';: g;ﬂ:zf"amlm‘ gg‘f
Mumber of Lines Executed: 181
1 DoRandomize () : Mumber of Lines Nt Executed: 346
1 Updateall (] : Percent of Methods Called: 34.5
N s umber of Methods: 5
q _’l_l koot oo o2
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Performance Analysis

Performance Analysis Results Summaries

DevPartner displays results for performance analysis in Visual Studio or in the Performance
Analysis Viewer. Session files present data in tabbed format, including the following tabs:
* Method List

¢ Source Code

e Session Summary

Performance Analysis Session Data

Filter the data view Locate methods in source code

View performance metrics for methods View session statistics

\

\ \ 4k x

Method Lit | Source Imanagedepp hl| Session Summary |

Dri\)ﬁr .dpprf - Driverl.dpprf |

- Compare Sessions [ 003
Al Madules: 29 M | hMethad List ISD e [managedenn hl| Session Summary | . DevP MET
[ C106645H01 - e P o Bn o . Basis session: CilProgram FlesiC artner YBim\Drivert  dpprf
Mame Method children Calles Average ™ in retnoa o Claren o aae. It sne i Ciaren
SpeedBump. ManagelCPP. Forml . UpdateSlot 0.9 716\ 47,916 3.8
SpeedBump, Managed(PP. Farml, SwapEm 0.6 714 \23,658 5.0 I i I I I i I i I i I
SpeedBump. Managed PP, Form 5. .. 0.3 65.0 1 585147 LT = ¥ P
SpeedBump. Driver, Form1, .ckor 0.3 6.4 1 sae7e: e s | i | cokd | e | =
] system (3 SpeedBump. ManagedCPR. Forml. . chor 0.2 0.4 1 46,333.8 dEump.Charp. Form1, Updatesiot [ e 47,916 L
SpeedBump. CSharp.Forml..ctar Method List  Source [maﬂaged\pp_h] | Session Summans| speedBump.ManagedCPP. Forml Updateslo: 0.6 42,2 47,916 4,0
. Top 20 Source Met SpeedBump. Driver. Forml. InitializeComponent Count | % with Children | Time | Source | peedBUmp.CSharp. Form L. SwapEm ' 23,658
Top 20 Methads SpeedBump, Driver, Forml, ManagedCppBtn_Click 1 ComMpOnents SpeedBump. ManagedPP, Forml BubbleSortBitn_Clck nz 401 1 sao0Le
E=] Top 20 Called Sour | SpeedBump. Driver. Forml. Main 1 Initializ ?JEE;SUWP-E;;EV Fﬁ'mlltﬁlném e ik g-? 43; : jéggg
eedBump.CSharp Form1 . BubbleSartetn_Clc . } 513,
~[E] Top 20 Called Mett | SpeedBump. CSharp, Forml, UpdateSlot L -6 RHzedUpdace Sposdbumy Hnagedch? Farml, o 0.1 03 1 460623
SpeedBump. ManagedCPP.Farml.L... i - i J SpeedBump.CSharp Farml,.chor 0. 0.3 1 28,0665
) " SpeedBump.Criver Formi IntiaizeComponent 0.1 3.1 1 29224
SpedBump. Driver. Form1. CSharpBtn_Click 114 <surmarys SpeedBump.Driver . Form1.ManagedCp. . 0.0 4.2 1 13,7163
SpeedBump. ManagedCPP.Farml.. .. - basis value 0.1 75.1 1 13,747.7
/¢4 Clean up any resources being used. i ! N 8 e
SpedBump. CSharp. Forml. SwapEm A </ smanary> = percent change 0% -31% 0% 0%
- SpeedBump. CSharp. Forml. QuickSortBtn_Click. protected: ~Spesdbump.ManagedCPP. Forml . QucksortBtn_Chck [ T2 T 7,004
SpeedBump. Managed PP, Forml, QSart void Dispose( bool disposing ) SpesdBump.CSharp.Formi . QuickSortdtn_Click o0 12 1 sz |
SpeedBump. CSharp. Forml, QSort {
SpeedBump. Managed PP, Farmi,DoRandomize 1 0.3 if{ disposing |} .
SpeedBump. ManagedCPP. Forml.... { Method List| Source [managedepp.hl Sesé‘qn Summeary | Compare session data to
SpeedBumnp, CSharp, Forml, RandomizeBtn_Click. :f teawps DevPartney - Performance Analysis Session Summary assess impact of code
i Call Graph _(o] x| —
Tk tarted: 6i24{2003 4:21:44 PM h
e o = i nded: 8124/2003 4:22:43 PM changes
i
= SpeedBumg.CohapF_ 950 8 %) Speedump CohapF _ 98,656 __super: : Dis)f bxecutable: ) Ci\Program Files|C Partner Studio|E: np. NETYBIN|Driver exe
H 15% 14% = ¥ Formand Args:
L it Code: 0
1% private:
void Tnitializecd frocessar Intel Pertium 647 Mhz
I of Processors:
D 5 Gy sembndonsFor_ - 5 Version: Microsoft Windows 2000
| | 21% & an
K of Called Methods (with thread starts): 3,069
0.1% R of Calls: 3,688,729
otal Timing: 19,619,664.6 Microseconds
0.0 % = SpeedBump.CShamF + C106645M01 - 1668 (Driver)
129 Humber of Called Methods: 3063
Percent of Time Spent on Machine:  100.0
P Explore calling
Instrumenked Source Images
no% = Speedbump CShamF sequence of methods
2a% H ManagedCPP
and identify critical path Humber of Called Methods: 15
A\ J flnker o oo etoss 1% o
4 L3 RIS »
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Using DPAnalysis.exe

Use DPAnalysis.exe to run coverage or performance analysis sessions from the command line.

DPAnalysis.exe accepts command line switches or an XML configuration file.

Command Line Operations

Use this syntax to run coverage or performance sessions from the command line:

DPAnalysis.exe [a] {b} {c} {d} [e] target {target args}

DPAnalysis.exe requires Analysis Type and Target Type switches. Use of other switches is

optional.
The following table lists the switches used with DPAnalysis.exe:

Category Switches

Category

Using DPAnalysis.exe

Switches

[a] Analysis Type /Cov[erage] - Sets analysis type to DevPartner coverage analysis
/Perf[ormance] - Sets analysis type to DevPartner performance analysis
{b} Data Collection /E[nable] - Enables data collection for the specified process or service
/Dlisable] - Disables data collection for the specified process or service
/R[epeat] - Profiling will occur any time you run the specified process until you use

the /D switch to disable profiling.

{c} Other Options

{d} Analysis Options

[e] Target Type

/O[utput] - Specify the session file output directory and/or filename
/W[orkingDir] - Specify working directory for the process or service
/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start
/N[ewconsole] - Run the process in its own command window

/F[orce] - Forces profiling for coverage or performance of applications written
without managed code or CTI.

/NO_MACHS - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (performance
analysis only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods
(coverage and performance analysis only)

/NO_OLEHOOKS- Disable collection of COM

/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (memory analysis
only)

Identifies target that follows as either a process or service. Pick only one. All
statements that follow the target name/path are considered arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)
/S[ervice] - Specify a target service (followed by arguments to service)
/Clonfig] - Path to configuration file
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Configuration File

Use this syntax to run coverage or performance analysis sessions through a configuration file:
DPAnalysis.exe /config c:\temp\config.xml

The following table briefly describes the XML elements. See the DevPartner online help or the
Understanding DevPartner manual for more information.

Element

Description

Using DPAnalysis.exe

AnalysisOptions

Arguments

Excludelmages

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner properties
accessible from the Properties Window in Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner Coverage,
Memory and Performance Analysis properties accessible from the Properties Window in
Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. No default if omitted. Defines
images (at least one, no maximum) which, if loaded by the target process or service,
will not be profiled. No attributes.

Element Description

Host (Optional) For each Process or Service, zero or one. No default if omitted. Sets the host
machine of the target process or service. No attributes.

Name One required for each service. Provides the name of the service as registered with the
service control manager. This is the same name you would use for the system's NET
START command. No attributes.

Path One required for each process. Specify a fully qualified or relative path to the
executable. You can specify the executable name without the path if the executable
exists in the current directory. No attributes.

Process The configuration file must contain at least one Process or one Service element.

RuntimeAnalysis
Service

Targets

Specifies a target executable.
Attributes: CollectData, Spawn, NoWaitForCompletion, NewConsole

Required; one only. Defines the type of analysis and maximum session time.

The configuration file must contain at least one Process or one Service element.
Specifies a target service.
Attributes: CollectData, Start, RestartlfRunning, RestartAtEndOfRun

Required. One only. Begins a block of one or more Process or Service entries. Target
processes and services are started in the order they are listed in the configuration file.
Attributes: RuninParallel
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Error Detection

File Extensions Used by Error Detection

Category

Error Detection

Settings

Extension  File Type Description

.dpbcl Error Detection Session File This is the Error Detection log for the user's program
execution.

.dpbcc Error Detection Settings File This file contains the various settings for Error

.dpbcd Detection. The .dpbcd extension refers to the default
settings file created, while .dpbcc refers to a custom
settings file that has been saved separately.

.dpsup Error Detection Suppressions File This file contains the various suppressions for the user's
program.

.dpflt Error Detection Filters File This file contains the various filters for the user's
program.

.dprul Error Detection Rules File This is a database of the user's suppressions and filters.

Default Options (Visual Studio) or Settings (Visual C++)
Default values vary slightly between Visual Studio 6.0 and Visual Studio .NET 2003 and 2005.

Category Settings
General On Log events
On Display error and pause

Data Collection

Prompt to save program results
Show memory and resource viewer when application exits

Source file search path - based on the location of the .EXE (standalone),
.DSW (Visual C++), or .SLN (Visual Studio).

Override symbol path - Default: empty

Working directory (standalone only) based on the location of the .EXE
Command line arguments (standalone only) - Default: empty

Call parameter coding depth = 1

Maximum call stack depth on allocation = 5

Maximum call stack depth on error = 20

NLB file directory is based on the location of the .EXE (standalone),
.DSW (Visual C++), or .SLN (Visual Studio).

Generate NLB files dynamically

API Call Reporting

Call Validation

COM Call Reporting

COM Object Tracking

Off

Off

Off

Enable API call reporting. All selections are unavailable until you select this
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On
All modules (tree view). - Default when active: All selected

Enable call validation. All selections unavailable until you select this item
Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active:
On

API failure codes - Default when active: On
Check invalid parameter errors: API, COM - Default when active: both On
Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default
when active: All items selected

Enable COM method call reporting on objects that are implemented in
the selected modules

Report COM method calls on objects implemented outside of the listed
modules - Default when active: On

All components tree view - Default when active: All selected
Enable COM object tracking
All COM classes tree view - Default when active: All selected

DevPartner Studio Quick Reference - 9



Category

Settings

Deadlock Analysis

Memory Tracking

.NET Analysis

.NET Call Reporting

Resource Tracking

Off

Enable deadlock analysis
Assume single process - Default when active: On
Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when
active: Off

Generate errors when: A wait is requested on an owned mutex - Default
when active: Off

Number of historical events per resource - Default when active: 10
Report synchronization API timeouts - Default when active: Off

Report wait limits or actual waits exceeding (seconds) - Default when
active: 60

Synchronization Naming Rules - Default when active: Don’t warn about
resource naming

Enable memory tracking

Enable Leak Analysis Only

Show leaked allocation blocks

Enforce strict reallocation semantics

Enable FinalCheck

Enable guard bytes; Pattern = FC; Count = 4 bytes
Check heap blocks at runtime: On free

Enable fill on allocation; Pattern = FB

Check uninitialized memory; Size = 2 bytes

Enable poison on free; Pattern = FD

Enable .NET analysis

Exception monitoring - Default when active: On

Finalizer monitoring - Default when active: On

COM interop monitoring - Default when active: On
PInvoke interop monitoring - Default when active: On
Interop reporting threshold - Default when active: 1
Enable .NET method call reporting

All types (tree view node) - Default when active: Selected.
.NET User Assemblies (tree view node) - Default when active: Selected

.NET System Assemblies (tree view node) - Default when active: Not
selected

Enable resource tracking
Resources tree view. All listed resources are selected by default

Error Detection Toolbar i

Error Detection

n Visual Studio
Start with Error Detection

Start with Coverage Analysis

Start with Error Detection and Coverage Analysis

Start without debugging with Performance Analysis

Note: The arrows next to each button allow you to start with or without
debugging, depending on the default action of the button.

M - @ - &‘: = @l - @ Error Detection

- ﬁf‘lf

Native C/C++ Instrumentation
Enable/disable instrumentation
Choose instrumentation type

Error Detection Toolbar i

I

Set DevPartner Options——|

n Visual C++ 6.0

DevPartner Integrated Error Detection

# ¢ o

Log Events Q

Display Error and Pause
Show filtered messages

|
LBuiId with Performance
Build with Coverage

Build with Error Detection
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Error Detection Window

— Results Pane

Summary, Memory Leaks, Other Leaks, Errors, .NET
Performance, Modules, Transcript tabs provide
overview and detail about detected errors.

— Details Pane

Displays long description of detected

error; call stack information; reference

count graph (see inset below).

Tpe Quantity Locat\ow;l Paipter Emrar: Pointer 0x0012EES0, used as an ;l
T M bie b E H] argunpient, is out of range; no longer within the buffer
= x owveable Memary Error fior wariable a 0x001 2EE78 (20] in function
X Monzero lack count 1 API_Fre Painter_ArayParamE <Fange
X Dangling pointer 1 Pointer, ;I
i Curment Call Stack - Thiead D [0+0108] |
. Function ‘ Fil= ;I
2.4 F'DmtelUnreIated. - ! g Fainter_&mayParamExRange  PTRERR.CPP J
X Unrelated painter comparison 1 Pointer_ EvecuteFunction BugBench7Dlg cp)
- X Read Dverun 1 OnTest BugBench7Dlg.cpy
- X 'wiite Overrun 1 ~ | | _Af=DispatchCmdisg cmdtarg.cpp
0l | S OnCmdMsg cmdtarg.cpp
OnCradhd di .
El Summaryl $ Memary Leaksl 4y Other Leaks X Errors |44 | 1? e 100[9 "

c:program fileshcompuwaredevpartner studiohexamplesibugbench? mainptrer.cpp

-
] 4

€THY Reference Count Yiew |Dbiecl |dEn[i|yV\Ewl
inta[5]:
int_b; Do G
b = a[B]: / amay index out of range
3L—u—u—n—u—n—n—\_ —
CATCH -
123456769 11 13 15
. LI
L AcHRief - Thread 0 [0<0070] =
Source Pane Finetion | File: | Line / Dffset | =]
ole32.dl Ox0001BDEF
. Crgatelnstance comip.h 570
Displays source code for the COp_Intetace_Lesk  comer.cpp 121
. . E: teFuncti bugbench?7d B35
detected error, if available. e nen bagnchTdo o 539J
_AlxDispatchCmdMsg  cmdtang.cpp 88
OrCmdtsg cmdtang.cpp BBEj

L Details Pane - Reference Count Graph

Displays Reference Count View and Object Identity
View tabs when you select an Interface Leak in the
Results pane.

Icons Used in the Results Pane

Icon

Error Detection

Description

Appears in...

b JE e B XS e

Memory Leaks
Other Leaks
Errors

.NET Performance

Module Load Event

Subroutine call

Summary, Memory Leaks, and Transcript tabs
Summary, Other Leaks, and Transcript tabs
Summary, Errors, and Transcript tabs
Summary, .NET Performance tabs

Summary, Modules, and Transcript tabs

Transcript tab

Garbage Collection Event Transcript tab
Event Begins Transcript tab
Event Resumes Transcript tab
Event Ends Transcript tab
Icons Used in the Details Pane
Icon Description
- Subroutine call
Entry Parameters
b
Exit Parameters
U

O+

By
@

Return Value

Property (default) for data types

Property for data types
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Error Detection

Reference Count Graph Toolbar Memory and Resource Viewer Dialog Box
Vertical Zoom Out Results Pane Memory Contents Pane
Vertical Zoom In Scale to Size .
Select Viewina Area Displays Memory, Resource, and Summary tabs Stack P
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ActiveCheck and FinalCheck Error Detection

ActiveCheck

ActiveCheck™ analyzes your program and searches for errors in your program executable as
well as the dynamic-link libraries (DLLs), third-party modules, and COM components used by
your program. The following tables list the types of errors found with ActiveCheck error

detection.

Deadlock-related Errors

API and COM Errors

Error Detection

Memory Errors

Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memory block
Stack memory overrun

Static memory overrun

Deadlock

Potential deadlock

Thread deadlocked

Critical section errors

Semaphore errors

Resource usage and naming errors
Suspicious or questionable resource usage
Handle errors

Event errors

Mutex errors

Windows event errors

COM interface method failure

Invalid argument

Parameter range error

Questionable use of thread

Windows function failed

Windows function not implemented
Invalid COM interface method argument

Memory Errors

FinalCheck Compile Time Instrumentation - Deepest Error Detection

FinalCheck™ compile time instrumentation (CTI) enables Error Detection to find more errors
(memory leaks, pointer errors, data corruption errors, and so on) as they occur in real time.
FinalCheck finds these types of errors, plus all errors found with ActiveCheck.

Pointer and Leak Errors

.NET Errors

Pointer and Leak Errors

Finalizer errors
GC.Suppress finalize not called
Dispose attributes errors

Unhandled native exception passed to managed
code

Interface leak
Memory leak
Resource leak

Reading overflows buffer
Reading uninitialized memory
Writing overflows buffer

Array index out of range
Assigning pointer out of range
Expression uses dangling pointer
Expression uses unrelated pointers
Function pointer is not a function
Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free
Memory leaked due to reassignment
Memory leaked leaving scope
Returning pointer to local variable
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List of Available Keyboard Commands - Visual Studio

Error Detection

List of Available Keyboard Commands - Visual C++ 6.0

Command Action

Ctrl+Shift+O File > Open > Project
Ctrl+Shift+N File > New > Project
Ctrl+S File > Save Project
Ctrl+Shift+S File > Save All
Ctrl+Shift+F Edit > Find in Files
Ctrl+Shift+H Edit > Replace in Files
Alt+F12 Edit > Find Symbol
Ctrl+Alt+L View > Solution Explorer
Ctrl+Shift+C View > Class View
Ctrl+Alt+S View > Server Explorer
Ctrl+Shift+E View > Resource View

F4 View > Properties Window
Ctrl+Alt+X View > Toolbox
Shift+Alt+Enter View > Full Screen
Shift+F4 View > Property Pages
Ctrl+Shift+B Build > Build Solution

F5 Debug > Start

Ctrl+F5 Debug > Start Without Debugging
Ctri+Alt+E Debug > Exceptions

F11 Debug > Step Into

F10 Debug > Step Over
Ctrl+B Debug > New Breakpoint
Ctrl+F1 Help > Dynamic Help
Ctrl+Alt+F1 Help > Contents
Ctri+Alt+F2 Help > Index

Ctrl+Alt+F3 Help > Search
Shift+Alt+F2 Help > Index results
Shift+Alt+F3 Help > Search results

Command Action

Ctrl+F Edit > Find

Ctrl+H Edit > Replace

Ctrl+G Edit > Go To

Alt+F2 Edit > Bookmarks

Alt+F9 Edit > Breakpoints

Ctri+Alt+T Edit > List Members
Ctrl+Shift+space Edit > Parameter Info
Ctrl+Space Edit > Complete Word

Ctrl+w View > ClassWizard

Alt+0 View > Workspace

Alt+2 View > Output

Alt+Enter View > Properties

Ctrl+F7 Build > Compile filename

F7 Build > Build application_name
F5 Build > Start Debug > Go

F11 Build > Start Debug > Step Into
Ctrl+F10 Build > Start Debug > Run to Cursor
Alt+F12 Tools > Source Browser
Ctrl+Shift+R Tools > Record Quick Macro
Ctrl+Shift+S Tools > Play Quick Macro
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Export DevPartner Data: Command Line Use

Export DevPartner Data: Command Line Use Switch Description
You can use DevPartner.Analysis.DataExport.exe from the command line to convert DevPartner /T [ecurse] Sear.ch subdirectories for DevPart.ner session files.
coverage analysis (.dpcov), coverage analysis merge (.dpmrg), and performance analysis /flilename]=<String> Specify the name of the XML output file. Appends .xml to the name

(.dpprf) session file data to XML. specified.

Use this syntax to export session data to XML: /showAll Shows all performance and coverage session file data available in a

performance or coverage session file.

DevPartner.Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options} For example, if you export a performance session file with this option,
the resulting XML file contains both performance and coverage data
Options fields.
/wlait] Wait for input before closing console window.

The following table lists the command line options for DevPartner.Analysis.DataExport.exe.

You can use an equal sign, a colon, or a space to separate an option from the value or values /nologo Do not display the logo or copyright notice.
you specify. /help or /? Display help in the console window.
Switch Description

/out [put]=<String> Specify the output directory for exported XML files. Creates the
directory if the directory does not exist.
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