DevPartnerStudio Quick Reference

Print out all or portions of this document and keep it handy for quick reference (use a color
printer when available).

DevPartner Features

Use the links in the left column in the following table to locate reference information about
DevPartner features.

Use this DevPartner
feature

To solve this problem

Detect programming problems and naming inconsistencies Code Review

Diagnose run-time errors in the source code Error Detection

Locate performance bottlenecks in the application Coverage, Memory, and

Performance Analysis
Ensure code base stability throughout development and testing phases Coverage Analysis Session Data

Determine memory allocation in an application and get feedback to Memory Analysis
reduce memory consumption

More Information

Refer to the DevPartner online help or to the Understanding DevPartner manual for more
information.

Common Elements

The DevPartner software provides these common elements, regardless of feature.
DevPartner Toolbar

DevPartner Menu

DevPartner File Extensions

Command Line Instrumentation Options

DevPartner Menu and Toolbar

Accessed from the DevPartner menu or toolbar in Visual Studio.

Choose this menu or toolbar item

To

x Error detection

V. Coverage Analysis
A
% Error detection and Coverage Analysis

#-5 Performance Analysis
-

Memory Analysis
Ef;j Performance Expert

&  Perform Code Review
Lol
PR

L]

o

Error Detection Rules

Manage Code Review Rules

. @ . Native C/C++ Instrumentation

Native C/C++ Instrumentation Manager
Correlate
Merge Coverage Files

‘@ Submit TrackRecord defect

Perform run-time error detection using
BoundsChecker technology

Perform run-time code coverage analysis

Perform run-time error detection with code
coverage analysis

Execute run-time performance analysis

Execute run-time memory analysis

Execute run-time analysis with Performance
Expert

Perform static code analysis

Access code review rules management

Access error detection rules management,
used to filter or suppress detected errors

Perform compile-time instrumentation for:
Error detection, Error detection with
coverage, Performance or coverage analysis

Access the Instrumentation Manager
Correlate performance or coverage files
Merge coverage analysis sessions

Submit TrackRecord defect
See Note

Note: The Submit TrackRecord defect toolbar button is only available when TrackRecord is

installed.
& Options

Access DevPartner options
Choices include: Analysis, Code review,
Error Detection




DevPartner File Extensions
File extensions for session files.

Run this DevPartner feature To create this session file (extension)

Code review .dpmdb
Code coverage .dpcov
Code coverage merge files .dpmrg
Error detection .dpbcl
Memory analysis .dpmem
Performance analysis .dpprf
Performance Expert .dppxp

Command Line Instrumentation Options

NMCL Options

The following table lists the NMCL options that you can use to instrument your unmanaged
(native) C++ code from the command line. Use NMCL.EXE only to compile unmanaged C++
code with DevPartner performance and coverage or error detection instrumentation. NMCL is
not used with managed code, which DevPartner instruments as it is passed to the common
language runtime during execution.

Note All NMCL options must begin with a forward slash (shown in the following list) or
hyphen, followed by the letters NM. For example: /NMoption or -NMoption.

Use... To...

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not

have the directory that contains NMCL on your path.

/NMclpath:cl-path Specify the directory location of cl.exe. You can use this
option to bypass the installed location of DEVENV, or if

DEVENV is not installed.
/NMhelp or /? Display help text

/NMignore:source-file or Specify a source file or a method in a source file that should
/NMignore:source-file:method source-file not be instrumented

Common Elements

Use... To...
/NMlog:log-file Specify a log file for NMCL messages (default: stdout)
/NMnogm Ignore the CL /Gm (minimal rebuild) option if it appears on

/NMonly:source-file

/NMopt:option-file or
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn
/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

the command line. You can use this option to avoid a
known conflict between the NMAKE /A and CL /Gm
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual
command-line options, each on a separate line.

Specify pass-through mode, which instructs NMCL to call
CL without intervention. In this case, no instrumentation
takes place.

Stop NMCL if an error occurs during instrumentation. If this
option is not specified, the default behavior is to fall back to
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the
default setting.

Specifies instrumentation for performance and coverage
analysis.

Instruments methods that are marked as inlineable if inline
optimizations are enabled (using the /O1, /02, /Ob1, or
/Ob2 option)

Instruct DevPartner not to collect line information. When
you use this option, DevPartner does not display any line
data in the Source tab. You can also use this to improve the
time required to instrument and run your application.

Specify the directory location of the performance and
coverage analysis library files if you do not have the
directory that contains NMCL on your path.

When using NMCL, add the directory containing these utilities to your path. For example, if
you installed the product into the default directory, add the following directory to your path:

C:\Program Files\Common Files\Compuware\NMShared
Note: For installs on 64-bit versions of Windows, add the following directory to your path:
C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Common Elements

NMLINK Options Use... To...
The following table lists the NMLINK options that you can use to link your unmanaged (native /NMpass Specify pass-through mode, which instructs NMLINK to call
code) C++ application to DevPartner. LINK without intervention.
Note: All NMLINK options must begin with a forward slash (shown in the following list) or /NMtxOn Spefifies instrumentation for coverage and performance
hyphen, followed by the letters NM. For example: /NMoption or -NMoption. analysis.

/NMtxpath:tx-path Specify the directory location of the performance and

coverage analysis library files if you do not have the

Use... To...

directory that contains NMCL on your path.

/NMbcOn Use DevPartner Error Detection instrumentation. This is the

default setting. When using NMCL and NMLINK, add the directory containing these utilities to your path. For

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not example, if you installed the product into the default directory, add the following directory to
have the directory that contains NMCL on your path. your path:
/NMhelp or /? Display help text C:\Program Files\Common Files\Compuware\NMShared
/NMlinkpath:link-path Specify the directory location of LINK.EXE. You can use this . . . . . .
P P ogtior{to bypass ch installed location of DEVENV, or if Note: For installs on 64-bit versions of Windows, add the following directory to your path:
DEVENV is not installed. C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Code Review

Command Shortcuts for Rule Manager

Use the following keyboard shortcuts to enter Rule Manager commands:

Code Review

Command-line Switches Used in CRExport

CRExport.exe /<switch>

Switch

Function

Command Action

Ctrl+A Rule > Select All Rules
Ctrl+C Rule > Copy Selected Rules
Ctrl+N Rule > New Rule

Ctrl+O File > Open Rule Set
Ctrl+P File > Print

Ctrl+V Rule > Paste Rules

F5 View > Refresh

Command-line Switches Used in CRBatch

CRBatch.exe /<switch>

Switch

Function

/f configuration file/file name

/v or /verbose

/vs "8.0" or /vs “9.0"

Informs CRBatch what configuration file
to use when reviewing a solution or
project

This switch is mandatory.

Instructs CRBatch to report errors in a
message box, and to set the exit code
used by batch procedures

Although this switch is optional, it is
useful if you want to physically debug
configuration files.

Indicates the Visual Studio environment
where the batch review will be
executed; choices include8.0 or 9.0

It is recommended that you use this
switch, most importantly if you have
more than one version of Visual Studio
on your system. If you do not include
this switch, DevPartner will default to
the latest version.

”

/f sessionfile

/e xml exportfile
/a

/ai

/p

/m

/n

/s
/c

/ci

Help — Displays this list of the available command line interface arguments.

Fully-qualified session file path and name — Identifies the session database to use
for this export. (Mandatory)

Fully-qualified export file path and name — Identifies the XML file to receive the
exported data. (Mandatory)

Export all session data — Exports all data for the specified session, including the
outbound methods for call graph data. Inbound methods are not exported.

Export all session data with inbound methods — Exports all data for the specified
session, including inbound and outbound methods for call graph data.

Export problems data — Exports the problems data for the specified session.
Export metrics data — Exports the metrics data for the specified session.

Export naming analysis data — Exports the naming analysis data for the specified
session.

Export code size data — Exports the code size data for the specified session.

Export call graph data — Exports the outbound, or called, methods in the call graph
data for the specified session.

Export call graph data with inbound methods — Exports the call graph data,
including inbound and outbound methods, for the specified session.
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Code Review Default Options (General Node)

Category Settings

Code Review

Description Default

Projects to be reviewed All projects selected (C# and VB.NET projects only)
Rule set All Rules

Naming analysis to use Naming Guidelines (see below)

Collect metrics On
Collect call graph data On
Always generate a batch file On
Always save review results On
Prompt for session file name Off

Include naming analysis for
Company name
Technology name

All identifiers selected

Naming Guidelines

Description Default

What to analyze All public or protected identifiers

Choose dictionary American English

Code Review Toolbars

Print <current code review results> —| £=§

Hide/Show Soluton Tree — |

— Submit TrackRecord bug
Filter Current View

Hide/Show Description
Mark Item Fixed

? T + 7%

Suppress Rule

E-E- @Y

‘—Layout
Scaling
Node style

Number of levels

|
Perform a review of the solution code——
Create and modify rules used during code review.
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Code Review Summaries

* Summaties include all rule viclations. Your Alter settings do not apply.

Summary of Problems *

Type Problems

Names Total | Fized
ZOM Interop 1 1]
Database 1] ]
Crate o o
Cresign Tirne Properties o o
ErrorfException Handling 21 o
Garbage Callection o o
Internationalization 12 1]
Language o o
Logic 2 a
Maint sinability 13 o
Performance 1 1]
Portability 1} o
Project 2 Solution Properties a 1]
Reliability a o
Securiby 3 1]
Standards ] 1]
Systern a 1]
Uzability o i}
User-Dafined Rule ] 1]
Wersioning a 1]
findows APT ] 1]
Totals 53 o

Severity

High |Medium | Low

0
1]

o
o

o | =

W el e e 2 = = =

o oo

20

olo|lo|la ol oo ala

23

Warning
1
o

11

Code Review

Summary of Counts

Summary Type Count
Rewiew Time (in rminutes) 1212
Total Lines (including blank lines) 2,183
Code Only Lines 1,162
Comment Cnlby Lines 270
Code with Camments 1]
Rule Comparisons Made 463,267
Total Lines Checked 2,183

Solution

Solution Path

Session File

Eatch Command Execution File

Praject Name

Doiver2003

CSharp2002

We2002

Metrics Analysis
Maming Analysis

Dictionary MName

Compile Errors

True

True

True

Review Settings

Setting Yalue
SpeedBump.Met2003

i MHT-MMSourcel666_MHT1015 15001
\DPS\DP_Mainline\AnalysistExamples\SpesdBump MetiSpeedBump. Met2003 sin

i MHT-MMSourcel666_MHT1015 15001
PRSVDP_MainfinelAnalysisiExamples\SpeedBump. MetiSpesdBump Net2003 DRMDE

iipd_ MHT-HMSource1666_MHT101515D01
Aralerici

ARSI A sinlined A horis E e el S i RaED SrencdBy o Kab 2003 BAT

Project List

Reviewed Project Path

Ci\pd_MHT-MMSource 1666_MHT 101515001
\DRSYER_Mainline! Analysis\ExamplesiSpeedBump Net|Driver Driver2003 csproj

Ct\pd_MHT-NMSource 1665 _MHT 101515001
\DRSYDP_Mainline! Analysis\Examples\SpeedBump et CSharplCSharp2003 csproj

Ct\pd_MHT-MMSource 1666 _MHT 101515001
\DRSYDR_Mainline!,Analysis|ExamplesiSpeedBump NatWB\WE2003 wbproj

True
Maming Guidelines

American English

Summary of Call Graph Data

Summary Type Count

Total Methods Graphed 24

Total Methods Uncalled o
Technology Mame ot supplied
all Graph Analysis True
Ignore compile errors False
Exclude rules that require a build Falze
Always generate a batch fle True
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Code Review Results Panes

Problems pane — displays rule-based programming problems

Code Review

4 b

e y/ﬁfuems E ) e — Naming pane — lists .NET naming violations and offers suggestions
Metrics pane — provides code complexity statistics
Fi... | Suppressed Rule | Title Sev... Project | File IMethod Class Tvpe o
|| 1050 Structured error handler not Faund low  CSharp  SpeedBump.cs Updateslot i
Yiew by Variables
[l 1619 Braces should not be optional for co...  War... CSharp  SpeedBump.cs Updateslot
D 1622 Use spaces instead of tabs War,., CShatp  SpeedBump.cs Updateslat S Eroblems/ﬁﬁ fietrics | Call Graph qp
D 1619 Braces should not be optional for co...  War... CSharp  SpeedBump.cs Updateal T i E
D 1050 Structured error handler not Found Low CSharp SpeedBump.cs Updateal dBump.Met AR - 5 il bt
<
— Fixed Narne Suggested Acce:
O Elements elements Private| Methad Project Complexity Bad Fix % Understanding | Lines of Cods
Structured error handler not found 0 bhesdlindate  needipdats Frivate|
Trigger: Detected no struchured exception handling at this level [Occurrences:1 E ! e Exp:anat\on Loca: =¥ BubbleSortBn_Click SpeedBump... CSharp 5 5 Simple ko moder....
Original Source Line: private void UpdateSlot(Int22 Slat) " See Explanation - Local | 59 csharpBtn_Click  Driver.cs Driver 1 1 Simple: 4
Location: SpeedBurmp.cs O iMidital See Explanation  Local | S8 pastiveCppBtn_Click  Driver.cs Driver 1 1 Simple 3
WForml SpeedBump, .. CSharp 1 1 Simple: 16
3 iew by all 1 1 Simple 2
Explanation 1 1 Simple: 1
Summary [Problems |“Naming [Metrics /Call Graph | g b 2 1 Simple: 5
A structured error handler was not found in this Visual Basic NET proc ~ 3 1 Simple 10
a try catch block to this code for more fine-grained error handling.
1 1 Simple 3
3 1 Simple 10
- (E - - -
) v - & 2 1 Simple 15
Repair 1 1 Simple 4
2 1 Simple 9
Add a structured error hander to trap and ranage error conditions. 1 1 Simpl 3
et ple:
i 1 1 Simple 4
. DoRandom
Wisual C# MET example: z=() A A Simple M
o 1 1 Simple 3
?ubhc wioid foof) 3 | Simple 19
try 22 Fomi 2 1 Simple 5
5% SwapEm() 1 1 Simple
[T

&3¢ Fomt 22 Fom1

5% RandomizeBn_Cick() BubblaSarBtn_Cick()

22 Fomi

5% QuicksonB_Cick{)

&2 Fomi

5% Updst=Siot)

& Fomt

L_ Call Graph pane — graphically shows method call tree
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Coverage, Memory, and Performance Analysis

Coverage, Memory, and Performance Analysis DevPartner toolbar buttons for Coverage, Memory, and Performance
Determine application test coverage, analyze an application’s use of memory, and profile

application performance. Select analysis preference

General and Data Collection Properties Coverage Analysis — // Performance Expert

Performance Analysis

The following data collection properties apply to performance, coverage, and memory analysis. Iﬁ, - @: - &3' - - E@ -
N . . / \ .
Property Default setting Error Detection with Coverage Memory Analysis
Automatically Merge Session Files Ask me if | would like to merge it -
Collect information about .NET assemblies True Set DevPartner Options
Collect COM Information True
Exclude Others True
Instrument inline functions True Native C/C++ Instrumentation
Instrumentation Level Line Enable/disable instrumentation

Track System Objects True \ —=
Performance ar coverage a -
Choose instrumentation type //

Performance and Coverage Analysis Session Toolbars

) View Call Graph
Performance Session toolbar

/_@j ==y | SpeedBumnp.Driver.Forml, . ctor -
Compare sessions \

Find method in source code

Coverage Session toolbar

SpeedBump.Driver . Forml, .char -
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Coverage Analysis

Coverage Analysis Results Summaries

DevPartner displays results for coverage analysis in Visual Studio or in the Coverage Analysis
Coverage Analysis Session Data Viewer. Session files present data in tabbed format, including the following tabs:

* Method List

¢ Source Code

e Merge History

e Session or Merge Summary

Filter the data view View coverage metrics for methods

05 lines executed (36.1%)
5] Source { 96.1% of 205 lines
(=77 Driver.exe { 95.4% of &
SpeedBump. Driver F
=7 Csharp,dil ¢ 96.4% of 14

20 of 22 methods called (30.3%) Merge coverage sessions and record merge history

Method List | Source{Driver cs]| Merge History | Merge Summary

%% spesdsump.Csharp. Method o, Cavered | allad # Lines
[E] Methods Mot Covered Mame .
=] Methads Less Than 20% Covered SpeedBump.CSharp. Form 1. ClearTiming{vaid) 0.0 s E2 of E5 lines executed [95.4;
SpeedBump. Driver Formi NativeCppBtn_Click{Object, EventArgs) 0.0

[E] Gver 30 Lines, Less Than 10% Cove View statistics for sessions or

—— E of 7 methods:

SpeedBump, CSharp, Farm 1, Dispase(Boolzan) 60,0
[ Remaved Methods SpeedBump. Driver Forml Dispose(Boolean) 200 .
SpeedBump. CSharp. Farm1.QSort(Int3z2, Int3z) 94.7 | Method List | Gource[Driver.cs]| Merge Histary | Merge Surmany merge file
SpeedBump.CSharp. Farm1. .ctor{void) 100.0
SpeedBump.CSharp. Form1 InitalizeComponent{yoid) oag | [ W0 B Lines Covered
SpeedEump.CSharp‘Forml.Forml_Loa_d(Ob]ectJ EventArgs) 100,0 B 3 Methads Covered
SpeedBump.CSharp, Faorm1 . DoRandomizelvoid) 100.0 a0 j— o
Sneedfimn.CSharn, Farm 1L indatesink k324 100.0
100.0 1) I 62 of B5 lines executed [95.47
I 135 of 140 lines executed (36.4%] .. :
) 100.0
b —— 6 of 7 methods called (85 7)
— 14 o 15 methods called [33.3%) (;; 13t°tEEV9E‘;WS) 133'3 70
fect, Eventrgs) bt Method List | SourcelDiiver.cs] | Merge History| Meige Summanys
Method List| Source(SpeedBump.cs] | Merge History | Merge Summary (Object, Evertirgs) 1000 0 DevPartmer - Coveroge Amalysis Sessien Smmrr =
Count Source ~ fooo
100.0 a0 staresa: 2/28/2008 5:32:17 PN
" " v Int3z nu us]; oid) 0.0 o Ended 2/28/2008 5:33:17 PN
100.0
sct, EveniArgs) 100.0 Executable: C:\SpeedBuap. Net\Driveribin\lelease\Driver. exe
Command hrgs:
H private Pen whitePen = new Pen(Color.White, l); Eventaras) 100.8 &0 Exit Code: 0
5 private Pen blackPen = new Pen{Color.Black, l);
0 Processor Speed: 2992 Maz
# of Processors: 1
10 0F Version Microsoft Windows XP
o
driver3.dpcov f driver] . dpcov driverZ. dpcov driversnap|merge Hiscory
5 public Formli)
Driver3.dpeov
. . Driverl.apeov 2/28/Z008 51 PH Ramimistrator
View execution data for briverz. apeov 2/2872008 B hdwinistrator
I f d DriverSnapl.dpeov 2/28/2008 5:42:00 PN Administrator ~
5 InitializeComponent{); Ines or source code < k)
v
< b3
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Memory Analysis

Memory Analysis

Session Control for memory analysis

Memory Leaks session controls Force a garbage Pause real-time graph (data

collection collection continues) .
Start and Stop Tracking Take a memory leaks Choose process to profile
potential memory leaks snapshot

DevPartner Memory Analy<sis

Leaks | ERAM — ] Graph shows state of managed
Memon Leaks | [alal{ay~ Erriporar jects . .
acy .}' lm i Lo _ heap in real time
Iy View Memdiy Leaks £ | DT'wWLIE4R-053 - 348 [Driver.exe] |
[ System M [ Profiled M ) )
e r e Dynamically change the class list sort order
3 . .
= Class list dynamically updates to show
= what is in memory
&
=
0 Session controls tailored to type of memory
00:05:32 00:05:37 00:05:42 00:05:47 00:05:53 gE 02 .
o data collection
Elaps: =

Top 20classes by: | Tracked instance count v| RAM Footprint session controls:
Class name | Mamespace | Instance count | Size (hM | Tracked instance  © | Tracked size (bytes) | ~ UDcveartner Memory Analysis |
K.nownColor Syztem. Drawing 1.837 22,044 1.837 22,044 [8] Memon Leaks [E] RAM Foolpiirt IE Ty M |
Object(] System 575 52520 550 27,088 [EvienranFoopit 8] o :
wieakReference System 576 3216 545 8.736 G Vst AN Fontpn 11 [CIGBBASNT - 1448 (Dptimiz=chFE eve)
Stack Syztem. Collections 436 10,464 434 10,418
DeviceContest Systern windows. For 435 27,840 434 27776 . .
Inth ativetd ethods. POINT Sustem. Windaws.For 429 6,364 429 854 Temporary Objects session controls:
ClientUtils.\WeakRefCollection.  5ystem. windows.For 358 5.728 357 5712
Aoatl] 220 10020 230 10,080

& Memary Leaks I |=] RAM Footprint [ Temporary Objects I
In leak analysis, monitor Tracked instance ) . % [@View Temporay Objects  F1 11 [CIDBB4ENDT - 1248 (O ptimasdwi 8. cie)
count for objects that were not collected as Clear temporary object allocations

expected tracked to this point
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Memory Analysis Session Data

Results tailored to type data collection
¢ RAM Footprint

* Memory Leaks

e Temporary Objects

e Click Show Complete Details to view session data

Driver - RAM ..isSnap2.dpmem™

DevPartner Memory Analysis - RAM footprint analysis

Object Distribution

26,152 bytes
176836
bytes f,

. Profied |
] System

iecs
biects

Object distribution: user vs.
system objects
(RAM footprint only)

Analyze object

allocations in depth

Summary of most

allocations

Objects that refer 4 the most allocated memory

17,954
15,696
4,852
4,608
5,000 10,000 15,000 20,000

Live memory referred to by object (bytes)

Show Complete D etails

Methods that allocate the most memory

105,416

20,738

16,138
9,828
50,000 100,000

Live memory allocated by method (bytes)
Show Complete Details

Summary of most memory-intensive methods

Call Graph
Analyze the calling sequence of methods that —

memory-intensive object

25,000

150,00

allocated memory. Answers the question: Who
allocated all that memory?

d

Memory An

4%

DevPatner Memory Analysis - RAM footprint analysis

| optimizednfb -1.. ok d | optimizedwfb - t...t analysis2 dpmem |

Objects that refer o the mast alocated memory

=)

=& CT0BB4SNDT (937 %)

% ssembly - Opti

[Object

=5 CAPiogiam Fles\Comp | Regiontis?
=" AppDamain - Optim [,

| Namespace | Referenced size (bytes)
Compumere DevPariner. Exa 42,404
40,932

278
Spstem Configuration Config 104
ObiectH2305ting Table  System 12,959 161
] | ListBox lteménay#it System Windows Foms 6376 270 =l
=< Il = Restinstancesof _
it - o
va i L
- Wy = quer
contml__—— 22,89

i wls

T
& windo >
B ControlW2 5 1
*® @ 8
_'l_I

taget
I
0 Graph [ Allocation Trace Graph | Soufe

30,000 35,000

Driver - Leak...sisSnapd.dpmem

DevPartner Memory Analysis - Memory leak

Jump to the allocating source line from any
method or object to edit source code

Driver - RAM .. isSnap2.dpmem &

Methods that sllocate the most lesked memory

—

alysis

Drill down sequentially from any
object in the list to examine

« | Referenced ohjects - .
m ’ EI/ referenced objects
512

Object Reference Graph

Trace object references back
to the garbage collection roots
that prevent objects from
being collected. Answers the
question: Why is this object
still in memory?

= B DTWUBaM-053( 100, 4 | [Method name | Nemespac | Execution c| Leakedfize (b | Leaked size (% | Leaked sizz . | Leaked size including chiren { | #
= [5h C\SpezdBump Ne || Fount StantTimi SpeedBu 7 34 16% 384
= B AppDomain -0 || ot uickSor SpeedBu 4 0 0% 44
=% At - | Eo) NafiveCp SpeedBu 1 1712 20% 1712
e ASSEDW";E'Z'* Fom’ Inilisize  SpeedBu 2 4256 00% 4,256
2l v Form1.ctorlvoid SpeedBu 438 21% 4534
< | SpesdBu 174 553 6013

< | )|

Call Graph | Source

E
6% Form1.ctor(void) 7% S FormLlnitilizeCon. |
53% 100.0%
ss
(19 S FormL.QuickSortBt... —
0% e
0a%
0o = FormLBubbleSorts...
0% e
= FormLRandomizes.. |
0% e

[T Drill down from any method in the
list to examine allocated objects,
and the objects they reference
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Performance Analysis

Performance Analysis Session Data

Filter the data view

Locate methods in source code

View performance metrics for methods

View session statistics

Performance Analysis

Results Summaries

DevPartner displays results for performance analysis in Visual Studio or in the Performance
Analysis Viewer. Session files present data in tabbed format, including the following tabs:

* Method List
¢ Source Code
e Session Summary

Method List | Sowce [SpeedBump.cs]| Session Summary
Drierl.dpprf* - Driver.dpprf& x 5
= Al { Madules: 30 Methar | bethad List | 5 ource [SpeedBurp.cs]| Session Summary Bussis session: Cx\SpeedBump, NetiDriveribin|ReleaseiDriver. dpprf &)
M) DTWLIB4M-053 - 11 . = -
Method %a in “a with called | 9% in Methad % with Children Average Average with Children
o, ;
3 Source (0.3% ] Mame Methad Children ale LercellE)
=0 f;ham'd:( Speedsnp. CSharp. Form1 Updateslot{Intaz) 0.1 3.5 97,632 3.7 I
 3peeddl | opecdauinp. Charp. Farm? SwapEm{Int32, Int3z) 0.1 35 94,632 3.2 i I
=] Driver.exe { SpeedBuryp. CSharp.Form? BubbleSortBtn_Click{Obj... oo 3.4 4 23,165.8 Method %in % with ~
“% Speedd | SpeedBurp, Driver.Form1,.ctor(void) 0.0 1.1 1 45,4626 Hame Method | Chidren | Colled |Average (us)
%)= System { 99.7% | SpeedBump.CSharp.Farml . .ckor(void) — = — CSharp.Form1 UpdateSiot(Int32) 0.1 2.7 93,832 38
Top stk | S o e Sencukm] T, e i NI B
) - % il -~ peedBumnp, CSharp, Farm1.BubbleSortBtn_Click(Object, Eventhrgs . . L 168,
Top 20 Methods Speedfim Drlver.Fnrml.InltlahzeCnrqp (Gl v Giltin TloE(b) | Setes SpeedBump, Driver Form1,.ctor{void) 0.0 0.8 1 46,4994
Top 20 Called Source p | 2PesdBumpACSharp Form1 DoRandorriz Spesdunp.Cohatp. Form., car(oid) 00 o1 3 osel
P Speedsump.\-Sharp Form 1 Updatealiive private void QuickSortBtn_Click(object\sender, System SpeedBump. Coharp. Form1 .QSort(Int 32, Ink32) 0.0 01 2,3% 63
Top 20 Called Methods Sneedsumn. &Sharp. Form 1 InitiglizeCom SpeedBump, Driver Form1 InitializeComponent (void) 0.0 0.3 1 14,867.8
P P P SN 1 Coharp, Form 1 DaRandorize(void 0.0 01 3 5557
SpeedBump. 45harp.Farmi QuickSortBtr 4 0.0 T4 SpeedBump, CSharp, Form1 . InitializeComponent{void) 0.0 0.1 3 793.8
SpeedBurnp, CEharp,Form1, EndTimingi 3! 4 oo 23,748.4 BubbleSortBtn.Enabled = false; SpeedBunip. Driver Forml MativeCppBtn_Click{Object, Eventargs) 0o 0o z 1,241.5
SpeedSump. Driver. Form1 .CSharpBtn_C| 4 0.1 324,423.0 QSort {0, numElems-1]; Speejﬁump CS:arp FUrml.EndE\ng(StnmI;)k( . , 0.0 0.0 8 293.4
. e 4 0.0 71.310.9 if (blecdUpdate) Updatesll(]; SpeedBump. Coharp. Form? QuickSortBtn_Click{Object, EventArgs: 0.0 0.1 4 5862
SpeedBump. Driver.Form1, Main(void) N oo 24 2118 BendemizeEtm. Enabled < trues SpeedBunp. CSharo. Farml UpdateAllvoid) 0.0 011 192.0
SpeedBumnp, Driver, Form1,MNativeCppBtn a 0.0 a’zs;,n EndTiming("Quick Sort:"); SpeedBump.Driver.Form1.CSharpBtn_Click{Object, EventA... 0.0 12.2 3 688.1
SpeedBump. CSharp.Form1 Randomizef 3 oo s \ b i value 0.0 226 1 k0
erence -
SpeedBurp, CSharp.Farmi . Farml_Load Z percent change o o .
SpeedBurnp. CSharp.Form 1, StartTiming(! private void BubbleSortBtn_Click{object sender, Syste: e = - o = T
SpeedSump. Driver. Form1 . Dispose{Boole { .
SpeedBumnp, Driver.Form1,Forml_Load(t 3 ﬁ'ﬁ ;’ifi': Eﬁfiizﬁzﬁ é::;?z Method List | Source [Diiver.cs]| Session Summary C iond
_o] x P — DevPartner - Performance Aaalysis Session Swmmry ~ ompare session data to
= Int32 i, j; i
00 % — for(i = mumElems - §|Starced: 2/29/2008 9:13:01 AN assess |mpaCt of code changes
{ Ended: Z/29/Z008 9:71:18 AM
=l SpeedBump.CShamp.F _ 950 % = Speedbump CohamF_ 985 % for{j = 0; j<=i
H 159 14 5% { Executable: £:YEpesdBump MeriDriveribinkeleassiDri
e if (Elementq|Command hrgs:
= 1% SwapEn (] [Exit Code: 0
¥
02% 5 Gysem. For } Processor Speed: 2992 Mhz
% - H if (bNeedUpdate] Up|# of Processors: n
0s Version: Microsoft Windows XP
0.1%
# of Called Methods (with thread scares): 3,725
§ of Calls: 12,069,849
0% =/ Speedbump CShapF_ | Toral Timing: 325,693,539, 8 Microssconds
12 %
00 % . DTWLIB4M-053 - 1116 (Driver)
Explore calhng Humber of Called Methods: 2,728
Percent of Time Spemt on Machine: 100.0
0% % Sposdbump CShamF_ sequence of methods
23% & ) 3 . Instrumented Source Images
and identify critical path
0o C8harp. A1l
Al Number of Called Methods: 14 4
4 3 K > < B
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Performance Expert

Performance Expert Performance Expert Session Controls

Results Summaries

DevPartner displays results for Performance Expert in session files. Session files present data in Window shows last 30 sec-
tabbed format, including the following tabs: onds of application activity.
e Call Graph Spikes in the graph indicate
e Call Tree Take a data snapshot - potential trouble spots.
e Methods table Clear data collected earlier in

this session
e Source code
e Call stacks

DevPartner #erformance Expert

T T T T T 1
00:00:09 00:00:14 00:00:19 00:00:24 00:00:29 00:00:34 00:00:39
Elapsed time
N P (process time) MMM Disk (bytes transferredsec) I Metwork (bytes transferred)sec)

0\81 .0 % of methods executed

Percentage of application code analyzed
during session

DevPartner Studio Quick Reference - 13



Performance Expert Session Data

Click individual method for Methods analysis

(without children)

Click entry point method for Path analysis

(with children)

Call Tree tab shows impact of
disk, network I/0, and wait time

Performance Expert

Call Graph tab highlights critical
path and expensive child methods

Icons indicate type of activity in method: disk,
network, or lock wait time

Paths that use the most CPU ; i
athsthatuse the mo = || Bars show time in
Form.M 10,418,100.0 | s ; :
ormtan i method vs. time in
Form. CtoF 9,815,903.0 |4 & 8 Farrn.Main Forrm. CtoF Service, CtoF I Chl|d methods
35,1 % 7%
Service, ChoF 7,426,693.0 10 & B = = J o /
o L —— 1
Service, .chor 2,386,806.0/ L4 = 16% 243 %
Form.ParseOption 163,456,4 E slawest metheds siong sl
] ralled paths Farm,ParseCption Service, . chor
Form,FtoC |26,761.4 .4, Service.CtoF 03% 3
0.0 CPU time in method (microseconds) 10,418,110 - Service. .ctor A I I —'| Select a method to
Individual methods that use the most CPLI ! Form.ParseCption update source and call
) § , Service Froc Form.FtaC Service FroC
Service ChoF 7,426,695 L) 4 ' 2% 4 stack tabs
Service, ctor 2,367,005, 1 ! Form. CtoP [ e—) ——
Form.Main [f11}780.0 Method Execution count | Disk activity (bytes transfe... | Wait time (us) | Disk regf count | [
Form.ParssOption [163,656.9 \ 245 I Methods table
Service. FtoC [25,747.0.4 Service..ctor 2,337,093.0 4 657,372 102 shows impact of
Form, CtoF2,314.6 Forrn,Main 411,780.0 1 0 X 0 disk, network I/0,
0.0 CPU time in method (microseconds) 7,426,695.0 Formn, Parse0ption 163,658.9 4 0 0.0 0 and wait time
Service FtoC 25,747.0 2 o 999.2 o
. Forrn, CkoF 2,314.6 2 o 0.0 o s
}/‘\‘ 43,8 % of methods executed Tatal elapsed time: 10,418,100.0 ps Tatal execution time: 10,418,100.0 ps £ | > -
Select method in stack to locate Double-click a line in a source display to edit in Method detail for: Service, CtoF Choose metric
source line that called child method Visual Studio Source | cal Stacks |
|CPU time without user children (us) j For each ling in Service, ChoF
Source | Call Stacks | 7,426,672.0 0.0
Call stacks showing paths that called EntryPointsiain, B 52 ¥ ~
xH
o o L . . 54: N =remarks)=
|82'5 ¥o - Call stack 1 / j (82,5 % of total time in mefhod is caused by this call stack) 55; [Svstem.web, Services. Protocols, SoapDocumentMethodattributed"http: / ftempuri, org/Ct
L . . S6; public System. Double CkoF{System.Double c) { Source tab shows
| Method | Lfne | LocaFlon in so.urce where/Programnder Test, EntryPoints, EntryPoints ey obiect{] results = this. Irvvoke{"CtoF", new obisct[] { !
ProgramUnder Tes 2? it (‘:Bi?lnDeDT=/nu") 56 o v most expensive
Pr Lnde P | ' < | 3T line for selected
ProgramUnder Test.Entry : else R
ProgramUnderTest. Entry... 18 63! B{10); 1= metric
£ >
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Using DPAnalysis.exe

Use DPAnalysis.exe to run coverage analysis, memory analysis, performance analysis, or
Performance Expert sessions from the command line. DPAnalysis.exe accepts command line
switches or an XML configuration file.

Command Line Operations

Use this syntax to run coverage, memory, performance, or Performance Expert sessions from

the command line:

DPAnalysis.exe

[a] {b} {c} {d} [e] target {target args}

DPAnalysis.exe requires Analysis Type and Target Type switches. Other switches are optional.

The following table lists the switches used with DPAnalysis.exe:

Category

Switches

Category

Using DPAnalysis.exe

Switches

[a] Analysis Type

{b} Data Collection

/Cov[erage] - Sets analysis type to DevPartner coverage analysis
/Memlory] - Sets analysis type to DevPartner memory analysis
/Perfl[ormance] - Sets analysis type to DevPartner performance analysis
/Explert] - Sets analysis type to DevPartner Performance Expert
/E[nable] - Enables data collection for the specified process or service
/Dlisable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use
the /D switch to disable profiling.

{c} Other Options

{d} Analysis Options

[e] Target Type

/O[utput] - Specify the session file output directory and/or filename
/W[orkingDir] - Specify working directory for the process or service
/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start
/N[ewconsole] - Run the process in its own command window

/F[orce] - Forces profiling for coverage or performance of applications written
without managed code or CTI.

/NO_MACHS - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (performance
analysis only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods
(coverage and performance analysis only)

/NO_OLEHOOKS- Disable collection of COM
/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (memory analysis
only)

Identifies target that follows as either a process or service. Pick only one. All
statements that follow the target name/path are considered arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)
/S[ervice] - Specify a target service (followed by arguments to service)
/C[onfig] - Path to configuration file
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Configuration File

Use this syntax to run coverage, memory, performance, or Performance Expert sessions
through a configuration file:

DPAnalysis.exe /config c:\temp\ config.xml

The following table briefly describes the XML elements. See the DevPartner online help or the
Understanding DevPartner manual for more information.

Element

Description

Using DPAnalysis.exe

AnalysisOptions

Arguments

Excludelmages

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner properties
accessible from the Properties Window in Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner Coverage,
Memory and Performance Analysis properties accessible from the Properties Window in
Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. No default if omitted. Defines
images (at least one, no maximum) which, if loaded by the target process or service,
will not be profiled. No attributes.

Element Description

Host (Optional) For each Process or Service, zero or one. No default if omitted. Sets the host
machine of the target process or service. No attributes.

Name One required for each service. Provides the name of the service as registered with the
service control manager. This is the same name you would use for the system's NET
START command. No attributes.

Path One required for each process. Specify a fully qualified or relative path to the
executable. You can specify the executable name without the path if the executable
exists in the current directory. No attributes.

Process The configuration file must contain at least one Process or one Service element.

RuntimeAnalysis
Service

Targets

Specifies a target executable.
Attributes: CollectData, Spawn, NoWaitForCompletion, NewConsole

Required; one only. Defines the type of analysis and maximum session time.

The configuration file must contain at least one Process or one Service element.
Specifies a target service.
Attributes: CollectData, Start, RestartlfRunning, RestartAtEndOfRun

Required. One only. Begins a block of one or more Process or Service entries. Target
processes and services are started in the order they are listed in the configuration file.
Attributes: RuninParallel
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Error Detection

File Extensions Used by Error Detection

Category

Error Detection

Settings

Extension  File Type Description

.dpbcl Error Detection Session File This is the Error Detection log for the user's program
execution.

.dpbcc Error Detection Settings File This file contains the various settings for Error

.dpbcd Detection. The .dpbcd extension refers to the default
settings file created, while .dpbcc refers to a custom
settings file that has been saved separately.

.dpsup Error Detection Suppressions File This file contains the various suppressions for the user's
program.

.dpflt Error Detection Filters File This file contains the various filters for the user's
program.

.dprul Error Detection Rules File This is a database of the user's suppressions and filters.

Default Options (DevPartner Studio Professional and Enterprise Editions)
or Settings (Visual C++ BoundsChecker Suite)

Category Settings
General On Log events
On Display error and pause

Data Collection

Prompt to save program results
Show memory and resource viewer when application exits

Source file search path - based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

Override symbol path - Default: empty

Working directory (standalone only) based on the location of the .EXE
Command line arguments (standalone only) - Default: empty

Call parameter coding depth = 1

Maximum call stack depth on allocation = 5

Maximum call stack depth on error = 20

NLB file directory is based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

API Call Reporting

Call Validation

COM Call Reporting

COM Object Tracking

Off

Off

Off

Enable API call reporting. All selections are unavailable until you select this
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On
All modules (tree view). - Default when active: All selected

Enable call validation. All selections unavailable until you select this item
Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active:
On

API failure codes - Default when active: On
Check invalid parameter errors: API, COM - Default when active: both On
Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default
when active: All items selected

Enable COM method call reporting on objects that are implemented in
the selected modules

Report COM method calls on objects implemented outside of the listed
modules - Default when active: On

All components tree view - Default when active: All selected
Enable COM object tracking
All COM classes tree view - Default when active: All selected
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Category

Settings

Deadlock Analysis

Memory Tracking

.NET Analysis

.NET Call Reporting

Resource Tracking

Off

Enable deadlock analysis
Assume single process - Default when active: On
Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when
active: Off

Generate errors when: A wait is requested on an owned mutex - Default
when active: Off

Number of historical events per resource - Default when active: 10
Report synchronization API timeouts - Default when active: Off

Report wait limits or actual waits exceeding (seconds) - Default when
active: 60

Synchronization Naming Rules - Default when active: Don’t warn about
resource naming

Enable memory tracking

Enable Leak Analysis Only

Show leaked allocation blocks

Enforce strict reallocation semantics

Enable FinalCheck

Enable guard bytes; Pattern = FC; Count = 4 bytes
Check heap blocks at runtime: On free

Enable fill on allocation; Pattern = FB

Check uninitialized memory; Size = 2 bytes

Enable poison on free; Pattern = FD

Enable .NET analysis

Exception monitoring - Default when active: On

Finalizer monitoring - Default when active: On

COM interop monitoring - Default when active: On
PInvoke interop monitoring - Default when active: On
Interop reporting threshold - Default when active: 1
Enable .NET method call reporting

All types (tree view node) - Default when active: Selected.
.NET User Assemblies (tree view node) - Default when active: Selected

.NET System Assemblies (tree view node) - Default when active: Not
selected

Enable resource tracking
Resources tree view. All listed resources are selected by default

Error Detection

Error Detection Toolbar in Visual Studio
Start with Error Detection

Start with Coverage Analysis

Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis

Note: The arrows next to each button allow you to start with or without
debugging, depending on the default action of the button.

M - @ - &‘: = @. - @ Error Detection - | Fy

Native C/C++ Instrumentation Set DevPartner Options——|

Enable/disable instrumentaton ~——

Choose instrumentation type
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Error Detection

Error Detection Window Icons Used in the Results Pane
— Results Pane __ Details Pane Icon Description Appears in...
. - Memory Leaks Summary, Memory Leaks, and Transcript tabs
Summary, Memory Leaks, Other Leaks, Errors, .NET Displays long description of detected $ y Y Y P
Performance, Modules, Transcript tabs provide error; call stack information; reference 8y Other Leaks Summary, Other Leaks, and Transcript tabs
overview and detail about detected errors. count graph (see inset below).
x Errors Summary, Errors, and Transcript tabs
- - .NET Performance Summary, .NET Performance tabs
Tlpe Quantity Lucalu:u;l Paipter Error: Pointer 0x0012EES0, used as an - -« £
- argunient, is out of range; no longer within the buffer .
=1 X Movesble Memory Error 2 o variable & D00 2EE 7S [20) in furction al; Module Load Event Summary, Modules, and Transcript tabs
X Norzero lock count 1 API_Fre Painter_ArayParamE «Fange
X Dangling pointer 1 Painter_ LI ) )
Fiiriter Enor 1 Current Call Stack - Thizad 0 [C40108] | - Subroutine call Transcript tab
+ Pl S TSI Function ‘ File ;I
E1- X Pointet Unielated : : Pairter_ArayPaianEsfiange  PTRERRCPP | | Garbage Collection Event Transcript tab
- 3 Unrelated painter comparison Fuainter_ ExscuteFunction BugBench7Dlg ol
b+ X Read Overun OnTest BugBench?Dlg.cp . .
- X wiite Overrun | | _Af=DizpatehCrdisg cmdtarg cpp T Event Begins Transcript tab
. | | » OnCrmdhsg cmdtarg.cpp
E Summary | & Memary Leaks I 84 OtherLeaks 3¢ Errors |24 ¢ ETCMdMSG dlc‘core_cnp _»l_l *T Event Resumes Transcript tab
c:\program fileshcompuwaredevpartner studiohexamples\bugbench?mainptrer. cpp =
= 1 Event Ends Transcript tab
{ -
TTHY Reference Count View | Dbject Identity View |
inta[5]; d h I
int b G=E o= 5K i i
B LTI e e | 5 — Icons Used in the Details Pane
3L—u—u—n—u—n—n—\_ =
CATCH ipti
123456789 11 13 15 Icon Description
\ =l & Subroutine call
L icfRief - Thread 0 [020070] =l
Source Pane Fulnction | Fie | Line /Dffset| =] 1 Entry Parameters
ole32.dl Ox0001BDEF [ ]
. Crgatelnst; ip.h 570
Displays source code for the COp Inrone.Leak.  comen cep 121 Exit Parameters
det . . ExgouteFunction buabench?dia.cpp B35 [T]
etected error, if available. Orfrest bughench7di cpp san
_ahDispatchCmdMsg  cmdtarg.cpp 88
OrfomdMsg emdtarg.cop %5 o []* Return Value
L— Details Pane - Reference Count Graph % Property (default) for data types
Displays Reference Count View and Object Identity
View tabs when you select an Interface Leak in the & Property for data types

Results pane.
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Reference Count Graph Toolbar

Error Detection

Memory and Resource Viewer Dialog Box

Results Pane

Vertical Zoom Out
Vertical Zoom In Scale to Size
Horizontal Zoom Out Select Viewing Area
Horizontal Zoom In —|
= | o= |5

o

Program Error Detected Dialog Box

Error description

M Program Error, Detected - BugBench7.exe

Memary Leak Due to Free: Calling free causes a leak of address 0x023E 2888 (10) allocated by
malloc.
Current Call Stack - Thiead O [0x0405] | Allocation Call Stack - Thiead 0[0:0408] |
Function File: Line / Offzet
Leak_L eakFromFree leaker cpp B5
ErecuteFunction bugbench?dlg.cpp B35
OnTest bugbench?dlg cpp B39
micF0.dil 0x00018430
~
PE *p :
p = (PE *)malloc | sizeof [ PE ) )
p->ptr = [char *malloc| 10 ) » =
free (p )
CATCH
1 L
< | >
[ Explain ] [ hemany/Rezource Viswer ]
[ Dot shaw this enor dialag | This Fun v|
[[] Digfable event logging ‘This Fun v| [ Delug ] [ Halt ] [ Continue ]

— Call stack information

Tabs for multiple call stacks

— Source code for the detected error

Displays Memory, Resource, and Summary tabs

Memory Contents Pane

Stack Pane
3 DevPartner Error Detection Memory and Resource Viewer,
Location [combined] Thread |D Byte Count Address gEE%gggg gggggﬁg% d.e
manbua. main.con, DilMain - line 67 00574 Oxdbzaf [ fncE1cpan| osz41eso 5
iIFACE . atlcom b, ATL: ClomCreators class Unllrd 401 D:D5elcds| IncE1CDA4| fEEFEEEf Wiy
ATL:CComDbjectCacheds clags 0SE1CDAZ| oooooooo
{ATL:CComClagsFactany: »:Createlnstance - line 0SE1CDAC| oooooooo
1801 DSEICDEO| 00000000
IFACE. dll atleom b, ATL: CComCreator<class 00574 160 | 0x05elcde| fncE1cpE4| oooooooo
ATL"EEanbie:Rc\ass Ciiews > Createlnstance - 0S5E1CDER| fbEbfbOl G
line 1801 DSEICDEC| 04b91fc3 &.?
Function F. Line/0OL.
ATL:CComCreatorecla.  at 1am
ATL:CComModule: Ge... at.. 21
DG etClass0Object if... 72
ATL:CComCreataorccla.. 4t 1am
< | >
8 vemory 4 Resources | B surmary ]
citprogeam files\microsoft wisual studio 9.0%wvohatlmfchincludehatlcom.h
#pragma warning(push) -~
fpragwa warningi(disable: 6014)
/% prefast noise W3IW 459981 */ 13
ATLTRY (p = new T1l(pv)]
#pripoea warning (pop)
if (p !'= NULL)
d 2
< | »
Lie Mumber: 1801 |Shnwing alliterns vl l Help ] [ Save ] l Mark |and Close: ] [ Close

L— Source Pane

Displays source code for the
detected error, if available.

Mark and Close —

Click to mark existing allocations and close the
dialog box. Marked items will not be shown when
Memory and Resource viewer reappears.
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ActiveCheck and FinalCheck Error Detection

ActiveCheck

ActiveCheck™ analyzes your program and searches for errors in your program executable as
well as the dynamic-link libraries (DLLs), third-party modules, and COM components used by
your program. The following tables list the types of errors found with ActiveCheck error

detection.

Deadlock-related Errors

API and COM Errors

Error Detection

Memory Errors

Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memory block
Stack memory overrun

Static memory overrun

Deadlock

Potential deadlock

Thread deadlocked

Critical section errors

Semaphore errors

Resource usage and naming errors
Suspicious or questionable resource usage
Handle errors

Event errors

Mutex errors

Windows event errors

COM interface method failure

Invalid argument

Parameter range error

Questionable use of thread

Windows function failed

Windows function not implemented
Invalid COM interface method argument

Memory Errors

FinalCheck Compile Time Instrumentation - Deepest Error Detection

FinalCheck™ compile time instrumentation (CTI) enables Error Detection to find more errors
(memory leaks, pointer errors, data corruption errors, and so on) as they occur in real time.
FinalCheck finds these types of errors, plus all errors found with ActiveCheck.

Pointer and Leak Errors

.NET Errors

Pointer and Leak Errors

Finalizer errors
GC.Suppress finalize not called
Dispose attributes errors

Unhandled native exception passed to managed
code

Interface leak
Memory leak
Resource leak

Reading overflows buffer
Reading uninitialized memory
Writing overflows buffer

Array index out of range
Assigning pointer out of range
Expression uses dangling pointer
Expression uses unrelated pointers
Function pointer is not a function
Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free
Memory leaked due to reassignment
Memory leaked leaving scope
Returning pointer to local variable
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List of Available Keyboard Commands - Visual Studio

Command Action

Ctrl+Shift+O File > Open > Project
Ctrl+Shift+N File > New > Project
Ctrl+S File > Save Project
Ctrl+Shift+S File > Save All
Ctrl+Shift+F Edit > Find in Files
Ctrl+Shift+H Edit > Replace in Files
Alt+F12 Edit > Find Symbol
Ctrl+Alt+L View > Solution Explorer
Ctrl+Shift+C View > Class View
Ctrl+Alt+S View > Server Explorer
Ctrl+Shift+E View > Resource View

F4 View > Properties Window
Ctrl+Alt+X View > Toolbox
Shift+Alt+Enter View > Full Screen
Shift+F4 View > Property Pages
Ctrl+Shift+B Build > Build Solution

F5 Debug > Start

Ctrl+F5 Debug > Start Without Debugging
Ctri+Alt+E Debug > Exceptions

F11 Debug > Step Into

F10 Debug > Step Over
Ctrl+B Debug > New Breakpoint
Ctrl+F1 Help > Dynamic Help
Ctrl+Alt+F1 Help > Contents
Ctrl+Alt+F2 Help > Index

Ctrl+Alt+F3 Help > Search
Shift+Alt+F2 Help > Index results
Shift+Alt+F3 Help > Search results

Export DevPartner Data: Command Line Use

Export DevPartner Data: Command Line Use

You can use DevPartner.Analysis.DataExport.exe from the command line to convert DevPartner
coverage analysis (.dpcov), coverage analysis merge (.dpmrg), performance analysis (.dpprf),
and Performance Expert (.dppxp) session file data to XML.

Use this syntax to export session data to XML:

DevPartner.Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options}

Options
The following table lists the command line options for DevPartner.Analysis.DataExport.exe.

You can use an equal sign, a colon, or a space to separate an option from the value or values
you specify.

Switch Description

/out [put]=<String> Specify the local or remote output directory for exported XML
files. Creates the directory if the directory does not exist

/r[ecurse] Search subdirectories for DevPartner Session Files.

/f[ilename]=<String> Specify the name of the XML output file. Appends .xml to the name
specified.

/showAll Shows all performance and coverage session file data available in a

performance or coverage session file.
For example, if you export a performance session file with this option,
the resulting XML file contains both performance and coverage data

fI!Eli(sisc.)ption is not available for Performance Expert session files.
/wlait] Wait for input before closing console window.
/nologo Do not display the logo or copyright notice.
/help or /? Display help in the console window.
/summary Export Performance Expert summary data which includes a default

maximum of the top ten callpaths and the top ten methods that use the
most CPU resources. Use the /maxpaths and /maxmethods options to
override the maximums.

/method Exports Performance Expert method data.
/calltree Export Performance Expert call tree data.
/maxpaths=<integer> Used only with the Performance Expert /summary option. Exports the

specified number of the top call paths that use the most CPU resources.

/maxmethods=<integer> Used only with the Performance Expert /summary option. Exports the
specified number of the top methods that use the most CPU resources.
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