DevPartnerStudio Quick Reference

Print out all or portions of this document and keep it handy for quick reference (use a color
printer when available).

DevPartner Features

Use the links in the left column in the following table to locate reference information about
DevPartner features.

Use this DevPartner
feature

To solve this problem

Detect programming problems and naming inconsistencies Code Review

Diagnose run-time errors in the source code Error Detection

Locate performance bottlenecks in the application Coverage, Memory, and

Performance Analysis
Ensure code base stability throughout development and testing phases Coverage Analysis Session Data

Determine memory allocation in an application and get feedback to Memory Analysis
reduce memory consumption

More Information

Refer to the DevPartner online help or to the Understanding DevPartner manual for more
information.

Common Elements

The DevPartner software provides these common elements, regardless of feature.
DevPartner Toolbar

DevPartner Menu

DevPartner File Extensions

Command Line Instrumentation Options

DevPartner Menu and Toolbar

Accessed from the DevPartner menu or toolbar in Visual Studio.

Choose this menu or toolbar item

To

n Error detection

> Coverage Analysis
M
% Error detection and Coverage Analysis

#-5 Performance Analysis
A

Memory Analysis

E@ Performance Expert

&  Perform Code Review

Lo’

]

s

Error Detection Rules

Manage Code Review Rules

& . Native C/C++ Instrumentation

Native C/C++ Instrumentation Manager
Correlate
Merge Coverage Files

@ Submit TrackRecord defect

Perform run-time error detection using
BoundsChecker technology

Perform run-time code coverage analysis

Perform run-time error detection with code
coverage analysis

Execute run-time performance analysis

Execute run-time memory analysis

Execute run-time analysis with Performance
Expert

Perform static code analysis

Access code review rules management

Access error detection rules management,
used to filter or suppress detected errors

Perform compile-time instrumentation for:
Error detection, Error detection with
coverage, Performance or coverage analysis

Access the Instrumentation Manager
Correlate performance or coverage files
Merge coverage analysis sessions

Submit TrackRecord defect
See Note

Note: The Submit TrackRecord defect toolbar button is only available when TrackRecord is

installed.
& Options

Access DevPartner options
Choices include: Analysis, Code review,
Error Detection




DevPartner File Extensions
File extensions for session files.

Run this DevPartner feature To create this session file (extension)

Code review .dpmdb
Code coverage .dpcov
Code coverage merge files .dpmrg
Error detection .dpbcl
Memory analysis .dpmem
Performance analysis .dpprf
Performance Expert .dppxp

Command Line Instrumentation Options

NMCL Options

The following table lists the NMCL options that you can use to instrument your unmanaged
(native) C++ code from the command line. Use NMCL.EXE only to compile unmanaged C++
code with DevPartner performance and coverage or error detection instrumentation. NMCL is
not used with managed code, which DevPartner instruments as it is passed to the common
language runtime during execution.

Note All NMCL options must begin with a forward slash (shown in the following list) or
hyphen, followed by the letters NM. For example: /NMoption or -NMoption.

Use... To...

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not

have the directory that contains NMCL on your path.

/NMclpath:cl-path Specify the directory location of cl.exe. You can use this
option to bypass the installed location of DEVENV, or if

DEVENV is not installed.
/NMhelp or /? Display help text

/NMignore:source-file or Specify a source file or a method in a source file that should
/NMignore:source-file:method source-file not be instrumented

Common Elements

Use... To...
/NMlog:log-file Specify a log file for NMCL messages (default: stdout)
/NMnogm Ignore the CL /Gm (minimal rebuild) option if it appears on

/NMonly:source-file

/NMopt:option-file or
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn
/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

the command line. You can use this option to avoid a
known conflict between the NMAKE /A and CL /Gm
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual
command-line options, each on a separate line.

Specify pass-through mode, which instructs NMCL to call
CL without intervention. In this case, no instrumentation
takes place.

Stop NMCL if an error occurs during instrumentation. If this
option is not specified, the default behavior is to fall back to
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the
default setting.

Specifies instrumentation for performance and coverage
analysis.

Instruments methods that are marked as inlineable if inline
optimizations are enabled (using the /O1, /02, /Ob1, or
/Ob2 option)

Instruct DevPartner not to collect line information. When
you use this option, DevPartner does not display any line
data in the Source tab. You can also use this to improve the
time required to instrument and run your application.

Specify the directory location of the performance and
coverage analysis library files if you do not have the
directory that contains NMCL on your path.

When using NMCL, add the directory containing these utilities to your path. For example, if
you installed the product into the default directory, add the following directory to your path:

C:\Program Files\Common Files\Compuware\NMShared
Note: For installs on 64-bit versions of Windows, add the following directory to your path:
C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Common Elements

NMLINK Options Use... To...
The following table lists the NMLINK options that you can use to link your unmanaged (native /NMpass Specify pass-through mode, which instructs NMLINK to call
code) C++ application to DevPartner. LINK without intervention.
Note: All NMLINK options must begin with a forward slash (shown in the following list) or /NMtxOn Spefifies instrumentation for coverage and performance
hyphen, followed by the letters NM. For example: /NMoption or -NMoption. analysis.

/NMtxpath:tx-path Specify the directory location of the performance and

coverage analysis library files if you do not have the

Use... To...

directory that contains NMCL on your path.

/NMbcOn Use DevPartner Error Detection instrumentation. This is the

default setting. When using NMCL and NMLINK, add the directory containing these utilities to your path. For

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not example, if you installed the product into the default directory, add the following directory to
have the directory that contains NMCL on your path. your path:
/NMhelp or /? Display help text C:\Program Files\Common Files\Compuware\NMShared
/NMlinkpath:link-path Specify the directory location of LINK.EXE. You can use this . . . . . .
P P ogtior{to bypass ch installed location of DEVENV, or if Note: For installs on 64-bit versions of Windows, add the following directory to your path:
DEVENV is not installed. C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Code Review

Command Shortcuts for Rule Manager

Use the following keyboard shortcuts to enter Rule Manager commands:

Code Review

Command-line Switches Used in CRExport

CRExport.exe /<switch>

Switch

Function

Command Action

Ctrl+A Rule > Select All Rules
Ctrl+C Rule > Copy Selected Rules
Ctrl+N Rule > New Rule

Ctrl+O File > Open Rule Set
Ctrl+P File > Print

Ctrl+V Rule > Paste Rules

F5 View > Refresh

Command-line Switches Used in CRBatch

CRBatch.exe /<switch>

Switch

Function

/f configuration file/file name

/v or /verbose

/vs "8.0" or /vs “9.0"

Informs CRBatch what configuration file
to use when reviewing a solution or
project

This switch is mandatory.

Instructs CRBatch to report errors in a
message box, and to set the exit code
used by batch procedures

Although this switch is optional, it is
useful if you want to physically debug
configuration files.

Indicates the Visual Studio environment
where the batch review will be
executed; choices include8.0 or 9.0

It is recommended that you use this
switch, most importantly if you have
more than one version of Visual Studio
on your system. If you do not include
this switch, DevPartner will default to
the latest version.

”

/f sessionfile

/e xml exportfile
/a

/ai

/p

/m

/n

/s
/c

/ci

Help — Displays this list of the available command line interface arguments.

Fully-qualified session file path and name — Identifies the session database to use
for this export. (Mandatory)

Fully-qualified export file path and name — Identifies the XML file to receive the
exported data. (Mandatory)

Export all session data — Exports all data for the specified session, including the
outbound methods for call graph data. Inbound methods are not exported.

Export all session data with inbound methods — Exports all data for the specified
session, including inbound and outbound methods for call graph data.

Export problems data — Exports the problems data for the specified session.
Export metrics data — Exports the metrics data for the specified session.

Export naming analysis data — Exports the naming analysis data for the specified
session.

Export code size data — Exports the code size data for the specified session.

Export call graph data — Exports the outbound, or called, methods in the call graph
data for the specified session.

Export call graph data with inbound methods — Exports the call graph data,
including inbound and outbound methods, for the specified session.
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Code Review

Code Review Default Options (General Node) Description Default
Include naming analysis for All identifiers selected

Category Settings Company name

Projects to be reviewed All projects selected (C# and VB.NET projects only) Technology name

Rule set All Rules

Naming analysis to use Naming Guidelines (see below) Code Review Toolbars

Collect metrics On | 2 sy | | |

< > —
Collect call graph data on Print <current code review results> —¢ D8 |+ % .
) Hide/Show Solution Tree — | Submit TrackRecord
Always generate a batch file On i o ) )
Always save review results on Hide/Show Pescrlptlon Filter Current View
Prompt for session file name Off Mark Item Fixed Suppress Rule
Naming Guidelines =4 - JESH - JURR) - JREs - [ o | 5|
L Layout Perform a review of the solution code——

Description Default Scaling Create and modify rules used during code review.
What to analyze All public or protected identifiers Node style

Choose dictionary American English Number of levels
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Code Review Summaries

Summary of Problems *

Type Problems

Names Total | Fized
COM Interop 1 o
Database 1] 1]
Crate o o
Dresign Tirne Properties o o
Error fException Handling 21 o
Garbage Callection o o
Internationalization 1z o
Language a a
Logic 2 a
Maintainability 13 i}
Performance 1 ]
Portability 1} i}
Project 2 Solution Properties a o
Reliability i} i}
Security 3 o
Standards ] 1]
Systermn a o
Usability 1} i}
Uszer-Dafined Rule ] 1]
Wersioning a 1]
findows APT ] 1]
Tetals 33 o

* Summaries include all rule violations. Your flter settings da not apply.

Severity

High |Medium | Low

1]
1]

o
o

o | =

Wl le|le|le|le|le|e|le|la|le|le|la|n

0

ol ol ool ololo|lo|lo|lao|lw

23

Warning
1
o

11

Code Review

Summary of Counts

| Summary Type Count
Review Time (in rminutes) 1.212

Total Lines (including blank lines) 2,183

|C0de Only Lines 1,162

|C0mment Only Lines 270

Code with Camments 1]

Rule Comparisons Made 468,267

Total Lines Checked 2,183

Review Settings

Review Settings Setting Yalue
Solution SpeedBump.Net2005

Cihpd_MHT-HMSource 1666_MHT1015 15001

Solution Path \DPSYOP_Mainline\Analysis\Examples\SpeedBump MetSpeedBump Met2005 sin

Cihpd MHT-MNMSource1666_MHT101515D01

Session File \DRSVDP_Mainfine\AnalysistExamples\SpeedBump. MetiSpesdBump Net2005 DRMDE

Ciipd MHT-HMSource1666_MHT101515D01
Y

Esteh Command Exscution File ARSI A simlinad Amalnin E il Emmn AT vmmms RLABYED Smm ADs e KIAb3OAE BAT

Project List
Project Name Compile Errors Reviewed Project Path

Cihpd_MHT-MMSaurce 1BBE_MHT 101515001

Delver2003 s s \BRSDP_MainlinelAnalysis |Examples\peedBurmp Het\Priver\Driver2005.csproj
14 MHT-MMSaurcs 1665_MHT 101515001
iy i e \PPS\DP_Mainlinelanalysis{ExamplesiSpeedBump.MetyCSharpiCSharp2005 csproj
Cripd_MHT-HMSourcs 1666_MHT 101515001
WE2003 False e \DPSADR_Mairlinelanalysis\Examples\SpeedBurp . Met WEAWE 2005 vbpraj
Mekrics Analysis True
Maming Analysis Maming Guidelines
Dictionary Name American English
Summary of Call Graph Data &
[ Summary Type Count
[Tatal Methods Graphed 24
[ Total Methods Uncalkd 0
TG A T sUppeS
Call Graph analysis True
Igners compile errars Fale
Enclude rules that require  build Fale
Ay generste a batch file True
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Code Review Results Panes

iummar}/ﬁfblems Marning } r‘ﬁetncs. Call Graph

Problems pane — displays rule-based programming problems

Fi... | Suppressed Rule @ Title Sev...
Fi 1050 Struckured error handler not Found Low
(] 1619 Braces should nat be optional for co...  War. .
D 1622 Use spaces instead of tabs Wat,.,
D 1619 Braces should not be optional for ca...  War...
|:] 1050 Structured error handler not Found Low
<

Praject
CSharp
CSharp
iZSharp
CSharp
Sharp

File

SpeedBump.cs
SpeedBump cs
SpeedBump cs
SpeedBump cs
SpeedBump.cs

Method
Updatesiot
Updatesiot
Updateslat
Updateal
Updateall

Structured error handler not found

Trigger: Detected no structured exception handling at this level [Occurrences:1

Original Source Line: private void UpdateSlotInt32 iSlot)
Location: SpeedBurnp.cs

Explanation

A structured error handler was not found in this Visual Basic \NET procs
a try catch block to this code for more fine-grained error handling.
Repair

Add a structured error handler to trap and manage error canditions.
Wisual C# JWET example:

?ublic woid foog)

try

F R e

“wiews by all

iummary‘ Eroblems-'ﬂaming Metrics ~'Call Graph 4

=T

& Fomt

5% RandomizaBin_Cick()

22 Fomi

5% QuicksonBun_ Cick()

Class Tvpe

Viewby Wariables

Code Review

Naming pane — lists .NET naming violations and offers suggestions

Summary |“Eroblers +Naming | fetrics [Call Graph |

Ficed Name
| Elements
(] bheedUpdate
(| i
O r
O itidval

Suggested Acce:
elements Private
needUpdate Private
See Explanation Local
See Explanation Local
See Explanation Local

Current Name: r

Summary | Problems ics | Call Graph |

Metrics pane — provides code complexity statistics

4
4 b

&2 Formt

5® DoRandomas()

22 romi

5% qzenl)

&2 Fomt

5® BubblaSontin_Cick()

Formi
5% SwapEm()

2 Fomt

5% Updsi=al)

Method Fils Project Complexity Biad Fix % Understanding Lines of Code

5

= ¥BubblesortBtn_Click SpeedBump... CSharp g g Simple ko moder...

¥ CSharpBtn Click  Driver.cs Driver 1 1 Simple 4

S¥NativeCppBtn_Click  Driver.cs Driver 1 1 Simple 3

WForml SpeedBump, .. CSharp 1 1 Simple: 16
1 1 Simple 2
1 1 Simple 1

qpr 2 1 Simple: 5

3 1 Simple 10
1 1 Simple 3
3 1 Simple 10
2 1 Simple 15
1 1 Simple 4
2 1 Simple 9
1 1 Simple 4
1 1 Simple 4
1 1 Simple 9
1 1 Simple 3
3 1 Simple 19
2 1 Simple 5
1 1 Simple

&2 Fomt

5% Updst=Siat)

L_ Call Graph pane — graphically shows method call tree
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Coverage, Memory, and Performance Analysis

Coverage, Memory, and Performance Analysis DevPartner toolbar buttons for Coverage, Memory, and Performance
Determine application test coverage, analyze an application’s use of memory, and profile

application performance. Select analysis preference

General and Data Collection Properties Coverage Analysis — // Performance Expert

Performance Analysis

The following data collection properties apply to performance, coverage, and memory analysis. Iﬁ, 5 @: -, &3' = = E@ 7
Property Default setting Error Detection with Coverage Memory Analysis
Automatically Merge Session Files Ask me if | would like to merge it
Collect information about .NET assemblies True H“\ Set DevPartner Options
Collect COM Information True
Exclude Others True
Instrument inline functions True Native C/C++ Instrumentation

Instrumentation Level Line Enable/disable instrumentation

Track System Objects True \. - §
Perfarmance or coverage a -

Choose instrumentation type

Performance and Coverage Analysis Session Toolbars

) View Call Graph
Performance Session toolbar

/L—bﬁ| = . SpeedBumnp.Driver Forml ., ckor =
Compare sessions \

Find method in source code

Coverage Session toolbar

SpeadBump.Driver,Form1, .ckar -
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Coverage Analysis

Results Summaries

DevPartner displays results for coverage analysis in Visual Studio or in the Coverage Analysis
Coverage Analysis Session Data Viewer. Session files present data in tabbed format, including the following tabs:

* Method List

¢ Source Code

e Merge History

e Session or Merge Summary

Coverage Analysis

Filter the data view View coverage metrics for methods

05 lines executed (36.1%)
N Source {96, 1% of 205 lines
=77 Driver.exe { 95,4% of 68
SpeedBump. Driver F
= Charp.dil { 96.4% of 14

20 of 22 methods called (30.3%) Merge coverage sessions and record merge history

Method List | SourcelDiiver. cs]| Merge History | Merge Summany,

% spesdsump. Csharp. Method P | m #lines |
Methods Mot Covered i .
=] Methads Less Than 20% Covered SpeedBump.CSharp. Form 1. ClearTiming{vaid) 0.0 —— E2 of BB lines executed (95,433
SpeedBump. Driver.Formi MativeCppBtn_Click{Object, EventArgs) 0.0

Gver 30 Lines, Less Than 10% Cove

—— G of 7 methods View statistics for sessions or

SpeedBump. CSharp, Farm 1, Dispase(Boolzan) 60.0
Removed Methods SpeedBump.Driver.Form1,Dispose{Boolean) 80,0 3 .
SpeedBump. CSharp, Form! .QSork{Ink32, Int32) 94.7 | Method List | Source[Driver.cs]| Merge History | Merge Summary merge file
SpeedBump.CSharp, Farm1. .ctor{void) 100.0 | i = '
SpeedBump. CSharp, Form1  InitializeComponantivoid) oo, | [ THD M % Lires Covered
SpeedBump. CSharp, Farm1.Forml_Load{Object, Eventargs) 100,0 M Methods Covered
SpeedBump.CSharp. Form 1. DoRandomizelvaid) 100.0 a0 ik
Sneedfimn.CSharn, Farm 1L indatesink k324 100.0
100.0 a0 —— 52 of 65 linec executed (35.45
—— 135 of 140 fines executed (35.4%] 2) 1DD.D
¥ b i — 6 of 7 methods called [85. )
—— 14 015 melhods called (93.37) (;; 13t°tEEV9E‘;WS) o0 e
fect, Bventirgs) i Method List| Source{Diiver.cs]| Meige History | Merge Summay
Method List| Source[SpeedBump.cs] | Merge History | Merge Summary (Objsct, Eventargs) 0.0 60 DevPartner - Coverage Analysis Session Summary -
Count| Source -~ 100.0
- - 100.0 0 starced: 2/28/2009 §:32:
: e T s 3 1000 Ended: 2/26/2009 §:33:
- z 100.0 40
sct, Eventargs) 1000 Executable: C: % SpeedBunp. Net\Driver\bin Release\Driver . axe
¢ Command Args:
H private Pen whitePen = new Pen{Color.White, li; Eventérgs) 100:0 a0 Exit Code: 0
5 private Pen blackPen = new Pen{Color.Black, l);
' 20 Processor Speed: 2992 Mhz
# of Processors: 1
10 0F Version: Microsoft Windows XP
. o
driver3. dpcoy £ driver] dpcov driverZ dpcov driversnap|terge History
5 public Formli)
Driver:.dpeov
. . Driverl.apcew 2/z8/2008 PM Raminiserator
View execution data for briverz. apeov 2/28/2008 P hwinistrator
l f q Driversnapl.dpcov 22672008 100 PM Aduinistrator ~
5 InitializeComponent (}; Ines or source code L 2
v
< >
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Memory Analysis

Memory Analysis

Session Control for memory analysis

Memory Leaks session controls Force a garbage Pause real-time graph (data
collection collection continues)

Start and Stop Tracking Take a memory leaks Choose process to profile

potential memory leaks snapshot

DevPartner Memory nnalysus

Graph shows state of managed
heap in real time
|-
[ System M [ Profiled Memoary . )
e remea e Dynamically change the class list sort order
g . .
= Class list dynamically updates to show
= what is in memory
&
=
0 Session controls tailored to type of memory
00:05:32 00:05:37 D0:05:42 00:05:47 00:05:53 Le6 02 .
: data collection
Elapseg i
Top 20 classes by: | Tracked instance count ¥ RAM Footprint session controls:
Class narne | Namespace | Instance count | Sizw | Tracked instanice © | Tracked size (hytes) |l i -
E.riownColor Sustem. Drawing 1.837 22,044 1.837 22) E|44 [@] Memon Leoks | [&] RAM Foolpink IE T TETTS |
Object(] System 575 53520 550 27.088 TEvienFanFocpt. 0] o -
wieakReference System 576 9216 545 873 el ool 1 [EIGBEASH - 148 (Dptimiaedh/FE cve)
Stack Syztem. Collections 436 10,464 434 10416
DeviceContest Systern wWindows.For 435 27,840 434 27776 . .
Inth ativetd ethods. POINT Sustem. Windows. For 429 6,964 429 6884 Temporary Objects session controls:
ClientUtils.\WeakRefCollection.  System windows.Far 358 5.728 357 5.712
Hoat] 250 (G 220 1008088
& Memary Leaks I | RAM Footprint [ Temporary Objects I
In leak analysis, monitor Tracked instance ) . x [@ViewTemporay Objects  F1 11 [CTOBEAENDT - 1248 (O ptimasdw . cse)
count for objects that were not collected as Clear temporary object allocations

expected tracked to this point
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Memory Analysis Session Data

Results tailored to type data collection

¢ RAM Footprint

* Memory Leaks

e Temporary Objects
L]

Driver - RAM ...isSnap2.dpmem™

DevPartner Memory Analysis - RAM footprint analysis

Click Show Complete Details to view session data

Analyze object
allocations in depth

Summary of most

allocations

Objects that refer to e most allocated memory

i S,
s L e
S e
e 17,954
o e
, o, 15,696
g, 4,852
Object Distribution b 4,608
0 5,000 10,000 15,000 20,000 25,000
Live memory referred to by cbiect (bytes)
Arzs_wsz bytes Shouw Complste Detils
753 = T —
ies 5, ethods that allocate the most memory
NG
Ty g, Oy %
c%%’ o,
LN
g, ony Y 105,416
AN
i ciece q%%og 20,738
yotem chjes
B, lr*/ 16,138
3
= 9,828
0 50,090 100,000 150,00

Object distribution: user vs.
system objects
(RAM footprint only)

Summary of most memory-intensive methods

Live memery allocated by methed (bytes)

memory-intensive object

BugBenchDOtN..sSnap5.d

BugBenchDoth,

| BugBsnchpot.

Memory An

ysisd. o [

DevPartner Memory Analysis - RAM footprint

Objects that refer to the mast allocated memary

Object

Unreachable Object
Obiect(}#25:5ting Table
Object]}#15:5ting Table
(Ibject]}#25:5ting Table
Stigel{ 46 Sting Table
biecH{[#13:5ting Table

Hamespace

<geronty
System
System
System
System
System

Referenced size (bytes)

+ | Referenced objects
6476

handlr

< |
bi

30,000 35,000

Driver - Leak...sissnap4.dpmem
DevPartner Memory Analysis - Memory leak

Eventhandlerli... hander =
2

= EventHandlers pars=: (-
32 {
b

g

EventHiandienss
)

Qbject Reference Graph | Alocalion Trace Greph | Sayfice

4716
1644
4352 a1
4210 110
4166 72

"

CheckBax#1
38

\_

Jump to the allocating source line from any
method or object to edit source code

Driver - RAM .. is3nap2.dpmem &

- x

Methads that alocate the most leaked memory

alysis

Drill down sequentially from any
object in the list to examine

Object Reference Graph

Trace object references back
to the garbage collection roots
that prevent objects from
being collected. Answers the
question: Why is this object
still in memory?

= B DTWLIBAM-053 (100, &
=-[Eh C:\SpeedBump Ne
= AppDomain - O
=g Assembly -
[ Drivera
=% ’A_isimnly ‘@
| >

Method name
Fam1 StartTimi
Fam1.QuickSor
Fam1 NativeCp
Fom.Inifialize

Hamespac
SpesdBu
SpeedBu
SpesdBu

Execution

344

0
1712
4256

caked size (b | Leaked size (% | Leaked size | Leaked size including chidren (| A

16%
0o
80%
200%

344
344
1712
4256
4634

16%
168%
80%
200%
220%

Shouw Complete Detaile

Call Graph

Analyze the calling sequence of methods that —
allocated memory. Answers the question:
Who allocated all that memory?

<

| 1) |

Cal Graph | Souce

7
4
1
2
2 438 21%
N .7 R N F M P
Al Drill down from any method in the

5% ~ Form1..ctor{void)
e 533
55%
2% % Form1.QuickSorte...
003
LR
2%

2 FormLiRandomizes...
0.0%

07% * FormLnitislizeCo..
Lt 100.0 %

e

2 FormlBubbleSorts...
00% &

list to examine allocated objects,
and the objects they reference
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Performance Analysis

Performance Analysis Session Data

Filter the data view

Locate methods in source code

View performance metrics for methods

Driyerl.dpprf*

Driver.dpprf2

View session statistics

Performance Analysis

Results Summaries

DevPartner displays results for performance analysis in Visual Studio or in the Performance
Analysis Viewer. Session files present data in tabbed format, including the following tabs:

* Method List
¢ Source Code
e Session Summary

E=EN\all { Modules: 30 Metho
4 DTWLIB4M-053 - 11
3£ Source ( 0.3%
= csharp.di {
“% Speeds
= Driver.exe
“% Speedm
- 3] System (99.7%
Top 20 Source Methods
Top 20 Methods
Top 20 Called Source M
Top 20 Called Methods

Method List | S ource [SpeedBump.cs] | Session Summary

SpeadBump.Driver....
0.0%

X L]
Method List | §ource [SpeedBump.cs]| Session Summary Basis session; €;\SpesdBump. Net\DriveribiniReleaselDriver. dpprf =
Method Yo it % with Caled || average (isy % in Methad 9 with Children Byerage Buerage with Children
Mame Method Children 4 o
SpeedBUmp. CSharp Forml, Updateslat(Int3z) 0.1 35 97,632 37 1] ¥ I
SpeedBufpp. CSharp.Form1, SwapEmiInt3Z, Ink32) 0.1 3.5 94,652 3.2 || .- 8 o o R I e
SpeedBurkp, CSharp.Farml BubbleSortBtn_Click(Obj. .. 0.0 3.4 4 23,165.8 i = =]
WMethod o in 6wt | e | average ws)
SpeedBurp, Driver.Form1, .ckor(void) 0.0 1.1 1 45,462 6 Mame Method Children &
SpeedBump. CSharp.Forml ,.ctor{vaid) — = B SpeedBump. CSharp.Formt, UpdateSiot(Int32) 0.1 7.7 08,832
speedBump, CSharp.Forml QSort(Int32 | Methed List| Source [SpeedBump.os] \session Summany ) gpeeggumugg:aru-gmm;EWS‘;:‘E?(l:EfLClFt&?b i g‘é 27 94,632
% i = peedBump, CSharp, Farml BubbleSorttn_Click{Object, Eventaras i
SpeedBum| Drwer.Forml‘InltlahzeCom_p Count % with Children Tipe fus] | Source SpeedBump. Driver Form1 .ctor{void) 0.0
SpeedBumplCSharp.Form! DoRandomiz Spesdeump, CSharp.FarmL. . ctar(vaid) a0
SpeedBump.\-Sharp. Form1 Updateallive private void QuickSortBtn_Click (object\sender, System SpeedBump. CSharp. FormL . QSorb(Int32, Int3z) 0.0
dBump Driver Form 1. InitislizeComponentvoid) 00
SpeedBump. §Sharp.Forml  InitislizeCom P pesilBing, P
= el ] i SpeedBump. CSharp. Forml DoR.andomizelvaid) 0.0
SpeedBump. 4Sharp.Formt . QuickSortBtr 1 0.0 33,1804 SpeedBump. € Sharp. Form1. InitializeComponent{void) 0o
SpeedBump, CEharp.Farm 1l EndTiming( Sl 4 0.0 23,7484 BubbleSortBtn. Enshled = false; SpeedBump Driver.Form1 NativeCppBtn_Click{Object, EventArgs) (illi}
peedBump. Driver.Form]  CsharpBtn_C| 4 0.1 334,423.0 QSort (0, mmElems-1); gneeggumngg:arn.iurmi‘EQndTgmth(‘tStmzlg)MOh _— g‘g
: ; h a4 0.0 71,310.% if (bNeedUpdate) Updatedlli): peedBump, CSharp.Form1, QuickSortBtn_Click{Object, EventArgs; i
gueeggumu-gryver-;wmi‘ma:j(vgld)Bt i g L i e e Speedounp. Charp.FomL Undateallvad) 00
peedBump, Driver, Faorm1, NativeCppBin 5 e e EndTiming{"Quick Sort:"); SpeedBump.Driver.Form1.CSharpBtn_Click(Object, Eventa... 0.0
SpeedBump. CSharp.Forml RandomizeE! a 0.0 5.3 ¥ basis value 0.0
SpeedBump. CSharp.Formi Farml_Load = diteience
it = percent change 0%
SpeedBump. CSharp.Form, StartTiming! private void BubbleSortBtn_Clicki{object sender, Syste 2 T T = v
Speedsump. Driver . Form 1 Dispose({Boole s G { L i IS = :
Speediump. Cri rmi Formi_Load(c - hSwrtmon. Enapro JHethod List| Souwse [Driver.cs]] Session Summay :
L} kSortBtn. Enabl
e DerPartner - Perfornance Analyeis Seosion Swmary =] Compare session data to

509 %

SpeedBump.CSharp.Fo
65%

0.0% RtlGetlastWin32Error
100.0 %

0.0%

00 % RtlAllocateHeap
100.0 %

#

System.Windows.Form....
01%

BubbleSortBtn. Enabl
Int3z i, i;

for(i =
% 1

mmElems -

for (3
{

= 0; je=i
if (Element.
SwapEmi

1

]
if (bNeedUpdate) Up

Explore calling
sequence of methods
and identify critical path

Started:
Ended:

Executable:
Command Args:
Exit Code:

Processor Speed:
# of Processors:
05 Version:

# of Called Methods (with thread starts):

# of Calls:
Total Timing:

DIWLIB4N-083 - 1116 (Driver)
Humber of Called Methods:
Percent of Time Spent on Machine

Instrumented Source Tmages

CSharp.dll

Number of Called Methods:

2/19/2010 3:19:01 AM
2/19/2010 9:21:18 &M

C:4EpeedBunp New)\DriveribiniRelease\Dri
o

2992 Mhz

1

Microsoft Windows XF

3,728

12,069,849
325,693,539 8 Microseconds

3,728
© 100.0

1a L2

assess impact of code changes
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Performance Expert

Performance Expert Performance Expert Session Controls

Results Summaries

DevPartner displays results for Performance Expert in session files. Session files present data in Window shows last 30 sec-
tabbed format, including the following tabs: onds of application activity.
e Call Graph Spikes in the graph indicate
e Call Tree Take a data snapshot - potential trouble spots.
e Methods table Clear data collected earlier in

this session
e Source code
e Call stacks

DevPartner Performance Expert

T T T T T 1
00:00:09 00:00:14 00:00:19 00:00:24 00:00:29 00:00:34 00:00:39
Elapsed time
N P (process time) BN Disk (bytes transferredfsec) I Metwork (bytes transferred)sec)

Ql .0 % of methods executed

Percentage of application code analyzed
during session
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Performance Expert

Performance Expert Session Data

C|I.Ck mdm@ual method for Methods analysis Click entry point method for Path analysis ((j)_alli Tret?N tat:( sllhgws I(;Tlpa_(;ttpf Call Graph tab highlights critical Icons indicate type gf gct|V|ty in method: disk,
(without children) (with children) Isk, network 1/0, and wait time path and expensive child methods network, or lock wait time
Paths that use the most CPU ! 5 _:j Bars show time in
Farm,Main 10,418,100.0 L & . E method VS. time in
Form.CtoF 9,815,903.0 (4 4 | 8 Fotmn. Main Farm. CtoF Service CtoF L. .
Servics.Chor 75260 L & - o 213 FBI%® iy & / child methods
e — | e —
Service..cor 2,386,896.0 [ 4 g 15 % 24,3 %
Form.ParseOption 163,456,4 E SRSt metidsorg el I
T called paths Farm.ParseCption Service. .ctar
Form.FoC |26,761.4 .4, CEEEICEAE 032% 3
0.0 CPU time in method (microseconds) 10,418,110.0 - Service. .ctor — E————| —'| Select a method to
0.0 %
Individualmethods that use the most CPU ! ES A update source and call
——— | Service FtoC Form.FtaC Service, FroC
Service.CtaF 7,426,680 L1 L 2% 4 stack tabs
Service..ctor 50560 : oEar [ —) ——
Farm Main A1) 750.0 Method Execution count | Disk activity (bytes transfe... | Wait time (us)  Disk reafl count | [
Form.ParseOption 163, 658.9 \ 245,148 I Methods table
Service.FtaC 25, 747.0.4 Service, .ctor 2,37,093.0 4 657,672 102 shows impact of
Form,CtoF 2,314.6 Forrn.Main 411,780.0 1 i ] i disk, network I/0,
0.0 CPU time in methad (microseconds) 7,426,698.0 Form.ParseCption 163,658.9 4 0 0.0 0 and wait time
Service FtaC 25,747.0 2 o 999.2 o =
- Forrn, CkoF 2,314.6 2 a 0.0 a -
| \/‘\ 43,8 % of methods executed Takal elapsed time: 10,418,100.0 ps Tatal execution time: 10,418, 100.0 ps £ T | > N
Method detail for: Service, CtoF Choose metric
Select method in stack to locate Double-click a line in urce display to edit in Source | Call Stacks |
|CPU time without user children (us) _:_J For each ling in Service, ChoF
| Source | Call Stacks | 7,426,672.0 0.0
Call stacks showing paths that called EntryPointsMain, B 52 + |_u_\
53
A . i 54: N =remarks)=
182'5 % - Call stack 1 / LJ (82,5 % of tatal time in mefhod is caused by this call stack) 55: [Svstem.web, Services. Protocols. SoapDocumentMethodattribute("htkp: f ftempuri. org/Ch
L . . S6; public System. Double CkoF{System.Double c) { - Source tab shows
] Method ] Lfne J Location in source where/ProgramUnder Test. EntryPoints, EntryPoints 7 obiect{] results = this. Irvoke{"CtoF", new obisct[] { |
ProgrambUnderTes 2? it (golng;:/nu") S o | most expensive
Programinde o i < ] 3 line for selected
ProgramUnder Test.Entry : Bse = R
ProgramUnderTest.Entry... 18 £3: B(10%; T 5 = metric
< I
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Using DPAnalysis.exe

Use DPAnalysis.exe to run coverage analysis, memory analysis, performance analysis, or
Performance Expert sessions from the command line. DPAnalysis.exe accepts command line
switches or an XML configuration file.

Command Line Operations

Use this syntax to run coverage, memory, performance, or Performance Expert sessions from

the command line:

DPAnalysis.exe

[a] {b} {c} {d} [e] target {target args}

DPAnalysis.exe requires Analysis Type and Target Type switches. Other switches are optional.

The following table lists the switches used with DPAnalysis.exe:

Category

Switches

Category

Using DPAnalysis.exe

Switches

[a] Analysis Type

{b} Data Collection

/Cov[erage] - Sets analysis type to DevPartner coverage analysis
/Memlory] - Sets analysis type to DevPartner memory analysis
/Perfl[ormance] - Sets analysis type to DevPartner performance analysis
/Explert] - Sets analysis type to DevPartner Performance Expert
/E[nable] - Enables data collection for the specified process or service
/Dlisable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use
the /D switch to disable profiling.

{c} Other Options

{d} Analysis Options

[e] Target Type

/O[utput] - Specify the session file output directory and/or filename
/W[orkingDir] - Specify working directory for the process or service
/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start
/N[ewconsole] - Run the process in its own command window

/F[orce] - Forces profiling for coverage or performance of applications written
without managed code or CTI.

/NO_MACHS - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (performance
analysis only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods
(coverage and performance analysis only)

/NO_OLEHOOKS- Disable collection of COM
/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (memory analysis
only)

Identifies target that follows as either a process or service. Pick only one. All
statements that follow the target name/path are considered arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)
/S[ervice] - Specify a target service (followed by arguments to service)
/C[onfig] - Path to configuration file
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Configuration File

Use this syntax to run coverage, memory, performance, or Performance Expert sessions
through a configuration file:

DPAnalysis.exe /config c:\temp\ config.xml

The following table briefly describes the XML elements. See the DevPartner online help or the
Understanding DevPartner manual for more information.

Element

Description

Using DPAnalysis.exe

AnalysisOptions

Arguments

Excludelmages

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner properties
accessible from the Properties Window in Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner Coverage,
Memory and Performance Analysis properties accessible from the Properties Window in
Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. No default if omitted. Defines
images (at least one, no maximum) which, if loaded by the target process or service,
will not be profiled. No attributes.

Element Description

Host (Optional) For each Process or Service, zero or one. No default if omitted. Sets the host
machine of the target process or service. No attributes.

Name One required for each service. Provides the name of the service as registered with the
service control manager. This is the same name you would use for the system's NET
START command. No attributes.

Path One required for each process. Specify a fully qualified or relative path to the
executable. You can specify the executable name without the path if the executable
exists in the current directory. No attributes.

Process The configuration file must contain at least one Process or one Service element.

RuntimeAnalysis
Service

Targets

Specifies a target executable.
Attributes: CollectData, Spawn, NoWaitForCompletion, NewConsole

Required; one only. Defines the type of analysis and maximum session time.

The configuration file must contain at least one Process or one Service element.
Specifies a target service.
Attributes: CollectData, Start, RestartlfRunning, RestartAtEndOfRun

Required. One only. Begins a block of one or more Process or Service entries. Target
processes and services are started in the order they are listed in the configuration file.
Attributes: RuninParallel

DevPartner Studio Quick Reference - 16



Error Detection

File Extensions Used by Error Detection

Category

Error Detection

Settings

Extension  File Type Description

.dpbcl Error Detection Session File This is the Error Detection log for the user's program
execution.

.dpbcc Error Detection Settings File This file contains the various settings for Error

.dpbcd Detection. The .dpbcd extension refers to the default
settings file created, while .dpbcc refers to a custom
settings file that has been saved separately.

.dpsup Error Detection Suppressions File This file contains the various suppressions for the user's
program.

.dpflt Error Detection Filters File This file contains the various filters for the user's
program.

.dprul Error Detection Rules File This is a database of the user's suppressions and filters.

Default Options (DevPartner Studio Professional and Enterprise Editions)
or Settings (Visual C++ BoundsChecker Suite)

Category Settings
General On Log events
On Display error and pause

Data Collection

Prompt to save program results
Show memory and resource viewer when application exits

Source file search path - based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

Override symbol path - Default: empty

Working directory (standalone only) based on the location of the .EXE
Command line arguments (standalone only) - Default: empty

Call parameter coding depth = 1

Maximum call stack depth on allocation = 5

Maximum call stack depth on error = 20

NLB file directory is based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

API Call Reporting

Call Validation

COM Call Reporting

COM Object Tracking

Off

Off

Off

Enable API call reporting. All selections are unavailable until you select this
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On
All modules (tree view). - Default when active: All selected

Enable call validation. All selections unavailable until you select this item
Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active:
On

API failure codes - Default when active: On
Check invalid parameter errors: API, COM - Default when active: both On
Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default
when active: All items selected

Enable COM method call reporting on objects that are implemented in
the selected modules

Report COM method calls on objects implemented outside of the listed
modules - Default when active: On

All components tree view - Default when active: All selected
Enable COM object tracking
All COM classes tree view - Default when active: All selected
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Category

Settings

Deadlock Analysis

Memory Tracking

.NET Analysis

.NET Call Reporting

Resource Tracking

Off

Enable deadlock analysis
Assume single process - Default when active: On
Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when
active: Off

Generate errors when: A wait is requested on an owned mutex - Default
when active: Off

Number of historical events per resource - Default when active: 10
Report synchronization API timeouts - Default when active: Off

Report wait limits or actual waits exceeding (seconds) - Default when
active: 60

Synchronization Naming Rules - Default when active: Don’t warn about
resource naming

Enable memory tracking

Enable Leak Analysis Only

Show leaked allocation blocks

Enforce strict reallocation semantics

Enable FinalCheck

Enable guard bytes; Pattern = FC; Count = 4 bytes
Check heap blocks at runtime: On free

Enable fill on allocation; Pattern = FB

Check uninitialized memory; Size = 2 bytes

Enable poison on free; Pattern = FD

Enable .NET analysis

Exception monitoring - Default when active: On

Finalizer monitoring - Default when active: On

COM interop monitoring - Default when active: On
PInvoke interop monitoring - Default when active: On
Interop reporting threshold - Default when active: 1
Enable .NET method call reporting

All types (tree view node) - Default when active: Selected.
.NET User Assemblies (tree view node) - Default when active: Selected

.NET System Assemblies (tree view node) - Default when active: Not
selected

Enable resource tracking
Resources tree view. All listed resources are selected by default

Error Detection

Error Detection Toolbar in Visual Studio
Start with Error Detection

Start with Coverage Analysis

Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis

Note: The arrows next to each button allow you to start with or without
debugging, depending on the default action of the button.

M - @ . &‘: = Iﬁ% - @ Error Detection - | Fy

Native C/C++ Instrumentation Set DevPartner Options

Enable/disable instrumentaton ~——

Choose instrumentation type
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Error Detection Window

— Results Pane

Summary, Memory Leaks, Other Leaks, Errors, .NET
Performance, Modules, Transcript tabs provide
overview and detail about detected errors.

— Details Pane

Displays long description of detected
error; call stack information; reference
count graph (see inset below).

Foipter Error: Pointer 0x0012EES0, used as an -

P 1 gurment
El- X Painter Unrelated

Tlpe uantity anahnw;l - ks
- W Y E 3 argunhent, is out of range; na longer within the buffer
- X Movesble Memary Errar ffor wariable a 0x0012EE7E [20] in function
§ gonziro \oc!( count :: *;P_l_thE Painter_AnayParamExRange _I
angling pointer ginter_ ¥
Painter Error 1 Current Call Stack - Thread 0 [0x0108] j
Function ‘ File ;I

X Unrelated painter comparison

Pointer_

Pointer_ArrayParamE #F ange

ExecuteFunction BugBench?Dlg.cp;

- X Read Overrun OnTest BugBench?Dlg.cp
- X 'Wwiite Overrun + | | _Af=DispatchCmdMsg cmdtarg.cpp
1 | v OnCmdMeg cmdtarg.cpp
El Summary | 4§ Memory Leaks I 44 Other Leaks X Errors [£4 | bl ETCmdMSG dIE‘core.cDD

PTRERR.CPP |

{

c:hprogram fileshmicra focushdevpartner studichexamplesi\bugbench?mainhptiem.cpp

=
DI 4

TTHY Refersnce Count Yiew |[|ma:t Identity View |
inta[5];
int_b; g ag|sm
b =a[B]: /¢ amay index out of range
?iru—u—n—u—n—n—\_ —
CATCH -ttt
123456789 11 13 15
L j
L AddFiel - Thread 0 [00070] =l
Source Pane Fifrction | File | Line £ Dffsst| « |
oledz.di 040001BDEF
’ Crdatelnstance comph
Displays source code for the CM_intetface_Leak  comencpp 121
. ) ExpeatsFuncti bugbench?dl 695
detected error, if available. o oen A 535J
_AfsDispatchCmdMsg  emdtarg.cpp 88
OrCmdisg cmdtarg.cpp 3% 5

L Details Pane - Reference Count Graph

Displays Reference Count View and Object Identity
View tabs when you select an Interface Leak in the
Results pane.

Icons Used in the Results Pane

Icon

Error Detection

Description

Appears in...

b AE ¢ P EXS e

Memory Leaks
Other Leaks

Errors

.NET Performance

Module Load Event

Summary, Memory Leaks, and Transcript tabs
Summary, Other Leaks, and Transcript tabs
Summary, Errors, and Transcript tabs
Summary, .NET Performance tabs

Summary, Modules, and Transcript tabs

Subroutine call Transcript tab
Garbage Collection Event Transcript tab
Event Begins Transcript tab
Event Resumes Transcript tab
Event Ends Transcript tab
Icons Used in the Details Pane
Icon Description
& Subroutine call
[1] Entry Parameters
[T] Exit Parameters

(+

By
@

Return Value

Property (default) for data types

Property for data types
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Reference Count Graph Toolbar

Vertical Zoom Out
Vertical Zoom In Scale to Size
Horizontal Zoom Out Select Viewing Area
Horizontal Zoom In —I
= |05

o

Program Error Detected Dialog Box

Error description

M Program Error, Detected - BugBench.exe

& |Memary Leak Due ta Free: C4ling free causes a leagk of addiess 0:029E 2868 [10] alacated by I
malloc. |
‘ |
| Current Call Stack. - Thread 0 [00405] | Allocation Call Stack - Thread O [0x0408] |
Function File: Line / Offzet
Leak_L eakFromFree leaker cpp B5
ErecuteFunction bugbench?dlg.cpp B35
OnTest bugbench?dlg cpp B33
micF0.dl 0x00018430
~
PB *p ;
p = (PE *)walloc | sizeof ( PE ) ) :
p->ptr = (char *)malloc| 10 )} =
free ([ p )
CATCH
9 55
& | 2
[ Eplain ] [ Memany/Resource Viewer ]
[] Dap't show this errcr dislog | This Run v|
[[] Digfable event logging ‘This Run v| [ Debug ] [ Halt ] [ Continue ]

— Call stack information — Source code for the detected error

Tabs for multiple call stacks

Error Detection

Memory and Resource Viewer Dialog Box

Results Pane

Memory Contents Pane

Displays Memory, Resource, and Summary tabs

Stack Pane

3 DeyPartner Error Detection Memory and Resource Yiewer

Address OSEICD93| 04bBb0=Ed d.»

i
Location [combined)] Thread 1D Eyte Count
OSE1CD9C| 00000001
3 T N, L T 84 Debldboef| lncE1CDAD| 05241280 5
IFACE. dll, atlcom.h, ATL::CLomCreator: class U574 407 Da00eleds| INEE1CDA4| FEEFEEEf  wipwy
ATL:CComObjectCached<class ncE1cDAS| 0o0oooooo
ATL::CComClagsFactory »:Createlnstance - line NSE1CDAC| 00000000
1801 ! DSEICDEO 00000000
IFACE. dll, atlcom.h, ATL::CCamCreator< class 00574 160 Ow05elcde| lncEicpe4| ooooooon
»_ATL :CComObject<class Cview: >:Createlnstance - OSE1CDES| fbfbfbol i
LAk OSEICDEC| 04b9lfc3 X.°
Function F. Line/0Of..
ATL:CComCreator<cla. . at 18m
ATL:CComModule:Ge...  at. 721
DIGetClassObject if... 72
ATL:CComCreator<cla. . at 18m
< | »
8 memory_ |8 Resources | B sarmary |
cidvprogram files‘microsoft visual studioc 2.0%vchatlmfc) includehatlocom.h
#pragma warning(push) ~
#pragma warning(disable: 6014)
/* prefast noise VSU 4589951 +/
| ATLTRY [p = new T1(pv))
#prhoma warning(pop)
if (p != NULL)
1 ol
4 ]
Lirje Mumber: 1801 | Shawing allitems v ! [ Help ] [ Save ] [ Mark |and Close ] [ Close

L— Source Pane

Displays source code for the
detected error, if available.

Mark and Close —

Click to mark existing allocations and close the
dialog box. Marked items will not be shown when
Memory and Resource viewer reappears.
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ActiveCheck and FinalCheck Error Detection

ActiveCheck

ActiveCheck™ analyzes your program and searches for errors in your program executable as
well as the dynamic-link libraries (DLLs), third-party modules, and COM components used by
your program. The following tables list the types of errors found with ActiveCheck error

detection.

Deadlock-related Errors

API and COM Errors

Error Detection

Memory Errors

Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memory block
Stack memory overrun

Static memory overrun

Deadlock

Potential deadlock

Thread deadlocked

Critical section errors

Semaphore errors

Resource usage and naming errors
Suspicious or questionable resource usage
Handle errors

Event errors

Mutex errors

Windows event errors

COM interface method failure

Invalid argument

Parameter range error

Questionable use of thread

Windows function failed

Windows function not implemented
Invalid COM interface method argument

Memory Errors

FinalCheck Compile Time Instrumentation - Deepest Error Detection

FinalCheck™ compile time instrumentation (CTI) enables Error Detection to find more errors
(memory leaks, pointer errors, data corruption errors, and so on) as they occur in real time.
FinalCheck finds these types of errors, plus all errors found with ActiveCheck.

Pointer and Leak Errors

.NET Errors

Pointer and Leak Errors

Finalizer errors
GC.Suppress finalize not called
Dispose attributes errors

Unhandled native exception passed to managed
code

Interface leak
Memory leak
Resource leak

Reading overflows buffer
Reading uninitialized memory
Writing overflows buffer

Array index out of range
Assigning pointer out of range
Expression uses dangling pointer
Expression uses unrelated pointers
Function pointer is not a function
Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free
Memory leaked due to reassignment
Memory leaked leaving scope
Returning pointer to local variable
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List of Available Keyboard Commands - Visual Studio

Command Action

Ctrl+Shift+O File > Open > Project
Ctrl+Shift+N File > New > Project
Ctrl+S File > Save Project
Ctrl+Shift+S File > Save All
Ctrl+Shift+F Edit > Find in Files
Ctrl+Shift+H Edit > Replace in Files
Alt+F12 Edit > Find Symbol
Ctrl+Alt+L View > Solution Explorer
Ctrl+Shift+C View > Class View
Ctrl+Alt+S View > Server Explorer
Ctrl+Shift+E View > Resource View

F4 View > Properties Window
Ctrl+Alt+X View > Toolbox
Shift+Alt+Enter View > Full Screen
Shift+F4 View > Property Pages
Ctrl+Shift+B Build > Build Solution

F5 Debug > Start

Ctrl+F5 Debug > Start Without Debugging
Ctri+Alt+E Debug > Exceptions

F11 Debug > Step Into

F10 Debug > Step Over
Ctrl+B Debug > New Breakpoint
Ctrl+F1 Help > Dynamic Help
Ctrl+Alt+F1 Help > Contents
Ctrl+Alt+F2 Help > Index

Ctrl+Alt+F3 Help > Search
Shift+Alt+F2 Help > Index results
Shift+Alt+F3 Help > Search results

Export DevPartner Data: Command Line Use

Export DevPartner Data: Command Line Use

You can use DevPartner.Analysis.DataExport.exe from the command line to convert DevPartner
coverage analysis (.dpcov), coverage analysis merge (.dpmrg), performance analysis (.dpprf),
and Performance Expert (.dppxp) session file data to XML.

Use this syntax to export session data to XML:

DevPartner.Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options}

Options
The following table lists the command line options for DevPartner.Analysis.DataExport.exe.

You can use an equal sign, a colon, or a space to separate an option from the value or values
you specify.

Switch Description

/out [put]=<String> Specify the local or remote output directory for exported XML
files. Creates the directory if the directory does not exist

/r[ecurse] Search subdirectories for DevPartner Session Files.

/f[ilename]=<String> Specify the name of the XML output file. Appends .xml to the name
specified.

/showAll Shows all performance and coverage session file data available in a

performance or coverage session file.
For example, if you export a performance session file with this option,
the resulting XML file contains both performance and coverage data

fI!Eli(sisc.)ption is not available for Performance Expert session files.
/wlait] Wait for input before closing console window.
/nologo Do not display the logo or copyright notice.
/help or /? Display help in the console window.
/summary Export Performance Expert summary data which includes a default

maximum of the top ten callpaths and the top ten methods that use the
most CPU resources. Use the /maxpaths and /maxmethods options to
override the maximums.

/method Exports Performance Expert method data.
/calltree Export Performance Expert call tree data.
/maxpaths=<integer> Used only with the Performance Expert /summary option. Exports the

specified number of the top call paths that use the most CPU resources.

/maxmethods=<integer> Used only with the Performance Expert /summary option. Exports the
specified number of the top methods that use the most CPU resources.
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