CICS Support Commands

Lists the CICS Support commands

The following commands are available for CICS support:

  • CICS API Calls
  • CICS SPI Calls


CICS API Calls

  • ABEND
    The ABEND function is supported.
  • ADD SUBEVENT
    The ADD SUBEVENT function is not supported.
  • ADDRESS
    The ADDRESS function is supported.
  • ADDRESS SET
    The ADDRESS SET function is supported.
  • ALLOCATE
    The ALLOCATE function is supported.
  • ASKTIME
    The ASKTIME function is supported.
  • ASSIGN
    The ASSIGN function is supported.
  • BIF DEEDIT
    The BIF DEEDIT function is supported.
  • BIF DIGEST
    The BIF DIGEST function is not supported.
  • BUILD ATTACH
    The BUILD ATTACH function is not supported.
  • CANCEL
    The CANCEL function is supported.
  • CHANGE PASSWORD
    The CHANGE PASSWORD function is not supported.
  • CHANGE PHRASE
    The CHANGE PHRASE function is supported.
  • CHECK ACQACTIVITY
    The CHECK ACQACTIVITY function is not supported.
  • CHECK ACQPROCESS
    The CHECK ACQPROCESS function is not supported.
  • CHECK ACTIVITY
    The CHECK ACTIVITY function is not supported.
  • CHECK TIMER
    The CHECK TIMER function is not supported.
  • CONNECT PROCESS
    The CONNECT PROCESS function is supported.
  • CONVERSE
    The CONVERSE function is supported.
  • CONVERTTIME
    The CONVERTTIME function is supported.
  • DEFINE ACTIVITY
    The DEFINE ACTIVITY function is not supported.
  • DEFINE COMPOSITE EVENT
    The DEFINE COMPOSITE EVENT function is not supported.
  • DEFINE COUNTER
    The DEFINE COUNTER function is not supported.
  • DEFINE DCOUNTER
    The DEFINE DCOUNTER function is not supported.
  • DEFINE INPUT EVENT
    The DEFINE INPUT EVENT function is not supported.
  • DEFINE PROCESS
    The DEFINE PROCESS function is not supported.
  • DEFINE TIMER
    The DEFINE TIMER function is not supported.
  • DELAY
    The DELAY function is supported.
  • DELETE
    The DELETE function is supported.
  • DELETE ACTIVITY
    The DELETE ACTIVITY function is not supported.
  • DELETE CONTAINER
    The DELETE CONTAINER function is supported.
  • DELETE COUNTER
    The DELETE COUNTER function is not supported.
  • DELETE DCOUNTER
    The DELETE DCOUNTER function is not supported.
  • DELETE EVENT
    The DELETE EVENT function is not supported.
  • DELETE RIDFLD
    The DELETE RIDFLD function is supported.
  • DELETE TIMER
    The DELETE TIMER function is not supported.
  • DELETEQ
    The DELETEQ function is supported.
  • DELETEQ TD
    The DELETEQ TD function is supported.
  • DELETEQ TS
    The DELETEQ TS function is supported.
  • DEQ
    The DEQ function is supported.
  • DOCUMENT CREATE
    The DOCUMENT CREATE function is supported.
  • DOCUMENT DELETE
    The DOCUMENT DELETE function is supported.
  • DOCUMENT INSERT
    The DOCUMENT INSERT function is supported.
  • DOCUMENT RETRIEVE
    The DOCUMENT RETRIEVE function is supported.
  • DOCUMENT SET
    The DOCUMENT SET function is supported.
  • DUMP
    The DUMP function is supported.
  • DUMP SYSTEM
    The DUMP SYSTEM function is supported.
  • DUMP TRANSACTION
    The DUMP TRANSACTION function is supported.
  • ENDBR
    The ENDBR function is supported.
  • ENDBROWSE ACTIVITY
    The ENDBROWSE ACTIVITY function is not supported.
  • ENDBROWSE CONTAINER
    The ENDBROWSE CONTAINER function is supported.
  • ENDBROWSE EVENT
    The ENDBROWSE EVENT function is not supported.
  • ENDBROWSE PROCESS
    The ENDBROWSE PROCESS function is not supported.
  • ENQ
    The ENQ function is supported.
  • ENTER TRACEID
    The ENTER TRACEID function is supported.
  • ENTER TRACENUM
    The ENTER TRACENUM function is supported.
  • FEPI
    The FEPI function is not supported.
  • FORCE TIMER
    The FORCE TIMER function is not supported.
  • FORMATTIME
    The FORMATTIME function is supported.
  • FREE
    The FREE function is supported.
  • FREEMAIN
    The FREEMAIN function is supported.
  • GDS ALLOCATE
    The GDS ALLOCATE function is supported.
  • GDS ASSIGN
    The GDS ASSIGN function is supported.
  • GDS CONNECT PROCESS
    The GDS CONNECT PROCESS function is supported.
  • GDS EXTRACT ATTRIBUTES
    The GDS EXTRACT ATTRIBUTES function is supported.
  • GDS EXTRACT PROCESS
    The GDS EXTRACT PROCESS function is supported.
  • GDS FREE
    The GDS FREE function is supported.
  • GDS ISSUE ABEND
    The GDS ISSUE ABEND function is supported.
  • GDS ISSUE CONFIRMATION
    The GDS ISSUE CONFIRMATION function is supported.
  • GDS ISSUE ERROR
    The GDS ISSUE ERROR function is supported.
  • GDS ISSUE PREPARE
    The GDS ISSUE PREPARE function is supported.
  • GDS ISSUE SIGNAL
    The GDS ISSUE SIGNAL function is supported.
  • GDS RECEIVE
    The GDS RECEIVE function is supported.
  • GDS SEND
    The GDS SEND function is supported.
  • GDS WAIT
    The GDS WAIT function is supported.
  • GET CONTAINER
    The GET CONTAINER function is supported.
  • GET COUNTER
    The GET COUNTER function is not supported.
  • GET DCOUNTER
    The GET DCOUNTER function is not supported.
  • GETMAIN
    The GETMAIN function is supported.
  • GETNEXT ACTIVITY
    The GETNEXT ACTIVITY function is not supported.
  • GETNEXT CONTAINER
    The GETNEXT CONTAINER function is supported.
  • GETNEXT EVENT
    The GETNEXT EVENT function is not supported.
  • GETNEXT PROCESS
    The GETNEXT PROCESS function is not supported.
  • HANDLE ABEND
    The HANDLE ABEND function is supported.
  • HANDLE AID
    The HANDLE AID function is supported.
  • HANDLE CONDITION
    The HANDLE CONDITION function is supported.
  • IGNORE CONDITION
    The IGNORE CONDITION function is supported.
  • INVOKE SERVICE
    The INVOKE SERVICE function is supported.
  • INVOKE WEBSERVICE
    The INVOKE WEBSERVICE function is supported.
  • ISSUE ABEND
    The ISSUE ABEND function is supported.
  • ISSUE ABORT
    The ISSUE ABORT function is not supported.
  • ISSUE ADD
    The ISSUE ADD function is not supported.
  • ISSUE CONFIRMATION
    The ISSUE CONFIRMATION function is supported.
  • ISSUE COPY
    The ISSUE COPY function is not supported.
  • ISSUE DISCONNECT
    The ISSUE DISCONNECT function is supported.
  • ISSUE END
    The ISSUE END function is not supported.
  • ISSUE ENDFILE
    The ISSUE ENDFILE function is not supported.
  • ISSUE ENDOUTPUT
    The ISSUE ENDOUTPUT function is not supported.
  • ISSUE EODS
    The ISSUE EODS function is not supported.
  • ISSUE ERASE
    The ISSUE ERASE function is not supported.
  • ISSUE ERASEAUP
    The ISSUE ERASEAUP function is supported.
  • ISSUE ERROR
    The ISSUE ERROR function is supported.
  • ISSUE LOAD
    The ISSUE LOAD function is not supported.
  • ISSUE NOTE
    The ISSUE NOTE function is not supported.
  • ISSUE PASS
    The ISSUE PASS function is not supported.
  • ISSUE PREPARE
    The ISSUE PREPARE function is supported.
  • ISSUE PRINT
    The ISSUE PRINT function is supported.
  • ISSUE QUERY
    The ISSUE QUERY function is not supported.
  • ISSUE RECEIVE
    The ISSUE RECEIVE function is not supported.
  • ISSUE REPLACE
    The ISSUE REPLACE function is not supported.
  • ISSUE RESET
    The ISSUE RESET function is supported.
  • ISSUE SEND
    The ISSUE SEND function is not supported.
  • ISSUE SIGNAL
    The ISSUE SIGNAL function is supported.
  • ISSUE WAIT
    The ISSUE WAIT function is not supported.
  • JOURNAL
    The JOURNAL function is supported.
  • LINK
    The LINK function is supported.
  • LINK ACQACTIVITY
    The LINK ACQACTIVITY function is not supported.
  • LINK ACQPROCESS
    The LINK ACQPROCESS function is not supported.
  • LINK ACTIVITY
    The LINK ACTIVITY function is not supported.
  • LOAD
    The LOAD function is supported.
  • MONITOR
    The MONITOR function is not supported.
  • MOVE CONTAINER
    The MOVE CONTAINER function is supported.
  • POINT
    The POINT function is not supported.
  • POP
    The POP function is supported.
  • POP HANDLE
    The POP HANDLE function is supported.
  • POST
    The POST function is supported.
  • PURGE MESSAGE
    The PURGE MESSAGE function is supported.
  • PUSH
    The PUSH function is supported.
  • PUSH HANDLE
    The PUSH HANDLE function is supported.
  • PUT CONTAINER
    The PUT CONTAINER function is supported.
  • QUERY COUNTER
    The QUERY COUNTER function is not supported.
  • QUERY DCOUNTER
    The QUERY DCOUNTER function is not supported.
  • QUERY SECURITY
    The QUERY SECURITY function is supported.
  • READ
    The READ function is supported.
  • READNEXT
    The READNEXT function is supported.
  • READPREV
    The READPREV function is supported.
  • READQ
    The READQ function is supported.
  • READQ TD
    The READQ TD function is supported.
  • READQ TS
    The READQ TS function is supported.
  • RECEIVE
    The RECEIVE function is supported.
  • RECEIVE MAP
    The RECEIVE MAP function is supported.
  • RECEIVE MAP MAPPINGDEV
    The RECEIVE MAP MAPPINGDEV function is not supported.
  • RECEIVE MAPSET
    The RECEIVE MAPSET function is supported.
  • RECEIVE PARTN
    The RECEIVE PARTN function is not supported.
  • RELEASE
    The RELEASE function is supported.
  • REMOVE SUBEVENT
    The REMOVE SUBEVENT function is not supported.
  • RESET ACQPROCESS
    The RESET ACQPROCESS function is not supported.
  • RESET ACTIVITY
    The RESET ACTIVITY function is not supported.
  • RESETBR
    The RESETBR function is supported.
  • RESUME
    The RESUME function is not supported.
  • RETRIEVE
    The RETRIEVE function is supported.
  • RETRIEVE REATTACH
    The RETRIEVE REATTACH function is not supported.
  • RETRIEVE SUBEVENT
    The RETRIEVE SUBEVENT function is not supported.
  • RETURN
    The RETURN function is supported.
  • REWIND COUNTER
    The REWIND COUNTER function is not supported.
  • REWIND DCOUNTER
    The REWIND DCOUNTER function is not supported.
  • REWRITE
    The REWRITE function is supported.
  • ROUTE
    The ROUTE function is not supported.
  • RUN
    The RUN function is not supported.
  • SEND
    The SEND function is supported.
  • SEND CONTROL
    The SEND CONTROL function is supported.
  • SEND MAP
    The SEND MAP function is supported.
  • SEND MAP MAPPINGDEV
    The SEND MAP MAPPINGDEV function is not supported.
  • SEND MAPSET
    The SEND MAPSET function is supported.
  • SEND PAGE
    The SEND PAGE function is supported.
  • SEND PARTNSET
    The SEND PARTNSET function is not supported.
  • SEND TEXT
    The SEND TEXT function is supported.
  • SEND TEXT MAPPED
    The SEND TEXT MAPPED function is supported.
  • SEND TEXT NOEDIT
    The SEND TEXT NOEDIT function is supported.
  • SIGNAL EVENT
    The SIGNAL EVENT function is not supported.
  • SIGNOFF
    The SIGNOFF function is supported.
  • SIGNON
    The SIGNON function is supported.
  • SOAPFAULT ADD
    The SOAPFAULT ADD function is supported.
  • SOAPFAULT CREATE
    The SOAPFAULT CREATE function is supported.
  • SOAPFAULT DELETE
    The SOAPFAULT DELETE function is supported.
  • SPOOLCLOSE
    The SPOOLCLOSE function is supported.
  • SPOOLCLOSE REPORT
    The SPOOLCLOSE REPORT function is supported.
  • SPOOLOPEN ESCAPE
    The SPOOLOPEN ESCAPE function is not supported.
  • SPOOLOPEN INPUT
    The SPOOLOPEN INPUT function is not supported.
  • SPOOLOPEN MAPNAME
    The SPOOLOPEN MAPNAME function is not supported.
  • SPOOLOPEN OUTPUT
    The SPOOLOPEN OUTPUT function is supported.
  • SPOOLOPEN REPORT ASA
    The SPOOLOPEN REPORT ASA function is supported.
  • SPOOLOPEN REPORT JCL
    The SPOOLOPEN REPORT JCL function is supported.
  • SPOOLOPEN REPORT MCC
    The SPOOLOPEN REPORT MCC function is supported.
  • SPOOLOPEN REPORT NOCC
    The SPOOLOPEN REPORT NOCC function is supported.
  • SPOOLOPEN REPORT SCS
    The SPOOLOPEN REPORT SCS function is not supported.
  • SPOOLOPEN REPORT T3270
    The SPOOLOPEN REPORT T3270 function is not supported.
  • SPOOLOPEN RESUME
    The SPOOLOPEN RESUME function is not supported.
  • SPOOLREAD
    The SPOOLREAD function is not supported.
  • SPOOLWRITE
    The SPOOLWRITE function is supported.
  • SPOOLWRITE MAPNAME
    The SPOOLWRITE MAPNAME function is not supported.
  • SPOOLWRITE REPORT
    The SPOOLWRITE REPORT function is supported.
  • START
    The START function is supported.
  • START ATTACH
    The START ATTACH function is not supported.
  • START BREXIT
    The START BREXIT function is supported.
  • START CHANNEL
    The START CHANNEL function is supported.
  • STARTBR
    The STARTBR function is supported.
  • STARTBROWSE ACTIVITY
    The STARTBROWSE ACTIVITY function is not supported.
  • STARTBROWSE CONTAINER
    The STARTBROWSE CONTAINER function is supported.
  • STARTBROWSE EVENT
    The STARTBROWSE EVENT function is not supported.
  • STARTBROWSE PROCESS
    The STARTBROWSE PROCESS function is not supported.
  • SUSPEND
    The SUSPEND function is supported.
  • SYNCPOINT
    The SYNCPOINT function is supported.
  • TEST EVENT
    The TEST EVENT function is not supported.
  • TRACE
    The TRACE function is not supported.
  • TRANSFORM DATATOXML
    The TRANSFORM DATATOXML function is supported.
  • TRANSFORM XMLTODATA
    The TRANSFORM XMLTODATA function is supported.
  • UNLOCK
    The UNLOCK function is supported.
  • UPDATE COUNTER
    The UPDATE COUNTER function is not supported.
  • UPDATE DCOUNTER
    The UPDATE DCOUNTER function is not supported.
  • VERIFY PASSWORD
    The VERIFY PASSWORD function is supported.
  • VERIFY PHRASE
    The VERIFY PHRASE function is supported.
  • WAIT CONVID
    The WAIT CONVID function is supported.
  • WAIT EVENT
    The WAIT EVENT function is supported.
  • WAIT EXTERNAL
    The WAIT EXTERNAL function is not supported.
  • WAIT JOURNAL
    The WAIT JOURNAL function is supported.
  • WAIT JOURNALNAME
    The WAIT JOURNALNAME function is not supported.
  • WAIT JOURNALNUM
    The WAIT JOURNALNUM function is supported.
  • WAIT SIGNAL
    The WAIT SIGNAL function is not supported.
  • WAIT TERMINAL
    The WAIT TERMINAL function is not supported.
  • WAITCICS
    The WAITCICS function is supported.
  • WEB CLOSE
    The WEB CLOSE function is supported.
  • WEB CONVERSE
    The WEB CONVERSE function is supported.
  • WEB ENDBROWSE FORMFIELD
    The WEB ENDBROWSE FORMFIELD function is supported.
  • WEB ENDBROWSE HTTPHEADER
    The WEB ENDBROWSE HTTPHEADER function is supported.
  • WEB ENDBROWSE QUERYPARM
    The WEB ENDBROWSE QUERYPARM function is supported.
  • WEB EXTRACT
    The WEB EXTRACT function is supported.
  • WEB OPEN
    The WEB OPEN function is supported.
  • WEB PARSE
    The WEB PARSE function is supported.
  • WEB READ FORMFIELD
    The WEB READ FORMFIELD function is supported.
  • WEB READ HTTPHEADER
    The WEB READ HTTPHEADER function is supported.
  • WEB READ QUERYPARM
    The WEB READ QUERYPARM function is supported.
  • WEB READNEXT FORMFIELD
    The WEB READNEXT FORMFIELD function is supported.
  • WEB READNEXT HTTPHEADER
    The WEB READNEXT HTTPHEADER function is supported.
  • WEB READNEXT QUERYPARM
    The WEB READNEXT QUERYPARM function is supported.
  • WEB RECEIVE
    The WEB RECEIVE function is supported.
  • WEB RECEIVE SESSTOKEN
    The WEB RECEIVE SESSTOKEN function is supported.
  • WEB RETRIEVE
    The WEB RETRIEVE function is supported.
  • WEB SEND
    The WEB SEND function is supported.
  • WEB SEND SESSTOKEN
    The WEB SEND SESSTOKEN function is supported.
  • WEB STARTBROWSE FORMFIELD
    The WEB STARTBROWSE FORMFIELD function is supported.
  • WEB STARTBROWSE HTTPHEADER
    The WEB STARTBROWSE HTTPHEADER function is supported.
  • WEB STARTBROWSE QUERYPARM
    The WEB STARTBROWSE QUERYPARM function is supported.
  • WEB WRITE
    The WEB WRITE function is supported.
  • WRITE
    The WRITE function is supported.
  • WRITE JOURNALNAME
    The WRITE JOURNALNAME function is not supported.
  • WRITE JOURNALNUM
    The WRITE JOURNALNUM function is supported.
  • WRITE OPERATOR
    The WRITE OPERATOR function is supported.
  • WRITEQ
    The WRITEQ function is supported.
  • WRITEQ TD
    The WRITEQ TD function is supported.
  • WRITEQ TS
    The WRITEQ TS function is supported.
  • WSACONTEXT BUILD
    The WSACONTEXT BUILD function is not supported.
  • WSACONTEXT DELETE
    The WSACONTEXT DELETE function is not supported.
  • WSACONTEXT GET
    The WSACONTEXT GET function is not supported.
  • WSAEPR CREATE
    The WSAEPR CREATE function is not supported.
  • WSAEPR EVENT
    The WSAEPR EVENT function is not supported.
  • XCTL
    The XCTL function is supported.
Parent topic: CICS Support Commands


ABEND

The ABEND function is supported.

Operand | Support
ABCODE (data-value) | Full
CANCEL | Full
NODUMP | Full
Parent topic: CICS API Calls


ADD SUBEVENT

The ADD SUBEVENT function is not supported.


ADDRESS

The ADDRESS function is supported.

Operand | Support
ACEE (ptr-ref) | Full
COMMAREA (ptr-ref) | Full
CSA (ptr-ref) | Partial: returns a NULL pointer
CWA (ptr-ref) | Full
EIB (ptr-ref) | Full
TCTUA (ptr-ref) | Full
TWA (ptr-ref) | Full


ADDRESS SET

The ADDRESS SET function is supported.

Operand | Support
SET (ptr-ref) | Full
USING (ptr-ref) | Full


ALLOCATE

The ALLOCATE function is supported.

Operand | Support
NOQUEUE | Full
NOSUSPEND | Full
PARTNER (data-value) | Validated
PROFILE (data-value) | Validated
SESSION (data-value) | Validated
STATE (cvda) | Full
SYSID (data-value) | Full


ASKTIME

The ASKTIME function is supported.

Operand | Support
ABSTIME (data-area) | Full


ASSIGN

The ASSIGN function is supported.

Operand | Support
ABCODE (data-area) | Full
ABDUMP (data-area) | Partial: returns x"00" meaning "No dump has been produced"
ABPROGRAM (data-area) | Partial: returns x"00" meaning "Indeterminable"
ACTIVITY (data-area) | Validated
ACTIVITYID (data-area) | Validated
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
APLKYBD (data-area) | Partial: returns x"00" meaning "No"
APLTEXT (data-area) | Partial: returns x"00" meaning "No"
APPLID (data-area) | Full
ASRAINTRPT (data-area) | Partial: returns x"00"
ASRAKEY (data-area) | Validated
ASRAPSW (data-area) | Partial: returns x"00"
ASRAREGS (data-area) | Partial: returns x"00"
ASRASPC (data-area) | Validated
ASRASTG (data-area) | Validated
BRIDGE (data-area) | Full
BTRANS (data-area) | Partial: returns x"00" meaning "No"
CHANNEL (data-area) | Full
CMDSEC (data-area) | Partial: returns Blank meaning "No"
COLOR (data-area) | Full
CWALENG (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DELIMITER (data-area) | Partial: returns x"00"
DESTCOUNT (data-area) | Partial: returns x"0000"
DESTID (data-area) | Partial: INVREQ occurs
DESTIDLENG (data-area) | Partial: INVREQ occurs
DS3270 (data-area) | Partial: returns x"00" meaning "No"
DSSCS (data-area) | Partial: returns x"00" meaning "No"
EWASUPP (data-area) | Full
EXTDS (data-area) | Full
FACILITY (data-area) | Full
FCI (data-area) | Full
GCHARS (data-area) | Full
GCODES (data-area) | Full
GMMI (data-area) | Full
HILIGHT (data-area) | Full
INITPARM (ptr-ref) | Partial: returns x"00" meaning "No parameters"
INITPARMLEN (data-area) | Partial: returns x"00" meaning "No parameter"
INPARTN (data-area) | Partial: returns spaces
INVOKINGPROG (data-area) | Full
KATAKANA (data-area) | Partial: returns x"00" meaning "No"
LANGINUSE (data-area) | Validated
LDCMNEM (data-area) | Partial: returns x"00"
LDCNUM (data-area) | Partial: returns x"00"
MAPCOLUMN (data-area) | Full
MAPHEIGHT (data-area) | Full
MAPLINE (data-area) | Full
MAPWIDTH (data-area) | Full
MSRCONTROL (data-area) | Partial: returns x"00" meaning "No"
NATLANGINUSE (data-area) | Partial: returns "E" meaning "English (US)"
NETNAME (data-area) | Full
NEXTTRANSID (data-area) | Full
NUMTAB (data-area) | Partial: returns x"00"
OPCLASS (data-area) | Full
OPERKEYS (data-area) | Full
OPID (data-area) | Full
OPSECURITY (data-area) | Full
ORGABCODE (data-area) | Full
OUTLINE (data-area) | Full
PAGENUM (data-area) | Full
PARTNPAGE (data-area) | Partial: returns spaces
PARTNS (data-area) | Partial: returns x"00" meaning "No"
PARTNSET (data-area) | Partial: returns spaces meaning "No application partition set"
PRINSYSID (data-area) | Full
PROCESS (data-area) | Validated
PROCESSTYPE (data-area) | Validated
PROGRAM (data-area) | Full
PS (data-area) | Full
QNAME (data-area) | Full
RESSEC (data-area) | Full
RESTART (data-area) | Partial: returns x"00" meaning "Normal Start"
RETURNPROG (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SIGDATA (data-area) | Partial: returns spaces
SOSI (data-area) | Full
STARTCODE (data-area) | Full
STATIONID (data-area) | Partial: returns x"00"
SYSID (data-area) | Full
TASKPRIORITY (data-area) | Full
TCTUALENG (data-area) | Full
TELLERID (data-area) | Partial: returns x"00"
TERMCODE (data-area) | Full
TERMPRIORITY (data-area) | Full
TEXTKYBD (data-area) | Partial: returns x"00" meaning "No"
TEXTPRINT (data-area) | Partial: returns x"00" meaning "No"
TRANPRIORITY (data-area) | Full
TWALENG (data-area) | Full
UNATTEND (data-area) | Full
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
USERPRIORITY (data-area) | Full
VALIDATION (data-area) | Partial: returns x"00" meaning "No"


BIF DEEDIT

The BIF DEEDIT function is supported.

Operand | Support
FIELD (data-area) | Full
LENGTH (data-value) | Full


BIF DIGEST

The BIF DIGEST function is not supported.


BUILD ATTACH

The BUILD ATTACH function is not supported.

Operand | Support
ATTACHID (data-value) | Recognized
DATASTR (data-area) | Recognized
IUTYPE (data-area) | Recognized
PROCESS (data-value) | Recognized
QUEUE (data-value) | Recognized
RECFM (data-area) | Recognized
RESOURCE (data-value) | Recognized
RPROCESS (data-value) | Recognized
RRESOURCE (data-value) | Recognized


CANCEL

The CANCEL function is supported.

Operand | Support
REQID (data-value) | Full
SYSID (data-value) | Full
TRANSID (data-value) | Full


CHANGE PASSWORD

The CHANGE PASSWORD function is not supported.

Operand | Support
ESMREASON (data-area) | Recognized
ESMRESP (data-area) | Recognized
NEWPASSWORD (data-value) | Recognized
PASSWORD (data-value) | Recognized
USERID (data-value) | Recognized


CHANGE PHRASE

The CHANGE PHRASE function is supported.

Operand | Support
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
NEWPHRASE (data-area) | Full
NEWPHRASELEN (data-value) | Full
PHRASE (data-area) | Full
PHRASELEN (data-value) | Full
USERID (data-value) | Full


CHECK ACQACTIVITY

The CHECK ACQACTIVITY function is not supported.


CHECK ACQPROCESS

The CHECK ACQPROCESS function is not supported.


CHECK ACTIVITY

The CHECK ACTIVITY function is not supported.


CHECK TIMER

The CHECK TIMER function is not supported.


CONNECT PROCESS

The CONNECT PROCESS function is supported.

Operand | Support
CONVID (data-value) | Full
PARTNER | Validated
PIPLENGTH (data-value) | Full
PIPLIST (data-area) | Full
PROCLENGTH (data-value) | Full
PROCNAME (data-area) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
SYNCLEVEL (data-value) | Full


CONVERSE

The CONVERSE function is supported.

Operand | Support
ALTERNATE | Full
ASIS | Full
CONVID (data-value) | Full
CTLCHAR (data-value) | Full
DEFAULT | Full
DEFRESP | Validated
DEST (data-value) | Validated
ERASE | Full
FMH | Full
FROM (data-area) | Full
FROMFLENGTH (data-value) | Full
FROMLENGTH (data-value) | Full
INTO (data-area) | Full
MAXFLENGTH (data-value) | Full
MAXLENGTH (data-value) | Full
NOTRUNCATE | Full
SESSION (data-value) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full
STRFIELD | Full
TOFLENGTH (data-area) | Full
TOLENGTH (data-area) | Full


CONVERTTIME

The CONVERTTIME function is supported.

Operand | Support
ABSTIME (data-area) | Full
ASKTIME (data-area) | Full
DATESTRING (data-area) | Full


DEFINE ACTIVITY

The DEFINE ACTIVITY function is not supported.


DEFINE COMPOSITE EVENT

The DEFINE COMPOSITE EVENT function is not supported.


DEFINE COUNTER

The DEFINE COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
MAXIMUM (data-value) | Recognized
MINIMUM (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-value) | Recognized


DEFINE DCOUNTER

The DEFINE DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized


DEFINE INPUT EVENT

The DEFINE INPUT EVENT function is not supported.


DEFINE PROCESS

The DEFINE PROCESS function is not supported.


DEFINE TIMER

The DEFINE TIMER function is not supported.


DELAY

The DELAY function is supported.

Operand | Support
FOR | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
MINUTES (data-value) | Full
REQID (data-value) | Full
SECONDS (data-value) | Full
TIME (data-value) | Full
UNTIL | Full


DELETE

The DELETE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
GENERIC | Full
KEYLENGTH (data-value) | Full
NUMREC (data-area) | Full
RBA | Validated
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full


DELETE ACTIVITY

The DELETE ACTIVITY function is not supported.


DELETE CONTAINER

The DELETE CONTAINER function is supported.

Operand | Support
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full


DELETE COUNTER

The DELETE COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
POOL (data-value) | Recognized


DELETE DCOUNTER

The DELETE DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
POOL (data-value) | Recognized


DELETE EVENT

The DELETE EVENT function is not supported.


DELETE RIDFLD

The DELETE RIDFLD function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
GENERIC | Full
KEYLENGTH (data-value) | Full
NUMREC (data-area) | Full
RBA | Validated
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
TOKEN (data-area) | Validated


DELETE TIMER

The DELETE TIMER function is not supported.


DELETEQ

The DELETEQ function is supported.

Operand | Support
QNAME (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full


DELETEQ TD

The DELETEQ TD function is supported.

Operand | Support
QUEUE (data-value) | Full
SYSID (data-value) | Full


DELETEQ TS

The DELETEQ TS function is supported.

Operand | Support
QNAME (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full


DEQ

The DEQ function is supported.

Operand | Support
LENGTH (data-value) | Full
LUW (cvda) | Full
MAXLIFETIME (data-value) | Full
RESOURCE (data-value) | Full
TASK (cvda) | Full


DOCUMENT CREATE

The DOCUMENT CREATE function is supported.

Operand | Support
BINARY (data-area) | Full
DELIMITER (data-value) | Full
DOCSIZE (data-area) | Full
DOCTOKEN (data-area) | Full
FROM (data-area) | Full
FROMDOC (data-area) | Full
HOSTCODEPAGE (data-value) | Full
LENGTH (data-value) | Full
LISTLENGTH (data-value) | Full
SYMBOLLIST (data-area) | Full
TEMPLATE (data-value) | Full
TEXT (data-area) | Full
UNESCAPED | Full


DOCUMENT DELETE

The DOCUMENT DELETE function is supported.

Operand | Support
DOCTOKEN (data-area) | Full


DOCUMENT INSERT

The DOCUMENT INSERT function is supported.

Operand | Support
AT (data-value) | Full
BINARY (data-area) | Full
BOOKMARK (data-value) | Full
DOCSIZE (data-area) | Full
DOCTOKEN (data-area) | Full
FROM (data-area) | Full
FROMDOC (data-area) | Full
HOSTCODEPAGE (data-value) | Full
LENGTH (data-value) | Full
SYMBOL (data-value) | Full
TEMPLATE (data-value) | Full
TEXT (data-area) | Full
TO (data-value) | Full


DOCUMENT RETRIEVE

The DOCUMENT RETRIEVE function is supported.

Operand | Support
CLNTCODEPAGE (data-value) | Full
DATAONLY | Full
DOCTOKEN (data-area) | Full
INTO (data-area) | Full
LENGTH (data-area) | Full
MAXLENGTH (data-value) | Full


DOCUMENT SET

The DOCUMENT SET function is supported.

Operand | Support
DELIMITER (data-value) | Full
DOCTOKEN (data-area) | Full
LENGTH (data-value) | Full
SYMBOL (data-value) | Full
SYMBOLLIST (data-area) | Full
UNESCAPED | Full
VALUE (data-area) | Full


DUMP

The DUMP function is supported.

Operand | Support
COMPLETE | Full
DCT | Full
DUMPCODE (data-value) | Full
FCT | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
PCT | Full
PPT | Full
PROGRAM | Full
SIT | Full
STORAGE | Full
TABLES | Full
TASK | Full
TCT | Full
TERMINAL | Full


DUMP SYSTEM

The DUMP SYSTEM function is supported.

Operand | Support
CALLER (data-value) | Full
CALLERLENGTH (data-value) | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
TITLE (data-value) | Full
TITLELENGTH (data-value) | Full


DUMP TRANSACTION

The DUMP TRANSACTION function is supported.

Operand | Support
COMPLETE | Full
DCT | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
FCT | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
LENGTHLIST (data-area) | Full
NUMSEGMENTS (data-area) | Full
PCT | Full
PPT | Full
PROGRAM | Full
SEGMENTLIST (data-area) | Full
SIT | Full
STORAGE | Full
TABLES | Full
TASK | Full
TCT | Full
TERMINAL | Full
TRT | Full


ENDBR

The ENDBR function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
REQID (data-value) | Full
SYSID (data-value) | Full


ENDBROWSE ACTIVITY

The ENDBROWSE ACTIVITY function is not supported.


ENDBROWSE CONTAINER

The ENDBROWSE CONTAINER function is supported.

Operand | Support
BROWSETOKEN (data-area) | Full


ENDBROWSE EVENT

The ENDBROWSE EVENT function is not supported.


ENDBROWSE PROCESS

The ENDBROWSE PROCESS function is not supported.


ENQ

The ENQ function is supported.

Operand | Support
LENGTH (data-value) | Full
LUW (cvda) | Full
MAXLIFETIME (data-value) | Full
NOSUSPEND | Full
RESOURCE (data-value) | Full
TASK (cvda) | Full
UOW (cvda) | Full


ENTER TRACEID

The ENTER TRACEID function is supported.

Operand | Support
ACCOUNT (data-area) | Validated
ENTRYNAME (data-value) | Validated
FROM (data-area) | Full
MONITOR | Validated
PERFORM | Validated
RESOURCE (data-value) | Validated
TRACEID (data-value) | Full


ENTER TRACENUM

The ENTER TRACENUM function is supported.

Operand | Support
EXCEPTION | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
RESOURCE (data-value) | Full
TRACENUM (data-value) | Full


FEPI

The FEPI function is not supported.


FORCE TIMER

The FORCE TIMER function is not supported.


FORMATTIME

The FORMATTIME function is supported.

Operand | Support
ABSTIME (data-area) | Full
DATE (data-area) | Full
DATEFORM (data-area) | Full
DATESEP (data-value) | Full
DATESTRING (data-area) | Full
DAYCOUNT (data-area) | Full
DAYOFMONTH (data-area) | Full
DAYOFWEEK (data-area) | Full
DDMMYY (data-area) | Full
DDMMYYYY (data-area) | Full
FULLDATE (data-area) | Full
MILLISECONDS (data-area) | Full
MMDDYY (data-area) | Full
MMDDYYYY (data-area) | Full
MONTHOFYEAR (data-area) | Full
RFC1123 (cvda) | Full
RFC3339 (cvda) | Full
STRINGFORMAT (data-value) | Full
TIME (data-area) | Full
TIMESEP (data-value) | Full
YEAR (data-area) | Full
YYDDD (data-area) | Full
YYDDMM (data-area) | Full
YYMMDD (data-area) | Full
YYYYDDD (data-area) | Full
YYYYDDMM (data-area) | Full
YYYYMMDD (data-area) | Full


FREE

The FREE function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


FREEMAIN

The FREEMAIN function is supported.

Operand | Support
DATA (data-area) | Full
DATAPOINTER (ptr-ref) | Full


GDS ALLOCATE

The GDS ALLOCATE function is supported.

Operand | Support
CONVID (data-area) | Full
MODENAME (data-value) | Validated
NOQUEUE | Full
PARTNER (data-value) | Validated
RETCODE (data-area) | Full
STATE (cvda) | Full
SYSID (data-value) | Full


GDS ASSIGN

The GDS ASSIGN function is supported.

Operand | Support
PRINCONVID (data-area) | Full
PRINSYSID (data-area) | Full
RETCODE (data-area) | Full


GDS CONNECT PROCESS

The GDS CONNECT PROCESS function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
PARTNER (data-value) | Validated
PIPLENGTH (data-value) | Full
PIPLIST (data-area) | Full
PROCLENGTH (data-value) | Full
PROCNAME (data-area) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
SYNCLEVEL (data-value) | Full


GDS EXTRACT ATTRIBUTES

The GDS EXTRACT ATTRIBUTES function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS EXTRACT PROCESS

The GDS EXTRACT PROCESS function is supported.

Operand | Support
CONVID (data-area) | Full
MAXPROCLEN (data-area) | Full
PIPLENGTH (data-area) | Full
PIPLIST (ptr-ref) | Full
PROCLENGTH (data-area) | Full
PROCNAME (data-area) | Full
RETCODE (data-area) | Full
SYNCLEVEL (data-area) | Full


GDS FREE

The GDS FREE function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS ISSUE ABEND

The GDS ISSUE ABEND function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS ISSUE CONFIRMATION

The GDS ISSUE CONFIRMATION function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS ISSUE ERROR

The GDS ISSUE ERROR function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS ISSUE PREPARE

The GDS ISSUE PREPARE function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS ISSUE SIGNAL

The GDS ISSUE SIGNAL function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GDS RECEIVE

The GDS RECEIVE function is supported.

Operand | Support
BUFFER | Full
CONVDATA (data-area) | Full
CONVID (data-area) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
LLID | Full
MAXFLENGTH (data-value) | Full
RETCODE (data-area) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full


GDS SEND

The GDS SEND function is supported.

Operand | Support
CONFIRM | Full
CONVDATA (data-area) | Full
CONVID (data-value) | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
INVITE | Full
LAST | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
WAIT | Full


GDS WAIT

The GDS WAIT function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full


GET CONTAINER

The GET CONTAINER function is supported.

Operand | Support
ACQACTIVITY | Validated
ACQPROCESS | Validated
ACTIVITY (data-value) | Validated
CCSID (data-area) | Full
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full
CONVERTST (data-value) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
INTOCCSID (data-area) | Full
INTOCODEPAGE (data-value) | Full
NOCONVERT (cvda) | Full
NODATA | Full
PROCESS | Validated
SET (ptr-ref) | Full


GET COUNTER

The GET COUNTER function is not supported.

Operand | Support
COMPAREMAX (data-value) | Recognized
COMPAREMIN (data-value) | Recognized
COUNTER (data-value) | Recognized
INCREMENT (data-value) | Recognized
POOL (data-value) | Recognized
REDUCE | Recognized
VALUE (data-area) | Recognized
WRAP | Recognized


GET DCOUNTER

The GET DCOUNTER function is not supported.

Operand | Support
COMPAREMAX (data-area) | Recognized
COMPAREMIN (data-area) | Recognized
DCOUNTER (data-value) | Recognized
INCREMENT (data-area) | Recognized
POOL (data-value) | Recognized
REDUCE | Recognized
VALUE (data-area) | Recognized
WRAP | Recognized


GETMAIN

The GETMAIN function is supported.

Operand | Support
BELOW | Validated
CICSDATAKEY | Validated
FLENGTH (data-value) | Full
INITIMG (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
SET (ptr-ref) | Full
SHARED | Full
USERDATAKEY | Validated


GETNEXT ACTIVITY

The GETNEXT ACTIVITY function is not supported.


GETNEXT CONTAINER

The GETNEXT CONTAINER function is supported.

Operand | Support
BROWSETOKEN (data-area) | Full
CONTAINER (data-area) | Full


GETNEXT EVENT

The GETNEXT EVENT function is not supported.


GETNEXT PROCESS

The GETNEXT PROCESS function is not supported.


HANDLE ABEND

The HANDLE ABEND function is supported.

Operand | Support
CANCEL | Full
LABEL (label) | Full
PROGRAM (data-value) | Full
RESET | Full


HANDLE AID

The HANDLE AID function is supported.


HANDLE CONDITION

The HANDLE CONDITION function is supported.


IGNORE CONDITION

The IGNORE CONDITION function is supported.


INVOKE SERVICE

The INVOKE SERVICE function is supported.

Operand | Support
CHANNEL (data-value) | Full
OPERATION (data-value) | Full
SCOPE (data-value) | Full
SCOPELEN (data-value) | Full
SERVICE (data-value) | Full
URI (data-value) | Full
URIMAP (data-value) | Full
WEBSERVICE (data-value) | Full


INVOKE WEBSERVICE

The INVOKE WEBSERVICE function is supported.

Operand | Support
CHANNEL (data-value) | Full
OPERATION (data-value) | Full
SCOPE (data-value) | Full
SCOPELEN (data-value) | Full
SERVICE (data-value) | Full
URI (data-value) | Full
URIMAP (data-value) | Full
WEBSERVICE (data-value) | Full


ISSUE ABEND

The ISSUE ABEND function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


ISSUE ABORT

The ISSUE ABORT function is not supported.


ISSUE ADD

The ISSUE ADD function is not supported.


ISSUE CONFIRMATION

The ISSUE CONFIRMATION function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


ISSUE COPY

The ISSUE COPY function is not supported.

Operand | Support
CTLCHAR (data-value) | Recognized
TERMID (data-value) | Recognized
WAIT | Recognized


ISSUE DISCONNECT

The ISSUE DISCONNECT function is supported.


ISSUE END

The ISSUE END function is not supported.


ISSUE ENDFILE

The ISSUE ENDFILE function is not supported.


ISSUE ENDOUTPUT

The ISSUE ENDOUTPUT function is not supported.


ISSUE EODS

The ISSUE EODS function is not supported.


ISSUE ERASE

The ISSUE ERASE function is not supported.


ISSUE ERASEAUP

The ISSUE ERASEAUP function is supported.

Operand | Support
WAIT | Full


ISSUE ERROR

The ISSUE ERROR function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


ISSUE LOAD

The ISSUE LOAD function is not supported.


ISSUE NOTE

The ISSUE NOTE function is not supported.


ISSUE PASS

The ISSUE PASS function is not supported.

Operand | Support
FROM (data-area) | Recognized
LENGTH (data-value) | Recognized
LOGMODE (data-value) | Recognized
LOGONLOGMODE | Recognized
LUNAME (data-value) | Recognized
NOQUIESCE | Recognized


ISSUE PREPARE

The ISSUE PREPARE function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


ISSUE PRINT

The ISSUE PRINT function is supported.


ISSUE QUERY

The ISSUE QUERY function is not supported.


ISSUE RECEIVE

The ISSUE RECEIVE function is not supported.


ISSUE REPLACE

The ISSUE REPLACE function is not supported.


ISSUE RESET

The ISSUE RESET function is supported.


ISSUE SEND

The ISSUE SEND function is not supported.


ISSUE SIGNAL

The ISSUE SIGNAL function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


ISSUE WAIT

The ISSUE WAIT function is not supported.


JOURNAL

The JOURNAL function is supported.

Operand | Support
FROM (data-area) | Full
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
JTYPEID (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
PFXLENG (data-value) | Full
PREFIX (data-area) | Full
REQID (data-area) | Full
STARTIO | Full
WAIT | Full


LINK

The LINK function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
DATALENGTH (data-value) | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
PROGRAM (data-value) | Full
SYNCONRETURN | Full
SYSID (data-value) | Full
TRANSID (data-value) | Full


LINK ACQACTIVITY

The LINK ACQACTIVITY function is not supported.


LINK ACQPROCESS

The LINK ACQPROCESS function is not supported.


LINK ACTIVITY

The LINK ACTIVITY function is not supported.


LOAD

The LOAD function is supported.

Operand | Support
ENTRY (ptr-ref) | Full
FLENGTH (data-area) | Full
HOLD | Full
LENGTH (data-area) | Full
PROGRAM (data-value) | Full
SET (ptr-ref) | Full


MONITOR

The MONITOR function is not supported.

Operand | Support
DATA1 (data-area) | Recognized
DATA2 (data-area) | Recognized
ENTRYNAME (data-area) | Recognized
POINT (data-value) | Recognized


MOVE CONTAINER

The MOVE CONTAINER function is supported.

Operand | Support
AS (data-value) | Full
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full
TOCHANNEL (data-value) | Full


POINT

The POINT function is not supported.


POP

The POP function is supported.


POP HANDLE

The POP HANDLE function is supported.


POST

The POST function is supported.

Operand | Support
AFTER | Full
AT | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
MINUTES (data-value) | Full
REQID (data-value) | Full
SECONDS (data-value) | Full
SET (ptr-ref) | Full
TIME (data-value) | Full


PURGE MESSAGE

The PURGE MESSAGE function is supported.


PUSH

The PUSH function is supported.


PUSH HANDLE

The PUSH HANDLE function is supported.


PUT CONTAINER

The PUT CONTAINER function is supported.

Operand | Support
ACQACTIVITY | Validated
ACQPROCESS | Validated
ACTIVITY (data-value) | Validated
APPEND (cvda) | Full
BIT (cvda) | Full
CHANNEL (data-value) | Full
CHAR (cvda) | Full
CONTAINER (data-value) | Full
DATATYPE (data-value) | Full
FLENGTH (data-area) | Full
FROM (data-area) | Full
FROMCCSID (data-area) | Full
FROMCODEPAGE (data-value) | Full
PROCESS | Validated


QUERY COUNTER

The QUERY COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized


QUERY DCOUNTER

The QUERY DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized


QUERY SECURITY

The QUERY SECURITY function is supported.

Operand | Support
ALTER (data-area) | Full
CONTROL (data-area) | Full
LOG (cvda) | Full
LOGMESSAGE (data-value) | Full
NOLOG (cvda) | Full
READ (data-area) | Full
RESCLASS (data-value) | Full
RESID (data-value) | Full
RESIDLENGTH (data-value) | Full
RESTYPE (data-value) | Full
UPDATE (data-area) | Full


READ

The READ function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
DEBKEY | Validated
DEBREC | Validated
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
NOSUSPEND | Full
RBA | Full
REPEATABLE | Validated
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full


READNEXT

The READNEXT function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
FILE (data-value) | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
RBA | Full
REPEATABLE | Validated
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full


READPREV

The READPREV function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
FILE (data-value) | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
RBA | Full
REPEATABLE | Validated
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full


READQ

The READQ function is supported.

Operand | Support
INTO (data-area) | Full
ITEM (data-value) | Full
LENGTH (data-area) | Full
NEXT | Full
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full


READQ TD

The READQ TD function is supported.

Operand | Support
INTO (data-area) | Full
LENGTH (data-area) | Full
NOSUSPEND | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full


READQ TS

The READQ TS function is supported.

Operand | Support
INTO (data-area) | Full
ITEM (data-value) | Full
LENGTH (data-area) | Full
NEXT | Full
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full


RECEIVE

The RECEIVE function is supported.

Operand | Support
ASIS | Full
BUFFER | Full
CONVID (data-value) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
LEAVEKB | Validated
LENGTH (data-area) | Full
MAXFLENGTH (data-value) | Full
MAXLENGTH (data-value) | Full
NOTRUNCATE | Full
SESSION (data-value) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full


RECEIVE MAP

The RECEIVE MAP function is supported.

Operand | Support
ASIS | Full
FROM (data-area) | Full
INPARTN (data-value) | Validated
INTO (data-area) | Full
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPSET (data-value) | Full
SET (ptr-ref) | Full
TERMINAL | Full


RECEIVE MAP MAPPINGDEV

The RECEIVE MAP MAPPINGDEV function is not supported.

Operand | Support
AID (data-area) | Recognized
CURSOR (data-value) | Recognized
FROM (data-area) | Recognized
INTO (data-area) | Recognized
LENGTH (data-value) | Recognized
MAP (data-value) | Recognized
MAPPINGDEV (data-value) | Recognized
MAPSET (data-value) | Recognized
SET (ptr-ref) | Recognized


RECEIVE MAPSET

The RECEIVE MAPSET function is supported.

Operand | Support
ASIS | Full
FROM (data-area) | Full
INPARTN (data-value) | Validated
INTO (data-area) | Full
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPSET (data-value) | Full
SET (ptr-ref) | Full
TERMINAL | Full


RECEIVE PARTN

The RECEIVE PARTN function is not supported.

Operand | Support
ASIS | Recognized
INTO (data-area) | Recognized
LENGTH (data-area) | Recognized
PARTN (data-area) | Recognized
SET (ptr-ref) | Recognized


RELEASE

The RELEASE function is supported.

Operand | Support
PROGRAM (data-value) | Full


REMOVE SUBEVENT

The REMOVE SUBEVENT function is not supported.


RESET ACQPROCESS

The RESET ACQPROCESS function is not supported.


RESET ACTIVITY

The RESET ACTIVITY function is not supported.


RESETBR

The RESETBR function is supported.

Operand | Support
DATASET (data-value) | Full
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
KEYLENGTH (data-value) | Full
RBA | Full
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full


RESUME

The RESUME function is not supported.


RETRIEVE

The RETRIEVE function is supported.

Operand | Support
INTO (data-area) | Full
LENGTH (data-area) | Full
QUEUE (data-area) | Full
RTERMID (data-area) | Full
RTRANSID (data-area) | Full
SET (ptr-ref) | Full
WAIT | Full


RETRIEVE REATTACH

The RETRIEVE REATTACH function is not supported.


RETRIEVE SUBEVENT

The RETRIEVE SUBEVENT function is not supported.


RETURN

The RETURN function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
ENDACTIVITY | Validated
IMMEDIATE | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
TRANSID (data-value) | Full


REWIND COUNTER

The REWIND COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
INCREMENT (data-value) | Recognized
POOL (data-value) | Recognized


REWIND DCOUNTER

The REWIND DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
INCREMENT (data-area) | Recognized
POOL (data-value) | Recognized


REWRITE

The REWRITE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full


ROUTE

The ROUTE function is not supported.

Operand | Support
AFTER | Recognized
AT | Recognized
ERRTERM (data-value) | Recognized
HOURS (data-value) | Recognized
INTERVAL (data-value) | Recognized
LDC (data-value) | Recognized
LIST (data-area) | Recognized
MINUTES (data-value) | Recognized
NLEOM | Recognized
OPCLASS (data-area) | Recognized
REQID (data-value) | Recognized
SECONDS (data-value) | Recognized
TIME (data-value) | Recognized
TITLE (data-area) | Recognized


RUN

The RUN function is not supported.


SEND

The SEND function is supported.

Operand | Support
ALTERNATE | Full
ATTACHID (data-value) | Validated
CNOTCOMPL | Validated
CONFIRM | Full
CONVID (data-value) | Full
CTLCHAR (data-value) | Full
DEFAULT | Full
DEFRESP | Validated
DEST (data-value) | Validated
ERASE | Full
FLENGTH (data-value) | Full
FMH | Full
FROM (data-area) | Full
INVITE | Full
LAST | Full
LEAVEKB | Validated
LENGTH (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
STRFIELD | Full
WAIT | Full


SEND CONTROL

The SEND CONTROL function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FORMFEED | Full
FREEKB | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
MSR (data-value) | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full


SEND MAP

The SEND MAP function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DATAONLY | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FMHPARM | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPONLY | Full
MAPSET (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
NOFLUSH | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full


SEND MAP MAPPINGDEV

The SEND MAP MAPPINGDEV function is not supported.

Operand | Support
ALARM | Recognized
CURSOR (data-value) | Recognized
DATAONLY | Recognized
ERASE | Recognized
ERASEAUP | Recognized
FORMFEED | Recognized
FREEKB | Recognized
FROM (data-area) | Recognized
FRSET | Recognized
LENGTH (data-value) | Recognized
MAP (data-value) | Recognized
MAPONLY | Recognized
MAPPINGDEV (data-value) | Recognized
MAPSET (data-value) | Recognized
PRINT | Recognized
SET (ptr-ref) | Recognized


SEND MAPSET

The SEND MAPSET function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DATAONLY | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FMHPARM | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPONLY | Full
MAPSET (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
NOFLUSH | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full


SEND PAGE

The SEND PAGE function is supported.

Operand | Support
ALL | Validated
AUTOPAGE | Full
CURRENT | Validated
FMHPARM (data-value) | Validated
LAST | Full
NOAUTOPAGE | Full
OPERPURGE | Full
RELEASE | Full
RETAIN | Full
SET (ptr-ref) | Full
TRAILER (data-area) | Full
TRANSID (data-value) | Full


SEND PARTNSET

The SEND PARTNSET function is not supported.

Operand | Support
PARTNSET (data-value) | Recognized


SEND TEXT

The SEND TEXT function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DEFAULT | Full
ERASE | Full
FMHPARM (data-value) | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
HEADER (data-area) | Full
HONEOM | Full
JUSFIRST (cvda) | Full
JUSLAST (cvda) | Full
JUSTIFY (data-value) | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
TRAILER (data-area) | Full
WAIT | Full


SEND TEXT MAPPED

The SEND TEXT MAPPED function is supported.

Operand | Support
FROM (data-area) | Full
LAST | Full
LENGTH (data-value) | Full
PAGING | Full
REQID (data-value) | Validated
TERMINAL | Full
WAIT | Full


SEND TEXT NOEDIT

The SEND TEXT NOEDIT function is supported.

Operand | Support
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Validated
DEFAULT | Full
ERASE | Full
FREEKB | Full
FROM (data-area) | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LENGTH (data-value) | Full
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
TERMINAL | Full
WAIT | Full


SIGNAL EVENT

The SIGNAL EVENT function is not supported.


SIGNOFF

The SIGNOFF function is supported.


SIGNON

The SIGNON function is supported.

Operand | Support
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
GROUPID (data-value) | Full
LANGINUSE (data-area) | Validated
LANGUAGECODE (data-value) | Validated
NATLANG (data-value) | Validated
NATLANGINUSE (data-area) | Validated
NEWPASSWORD (data-value) | Full
NEWPHRASE (data-area) | Full
NEWPHRASELEN (data-value) | Full
OIDCARD (data-value) | Validated
PASSWORD (data-value) | Full
PHRASE (data-area) | Full
PHRASELEN (data-value) | Full
USERID (data-value) | Full


SOAPFAULT ADD

The SOAPFAULT ADD function is supported.

Operand | Support
FAULTSTRING (data-value) | Full
FAULTSTRLEN (data-value) | Full
FROMCCSID (data-value) | Full
NATLANG (data-value) | Validated
SUBCODELEN (data-value) | Validated
SUBCODESTR (data-value) | Validated


SOAPFAULT CREATE

The SOAPFAULT CREATE function is supported.

Operand | Support
CLIENT (cvda) | Full
DETAIL (data-value) | Full
DETAILLENGTH (data-value) | Full
FAULTACTLEN (data-value) | Full
FAULTACTOR (data-value) | Full
FAULTCODE (data-value) | Full
FAULTCODELEN (data-value) | Full
FAULTCODESTR (data-value) | Full
FAULTSTRING (data-value) | Full
FAULTSTRLEN (data-value) | Full
FROMCCSID (data-value) | Full
NATLANG (data-value) | Validated
RECEIVER (cvda) | Full
ROLE (data-value) | Full
ROLELENGTH (data-value) | Full
SENDER (cvda) | Full
SERVER (cvda) | Full


SOAPFAULT DELETE

The SOAPFAULT DELETE function is supported.


SPOOLCLOSE

The SPOOLCLOSE function is supported.

Operand | Support
DELETE | Full
KEEP | Full
TOKEN (data-value) | Full


SPOOLCLOSE REPORT

The SPOOLCLOSE REPORT function is supported.

Operand | Support
DELETE | Full
DISP (data-value) | Full
HOLD | Full
KEEP | Full
LOG | Validated
RELEASE | Full
REPORT (data-value) | Full
RESUME | Validated
TOKEN (data-value) | Full


SPOOLOPEN ESCAPE

The SPOOLOPEN ESCAPE function is not supported.


SPOOLOPEN INPUT

The SPOOLOPEN INPUT function is not supported.

Operand | Support
CLASS (data-value) | Recognized
TOKEN (data-area) | Recognized
USERID (data-value) | Recognized


SPOOLOPEN MAPNAME

The SPOOLOPEN MAPNAME function is not supported.


SPOOLOPEN OUTPUT

The SPOOLOPEN OUTPUT function is supported.

Operand | Support
ASA | Full
CLASS (data-value) | Full
MCC | Full
NOCC | Full
NODE (data-value) | Full
OUTDESCR (ptr-ref) | Partial: handles USERID and recognizes other values
PRINT | Full
PUNCH | Full
RECORDLENGTH (data-value) | Full
TOKEN (data-area) | Full
USERID (data-value) | Partial: handles * and recognizes other values


SPOOLOPEN REPORT ASA

The SPOOLOPEN REPORT ASA function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full


SPOOLOPEN REPORT JCL

The SPOOLOPEN REPORT JCL function is supported.

Operand | Support
JCL | Full
LOG | Validated
REPORT (data-value) | Full
TOKEN (data-area) | Full


SPOOLOPEN REPORT MCC

The SPOOLOPEN REPORT MCC function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full


SPOOLOPEN REPORT NOCC

The SPOOLOPEN REPORT NOCC function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full


SPOOLOPEN REPORT SCS

The SPOOLOPEN REPORT SCS function is not supported.


SPOOLOPEN REPORT T3270

The SPOOLOPEN REPORT T3270 function is not supported.


SPOOLOPEN RESUME

The SPOOLOPEN RESUME function is not supported.


SPOOLREAD

The SPOOLREAD function is not supported.

Operand | Support
INTO (data-area) | Recognized
MAXFLENGTH (data-value) | Recognized
TOFLENGTH (data-value) | Recognized
TOKEN (data-value) | Recognized


SPOOLWRITE

The SPOOLWRITE function is supported.

Operand | Support
FLENGTH (data-value) | Full
FROM (data-area) | Full
LINE | Full
PAGE | Full
TOKEN (data-value) | Full


SPOOLWRITE MAPNAME

The SPOOLWRITE MAPNAME function is not supported.


SPOOLWRITE REPORT

The SPOOLWRITE REPORT function is supported.

Operand | Support
FLENGTH (data-value) | Full
FROM (data-area) | Full
LOG | Validated
REPORT (data-value) | Full
TOKEN (data-value) | Full


START

The START function is supported.

Operand | Support
AFTER | Full
AT | Full
FMH | Validated
FROM (data-area) | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
LENGTH (data-value) | Full
MINUTES (data-value) | Full
NOCHECK | Full
PROTECT | Full
QUEUE (data-value) | Full
REQID (data-value) | Full
RTERMID (data-value) | Full
RTRANSID (data-value) | Full
SECONDS (data-value) | Full
SYSID (data-value) | Full
TERMID (data-value) | Full
TIME (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full


START ATTACH

The START ATTACH function is not supported.

Operand | Support
FROM (data-area) | Recognized
LENGTH (data-value) | Recognized
TRANSID (data-value) | Recognized


START BREXIT

The START BREXIT function is supported.

Operand | Support
BRDATA (data-area) | Full
BRDATALENGTH (data-area) | Full
BREXIT (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full


START CHANNEL

The START CHANNEL function is supported.

Operand | Support
CHANNEL (data-value) | Full
SYSID (data-value) | Full
TERMID (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full


STARTBR

The STARTBR function is supported.

Operand | Support
DATASET (data-value) | Full
DEBKEY | Validated
DEBREC | Validated
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
KEYLENGTH (data-value) | Full
RBA | Full
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full


STARTBROWSE ACTIVITY

The STARTBROWSE ACTIVITY function is not supported.


STARTBROWSE CONTAINER

The STARTBROWSE CONTAINER function is supported.

Operand | Support
ACTIVITYID (data-value) | Validated
BROWSETOKEN (data-area) | Full
CHANNEL (data-value) | Full
PROCESS (data-value) | Validated
PROCESSTYPE (data-value) | Validated


STARTBROWSE EVENT

The STARTBROWSE EVENT function is not supported.


STARTBROWSE PROCESS

The STARTBROWSE PROCESS function is not supported.


SUSPEND

The SUSPEND function is supported.


SYNCPOINT

The SYNCPOINT function is supported.

Operand | Support
ROLLBACK | Full


TEST EVENT

The TEST EVENT function is not supported.


TRACE

The TRACE function is not supported.


TRANSFORM DATATOXML

The TRANSFORM DATATOXML function is supported.

Operand | Support
CHANNEL (data-value) | Full
DATCONTAINER (data-value) | Full
ELEMNAME (data-area) | Full
ELEMNAMELEN (data-area) | Full
ELEMNS (data-area) | Full
ELEMNSLEN (data-area) | Full
TYPENAME (data-area) | Validated
TYPENAMELEN (data-area) | Validated
TYPENS (data-area) | Validated
TYPENSLEN (data-area) | Validated
XMLCONTAINER (data-value) | Full
XMLTRANSFORM (data-value) | Full


TRANSFORM XMLTODATA

The TRANSFORM XMLTODATA function is supported.

Operand | Support
CHANNEL (data-value) | Full
DATCONTAINER (data-value) | Full
ELEMNAME (data-area) | Full
ELEMNAMELEN (data-area) | Full
ELEMNS (data-area) | Full
ELEMNSLEN (data-area) | Full
NSCONTAINER (data-value) | Validated
TYPENAME (data-area) | Validated
TYPENAMELEN (data-area) | Validated
TYPENS (data-area) | Validated
TYPENSLEN (data-area) | Validated
XMLCONTAINER (data-value) | Full
XMLTRANSFORM (data-value) | Full


UNLOCK

The UNLOCK function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full


UPDATE COUNTER

The UPDATE COUNTER function is not supported.

Operand | Support
COMPAREMAX (data-value) | Recognized
COMPAREMIN (data-value) | Recognized
COUNTER (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-value) | Recognized


UPDATE DCOUNTER

The UPDATE DCOUNTER function is not supported.

Operand | Support
COMPAREMAX (data-area) | Recognized
COMPAREMIN (data-area) | Recognized
DCOUNTER (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized


VERIFY PASSWORD

The VERIFY PASSWORD function is supported.

Operand | Support
CHANGETIME (data-area) | Full
DAYSLEFT (data-area) | Full
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
EXPIRYTIME (data-area) | Full
INVALIDCOUNT (data-area) | Full
LASTUSETIME (data-area) | Full
PASSWORD (data-value) | Full
USERID (data-value) | Full


VERIFY PHRASE

The VERIFY PHRASE function is supported.

Operand | Support
CHANGETIME (data-area) | Full
DAYSLEFT (data-area) | Full
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
EXPIRYTIME (data-area) | Full
INVALIDCOUNT (data-area) | Full
LASTUSETIME (data-area) | Full
PHRASE (data-area) | Full
PHRASELEN (data-value) | Full
USERID (data-value) | Full


WAIT CONVID

The WAIT CONVID function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full


WAIT EVENT

The WAIT EVENT function is supported.

Operand | Support
ECADDR (ptr-ref) | Full
NAME (data-value) | Full


WAIT EXTERNAL

The WAIT EXTERNAL function is not supported.

Operand | Support
ECBLIST (data-area) | Recognized
NAME (data-value) | Recognized
NOTPURGEABLE (cvda) | Recognized
NUMEVENTS (data-value) | Recognized
PURGEABILITY (data-value) | Recognized
PURGEABLE (cvda) | Recognized


WAIT JOURNAL

The WAIT JOURNAL function is supported.

Operand | Support
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
REQID (data-value) | Full
STARTIO | Full


WAIT JOURNALNAME

The WAIT JOURNALNAME function is not supported.

Operand | Support
JOURNALNAME (data-value) | Recognized
REQID (data-value) | Recognized


WAIT JOURNALNUM

The WAIT JOURNALNUM function is supported.

Operand | Support
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
REQID (data-value) | Full
STARTIO | Full


WAIT SIGNAL

The WAIT SIGNAL function is not supported.


WAIT TERMINAL

The WAIT TERMINAL function is not supported.


WAITCICS

The WAITCICS function is supported.

Operand | Support
ECBLIST (data-area) | Full
NAME (data-value) | Full
NOTPURGEABLE (cvda) | Full
NUMEVENTS (data-value) | Full
PURGEABILITY (data-value) | Full
PURGEABLE (cvda) | Full


WEB CLOSE

The WEB CLOSE function is supported.

Operand | Support
SESSTOKEN (data-area) | Full


WEB CONVERSE

The WEB CONVERSE function is supported.

Operand | Support
ACTION (data-value) | Full
AUTHENTICATE (data-value) | Full
BASICAUTH (cvda) | Full
BODYCHARSET (data-area) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DELETE (cvda) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EXPECT (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
GET (cvda) | Full
HEAD (cvda) | Full
INTO (data-area) | Full
MAXLENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
METHOD (data-value) | Full
NOCLICONVERT (cvda) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NOINCONVERT (cvda) | Full
NONE (cvda) | Full
NOOUTCONVERT (cvda) | Full
NOTRUNCATE | Full
OPTIONS (cvda) | Full
PASSWORD (data-area) | Full
PASSWORDLEN (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
POST (cvda) | Full
PUT (cvda) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SESSTOKEN (data-area) | Full
SET (ptr-ref) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full
TOLENGTH (data-area) | Full
TRACE (cvda) | Full
URIMAP (data-value) | Full
USERNAME (data-area) | Full
USERNAMELEN (data-value) | Full


WEB ENDBROWSE FORMFIELD

The WEB ENDBROWSE FORMFIELD function is supported.

Operand | Support
FORMFIELD | Full


WEB ENDBROWSE HTTPHEADER

The WEB ENDBROWSE HTTPHEADER function is supported.

Operand | Support
HTTPHEADER | Full
SESSTOKEN (data-area) | Full


WEB ENDBROWSE QUERYPARM

The WEB ENDBROWSE QUERYPARM function is supported.

Operand | Support
QUERYPARM | Full


WEB EXTRACT

The WEB EXTRACT function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
HTTPMETHOD (data-area) | Full
HTTPVERSION (data-area) | Full
METHODLENGTH (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
REALM (data-area) | Full
REALMLEN (data-value) | Full
REQUESTTYPE (cvda) | Full
SCHEME (cvda) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-area) | Full
VERSIONLEN (data-value) | Full


WEB OPEN

The WEB OPEN function is supported.

Operand | Support
CERTIFICATE (data-value) | Full
CIPHERS (data-value) | Full
CODEPAGE (data-value) | Full
HOST (data-value) | Full
HOSTLENGTH (data-value) | Full
HTTP (cvda) | Full
HTTPRNUM (data-area) | Full
HTTPS (cvda) | Full
HTTPVNUM (data-area) | Full
NUMCIPHERS (data-value) | Full
PORTNUMBER (data-value) | Full
SCHEME (data-value) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-value) | Full


WEB PARSE

The WEB PARSE function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SCHEMENAME (data-area) | Full
URL (data-value) | Full
URLLENGTH (data-value) | Full


WEB READ FORMFIELD

The WEB READ FORMFIELD function is supported.

Operand | Support
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
FORMFIELD (data-area) | Full
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
SET (ptr-ref) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB READ HTTPHEADER

The WEB READ HTTPHEADER function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB READ QUERYPARM

The WEB READ QUERYPARM function is supported.

Operand | Support
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
QUERYPARM (data-area) | Full
SET (ptr-ref) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB READNEXT FORMFIELD

The WEB READNEXT FORMFIELD function is supported.

Operand | Support
FORMFIELD (data-area) | Full
NAMELENGTH (data-value) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB READNEXT HTTPHEADER

The WEB READNEXT HTTPHEADER function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB READNEXT QUERYPARM

The WEB READNEXT QUERYPARM function is supported.

Operand | Support
NAMELENGTH (data-value) | Full
QUERYPARM (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WEB RECEIVE

The WEB RECEIVE function is supported.

Operand | Support
BODYCHARSET (data-area) | Full
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
HOSTCODEPAGE (data-value) | Full
INTO (data-area) | Full
LENGTH (data-area) | Full
MAXLENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
NOSRVCONVERT (cvda) | Full
NOTRUNCATE | Full
SERVERCONV (data-value) | Full
SET (ptr-ref) | Full
SRVCONVERT (cvda) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full
TYPE (cvda) | Full


WEB RECEIVE SESSTOKEN

The WEB RECEIVE SESSTOKEN function is supported.

Operand | Support
BODYCHARSET (data-area) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
INTO (data-area) | Full
LENGTH (data-value) | Full
MAXLENGTH (data-area) | Full
MEDIATYPE (data-area) | Full
NOCLICONVERT (cvda) | Full
NOTRUNCATE | Full
SESSTOKEN (data-area) | Full
SET (ptr-ref) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full


WEB RETRIEVE

The WEB RETRIEVE function is supported.

Operand | Support
DOCTOKEN (data-value) | Full


WEB SEND

The WEB SEND function is supported.

Operand | Support
ACTION (data-value) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CHUNKEND (cvda) | Full
CHUNKING (data-value) | Full
CHUNKNO (cvda) | Full
CHUNKYES (cvda) | Full
CLNTCODEPAGE (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EVENTUAL (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
HOSTCODEPAGE (data-value) | Full
IMMEDIATE (cvda) | Full
LENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NOSRVCONVERT (cvda) | Full
SERVERCONV (data-value) | Full
SRVCONVERT (cvda) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full


WEB SEND SESSTOKEN

The WEB SEND SESSTOKEN function is supported.

Operand | Support
ACTION (data-value) | Full
AUTHENTICATE (data-value) | Full
BASICAUTH (cvda) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CHUNKEND (cvda) | Full
CHUNKING (data-value) | Full
CHUNKNO (cvda) | Full
CHUNKYES (cvda) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DELETE (cvda) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EXPECT (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
GET (cvda) | Full
HEAD (cvda) | Full
MEDIATYPE (data-value) | Full
METHOD (data-value) | Full
NOCLICONVERT (cvda) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NONE (cvda) | Full
OPTIONS (cvda) | Full
PASSWORD (data-area) | Full
PASSWORDLEN (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
POST (cvda) | Full
PUT (cvda) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SESSTOKEN (data-area) | Full
TRACE (cvda) | Full
URIMAP (data-value) | Full
USERNAME (data-area) | Full
USERNAMELEN (data-value) | Full


WEB STARTBROWSE FORMFIELD

The WEB STARTBROWSE FORMFIELD function is supported.

Operand | Support
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
FORMFIELD (data-value) | Full
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full


WEB STARTBROWSE HTTPHEADER

The WEB STARTBROWSE HTTPHEADER function is supported.

Operand | Support
HTTPHEADER | Full
SESSTOKEN (data-area) | Full


WEB STARTBROWSE QUERYPARM

The WEB STARTBROWSE QUERYPARM function is supported.

Operand | Support
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
QUERYPARM (data-value) | Full


WEB WRITE

The WEB WRITE function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full


WRITE

The WRITE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
FROM (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-value) | Full
MASSINSERT | Full
NOSUSPEND | Validated
RBA | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full


WRITE JOURNALNAME

The WRITE JOURNALNAME function is not supported.

Operand | Support
FLENGTH (data-value) | Recognized
FROM (data-area) | Recognized
JOURNALNAME (data-value) | Recognized
JTYPEID (data-value) | Recognized
NOSUSPEND | Recognized
PFXLENG (data-value) | Recognized
PREFIX (data-area) | Recognized
REQID (data-area) | Recognized
WAIT | Recognized


WRITE JOURNALNUM

The WRITE JOURNALNUM function is supported.

Operand | Support
FROM (data-area) | Full
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
JTYPEID (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
PFXLENG (data-value) | Full
PREFIX (data-area) | Full
REQID (data-area) | Full
STARTIO | Full
WAIT | Full


WRITE OPERATOR

The WRITE OPERATOR function is supported.

Operand | Support
ACTION (data-value) | Full
CRITICAL (cvda) | Full
EVENTUAL (cvda) | Full
IMMEDIATE (cvda) | Full
MAXLENGTH (data-value) | Full
NUMROUTES (data-value) | Validated
REPLY (data-area) | Partial: not yet implemented
REPLYLENGTH (data-area) | Full
ROUTECODES (data-value) | Validated
TEXT (data-value) | Full
TEXTLENGTH (data-value) | Full
TIMEOUT (data-value) | Full


WRITEQ

The WRITEQ function is supported.

Operand | Support
AUXILIARY | Full
FROM (data-area) | Full
ITEM (data-area) | Full
LENGTH (data-value) | Full
MAIN | Full
NOSUSPEND | Validated
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
REWRITE | Full
SYSID (data-value) | Full


WRITEQ TD

The WRITEQ TD function is supported.

Operand | Support
FROM (data-area) | Full
LENGTH (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full


WRITEQ TS

The WRITEQ TS function is supported.

Operand | Support
AUXILIARY | Full
FROM (data-area) | Full
ITEM (data-area) | Full
LENGTH (data-value) | Full
MAIN | Full
NOSUSPEND | Validated
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
REWRITE | Full
SYSID (data-value) | Full


WSACONTEXT BUILD

The WSACONTEXT BUILD function is not supported.


WSACONTEXT DELETE

The WSACONTEXT DELETE function is not supported.


WSACONTEXT GET

The WSACONTEXT GET function is not supported.


WSAEPR CREATE

The WSAEPR CREATE function is not supported.


WSAEPR EVENT

The WSAEPR EVENT function is not supported.


XCTL

The XCTL function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
PROGRAM (data-value) | Full


CICS SPI Calls

  • ACQUIRE TERMINAL
    The ACQUIRE TERMINAL function is not supported.
  • COLLECT STATISTICS
    The COLLECT STATISTICS function is not supported.
  • CREATE CONNECTION
    The CREATE CONNECTION function is not supported.
  • CREATE CORBASERVER
    The CREATE CORBASERVER function is not supported.
  • CREATE DB2CONN
    The CREATE DB2CONN function is not supported.
  • CREATE DB2ENTRY
    The CREATE DB2ENTRY function is not supported.
  • CREATE DB2TRAN
    The CREATE DB2TRAN function is not supported.
  • CREATE DJAR
    The CREATE DJAR function is not supported.
  • CREATE DOCTEMPLATE
    The CREATE DOCTEMPLATE function is not supported.
  • CREATE ENQMODEL
    The CREATE ENQMODEL function is not supported.
  • CREATE FILE
    The CREATE FILE function is not supported.
  • CREATE JOURNALMODEL
    The CREATE JOURNALMODEL function is not supported.
  • CREATE LSRPOOL
    The CREATE LSRPOOL function is not supported.
  • CREATE MAPSET
    The CREATE MAPSET function is not supported.
  • CREATE PARTITIONSET
    The CREATE PARTITIONSET function is not supported.
  • CREATE PARTNER
    The CREATE PARTNER function is not supported.
  • CREATE PROCESSTYPE
    The CREATE PROCESSTYPE function is not supported.
  • CREATE PROFILE
    The CREATE PROFILE function is not supported.
  • CREATE PROGRAM
    The CREATE PROGRAM function is not supported.
  • CREATE REQUESTMODEL
    The CREATE REQUESTMODEL function is not supported.
  • CREATE SESSIONS
    The CREATE SESSIONS function is not supported.
  • CREATE TCPIPSERVICE
    The CREATE TCPIPSERVICE function is not supported.
  • CREATE TDQUEUE
    The CREATE TDQUEUE function is not supported.
  • CREATE TERMINAL
    The CREATE TERMINAL function is not supported.
  • CREATE TRANCLASS
    The CREATE TRANCLASS function is not supported.
  • CREATE TRANSACTION
    The CREATE TRANSACTION function is not supported.
  • CREATE TSMODEL
    The CREATE TSMODEL function is not supported.
  • CREATE TYPETERM
    The CREATE TYPETERM function is not supported.
  • DISABLE PROGRAM
    The DISABLE PROGRAM function is supported.
  • DISCARD AUTINSTMODEL
    The DISCARD AUTINSTMODEL function is not supported.
  • DISCARD CONNECTION
    The DISCARD CONNECTION function is not supported.
  • DISCARD CORBASERVER
    The DISCARD CORBASERVER function is not supported.
  • DISCARD DB2CONN
    The DISCARD DB2CONN function is not supported.
  • DISCARD DB2ENTRY
    The DISCARD DB2ENTRY function is not supported.
  • DISCARD DB2TRAN
    The DISCARD DB2TRAN function is not supported.
  • DISCARD DJAR
    The DISCARD DJAR function is not supported.
  • DISCARD DOCTEMPLATE
    The DISCARD DOCTEMPLATE function is supported.
  • DISCARD ENQMODEL
    The DISCARD ENQMODEL function is not supported.
  • DISCARD FILE
    The DISCARD FILE function is not supported.
  • DISCARD JOURNALMODEL
    The DISCARD JOURNALMODEL function is not supported.
  • DISCARD JOURNALNAME
    The DISCARD JOURNALNAME function is not supported.
  • DISCARD PARTNER
    The DISCARD PARTNER function is not supported.
  • DISCARD PIPELINE
    The DISCARD PIPELINE function is supported.
  • DISCARD PROCESSTYPE
    The DISCARD PROCESSTYPE function is not supported.
  • DISCARD PROFILE
    The DISCARD PROFILE function is not supported.
  • DISCARD PROGRAM
    The DISCARD PROGRAM function is supported.
  • DISCARD REQUESTMODEL
    The DISCARD REQUESTMODEL function is not supported.
  • DISCARD TCPIPSERVICE
    The DISCARD TCPIPSERVICE function is supported.
  • DISCARD TDQUEUE
    The DISCARD TDQUEUE function is not supported.
  • DISCARD TERMINAL
    The DISCARD TERMINAL function is not supported.
  • DISCARD TRANCLASS
    The DISCARD TRANCLASS function is not supported.
  • DISCARD TRANSACTION
    The DISCARD TRANSACTION function is not supported.
  • DISCARD TSMODEL
    The DISCARD TSMODEL function is not supported.
  • DISCARD URIMAP
    The DISCARD URIMAP function is supported.
  • DISCARD WEBSERVICE
    The DISCARD WEBSERVICE function is supported.
  • ENABLE PROGRAM
    The ENABLE PROGRAM function is supported.
  • EXTRACT ATTACH
    The EXTRACT ATTACH function is not supported.
  • EXTRACT ATTRIBUTES
    The EXTRACT ATTRIBUTES function is supported.
  • EXTRACT CERTIFICATE
    The EXTRACT CERTIFICATE function is supported.
  • EXTRACT EXIT
    The EXTRACT EXIT function is supported.
  • EXTRACT LOGONMSG
    The EXTRACT LOGONMSG function is not supported.
  • EXTRACT PROCESS
    The EXTRACT PROCESS function is supported.
  • EXTRACT TCPIP
    The EXTRACT TCPIP function is supported.
  • EXTRACT TCT
    The EXTRACT TCT function is not supported.
  • EXTRACT WEB
    The EXTRACT WEB function is supported.
  • INQUIRE ACTIVITYID
    The INQUIRE ACTIVITYID function is not supported.
  • INQUIRE AUTINSTMODEL
    The INQUIRE AUTINSTMODEL function is not supported.
  • INQUIRE AUTOINSTALL
    The INQUIRE AUTOINSTALL function is not supported.
  • INQUIRE BEAN
    The INQUIRE BEAN function is not supported.
  • INQUIRE BRFACILITY
    The INQUIRE BRFACILITY function is not supported.
  • INQUIRE CFDTPOOL
    The INQUIRE CFDTPOOL function is not supported.
  • INQUIRE CONNECTION
    The INQUIRE CONNECTION function is supported.
  • INQUIRE CONTAINER
    The INQUIRE CONTAINER function is not supported.
  • INQUIRE CORBASERVER
    The INQUIRE CORBASERVER function is not supported.
  • INQUIRE DATASET
    The INQUIRE DATASET function is supported.
  • INQUIRE DB2CONN
    The INQUIRE DB2CONN function is not supported.
  • INQUIRE DB2ENTRY
    The INQUIRE DB2ENTRY function is not supported.
  • INQUIRE DB2TRAN
    The INQUIRE DB2TRAN function is not supported.
  • INQUIRE DELETSHIPPED
    The INQUIRE DELETSHIPPED function is not supported.
  • INQUIRE DISPATCHER
    The INQUIRE DISPATCHER function is not supported.
  • INQUIRE DJAR
    The INQUIRE DJAR function is not supported.
  • INQUIRE DOCTEMPLATE
    The INQUIRE DOCTEMPLATE function is supported.
  • INQUIRE DSNAME
    The INQUIRE DSNAME function is not supported.
  • INQUIRE DUMPDS
    The INQUIRE DUMPDS function is not supported.
  • INQUIRE ENQ
    The INQUIRE ENQ function is not supported.
  • INQUIRE ENQMODEL
    The INQUIRE ENQMODEL function is not supported.
  • INQUIRE EVENT
    The INQUIRE EVENT function is not supported.
  • INQUIRE EXCI
    The INQUIRE EXCI function is not supported.
  • INQUIRE EXITPROGRAM
    The INQUIRE EXITPROGRAM function is not supported.
  • INQUIRE FILE
    The INQUIRE FILE function is supported.
  • INQUIRE IRC
    The INQUIRE IRC function is not supported.
  • INQUIRE JOURNALMODEL
    The INQUIRE JOURNALMODEL function is not supported.
  • INQUIRE JOURNALNAME
    The INQUIRE JOURNALNAME function is not supported.
  • INQUIRE JOURNALNUM
    The INQUIRE JOURNALNUM function is supported.
  • INQUIRE JVMPOOL
    The INQUIRE JVMPOOL function is not supported.
  • INQUIRE MODENAME
    The INQUIRE MODENAME function is not supported.
  • INQUIRE MONITOR
    The INQUIRE MONITOR function is not supported.
  • INQUIRE NETNAME
    The INQUIRE NETNAME function is supported.
  • INQUIRE PARTNER
    The INQUIRE PARTNER function is not supported.
  • INQUIRE PIPELINE
    The INQUIRE PIPELINE function is supported.
  • INQUIRE PROCESS
    The INQUIRE PROCESS function is not supported.
  • INQUIRE PROCESSTYPE
    The INQUIRE PROCESSTYPE function is not supported.
  • INQUIRE PROFILE
    The INQUIRE PROFILE function is not supported.
  • INQUIRE PROGRAM
    The INQUIRE PROGRAM function is supported.
  • INQUIRE REQID
    The INQUIRE REQID function is supported.
  • INQUIRE REQUESTMODEL
    The INQUIRE REQUESTMODEL function is not supported.
  • INQUIRE RRMS
    The INQUIRE RRMS function is not supported.
  • INQUIRE STATISTICS
    The INQUIRE STATISTICS function is not supported.
  • INQUIRE STORAGE
    The INQUIRE STORAGE function is not supported.
  • INQUIRE STREAMNAME
    The INQUIRE STREAMNAME function is not supported.
  • INQUIRE SYSDUMPCODE
    The INQUIRE SYSDUMPCODE function is not supported.
  • INQUIRE SYSTEM
    The INQUIRE SYSTEM function is supported.
  • INQUIRE TASK
    The INQUIRE TASK function is supported.
  • INQUIRE TASK LIST
    The INQUIRE TASK LIST function is supported.
  • INQUIRE TCLASS
    The INQUIRE TCLASS function is supported.
  • INQUIRE TCPIP
    The INQUIRE TCPIP function is not supported.
  • INQUIRE TCPIPSERVICE
    The INQUIRE TCPIPSERVICE function is supported.
  • INQUIRE TDQUEUE
    The INQUIRE TDQUEUE function is supported.
  • INQUIRE TERMINAL
    The INQUIRE TERMINAL function is supported.
  • INQUIRE TIMER
    The INQUIRE TIMER function is not supported.
  • INQUIRE TRACEDEST
    The INQUIRE TRACEDEST function is not supported.
  • INQUIRE TRACEFLAG
    The INQUIRE TRACEFLAG function is not supported.
  • INQUIRE TRACETYPE
    The INQUIRE TRACETYPE function is not supported.
  • INQUIRE TRANCLASS
    The INQUIRE TRANCLASS function is supported.
  • INQUIRE TRANDUMPCODE
    The INQUIRE TRANDUMPCODE function is not supported.
  • INQUIRE TRANSACTION
    The INQUIRE TRANSACTION function is supported.
  • INQUIRE TSMODEL
    The INQUIRE TSMODEL function is not supported.
  • INQUIRE TSPOOL
    The INQUIRE TSPOOL function is not supported.
  • INQUIRE TSQNAME
    The INQUIRE TSQNAME function is not supported.
  • INQUIRE TSQUEUE
    The INQUIRE TSQUEUE function is supported.
  • INQUIRE UOW
    The INQUIRE UOW function is not supported.
  • INQUIRE UOWDSNFAIL
    The INQUIRE UOWDSNFAIL function is not supported.
  • INQUIRE UOWENQ
    The INQUIRE UOWENQ function is not supported.
  • INQUIRE UOWLINK
    The INQUIRE UOWLINK function is not supported.
  • INQUIRE URIMAP
    The INQUIRE URIMAP function is supported.
  • INQUIRE VOLUME
    The INQUIRE VOLUME function is not supported.
  • INQUIRE VTAM
    The INQUIRE VTAM function is not supported.
  • INQUIRE WEB
    The INQUIRE WEB function is not supported.
  • INQUIRE WEBSERVICE
    The INQUIRE WEBSERVICE function is supported.
  • INQUIRE XMLTRANSFORM
    The INQUIRE XMLTRANSFORM function is supported.
  • PERFORM CORBASERVER
    The PERFORM CORBASERVER function is not supported.
  • PERFORM DELETSHIPPED
    The PERFORM DELETSHIPPED function is not supported.
  • PERFORM DJAR
    The PERFORM DJAR function is not supported.
  • PERFORM DUMP
    The PERFORM DUMP function is supported.
  • PERFORM ENDAFFINITY
    The PERFORM ENDAFFINITY function is not supported.
  • PERFORM RESETTIME
    The PERFORM RESETTIME function is supported.
  • PERFORM SECURITY REBUILD
    The PERFORM SECURITY REBUILD function is not supported.
  • PERFORM SHUTDOWN
    The PERFORM SHUTDOWN function is supported.
  • PERFORM STATISTICS RECORD
    The PERFORM STATISTICS RECORD function is not supported.
  • RESYNC ENTRYNAME
    The RESYNC ENTRYNAME function is not supported.
  • SET AUTOINSTALL
    The SET AUTOINSTALL function is not supported.
  • SET BRFACILITY
    The SET BRFACILITY function is not supported.
  • SET BUNDLE
    The SET BUNDLE function is supported.
  • SET CONNECTION
    The SET CONNECTION function is supported.
  • SET CORBASERVER
    The SET CORBASERVER function is not supported.
  • SET DATASET
    The SET DATASET function is supported.
  • SET DB2CONN
    The SET DB2CONN function is not supported.
  • SET DB2ENTRY
    The SET DB2ENTRY function is not supported.
  • SET DB2TRAN
    The SET DB2TRAN function is not supported.
  • SET DELETSHIPPED
    The SET DELETSHIPPED function is not supported.
  • SET DISPATCHER
    The SET DISPATCHER function is not supported.
  • SET DOCTEMPLATE
    The SET DOCTEMPLATE function is supported.
  • SET DSNAME
    The SET DSNAME function is not supported.
  • SET DUMPDS
    The SET DUMPDS function is not supported.
  • SET ENQMODEL
    The SET ENQMODEL function is not supported.
  • SET FILE
    The SET FILE function is supported.
  • SET IRC
    The SET IRC function is not supported.
  • SET JOURNALNAME
    The SET JOURNALNAME function is not supported.
  • SET JOURNALNUM
    The SET JOURNALNUM function is supported.
  • SET JVMPOOL
    The SET JVMPOOL function is not supported.
  • SET MODENAME
    The SET MODENAME function is not supported.
  • SET MONITOR
    The SET MONITOR function is not supported.
  • SET NETNAME
    The SET NETNAME function is supported.
  • SET PIPELINE
    The SET PIPELINE function is supported.
  • SET PROCESSTYPE
    The SET PROCESSTYPE function is not supported.
  • SET PROGRAM
    The SET PROGRAM function is supported.
  • SET STATISTICS
    The SET STATISTICS function is not supported.
  • SET SYSDUMPCODE
    The SET SYSDUMPCODE function is not supported.
  • SET SYSTEM
    The SET SYSTEM function is supported.
  • SET TASK
    The SET TASK function is supported.
  • SET TCLASS
    The SET TCLASS function is supported.
  • SET TCPIP
    The SET TCPIP function is not supported.
  • SET TCPIPSERVICE
    The SET TCPIPSERVICE function is supported.
  • SET TDQUEUE
    The SET TDQUEUE function is supported.
  • SET TERMINAL
    The SET TERMINAL function is supported.
  • SET TRACEDEST
    The SET TRACEDEST function is not supported.
  • SET TRACEFLAG
    The SET TRACEFLAG function is not supported.
  • SET TRACETYPE
    The SET TRACETYPE function is not supported.
  • SET TRANCLASS
    The SET TRANCLASS function is supported.
  • SET TRANDUMPCODE
    The SET TRANDUMPCODE function is not supported.
  • SET TRANSACTION
    The SET TRANSACTION function is supported.
  • SET TSQNAME
    The SET TSQNAME function is not supported.
  • SET TSQUEUE
    The SET TSQUEUE function is not supported.
  • SET UOW
    The SET UOW function is not supported.
  • SET UOWLINK
    The SET UOWLINK function is not supported.
  • SET URIMAP
    The SET URIMAP function is supported.
  • SET VOLUME
    The SET VOLUME function is not supported.
  • SET VTAM
    The SET VTAM function is not supported.
  • SET WEB
    The SET WEB function is not supported.
  • SET WEBSERVICE
    The SET WEBSERVICE function is supported.
Parent topic: CICS Support Commands


ACQUIRE TERMINAL

The ACQUIRE TERMINAL function is not supported.

Parent topic: CICS SPI Calls


COLLECT STATISTICS

The COLLECT STATISTICS function is not supported.

Operand | Support
AUTOINSTALL | Recognized
CONNECTION (data-value) | Recognized
CORBASERVER | Recognized
DISPATCHER | Recognized
DTB | Recognized
FILE (data-value) | Recognized
IRCBATCH | Recognized
JOURNALNUM (data-value) | Recognized
JVMPOOL | Recognized
LASTRESET (data-area) | Recognized
LASTRESETHRS (data-area) | Recognized
LASTRESETMIN (data-area) | Recognized
LASTRESETSEC (data-area) | Recognized
LSRPOOL (data-value) | Recognized
MONITOR (data-value) | Recognized
PROGRAM (data-value) | Recognized
REQUESTMODEL | Recognized
SET (ptr-ref) | Recognized
STORAGE | Recognized
SYSDUMPCODE (data-value) | Recognized
TABLEMGR | Recognized
TASKCONTROL | Recognized
TCLASS (data-area) | Recognized
TCPIP | Recognized
TCPIPSERVICE | Recognized
TDQUEUE (data-value) | Recognized
TERMINAL (data-value) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANSACTION (data-value) | Recognized
TSQUEUE | Recognized
VTAM | Recognized
Parent topic: CICS SPI Calls


CREATE CONNECTION

The CREATE CONNECTION function is not supported.

Parent topic: CICS SPI Calls


CREATE CORBASERVER

The CREATE CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2CONN

The CREATE DB2CONN function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2ENTRY

The CREATE DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2TRAN

The CREATE DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


CREATE DJAR

The CREATE DJAR function is not supported.

Parent topic: CICS SPI Calls


CREATE DOCTEMPLATE

The CREATE DOCTEMPLATE function is not supported.

Operand | Support
ATTRIBUTES (data-area) | Recognized
ATTRLEN (data-value) | Recognized
DOCTEMPLATE (data-value) | Recognized
LOG (cvda) | Recognized
LOGMESSAGE (data-value) | Recognized
NOLOG (cvda) | Recognized
Parent topic: CICS SPI Calls


CREATE ENQMODEL

The CREATE ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE FILE

The CREATE FILE function is not supported.

Parent topic: CICS SPI Calls


CREATE JOURNALMODEL

The CREATE JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE LSRPOOL

The CREATE LSRPOOL function is not supported.

Parent topic: CICS SPI Calls


CREATE MAPSET

The CREATE MAPSET function is not supported.

Parent topic: CICS SPI Calls


CREATE PARTITIONSET

The CREATE PARTITIONSET function is not supported.

Parent topic: CICS SPI Calls


CREATE PARTNER

The CREATE PARTNER function is not supported.

Parent topic: CICS SPI Calls


CREATE PROCESSTYPE

The CREATE PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


CREATE PROFILE

The CREATE PROFILE function is not supported.

Parent topic: CICS SPI Calls


CREATE PROGRAM

The CREATE PROGRAM function is not supported.

Parent topic: CICS SPI Calls


CREATE REQUESTMODEL

The CREATE REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE SESSIONS

The CREATE SESSIONS function is not supported.

Parent topic: CICS SPI Calls


CREATE TCPIPSERVICE

The CREATE TCPIPSERVICE function is not supported.

Parent topic: CICS SPI Calls


CREATE TDQUEUE

The CREATE TDQUEUE function is not supported.

Parent topic: CICS SPI Calls


CREATE TERMINAL

The CREATE TERMINAL function is not supported.

Parent topic: CICS SPI Calls


CREATE TRANCLASS

The CREATE TRANCLASS function is not supported.

Parent topic: CICS SPI Calls


CREATE TRANSACTION

The CREATE TRANSACTION function is not supported.

Parent topic: CICS SPI Calls


CREATE TSMODEL

The CREATE TSMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE TYPETERM

The CREATE TYPETERM function is not supported.

Parent topic: CICS SPI Calls


DISABLE PROGRAM

The DISABLE PROGRAM function is supported.

Operand | Support
ENTRYNAME (data-value) | Full
EXIT (data-value) | Full
EXITALL | Full
FORMATEDF | Validated
PROGRAM (data-value) | Full
SHUTDOWN | Full
STOP | Full
TASKSTART | Full
Parent topic: CICS SPI Calls


DISCARD AUTINSTMODEL

The DISCARD AUTINSTMODEL function is not supported.

Operand | Support
AUTINSTMODEL (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD CONNECTION

The DISCARD CONNECTION function is not supported.

Parent topic: CICS SPI Calls


DISCARD CORBASERVER

The DISCARD CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2CONN

The DISCARD DB2CONN function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2ENTRY

The DISCARD DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2TRAN

The DISCARD DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


DISCARD DJAR

The DISCARD DJAR function is not supported.

Parent topic: CICS SPI Calls


DISCARD DOCTEMPLATE

The DISCARD DOCTEMPLATE function is supported.

Operand | Support
DOCTEMPLATE (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD ENQMODEL

The DISCARD ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD FILE

The DISCARD FILE function is not supported.

Operand | Support
FILE (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD JOURNALMODEL

The DISCARD JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD JOURNALNAME

The DISCARD JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


DISCARD PARTNER

The DISCARD PARTNER function is not supported.

Operand | Support
PARTNER (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD PIPELINE

The DISCARD PIPELINE function is supported.

Operand | Support
PIPELINE (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD PROCESSTYPE

The DISCARD PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


DISCARD PROFILE

The DISCARD PROFILE function is not supported.

Operand | Support
PROFILE (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD PROGRAM

The DISCARD PROGRAM function is supported.

Operand | Support
PROGRAM (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD REQUESTMODEL

The DISCARD REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD TCPIPSERVICE

The DISCARD TCPIPSERVICE function is supported.

Operand | Support
TCPIPSERVICE (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD TDQUEUE

The DISCARD TDQUEUE function is not supported.

Parent topic: CICS SPI Calls


DISCARD TERMINAL

The DISCARD TERMINAL function is not supported.

Parent topic: CICS SPI Calls


DISCARD TRANCLASS

The DISCARD TRANCLASS function is not supported.

Parent topic: CICS SPI Calls


DISCARD TRANSACTION

The DISCARD TRANSACTION function is not supported.

Operand | Support
TRANSACTION (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD TSMODEL

The DISCARD TSMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD URIMAP

The DISCARD URIMAP function is supported.

Operand | Support
URIMAP (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD WEBSERVICE

The DISCARD WEBSERVICE function is supported.

Operand | Support
WEBSERVICE (data-value) | Full
Parent topic: CICS SPI Calls


ENABLE PROGRAM

The ENABLE PROGRAM function is supported.

Operand | Support
ENTRY (ptr-ref) | Full
ENTRYNAME (data-value) | Full
EXIT (data-value) | Full
FORMATEDF | Validated
GAENTRYNAME (data-value) | Full
GALENGTH (data-value) | Full
LINKEDITMODE | Validated
PROGRAM (data-value) | Full
SHUTDOWN | Full
START | Full
TALENGTH (data-value) | Full
TASKSTART | Full
Parent topic: CICS SPI Calls


EXTRACT ATTACH

The EXTRACT ATTACH function is not supported.

Parent topic: CICS SPI Calls


EXTRACT ATTRIBUTES

The EXTRACT ATTRIBUTES function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS SPI Calls


EXTRACT CERTIFICATE

The EXTRACT CERTIFICATE function is supported.

Operand | Support
CERTIFICATE (data-area) | Full
COMMONNAME (data-area) | Full
COMMONNAMLEN (data-area) | Full
COUNTRY (data-area) | Full
COUNTRYLEN (data-area) | Full
ISSUER | Full
LENGTH (data-area) | Full
LOCALITY (data-area) | Full
LOCALITYLEN (data-area) | Full
ORGANIZATION (data-area) | Full
ORGANIZATLEN (data-area) | Full
ORGUNIT (data-area) | Full
ORGUNITLEN (data-area) | Full
OWNER | Full
SERIALNUM (data-area) | Full
SERIALNUMLEN (data-area) | Full
STATE (data-area) | Full
STATELEN (data-area) | Full
USERID (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT EXIT

The EXTRACT EXIT function is supported.

Operand | Support
ENTRYNAME (data-value) | Full
GALENGTH (data-area) | Full
GASET (ptr-ref) | Full
PROGRAM (data-value) | Full
Parent topic: CICS SPI Calls


EXTRACT LOGONMSG

The EXTRACT LOGONMSG function is not supported.

Operand | Support
INTO (data-area) | Recognized
LENGTH (data-area) | Recognized
SET (ptr-ref) | Recognized
Parent topic: CICS SPI Calls


EXTRACT PROCESS

The EXTRACT PROCESS function is supported.

Operand | Support
CONVID (data-area) | Full
MAXPROCLEN (data-area) | Full
PIPLENGTH (data-area) | Full
PIPLIST (ptr-ref) | Full
PROCLENGTH (data-area) | Full
PROCNAME (data-area) | Full
SESSION (data-area) | Full
SYNCLEVEL (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT TCPIP

The EXTRACT TCPIP function is supported.

Operand | Support
AUTHENTICATE (cvda) | Full
CADDRLENGTH (data-area) | Full
CLIENTADDR (data-area) | Full
CLIENTADDRNU (data-area) | Full
CLIENTNAME (data-area) | Full
CNAMELENGTH (data-area) | Full
MAXDATALEN (data-area) | Full
PORTNUMBER (data-area) | Full
PORTNUMNU (data-area) | Full
PRIVACY (data-area) | Partial: returns "NOTSUPPORTED"
SADDRLENGTH (data-area) | Full
SERVERADDR (data-area) | Full
SERVERADDRNU (data-area) | Full
SERVERNAME (data-area) | Full
SNAMELENGTH (data-area) | Full
SSLTYPE (cvda) | Full
TCPIPSERVICE (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT TCT

The EXTRACT TCT function is not supported.

Parent topic: CICS SPI Calls


EXTRACT WEB

The EXTRACT WEB function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
HTTPMETHOD (data-area) | Full
HTTPVERSION (data-area) | Full
METHODLENGTH (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
REALM (data-area) | Full
REALMLEN (data-value) | Full
REQUESTTYPE (cvda) | Full
SCHEME (cvda) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-area) | Full
VERSIONLEN (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE ACTIVITYID

The INQUIRE ACTIVITYID function is not supported.

Parent topic: CICS SPI Calls


INQUIRE AUTINSTMODEL

The INQUIRE AUTINSTMODEL function is not supported.

Operand | Support
AUTINSTMODEL (data-value) | Recognized
NEXT | Recognized
Parent topic: CICS SPI Calls


INQUIRE AUTOINSTALL

The INQUIRE AUTOINSTALL function is not supported.

Operand | Support
CURREQS (data-area) | Recognized
ENABLESTATUS (data-area) | Recognized
MAXREQS (data-area) | Recognized
PROGRAM (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE BEAN

The INQUIRE BEAN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE BRFACILITY

The INQUIRE BRFACILITY function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CFDTPOOL

The INQUIRE CFDTPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CONNECTION

The INQUIRE CONNECTION function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Full
AUTOCONNECT (cvda) | Partial: returns "NONAUTOCONN"
CONNECTION (data-value) | Full
CONNSTATUS (cvda) | Full
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
NETNAME (data-area) | Full
NEXT | Full
PENDSTATUS (cvda) | Partial: returns "NOTPENDING"
PROTOCOL (cvda) | Partial: returns "APPC"
SERVSTATUS (cvda) | Full
XLNSTATUS (cvda) | Partial: returns "XNOTDONE"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE CONTAINER

The INQUIRE CONTAINER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CORBASERVER

The INQUIRE CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DATASET

The INQUIRE DATASET function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VSAM"
ADD (cvda) | Full
BASEDSNAME (data-area) | Full
BASENAME (data-area) | Full
BLOCKFORMAT (cvda) | Partial: returns "BLOCKED"
BLOCKKEYLEN (data-area) | Partial: returns 0
BLOCKSIZE (data-area) | Partial: returns 0
BROWSE (cvda) | Full
CATNAME (data-area) | Validated
CFDTPOOL (data-area) | Validated
DATASET (data-value) | Full
DELETE (cvda) | Full
DISPOSITION (cvda) | Partial: returns "SHARE"
DSNAME (data-area) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
EXCLUSIVE (cvda) | Partial: returns "NOTAPPLIC"
FILE (data-value) | Full
FWDRECSTATUS (cvda) | Partial: returns "NOTFWDRCVBLE"
JOURNALNUM (data-area) | Partial: If the Journal is a remote file, returns -1 If FWDRECSTATUS=NOTFWDRCVBLE, returns 0 If FWDRECSTATUS=FWDRECOVBLE, returns 1
KEYLENGTH (data-area) | Full
KEYPOSITION (data-area) | Full
LOADTYPE (cvda) | Validated
LSRPOOLID (data-area) | Partial: returns 0
MAXNUMRECS (data-area) | Partial: returns 0
NEXT | Full
OBJECT (cvda) | Full
OBJECTNAME (data-area) | Full
OPENSTATUS (cvda) | Full
READ (cvda) | Full
READINTEG (cvda) | Validated
RECORDFORMAT (cvda) | Full
RECORDSIZE (data-area) | Full
RECOVSTATUS (cvda) | Full
RELTYPE (cvda) | Partial: returns "NOTAPPLIC"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
REMOTETABLE (cvda) | Validated
RLSACCESS (cvda) | Validated
STRINGS (data-area) | Partial: returns 1
TABLE (cvda) | Partial: returns "NOTTABLE"
TABLENAME (data-area) | Validated
TYPE (cvda) | Full
UPDATE (cvda) | Full
UPDATEMODEL (cvda) | Validated
Parent topic: CICS SPI Calls


INQUIRE DB2CONN

The INQUIRE DB2CONN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DB2ENTRY

The INQUIRE DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DB2TRAN

The INQUIRE DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DELETSHIPPED

The INQUIRE DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DISPATCHER

The INQUIRE DISPATCHER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DJAR

The INQUIRE DJAR function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DOCTEMPLATE

The INQUIRE DOCTEMPLATE function is supported.

Operand | Support
APPENDCRLF (cvda) | Full
CACHESIZE (data-area) | Full
DDNAME (data-area) | Full
DOCTEMPLATE (data-value) | Full
DSNAME (data-area) | Full
EXITPGM (data-area) | Full
FILE (data-area) | Full
HFSFILE (data-area) | Full
MEMBER (data-area) | Full
NEXT | Full
PROGRAM (data-area) | Full
TDQUEUE (data-area) | Full
TEMPLATENAME (data-area) | Full
TEMPLATETYPE (cvda) | Full
TSQUEUE (data-area) | Full
TYPE (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE DSNAME

The INQUIRE DSNAME function is not supported.

Operand | Support
ACCESSMETHOD (cvda) | Recognized
BACKUPTYPE (cvda) | Recognized
BASEDSNAME (data-area) | Recognized
BKOUTSTATUS (cvda) | Recognized
DSNAME (data-value) | Recognized
FILECOUNT (data-area) | Recognized
FWDRECOVLOG (data-area) | Recognized
NEXT | Recognized
OBJECT (cvda) | Recognized
RECOVSTATUS (cvda) | Recognized
VALIDITY (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE DUMPDS

The INQUIRE DUMPDS function is not supported.

Operand | Support
CURRENTDDS (data-area) | Recognized
INITIALDDS (data-area) | Recognized
OPENSTATUS (cvda) | Recognized
SWITCHSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE ENQ

The INQUIRE ENQ function is not supported.

Parent topic: CICS SPI Calls


INQUIRE ENQMODEL

The INQUIRE ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EVENT

The INQUIRE EVENT function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EXCI

The INQUIRE EXCI function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EXITPROGRAM

The INQUIRE EXITPROGRAM function is not supported.

Parent topic: CICS SPI Calls


INQUIRE FILE

The INQUIRE FILE function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VSAM"
ADD (cvda) | Full
BASEDSNAME (data-area) | Full
BASENAME (data-area) | Full
BLOCKFORMAT (cvda) | Partial: returns "BLOCKED"
BLOCKKEYLEN (data-area) | Partial: returns 0
BLOCKSIZE (data-area) | Partial: returns 0
BROWSE (cvda) | Full
CATNAME (data-area) | Validated
CFDTPOOL (data-area) | Validated
DATASET (data-value) | Full
DELETE (cvda) | Full
DISPOSITION (cvda) | Partial: returns "SHARE"
DSNAME (data-area) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
EXCLUSIVE (cvda) | Partial: returns "NOTAPPLIC"
FILE (data-value) | Full
FWDRECSTATUS (cvda) | Partial: returns "NOTFWDRCVBLE"
JOURNALNUM (data-area) | Partial: If the Journal is a remote file, returns -1 If FWDRECSTATUS=NOTFWDRCVBLE, returns 0 If FWDRECSTATUS=FWDRECOVBLE, returns 1
KEYLENGTH (data-area) | Full
KEYPOSITION (data-area) | Full
LOADTYPE (cvda) | Validated
LSRPOOLID (data-area) | Partial: returns 0
MAXNUMRECS (data-area) | Partial: returns 0
NEXT | Full
OBJECT (cvda) | Full
OBJECTNAME (data-area) | Full
OPENSTATUS (cvda) | Full
READ (cvda) | Full
READINTEG (cvda) | Validated
RECORDFORMAT (cvda) | Full
RECORDSIZE (data-area) | Full
RECOVSTATUS (cvda) | Full
RELTYPE (cvda) | Partial: returns "NOTAPPLIC"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
REMOTETABLE (cvda) | Validated
RLSACCESS (cvda) | Validated
STRINGS (data-area) | Partial: returns 1
TABLE (cvda) | Partial: returns "NOTTABLE"
TABLENAME (data-area) | Validated
TYPE (cvda) | Full
UPDATE (cvda) | Full
UPDATEMODEL (cvda) | Validated
Parent topic: CICS SPI Calls


INQUIRE IRC

The INQUIRE IRC function is not supported.

Operand | Support
OPENSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE JOURNALMODEL

The INQUIRE JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE JOURNALNAME

The INQUIRE JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


INQUIRE JOURNALNUM

The INQUIRE JOURNALNUM function is supported.

Operand | Support
ARCHSTATUS (cvda) | Partial: returns "NOAUTOARCH"
CURRENTVOL (data-area) | Partial: returns spaces
DISKASTATUS (cvda) | Partial: returns "CURRENT"
DISKBSTATUS (cvda) | Partial: returns "NOTAPPLIC"
DISKXSTATUS (cvda) | Partial: returns "NOTAPPLIC"
JOURNALNUM (data-value) | Full
JTYPE (cvda) | Partial: returns "DISK1"
NEXT | Full
OLDESTPART (data-area) | Partial: returns spaces
OPENSTATUS (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE JVMPOOL

The INQUIRE JVMPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE MODENAME

The INQUIRE MODENAME function is not supported.

Operand | Support
ACTIVE (data-area) | Recognized
AUTOCONNECT (cvda) | Recognized
AVAILABLE (data-area) | Recognized
CONNECTION (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MAXWINNERS (data-area) | Recognized
MODENAME (data-value) | Recognized
NEXT | Recognized
Parent topic: CICS SPI Calls


INQUIRE MONITOR

The INQUIRE MONITOR function is not supported.

Operand | Support
EVENTCLASS (cvda) | Recognized
EXCEPTCLASS (cvda) | Recognized
PERFCLASS (cvda) | Recognized
STATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE NETNAME

The INQUIRE NETNAME function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Partial: returns "ACQUIRED"
ALTPAGEHT (data-area) | Full
ALTPAGEWD (data-area) | Full
ALTPRINTER (data-area) | Partial: returns spaces
ALTPRTCOPYST (cvda) | Partial: returns "NOALTPRTCOPY"
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
ALTSUFFIX (data-area) | Partial: returns spaces
APLKYBDST (cvda) | Partial: returns "NOAPLKYBD"
APLTEXTST (cvda) | Partial: returns "NOAPLTEXT"
ASCII (cvda) | Full
ATISTATUS (cvda) | Partial: returns "ATI"
AUDALARMST (cvda) | Partial: returns "AUDALARM"
AUTOCONNECT (cvda) | Full
BACKTRANSST (cvda) | Partial: returns "NOBACKTRANS"
COLORST (cvda) | Full
COPYST (cvda) | Partial: returns "NOCOPY"
CREATESESS (cvda) | Partial: returns "NOCREATE"
DATASTREAM (data-area) | Full
DEFPAGEHT (data-area) | Full
DEFPAGEWD (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DEVICE (cvda) | Partial: returns "T3277L"
DEVICEST (cvda) | Full
DISCREQST (cvda) | Partial: returns "DISCREQ"
DUALCASEST (cvda) | Partial: returns "DUALCASE"
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
EXTENDEDDSST (cvda) | Partial: returns "EXTENDEDDS"
FMHPARMST (cvda) | Partial: returns "NOFMHPARM"
FORMFEEDST (cvda) | Partial: returns "NOFORMFEED"
GCHARS (data-area) | Full
GCODES (data-area) | Full
HFORMST (cvda) | Partial: returns "NOHFORM"
HILIGHTST (cvda) | Partial: returns "HILIGHT"
KATAKANAST (cvda) | Partial: returns "NOKATAKANA"
LIGHTPENST (cvda) | Partial: returns "NOLIGHTPEN"
MODENAME (data-area) | Full
MSRCONTROLST (cvda) | Partial: returns "NOMSRCONTROL"
NATLANG (data-area) | Partial: returns "E" (meaning US English)
NATURE (cvda) | Full
NETNAME (data-value) | Full
NEXTTRANSID (data-area) | Partial: returns spaces
OBFORMATST (cvda) | Partial: returns "NOOBFORMAT"
OBOPERIDST (cvda) | Partial: returns "NOOBOPERID"
OPERID (data-area) | Full
OUTLINEST (cvda) | Partial: returns "NOOUTLINE"
PAGEHT (data-area) | Full
PAGESTATUS (cvda) | Partial: returns "PAGEABLE"
PAGEWD (data-area) | Full
PARTITIONSST (cvda) | Partial: returns "NOPARTITIONS"
PRINTADAPTST (cvda) | Partial: returns "NOPRINTADAPT"
PRINTER (data-area) | Partial: returns spaces
PROGSYMBOLST (cvda) | Partial: returns "NOPROGSYMBOL"
PRTCOPYST (cvda) | Partial: returns "NOPRTCOPY"
QUERYST (cvda) | Partial: returns "NOQUERY"
RELREQST (cvda) | Partial: (VTAM only) returns "NORELREQ"
REMOTENAME (data-area) | Partial: returns spaces
REMOTESYSTEM (data-area) | Partial: returns spaces
SCREENHEIGHT (data-area) | Full
SCREENWIDTH (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SECURITY (cvda) | Partial: returns "NOPRESETSEC"
SERVSTATUS (cvda) | Full
SESSIONTYPE (cvda) | Partial: returns "NOTAPPLIC"
SIGNONSTATUS (cvda) | Full
SOSIST (cvda) | Partial: returns "NOSOSI"
TASKID (data-area) | Partial: returns 0 meaning no task is using the terminal
TCAMCONTROL (data-area) | Partial: returns x"00" meaning null
TERMINAL (data-area) | Full
TERMMODEL (data-area) | Partial: returns 2
TERMPRIORITY (data-area) | Full
TERMSTATUS (cvda) | Full
TEXTKYBDST (cvda) | Partial: returns "NOTEXTKYBD"
TEXTPRINTST (cvda) | Partial: returns "NOTEXTPRINT"
TRACING (cvda) | Partial: returns "STANTRACE"
TRANSACTION (data-area) | Full
TTISTATUS (cvda) | Partial: returns "TTI"
UCTRANST (cvda) | Full
USERAREA (data-area) | Full
USERAREALEN (data-area) | Full
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
VALIDATIONST (cvda) | Partial: returns "NOVALIDATION"
VFORMST (cvda) | Partial: returns "NOVFORM"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE PARTNER

The INQUIRE PARTNER function is not supported.

Operand | Support
NETNAME (data-area) | Recognized
NETWORK (data-area) | Recognized
NEXT | Recognized
PARTNER (data-value) | Recognized
PROFILE (data-area) | Recognized
TPNAME (data-area) | Recognized
TPNAMELEN (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE PIPELINE

The INQUIRE PIPELINE function is supported.

Operand | Support
CONFIGFILE (data-area) | Full
ENABLESTATUS (cvda) | Full
MODE (data-area) | Full
NEXT | Full
PIPELINE (data-value) | Full
RESPWAIT (data-area) | Full
SHELF (data-area) | Full
SOAPLEVEL (data-area) | Full
WSDIR (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE PROCESS

The INQUIRE PROCESS function is not supported.

Parent topic: CICS SPI Calls


INQUIRE PROCESSTYPE

The INQUIRE PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


INQUIRE PROFILE

The INQUIRE PROFILE function is not supported.

Operand | Support
NEXT | Recognized
PROFILE (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE PROGRAM

The INQUIRE PROGRAM function is supported.

Operand | Support
CEDFSTATUS (cvda) | Partial: returns "NOCEDF"
COBOLTYPE (cvda) | Partial: If the program has a PPT, returns "COBOLII" If not, returns "NOTAPPLIC"
CONCURRENCY (cvda) | Validated
COPY (cvda) | Full
DATALOCATION (cvda) | Partial: returns "ANY"
DYNAMSTATUS (cvda) | Validated
ENTRYPOINT (ptr-ref) | Full
EXECKEY (cvda) | Partial: returns "CICSEXECKEY"
EXECUTIONSET (cvda) | Partial: returns "FULLAPI"
HOLDSTATUS (cvda) | Full
HOTPOOLING (cvda) | Validated
JVMCLASS (data-area) | Validated
JVMDEBUG (cvda) | Validated
JVMPROFILE (cvda) | Validated
LANGDEDUCED (cvda) | Validated
LANGUAGE (cvda) | Partial: returns "ASSEMBLER", "C", "COBOL", "PLI" or "NOTAPPLIC" (based on the program's PPT entry).
LENGTH (data-area) | Full
LOADPOINT (ptr-ref) | Full
LPASTATUS (cvda) | Partial: returns "NOTLPA"
NEXT | Full
PROGRAM (data-value) | Full
PROGTYPE (cvda) | Partial: returns "PROGRAM"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESCOUNT (data-area) | Full
RUNTIME (cvda) | Validated
SHARESTATUS (cvda) | Full
STATUS (cvda) | Partial: if program is local, returns "PRIVATE"; if program is remote, returns "NOTAPPLIC"
TRANSID (data-area) | Full
USECOUNT (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE REQID

The INQUIRE REQID function is supported.

Operand | Support
AFTER (data-area) | Validated
AT (data-area) | Validated
FMHSTATUS (cvda) | Validated
INTERVAL (data-area) | Full
LENGTH (data-value) | Validated
NEXT | Full
REQID (data-value) | Full
REQTYPE (cvda) | Validated
RTERMID (data-value) | Validated
RTRANSID (data-value) | Validated
SET (ptr-ref) | Validated
TERMID (data-value) | Validated
TIME (data-area) | Validated
TRANSID (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE REQUESTMODEL

The INQUIRE REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE RRMS

The INQUIRE RRMS function is not supported.

Parent topic: CICS SPI Calls


INQUIRE STATISTICS

The INQUIRE STATISTICS function is not supported.

Operand | Support
ENDOFDAY (data-area) | Recognized
ENDOFDAYHRS (data-area) | Recognized
ENDOFDAYMIN (data-area) | Recognized
ENDOFDAYSEC (data-area) | Recognized
INTERVAL (data-area) | Recognized
INTERVALHRS (data-area) | Recognized
INTERVALMIN (data-area) | Recognized
INTERVALSEC (data-area) | Recognized
NEXTTIME (data-area) | Recognized
NEXTTIMEHRS (data-area) | Recognized
NEXTTIMEMIN (data-area) | Recognized
NEXTTIMESEC (data-area) | Recognized
RECORDING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE STORAGE

The INQUIRE STORAGE function is not supported.

Parent topic: CICS SPI Calls


INQUIRE STREAMNAME

The INQUIRE STREAMNAME function is not supported.

Parent topic: CICS SPI Calls


INQUIRE SYSDUMPCODE

The INQUIRE SYSDUMPCODE function is not supported.

Operand | Support
CURRENT (data-area) | Recognized
MAXIMUM (data-area) | Recognized
NEXT | Recognized
SHUTOPTION (cvda) | Recognized
SYSDUMPCODE (data-value) | Recognized
SYSDUMPING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE SYSTEM

The INQUIRE SYSTEM function is supported.

Operand | Support
ACTOPENTCBS (data-area) | Validated
AKP (data-area) | Partial: returns 0 meaning keypoints are not being taken
AMAXTASKS (data-area) | Full
CDSASIZE (data-area) | Partial: returns 0
CICSSTATUS (cvda) | Full
CICSSYS (data-area) | Partial: returns "U", "2" or "D"
CICSTSLEVEL (data-area) | Validated
CMDPROTECT (cvda) | Validated
COLDSTATUS (cvda) | Validated
CSCS (data-area) | Partial: returns 0
DB2CONN (data-area) | Validated
DFLTUSER (data-area) | Validated
DSALIMIT (data-area) | Validated
DSRTPROGRAM (data-area) | Validated
DTRPROGRAM (data-area) | Partial: returns spaces
DUMPING (cvda) | Partial: returns "SYSDUMP"
ECDSASIZE (data-area) | Partial: returns 0
ECSCS (data-area) | Partial: returns 0
EDSALIMIT (data-area) | Validated
ERDSASIZE (data-area) | Partial: returns 0
ERSCS (data-area) | Partial: returns 0
ESDSASIZE (data-area) | Validated
EUDSASIZE (data-area) | Partial: returns 0
EUSCS (data-area) | Partial: returns 0
FORCEQR (cvda) | Validated
GMMLENGTH (data-area) | Validated
GMMTEXT (data-area) | Validated
GMMTRANID (data-area) | Full
INITSTATUS (cvda) | Validated
JOBNAME (data-area) | Full
LOGDEFER (data-area) | Validated
MAXOPENTCBS (data-area) | Validated
MAXTASKS (data-area) | Partial: returns 999 (x"03E7")
MROBATCH (data-area) | Partial: returns 0
OPREL (data-area) | Full
OPSYS (data-area) | Partial: returns "U", "2" or "D"
OSLEVEL (data-area) | Validated
PROGAUTOCTLG (cvda) | Validated
PROGAUTOEXIT (data-area) | Validated
PROGAUTOINST (cvda) | Validated
PRTYAGING (data-area) | Partial: returns 0
RDSASIZE (data-area) | Validated
REENTPROTECT (cvda) | Validated
RELEASE (data-area) | Full
RLSSTATUS (cvda) | Validated
RUNAWAY (data-area) | Partial: returns 0
SCANDELAY (data-area) | Partial: returns 0
SDSASIZE (data-area) | Validated
SDTRAN (data-area) | Validated
SECURITYMGR (cvda) | Partial: returns "NOSECURITY"
SHUTSTATUS (cvda) | Full
SOSSTATUS (cvda) | Validated
STARTUP (cvda) | Partial: returns "COLDSTART"
STARTUPDATE (data-area) | Validated
STOREPROTECT (cvda) | Partial: returns "INACTIVE"
TIME (data-area) | Partial: returns 0
TRANISOLATE (cvda) | Validated
UDSASIZE (data-area) | Partial: returns 0
USCS (data-area) | Partial: returns 0
XRFSTATUS (cvda) | Partial: returns "PRIMARY"
Parent topic: CICS SPI Calls


INQUIRE TASK

The INQUIRE TASK function is supported.

Operand | Support
ACTIVITY (data-area) | Validated
ACTIVITYID (data-area) | Validated
ATTACHTIME (data-area) | Full
BRIDGE (data-area) | Full
CMDSEC (cvda) | Partial: returns "CMDSECNO"
DB2PLAN (data-area) | Validated
DTB (cvda) | Partial: returns "BACKOUT"
DTIMEOUT (data-area) | Partial: returns 0
DUMPING (cvda) | Full
FACILITY (data-area) | Full
FACILITYTYPE (cvda) | Full
IDENTIFIER (data-area) | Full
INDOUBT (cvda) | Validated
INDOUBTMINS (data-area) | Validated
INDOUBTWAIT (cvda) | Validated
ISOLATEST (cvda) | Partial: returns "ISOLATE"
PRIORITY (data-area) | Full
PROCESS (data-area) | Validated
PROCESSTYPE (data-area) | Validated
PROFILE (data-area) | Partial: returns "DFHCICST"
PROGRAM (data-area) | Full
PURGEABILITY (cvda) | Partial: returns "NOTPURGEABLE"
RECUNITID (data-area) | Full
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESNAME (data-area) | Full
RESSEC (cvda) | Full
ROUTING (cvda) | Full
RTIMEOUT (data-area) | Full
RUNAWAY (data-area) | Partial: returns 0
RUNSTATUS (cvda) | Partial: returns "RUNNING" or "SUSPENDED"
SCRNSIZE (cvda) | Partial: returns "DEFAULT"
STARTCODE (data-area) | Full
STORAGECLEAR (cvda) | Partial: returns "NOCLEAR"
SUSPENDTIME (data-area) | Partial: returns 0 meaning the task is running or dispatchable
SUSPENDTYPE (data-area) | Partial: returns spaces meaning the task is running or dispatchable
SUSPENDVALUE (data-area) | Partial: returns spaces meaning the task is running or dispatchable
TASK (data-value) | Full
TASKDATAKEY (cvda) | Partial: returns "USERDATAKEY"
TASKDATALOC (cvda) | Partial: returns "ANY"
TCB (cvda) | Validated
TCLASS (data-area) | Full
TRACING (cvda) | Full
TRANCLASS (data-area) | Partial: returns "DFHTCL00"
TRANPRIORITY (data-area) | Full
TRANSACTION (data-area) | Full
TRPROF (data-area) | Partial: returns spaces
TWASIZE (data-area) | Full
UOW (data-area) | Validated
USERID (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TASK LIST

The INQUIRE TASK LIST function is supported.

Operand | Support
DISPATCHABLE | Full
LISTSIZE (data-area) | Full
RUNNING | Full
SET (ptr-ref) | Full
SETTRANSID (ptr-ref) | Full
SUSPENDED | Full
Parent topic: CICS SPI Calls


INQUIRE TCLASS

The INQUIRE TCLASS function is supported.

Operand | Support
CURRENT (data-area) | Full
MAXIMUM (data-area) | Full
TCLASS (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE TCPIP

The INQUIRE TCPIP function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TCPIPSERVICE

The INQUIRE TCPIPSERVICE function is supported.

Operand | Support
ATTACHSEC (cvda) | Full
AUTHENTICATE (cvda) | Full
BACKLOG (data-area) | Full
CERTIFICATE (data-area) | Full
CIPHERS (data-area) | Full
CLOSETIMEOUT (data-area) | Full
CONNECTIONS (data-area) | Partial: returns 0
DNSGROUP (data-area) | Full
DNSSTATUS (cvda) | Partial: returns "UNAVAILABLE"
GRPCRITICAL (cvda) | Full
IPADDRESS (data-area) | Full
MAXDATALEN (data-area) | Full
NEXT | Full
NUMCIPHERS (data-area) | Full
OPENSTATUS (cvda) | Partial: returns only "OPEN" or "CLOSED"
PORT (data-area) | Full
PRIVACY (cvda) | Full
PRIVACY (cvda) | Full
PROTOCOL (cvda) | Full
SOCKETCLOSE (cvda) | Full
SSLTYPE (cvda) | Full
TCPIPSERVICE (data-value) | Full
TRANSID (data-area) | Full
TSQPREFIX (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TDQUEUE

The INQUIRE TDQUEUE function is supported.

Operand | Support
ATIFACILITY (cvda) | Full
ATITERMID (data-area) | Full
ATITRANID (data-area) | Full
BLOCKFORMAT (cvda) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
INDIRECTNAME (data-area) | Full
IOTYPE (cvda) | Full
NEXT | Full
NUMITEMS (data-area) | Full
OPENSTATUS (cvda) | Full
PRINTCONTROL (cvda) | Full
RECORDFORMAT (cvda) | Full
RECORDLENGTH (data-area) | Full
RECOVSTATUS (cvda) | Full
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
TDQUEUE (data-value) | Full
TRIGGERLEVEL (data-area) | Full
TYPE (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE TERMINAL

The INQUIRE TERMINAL function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Partial: (VTAM only) returns "ACQUIRED"
ALTPAGEHT (data-area) | Full
ALTPAGEWD (data-area) | Full
ALTPRINTER (data-area) | Partial: returns spaces
ALTPRTCOPYST (cvda) | Partial: returns "NOALTPRTCOPY"
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
ALTSUFFIX (data-area) | Partial: returns spaces
APLKYBDST (cvda) | Partial: returns "NOAPLKYBD"
APLTEXTST (cvda) | Partial: returns "NOAPLTEXT"
ASCII (cvda) | Full
ATISTATUS (cvda) | Partial: returns "ATI"
AUDALARMST (cvda) | Partial: returns "AUDALARM"
AUTOCONNECT (cvda) | Full
BACKTRANSST (cvda) | Partial: returns "NOBACKTRANS"
COLORST (cvda) | Full
COPYST (cvda) | Partial: returns "NOCOPY"
CREATESESS (cvda) | Partial: returns "NOCREATE"
DATASTREAM (data-area) | Full
DEFPAGEHT (data-area) | Full
DEFPAGEWD (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DEVICE (cvda) | Partial: returns "T3277L"
DEVICEST (cvda) | Full
DISCREQST (cvda) | Partial: returns "DISCREQ"
DUALCASEST (cvda) | Partial: returns "DUALCASE"
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
EXTENDEDDSST (cvda) | Partial: returns "EXTENDEDDS"
FMHPARMST (cvda) | Partial: returns "NOFMHPARM"
FORMFEEDST (cvda) | Partial: returns "NOFORMFEED"
GCHARS (data-area) | Full
GCODES (data-area) | Full
HFORMST (cvda) | Partial: returns "NOHFORM"
HILIGHTST (cvda) | Partial: returns "HILIGHT"
KATAKANAST (cvda) | Partial: returns "NOKATAKANA"
LIGHTPENST (cvda) | Partial: returns "NOLIGHTPEN"
MAPNAME (data-area) | Validated
MAPSETNAME (data-area) | Full
MODENAME (data-area) | Full
MSRCONTROLST (cvda) | Partial: returns "NOMSRCONTROL"
NATLANG (data-area) | Partial: returns "E" meaning US English
NATURE (cvda) | Full
NETNAME (data-area) | Full
NEXT | Full
NEXTTRANSID (data-area) | Full
OBFORMATST (cvda) | Partial: returns "NOOBFORMAT"
OBOPERIDST (cvda) | Partial: returns "NOOBOPERID"
OPERID (data-area) | Full
OUTLINEST (cvda) | Partial: returns "NOOUTLINE"
PAGEHT (data-area) | Full
PAGESTATUS (cvda) | Partial: returns "PAGEABLE"
PAGEWD (data-area) | Full
PARTITIONSST (cvda) | Partial: returns "NOPARTITIONS"
PRINTADAPTST (cvda) | Partial: returns "NOPRINTADAPT"
PRINTER (data-area) | Partial: returns spaces
PROGSYMBOLST (cvda) | Partial: returns "NOPROGSYMBOL"
PRTCOPYST (cvda) | Partial: returns "NOPRTCOPY"
QUERYST (cvda) | Partial: returns "NOQUERY"
RELREQST (cvda) | Partial: returns "NORELREQ"
REMOTENAME (data-area) | Partial: returns spaces
REMOTESYSTEM (data-area) | Partial: returns spaces
SCREENHEIGHT (data-area) | Full
SCREENWIDTH (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SECURITY (cvda) | Partial: returns "NOPRESETSEC"
SERVSTATUS (cvda) | Full
SESSIONTYPE (cvda) | Partial: returns "NOTAPPLIC"
SIGNONSTATUS (cvda) | Full
SOSIST (cvda) | Full
TASKID (data-area) | Partial: returns 0 meaning no task is using the terminal
TCAMCONTROL (data-area) | Partial: returns x"00" meaning null
TERMINAL (data-value) | Full
TERMMODEL (data-area) | Partial: returns 2
TERMPRIORITY (data-area) | Full
TERMSTATUS (cvda) | Full
TEXTKYBDST (cvda) | Partial: returns "NOTEXTKYBD"
TEXTPRINTST (cvda) | Partial: returns "NOTEXTPRINT"
TRACING (cvda) | Partial: returns "STANTRACE"
TRANSACTION (data-area) | Full
TTISTATUS (cvda) | Partial: returns "TTI"
UCTRANST (cvda) | Full
USERAREA (ptr-ref) | Full
USERAREALEN (data-area) | Partial: returns 0
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
VALIDATIONST (cvda) | Partial: returns "NOVALIDATION"
VFORMST (cvda) | Partial: returns "NOVFORM"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE TIMER

The INQUIRE TIMER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TRACEDEST

The INQUIRE TRACEDEST function is not supported.

Operand | Support
AUXSTATUS (cvda) | Recognized
CURAUXDS (data-area) | Recognized
GTFSTATUS (cvda) | Recognized
INTSTATUS (cvda) | Recognized
SWITCHSTATUS (cvda) | Recognized
TABLESIZE (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRACEFLAG

The INQUIRE TRACEFLAG function is not supported.

Operand | Support
SINGLESTATUS (cvda) | Recognized
SYSTEMSTATUS (cvda) | Recognized
TCEXITSTATUS (cvda) | Recognized
USERSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRACETYPE

The INQUIRE TRACETYPE function is not supported.

Operand | Support
AP (data-area) | Recognized
APPLICATION (data-area) | Recognized
BF (data-area) | Recognized
BM (data-area) | Recognized
CP (data-area) | Recognized
CPI (data-area) | Recognized
DC (data-area) | Recognized
DI (data-area) | Recognized
DISPATCHER (data-area) | Recognized
DM (data-area) | Recognized
DOMAINMGR (data-area) | Recognized
DS (data-area) | Recognized
DU (data-area) | Recognized
DUMP (data-area) | Recognized
EI (data-area) | Recognized
FC (data-area) | Recognized
GC (data-area) | Recognized
GLOBALCATLG (data-area) | Recognized
IC (data-area) | Recognized
IS (data-area) | Recognized
JC (data-area) | Recognized
KC (data-area) | Recognized
KE (data-area) | Recognized
KERNEL (data-area) | Recognized
LC (data-area) | Recognized
LD (data-area) | Recognized
LM (data-area) | Recognized
LOADER (data-area) | Recognized
LOCALCATLG (data-area) | Recognized
LOCKMGR (data-area) | Recognized
ME (data-area) | Recognized
MESSAGE (data-area) | Recognized
MN (data-area) | Recognized
MONITOR (data-area) | Recognized
PA (data-area) | Recognized
PARAMGR (data-area) | Recognized
PC (data-area) | Recognized
SC (data-area) | Recognized
SM (data-area) | Recognized
SP (data-area) | Recognized
SPECIAL | Recognized
ST (data-area) | Recognized
STANDARD | Recognized
STATISTICS (data-area) | Recognized
STORAGE (data-area) | Recognized
SZ (data-area) | Recognized
TC (data-area) | Recognized
TD (data-area) | Recognized
TI (data-area) | Recognized
TIMER (data-area) | Recognized
TR (data-area) | Recognized
TRACE (data-area) | Recognized
TS (data-area) | Recognized
UE (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRANCLASS

The INQUIRE TRANCLASS function is supported.

Operand | Support
ACTIVE (data-area) | Full
MAXACTIVE (data-area) | Full
NEXT | Full
PURGETHRESH (data-area) | Full
QUEUED (data-value) | Full
TRANCLASS (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE TRANDUMPCODE

The INQUIRE TRANDUMPCODE function is not supported.

Operand | Support
CURRENT (data-area) | Recognized
MAXIMUM (data-area) | Recognized
NEXT | Recognized
SHUTOPTION (cvda) | Recognized
SYSDUMPING (cvda) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANDUMPING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRANSACTION

The INQUIRE TRANSACTION function is supported.

Operand | Support
BREXIT (data-area) | Full
CMDSEC (cvda) | Partial: returns "CMDSECNO"
DTB (cvda) | Full
DTIMEOUT (data-area) | Partial: returns 0
DUMPING (cvda) | Full
FACILITYLIKE (data-area) | Full
ISOLATEST (cvda) | Full
NEXT | Full
OTSTIMEOUT (data-area) | Validated
PRIORITY (data-area) | Full
PROFILE (data-area) | Partial: returns spaces
PROGRAM (data-area) | Full
PURGEABILITY (cvda) | Full
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESSEC (cvda) | Full
ROUTING (cvda) | Partial: returns "STATIC"
RTIMEOUT (data-area) | Full
SCRNSIZE (cvda) | Partial: returns "DEFAULT"
STATUS (cvda) | Full
TASKDATAKEY (cvda) | Partial: returns "CICSDATAKEY"
TASKDATALOC (cvda) | Partial: returns "ANY"
TCLASS (data-area) | Partial: returns 0
TRACING (cvda) | Partial: returns "STANTRACE"
TRANCLASS (data-area) | Partial: returns spaces
TRANSACTION (data-value) | Full
TRPROF (data-area) | Partial: returns spaces
TWASIZE (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TSMODEL

The INQUIRE TSMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TSPOOL

The INQUIRE TSPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TSQNAME

The INQUIRE TSQNAME function is not supported.

Operand | Support
FLENGTH (data-area) | Recognized
LASTUSEDINT (data-area) | Recognized
LOCATION (cvda) | Recognized
MAXITEMLEN (data-area) | Recognized
MINITEMLEN (data-area) | Recognized
NEXT | Recognized
NUMITEMS (data-area) | Recognized
POOLNAME (data-value) | Recognized
RECOVSTATUS (data-area) | Recognized
SYSID (data-value) | Recognized
TRANSID (data-value) | Recognized
TSQNAME (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TSQUEUE

The INQUIRE TSQUEUE function is supported.

Operand | Support
FLENGTH (data-area) | Partial: returns -1
LASTUSEDINT (data-area) | Validated
LOCATION (cvda) | Partial: returns "AUXILIARY"
MAXITEMLEN (data-area) | Partial: returns -1
MINITEMLEN (data-area) | Partial: returns -1
NEXT | Full
NUMITEMS (data-area) | Partial: returns -1
POOLNAME (data-value) | Validated
RECOVSTATUS (data-area) | Validated
SYSID (data-value) | Validated
TRANSID (data-value) | Validated
TSQUEUE (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE UOW

The INQUIRE UOW function is not supported.

Operand | Support
AGE (data-area) | Recognized
LINK (data-area) | Recognized
NETNAME (data-area) | Recognized
NETUOWID (data-area) | Recognized
NEXT | Recognized
SYSID (data-area) | Recognized
TASKID (data-area) | Recognized
TERMID (data-area) | Recognized
TRANSID (data-area) | Recognized
UOW (data-value) | Recognized
UOWSTATE (data-area) | Recognized
USERID (data-area) | Recognized
WAITCAUSE (cvda) | Recognized
WAITSTATE (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE UOWDSNFAIL

The INQUIRE UOWDSNFAIL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE UOWENQ

The INQUIRE UOWENQ function is not supported.

Parent topic: CICS SPI Calls


INQUIRE UOWLINK

The INQUIRE UOWLINK function is not supported.

Parent topic: CICS SPI Calls


INQUIRE URIMAP

The INQUIRE URIMAP function is supported.

Operand | Support
ANALYZERSTAT (cvda) | Full
CERTIFICATE (data-area) | Full
CHARACTERSET (data-area) | Full
CIPHERS (data-area) | Full
CONVERTER (data-area) | Full
ENABLESTATUS (cvda) | Full
HFSFILE (data-area) | Full
HOST (data-area) | Full
HOSTCODEPAGE (data-area) | Full
LOCATION (data-area) | Full
MEDIATYPE (data-area) | Full
NEXT | Full
NUMCIPHERS (data-area) | Full
PATH (data-area) | Full
PIPELINE (data-area) | Full
PROGRAM (data-area) | Full
REDIRECTTYPE (cvda) | Full
SCHEME (cvda) | Full
TCPIPSERVICE (data-area) | Full
TEMPLATENAME (data-area) | Full
TRANSACTION (data-area) | Full
URIMAP (data-value) | Full
USAGE (cvda) | Full
USERID (data-area) | Full
WEBSERVICE (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE VOLUME

The INQUIRE VOLUME function is not supported.

Operand | Support
AVAILSTATUS (cvda) | Recognized
DATE (data-area) | Recognized
EMPTYSTATUS (cvda) | Recognized
JOURNALNUM (data-area) | Recognized
NEXT | Recognized
OPENSTATUS (cvda) | Recognized
PART (data-area) | Recognized
TIME (data-area) | Recognized
VOLUME (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE VTAM

The INQUIRE VTAM function is not supported.

Operand | Support
OPENSTATUS (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE WEB

The INQUIRE WEB function is not supported.

Parent topic: CICS SPI Calls


INQUIRE WEBSERVICE

The INQUIRE WEBSERVICE function is supported.

Operand | Support
BINDING (cvda) | Full
CCSID (data-area) | Full
CONTAINER (data-area) | Full
ENDPOINT (data-area) | Full
LASTMODTIME (data-area) | Partial: returns 0
MAPPINGLEVEL (data-area) | Full
MAPPINGRNUM (cvda) | Full
MAPPINGVNUM (cvda) | Full
MINRUNLEVEL (data-area) | Full
MINRUNRNUM (cvda) | Full
MINRUNVNUM (cvda) | Full
NEXT | Full
PGMINTERFACE (cvda) | Full
PIPELINE (data-area) | Full
PROGRAM (data-area) | Full
STATE (cvda) | Full
URIMAP (data-area) | Full
VALIDATIONST (cvda) | Full
WEBSERVICE (data-value) | Full
WSBIND (data-area) | Full
WSDLFILE (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE XMLTRANSFORM

The INQUIRE XMLTRANSFORM function is supported.

Operand | Support
BUNDLE (data-area) | Full
CCSID (data-area) | Full
ENABLESTATUS (cvda) | Full
MAPPINGLEVEL (data-area) | Full
MAPPINGRNUM (cvda) | Full
MAPPINGVNUM (cvda) | Full
MINRUNLEVEL (data-area) | Full
MINRUNRNUM (cvda) | Full
MINRUNVNUM (cvda) | Full
NEXT | Full
VALIDATIONST (cvda) | Partial: returns "NOVALIDATION"
XMLSCHEMA (data-area) | Full
XMLTRANSFORM (data-value) | Full
XSDBIND (data-area) | Full
Parent topic: CICS SPI Calls


PERFORM CORBASERVER

The PERFORM CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


PERFORM DELETSHIPPED

The PERFORM DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


PERFORM DJAR

The PERFORM DJAR function is not supported.

Parent topic: CICS SPI Calls


PERFORM DUMP

The PERFORM DUMP function is supported.

Operand | Support
CALLER (data-value) | Full
CALLERLENGTH (data-value) | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
TITLE (data-value) | Full
TITLELENGTH (data-value) | Full
Parent topic: CICS SPI Calls


PERFORM ENDAFFINITY

The PERFORM ENDAFFINITY function is not supported.

Parent topic: CICS SPI Calls


PERFORM RESETTIME

The PERFORM RESETTIME function is supported.

Parent topic: CICS SPI Calls


PERFORM SECURITY REBUILD

The PERFORM SECURITY REBUILD function is not supported.

Operand | Support
ESMRESP (data-area) | Recognized
Parent topic: CICS SPI Calls


PERFORM SHUTDOWN

The PERFORM SHUTDOWN function is supported.

Operand | Support
DUMP | Full
IMMEDIATE | Full
NORESTART | Full
NOSDTRAN | Validated
PLT (data-value) | Full
SDTRAN (data-value) | Validated
TAKEOVER | Validated
XLT (data-value) | Validated
Parent topic: CICS SPI Calls


PERFORM STATISTICS RECORD

The PERFORM STATISTICS RECORD function is not supported.

Operand | Support
ALL | Recognized
AUTOINSTALL | Recognized
CONNECTION | Recognized
CORBASERVER | Recognized
DISPATCHER | Recognized
DTB | Recognized
FILE | Recognized
IRCBATCH | Recognized
JOURNALNUM | Recognized
JVMPOOL | Recognized
LSRPOOL | Recognized
MONITOR | Recognized
PROGRAM | Recognized
REQUESTMODEL | Recognized
RESETNOW | Recognized
STATS | Recognized
STORAGE | Recognized
SYSDUMP | Recognized
TABLEMGR | Recognized
TASKCONTROL | Recognized
TCLASS | Recognized
TCPIP | Recognized
TCPIPSERVICE | Recognized
TDQUEUE | Recognized
TERMINAL | Recognized
TRANDUMP | Recognized
TRANSACTION | Recognized
TSQUEUE | Recognized
VTAM | Recognized
Parent topic: CICS SPI Calls


RESYNC ENTRYNAME

The RESYNC ENTRYNAME function is not supported.

Operand | Support
ENTRYNAME (data-value) | Recognized
IDLIST (data-value) | Recognized
IDLISTLENGTH (data-value) | Recognized
QUALIFIER (data-value) | Recognized
Parent topic: CICS SPI Calls


SET AUTOINSTALL

The SET AUTOINSTALL function is not supported.

Operand | Support
MAXREQS (data-value) | Recognized
PROGRAM (data-value) | Recognized
Parent topic: CICS SPI Calls


SET BRFACILITY

The SET BRFACILITY function is not supported.

Parent topic: CICS SPI Calls


SET BUNDLE

The SET BUNDLE function is supported.

Operand | Support
BUNDLE (data-value) | Full
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
Parent topic: CICS SPI Calls


SET CONNECTION

The SET CONNECTION function is supported.

Operand | Support
ACQSTATUS (data-value) | Full
ACQUIRED (cvda) | Full
CONNECTION (data-value) | Full
CONNSTATUS (data-value) | Full
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Full
FORCEPURGE (cvda) | Full
INSERVICE (cvda) | Full
NOEXITTRACE (cvda) | Full
NOTPENDING (cvda) | Full
NOZCPTRACE (cvda) | Full
OUTSERVICE (cvda) | Full
PENDSTATUS (data-value) | Partial: requires "NOTPENDING"
PURGE (cvda) | Full
PURGETYPE (data-value) | Full
RELEASED (cvda) | Full
SERVSTATUS (data-value) | Full
ZCPTRACE (cvda) | Full
ZCPTRACING (data-value) | Partial: requires "NOZCPTRACE"
Parent topic: CICS SPI Calls


SET CORBASERVER

The SET CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


SET DATASET

The SET DATASET function is supported.

Operand | Support
ADD (data-value) | Full
ADDABLE (cvda) | Full
BROWSABLE (cvda) | Full
BROWSE (data-value) | Full
BUSY (data-value) | Full
CFDTPOOL (data-value) | Validated
CFTABLE (cvda) | Validated
CICSTABLE (cvda) | Validated
CLOSED (cvda) | Full
CONSISTENT (cvda) | Validated
CONTENTION (cvda) | Validated
DATASET (data-value) | Full
DELETABLE (cvda) | Full
DELETE (data-value) | Full
DISABLED (cvda) | Full
DISPOSITION (data-value) | Partial: requires "SHARE"
DSNAME (data-area) | Full
EMPTYREQ (cvda) | Full
EMPTYSTATUS (data-value) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
EXCLUSIVE (data-value) | Partial: requires "NOTAPPLIC"
EXCTL (cvda) | Full
FILE (data-value) | Full
FORCE (cvda) | Full
KEYLENGTH (data-value) | Validated
LOAD (cvda) | Validated
LOADTYPE (data-value) | Validated
LOCKING (cvda) | Validated
LSRPOOLID (data-area) | Partial: requires 0
MAXNUMRECS (data-area) | Partial: requires 0
NOEMPTYREQ (cvda) | Full
NOEXCTL (cvda) | Full
NOLOAD (cvda) | Validated
NOTADDABLE (cvda) | Full
NOTAPPLIC (cvda) | Validated
NOTBROWSABLE (cvda) | Full
NOTDELETABLE (cvda) | Full
NOTREADABLE (cvda) | Full
NOTRLS (cvda) | Validated
NOTTABLE (cvda) | Validated
NOTUPDATABLE (cvda) | Full
NOWAIT (cvda) | Full
OBJECTNAME (data-area) | Full
OLD (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
READ (data-value) | Full
READABLE (cvda) | Full
READINTEG (data-value) | Validated
RECORDSIZE (data-value) | Validated
REPEATABLE (cvda) | Validated
RLS (cvda) | Validated
RLSACCESS (data-value) | Validated
SHARE (cvda) | Full
STRINGS (data-area) | Partial: requires 1
TABLE (data-value) | Validated
TABLENAME (data-value) | Validated
UNCOMMITTED (cvda) | Validated
UPDATABLE (cvda) | Full
UPDATE (data-value) | Full
UPDATEMODEL (data-value) | Validated
USERTABLE (cvda) | Validated
WAIT (cvda) | Full
Parent topic: CICS SPI Calls


SET DB2CONN

The SET DB2CONN function is not supported.

Parent topic: CICS SPI Calls


SET DB2ENTRY

The SET DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


SET DB2TRAN

The SET DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


SET DELETSHIPPED

The SET DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


SET DISPATCHER

The SET DISPATCHER function is not supported.

Parent topic: CICS SPI Calls


SET DOCTEMPLATE

The SET DOCTEMPLATE function is supported.

Operand | Support
COPY (data-value) | Full
DOCTEMPLATE (data-value) | Full
NEWCOPY (cvda) | Full
Parent topic: CICS SPI Calls


SET DSNAME

The SET DSNAME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
AVAILABILITY (data-value) | Recognized
AVAILABLE (cvda) | Recognized
BACKOUT (cvda) | Recognized
BKOUTSTATUS (data-value) | Recognized
BUSY (data-value) | Recognized
COMMIT (cvda) | Recognized
DSNAME (data-value) | Recognized
FAILEDBKOUT (cvda) | Recognized
FORCE (cvda) | Recognized
IMMQUIESCED (cvda) | Recognized
NORMALBKOUT (cvda) | Recognized
NOWAIT (cvda) | Recognized
QUIESCED (cvda) | Recognized
QUIESCESTATE (data-value) | Recognized
RECOVERED (cvda) | Recognized
REMOVE (cvda) | Recognized
RESETLOCKS (cvda) | Recognized
RETRY (cvda) | Recognized
UNAVAILABLE (cvda) | Recognized
UNQUIESCED (cvda) | Recognized
UOWACTION (data-value) | Recognized
WAIT (cvda) | Recognized
Parent topic: CICS SPI Calls


SET DUMPDS

The SET DUMPDS function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
INITIALDDS (data-value) | Recognized
NOSWITCH (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
SWITCH (cvda) | Recognized
SWITCHNEXT (cvda) | Recognized
SWITCHSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET ENQMODEL

The SET ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


SET FILE

The SET FILE function is supported.

Operand | Support
ADD (data-value) | Full
ADDABLE (cvda) | Full
BROWSABLE (cvda) | Full
BROWSE (data-value) | Full
BUSY (data-value) | Full
CFDTPOOL (data-value) | Validated
CFTABLE (cvda) | Validated
CICSTABLE (cvda) | Validated
CLOSED (cvda) | Full
CONSISTENT (cvda) | Validated
CONTENTION (cvda) | Validated
DATASET (data-value) | Full
DELETABLE (cvda) | Full
DELETE (data-value) | Full
DISABLED (cvda) | Full
DISPOSITION (data-value) | Partial: requires "SHARE"
DSNAME (data-area) | Full
EMPTYREQ (cvda) | Full
EMPTYSTATUS (data-value) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
EXCLUSIVE (data-value) | Partial: requires "NOTAPPLIC"
EXCTL (cvda) | Full
FILE (data-value) | Full
FORCE (cvda) | Full
KEYLENGTH (data-value) | Validated
LOAD (cvda) | Validated
LOADTYPE (data-value) | Validated
LOCKING (cvda) | Validated
LSRPOOLID (data-area) | Partial: requires 0
MAXNUMRECS (data-area) | Partial: requires 0
NOEMPTYREQ (cvda) | Full
NOEXCTL (cvda) | Full
NOLOAD (cvda) | Validated
NOTADDABLE (cvda) | Full
NOTAPPLIC (cvda) | Validated
NOTBROWSABLE (cvda) | Full
NOTDELETABLE (cvda) | Full
NOTREADABLE (cvda) | Full
NOTRLS (cvda) | Validated
NOTTABLE (cvda) | Validated
NOTUPDATABLE (cvda) | Full
NOWAIT (cvda) | Full
OBJECTNAME (data-area) | Full
OLD (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
READ (data-value) | Full
READABLE (cvda) | Full
READINTEG (data-value) | Validated
RECORDSIZE (data-value) | Validated
REPEATABLE (cvda) | Validated
RLS (cvda) | Validated
RLSACCESS (data-value) | Validated
SHARE (cvda) | Full
STRINGS (data-area) | Partial: requires 1
TABLE (data-value) | Validated
TABLENAME (data-value) | Validated
UNCOMMITTED (cvda) | Validated
UPDATABLE (cvda) | Full
UPDATE (data-value) | Full
UPDATEMODEL (data-value) | Validated
USERTABLE (cvda) | Validated
WAIT (cvda) | Full
Parent topic: CICS SPI Calls


SET IRC

The SET IRC function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
IMMCLOSE (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET JOURNALNAME

The SET JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


SET JOURNALNUM

The SET JOURNALNUM function is supported.

Operand | Support
ADVANCE (cvda) | Full
CLOSED (cvda) | Full
CLOSELEAVE (cvda) | Full
JOURNALNUM (data-value) | Full
OPENOUTPUT (cvda) | Full
OPENSTATUS (data-value) | Full
Parent topic: CICS SPI Calls


SET JVMPOOL

The SET JVMPOOL function is not supported.

Parent topic: CICS SPI Calls


SET MODENAME

The SET MODENAME function is not supported.

Operand | Support
ACQSTATUS (data-area) | Recognized
ACQUIRED (cvda) | Recognized
AVAILABLE (data-value) | Recognized
CLOSED (cvda) | Recognized
CONNECTION (data-value) | Recognized
MODENAME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET MONITOR

The SET MONITOR function is not supported.

Operand | Support
EVENT (cvda) | Recognized
EVENTCLASS (data-value) | Recognized
EXCEPT (cvda) | Recognized
EXCEPTCLASS (data-value) | Recognized
NOEVENT (cvda) | Recognized
NOEXCEPT (cvda) | Recognized
NOPERF (cvda) | Recognized
OFF (cvda) | Recognized
ON (cvda) | Recognized
PERF (cvda) | Recognized
PERFCLASS (data-value) | Recognized
STATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET NETNAME

The SET NETNAME function is supported.

Operand | Support
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Partial: requires "NOEXITTRACE"
NETNAME (data-value) | Full
NOEXITTRACE (cvda) | Full
Parent topic: CICS SPI Calls


SET PIPELINE

The SET PIPELINE function is supported.

Operand | Support
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
PIPELINE (data-value) | Full
RESPWAIT (data-area) | Full
Parent topic: CICS SPI Calls


SET PROCESSTYPE

The SET PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


SET PROGRAM

The SET PROGRAM function is supported.

Operand | Support
CEDF (cvda) | Full
CEDFSTATUS (data-value) | Partial: requires "NOCEDF"
COPY (data-value) | Full
DISABLED (cvda) | Full
DPLSUBSET (cvda) | Full
ENABLED (cvda) | Full
EXECUTIONSET (data-value) | Partial: requires "FULLAPI"
FULLAPI (cvda) | Full
HOTPOOL (cvda) | Validated
HOTPOOLING (data-value) | Validated
JVM (cvda) | Validated
JVMCLASS (data-area) | Validated
NEWCOPY (cvda) | Full
NOCEDF (cvda) | Full
NOJVM (cvda) | Validated
NOTHOTPOOL (cvda) | Validated
PHASEIN (cvda) | Full
PRIVATE (cvda) | Full
PROGRAM (data-value) | Full
RUNTIME (data-value) | Validated
SHARED (cvda) | Full
SHARESTATUS (data-value) | Partial: requires ""
STATUS (data-value) | Partial: if program is local, returns "PRIVATE"; if program is remote, returns "NOTAPPLIC"
VERSION (data-value) | Partial: requires "NEWCOPY"
Parent topic: CICS SPI Calls


SET STATISTICS

The SET STATISTICS function is not supported.

Operand | Support
ENDOFDAY (data-value) | Recognized
ENDOFDAYHRS (data-value) | Recognized
ENDOFDAYMINS (data-value) | Recognized
ENDOFDAYSECS (data-value) | Recognized
INTERVAL (data-value) | Recognized
INTERVALHRS (data-value) | Recognized
INTERVALMINS (data-value) | Recognized
INTERVALSECS (data-value) | Recognized
OFF (cvda) | Recognized
ON (cvda) | Recognized
RECORDING (data-value) | Recognized
RECORDNOW | Recognized
RESETNOW | Recognized
Parent topic: CICS SPI Calls


SET SYSDUMPCODE

The SET SYSDUMPCODE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
MAXIMUM (data-value) | Recognized
NOSHUTDOWN (cvda) | Recognized
NOSYSDUMP (cvda) | Recognized
REMOVE (cvda) | Recognized
RESET (cvda) | Recognized
SHUTDOWN (cvda) | Recognized
SHUTOPTION (data-value) | Recognized
SYSDUMP (cvda) | Recognized
SYSDUMPCODE (data-value) | Recognized
SYSDUMPING (data-value) | Recognized
Parent topic: CICS SPI Calls


SET SYSTEM

The SET SYSTEM function is supported.

Operand | Support
AKP (data-value) | Partial: requires "FULLAPI"
AMAXTASKS (data-value) | Full
CSCS (data-value) | Partial: requires ""
CUSHION (data-value) | Partial: requires ""
DTRPROGRAM (data-value) | Full
DUMPING (data-value) | Partial: requires ""
ECSCS (data-value) | Validated
ECUSHION (data-value) | Validated
ERSCS (data-value) | Validated
EUSCS (data-value) | Validated
MAXTASKS (data-value) | Partial: requires 999
MROBATCH (data-value) | Full
NEWMAXTASKS (data-value) | Full
NOSYSDUMP (cvda) | Full
PRTYAGING (data-value) | Full
RUNAWAY (data-value) | Full
SCANDELAY (data-value) | Full
SYSDUMP (cvda) | Full
TIME (data-value) | Full
USCS (data-value) | Validated
Parent topic: CICS SPI Calls


SET TASK

The SET TASK function is supported.

Operand | Support
FORCEPURGE (cvda) | Full
KILL (cvda) | Full
PRIORITY (data-value) | Validated
PURGE (cvda) | Full
PURGETYPE (data-value) | Full
TASK (data-value) | Full
Parent topic: CICS SPI Calls


SET TCLASS

The SET TCLASS function is supported.

Operand | Support
MAXIMUM (data-value) | Full
TCLASS (data-value) | Full
Parent topic: CICS SPI Calls


SET TCPIP

The SET TCPIP function is not supported.

Parent topic: CICS SPI Calls


SET TCPIPSERVICE

The SET TCPIPSERVICE function is supported.

Operand | Support
BACKLOG (data-area) | Full
CLOSED (cvda) | Full
DEREGISTERED (cvda) | Full
DNSSTATUS (data-value) | Partial: not yet implemented
IMMCLOSE (cvda) | Full
MAXDATALEN (data-area) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Partial: IMMCLOSE sets CLOSED
TCPIPSERVICE (data-value) | Full
URM (data-value) | Full
Parent topic: CICS SPI Calls


SET TDQUEUE

The SET TDQUEUE function is supported.

Operand | Support
ATIFACILITY (data-value) | Full
ATITERMID (data-value) | Full
ATITRANID (data-value) | Full
CLOSED (cvda) | Full
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
NOTERMINAL (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
TDQUEUE (data-value) | Full
TERMINAL (cvda) | Full
TRIGGERLEVEL (data-value) | Full
Parent topic: CICS SPI Calls


SET TERMINAL

The SET TERMINAL function is supported.

Operand | Support
ACQSTATUS (data-value) | Full
ACQUIRED (cvda) | Full
ALTPRINTER (data-value) | Partial: requires spaces
ALTPRTCOPY (cvda) | Full
ALTPRTCOPYST (data-value) | Partial: requires "NOALTPRTCOPY"
ATI (cvda) | Full
ATISTATUS (data-value) | Full
AUTOPAGEABLE (cvda) | Full
COLDACQ (cvda) | Full
CREATE (cvda) | Full
CREATESESS (data-value) | Partial: requires "NOCREATE"
DISCREQ (cvda) | Full
DISCREQST (data-value) | Full
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Partial: requires "NOEXITTRACE"
FORCEPURGE (cvda) | Full
INSERVICE (cvda) | Full
NEXTTRANSID (data-value) | Full
NOALTPRTCOPY (cvda) | Full
NOATI (cvda) | Full
NOCREATE (cvda) | Full
NODISCREQ (cvda) | Full
NOEXITTRACE (cvda) | Full
NOOBFORMAT (cvda) | Full
NOPRTCOPY (cvda) | Full
NORELREQ (cvda) | Full
NOTTI (cvda) | Full
NOUCTRAN (cvda) | Full
NOZCPTRACE (cvda) | Full
OBFORMAT (cvda) | Full
OBFORMATST (data-value) | Partial: requires "NOOBFORMAT"
OPERID (data-value) | Full
OUTSERVICE (cvda) | Full
PAGEABLE (cvda) | Full
PAGESTATUS (data-value) | Full
PRINTER (data-value) | Full
PRTCOPY (cvda) | Full
PRTCOPYST (data-value) | Partial: requires "NOPRTCOPY"
PURGE (cvda) | Full
PURGETYPE (data-value) | Full
RELEASED (cvda) | Full
RELREQ (cvda) | Full
RELREQST (data-value) | Partial: requires "NORELREQ"
SERVSTATUS (data-value) | Full
SPECTRACE (cvda) | Full
STANTRACE (cvda) | Full
TCAMCONTROL (data-value) | Partial: requires x"00" meaning no change
TERMINAL (data-value) | Full
TERMPRIORITY (data-value) | Full
TERMSTATUS (data-value) | Full
TRACING (data-value) | Partial: requires "STANTRACE"
TRANIDONLY (cvda) | Full
TTI (cvda) | Full
TTISTATUS (data-value) | Full
UCTRAN (cvda) | Full
UCTRANST (data-value) | Full
ZCPTRACE (cvda) | Full
ZCPTRACING (data-value) | Partial: requires "NOZCPTRACE"
Parent topic: CICS SPI Calls


SET TRACEDEST

The SET TRACEDEST function is not supported.

Operand | Support
AUXPAUSE (cvda) | Recognized
AUXSTART (cvda) | Recognized
AUXSTATUS (data-value) | Recognized
AUXSTOP (cvda) | Recognized
GTFSTART (cvda) | Recognized
GTFSTATUS (data-value) | Recognized
GTFSTOP (cvda) | Recognized
INTSTART (cvda) | Recognized
INTSTATUS (data-value) | Recognized
INTSTOP (cvda) | Recognized
NOSWITCH (cvda) | Recognized
SWITCH (cvda) | Recognized
SWITCHACTION (data-value) | Recognized
SWITCHALL (cvda) | Recognized
SWITCHNEXT (cvda) | Recognized
SWITCHSTATUS (data-value) | Recognized
TABLESIZE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRACEFLAG

The SET TRACEFLAG function is not supported.

Operand | Support
SINGLEOFF (cvda) | Recognized
SINGLEON (cvda) | Recognized
SINGLESTATUS (data-value) | Recognized
SYSTEMOFF (cvda) | Recognized
SYSTEMON (cvda) | Recognized
SYSTEMSTATUS (data-value) | Recognized
TCEXITALL (cvda) | Recognized
TCEXITALLOFF (cvda) | Recognized
TCEXITNONE (cvda) | Recognized
TCEXITSTATUS (data-value) | Recognized
TCEXITSYSTEM (cvda) | Recognized
USEROFF (cvda) | Recognized
USERON (cvda) | Recognized
USERSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRACETYPE

The SET TRACETYPE function is not supported.

Operand | Support
AP (data-value) | Recognized
APPLICATION (data-value) | Recognized
BF (data-value) | Recognized
BM (data-value) | Recognized
CP (data-value) | Recognized
CPI (data-value) | Recognized
DC (data-value) | Recognized
DI (data-value) | Recognized
DISPATCHER (data-value) | Recognized
DM (data-value) | Recognized
DOMAINMGR (data-value) | Recognized
DS (data-value) | Recognized
DU (data-value) | Recognized
DUMP (data-value) | Recognized
EI (data-value) | Recognized
FC (data-value) | Recognized
GC (data-value) | Recognized
GLOBALCATLG (data-value) | Recognized
IC (data-value) | Recognized
IS (data-value) | Recognized
JC (data-value) | Recognized
KC (data-value) | Recognized
KE (data-value) | Recognized
KERNEL (data-value) | Recognized
LC (data-value) | Recognized
LD (data-value) | Recognized
LM (data-value) | Recognized
LOADER (data-value) | Recognized
LOCALCATLG (data-value) | Recognized
LOCKMGR (data-value) | Recognized
ME (data-value) | Recognized
MESSAGE (data-value) | Recognized
MN (data-value) | Recognized
MONITOR (data-value) | Recognized
PA (data-value) | Recognized
PARAMGR (data-value) | Recognized
PC (data-value) | Recognized
SC (data-value) | Recognized
SM (data-value) | Recognized
SP (data-value) | Recognized
SPECIAL | Recognized
ST (data-value) | Recognized
STANDARD | Recognized
STATISTICS (data-value) | Recognized
STORAGE (data-value) | Recognized
SZ (data-value) | Recognized
TC (data-value) | Recognized
TD (data-value) | Recognized
TI (data-value) | Recognized
TIMER (data-value) | Recognized
TR (data-value) | Recognized
TRACE (data-value) | Recognized
TS (data-value) | Recognized
UE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRANCLASS

The SET TRANCLASS function is supported.

Operand | Support
MAXACTIVE (data-area) | Full
PURGETHRESH (data-area) | Full
TRANCLASS (data-value) | Full
Parent topic: CICS SPI Calls


SET TRANDUMPCODE

The SET TRANDUMPCODE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
MAXIMUM (data-value) | Recognized
NOSHUTDOWN (cvda) | Recognized
NOSYSDUMP (cvda) | Recognized
NOTRANDUMP (cvda) | Recognized
REMOVE (cvda) | Recognized
RESET (cvda) | Recognized
SHUTDOWN (cvda) | Recognized
SHUTOPTION (data-value) | Recognized
SYSDUMP (cvda) | Recognized
SYSDUMPING (data-value) | Recognized
TRANDUMP (cvda) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANDUMPING (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRANSACTION

The SET TRANSACTION function is supported.

Operand | Support
DISABLED (cvda) | Full
DUMPING (data-value) | Full
ENABLED (cvda) | Full
NOTPURGEABLE (cvda) | Full
NOTRANDUMP (cvda) | Full
OTSTIMEOUT (data-area) | Validated
PRIORITY (data-value) | Full
PRIORITY (data-value) | Validated
PURGEABILITY (data-value) | Full
PURGEABLE (cvda) | Full
RUNAWAYTYPE (data-value) | Validated
SHUTDISABLED (cvda) | Validated
SHUTDOWN (data-value) | Validated
SHUTENABLED (cvda) | Validated
SPECTRACE (cvda) | Full
SPRSTRACE (cvda) | Full
STANTRACE (cvda) | Full
STATUS (data-value) | Full
SYSTEM (cvda) | Validated
TCLASS (data-value) | Full
TRACING (data-value) | Partial: requires "STANTRACE"
TRANCLASS (data-value) | Full
TRANDUMP (cvda) | Full
TRANSACTION (data-value) | Full
USER (cvda) | Validated
Parent topic: CICS SPI Calls


SET TSQNAME

The SET TSQNAME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
DELETE (cvda) | Recognized
LASTUSEDINT (data-value) | Recognized
POOLNAME (data-value) | Recognized
SYSID (data-value) | Recognized
TSQNAME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TSQUEUE

The SET TSQUEUE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
DELETE (cvda) | Recognized
LASTUSEDINT (data-value) | Recognized
POOLNAME (data-value) | Recognized
SYSID (data-value) | Recognized
TSQUEUE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET UOW

The SET UOW function is not supported.

Operand | Support
BACKOUT (cvda) | Recognized
COMMIT (cvda) | Recognized
FORCE (cvda) | Recognized
UOW (data-value) | Recognized
UOWSTATE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET UOWLINK

The SET UOWLINK function is not supported.

Parent topic: CICS SPI Calls


SET URIMAP

The SET URIMAP function is supported.

Operand | Support
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
LOCATION (data-area) | Full
NONE (cvda) | Full
PERMANENT (cvda) | Full
REDIRECTTYPE (cvda) | Full
TEMPORARY (cvda) | Full
URIMAP (data-value) | Full
Parent topic: CICS SPI Calls


SET VOLUME

The SET VOLUME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
AVAILSTATUS (data-value) | Recognized
JOURNALNUM (data-value) | Recognized
NOWRITE (cvda) | Recognized
OK (cvda) | Recognized
REMOVE (cvda) | Recognized
VOLUME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET VTAM

The SET VTAM function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
FORCECLOSE (cvda) | Recognized
IMMCLOSE (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET WEB

The SET WEB function is not supported.

Parent topic: CICS SPI Calls


SET WEBSERVICE

The SET WEBSERVICE function is supported.

Operand | Support
NOVALIDATION (cvda) | Full
VALIDATION (cvda) | Full
VALIDATIONST (data-value) | Full
WEBSERVICE (data-value) | Full
Parent topic: CICS SPI Calls