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Preface

Preface

Contacting Micro Focus Fortify Customer Support

Visit the Support website to:

e Manage licenses and entitlements

o Creatfe and manage fechnical assistance requests
o Browse documentation and knowledge articles

o Download software

o Explore the Community

https://www.microfocus.com/support

For More Information

For more information about Fortify software products:
https://www.microfocus.com/solutions/application-security

About the Documentation Set

The Fortify Software documentation set contains installation, user, and deployment guides for all
Fortify Software products and components. In addition, you will find technical notes and release notes
that describe new features, known issues, and last-minute updates. You can access the latest versions of
these documents from the following Micro Focus Product Documentation website:

https://www.microfocus.com/support/documentation
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Change Log

The following table lists changes made to this document. Revisions to this document are published only
if the changes made affect product functionality.

Software Release /
Document Version Change

21.1.0 Added:

e "About Analyzing the Source Code" on page 22 and "About Scanning
with Fortify ScanCentral SAST" on page 34 - New ability to scan source
code with Micro Focus Fortify ScanCentral SAST

20.2.0 Updated:

¢ "Logging in to Fortify Software Security Center" on page 95 and
"Opening a Fortify Software Security Center Application Version" on
page 121 - New ability to connect to Fortify Software Security Center
with an authentication token

20.1.0 Updated:

e "Generatfing Legacy Reports" on page 85 - Removed RTF as an output
format for legacy reports

19.2.0 Updated:

¢ '"Issue Auditing View" on page 53 - Tab names were changed to be
consistent with Micro Focus Fortify Software Security Center
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Chapter 1: Introduction

This guide provides information about how to install and use the Fortify Plugins for Eclipse.

This section contains the following topics:

Fortify Plugin for EClipse .l 10
Fortify Remediation Plugin for EClipse ... . 10
Related DOCUMENTS 11

Fortify Plugin for Eclipse

The Fortify Plugin for Eclipse (Eclipse Complete Plugin) consists of three separate plugin components:

o Analysis—Enables you to initiate a Micro Focus Fortify Static Code Analyzer analysis with Fortify
Software Security Content, view the analysis results, and fix the code associated with uncovered
issues, all within the Eclipse IDE.

« Audit—Enables you to open existing analysis results and audit them. These results include detailed
descriptions of the security vulnerabilities detected and recommended remediation strategies. The
audit plugin component helps security code inspection by enabling you to easily navigate to the
source code location associated with each vulnerability, and then prioritize and audit the results.

¢ Collaboration—Includes server-related functionality such as connecting to Micro Focus Fortify
Software Security Center, uploading results to Fortify Software Security Center, and performing
collaborative audits. (If you do not want this functionality, then there is no need to install the
collaboration plugin.)

Note: For information about supported versions of Eclipse, see the Micro Focus Fortify Software
System Requirements document.

For instructions on how to install and use the Eclipse Complete Plugin, see "Using the Eclipse Complete
Plugin" on page 15.

Fortify Remediation Plugin for Eclipse

The Fortify Remediation Plugin for Eclipse (Eclipse Remediation Plugin) works in conjunction with Micro
Focus Fortify Software Security Center to add remediation functionality to your software security
analysis from the Eclipse IDE. The Eclipse Remediation Plugin is a lightweight plugin option for
developers who do not need the scanning and auditing capabilities of Audit Workbench and the Eclipse
Complete Plugin.

The Eclipse Remediation Plugin enables developers to quickly and easily understand the reported
vulnerabilities and implement appropriate solutions.
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Developers can address security issues while they write code in Eclipse. Your organization can use the
Eclipse Remediation Plugin with Fortify Software Security Center to manage projects and assign specific

issues fo the relevant developers.

For instructions on how to install and use the Eclipse Remediation Plugin, see "Using the Eclipse

Remediation Plugin" on page 119.

Related Documents

This topic describes documents that provide information about Micro Focus Fortify software products.

Note: You can find the Micro Focus Fortify Product Documentation at
https://www.microfocus.com/support/documentation. All guides are available in both PDF and

HTML formats.

All Products

The following documents provide general information for all products. Unless otherwise noted, these
documents are available on the Micro Focus Product Documentation website.

Document / File Name

About Micro Focus Fortify Product
Software Documentation

About_Fortify_Docs_<version>.pdf

Micro Focus Fortify Software System
Requirements

Fortify_Sys_Reqs_<version>.pdf

Micro Focus Fortify Software Release
Notes

FortifySW_RN_<version>.pdf

What’s New in Micro Focus Fortify
Software <version>

Fortify_Whats_New_<version>.pdf

Micro Focus Fortify Plugins for Eclipse (21.1.0)

Description

This paper provides information about how fo access Micro
Focus Fortify product documentation.

Note: This document is included only with the product
download.

This document provides the details about the
environments and products supported for this version of
Fortify Software.

This document provides an overview of the changes made
to Fortify Software for this release and important
information not included elsewhere in the product
documentation.

This document describes the new features in Fortify
Software products.
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Micro Focus Fortify ScanCentral SAST

The following document provides information about Fortify ScanCentral SAST. Unless otherwise
noted, these documents are available on the Micro Focus Product Documentation website at
https://www.microfocus.com/documentation/fortify-software-security-center.

Document / File Name

Micro Focus Fortify ScanCentral
SAST Installation, Configuration, and
Usage Guide

SC_SAST_Guide_<version>.pdf

Description

This document provides information about how to install,
configure, and use Fortify ScanCentral SAST to streamline
the static code analysis process. It is written for anyone who
intends to install, configure, or use Fortify ScanCentral
SAST to offload the resource-intensive translation and
scanning phases of their Fortify Static Code Analyzer
process.

Micro Focus Fortify Software Security Center

The following document provides information about Fortify Software Security Center. Unless otherwise
noted, these documents are available on the Micro Focus Product Documentation website at
https://www.microfocus.com/documentation/fortify-software-security-center.

Document / File Name

Micro Focus Fortify Software
Security Center User Guide

SSC_Guide_<version>.pdf

Description

This document provides Fortify Software Security Center
users with detailed information about how to deploy and use
Software Security Center. I provides all of the information you
need to acquire, install, configure, and use Software Security
Center.

It is intended for use by system and instance administrators,
database administrators (DBAs), enterprise security leads,
development team managers, and developers. Software
Security Center provides security team leads with a high-level
overview of the history and current status of a project.
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Micro Focus Fortify Static Code Analyzer

The following documents provide information about Fortify Static Code Analyzer. Unless otherwise
noted, these documents are available on the Micro Focus Product Documentation website at
https://www.microfocus.com/documentation/fortify-static-code.

Document / File Name

Micro Focus Fortify Static Code
Analyzer User Guide

SCA_Guide_<version>.pdf

Micro Focus Fortify Static Code
Analyzer Custom Rules Guide

SCA_Cust_Rules_Guide_<version>.zip

Micro Focus Fortify Audit Workbench
User Guide

AWB_Guide_<version>.pdf

Micro Focus Fortify Plugins for Eclipse
User Guide

Eclipse_Plugins_Guide_<version>.pdf

Micro Focus Fortify Plugins for
JetBrains IDEs and Android Studio
User Guide

JetBrains_AndStud_Plugins_Guide_
<version>.pdf

Micro Focus Fortify Jenkins Plugin
User Guide

Jenkins_Plugin_Guide_<version>.pdf

Micro Focus Fortify Plugins for Eclipse (21.1.0)

Description

This document describes how to install and use Fortify
Static Code Analyzer to scan code on many of the major
programming platforms. It is intended for people
responsible for security audits and secure coding.

This document provides the information that you need to
create custom rules for Fortify Static Code Analyzer. This
guide includes examples that apply rule-writing concepts to
real-world security issues.

Note: This document is included only with the product
download.

This document describes how to use Fortify Audit
Workbench to scan software projects and audit analysis
results. This guide also includes how to integrate with bug
trackers, produce reports, and perform collaborative
auditing.

This document provides information about how to install
and use the Fortify Complete and the Fortify Remediation
Plugins for Eclipse.

This document describes how to install and use both the
Fortify Analysis Plugin for IntelliJ IDEA and Android Studio
and the Fortify Remediation Plugin for IntelliJ IDEA,
Android Studio, and other JetBrains IDEs.

This document describes how to install, configure, and use
the plugin. This documentation is available at
https://www.microfocus.com/documentation/fortify-
jenkins-plugin.
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Document / File Name

Micro Focus Fortify Security Assistant
Plugin for Eclipse User Guide

SecAssist_Eclipse_Guide_
<version>.pdf

Micro Focus Fortify Extension for
Visual Studio User Guide

VS_Ext_Guide_<version>.pdf
Micro Focus Fortify Static Code

Analyzer Tools Properties Reference
Guide

SCA_Tools_Props_Ref_<version>.pdf

Description

This document describes how to install and use Fortify
Security Assistant plugin for Eclipse to provide alerts to
security issues as you write your Java code.

This document provides information about how to install
and use the Fortify extension for Visual Studio to analyze,
audit, and remediate your code to resolve security-related
issues in solutions and projects.

This document describes the properties used by Fortify
Static Code Analyzer tools.
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Chapter 2: Using the Eclipse Complete Plugin

This section contains the following topics:

About Installing the Eclipse Complete Plugin ... 15
Fortify Software Security Content L 19
About Analyzing the Source Code ...l 22
About Scanning Locally . 23
About Scanning with Fortify ScanCentral SAS T . L 34
About Viewing Analysis ResUNs . L 39
Working With ISSUES . 59
Searching for ISSUES . .. 74
GenErating RE PO S L 85
Configuring a Connection to Fortify Software Security Center ... . .. 94
Working with Audit Projects .. 97
AboUt ISSUE TeMPIATES . L 101
TroubleshoOtiNg .. L 116

About Installing the Eclipse Complete Plugin

Before you install the plugin in Eclipse, you must have selected the Eclipse Plugin during your Micro
Focus Fortify Static Code Analyzer installation.

You have the follow options for installing the Eclipse Complete Plugin:
¢ '"Installing the Eclipse Complete Plugin from Eclipse" on the next page

¢ '"Installing the Eclipse Complete Plugin from an Update Site" on page 17

To update from an earlier Eclipse Complete Plugin version, you must first remove the existing version.
For information about how to uninstall the plugin, see About Uninstalling the Eclipse Complete Plugin.

Note: These instructions describe a third-party product and might not match the specific,
supported version you are using. See your product documentation for the instructions for your
version.

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 15 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

Installing the Eclipse Complete Plugin from Eclipse
To install the Eclipse Complete Plugin locally:

1. Start Eclipse.
2. Select Help > Install New Software.
3. Click Add.
The Add Repository dialog box opens.
4. To create a local update site on your file system (as opposed to one on the Internet):

a. (Optional) In the Name box, type a name for the local update site.

b. Click Local, and then browse to and select the <sca_install dir>/plugins/eclipse
directory.

c. Click Add.

In the Install window, the Work with list displays the name and location of your local update site
and the Fortify Eclipse Plugins node is listed as available software.

5. Expand the Fortify Eclipse Plugins node and select the check boxes for the features you want to
install.

type filter et

Mame

~ [] 000 Fortify Eclipse Plugins
[] &k Fortify Analysis Plugin for Eclipse
[ ]k Fortify Audit Plugin for Eclipse
[] 4 Fortify Collaboration Plugin for Eclipse

Note: Any required third-party dependencies are automatically installed if they do not already
exist on your system.

6. If you have Eclipse Java Development Tools (JDT) installed, you can clear the Contact all update
sites during install to find required software check box to reduce the installation time.

Note: Only the Fortify Analysis Plugin for Eclipse feature requires JDT.

7. Click Next.
The Install Details step lists the plugins you selected.

8. Todisplay version and copyright information for a plugin in the Details section, click the feature
name.

9. Click Next.
10. On the Review Licenses step, review and accept the terms of the Micro Focus license agreement.
11. Click Finish.
12. To complete the installation and restart Eclipse, click Restart Now when prompted.

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 16 of 130
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After Eclipse restarts, the menu bar includes the Fortify menu.

Installing the Eclipse Complete Plugin from an Update Site

An alternative to requiring every developer to install the Eclipse Complete Plugin locally is to post the
plugin to an internal update site that can serve as a single distribution point. The only requirement is
that you have an internal web server.

Posting the Eclipse Complete Plugin to an Internal Update Site

To post the plugin for other users to access:

1. Copy the contents of <sca_install_dir>/plugins/eclipse directory on to your web server.
2. Provide the URL for the update site to the appropriate users.

Installing the Eclipse Complete Plugin from an Update Site
To install the Eclipse Complete Plugin after it has been posted to an update site:

1. Obtain the URL of the plugin update site for your organization.
2. Select Help > Install New Software.

3. Click Add.

4. In the Name box, type a name for the update site.

5. In the Location box, type the URL of the update site.

6. Click OK.

In the Install window, the Work with list displays the update site you specified and the Fortify
Eclipse Plugins node is listed as available software.

~

Expand the Fortify Eclipse Plugins node, select the Fortify Eclipse Plugins check box, and then
select the check box or check boxes for the plugins you want to install.

type filter text

Mame

w [_] 000 Fortify Eclipse Plugins
[ 4k Fortify Analysis Plugin for Eclipse
[ 4 Fortify Audit Plugin for Eclipse
[] & Fortify Collaboration Plugin for Eclipse

Note: Any required third-party dependencies are automatically installed if they do not already
exist on your system.

8. Click Next.
The Install Details step lists the plugins you selected.

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 17 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

9. To display version and copyright information about the plugin in the Details box, click the plugin
name.

10. Click Next.

11. Onthe Review Licenses step, review and accept the terms of the Micro Focus license agreement.
12. Click Finish.

13. Click OK.

14. To complete the installation, click Yes to restart Eclipse when prompted.

After Eclipse restarts, the menu bar includes the Fortify menu.

About Re-installing After Upgrading Fortify SCA and Applications
from Fortify Audit Workbench

If you have upgraded Fortify SCA and Applications from Audit Workbench, you must uninstall, and
then reinstall the Eclipse Complete Plugin. For information about how you can upgrade the Fortify
SCA and Applications from Fortify Audit Workbench, see the Micro Focus Fortify Audit Workbench
User Guide.

Managing the License

The Fortify license enables you to scan your code with the Eclipse Complete Plugin. For information
about how to obtain a Fortify license file, see the Micro Focus Fortify Software System Requirements
document.

To update your license file:

1. Select Fortify > Manage License.

2. Click Browse and locate the license file on your computer, and then click OK.

Uninstalling the Eclipse Complete Plugin

You can uninstall the Eclipse Complete Plugin from either Eclipse or from the command line. See the
Eclipse instructions for how to remove installed software from Eclipse.

An uninstall script isin the <sca_install_dir>/plugins/eclipse directory.

To uninstall all the Fortify Eclipse plugins from the command line:

1. Close Eclipse if it is open.

2. Run the uninstall script for your operating system:

e On Windows, rununinstall fortify plugins.cmd.

e On LinuxormacOS, rununinstall fortify plugins.sh.

3. Type the location of the folder that contains the Eclipse executable.
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Fortify Software Security Content

The Eclipse Complete Plugin uses a knowledge base of rules to enforce secure coding standards
applicable to the codebase for static analysis. Fortify software security content consists of Fortify
Secure Coding Rulepacks and external metadata:

o Fortify Secure Coding Rulepacks describe general secure coding idioms for popular languages and
public APIs

o External metadata provides mappings from the Fortify vulnerability categories to alternative
categories (such as CWE, OWASP Top 10, and PCD

Fortify provides the ability to write custom rules that add to the functionality of Fortify Static Code
Analyzer and the Secure Coding Rulepacks. For example, you might need to enforce proprietary
security guidelines or analyze a project that uses third-party libraries or other pre-compiled binaries that
are not already covered by the Secure Coding Rulepacks. You can also customize the external metadata
to map Fortify issues to different taxonomies, such as internal application security standards or
additional compliance obligations. For instructions on how to create your own custom rules or custom
external metadata, see the Micro Focus Fortify Static Code Analyzer Custom Rules Guide.

If you are using collaborative auditing with Micro Focus Fortify Software Security Center, make sure
that any custom rules or external metadata changes are also made in Fortify Software Security Center.

Typically, you obtain the current Fortify Software Security Content when you install Fortify SCA and
Applications.

See Also

o "Configuring Security Content Updates" below
o "Updating Security Content" on page 21
e "Manually Updating Security Content" on page 22

e "Importing Custom Security Content" on page 22

Configuring Security Content Updates

If the analysis plugin component is installed, you can specify the server information to use fo update
security content. To update security content manually (without an Internet connection or Micro Focus
Fortify Software Security Center), see "Manually Updating Security Content" on page 22.

To configure security content updates:

1. Select Fortify > Options.
2. In the left pane, select Server Configuration.
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B Options X

Server Configuration
Server Configuration Security Content Update

Bugtracker Proxy Configuratiof (O Update from Software Security Center

Security Content Management| (@) Update from Fortify Update Server
Audit Configuration

Default Project Settings Server URL: | https://update.fortify.com |
ScanCentral SAST Configuratic Proxy Server: | Port: | |
Usernarme: | |
Passwaord: | |

[] Update security content automatically

Update frequency (days) | 15

Software Security Center

Server URL: | http://localhost:8180/ssd |
Proxy Server: | | Port: :]
— |
Password: | ]

Refresh Permissions for the Current Audit  Disconnect the Current Audit

Apply Defaults

3. To update security content from your Fortify Software Security Center server:

a. Under Security Content Update, select the Update from Software Security Center check
box.

Note: If this check box is unavailable, then click Security Content Management in the left
pane and if prompted to locate the Fortify Static Code Analyzer executable location, click
OK and specify its location.

b. Under Software Security Center, specify the Fortify Software Security Center server URL and
if necessary, the proxy server, port number, and optionally credentials for proxy authentication.

4. To specify an update server from which to update security content, under Security Content
Update, do the following:

a. Inthe Server URL box, type the URL for the update server.

b. If required, specify the proxy server, port number, and optionally credentials for proxy
authentication.
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5. To update security content automatically and with a specific frequency:
a. Select the Perform security content update automatically check box.

b. Inthe Update frequency (days) box, specify how often (type the number of days) you want
the security content automatically updated.

6. Click Apply, and then click OK.

Updating Security Content

Fortify provides security content in English, Spanish, Brazilian Portuguese, Japanese, Korean,
Simplified Chinese, or Traditional Chinese. Issue descriptions and recommendations are available in the
selected language and the Fortify categories are in English.

To update your security content:

1. Select Fortify > Options.
2. Inthe left pane, select Security Content Management.

B Options

Security Content Management

Server Configuration SCA Path: | C:\Program Files\Fortify\Fortify_SCA_and_Apps_21. || Browse...
Bugtracker Proxy Configuration ¢ a version: 21.1.0.0100

Security Content Management secyyrity Content Last Update: Thu Feb 18 18:09:55 GMT 2021
Audit Configuration : : "
Default Project Settings Installed Fortify Security Content

ScanCentral SAST Cenfiguratic Fortify Secure Coding Rules, Core, .MET

Fortify Secure Coding Rules, Core, ABAP

Fortify Secure Coding Rules, Core, ActionScript 3.0

Fortify Secure Coding Rules, Core, Android

Fortify Secure Coding Rules, Core, Annotations

Fortify Secure Coding Rules, Core, Apex

Fortify Secure Coding Rules, Core, C/Cs+

Fortify Secure Coding Rules, Core, Classic ASP, VBScnpt, and VBG

Fortify Secure Coding Rules, Core, COBOL hd

Installed Custom Security Content

Update Security Content - en ¥ | Import Custom Security Content
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Note: Scroll fo the bottom of the Installed Fortify Security Content list to see the external
mappings.

Any custom rules and custom external mappings appear in the Installed Custom Security
Content list.

3. In the Update Security Content list, select the security content in the language you want.
The Security Content Update window displays the results of the security content update.

4. Click OK to close the Security Content Update window.

Manually Updating Security Content

You can manually update security content from a local ZIP file with the fortifyupdate utility.

To manually update your security content:

1. Open acommand prompt window, and then navigate to the <sca_1install_dir>/bin directory.
2. At the prompt, type the following:
fortifyupdate -import <file>.zip

For more information about the fortifyupdate utility, see the Micro Focus Fortify Static Code Analyzer
User Guide.

Importing Custom Security Content
You can import custom security content to use in your scans.

Note: To import custom external metadata, place your external metadata file in the <sca_install_
dir>/Core/config/CustomExternalMetadata directory.

To import custom rules, do the following:

1. Select Fortify > Options.
2. Inthe left pane, select Security Content Management.
3. Click Import Custom Security Content.

4, Select the customrules file you want to import, and then click Open.

Note: Custom security content is only supported with static analysis.

About Analyzing the Source Code

If you installed the analysis plugin component, you can initiate an analysis of your source code from
Eclipse. To get the best analysis results, make sure that you can compile the project with no errors
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before you analyze your project source code. A security analysis with Micro Focus Fortify Static Code
Analyzer consists of the following main phases:

e Translate the source code files into intermediate files

« Scan the intermediate files fo complete the security analysis

There are two ways to analyze your source code:

o Use the locally installed Micro Focus Fortify Static Code Analyzer to perform the entire analysis
(translation and scan phases). For information about how to configure and run the analysis locally,
see "About Scanning Locally" below.

After the scan is complete, the Eclipse Complete Plugin displays the analysis results in Eclipse.

o Use Micro Focus Fortify ScanCentral SAST to perform the entire analysis (franslation and scan
phases) or only the scan phase. For information about how to configure and run the analysis using
Fortify ScanCentral SAST, see "About Scanning with Fortify ScanCentral SAST" on page 34.

Note: If you use Fortify ScanCentral SAST to perform only the scan phase, then the Eclipse
Complete Plugin performs the translation using the locally installed Fortify Static Code Analyzer.

To view the analysis results after a Fortify ScanCentral SAST scan, configure the Eclipse Complete
Plugin to upload the analysis results to a Fortify Software Security Center server. You can then
connect to Fortify Software Security Center to view the analysis results in Eclipse (see "Using the
Eclipse Remediation Plugin" on page 119).

Alternatively, use the provided job token in the Fortify ScanCentral SAST command-line interface to
retrieve the analysis results (FPR) file (see the Micro Focus Fortify ScanCentral SAST Installation,
Configuration, and Usage Guide). You can then use the Eclipse Complete Plugin to open the analysis
results in Eclipse (see "Opening an Audit Project" on page 98).

About Scanning Locally

This section describes how to configure the analysis options and perform a scan of your Java source
code using the locally installed Micro Focus Fortify Static Code Analyzer. The Eclipse Complete Plugin
invokes Fortify Static Code Analyzer with the server Java Virtual Machine.

Fortify strongly recommends that you periodically update the security content, which contains Fortify
Secure Coding Rulepacks and external metadata. For instructions, see "Updating Security Content" on
page 21.

About Quick Scan Mode

Quick scan mode provides a way to quickly scan your projects for critical- and high-priority issues.
Fortify Static Code Analyzer performs the scan faster by reducing the depth of the analysis and
applying the Quick View filter set. The quick scan settings are configurable. For more details about the
configuration of quick scan mode, see the Micro Focus Fortify Static Code Analyzer User Guide.

Quick scans are a great way to get many applications through an assessment so that you can quickly
find issues and begin remediation. The performance improvement you get depends on the complexity
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and size of the application. Although the scan is faster than a full scan, it does not provide as robust a
result set. Other issues that a quick scan cannot detect might exist in your application. Fortify
recommends that you run full scans whenever possible.

Note: By default, Micro Focus Fortify Software Security Center does not allow you to upload scans
performed in quick scan mode. However, you can configure your Fortify Software Security Center
application version so that uploaded audit projects scanned in quick scan mode are processed. For
more information, see analysis results processing rules in the Micro Focus Fortify Software Security
Center User Guide.

You can use quick scan mode for scans that use a locally installed Fortify Static Code Analyzer. Audit
quick scan results just as you audit full analysis results. To configure your scan to run in full scan or
quick scan mode, see "Configuring Advanced Local Analysis Options" on the next page.

Configuring Local Analysis Options

The analysis options enable you to customize the security content and the amount of memory Micro
Focus Fortify Static Code Analyzer uses during a local analysis. You can also specify the SQL type used
in your project. The source code analysis options are available only if the analysis plugin is installed.

To configure the analysis options:

1. Select Fortify > Options.
2. Select Default Project Configuration.
The Analysis Configuration tab opens.

B Options X

Default Project Configuration

Server Configuration Analysis Configuration Advanced Analysis Options Synchronize Options

Bugtracker Proxy Configuratiol ¢ Cenfiguration

Security Content Management
Audit Configuration Memory (MB): SQL Type: v

Default Project Configuration Security Content

ScanCentral SAST Configuratic 4] Use All Installed Security Content Manage Security Content

3 [ ] Installed Fortify Security Content

[] Installed Custom Security Content

3. To specify the amount of memory to use for the scan, type an integer in the Memory (MB) box.

Note: Do not allocate more than two thirds of the available physical memory.
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4. By default, Fortify Static Code Analyzer treats SQL files as though they use the T-SQL procedural
language on Windows systems and PL/SQL on other platforms. To specify the SQL type, from the
SQL Type list, select TSQL or PLSQL.

Note: The SQL Type option notifies Fortify Static Code Analyzer about the SQL type that the
project uses. SQL code is only scanned if it is included in the project.

5. To use specific security content to scan the project (instead of all security content), under Security
Content, clear the Use All Installed Security Content check box, and then select the check boxes
for the installed Fortify and custom security content to use.

6. To update or import custom security content, click Manage Security Content.
For more information, see "Updating Security Content" on page 21.
7. Click OK.

Configuring Advanced Local Analysis Options

Use the advanced analysis options to customize Micro Focus Fortify Static Code Analyzer translation
and scan command-line options. You can also specify whether quick scan mode is enabled, if issues are
merged during a rescan, if resources in dependent projects are scanned, and the location for the
analysis results file. These options are available only if the analysis plugin is installed.

To change the advanced analysis options:

1. Select Fortify > Options.
2. Inthe left pane, select Default Project Configuration.
3. Select the Advanced Analysis Options tab.
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B Options X

Default Project Configuration

Server Configuration Analysis Configuration Advanced Analysis Options  Synchronize Options
Bugtracker Proxy Configuratio
Secunty Content Management
Audit Configuration

Default Project Configuration
SeanCentral SAST Configuratic|

[] Scan resources in dependent projects

[] Use additional SCA options

Local 5can Options

[] Enable quick scan mode
Merge with previous scan

QOutput results to: | S{project_loc\5{project_name}_scan.fpr

Workspace... | File System... | Variables...

4, To scan only the selected project, clear the Scan resources in dependent projects check box.

By default, the Eclipse Complete Plugin includes all source files from dependent projects in scans of
selected projects. For more information, see "Viewing the Resources and Classpath to be Scanned"
on the next page.

5. Select the Use additional SCA options check box and type command-line options for either the
translation or scan phase.

For example, if you include the -verbose command-line option, detailed status messages are sent
to the console during the analysis.

For information about the available command-line options and the proper syntax, see the Micro
Focus Fortify Static Code Analyzer User Guide.

6. To perform a quick scan, select the Enable quick scan mode check box.
For more information about quick scans, see "About Quick Scan Mode" on page 23.

7. To disable merging the results of the next scan you run with results from the previous scan, clear
the Merge with previous scan check box.

For more information about merging analysis results with rescanning, see "Rescanning Projects" on
page 33.
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8. To change the default directory and FPR file name for all projects, do one of the following:
¢ Inthe Output results to box, type the absolute path for FPR files.

o To specify a name and a static workspace folder for FPR files, click Workspace, and then, in the
Folder Selection window, navigate to and select a workspace relative directory.

o To specify a name and a static folder that is not part of your workspace, click File System, and
then select a directory for FPR files.

¢ To specify a name and a dynamic path that changes based on the project you are analyzing, click
Variables, and then, in the Select Variable window, select core Eclipse variables to specify the
relative path for FPR files.

To change the default directory and FPR file name for a specific project, use the Eclipse Properties
window (see "Configuring Analysis Options for Specific Projects" below).

9. Click OK to save the advanced analysis options.

Configuring Analysis Options for Specific Projects
To specify Micro Focus Fortify Static Code Analyzer analysis options a specific project:

1. From the Java perspective in Eclipse, right-click a project name, and then select Properties.
The Properties for <project_name> window opens.

2. Inthe left pane, select Fortify Project Properties.

3. Select the Enable Project Specific Settings check box.

4. Make the changes you want for this specific project.

For descriptions of the options, see "Configuring Local Analysis Options" on page 24 and
"Configuring Advanced Local Analysis Options" on page 25.

Viewing the Resources and Classpath to be Scanned

To see the project resources and classpath to be scanned for a project:

1. Fromthe Java view in Eclipse, do one of the following:
o Right-click a project name, and then select Advanced Analysis.

o Select a project name, and then select Fortify > Advanced Analysis.

The Advanced Static Analysis wizard opens.
2. Expand the directory tree.

The Advanced Static Analysis displays the complete absolute path of the project resources and
classpath files to be scanned. If you have Scan resources in dependent projects enabled in the default
project configuration options (see "Configuring Advanced Local Analysis Options" on page 25), you can
see any dependent projects in the Scanning Resources rooft. All library JAR files configured for your
project are shown in the Classpath folder.
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Scanning Projects Locally

The Eclipse Complete Plugin automatically includes all source files from dependent projects in scans.
Although you can scan individual packages and files (see "Scanning Individual Files and Packages"
below), the results are more accurate if you scan an entire project at once.

Note: To scan projects in languages other than Java or to scan multiple projects at the same time,
use the advanced analysis (see "Running an Advanced Analysis" below).

To scan a project:

1. Open the project in the Java perspective.

2. Inthe Package Explorer or Project Explorer view, right-click the project, and then select Analyze
Project.

After the scan finishes, the results are loaded into and displayed in the Fortify Audit perspective.
Scanning Individual Files and Packages

You can also scan individual files and packages.

Note: Fortify does not recommend this scan method, because analysis results are more accurate
when an entire project is scanned together.

To scan individual files or packages:

1. Open the project in the Java perspective.

2. Inthe Package Explorer view, right-click the file or package to scan, and then select Analyze
Project Component.

Running an Advanced Analysis

Use the advanced analysis to locally scan Eclipse projects that have source code in multiple directories,
special translation or build conditions, or that have files that you want to exclude from the project. With
advanced analysis, you can scan Java projects, JavaScript projects, PHP projects, C/C++ projects, and all
other types of projects that you can create in Eclipse.

Note: The Eclipse Complete Plugin filters out unsupported files within the selected source code
directories.

To perform an advanced analysis:

1. From Eclipse, select one or more projects.
2. Select Fortify > Advanced Analysis.
The Advanced Static Analysis wizard opens.
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= Advanced Static Analysis

Configure Translation

Specify translation options for each project.

Build ID: I 912828497

[] Enable Translation
[] Deselect All a X

v [A1= eightball_basic
[m] # Scanning Resources
[m] ® Classpath
[m] ® Sourcepath
(W] 5} Settings
v Al javel3
[m] ® Scanning Resources
[m] ® Classpath
[m] @ Sourcepath
[m]izi Settings

< Back MNext = Scan Cancel

The selected Eclipse projects to be scanned are listed in the left pane.
3. Inthe Build ID box, type the build ID.

If you selected only one project for the advanced analysis, the first root directory is the default
build ID. Otherwise, the wizard creates a unique number for the Build ID, which you can change.

4. To disable translation, clear the Enable Translation check box.

For example, if the security content has changed but the source code has not, you might want to
disable the franslate phase so that the project is scanned without retranslating.

Note: Selection of the Enable Translation option directs the wizard to perform the Micro
Focus Fortify Static Code Analyzer clean phase for the build ID in addition to the source code
translation. During the clean phase, Fortify Static Code Analyzer removes temporary files from
previous translation of the project. If franslation is disabled, the clean phase is also not
performed.

5. To add additional Eclipse projects for analysis, click Add Project “ above the Eclipse projects list
on the left.

The wizard automatically includes all supported files in the translation as determined by the project
type. For Java projects, the wizard uses Eclipse logic to resolve source paths. For non-Java projects,
the wizard includes all files under the project root.
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o Scanning Resources—Source files for tfranslation.

Make sure only the files or directories that you want to translate are selected. To add additional

files for translation, click Add Files — .

o Classpath—(Java projects only) The classpath to use for the Java source code. Include all
JAR dependencies normally used to build the project.

Make sure to select only the files or directories that you want to translate. To add additional files

for translation, click Add Folders —! . To add JAR files, click Add JAR =

o Sourcepath—(Java projects only) Folders that contain source code of dependent projects.

To add additional files for translation, click Add Folders O,

6. Click Settings for each Eclipse project to specify additional translation options.

Note: The translation setting options available depend on the Eclipse project type. The

following image shows the options for a Java project.

= Advanced Static Analysis

Configure Translation

Build ID: | 912828497
[] Enable Translation
[] Deselect All g ¥

v [ 1= eightball_basic
[m] ® Scanning Resources
[m] ® Classpath
W] # Sourcepath
[w] =} Settings
v 1= javal3
[m] ® Scanning Resources
[w] # Classpath
[m] @ Sourcepath
[W] () Settings

Specify translation options for each project.

O b
javall Settings
JDE version: |13
SOL Type: v
Additional Translation Arguments:
< Back Mext > Scan Cancel

a. Fromthe JDK version list, select the Java version of the code in the project.

b. By default, Micro Focus Fortify Static Code Analyzer treats SQL files as though they use the
T-SQL procedural language on Windows systems and PL/SQL on other platforms. To specify
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the SQL type, from the SQL Type list, select TSQL or PLSQL.
¢. Specify any additional translation options in the Additional Translation Arguments box.

For information about the available command-line options, see the Micro Focus Fortify Static
Code Analyzer User Guide.

7. Click Next to configure the scan options.

== Advanced Static Analysis

Configure Scan

Specify required rulepacks and scan options.

Build ID: | 912828497 [ Enable Scan
Scan Options

Output file: C:\FortifyScans\912828497_scan.fpd I T

Secure Coding Rulepacks
» [] Installed Fortify Security Cos

[] Installed Custom Security C []Enable quick scan mode

[[]Merge with previous scan

Browse

Sourceanalyzer Memory:

I 14456 / 16063 MB

Additional 5can Arguments:

a. (Optional) To skip the scan phase, clear the Enable Scan check box.

For example, to offload the scan phase to a different machine, skip the scan phase, use the
command line to create a mobile build session (MBS) file, and import the MBS to the scan
machine. See the Micro Focus Fortify Static Code Analyzer User Guide for instructions on how
use mobile build sessions.

b. To specify a different output file path than the default, in the Output file box, type the path
and file name for the FPR file that Fortify Static Code Analyzer is to generate.

c. To perform a quick scan, select the Enable Quick Scan Mode check box.

For information about quick scans, see "About Quick Scan Mode" on page 23.
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d. To merge these results with a previous scan, select the Merge with previous scan check box,
and then click Browse fo navigate to and select the previous FPR file.

e. (Optional) To specify the amount of memory Fortify Static Code Analyzer uses for scanning,
adjust the slider to the amount of memory as needed.

Note: The Fortify Plugin for Eclipse displays the amount of memory specified for Fortify
Static Code Analyzer followed by the amount of memory on your system.

f. (Optional) Specify any additional scan options in the Additional Scan Arguments box.

For information about the available command-line scan options, see the Micro Focus Fortify
Static Code Analyzer User Guide.

8. (Optional) To scan the code with a custom selection of Rulepacks, do the following:

a. Inthe Secure Coding Rulepacks list in the left pane, expand the Installed Fortify Security
Content node and display the installed Rulepacks.

b. Inthe Installed Fortify Security Content list, clear the check boxes that correspond to any
Rulepacks you want fo disable for the scan.

Note: For instructions on how to add custom security content, see "Importing Custom
Security Content" on page 22.

Q. Click Next.

The Preview SCA Commands page displays a preview of the Fortify Static Code Analyzer
commands to be used for the analysis.

10. (Optional) On the Preview SCA Commands page, review and modify the Fortify Static Code
Analyzer translation and scan commands.
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11. Click Next to proceed to the Audit guide page.

== Advanced 5tatic Analysis

Audit Guide

Filter reported issues based on a set of security-related questions,

How concerned about security are you?

(®) Show me all issues that may have security implications.
() Show me likely problems.

() Show me only remotely exploitable issues.

I am concerned about attacks that can originate from remaote and local attackers.
This program might be influenced by data sources that have not been verified for
data integrity

Are you concerned about code quality in addition to security?
(®) Show me all code quality issues.

() Show me quality issues that may result in program instability.
(C) Mo, | don't want to see code quality issues.

Iam concerned about issues that may impact stability or make the codebase
maore difficult to maintain.

Is this a Java EE Web application?

(®) Yes
I Mo

Does this program run with escalated privileges (such as administrator account, root
user, account with access to sensitive data, etc.)?

(®) Yes
Mo

Mext = Scan Cancel

12. (Optional) Select your scan settings, and then click Scan.

The scan starts and progress information is displayed throughout the process. If Fortify Static Code
Analyzer encounters any problems scanning the source code, a warning is displayed.

After the scan is completed, the analysis results are displayed in the Fortify Audit perspective.

Rescanning Projects

By default, when you rescan a project from Eclipse, the scan merges results from the previous scan with
the results from the new scan. This enables you to see specifically which issues have been fixed and
which issues were intfroduced since the earlier scan. You can enable or disable the merging of scan
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results. If you disable merging analysis results, then the existing analysis results file is overwritten with
the new analysis results.

Disabling Merging Scan Results for all Projects

To disable merging the results of the next scan you run with results from the previous scan as the
default for all projects:

Select Fortify > Options.

In the left pane, select Default Project Configuration.

Select the Advanced Analysis Options tab.

Under Local Scan Options section, clear the Merge with previous scan check box.
Click OK.

ua N E

Note: You can override this merging option for a specific project by configuring project properties.
For more information, see "Disabling Merging Scan Results for a Specific Project" below.

You can specify whether the results are merged with the previous scan results on a per-scan bases using
an advanced scan (see "Running an Advanced Analysis" on page 28).

Disabling Merging Scan Results for a Specific Project

You can override merging for a specific project.

To disable Fortify Plugins for Eclipse from merging scan results for a specific project:

From the Java perspective, right-click a project name, and then select Properties.
In the left pane, select Fortify Project Properties.

Select the Enable Project Specific Settings check box.

Select the Advanced Analysis Options fab.

Under Local Scan Options, clear the Merge with previous scan check box.

S R S

Click Apply and Close.

About Scanning with Fortify ScanCentral SAST

This topic describes the requirements for using Micro Focus Fortify ScanCentral SAST to analyze your
code and to upload the analysis results to Micro Focus Fortify Software Security Center. For
instructions about how to configure the Fortify ScanCentral SAST options, see "Configuring Fortify
ScanCentral SAST Options" on page 36.

With Eclipse Complete Plugin, you can either:

o Perform the entire analysis (translation and scan) with Fortify ScanCentral SAST.

o Perform the translation locally and then automatically upload the translated project to Fortify
ScanCentral SAST for the scan phase.
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You must translate the project locally if it uses a language that Fortify ScanCentral SAST does not
support for remote translation (see Micro Focus Fortify Software System Requirements).

Make sure that the Fortify Software Security Content version on the local system is the same as the
version on the Fortify ScanCentral sensor. Fortify strongly recommends that you periodically update
the security content. For information about how to update the security content locally, see "Updating
Security Content" on page 21. Use the fortifyupdate ufility to update security content on the
ScanCentral sensor (see the Micro Focus Fortify Static Code Analyzer User Guide).

To analyze your code with Fortify ScanCentral SAST, you need the following:

o A properly configured Fortify ScanCentral SAST installation. For more information, see the Micro
Focus Fortify ScanCentral SAST Installation, Configuration, and Usage Guide.

o To connect to Fortify ScanCentral SAST, you need either:
e A ScanCentral Controller URL

Important! If the ScanCentral Controller uses an SSL connection from an internal certificate
authority or a self-signed certificate, you must add the certificate to the Java Keystore for

Fortify Static Code Analyzer (in <sca_install dir>/jre/lib/security/cacerts)and
for Eclipse. For more information, see the Micro Focus Fortify ScanCentral SAST Installation,

Configuration, and Usage Guide.

o A Fortify Software Security Center URL and an authentication token of type ToolsConnectToken

To configure the Fortify Software Security Center URL, see "Configuring a Connection to Fortify
Software Security Center" on page 94. For instructions on how to create an authentication token,
see the Micro Focus Fortify Software Security Center User Guide.

Important! If the Fortify Software Security Center or the ScanCentral Controller uses an SSL
connection from an internal certificate authority or a self-signed certificate, you must add the

certificate to the Java Keystore for Fortify Static Code Analyzer (in <sca_install

dir>/jre/lib/security/cacerts)and for Eclipse. For more information, see the Micro
Focus Fortify Software Security Center User Guide.

To send the analysis results to a Fortify Software Security Center server, you need the following:

o A Fortify Software Security Center URL or a ScanCenftral Controller that is integrated with a Fortify
Software Security Center server.

Note: Fortify recommends that the Fortify Software Security Center URL configured in the
Server Configuration options is the same as the Fortify Software Security Center server
integrated with the ScanCentral Controller.

o A Fortify Software Security Center authentication token of type ToolsConnectToken

For instructions on how to create an authentication token, see the Micro Focus Fortify Software
Security Center User Guide.

o An application version that exists in Fortify Software Security Center

o Permission to access the application version where you want to upload analysis results

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 35 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

Configuring Fortify ScanCentral SAST Options

This section describes how to configure the default Micro Focus Fortify ScanCentral SAST options to
use when you submit project for analysis. You can specify the translation type (local or remote), the
SCA ftranslation and scan options, the sensor pool selection, and whether to upload analysis results to
Micro Focus Fortify Software Security Center.

To configure the Fortify ScanCentral SAST options:

1. Select Fortify > Options.
2. In the left pane, select ScanCentral SAST Configuration.
3. Select Enable ScanCentral SAST Upload.

ScanCentral SAST Configuration

Server Configuration Configuration
Bugtracker Proxy Configuration ] Enable ScanCentral SAST Upload

Security Content Management {®) Use Controller URL () Get Controller URL From SSC | Test Connection

Audit Configuration
Controller URL: |

Default Project Configuration
ScanCentral SAST Configuratic Advanced Scan Options
Token: [ |

[[] Send Scan Results to S5C

Default Translation Type:

®) Local
() Remote

Sensor Pool:

(@) Use Default
(O Select Before Upload

Motification Email:

4, To specify how to connect to Fortify ScanCentral SAST, do one of the following:

o Select Use Controller URL, and then in the Controller URL box, type the URL for the
ScanCentral Confroller.

Example: https://<controller_host>:<port>/scancentral-ctrl

Tip: Click Test Controller Connection to confirm that the URL is valid, and the Controller
is accessible.
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o Select Get Controller URL from SSC, and then in the Token box, paste the decoded token
value for an authentication token of type ToolsConnectToken.

Make sure that you have the Fortify Software Security Center URL that is associated with the
ScanCentral Conftroller provided in the Server Configuration options (see "Configuring a
Connection to Fortify Software Security Center" on page 94).

Tip: Click Test SSC Connection to confirm that the URL and token is valid, and the server is
accessible.

5. To upload the analysis results to Fortify Software Security Center, select the Send Scan Results to
SSC check box.

If you have not already specified a Fortify Software Security Center authentication token, do the
following:

¢ Inthe Token box, paste the decoded token value for an authentication token of type
ToolsConnectToken.

Note: If you connect to Fortify ScanCentral SAST using a Conftroller URL, analysis results are
uploaded to the Fortify Software Security Center server specifically integrated with the
ScanCentral Controller.

6. Under Default Translation Type, specify where to run the translation phase of the analysis by
selecting one of the following:

o Local—Run the franslation phase on the local system and the scan phase with Fortify
ScanCentral SAST.
o Remote—Run the entire analysis with Fortify ScanCentral SAST.
7. Under Sensor Pool, specify whether to use the default sensor pool or to be provided a list of
sensor pools to choose from when you initiate a Fortify ScanCentral SAST scan.
8. (Optional) In the Notification Email box, type an email address for job status notification.

9. (Optional) To specify Fortify Static Code Analyzer command-line options for the translation or
scan phase (or to specify whether to scan resources in dependent projects):

a. Click Advanced Scan Options.
The Default Project Configuration page opens.
b. Select the Advanced Analysis Options tab.

c. Select the Use additional SCA Options check box and type Fortify Static Code Analyzer
command-line options for the franslation or scan phase. For detailed information about the
available Fortify Static Code Analyzer options and the proper syntax, see the Micro Focus
Fortify Static Code Analyzer User Guide.

d. Click OK.
10. Click OK to save your configuration.
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Scanning Projects with ScanCentral SAST

Before you can scan your project with Fortify ScanCentral SAST, you must configure the Fortify
ScanCentral SAST analysis options as described in "Configuring Fortify ScanCentral SAST Options" on
page 36.

To scan a project with Fortify ScanCentral SAST:
Open the project in the Java perspective.

In the Package Explorer or Project Explorer view, select the project.

Select Fortify > Analyze Project with ScanCentral.

C A

If prompted, select the application version where you want to upload the analysis results, and then
click OK.

5. If prompted, select a sensor pool, and then click OK.

Note: The following dialog box contains example sensor pool names.

= Select Sensor Pool

Default Pool
Complex
Large
Small-Med
Team&BC
TeamX¥Z

To view the analysis results, you can either:

o Copy the provided job token and use it in the Fortify ScanCentral SAST command-line interface to
check the status and retrieve the analysis results (see the Micro Focus Fortify ScanCentral
SAST Installation, Configuration, and Usage Guide). You can then open the analysis results in Eclipse
(see "Opening an Audit Project" on page 98).

Tip: If you need to retrieve the job token, you can find it in the Fortify ScanCentral SAST log file.
The default log file locations are listed in "Locating Log Files" on page 118.

o |f you uploaded the analysis results to Fortify Software Security Center, you can check the status of
the job (and view the results) on the Fortify Software Security Center server. After the scan is
complete, you can open the results in Eclipse (see "Using the Eclipse Remediation Plugin" on
page 119).
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About Viewing Analysis Results

The Fortify Audit perspective displays four audit-focused views.

After the scan is completed (or, after you open an existing audit project), summary analysis results are
displayed in the Static Analysis Results view and in the Project Summary view of the Fortify Audit
perspective. The Analysis Trace and Issue Auditing views are open, but do not contain any
information until you select an issue from the Static Analysis Results view.
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View/Tab More Information

Static Analysis Results (top left) = "Statfic Analysis Results View" below

Project Summary (top center) "Project Summary View" on page 45
Source Code (top center) Source Code Tab

Analysis Trace (bottom left) "Analysis Trace View" on page 51
Issue Auditing (bottom center) "Issue Auditing View" on page 53

You can also open audit-related views in other perspectives, such as the Java perspective or the C/C++
perspective, and rearrange the views. You might decide to use the audit views only and stay within a
customized development perspective.

Static Analysis Results View
The Static Analysis Results view lists the issues detected in the application and provides several ways
to group them. The view contains the Filter Set list, folders (tabs), the Group By list, the My Issues

check box, and a search box.

Note: In this view, you can right-click an issue and select Issue Attributes to see all the attributes
associated with the issue such as Analysis tag, analyzer that detected the issue, severity, and more.
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[G] static Analysis Results &2 ¥ =8

Filter Set: |Quick View v [ My Issues
-265|D30|D0|Dn| |I295|

Critical (265)

Group By: |Category e -

Command Injection - [0 / 3]

Cross-Site Scripting: Persistent - [0 / 38]

Cross-5Site Scripting: Reflected - [0/ 70]

Dynamic Code Evaluation: Code Injection - [0/ 1]
Key Management: Hardcoded Encryption Key - [0/ 3]
Open Redirect - [0 / 5]

Password Management: Hardcoded Password - [0 / 16]
Path Manipulation - [0 / 5]

Privacy Violation - [0 / 75]

SQL Injection - [0/ 43]

Weak Encryption - [0 / 4]

XML External Entity Injection - [0 / 1]

XPath Injection - [0/ 1]

< >
(o § Advanced...
Filter Sets

The selected filter set controls which issues are listed in the Static Analysis Results view. The filter set
determines the number and types of containers (folders) that are shown and how and where to display
issues. The default filter sets sort the issues by severity into the Critical, High, Medium, Low, and All
folders.

Because filter sets are saved to audit project files, each audit project can have unique filter sets.
The plugin provides the following filter sets for new projects:

¢ Quick View: This is the default initial filter set for new projects. The Quick View filter set provides a
view only of issues in the Critical folder (these have a potentially high impact and a high likelihood of
occurring) and the High folder (these have a potentially high impact and a low likelihood of
occurring). The Quick View filter set provides a useful first look at results that enables you to quickly
address the most pressing issues.

« Security Auditor View: This is the default filter set for projects scanned in earlier product versions.
This view shows all security issues detected. The Security Auditor View filter contains no visibility
filters, so all issues are shown.
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For instructions on how to create custom filter sets, see "Configuring Custom Filter Sets and Filters" on
page 102.

If you open an FPR file that contains no custom filtertemplate.xml file or if you open an FVDL file
orawebinspect.xml file, the audit project opens with the Quick View filter set selected.

Specifying the Default Filter Set

You can change the initial filter set to use for new or opened projects. You can also disable the default
filter set so that the Eclipse Complete Plugin uses the filter set last enabled in the issue template to
display analysis results for new projects.

To select the filter set for new or opened projects:

1. Select Fortify > Options.

2. Inthe left pane, select Audit Configuration, and then select the Configuration tab on the right.

3. Under Audit Project Load Mode, leave the Default Filter Set check box selected.
If you clear the check box, the default filter is loaded. For newly-opened projects, the default filter
for FPRs that have no embedded template or the default filter from the embedded template is the
Security Auditor View filter sef.

4. From the list to the right of the Default Filter Set check box, select the filter set to use to display
analysis results for new projects.

5. Click OK.

Folders (Tabs)

The color-coded Critical, High, Medium, Low, and All tabs on the Static Analysis Results view are
called folders. You can customize the folders and their settings. The number of folders, names, colors,
and the issue list can vary between filter sets and projects.

Note: In the Eclipse Complete Plugin, the term folder does not refer to the folder icons in the issues
list.

Within each color-coded folder, issues are grouped into subfolders. At the end of each folder name,
enclosed in brackets, is the number of audited issues and the fotal number of issues in the folder. For
example, Command Injection - [1 / 3] indicates that one out of three issues categorized as Command
Injection has been audited.

Group By: | Category w

W Command Injection - [1/ 3]
& Execjava:103 (Command Injection)
@ Execjava:292 (Command Injection)
@ WSDL5canning.java:143 (Command Injection)
Cross-5ite Scripting: Persistent - [0/ 38]

The filter set you select from the Filter Set list determines which folders are visible in the Static Analysis
Results view. The following folders are visible while the Security Auditor View filter set is selected:
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o The Critical folder contains issues that have a high impact and a high likelihood of occurring. Issues
at this risk level are easy to discover and to exploit and represent the highest security risk to a
program. Remediate critical issues immediately.

Example: SQL Injection

« The High folder contains issues that have a high impact and a low likelihood of occurring.
High-priority issues are often difficult to discover and exploit, but can result in much asset damage.
They represent a significant security risk to a program. Remediate these issues with the next patch
release.

Example: Password Management: Hardcoded Password

o The Medium folder contains issues that a have low impact and a high likelihood of exploitation.
Medium-priority issues are easy to discover and exploit but often result in little asset damage. These
issues represent a moderate security risk to a program. Remediate these issues as fime permits.

Example: ASP.NET Misconfiguration: Missing Error Handling

o The Low folder contains issues that have a low impact and a low likelihood of exploitation. Remediate
these issues as time permits. Low-priority issues are potentially difficult to discover and to exploit and
typically result in little asset damage. These issues represent a minor security risk to the program.

Example: Poor Error Handling: Empty Catch Block
e The All folder contains the issues from all the other folders.

Anissueis listed in a folder if the folder filter conditions match the issue attributes. Each filter set has a
default folder, indicated by (default) next to the folder name. If an issue does not match any of the
folder filters, the issue is listed in the default folder.

Filter Set: |Security Auditor View L] My Issues

W 265 os |11 | Dooo ... [B1274]

' Low (default) (900) ]

Group By: |Category e W
Access Control: Database - [0 f 23] ~

You can create your own folders as you need them. For example, you might group all hot issues for a
project into a Hot folder and group all warning issues for the same project into a Warning folder. For
instructions on how to create your own folders, see "Creating a Folder" on page 108.

Each folder contains a list of all the issues with attributes that match the folder filter conditions. One
folder in each filter set is the default folder, indicated by (default) in the folder name.

Note: To show or hide suppressed, hidden, and removed issues, set the user interface preferences
from the Options dialog box (see "Customizing the Static Analysis Results View" on page 70).

Group By List

The Group By list options sort the issues into sub folders. The option you select is applied to all visible
folders. To list all issues in the folder without any grouping, select <none>.
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To customize the existing groups, you can specify which attributes to sort by, add or remove the
attributes to create sub-groupings, and add your own grouping options.

The Group By settings apply to the application instance. You can apply the Group By option to any
project opened with that instance of the application.

For more information, see "Grouping Issues" on page 61.

Specifying the Default Issue Grouping

You can change the initial Group By setting to use for new or opened projects.

To select the default Group By setting:

1. Select Fortify > Options.
2. Inthe left pane, select Audit Configuration, and then select the Configuration tab on the right.
3. Under Audit Project Load Mode, select the Default Issue Grouping check box.

If you clear the check box, the default Group By setting is set to Category.

4, From the list to the right of the Default Issue Grouping check box, select the grouping you want
to use to sort issues.

5. Click OK.

Sorting Issues

There are several different ways to sort the issues in the Static Analysis Results View. Select a sort
option from the Sort list. The following table describes the sort options.

Sort Method Icons Description

Alphabetical Al Sorts the groups and the issues within the groups in alphabetical
order.
z) Sorts the groups and the issues within the groups in reverse-

alphabetical order

Group size = Sorts the groups by the number of contained issues from largest to
smallest
21 Sorts the groups by the number of contained issues from smallest
to largest.

Last modified Sorts the groups and issues in groups by the date last modified by
date Micro Focus Fortify Static Code Analyzer or the audit/comment
date from newest to oldest

Sorts the groups and issues in groups by the date last modified by

ok
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Sort Method Icons Description
Fortify Static Code Analyzer or the audit/comment date from

oldest o newest

Search Box

The search box enables you to limit the issues displayed in the folder and to search for specific issues.
For detailed information about how fo use the search box, see "Searching for Issues" on page 74.

Project Summary View

The Project Summary view provides detailed information about the scan.

[] Project Summary 53 = 0

Summary | Certification | Build Information | Analysis Information

Build ID: WebGoat5.0 Scanned: 193 files, 8,903 LOC (Executable
Scan Date: Sep 26 2019 Total Issues: 1,279
Warnings: [MNone Certification: Results Certification Va

All Issues by Folder

I Medium (11)
High (99)
I Citical (265)

To open this view, select Fortify > Show Project Summary.

Summary Tab

The Summary tab shows high-level information about the project. For more information, see "Viewing
Summary Graph Information" on the next page.

Certification Tab

The Certification tab displays the result certification status and indicates whether the code analysis for
a scan was complete. Results certification is a check to ensure that the analysis results have not been
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altered after Micro Focus Fortify Static Code Analyzer produced them. Results certification shows
specificinformation about the scanned code, including:
e FPR certification

o Certification details such as the results and rules signatures

Build Information Tab

The Build Information tab displays the following information:
o Build details such as the build ID, number of files scanned, source last-modified date, and the date of
the scan, which might be different than the date the files were translated

e Executable lines of code (Executable LOC) scanned

Note: Ignore this metric. It is no longer used.

e Totallines of code (Total LOC) scanned

This metric provides the approximate number of lines that contain code constructs (comments are
excluded). The process to determine the LOC varies for the different supported languages.

o List of files scanned with file sizes and timestamps
o Libraries referenced for the scan

o Javaclasspath used for the translation

Analysis Information Tab

The Analysis Information tab shows the Fortify Static Code Analyzer version that performed the
scan, details about the computer on which the scan was run, the user who started the scan, scan date,
and the time required to scan the code.

The Analysis Information tab includes the following subtabs:

o Security Content—Lists information about the Rulepacks used to scan the source code
« Properties—Displays the Fortify Static Code Analyzer properties files settings
« Commandline Arguments—Displays the command-line options used to analyze the project

Viewing Summary Graph Information

The summary graph displayed in the Project Summary view provides multiple perspectives on the sets
of issues, grouped by priority (Critical, High, Medium, and Low) uncovered in a scan. You can drill down
in the graph to see detailed information about each issue set, and create various bar charts for issues
based on a selected issue attribute.

The following procedure uses the WebGoat sample Java application to demonstrate how to access
information about sets of issues graphically depicted in the summary graph.
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To access details about issue sets in an audit project:

1. Scan your project source code or open an existing audit project.

After the results are loaded, the Project Summary view displays the Summary tab, which includes
the summary graph. The summary graph initially displays issues sorted into the Critical, High,

Medium, and Low folders.

Note: If you change the selection in the Filter Set list (Static Analysis Results), the summary

graph changes accordingly.

E Project Summary &3

Summary | Certification | Build Information | Analysis Information

= O

Build ID:  WebGoat3.0
Scan Date: 5Sep 26, 2019

Warnings: PMNone

All Issues by Folder

Medium (11)
High {99}

Critical (265}

Total Issues: 1,278

Certification:

LOC (Executable)

Results Certification Valid
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2. To see a different view of the high priority issues, click the High bar.

[E] Project Summary 52 = O

Summary | Certification | Build Information | Analysis Information

Build 1D: WebGoat3.0 Scanned: 193 files, 8,905 LOC (Executable)

Scan Date: Sep 26, 2015 Total Issues: 1275

Warnings: [MNone Certification: Reszults Certification Valid
Issues in High View By: | Analysis i

Not an Issue (2)
Bad Practice (2)
Exploitable (8)

Suspicious (8)

By default, the graph displays high priority issues based on the analysis attribute (assigned analysis
values).

Note: The example here shows information for analysis results that have been partially
audited. If these results were from a fresh, unaudited scan, no analysis information would be
available. The graph would just display a single bar that represents all (unaudited) high priority
issues.
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3. To view the high priority issues based on a different attribute, select an item from the View By list.

[Z] Project Summary EE} = B

Surmmary Certificaticun| Build Information | Analysis Information

Build ID: WebGoat5.0 Scanned: 193 files, 8,905 LOC (Executable)
Scan Date: Sep 26, 2019 Total Issues: 1,279
Warnings: MNone Certification: FResults Certification Valid
Issues in High View By: Category v
~

Password Management: Empty Password (2)

Race Condition: Static Database Connection (2)

Header Manipulation {2)
JZ2EE Bad Practices: Non-Serializable Object Stored in Session (3)
Privacy Violation: Autocomplete (3)

Privacy Violation (3)
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4, On the Issues in High bar graph, select a bar for a category that contains multiple issues.

[Z] Project Summary 52 = O

Summmary | Certification | Build Information | Analysis Information

Build ID: WebGoat3.0 Scanned: 193 files, 8,905 LOC (Executable)
Scan Date: Sep 26, 2019 Total Issues: 1279
Warnings: PMone Certification: Results Certification Valid

Issues in High View By: | Analysis e

Restricted by: category:Null Dereference

Suspicious (3)
Bad Practice (5)

In the example shown here, the Null Dereference bar is selected. You can see that, of eight issues,
three are marked as Suspicious and five are marked as Bad Practice.

5. To synchronize the issues list with the displayed graphical view, click Sync Issue List with Graph.

|| g Issues in High

Restricted by: Sync Issue List with Graph i
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The issues list in the Static Analysis Results view now reflects the selections in the summary
graph.

[E] Static Analysis Results &3 = = B
Filter Set: | Security Auditor View [ My Issues
265 | Moo | 111|904 ... | 1279 |
High (8 of 99) |

Group By: | Analysis w |§‘L -

Bad Practice - [3/ 5]
A Suspicious - [3/ 3]

< >

32 ¥ category:Mull Dereference ¥ | Advanced...
6. Toreturn fo the previous view in the summary graph, click Back.

E @ &Y Issues in High

20 by: category:Null Dereference

Graph.

Q] Issues in High

ference

Return to Folder Graph

Analysis Trace View

When you select an issue, the Analysis Trace view displays the relevant trace output. This is a set of
program points that show how the analyzer found the issue. For dataflow and control flow issues, the
set is presented in the order executed. For dataflow issues, this trace view presents the path that the
tainted data follows from the source function to the sink function.

The Rule ID at the bottom of this pane provides the primary rule that found the issue.
Note: The Eclipse Remediation Plugin does not display the Rule ID.

For example, when you select an issue that is related to potentially tainted dataflow, the Analysis
Trace view shows the direction the dataflow moves in this section of the source code.
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The Analysis Trace view uses the icons listed in the following table to show how the dataflow moves in
this section of the source code or execution order.

Icon Description

= Data is assigned to a field or variable

<> Information is read from a source external to the code such as an HTML form or a URL
)] Datais assighed to a globally scoped field or variable

E31 A comparison is made

() The function call receives tainted data

&) The function call returns tainted data

) Passthrough, tainted data passes from one parameter to another in a function call
& An alias is created for a memory location

&0 Data is read from a variable

&0 Data is read from a global variable

Py Tainted data is refurned from a function

& A pointer is created

e A pointer is dereferenced

- The scope of a variable ends

5 The execution jumps

A A branch is taken in the code execution

M A branch is not taken in the code execution

Generic

@
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Icon Description

Aol A runtime source, sink, or validation step

+ Taint change

The Analysis Trace view can display inductions. Inductions provide supporting evidence for their
parent nodes. Inductions consist of a text node, displayed in italics as a child of the trace node, and an
induction trace, displayed as a child of the text node (a box surrounds the induction trace). The italics
and the box distinguish the induction from a standard subtrace.

Issue Auditing View

The Issue Auditing view at the bottom center of the Fortify Audit perspective provides detailed
information about each issue on the tabs described in the following topics.

Note: If any of the tabs are not visible, select Window > Show View to open them.

Audit 2 Details Recommendations History Diagram Screenshots Filters Warnings = 0
Issue: Execjava:103 (Command Injection a v

Command Injection (Input Validation
User: and Representation, Data Flow)
Analysis: W method execOptions( in Erec.___a-.fa.

execy) with a com

Edit..

More Information..

Recommendations..

Audit Tab

The Audit tab displays information about the selected issue and enables auditors to add an audit
evaluation, comments, and custom tag values. The following table describes the tab elements.

Element Description
Issue Displays the issue location, including the file name and line number.
User Displays the name of the user assigned to the issue if the results were

uploaded to Micro Focus Fortify Software Security Center and a user was
assigned in Fortify Software Security Cenfter.
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Element Description

Analysis List of values that the auditor can use to assess the issue. Valid values for
Analysis are Not an Issue, Reliability Issue, Bad Practice, Suspicious, and
Exploitable.

<custom_tags> Displays any custom tags if defined for the audit project.

If the audit results have been submitted to Audit Assistant in Fortify
Software Security Center, then in addition to any other custom tags, the
tab displays the following tags:

o AA_Prediction—Exploitability level that Audit Assistant assigned to
the issue. You cannot modify this tag value.

o AA_Confidence—Confidence level from Audit Assistant for the
accuracy of its AA_Prediction value. This is a percentage, expressed in
values that range from 0.000 to 1.000. For example, a value of 0.982
indicates a confidence level of 98.2 percent. You cannot modify this tag
value.

¢ AA_Training—Whether to include or exclude the issue from Audit
Assistant training. You can modify this value.

For more information about Audit Assistant, see the Micro Focus Fortify
Software Security Center User Guide.

Suppresses the issue.

* Suppress
Unsuppress FJnsuppresses the issue (only VISIb.|e if the issue is su‘ppressed). Suppressed

issues are hidden by default. To display suppressed issues, select Options
> Show Suppressed Issues.

* il Bug Provides access to a supported bug tracker.

Comment Appends additional information about the issue to the comment field.

Rule Information Shows information, such as the category and kingdom that describes the
issue.

More Information Opens the Details tab.

Recommendations Opens the Recommendations tab.

Show merge conflicts Shows merge conflicts in the Comments box that might exist after a merge
of audit projects. This check box is available only if merge conflicts exist.
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Details Tab

The Details tab provides an abstract of the issue, a detailed explanation, and examples. The following
table describes the tab elements.

Element

Abstract/Custom
Abstract

Explanation/Custom
Explanation

Instance ID

Priority Metadata
Values

Legacy Priority
Metadata Values

Remediation Effort

Description

Summary description of the issue, including custom abstracts that your
organization defined.

Description of the conditions in which this type of issue occurs. This
includes a discussion of the vulnerability, the constructs typically associated
with it, how an attacker can exploit it, and the potential consequences of an
attack. This element also provides custom explanations that your
organization defined.

Unique identifier for the issue.

Includes impact and likelihood.

Includes severity and confidence.

The relative amount of effort required to fix and verify an issue.

Weblnspect Agent Details Tab

The Weblnspect Agent Details tab displays the following information about runtime issues that
Fortify Weblnspect Agent discovered. The following table describes the tab elements.

Element Description

Request Shows the path of the request, the referrer address, and the method.

Stack Trace Shows the order of methods called during execution and line number information.
Blue, clickable code links are only displayed for Fortify Static Code Analyzer-scanned

code.
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Recommendations Tab

The Recommendations tab displays suggestions and examples of how to secure the vulnerability or
remedy the bad practice. The following table lists the elements on the tab.

Element Description

Recommendations/Custom Recommendations for this type of issue, including examples, as well
Recommendations as custom recommendations that your organization defined.

Tips/Custom Tips Tips for this type of issue, including any custom tips that your
organization defined.

References/Custom Reference information, including any custom reference that your
References organization defined.
History Tab

The History tab displays a complete list of audit actions, including details such as the time and date, and
the name of the user who modified the issue.

Diagram Tab

The Diagram tab displays a graphical representation of the node execution order, call depth, and
expression type of the issue selected in the Static Analysis Results view. This tab displays information
that is relevant to the rule type. The vertical axis represents the execution order.

Audit Details Recommendations History Diagram 2

CSRF java:193 (Cross-Site Scripting: Persist

| CSRF makelist |

(#l) executeQuery(return) 189) src
C}: Assignment to results 18__51)
(20) getString(this - return) 192)
C}: Assignment to link 18__553
{2{) addElement(0) 199 sink

For dataflow issues, the trace starts with the first function to call the taint source, then traces the calls to
the source (blue node) and ends the trace at the sink (red node). In the diagram, the source (src) and
sink nodes are also labeled. A red X on a vertical axis indicates that the called function finished
executing.

The horizontal axis shows the call depth. A line shows the direction that control is passed. If control
passes with tainted data through a variable, then the line is red. If control passes without tainted data,
the line is black.
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The icons used for the expression type of each node in the diagram are the same icons used in the
Analysis Trace view. To view the icons and the descriptions, see "Analysis Trace View" on page 51.

Filters Tab

The Filters tab displays all the filters in the selected filter set.

Audit Details Recommendations History Diagram Screenshots Filters &2 Warnings = 0

Quick View Filters: (applied in the order shown) Show Matching lssues
v = Visibility Filters Disab
If impact is not in range [2.5, 5.0] Then hide issue —
If likelihood is not in range (1.0, 5.0] Then hide issue
w Folder Filters
B If [fortify priority order] contains critical Then set folder to Critical
B If [fortify priority order] contains high Then set folder to High Delete Filter
3 If [fortify priority order] contains medium Then set folder to Medium
3 If [fortify priority order] contains low Then set folder to Low

Create New Filter...

The following table describes the options to create new filters.
Option Description

Filters Displays a list of the visibility and folder filters configured in the selected filter set.

« Visibility filters show or hide issues

o Folder filters sort the issues into the folder tabs in the Static Analysis Results view

Right-click a filter to show issues that match the filter or to enable, disable, copy, or
delete it.

If Displays the filters conditions.

The first list displays a list of issue attributes, the second list specifies how to match the
attribute, and third is the value the filter matches.

Note: This option is visible when you create a new filter or edit an existing filter. In
this case, a dialog box displays the If section.

Then Indicates the filter type, where Hide Issue is a visibility filter and Set Folder to is a folder
filter.

Note: This option is visible when you create a new filter or edit an existing filter. In
this case, a dialog box displays the Then section. For more information, see "Creating
a Filter from the Issue Auditing View" on page 104.
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Warnings Tab

The Warnings tab lists any warnings that occurred during the analysis.

Warnings & o B
Translation and analysis warnings. If the list is not empty you should check how you configured SCA
type filter text
Code Message
~ 12019

12011 ® The following references to Java functions could not be resolved, These functions may be part of classes

A common source of warnings are missing references. To resolve this type of warning, make sure that
the reference files are either within the project directory structure or in a location known to Micro Focus
Fortify Static Code Analyzer. The scan can also issue a warning if a class has no functional content. In
this case, the warning is not an issue because an empty class has no impact on a scan.

The following table describes the Warnings tab options.

Task Procedure

See the complete message thatis | e« Double-click the message.
fruncated on the tab.

& Warning Details

Warning Code: g | &

Message:

The following references to Java functions could not ~
be resolved. These functions may be part of classes

that could not be found, or there may be a type

error at the call site of the given function relative to

the function declaration. Please ensure the Java

W
| oK
Copy a warning message to the ¢ Right-click a message, and then select Copy.
clipboard.
Save a warning message to a file. 1. Right-click a message, and then select Export Entry.

2. Type a name for the file, and then click Save.

The file includes the audit project name, FPR file location, the
warning code, and the warning message.
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Task Procedure

Save all the warning messages to =
1. Click Export Warnings * .

a file.
2. Type a name for the file, and then click Save.
The file includes the project name, FPR file location, the warning
codes, and the warning messages.
Search the warning message Type the search text in the filter text box.
Modify the text message at the 1. Edit the <fortify working_
top of the fab. dir>/config/tools/warnings-view.properties file

where <fortify working_dir>is:
¢ Windows:

C:\Users\<username>\AppData\Local\Fortify
« Non-windows: /home/<username>/ .fortify

2. Edit the text following message= to the text you want to
display in the Warnings tab.

Close and reopen the Warnings tab to see the updated text.

Viewing Issues in the Source Code

The source code editor shows the section of code related to the issue selected in the Static Analysis
Results view. Each fime you select an issue in the Static Analysis Results view, a tab opensin the
source code editor and displays the code associated with the selected issue.

If multiple nodes represent an issue in the Analysis Trace view, the source code editor shows the code
associated with the selected node.

Working with Issues

This section provides information about how to use the Eclipse Complete Plugin to review issues.

Filtering Issues with Audit Guide

You can use the Audit Guide Wizard to filter vulnerability issues in your audit project based on a set of
security-related questions.
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To use the Audit Guide:

1. Select Fortify > Audit Guide.

B Audit Guide Wizard

How concerned about security are you?

(®) Show me all issues that may have security implications.

() Show me likely problems.

() Show me only remotely exploitable issues.

I am concerned about aftacks that can originate from remote and local attackers.
This program mright be influenced by data sources that have not been verified for
data integrity.

Are you concerned about code quality in addition to security?

(®) Show me all code quality issues.

() Show me quality issues that may result in program instability.

(_)No, | don't want to see code quality issues.

Iam concerned about issues that may impact stability or make the codebase
maore difficult to maintain.

Is this a Java EE Web application?

(®) Yes
I Ne

Does this program run with escalated privileges (such as administrator account, root
user, account with access to sensitive data, etc.)?

(®) Yes
Mo

Advanced Mode... Cancel

2. Make your selections for the types of issues you want to display.

3. To use the advanced filter options, click Advanced Mode.
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The Advanced Audit Guide dialog box opens.

B Advanced Audst Guide...

Select the types of issues that you want to hide
Audit Guide Filters: Code Quality Issues
I [ Code Cuality Fssues | Hide code quality issues

[] Database Inputs

] Serialization lssues

[] Denial of Service Issues

[] File Systerm Inputs

[ Denial of Service Attacks

[ Heap Inspection Attacks

] Environment Variable Inputs

] Property File Inputs

[] Taint from Command-Line Arguments
] J2EE Bad Practices

M1 tnermrictant leanlarsantatinm e
L b
This Audit Guide Filter will hide 122 issues.
Filters: Issue Matches
If kingdom contains code quality Then hide issue 122
Wizard Mode... Cancel

a. Inthe Audit Guide Filters list, select the types of issues you want to filter out and ignore.

As you select items in the Audit Guide Filters list, the Audit Guide Wizard also displays the
filter details for the selected filter type in the Filters table, including the number of issues that
match each filter.

b. To see a description of an issue type, click its name in the Audit Guide Filters list.
The Audit Guide Wizard displays a description to the right of the list.
4. Click OK to apply your filter selections.

Grouping Issues

The items visible in the navigation tree vary depending on the selected grouping option in the Static
Analysis Results view. The value you select from the Group By list sorts issues in all visible folders into
subfolders.

To list all issues in a folder without any grouping, select <none>.

You can view issues with any of the Group By options, and you can create and edit customized groups.
The Group By options enable you to group and view the issues in different ways. In practice, you will
probably switch frequently between different groupings. The following table lists descriptions of the
standard Group By options.
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Option Description

Analysis Groups issues by the audit analysis, such as Suspicious, Exploitable, and
Not an Issue.

Analysis Type Groups issues by analyzer product, such as SCA, WEBINSPECT, and

SECURITYSCOPE (Weblnspect Agen®).

Analyzer Groups issues by analyzer group, such as Configuration, Control Flow,
Data Flow, Pentest, Semantic, and Structural.

App Defender Protected Groups issues by whether Application Defender can protect the
vulnerability category.

Category Groups issues by vulnerability category. This is the default setting.
Category Analyzer A custom group that groups issues by category and then by analyzer.
File Name Groups issues by file name.

Fortify Priority Order Groups issues as Critical, High, Medium, and Low based on the

analyzer's combined values of impact and likelihood.
Kingdom Groups issues by the Seven Pernicious Kingdoms classification.

Manual Groups issues by whether they were manually created by penetration
test tools, and not automatically produced by a web crawler such as
Fortify Weblnspect.

New Issue Shows which issues are new since the last scan. For example, if you run
a new scan, any issues that are new display in the tree under the Issue
New group and the others are displayed in the Issue Updated group.
Issues not found in the latest scan are displayed in the Issue Removed

group.

<metadata_listname> Groups issues by the alternative metadata external list names (for
example, OWASP Top 10 <year>, CWE, PCI SSF <version>, STIG
<version>, and others).

Package Groups issues by package or namespace. Does not appear for projects
to which this option does not apply, such as C projects.

Priority by Category A custom group that groups issues by Fortify Priority Order and then
by category.
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Option Description

Sink Groups issues that share the same dataflow sink function.

Source Groups issues that share the same dataflow source functions.

Source File Type Groups issues by source file types that Micro Focus Fortify Static Code

Analyzer recognizes.

Note: Issues in files with different file extensions that are the same
source file type are grouped together (for example, issues in files

with the extensions: html, htm, and xhtml are grouped under

htmb.
Taint Flag Groups issues by the taint flags that they contain.
<none> Displays a flat view without any grouping.
Edit Select Edit to create a custom Group By option.

The following table describes additional grouping options that are available when you create a custom
Group By option (see "Creating a Custom Group By Option" below).

Option Description

Issue State Groups audited issues by whether the issue is an open issue or not an issue
based on the level of analysis set for the primary tag. Values equivalent to
suspicious and exploitable are considered open issue states.

Primary Context Groups issues where the primary location or sink node function call occurs in
the same code context.

Source Context Groups dataflow issues that have the source function call contained in the same
code context.

Status Groups issues by the audit status (Reviewed, Unreviewed, or Under Review)

URL Groups dynamic issues by the request URL.
Creating a Custom Group By Option

You can create a custom Group By option that groups issues in a hierarchical format in sequential order
based on specific attributes.
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To create a new grouping option:

1. Inthe Group By list, select Edit.
The Edit Custom Groupings dialog box opens.

B Edit Custom Groupings...

Custom Group Mame: | Category Analyzer

Grouping Types: Grouping Crder:

Analysis A Category
Analysis Type Analyzer
App Defender Protected
CWE

CWE Top 25 2019
DISACCI2

FIshA >
File Mame
Fortify Priority Order <
GDOPR

lssue State

Kingdom

MISRA C 2012

MISRA C++ 2008

Manual

MIST SP 200-53 Rev.d v

Cancel

2. To create a custom group by option, do the following:

a. Select Create New from the Custom Group Name list.

b. Inthe Enter Value dialog box, type a name for the new custom group.

¢. Click OK.

3. Fromthe Grouping Types list on the left, select a grouping type, and then click the right arrow to
move the option to the Grouping Order column.

For example, selecting Category and then Analyzer creates a list that has top-level nodes that
contain the category of the issue, such as SQL Injection, with the issues grouped below by analyzer

(such as Dataflow or Semantic).

W 50L Injection - [0/ &2] ~
W Data Flow - [0/ 43]
@ BackDoorsjava:106 (S0L Injection
& BackDoorsjavai113 (SOL Injection

N TIPTT Fp— -_h-'_'qu_“" -

. Ll v ol]ELun
@ ViewProfilejava:178 (S0L Injectior
&) Ws5gllnjection.java:240 (Shared 5i
Semantic - [0/ 19]

4, Repeat step 3 to select additional grouping types.
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5. To change the order of the grouping types:

a. Inthe Grouping Order list, select the grouping type that you want to move up or down in the
grouping order.

b. Right-click the selected grouping type, and then select Move Up or Move Down.

6. To delete a custom grouping, click Delete * .

Evaluating Issues

To evaluate and assign audit values to an issue or group of issues:

1. Select the issue or group of issues in the Static Analysis Results view, see "About Viewing
Analysis Results" on page 39.

2. Inthelssue Auditing view, read the abstract on the Audit tab. This abstract provides high-level
information about the issue, such as the analyzer that found the issue.

For example, Command Injection (Input Validation and Representation,

dataflow) indicates that this issue that the Dataflow Analyzer detected, is a Command Injection
issue in the Input Validation and Representation kingdom.

3. Click the More Information link to get more details about the issue.
4, On the Audit tab, specify an Analysis value for the issue to represent your evaluation.

5. Specify values for any custom tags as your organization requires.

For text-type custom tags, you can click Edit Text |~/ fo see and edit long text strings. This tag
accepts up to 500 characters (HTML/XML tags and newlines are not allowed).

For date-type custom tags, you can click = to select a date from a calendar.

6. If the audit results have been submitted to Audit Assistant in Micro Focus Fortify Software
Security Center, then you can specify whether to include or exclude the issue from Audit Assistant
training from the AA_Training list.

Note: If you select a different value for Analysis than the AA_Prediction value set by Audit
Assistant, and you select Include from the AA_Training list, then the next time the data is
submitted to Audit Assistant, it updates the information used to predict whether an issue
represents a true vulnerability. For more information about Audit Assistant, see the Micro
Focus Fortify Software Security Center User Guide.

7. (Optional) In the Comments box, type comments relevant to the issue and your evaluation.

Performing Quick Audits

As you audit issues, you can use a keyboard combination to assign an analysis value to multiple selected
issues.
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To assign an analysis value to multiple issues simultaneously:

1. Inthe Static Analysis Results view, select the issues that you want to assign the same analysis
value.

2. Press Ctrl + Shift + A (Cmd + Shift + A on macOS).

The Eclipse Complete Plugin displays a window in the lower-right corner to indicate you are in
Quick Audit Issue mode.

Note: Do not hold this keyboard combination in the next step.
3. Press one of the following number keys:
e Toassign Not an Issue, press 1
e To assign Reliability Issue, press 2
e To assign Bad Practice, press 3
e To assign Suspicious, press &
e To assign Exploitable, press 5

o To assign a custom analysis value configured for your organization, press the number that
corresponds to its position in the Analysis list on the Audit tab.

Shortcuts are provided for only the first ten values in the Analysis list. (To assign the tenth value in the
list, you press Ctrl + Shift + A, and then press 0). If no value is listed for the key you press, no value is
assigned.

Performing Quick Audits for Custom Tags

Instead of using the Analysis tag for quick audits, you can use a custom tag your organization has
created.

To use a custom tag for quick audits:

1. Select Fortify > Options.

2. In the left pane, select Audit Configuration, and then select the Configuration tab on the right.

3. Under Quick Audit Preference, from the Attribute to use for quick action audit list, select a
custom tag.

Note: Only list-type tags are available to use for quick audits.

If no custom tags have been created, the list only includes the Analysis tag.
4. Click OK.

The keyboard shortcut functions just as it does for the Analysis tag values. Shortcuts are provided for
only the first ten values in the list of custom tag values. (To assign the tenth value in the list, you press
Ctrl + Shift + A, and then press 0). If there is no value in the list for the key you press, no value is
assigned.

For information about custom tags, see "Configuring Custom Tags for Auditing" on page 111.
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Adding Screen Captures to Issues

You can attach a screen shot or other image to an issue. Attached images are stored in the FPR file and
are accessible from Micro Focus Fortify Software Security Center. The following image formats are
supported:

o GIF

e JPG

e PNG

To add an image to an issue:

Select the issue.

In the Issue Auditing pane, select the Screenshots tab.

Click Add.

In the New Screenshot dialog box, click Browse to find and select the image file.
(Optional) In the Description box, type a description.

Click Add.

SO A N o

Viewing Images
After you add an image to an issue, the image is displayed on the right side of the Screenshots tab.

To view a full-size version of an image added to an issue:

1. Inthelssue Auditing pane, select the Screenshots tab.
2. From the list of screenshots, click the image you want view.

3. Click Preview.

Creating Issues for Undetected Vulnerabilities

Add undetected issues that you want to identify as issues to the issues list. You can audit manually
configured issues on the Audit tab, just as you do other issues.

To create an issue:

1. Select the object in the line of code in the source code tab.

2. Right-click the line that contains the issue, and then select Create New Issue.
The Create New Issue dialog box opens.

3. Select the issue category, and then click OK.

The issues list displays the file name and source code line number for the new issue next to a blue icon.

The rule information in the Audit tab includes Custom Issue. You can edit the issue to include audit
information, just as you can other issues.
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Suppressing Issues

You can suppress issues that are either fixed or that you do not plan to fix.
To suppress an issue, do one of the following:
« In the Static Analysis Results view, select the issue, and then, on the Audit tab in the Issue

Auditing view, click Suppress *
« In the Static Analysis Results view, right-click the issue, and then click Suppress Issue.

Note: You can select and suppress multiple issues at the same time.

Suppression marks the issue and all future discoveries of this issue as suppressed. As such, it is a semi-
permanent marking of a vulnerability.

To review results that have been suppressed, select Show Suppressed Issues from the View menu on
the Static Analysis Results toolbar.

[E] static Analysis Results &2 v =g
Show Suppressed Issues h

Show Removed ssues
=265 ‘ —— ‘ Lo ‘ Ho | ‘ 295 | Show Hidden Issues

Critical (265) Show Only My Issues

~  Use Short Filenames E
Group By: |Category 3 ‘/

Filter Set: | Quick View b ]

Show Category of Issue

Command Injection - [0/ 3] Warnings:

To unsuppress an issue, first display the suppressed issues and then do one of the following:
o Inthe Static Analysis Results view, select the suppressed issue, and then, on the Audit tab in the

Issue Auditing view, click Unsuppress
¢ Right-click the issue in the Static Analysis Results view, and then select Unsuppress Issue.

Note: You can select and unsuppress multiple issues at the same time.

Creating Attribute Summary Tables for Multiple Issues

You can create a summary table of attributes (for example, in spreadsheet software such as Excel or
Google Sheets) for any number of issues that you select from the Static Analysis Results view. You
specify the format options, select the issues, and then paste the comma-delimited datainto a
spreadsheet program fo create the summary table.

The table can contain an attributes column followed by a single values column for every issue selected
or, the table can display one row per attribute and its corresponding values. Alternatively, you can
specify a customized table layout for the values that you copy to your spreadsheet program.
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To create a spreadsheet table that contains an attributes column followed by a single values column for
each selected issue:

C A

Select Fortify > Options.
In the left pane, select Audit Configuration, and then select the Configuration tab.
Under Multiple Issues Copy Format, leave the [h] List issues in columns option selected.

Select the attributes you want to include from the Include immutable attributes, Include
mutable attributes, and Include custom tags check boxes.

5. Click OK.

6. Fromthe Static Analysis Results view, use the Ctrl or Shift key and select all the issues you want

7.
8.

to include in a table.
With the issues selected, press Ctrl + Alt + Shift + C.

Start the spreadsheet software, and then paste (Ctrl + V) the copied data into a single column.

To create a spreadsheet table that displays one row per attribute and its values:

E A o

Select Fortify > Options.
In the left pane, select Audit Configuration, and then select the Configuration tab.
Under Multiple Issues Copy Format, select the [v] List issues in rows option.

Select the attributes you want to include from the Include immutable attributes, Include
mutable attributes, and Include custom tags check boxes.

5. Click OK.

6. From the Static Analysis Results view, use the Ctrl or Shift key and select all the issues you want

7.
8.

to include in a table.
With the issues selected, press Ctrl + Alt + Shift + C.

Start the spreadsheet software, and then paste (Ctrl + V) the copied data info a single column.

To create a customized table layout for the values that you copy to a spreadsheet program:

F NP

Select Fortify > Options.
In the left pane, select Audit Configuration, and then select the Configuration fab.
Under Multiple Issues Copy Format, select the Format manually option.

In the Attribute value format box, use the string described in the following table to specify the
data layout, format, and separators for the values you want to copy.

String Function

[h] Columnar format - Attributes are inserted in a single column and the spreadsheet
table expands to the right (horizontally) with a new column added for each issue
copied in.

[v] Row format - Attributes are inserted in a single row (table header) and a new row

populated with values is added for each issue added (table expands vertically).
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String Function

%S Textual data (you can use the complete java.util.Formatter syntax). See the

java.util.Formatter documentation at
https://docs.oracle.com/en/java/index.html.

Separator symbol - To import the copied value info most spreadsheet programs, you
;ortab | must specify the separator to use in the format field.

v Apply the preceding format string to all elements in the selection. This is only valid if

the format specification starts with [h] or [v].

%n Line separator (platform independent), whether it is the last value for anissuein a

row formatted table [ v] or it is the last value of a given attribute in a columnar
formatted table [h].

For example, to specify which specific attributes you want to copy with the row format ([ v]), use

[v]%file$s,%category$s,%fortify priority order$s%n. This copies the three attributes
for each selected issue.

5. To see the result of your syntax, look under Result example.
The example shown changes as you change the value in the Attribute Value Format box.

Note: Examples are not available for complex manual formats.

6. Select the attributes you want to include from the Include immutable attributes, Include
mutable attributes, and Include custom tags check boxes.

7. Click OK.

Customizing the Static Analysis Results View

You can customize the Static Analysis Results view to determine which issues it displays.

To change the Static Analysis Results view:

1. Select Fortify > Options.

2. Inthe left pane, select Audit Configuration.
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B Options

Server Configuration
Bugtracker Proxy Configuratio
Security Content Managemnent
Audit Configuration

Default Project Configuration
ScanCentral SAST Configuratic

Audit Configuration

Appearance | Configuration
Issue Rendering Preferences
[] Show Suppressed lssues
[]5how Removed lssues
[]Show Hidden lszues
Collapse Issues
Uze Short File Mames
Show Category of lssue
[ ] Show Qnly My lssues
Right Justify "All' Folder
L] Display Mame in Folder Tahs

Issue Surmrmary
Show Abstract
Show Comments

Project Sumrmary
(] Show 'All' Folder in Project Summary Graph

History

[]Include Comments

Reset Perspective...

Cancel

3. To change your preferences on the Appearance tab, select or clear the check boxes described in

the following table.

Preference
Show Suppressed Issues

Show Removed Issues

Show Hidden Issues

Description

Displays all suppressed issues (disabled by default).

Displays all issues detected in the previous scan, but are no longer
evident in the new Static Analysis Results view. When multiple
scans are run on a project over time, vulnerabilities are often
remediated or become obsolete. Micro Focus Fortify Static Code
Analyzer marks these vulnerabilities as Removed Issues.

Displays all hidden issues.
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Preference Description

Collapse Issues Shows similar issues based on certain attributes under a shared
parent node in the Static Analysis Results view.

Use Short File Names References the issues in the Static Analysis Results view by file
name only, instead of by relative path.

Show Category of Issue Displays the category of an issue in the Static Analysis Results
view and the Audit tab.
Show Only My Issues Displays only issues assigned to you.

Right justify ‘All' Folder Displays the All folder aligned on the right.

Display Name in Folder Displays the name text in the folder tabs.
Tabs

Show Abstract Displays the abstract text in the Audit tab.
Show Comments Displays comments in the Audit tab.

Show ‘All' Folder in Project = Displays another bar in the chart on the Summary tab in the
Summary Graph Project Summary view.

Include Comments Displays the history items for comments on the History tab.

Note: To restore the default settings at any time, click Reset Perspective.

4, To save your preferences, click OK.

Submitting an Issue as a Bug

You can submit issues to your bug tracker application if you have integrated the application with Eclipse
or if you are using Micro Focus Fortify Software Security Center.

To submit an issue as a bug:

1. Select the issue in the Static Analysis Results view, and then, on the Audit tab, click File Bug *.

When you submit a bug for first time, the Configure Bugtracker Integration dialog box opens. (For
information about configuring the plugin with bug tracker applications, see "Integrating with a Bug
Tracker Application" on the next page.) Select a bug tracker application, and then click OK.

2. Specify all required values and review the issue description. Depending on the integration and your
bug tracker application, the values include items such as the bug fracker application URL, product
name, severity level, summary, and version.
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3. If the connection to the bug tracker requires a proxy, select the Use proxy check box.

With this option selected, the Fortify Plugins for Eclipse use the proxy settings specified for bug
trackers. For more information, see "Configuring Proxy Settings for Bug Tracker Integration" on
the next page.

4. Click Submit.
You must already be logged in before you can file a bug through the user interface for bug tracker
applications that require a logon. The issue is submitted as a bug in the bug tracker application.

If you use Fortify Software Security Center, you can submit an issue as a bug using a bug tracker
application configured through Fortify Software Security Center.

To submit an issue as a bug through Fortify Software Security Center:

1. Select theissue in the Static Analysis Results view, and then, on the Audit tab, click the File Bug
icon.

When you submit a bug for first time, the Configure Bugtracker Integration dialog box opens.
Select Fortify Software Security Center, and then click OK.

2. Specify the values if changes are needed and review the issue description. Depending on the
integration and your bug tracker application, the values include items such as the bug tracker
application URL, product name, severity level, summary, and version.

3. Click Submit.

If your bug tracker application requires you to log in, you must do so before you can file a bug through
that interface.

Integrating with a Bug Tracker Application

The Eclipse Complete Plugin provides a plugin interface to integrate with bug tracker applications. This
enables you to file bugs directly from the Eclipse Complete Plugin. For a list of supported bug ftracker
applications, see the Micro Focus Fortify Software System Requirements document.

To select the plugin to use:
1. Open an audit project.
2. Select Fortify > Configure Bugtracker.

Note: For Jira bug tracker integration, you must restart Eclipse after you change the proxy settings.

If installed with Fortify SCA and Applications, example source code for bug tracker plugins is available in

<sca_install _dir>/Samples/advanced/BugTrackerPlugin<bugtracker>, where <bugtracker>
is the name of the bug tracker application.

To write your own plugin, see the instructions in the README text file, which is in each bug tracker
directory. Information about the APl is included in the JavaDoc located in <sca_install
dir>/Samples/advanced/JavaDoc/public-api/index.html.

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 73 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

Configuring Proxy Settings for Bug Tracker Integration

If the bug fracker you use requires a proxy connection, specify the proxy settings. When you submit an
issue as a bug, select the Use proxy check box. The Eclipse Complete Plugin provides the proxy
settings to the bug tracker plugin.

To configure proxy settings for bug tracker integration:

1. Select Fortify > Options.
2. Inthe left pane, select Bugtracker Proxy Configuration.

B Options

Bugtracker Proxy Configuration

Server Configuration Proxy Configuration
Bugtracker Proxy Configuratio HTTP Proxy
Security Content Management Proxy Server: | | Port: I:I

Audit Configuration Usernarme: | |

Default Project Configuration
ScanCentral SAST Configuratic| ~ Password: | |

HTTPS Proxy

Proxy Server: | | Port: |:|

Username: | |

Password: | |

Apply | | Clear

3. Under HTTP Proxy, specify the proxy server, port number, and optionally credentials for proxy
authentication.

4, If the connection uses HTTPS requests, then provide the proxy settings under HTTPS Proxy.
5. Click OK to save your changes.

Searching for Issues

You can use the search box below the issues list to search for issues. After you type a search term, the
label next to the folder name changes to indicate the number of issues that match the search as a subset
of the total.

To indicate the type of comparison to perform, wrap search terms with delimiters. The following table
describes the syntax to use for the search string.
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Comparison Description

contains Searches for a term without any special qualifying delimiters

equals Searches for an exact match when the term is wrapped in quotation marks (" ")

regex Searches for values that match a Java-style regular expression delimited by a
forward slash (/)

Example: /eas.+?/

Note: This comparison is not available in the remediation plugins.

number range = Searches for a range of numbers using the standard mathematical interval notation
of parentheses and/or brackets to indicate whether the endpoints are excluded or
included respectively

Example: (2,4] indicates greater than two and less than or equal to four

not equal Excludes issues specified by the string when you precede the string with the

exclamation character (!)

Example: file: !Main. java returns all issues that are notin Main. java

You can further qualify search terms with modifiers. The syntax for using a modifier is
modifier:<search_term>.

A search string can contain multiple modifiers and search terms. If you specify more than one modifier,
the search returns only issues that match all the modified search terms. For example,

file:ApplicationContext.java category:SQL Injection returnsonly SQL injection issues
foundin ApplicationContext.java.

If you use the same modifier more than once in a search string, then the search terms qualified by those
modifiers are treated as an OR comparison. For example, file:ApplicationContext.java

category:SQL Injection category:Cross-Site Scriptingreturns SQL injection issuesand
cross-site scripting issues found in ApplicationContext. java.

For complex searches, you can also insert the AND or the OR keyword between your search queries.
Note that AND and OR operations have the same priority in searches.

For more information, see "Search Modifiers" below.

Search Modifiers

You can use a search modifier to specify to which attribute of an issue the search term applies.

Note: To use a modifier that contains a space in the name, such as the name of the custom tag, you
must enclose the modifier in brackets. For example, to search for issues that are new, type [issue
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age]:new.

A search that is not qualified by a modifier tries to match the search string on the following attributes:
kingdom, primary rule id, analyzer, filename, severity, class name, function name, instance id, package,
confidence, type, subtype, taint flags, category, sink, and source.

o To apply the search to all modifiers, type a string such as control flow. This searches all the
modifiers and returns any result that contains the specified string.

o To apply the search to a specific modifier, type the modifier name and the string as follows:
analyzer:control flow. Thisreturns all results whose analyzeris control flow.

The following table describes the search modifiers. A few modifiers have a shortened modifier name
indicated in parentheses. You can use either modifier string.

Search Modifier

accuracy

analysis

[analysis type]

analyzer

[app defender protected]
(def)

[attack payload]

[attack type]

audience

audited

Micro Focus Fortify Plugins for Eclipse (21.1.0)

Description

Searches for issues based on the accuracy value specified (0.1
through 5.0).

Searches for issues that have the specified audit analysis value

such as exploitable,not an issue, andso on.

Searches for issues by analyzer product such as SCA and
WEBINSPECT.

Searches the issues for the specified analyzer such as control
flow, data flow, structural, andso on.

Searches for issues based on whether Application Defender can

protect the vulnerability category (protected or not
protected).

Searches for issues that contain the search term in the part of
the request that caused the vulnerability for penetration test
results.

Searches for issues based on the type of penetration test attack
conducted (URL, parameter, header, or cookie).

Searches for issues based on intended audience such as dev,
targeted, medium, broad, and so on.

Searches the issues to find true if the primary tag is set and

false if the primary tag is not set. The default primary tag is
the Analysis fag.
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Search Modifier Description

body Searches for issues that contain the search termin the HTTP
message body in penetration test results, which is all the data
that is transmitted immediately following the headers.

bug Searches for issues that contain the search termin the
information for the filed bug.

Note: This information is discarded each time you restart

Eclipse.

category(cat) Searches for the specified category or category substring.
class Searches for issues based on the specified class name.
comments Searches for issues that contain the search termin the
(comment, com) comments that have been submitted on the issue.
commentuser Searches for issues with comments from a specified user.
confidence (con) Searches for issues that have the specified confidence value

(legacy metadata).
cookies Searches for issues that contain the search termin the cookie

from the HTTP query for penetration test results.

correlated Searches for issues based on whether the issues are correlated
with another analyzer.

[correlation group] Searches for issues based on whether the issues are in the same
correlation group.

<custom_tagname> Searches for issues based on the value of the specified custom
tag.

You can search a list-type custom tag using a range of values.
The values of a list-type custom tag are an enumerated list
where the first value is O, the second is 1, and so on. You can use
the search syntax for a range of numbers to search for ranges
of list-type custom tag values. For example, analysis:[0,2]
returns the issues that have the values of the first three Analysis
values, O, 1, and 2 (Not an Issue, Reliability Issue, and Bad
Practice).
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Search Modifier Description

To search a date-type custom tag, specify the date in the
format: yyyy-mm-dd.

dynamic Searches for issues that have the specified dynamic hot spot
ranking value.

file Searches for issues where the primary location or sink node
function call occurs in the specified file.

filetype Searches for issues based on the file type such as asp, csharp,
java, jsp, xml, and so on.

[fortify priority order] Searches for issues that have a priority level that matches the
specified priority determined by Micro Focus Fortify Static Code

Analyzer. Valid values are critical, high, medium, and low,
based on the expected impact and likelihood of exploitation.

The impact value indicates the potential damage that might
result if an issue is successfully exploited. The likelihood value is
a combination of confidence, accuracy of the rule, and
probability that an attacker can exploit the issue.

headers Searches for issues that contain the search term in the request
header for penetration test results.

historyuser Searches for issues that have audit data modified by the
specified user.

[http version] Searches for issues based on the specified HTTP version such
asHTTP/1.1.
impact Searches for issues based on the impact value specified (0.1

through 5.0).

[instance id] Searches for an issue based on the specified instance ID.

[issue age] Searches for the issue age, which is new, updated,
reintroduced, or removed.

[issue state] Searches for audited issues based on whether the issue is an
open issue or not an issue (determined by the level of analysis
set for the primary tag).
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Search Modifier Description
kingdom Searches for all issues in the specified kingdom.
likelihood Searches for issues based on the specified likelihood value (0.1

through 5.0).

line Searches for issues on the primary location line number. For
dataflow issues, the value is the sink line number. Also see
"sourceline" on page 81.

manual Searches for issues based on whether they were manually
created by penetration test tools, and not automatically
produced by a web crawler such as Fortify Weblnspect.

[mapped category] Searches for issues based on the specified category that is
mapped across the various analyzers (SCA, Weblnspect, and
Weblnspect Agent).

maxconf Searches for all issues that have a confidence value equal to or
less than the number specified as the search term.

maxVirtConf Searches for dataflow issues that have a virtual call confidence
value equal to or less than the number specified as the search
term.

<metadata Listname> Searches for issues based on the value of the specified

metadata external list. Metadata external lists include [ owasp
top ten <year>], [cwe top 25 <version>],
[pci ssf <version>], [stig <version>], and others.

method Searches for issues based on the method, such as GET, POST,
DELETE, and so on.

minconf Searches for all issues that have a confidence value equal to or
greater than the number specified as the search term.

min_virtual call_ Searches for dataflow issues that have a virtual call confidence
confidence (virtconf, value equal to or greater than the number specified as the
minVirtConf) search term.

Searches for issues where the primary location occurs in the
package

specified package or namespace. For dataflow issues, the
primary location is the sink function.
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Search Modifier

parameters

primary

[primary context]

primaryrule (rule)

probability

[remediation effort]

[request id]

response

ruleid

[secondary requests]

severity (sev)

sink

source

[source context]

Micro Focus Fortify Plugins for Eclipse (21.1.0)

Description

Searches for issues that contain the search termin the HTTP
query parameters.

Searches for issues that have the specified primary tag value. By
default, the primary tag is the Analysis tag.

Searches for issues where the primary location or sink node
function call occurs in the specified code context. Also see sink
and [source context].

Searches for all issues related to the specified sink rule.

Searches for issues based on the probability value specified (1.0
through 5.0).

Searches for issues based on the remediation effort value
specified. The valid values are whole numbers from 1.0 to 12.0.

This attribute is not currently used.

Searches for issues that contain the search termin the response
from the protocol used in penetration test results.

Searches for all issues reported by the specified rule IDs used to
generate the issue source, sink and all passthroughs.

This attribute is not currently used.

Searches for issues based on the specified severity value (legacy
metadata).

Searches for issues that have the specified sink function name.
Also see [primary context].

Searches for dataflow issues that have the specified source
function name. Also see [source confext].

Searches for dataflow issues that have the source function call
contained in the specified code context.

Also see source and [primary context].
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Search Modifier

sourcefile

sourceline

status

suppressed
taint

trace

tracenode

tracenodeAllPaths

trigger

url

user

Micro Focus Fortify Plugins for Eclipse (21.1.0)

Description

Searches for dataflow issues with the source function call that
the specified file contains.

Also see file.

Searches for dataflow issues having taint source entering the
flow on the specified line. Also see "line" on page 79.

Searches issues that have the status reviewed, not reviewed, or
under review.

Searches for issues based on whether they are suppressed.
Searches for issues that have the specified taint flag.

Searches for issues that have the specified string in the dataflow
trace.

Note: This search modifier is not available in the
remediation plugin.

Enables you to search on the nodes within an issue’s analysis
trace. Each fracenode search value is a concatenation of the
tracenode’s file path, line number, and additional information.

Note: This search modifier is not available in the
remediation plugin.

Searches for the specified value in all the steps of analysis trace.

Note: This search modifier is not available in the
remediation plugin.

Searches for issues that contain the search termin the part of
the response that shows that a vulnerability occurred for
penetration test results.

Searches for issues based on the specified URL.

Searches for issues assigned to the specified user.
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Search Query Examples

The following are search query examples that use search modifiers.

e To search for all privacy violations in file names that contain jsp with getSSN() as a source, type:

category:"privacy violation" source:getssn file:jsp
e To search for all file names that contain com/fortify/awb, type:

file:com/fortify/awb
o To search for all paths that contain traces with mydbcode . sqlcleanse as part of the name, type:

trace:mydbcode.sqlcleanse
e To search for all paths that contain traces with cleanse as part of the name, type:

trace:cleanse
o To search for all issues that contain cleanse as part of any modifier, type:

cleanse
e To search for all suppressed vulnerabilities with asdf in the comments, type:

suppressed:true comments:asdf
o To search for all categories except for SQL Injection, type:

category:!SQL Injection
Performing Simple Searches

To use the search box to perform a simple search, do one of the following:

o Type asearch string in the box and press Enter.

IEE Y category:command injection ¥ Advanced...

e To select a search term you used previously, click the arrow in the search box, and then select a
search term from the list.
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To get assistance to compose the comparison for your search string, do the following:

1. Click your cursor in the search box, and then press Ctrl + Space.

(o ¥ | Advanced...
accura ~
.-’-‘-.ne _q'r [
| analysis
analysis type
analyzer

app defender protected

attack payload

attack type

audience

audited

body W

From the displayed list, double-click an issue attribute to begin your search string.

3. To get assistance to specify the comparison, with your cursor placed after the modifier in the
search box, press Ctrl + Space.

e anal}rsis:l ¥ | Advanced...

.E-.n' contains
c

does not contain
s

iz not

matches regex

does not match regex

4. From the displayed list, double-click the comparison to add to your search string.
5. Type the rest of the search term.
The Static Analysis Results view lists all the issues that match your search string.

The plugin saves all the search terms you type for the current session. To select a search term you used
previously, click the arrow in the search box, and then select a search term. (After you close Eclipse, the
saved search ferms are discarded.)

To create complex search strings can involve several steps. If you type an invalid search string, the
magnifying glass icon in the text field changes to a warning icon to notify you of the error. Click the
warning sign fo view information about the search term error.

The advanced search feature makes it easier to build complex search strings. For a description of this
feature and instructions on how to use it, see "Performing Advanced Searches" below.

Performing Advanced Searches

You can use the advanced search feature to build complex search strings.
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Note: The advanced search feature is not available in the Eclipse Remediation Plugin.
To use the advanced search feature:

1. To theright of the search box, click Advanced.

B Advanced Search

Search Query: & i

Clear Cancel

2. To create your search query:

a. Fromthe list of the left, select the modifier.
b. From the middle list, select the comparison and type.
¢. Fromthe list on the right, select the search term.

The list for the search term includes the known values in the current scan for the specified
attribute. However, you can type any value into this field. To specify an unqualified search term,
select Any Attribute from the bottom of the modifier list.

3. To add another query row, do one of the following:
o To add an AND query row, in the top right corner of the dialog box, click AND ( & ).

e To add an OR query row, in the top right corner of the dialog box, click OR (I ).
4. Add as many query rows as you need for the search.

5. To delete a row, to the right of the row, click Delete [=]. To remove all rows, click Clear.

6. To change a query row condition, double-click the current (underlined) query row operator AND or
OR.

In the following example, you can double-click AND to change the query operator to OR.

AND / OR - v v| =

7. Click Find.

Note: As you build your search string, the Advanced Search dialog box displays any errors in the
status below the search string builder. Find is only enabled after you resolve all errors.
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Generating Reports

The Eclipse Complete Plugin provides a flexible reporting infrastructure based on user-configurable
report tfemplates. Report templates provide several optional sections and subsections that gather and
present specific types of data. The following sections provide information about the default reports and
report templates, instructions on how to modify existing reports, and how to create your own reports.

Generating Legacy Reports

After you select a report template and specify report settings, you generate the report to view the
results. You can save the report results in PDF or XML format.

To run areport:
Select Fortify > Generate Legacy Report.

Select a report template from the Report list.

(Optional) Make changes to the report section settings.

F WD PR

Click Save Report.
The Save Report dialog box opens.

B Save Report

Title: | Fortify Security Report |

Author: | jsmith |

Copyright 2021 Micro Focus or one of its affiliates.
Footnote:

Location: C:EUsers‘ajsr‘nith\Du:ucuments‘aM}rRepnrts\WehGnatS.ﬂ_| I Browse ... |

Format: | PDF Report

Save Cancel

5. Make any necessary changes to the report details, including its location and format.
6. Click Save.
Fortify Plugins for Eclipse generates the report in the format you selected.
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Legacy Report Templates

This section describes how to select and edit a legacy report tfemplate. You can modify legacy report
templates from the Generate Legacy Report dialog box, or you can edit report templates directly in XML
(see "Report Template XML Files" on page 91). If you or another user have edited or created other
default report templates, you might not see the default report templates described in this section.

The legacy report templates include:

« Fortify Developer Workbook—Provides a comprehensive list of all categories of issues found and
multiple examples of each issue. This report also gives a high-level summary of the number of issues
in each category.

« Fortify Scan Summary—Provides high-level information based on the category of issues that Micro
Focus Fortify Static Code Analyzer found as well as a project summary and a detailed project
summary.

o Fortify Security Report—A mid-level report that provides comprehensive information on the
analysis performed and the high-level details of the audit that was performed. It also provides a high-
level description and examples of categories that are of the highest priority.

« OWASP Top Ten <year>—Provides high-level summaries of uncovered vulnerabilities organized
based on the top ten issues that the Open Web Security Project (OWASP) has idenfified.

The following sections describe how to view report templates and customize them to address your
reporting needs.
Selecting Legacy Report Sections

You can choose sections to include in the report.

To select the sections that you wanft o include in a report:

1. Click a section title fo view the contents of the section.
The section details are displayed to the right of the dialog box.
2. Toinclude a section in the report, select the section title check box in the list on the left side.
3. Toremove a section from the report, clear the check box next to the section title.
For instructions on how to edit each section, see "Editing Legacy Report Subsections" on the next page.

Opening Legacy Report Templates
To open a report template:

1. Select Fortify > Generate Legacy Report.
The Generate Report dialog box opens.
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B Generate Report...

Report: Fortify Security Report w Visibility Settings
D Executive Summary
Project Sumrmary [] Issues Overview
Results Qutline This section provides an overview of the issues
3
: : uncovered during analysis. The report covers a
[] Detailed Project Summary g anaty -Port
summary of vulnerability categories discovered by the
Issue Count by Category tool. The auditor should augment this section with
lssue Breakdown by Analysis higher-level conclusions derived from human review of
¥ il 4
[] Mew Issues the application (including architecture reviews, black-
box testing, compliance issues, etc.)
b Edit Text

Issue Surnmary by Fortify Pricrity Order

Select the attributes that the chart will be based on
Fortify Pricrity Order | X (Mumber of |ssues)
Refine Issues in Subsection (1279 |ssues Showing)

| | Advanced...

(® Table () Pie (") Bar

Recemmendations and Conclusions

This section gives some high-level recommendations
on remediating the issues discussed in the Issues
Summary sub section. Recommendations will vary
based on deployment scenarios, risk appetite, and
existing mitigating strategies. The auditor should
supplemnent the Fortify generic recommendations with
specific information that takes into account the
application specific variables,

Save as Mew Template... b Edit Text

Save Settings as Default

Save Report... Cancel

2. Select areport template from the Report list.
The Generate Report dialog box displays the report template settings.

Editing Legacy Report Subsections

When you select a section title, you can edit the contents that display in the report. You can edit text,
add or change text variables, or customize the issues shown in a chart or results list.
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Editing Text Subsections

To edit a text subsection:

1. Select the check box next to the subsection title to include this text in the report.
A description of the text displays below the subsection title.

2. Click Edit Text.
The text box displays the text and variables to include in the report.

3. Edit the text and text variables.

As you edit text subsections, you can insert variables that are defined when you run the report. The
following table describes these variables.

Variable Description

$AUDIT GUIDE_ List of filters created with answers to Audit Guide Wizard questions
SUMMARY$

$CLASSPATH_ JAR files used in the scan, one relative path per line

LISTING$

$COMMANDLINE Complete list of command-line options (same format as project summary)
ARGS$

$FILE_LISTINGS List of files scanned, each file in format <relative file path> # Lines
# kb <timestamp>

$FILTERSET List of filters the current filter set uses
DETAILSS$

$FILTERSET Name of the current filter set

NAME$

$FORTIFY_SCA_ Micro Focus Fortify Static Code Analyzer version
VERSION$

$LIBDIR_ Libdirs specified for the scan, one relative path per line
LISTINGS$

$LOCS$ Total lines of code

$NUMBER_OF _ Total number of files scanned

FILES$

$PROJECT BUILD  Buildlabel of project
LABEL$
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Variable

$PROJECT_NAME$

$PROPERTIES$

$RESULTS
CERTIFICATIONS

$RESULTS
CERTIFICATION
SUMMARY$

$RULEPACKS$

$SCAN_COMPUTER _

I1D$

$SCAN_DATE$
$SCAN_SUMMARY$
$SCAN_TIME$
$SCAN_USER$

$SOURCE_BASE_
PATH$

$TOTAL_
FINDINGS$

$VERSION_LABEL$

$WARNINGS$

$WARNING
SUMMARY$

Description
Build ID

Complete list of properties set for the analysis phase (same format as project
summary)

Complete certification detail with a list of validity on a per file basis (same
format as project summary)

Short description of certification (same format as project summary)

Complete list of Rulepacks used for the analysis (same format as project
summary)

Hostname of machine on which the scan was performed

Date of analysis with the default format style for the locale

Summary of codebase scanned in format # files, # lines of code
Time of analysis phase

Username for the user who performed the scan

Source base path of codebase

Number of issues, not including suppressed and removed issues

Label of the scanned project (available only if the Fortify Static Code

Analyzer -build-1abel option was used in the scan)

Complete list of warnings that occurred

Number of warnings found in scan

Editing Results List Subsections

To edit a result list subsection:

1. Select the check box next to the subsection title to include this text in the report.

A description of the results list displays below the subsection title.
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2. Click the issues list heading to expand the options.
3. Select the aftributes used to group the results list.

If you group by category, the recommendations, abstract, and explanation for the category are also
included in the report. For the list of attributes to group by, see "Grouping Issues" on page 61.

4, (Optional) To refine the issues shown in this subsection with a search query, click Advanced.
For information about the search syntax, see "Searching for Issues" on page 74.
5. Select or clear the Limit number of Issues in each group check box.

6. If you selected the check box, type the number of issues to display per group.

Editing Chart Subsections
To edit a chart subsection:

1. Select the check box next to the subsection ftitle to include this text in the report.
A chart description is displayed below the subsection title.

2. Select the attributes used to group the chart data.
For the list of attributes to group by, see "Grouping Issues" on page 61.

3. (Optional) To refine the issues shown in this subsection with a search query, click Advanced.
For information about the search syntax, see "Searching for Issues" on page 74.

4, Select the chart format (table, pie, or bar).

Saving Legacy Report Templates

You can save the current report settings as a new template that you can select later to run more reports.

To save settings as a report template:

1. Select Fortify > Generate Legacy Report.
The Generate Report dialog box opens.
2. Select the report template from the Report list.
3. Make changes to the report section and subsection settings.
4, Click Save as New Template.

When you select the report template name from the Report list, the report settings are displayed in the
Generate Report dialog box.

Saving Changes to Legacy Report Templates

You can save changes to a report template so that your new settings are displayed as the defaults for
that template.
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To save changes a report template:

1. Select Fortify > Generate Legacy Report.
The Generate Report dialog box opens.
Select the report template to save as the default report template from the Report list.
(Optional) Make changes to the report section and subsection settings.
Click Save Settings as Default.

Report Template XML Files

Report templates are saved as XML files. You can edit the XML files to make changes or to create new
report template files. When you edit the XML files, you can choose the sections and the contents of
each section to include in the report template.

The default location for report template XML files is:

<eclipse_install_dir>/plugins/com.fortify.dev.ide.eclipse_
<version>/Core/config/reports

To customize the logos used in the reports, you can replace header. jpg and footer. jpgin this
directory.

Adding Legacy Report Sections

You can add report sections by editing the XML files. In the structure of the XML, the ReportSection
element defines a new section. It includes a Tit1le element for the section name, and it must include at
least one Subsection element to define the contents of the section in the report. The following XML is
the Results Outline section of the Fortify Security Report:

<ReportSection enabled="true" optionalSubsections="true">
<Title>Results Outline</Title>
<SubSection enabled="true">
<Title>Overall number of results</Title>
<Description>Results count</Description>
<Text>The scan found $TOTAL_FINDINGS$ issues.</Text>
</SubSection>
<SubSection enabled="true">
<Title>Vulnerability Examples by Category</Title>
<Description>Results summary for critical and high priority issues.
Vulnerability examples are provided by category.
</Description>
<Issuelisting limit="1" listing="true">
<Refinement>[fortify priority order]:critical OR
[fortify priority order]:high</Refinement>
<Chart chartType="1list">
<Axis>Category</Axis>
</Chart>
</IssuelListing>
</SubSection>
</ReportSection>
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In the previous example, the Results Outline section contains two subsections. The first subsection
is a text subsection named Overall number of results. The section subsection is a results list
named Vulnerability Examples by Category. A section can contain multiple subsections.

Adding Report Subsections

In the report sections, you can add subsections or edit subsection content. Subsections can generate
text, results lists, or charts.

Adding Text Subsections

In a text subsection, you can include the Title element, the Description element, and the Text
element. In the Text element, you can provide the default content, although you can edit the content
before you generate a report. For a description of the text variables available to use in text subsections,
see "Editing Legacy Report Subsections" on page 87. The following XML is the Overall number of
results subsection in the Results Outline section:

<SubSection enabled="true">
<Title>Overall number of results</Title>
<Description>Results count</Description>
<Text>The scan found $TOTAL_FINDINGS$ issues.</Text>
</SubSection>

In this example, the text subsection is titled Overall number of results. The description text fo
describe the purpose of the textis Results count. The text in the text field that the user can edit
before running a report uses one variable named $TOTAL_FINDINGSS$.
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Adding Results List Subsections

In a results list subsection, you can include the Tit1le element, the Description element, and the
IssuelListing element. In the IssueListing element, you can define the default content for the
limit and set 1isting to true. You caninclude the Refinement element either with or without a
default statement, although you can edit the content before you generate a report. To generate a
results list, the Chart element attribute chartType is set to 1ist. You can also define the Axis
element. The following XML is the Vulnerability Examples by Category subsectionin the
Results Outline section:

<SubSection enabled="true">
<Title>Vulnerability Examples by Category</Title>
<Description>Results summary of the highest severity issues.
Vulnerability examples are provided by category.</Description>
<IssuelListing limit="1" listing="true">
<Refinement>[fortify priority order]:critical OR
[fortify priority order]:high</Refinement>
<Chart chartType="1list">
<Axis>Category</Axis>
</Chart>
</IssuelListing>
</SubSection>

In this example, the results list subsection is titled Vulnerability Examples by Category. The
description text to describe the purpose of the subsection is Results summary of the highest
severity issues. Vulnerability examples are provided by category. This subsection
lists (1isting=true)oneissue (1imit="1") per Category (the Axis element value) where there are
issues that match the statement [ fortify priority order]:critical OR [fortify
priority order]:high (the value of the Refinement element).

Adding Charts Subsections

In a chart subsection, you can include the Title element, the Description element, and the
IssuelListing element.In the IssuelListing element, you can define the default content for the
limit and set 1isting to false. You caninclude the Refinement element either with or without a
default statement, although you can edit the content before generating a report. To generate a pie
chart, the Chart element's attribute chartType is set to pie. The options are table, pie, and bar.
You can change this setting before you generate the report. You can also define the Axis element.
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The following code shows an example of a chart subsection:

<SubSection enabled="true">

<Title>New Issues</Title>
<Description>A list of issues discovered since the previous
analysis.</Description>
<Text>The following issues have been discovered since the
last scan.</Text>
<Issuelisting limit="-1" listing="false">

<Refinement />

<Chart chartType="pie">

<Axis>New Issue</Axis>

</Chart>

</IssuelListing>

</SubSection>

In this subsection, a chart (1imit="-1" listing="false") hasthe title New Issues and a text
section that contains the text The following issues have been discovered since the
last scan. This chartincludes all issues (the Refinement element is empty) and groups the issues on
the value of New Issues (the value of the Axis element). This chart is displayed as a pie chart
(chartType="pie™).

Configuring a Connection to Fortify Software
Security Center

To configure a connection to Micro Focus Fortify Software Security Center, you need the following:

The URL for your Fortify Software Security Center and if necessary, the proxy server and port
number for the connection

If you will connect to Fortify Software Security Center using X.509 SSO, download and deploy the
Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files to the Java JRE used
for Eclipse.

To configure a connection to Fortify Software Security Center:

1. Select Fortify > Options.
2. Inthe left pane, select Server Configuration.
3. Under Software Security Center Configuration, specify the Server URL for your Fortify

Software Security Center

The Fortify Software Security Center URL includes both the port number and the context path
/ssc. Forexample, http://my.domain.com:8080/ssc.

. If required, specify the proxy server, port number, and optionally credentials for proxy

authentication.

. Click OK.
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Logging in to Fortify Software Security Center

The first time you perform an operation that requires a connection to Micro Focus Fortify Software
Security Center such as uploading an audit project or opening a collaborative application, you are
prompted fo log in.

To log in to Fortify Software Security Center:

1. If you have not configured a connection to Fortify Software Security Center, in the SSC URL box,
type the server URL.

2. From the Login Method list, select the login method set up for you on Fortify Software Security
Center.

B Fortify Software Security Center

SSC URL: | http:ffmy.domain.com:B[}B[}fssc |

Login Method: |Username/Password £

Username:; ‘jsmith |

Password: ‘ |

0K Cancel
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3. Depending on the selected login method, do one of the following:

Login Method Procedure
Username/Password Type your Fortify Software Security Center user name and password.
Authentication Token In the Token box, specify the decoded value of a Fortify Software

Security Center authentication token of type ToolsConnectToken.

Note: For instructions about how to create an authentication
token from Fortify Software Security Cenfter, see the Micro
Focus Fortify Software Security Center User Guide.

X.509 SSO a. Click Browse to the right of Certificate.

b. Inthe Browser for Certificate dialog box, locate the p12 package
with the certificate, and then click Open.

c. Type the password if required.

Kerberos SSO Fortify Software Security Center must be configured to use
SPNEGO-based Kerberos authentication.

Note: Support for Kerberos SSO is limited to Windows systems.
4. Click OK to connect to Fortify Software Security Center.

Synchronizing with Fortify Software Security Center

You can automatically upload your changes to an application version on Micro Focus Fortify Software
Security Center each time you load, merge, save, or scan your local project. This automatic
synchronization helps facilitate collaborative auditing, and enables you to synchronize any offline
changes each time you connect to the server.

Note: Automatic synchronization requires that you specify an application version that already
exists in Fortify Software Security Center. If the application version does not exist in Fortify
Software Security Center, you must first create it. For instructions, see the Micro Focus Fortify
Software Security Center User Guide.

To enable or disable synchronization to the server:

Select Fortify > Options.

In the left pane, click Default Project Configuration.

Select the Synchronize Options tab.

To enable synchronization to the server, select Synchronize project with server.

F WD PR
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Scheduling Synchronization

You can customize which action synchronizes your local version of the project with the server. For
example, you can specify that synchronization only occurs when you merge or scan a project.

To customize when synchronization occurs:

Right-click a project.

Select Properties.

Select Fortify Project Properties.

You can schedule synchronization for either the current project or the workspace:

o To schedule synchronization for only the current project, select Enable project specific
settings.

F WD PR

¢ To schedule synchronization for the workspace, click Configure Workspace Settings.

5. Select the Synchronize Options tab.
6. Select the options that you want to exclude from automatic synchronization.
7. Click OK.

Refreshing Permissions from Fortify Software Security Center

The Micro Focus Fortify Software Security Center administrator assigns roles to users that determine
the actions they can performin Fortify Software Security Center. When you work on a collaborative
audit and the administrator changes your auditing permissions, you might need to refresh the
permissions in the Eclipse Complete Plugin.

To refresh your permissions from Fortify Software Security Center:

Select Fortify > Options.

In the left pane, select Server Configuration.

Click Refresh Permissions for the Current Audit.
Click OK.

C A

Working with Audit Projects

After you scan a project, you can audit the analysis results. You can also audit the results of a
collaborative audit from Micro Focus Fortify Software Security Cenfer.
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Opening an Audit Project
To open an audit project:

1. Select Fortify > Open Audit Project.
The Select Audit Project dialog box opens.
2. Browse to and select the FPR file, and then click Open.

Opening an Existing Audit
You can open a local, previously saved audit, and continue your work. Alternatively, you can open an
audit that someone else performed on a different machine.
To open a previously-saved audit:
1. From Eclipse, select a project.

2. Select Fortify > Load Saved Audit Project.
To open an externally generated audit:

o Select Fortify > Open Audit Project.

Opening Audit Projects Without the Default Filter Set

If you open an audit project that does not contain the filter set specified as the default filter set for new
projects (by default, this is the Quick View filter set), a message is displayed to inform you that the filter
set is not available in the audit project’s issue template.

B Filter Set Mot Available

The filter set you have selected to be applied on project load is not available in your current issue
template. The default filter set will be loaded instead if you click Cancel. You can configure the
filter set to be applied on load by configuring the Audit Project Load Mode under the Audit
Settings Configuration options or choose Never Override Default Filter Set to always load the
default filter set from any template.

Update Issue Ternplate Cancel | Mewver Override Default Filter Set

The default filter set from the template is loaded at startup, regardless of the setting. This would also
happen, for example, with any FPR files downloaded from the Fortify on Demand Server.

To resolve this, do one of the following:

o To apply the default filter set from the current issue template, click Cancel.

o To update the issue template for the project, click Update Issue Template.
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After you select Update Issue Template, some of the filter sets that were available before the
update, for example Developer View and Critical Exposure, are no longer available.

A warning is displayed to let you know that you cannot undo the update.

e To ensure that the default filter set for the project is never overridden, click Never Override Default
Filter Set.

Exporting an Audit Project
To save an audit project in a specific location:

1. Select Fortify > Export Audit Project.
2. Browse to where you want to save the FPR.

3. Type a file name, and then click Save.

Obtaining New Results

This topic covers how to obtain new results for an existing audit.

To obtain results for an existing audit:

1. From Eclipse, open the Java or C/C++ perspective.

2. Inthe Package Explorer view, right-click the project, and then select Analyze Project.

Merging Audit Data

Audit data includes the custom tags and comments that were added to an issue. You can merge the
audit data for your project with audit data from another results file. Comments are merged into a
chronological list and custom tag values are updated. If custom tag values conflict (if the same tag is set
to different values for a given issue), the Eclipse Complete Plugin prompts you to resolve the conflict.

Note: Issues are not merged. Merged results include only the issues found in the latest scan. Issues
uncovered in the older scan that were not uncovered in the latest scan are marked as Removed and
are hidden by default.

Make sure that the projects you merge contain the same analysis information. That is, make sure that
the scans were performed on the same source code (no missing libraries or files), the Micro Focus
Fortify Static Code Analyzer settings were the same, and the scan was performed using the same
security content.

To merge projects:
1. Open a project in the Eclipse Complete Plugin.
2. Select Fortify > Merge Audit Projects.
3. Select an audit project (FPR file), and then click Open.

The Progress Information dialog box opens. When complete, the Merge dialog box opens.
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4. Click Yes to confirm the number of issues added or removed from the file.

Note: If the scan is identical, no issues are added or removed.

The project now contains all audit data from both result files.

Performing a Collaborative Audit

You can audit a project on Micro Focus Fortify Software Security Center collaboratively with other
Fortify Software Security Center users. Before you can access audit results from Fortify Software
Security Center, you must have configured a connection to Fortify Software Security Center. See
"Configuring a Connection to Fortify Software Security Center" on page 94.

To start a collaborative audit:

1. Select Fortify > Open Collaborative Audit.
If you already have an audit project open, close it.
2. If prompted, provide your Fortify Software Security Center credentials.

For information about logging into Fortify Software Security Center, see "Logging in to Fortify
Software Security Center" on page 95.

3. Inthe Choose Application and Version Mapping for Collaboration dialog box, select an application
version, and then click OK.
The audit project is downloaded from Fortify Software Security Center and opened in the Fortify
Audit perspective.

4. Audit the project as described in "About Viewing Analysis Results" on page 39.

5. When you have completed the audit, select Fortify > Upload Audit Project.

6. Click OK.

Note: If necessary, you can refresh your Fortify Software Security Center audit permission settings.
See "Refreshing Permissions from Fortify Software Security Center" on page 97.

Uploading Audit Results to Fortify Software Security Center

Before you can upload audit results (audit project) to Fortify Software Security Center, you must have
configured a connection to Fortify Software Security Center. See "Configuring a Connection to Fortify
Software Security Center" on page 94.

When you work on a collaborative audit and you downloaded the audit project from Micro Focus Fortify
Software Security Center, the Eclipse Complete Plugin retains the application version for the audit
project. If you want to upload the audit project to a different application version, you need to
disconnect the audit project from Fortify Software Security Center before you upload the results. To
disconnect the current audit project from Fortify Software Security Center, select Fortify > Options,
click Server Configuration, and then click Disconnect the Current Audit.
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Note: If you created any custom tags or filter sets for your project's issue template, you must first
commit them to Fortify Software Security Center before you upload the project so that information
is also uploaded. See "Committing Custom Tags to Fortify Software Security Center" on page 114
and "Committing Filter Sets and Folders" on page 105 for more information.

Note: By default, Micro Focus Fortify Software Security Center does not allow you to upload scans
performed in quick scan mode. However, you can configure your Fortify Software Security Center
application version so that uploaded audit projects scanned in quick scan mode are processed. For
more information, see analysis results processing rules in the Micro Focus Fortify Software Security
Center User Guide.

To upload results to Fortify Software Security Center:

1. Select Fortify > Upload Audit Project.
2. If prompted, type your Fortify Software Security Center credentials.

For information about logging into Fortify Software Security Cenfter, see "Logging in fo Fortify
Software Security Center" on page 95.

3. If the audit project is not already associated with an application version, select an application
version, and then click OK.

Note: If you see a message that the application version is not committed or does not exist, this
indicates that you opened an audit project that was previously associated with an application
version that does not exist on Fortify Software Security Center to which Fortify Plugins for
Eclipse is currently connected. Disconnect the audit project from Fortify Software Security
Center as described previously in this section.

A message notifies you when the upload is complete.
4. Click OK.

Updates you made to issues including comments and tag values (for tags that already exist for the
application version on Fortify Software Security Center) are uploaded.

About Issue Templates

Micro Focus Fortify Static Code Analyzer produces comprehensive results for source code analysis. On
large codebases, these results can be overwhelming. The issue tfemplate assigned to your projects
enables you to sort and filter the results to best suit your needs. The filtering and sorting mechanisms
appropriate during a given phase in the development process can change depending on the phase of
development. Similarly, the filtering and sorting mechanisms might vary depending on the role of the
user.

You can sort issues by grouping them into folders, which are logically defined sets of issues presented in
the tabs on the Static Analysis Results. You can further customize the sorting to provide custom
definitions for the folders into which the issues are sorted. You can provide definitions for any number
of folders, whose contents are then defined by filters. Filters can either alter the visibility of an issue or
place it into a folder. When used to sort issues into folders, you define the nature of the issues that
appear in the customized folders.
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You group filters into filter sets and then use the filter sets to sort and filter the issues displayed. An
issue template can contain definitions for multiple filter sets. Using multiple filter sets in an audit project
enables you to quickly change the sorting and visibility of the issues you are auditing. For example, the
default issue template used in the interface provides two filter sets. These filter sets provide an
increasingly restrictive view of security-related issues. Defining multiple filter sets for an audit project
enables different views for different users, and a customized view does not affect any other views.

In addition to providing sorting and filtering mechanisms, you can also customize the auditing process
by defining custom tags in the issue template. Auditors associate custom tags with issues during
auditing. For example, you can use custom tags to track impact, severity, or priority of an issue using the
same names and values used to track these attributes in other systems, such as a bug tracker
application.

Issue templates contain the following settings:

o Folder filters—Confrol how issues are sorted into the folders

« Visibility filters—Control which issues are shown and hidden

o Filter sets—Group folder and/or visibility filters

o Folder properties—Name, color, and the filter set in which it is active

o Custom tags—Specify which audit fields are displayed and the values for each

The issue template applied to an audit project is determined using the following preference order:

1. Template that exists in the audit project

2. Template<eclipse_install_dir>/plugins/com.fortify.dev.ide.eclipse_
<version>/Core/config/filters/defaulttemplate.xml

3. Template <eclipse_install_dir>/plugins/com.fortify.dev.ide.eclipse_
<version>/Core/config/rules/defaulttemplate.xml

4, Embedded Fortify default template

Configuring Custom Filter Sets and Filters

If the filter sets available in the Eclipse Complete Plugin do not exactly suit your needs, you can create
your own, either by using the filter wizard, or by copying and then modifying an existing filter set.

If you are performing collaborative audits on Micro Focus Fortify Software Security Center, you can
synchronize your custom filters with Fortify Software Security Center. For more information, see
"Committing Filter Sets and Folders" on page 105 and "Synchronizing Filter Sets and Folders" on
page 106.

This section provides instructions on how to:

e Create a new filter set
e Create filters from the Issues view and add them to a filter set
e Create filters on the Filters tab and add them to a filter set

o Copy afilter to a different filter set
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Creating a New Filter Set

To create a new filter set, copy an existing set and modify the settings.

To create a new filter set:

1.
2.

Select Fortify > Project Configuration.
Select the Filter Sets tab.

Next to Filter Sets, click Add Filter Set [,
The Add New Filter Set dialog box opens.

4. Type aname for the new filter set.

5. Select an existing filter set to copy.
6. Click OK.
A new filter set with the same folders, visibility filters, and folder filters as the copied filter set is created.

Creating a Filter from the Static Analysis Results View

When a folder list includes an issue that you want to hide or direct to another folder, you can create a
new filter using the filter wizard. The wizard displays all the attributes that match the conditions in the
filter.

Note: To find the filter that directed the issue to the folder, right-click the issue, and then select
Why is this issue here? To find the filter that hid an issue, right-click the issue, and then select
Why is this issue hidden?

To create a new filter from an issue:

1. Inthe Static Analysis Results view, select a filter set from the Filter Set list.

Right-click an issue, and then select Create Filter.
The Create Filter dialog box lists suggested conditions.

To see all the conditions, select the Show all conditions check box.

4. Select the conditions you want to use in the filter.

You can fine tune the filter later by modifying it on the Filter tab.

Select the type of filter you want to create, as follows:

o To create a visibility filter, select Hide Issue.

o To create afolder filter, select Set Folder to, and then select the folder name or select Other
Folder to add an existing folder or create a new one.
A new folder is displayed in this filter set only.

Click Create Filter.

The wizard places the new filter at the end of the filter list. For folder filters, this gives the new filter
the highest priority. Issues that match the new folder filter appear in the targeted folder.

(Optional) For folder filters, drag the filter higher in the folder filter list to change the priority.
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The issues are sorted with the new filter.

Note: The filter is created only in the selected filter set.

Creating a Filter from the Issue Auditing View
Use the Filters tab in the Issue Auditing view fo create visibility filters and folder filters.
Folder filters are applied in order and the issue is directed to the last folder filter it matches in the list.

To create a new filter on the Filters tab:

1. From the Filter Set list, select a filter set.
2. Select the Filters tab in the Issue Auditing view.

Audit Details Recommendations History Diagram Screenshots Filters 22 Warnings =0
Quick View Filters: (applied in the order shown) Show Matching Issues
v A Visibi"t!lr Filters Disable Filter

“ If impact is not in range [2.5, 5.0] Then hide issue
= |f likelihood is not in range (1.0, 5.0] Then hide issue Edit Filter ..

~ Folder Filters

W If [fortify priority order] contains critical Then set folder to Critical Create New Filter..

B If [fortify priority order] contains high Then set folder to High Delete Filter
3 If [fortify priority order] contains medium Then set folder to Medium
@ If [fortify priority order] contains low Then set folder to Low Copy Filter

Copy Filter To...

3. Right-click Visibility Filters or Folder Filters, and then select Create New Filter.
The Create Filter dialog box opens.

B Create Filter

If & i

Then

(® Hide Issue
() Set Folder to:

Save Cancel

4. From the first list, select an issue attribute.
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The second list is automatically populated.
From the second list, select how to match the value.
The third list contains the possible values for the attribute.

Select a value or specify a range as instructed in the If line.

7. Set Then to one of the following options:

9.

o To create a visibility filter, select Hide Issue.

e To create a folder filter, select Set Folder to, and then select the folder name or select Other
Folder to add a folder from another filter set or create a new folder.
Click Save.

The new filter is displayed at the end of the list. For folder filters, this gives the new filter the
highest priority. Issues that match the new folder filter appear in the targeted folder.

(Optional) For folder filters, drag the filter higher in the folder filter list to change the priority.

The issues are sorted with the new filter.

Note: The filter is created in the selected filter set only.

Copying a Filter from One Filter Set to Another

Filter settings are local to a filter set. However, you can copy the filter to another filter set in the audit
project. If you copy a folder filter to another set and that folder is not already active in the set, the folder
is automatically added.

To copy a filter:

1

In the Static Analysis Results view, select a filter set from the Filter Set list.

2. Select the Filters tab in the Issue Auditing view.

Right-click a filter, and then select Copy Filter To.

The Select a Filter Set dialog box opens with a list of all the filter sets.
Select a filter set, and then click OK.

The filter is added to the filter set in the last position.

(Optional) For folder filters, you can adjust the order of the filter list by dragging and dropping the
filter to a different location in the list.

Committing Filter Sets and Folders

If you want to upload filter sets and folders to an issue template on Micro Focus Fortify Software
Security Center, do the following:

F WD PR

Select Fortify > Project Configuration.
Select the Filter Sets tab.

Select the filter set from the list.

Click Commiit.
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5. If required, provide your Fortify Software Security Center credentials.

For information about logging into Fortify Software Security Center, see "Logging in to Fortify
Software Security Center" on page 95.

The Update Existing Issue Template or Add Issue Template dialog box opens, depending on
whether the issue template already exists in Fortify Software Security Center.

6. Do one of the following:
a. To upload filter sets and folders to the issue template, click Yes.

b. To add the issue template that contains the current set of custom tags to Fortify Software
Security Center, click Yes.

Synchronizing Filter Sets and Folders

To download filter sets and folders configured from Micro Focus Fortify Software Security Center:

1. Select Fortify > Project Configuration.
2. Select the Filter Sets tab.
3. Click Synchronize.

A message advises you that downloading filter sets and folders from Fortify Software Security
Center overwrites your local filter sets and folders.

4. To proceed with the synchronization, click Yes.
5. If required, provide your Fortify Software Security Center credentials, and then click OK.
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For information about logging into Fortify Software Security Center, see "Logging in to Fortify
Software Security Center" on page 95.

B Issue Templates

P
E Issue Templates
Choose an Issue Template:
Issue Template Descripticn
PCI 55F 1.0 Basic lssue Template! The PCI 55F 1.0 standard gives specific gui
PClw3.2.1 Basic Issue Template The PCI D55 v3.2.1 standard gives specific
Prigritized High Risk [ssue Ternplate  High risk applications should receive more
Prioritized Low Risk 3rd Party lssue.. Theintroduction of third-party software di
Pricritized Low Risk Issue Template  Although an application is perceived as lov
< >
v
QK Cancel

If the current issue template does not exist on Fortify Software Security Center, do the following:
a. Inthelssue Template column, select an issue template name.
b. Click OK.

6. The Eclipse Complete Plugin downloads the filter sets and folders from the selected issue template
on Fortify Software Security Center, and overwrites your current issue template.

Setting the Default Filter Set

To specify the default filter set used to view scan findings:

1. Inthe Static Analysis Results view, click the Filter Set list, and then select Edit.

The Project Configuration dialog box opens to the Filter Sets fab.

In the Filter Sets list, select the filter set you want o use as the default for the issue template.
3. Select the Default filter set check box, and then click OK.

Managing Folders

Folders are logical sets of issues that are defined by the filters in the active filter set. Even though a
folder can appear in more than one filter set, the contents might differ depending on the filters in that
filter set that target the folder. To accommodate filter sets that provide sorting mechanisms with little
overlap, you can have filter sets with different folders. Folders are defined independent of the filter sets

they may appear in. For example, a filter set might place low priority issues into a red folder that is
labeled "Hot."
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Creating a Folder

You can create a new folder so that you can display a group of issues you have filtered to the folder.
Folders must have unique names.

To create a new folder:

1. Select Fortify > Project Configuration.
2. Select the Folders tab.

The Folders pane on the left lists the folders for the filter set selected in the Folder for Filter Set
list. Fields on the right show the name, color, and description of the selected folder.

B Project Configuration

Filter Sets | Folders | Custom Tags

Filter Set: Cuick View e

MName: Default Folder
Folders =] (=] -

| Critical |

0 Critical
Color:

@ High

[T Low (default) Description:

This folder provides a comprehensive list of
issues in the application with a high impact and
high likelihcod,

3. To associate the folder with an existing filter set, select the filter set from the Filter Set list.

Select (All Folders) to create a new folder in the issue template without associating the folder to a
specific filter set. You can associate the folder with an existing filter set later.

Note: Selecting a filter set updates the Folders list to display the folders that are associated
with the selected filter set.

4, To add afolder:

a. Next to Folders, click Add Folder [l
The Add Folder dialog box opens.

Note: If you have created folders in other filter sets, the Add New Folder to Filter Set
dialog box opens. Click Create New.

b. Type aunique name for the new folder, and then select a folder color.

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 108 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

c. Click OK.
The folder is added to the bottom of the folder list.
5. In the Description box, type a description for the new folder.

6. To change the tab position of the folder on the Static Analysis Results view, drag the folder up
or down in the Folders list.

The top position is on the left and the bottom position is on the right.

7. To put allissues that do not match a folder filter into this folder, select the Default Folder check
box.

8. Click OK.

The folder is displayed as a tab with the other folders. If you selected default, all issues that do not
match a folder filter are displayed. The new folder is added to the issue template for the audit project.

Note: To display issues in this folder, create a folder filter that targets the new folder. For more
information, see "Creating a Filter from the Static Analysis Results View" on page 103 and "Creating
a Filter from the Issue Auditing View" on page 104.

Adding a Folder to a Filter Set

This section describes how to enable an existing folder in a filter set. Create a new folder that is only
included in the selected filter set using the instructions in "Creating a Folder" on the previous page. To
display issues in this folder, create a folder filter that targets the new folder.

To add a folder to a filter set:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.

2. Select the Folders tab.

3. Click the Filter Set list to select the filter set where you want to add a folder.
The Folders list displays the folders in the selected filter set.

4. Next to Folders, click Add Folder [,
The Add New Folder to Filter Set dialog box opens.

Note: If the selected filter set already includes all existing folders, the Create Folder dialog box
opens and you can create a new folder for the selected filter set.

5. Select the folder to add to the selected filter set, and then click Select.
6. Click OK.
The folder is displayed as a tab along with the other folders.
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Renaming a Folder

You can rename a folder. Modifying the name of a folder is a global change reflected in all filter sets.

To rename a folder:

C A

6.

Select Fortify > Project Configuration.

Select the Folders tab.

In the Filter Set list, select (All Folders).

Select the folder in the Folders list.

The folder properties are displayed on the right.

Type the new name for the folder.

The folder name changes in the Folders list as you type.
Click OK.

The new folder name displays on the tabs.

Removing a Folder

You can remove a folder from a filter set without removing it from other filter sets.

To remove a folder:

1. Select Fortify > Project Configuration.
2. Select the Folders fab.
3. Select afilter set from the Filter Set list.

The Folders list displays the folders in the selected filter set.
Select the folder, and then next to Folders, click Delete Folder =l

Note: The folder is removed only from the selected filter set.

If the folder is a target of a folder filter, the Conflicts Occurred Removing Folder dialog box opens.

B Conflicts Occurred Removing Folder...

The folder ‘Audited’ is the target of the following filters:

B If Truefudit is true Then set folder to Audited

Retarget the filters: e

Retarget Filters Delete Filters Cancel
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Do one of the following:

a. To target the filter to a different folder, select a folder from the Retarget the filters list, and
then click Retarget Filters.

b. To delete the filter, click Delete Filters, and then click Yes to confirm the deletion.
5. Click OK to close the Project Configuration dialog box.
The folder is no longer displayed as a tab in the Static Analysis Results view.

Configuring Custom Tags for Auditing

To audit code in Micro Focus Fortify Software Security Center, the security team examines project
analysis results (FPR) and assigns values to custom tags associated with application version issues. The
development team can then use these tag values to determine which issues to address and in what
order.

The Analysis tag is provided by default. The Analysis tag is a list-type tag and has the following valid
values: Not an Issue, Reliability Issue, Bad Practice, Suspicious, and Exploitable. You can modify the
Analysis tag attributes, change the tag values, or add new values based on your auditing needs.

To refine your auditing process, you can define your own custom tags. You can create the following
types of custom tags: list, decimal, string, and date. For example, you could create a list-type custom tag
to track the sign-off process for an issue. After a developer audits his own issues, a security expert can
review those same issues and mark each as “approved” or “not approved.”

You can add the following attributes to your custom tags:

« Extensible—This enables users to create a new value while auditing, even without the permission to
manage custom tags.

o Restricted—This restricts who can set the tag value on an issue. Administrators, security leads, and
managers have permission to audit restricted tags.

After you define a custom tag, it is displayed below the Analysis tag, which enables you to specify
values as they relate to specific issues. Custom tags are also available in other areas of the interface,
such as in the Group By list o group issues in a folder, in the search field as a search modifier (similarly
available as a modifier for filters), and in the project summary graph as an attribute by which to
graphically sort issues.

Adding a Custom Tag

You can create custom tags to use in auditing results. Custom tags are project-wide and are saved as
part of an issue template.

To add a custom tag:

1. Select Fortify > Project Configuration.
2. Select the Custom Tags fab.
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B Project Configuration

Filter Sets  Folders Custom Tags
Tags &l || Values
List Tag: Extensibl Restricted
Analysis Mot an |ssue e [JEdensible [ ]Restricte
Reliability Issue Analysis
Bad Practice Description:
Cuspici
LISFII.CIEILIS The analysis tag must be set for an issue
Exploitable to be counted as 'Audited.’ This is
encouraged to be the final action
performed by an auditor.
Default Value:
Value:
Description:
Set Primary Tag... Commit Synchronize

3. Next to Tags, click Add Tag [l

Note: Any previously hidden tags are listed, and you can re-enable them. To create a new tag,
click Create New.

The Add New Tag dialog box opens.
In the Name box, type a name for the new tag.
5. Fromthe Type list, select one of the following tag types:

o List—Accepts selection from a list of values that you specify for the tag
o Date—Accepts a calendar date
o Decimal—Accepts a number with a precision of up to 18 (up to 9 decimal places)

o Text—Accepts a string with up to 500 characters (HTML/XML tags and newlines are not
allowed)

6. Click OK.
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The Tags list now includes the new tag.

7. Configure any or all the following optional tag settings:

To allow users to add new values for a list-type tag in an audit, leave the Extensible check box
selected.

To allow only administrators, security leads, and managers to set this tag on an issue, select the
Restricted check box.

Type a description of the custom tag in the Description box.

For a list-type tag, from the Default Value list, select the default value for the tag.

If you do not specify a default value, the default is null.

8. To add avalue for a list-type tag, do the following:

a.

b.
c
d.

e.

From the Tags list, select the tag name.

Next to Values, click Add Value £,
In the Enter Value dialog box, type a value, and then click OK.
Type a description of the value in the Description box.

Repeat steps a through d for each additional value required for the new tag.

9. To make this custom tag the primary tag:

Note: You can only set a list-type tag as a primary tag.

a.
b.

Click Set Primary Tag.
Select the custom tag from the Primary Tag list, and then click OK.

The primary tag determines the audit status for each issue as well as the audit icon in the Static
Analysis Results view. By defaulf, the primary tag is Analysis.

The Audit tab in the Issue Auditing view now displays the new tag and its default value (if you assigned

one).

Hiding a Custom Tag

If you hide a custom tag, it is no longer available on the Issue Auditing view's Audit tab or as a search or
filter option.

Note: If you hide a custom tag that was set for any issues, that tag and values are hidden from the

issue.

If you make the tag available again, the tag and values are restored.

You cannot hide the primary tag.

To hide a custom tag:

1. Select Fortify > Project Configuration.

The Project Configuration dialog box opens.

2. Select the Custom Tags tab.

3. Select the tag from the Tags list.
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4. Next to Tags, click Hide Tag =

This action hides the tag from your available custom tags. You can make this tag available again
when you add a custom tag (see "Adding a Custom Tag" on page 111).

5. Click OK.
If you hide a tag that has an associated filter, you are prompted to delete the filter.

Committing Custom Tags to Fortify Software Security Center

To commit custom tags to Micro Focus Fortify Software Security Center:

=

With an audit project open, select Fortify > Project Configuration.

N

Select the Custom Tags tab.
3. Click Commit.

Note: Any list-type custom tags without values are not uploaded to Fortify Software Security
Center.

4. If prompted, type your Fortify Software Security Center credentials.

For information about logging into Fortify Software Security Center, see "Logging in to Fortify
Software Security Center" on page 95.

The Custom Tag Upload dialog box opens.
5. Do one of the following:

o If theissue template and the application version already exist on Fortify Software Security
Center:

o To upload the custom tags to the global pool and assign them to the application version,
click Yes.

o To upload the custom tags to the global pool without assigning them to the application
version, click No.

o To prevent uploading the custom tags to Fortify Software Security Center, click Cancel.

o |f theissue template does not exist on Fortify Software Security Center:

o To upload the custom tags to the global pool only on Fortify Software Security Center, click
Yes.

o To prevent uploading the custom tags to Fortify Software Security Center, click No.
Synchronizing Custom Tags with Fortify Software Security Center

To synchronize custom tags for an audit project that has been uploaded to Micro Focus Fortify
Software Security Center.

1. Select Fortify > Project Configuration.
2. Select the Custom Tags tab.

3. Select the custom tag.
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4. Click Synchronize.
5. If required, type your Fortify Software Security Center credentials.

For information about logging into Fortify Software Security Center, see "Logging in to Forfify
Software Security Center" on page 95.

The Custom Tag Download dialog box opens.

6. If the application version and the issue femplate both exist on Fortify Software Security Center,
select either Application Version or Issue Template to specify from where to download the
custom tags.

7. To download custom tags from the issue template, click Yes.

Issue Template Sharing

After an issue template is associated with an audit project, all changes made to that template, such as
the addition of folders, custom tags, filter sets, or filters, apply to the audit project. The issue template is
stored in the FPR when the audit project is saved. For information about how to associate the issue
template with an audit project, see "Importing an Issue Template" below. With issue templates, you can
use the same project settings for another project.

Exporting an Issue Template

Exporting an issue template creates a file that contains the filter sets, folders, and custom tags for the
current project. After you export an issue template, you can import it intfo another audit project file.

To export an issue template:

1. Select Fortify > Project Configuration.
2. Select the Filter Sets tab.
3. Click Export.
The Select a Template File Location dialog box opens.
4. Browse to the location where you want to save the file.
5. Type a file name without an extension.
6. Click Save.
The current template settings are saved to an XML file.

Importing an Issue Template

Importing an issue femplate overwrites the audit project configuration settings. The local filter sets and
custom tags are replaced with the filter sets and custom tags in the issue template.

To import an issue template:

1. Select Fortify > Project Configuration.
2. Select the Filter Sets tab.
3. Click Import.
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The Locate Template File dialog box opens.
4. Select the issue template file to import.
5. Click Open.
The filter sets, custom folders, and custom tags are updated.

Note: You can also click Reset to Default fo return the settings to the default issue template.

Troubleshooting

The following topics provide information on how to troubleshoot problems you might encounter
working with the Eclipse Complete Plugin.

Resolving the Java OutOfMemory Message

If you see the java.lang.OutOfMemory message while managing security content or while loading a
large source code analysis results file, adjust the JVM size of the virtual machine for your IDE.

To adjust the JVM size, restart the IDE as follows:

eclipse.exe -vmargs -Xmx<nnn>M

where <nnn> is the amount of memory you are allocating to the IDE. For example, o allocate 300 MB to
the IDE, specify -Xmx300M.

If you specify this option, make sure that you do not allocate more memory than is physically available.
As a guideline, assuming no other memory-intensive processes are running, allocate no more than two
thirds of the available memory.

Resolving Scan Failures Due to Insufficient Memory

If you run out of memory during a scan, configure project properties settings to increase the memory
for that scan (see "Configuring Local Analysis Options" on page 24).

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 116 of 130



User Guide
Chapter 2: Using the Eclipse Complete Plugin

Saving a Project That Exceeds the Maximum Removed Issues
Limit

When you save a project that has more than the maximum number of removed issues, the Eclipse
Complete Plugin displays following warning message:

Your project contains more than <RemovedIssuesLimit> removed issues.
Would you like to persist them all, or limit the number to
<RemovedIssuesLimit>?

If you limit the number, audited removed issues will take precedence of
unaudited ones.

Choose Limit to limit the number of issues to the maximum or Save All 1o save all the removed issues.
The maximum number of removed issues <RemovedIssuesLimit> is controlled by the

com.fortify.RemovedIssuePersistancelLimit property. See Micro Focus Fortify Static Code
Analyzer Tools Properties Reference Guide for more information.

To configure how the Eclipse Complete Plugin handles this issue for future occurrences:
Select Fortify > Options.

In the left pane, select Audit Configuration.
Select the Configuration tab.

E A

Under Save Audit Project Options, specify one of the following configuration settings:
¢ Limit removed issues to the maximum number

+ Save all removed issues every time
o Prompt me next time

5. Click OK.

Using the Debug Option

If you encounter errors, you can enable the debug option to help troubleshoot.

To enable debugging:

1. Openthefortify.properties file located in the following directory depending on the area you
want to debug:

To debug... Open the properties file in this location
Scanning <sca_install_dir>/Core/config

Eclipse Complete Plugin  <eclipse_install dirs/plugins/com.fortify.dev.ide.
eclipse_<version>/Core/config
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2. You can either enable debug mode for all Micro Focus Fortify Static Code Analyzer tools or for
specific fools. Remove the comment tag (#) fromin front of the property and set the value to true.

Property Description

com.fortify.Debug If set to true, all the Fortify Static Code Analyzer tools
run in debug mode.

com.fortify.awb.Debug If set to true, Fortify Audit Workbench runs in debug
mode.

com.fortify.eclipse.Debug If set to true, the Eclipse Complete Plugin runs in debug
mode.

Locating Log Files

For help diagnosing the problem, provide the log files to Micro Focus Fortify Customer Support.

On Windows systems, the default log file locations are in the following directories:

e C:\Users\<username>\AppData\Local\Fortify\sca<version>\log
This log file is only available if you analyze the code with Micro Focus Fortify Static Code Analyzer.

e C:\Users\<username>\AppData\Local\Fortify\Eclipse.Plugin-<version>\log

e C:\users\<username>\AppData\Local\Fortify\scancentral-<version>\log
This log file is only available if you analyze the code with Micro Focus Fortify ScanCentral SAST.

On Linux and macOS systems, the default log file locations are in the following directories:

e <username>/.fortify/sca<version>/log
This log file is only available if you analyze the code with Fortify Static Code Analyzer.

e <username>/.fortify/Eclipse.Plugin-<version>/log

e <username>/.fortify/scancentral-<version>/log
This log file is only available if you analyze the code with Fortify ScanCentral SAST.
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This chapter provides an overview of the Eclipse Remediation Plugin, instructions on how to install the
plugin, and how to use the plugin to audit issues associated with your Micro Focus Fortify Software
Security Center applications.

Use the Eclipse Remediation Plugin to download audit results for your code from Fortify Software
Security Center so that you can resolve security-related issues in Eclipse.

This section contains the following topics:

Installing the Eclipse Remediation Plugin ... . 119
Uninstalling the Eclipse Remediation Plugin from Eclipse . ... .. ... 121
Opening a Fortify Software Security Center Application Version ... ... ... ... ................ 121
Viewing Analysis Results from Fortify Software Security Center ... .. 123
Locating the Source Code Associated with Issues ... .. 128
Generating and Downloading Reports ... 129

Installing the Eclipse Remediation Plugin

You can install the Eclipse Remediation Plugin on Windows, Linux, and macOS systems. You can install
the plugin locally or, if you set up an update site, you can install the Eclipse Remediation Plugin by
connecting to the update site from Eclipse.

To update from an earlier Eclipse Remediation Plugin version, you must first remove the existing
version. For information about how to uninstall the plugin, see "Uninstalling the Eclipse Remediation
Plugin from Eclipse" on page 121.

Note: You do not need to specify a Fortify license file for the Eclipse Remediation Plugin. It uses the
license file for Micro Focus Fortify Software Security Center, with which it works.

Installing the Eclipse Remediation Plugin Locally

Note: These instructions describe a third-party product and might not match the specific,
supported version you are using. See your product documentation for the instructions for your
version.
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To install the Eclipse Remediation Plugin locally:

1. Start Eclipse.
2. Select Help > Install New Software.
3. Click Add.

The Add Repository dialog box opens.

4. Click Archive, and then locate and select the Fortify Eclipse Remediation Plugin_
<version>.zip file.

5. Click Add.

On the Available Software step, the Fortify Eclipse Remediation Plugin node is listed as
available software.

Click Select All and then click Next.

To view version and copyright information for the plugin in the Details box, click the plugin name.
Click Next.

On the Review Licenses step, review and accept the terms of the Micro Focus license agreement.
10. Click Finish.

11. To complete the installation and restart Eclipse, click Restart Now when prompted.

0 © N O

After Eclipse restarts, the menu bar displays the Fortify menu.

Installing the Eclipse Remediation Plugin from an Update Site

An alternative to requiring every developer fo install the Eclipse Remediation Plugin locally is to post the
plugin to an internal update site that can serve as a single distribution point. The only requirement is
that you have an internal web server.

Posting the Eclipse Remediation Plugin to an Internal Update Site

To post the plugin to an infernal update site:

1. Extract the contents of the Eclipse Remediation Plugin archive (Fortify Eclipse_
Remediation_Plugin_<version>.zip)onto your web server.

2. Provide the URL for the update site to the appropriate users.

Installing from an Update Site
To install the Eclipse Remediation Plugin from an update site:

Obtain the URL of the plugin update site.
Start Eclipse.

Select Help > Install New Software.
Click Add.

E A o
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5. Do the following:
a. Inthe Name box, type a name for the update site.
b. Inthe Location box, type the URL for the update site.
c. Click OK.

In the Install window, the Work with list displays the update site you specified and the Eclipse
Remediation Plugin node is listed as available software.

6. Click Select All and then click Next.

7. To view version and copyright information about the plugin in the Details box, click the plugin
name.

8. Click Next.

9. On the Review Licenses step, review and accept the terms of the Micro Focus license agreement.
10. Click Finish.
11. To complete the installation, click Yes to restart Eclipse when prompted.

After Eclipse restarts, the menu bar displays the Fortify menu.

Uninstalling the Eclipse Remediation Plugin from
Eclipse

Note: These instructions describe a third-party product and might not match the specific,
supported version you are using. See your product documentation for the instructions for your
version.

To uninstall the Eclipse Remediation Plugin:

Start Eclipse.

Select Help > About Eclipse IDE, and then click Installation Details.

On the Installed Software tab, select Fortify Remediation Plugin for Eclipse.
Click Uninstall.

In the Uninstall window, click Finish.

ua N E

6. To implement the change, click Yes to restart Eclipse.

The Eclipse menu bar no longer includes the Fortify menu.

Opening a Fortify Software Security Center
Application Version

Because the Eclipse Remediation Plugin is designed to work with Micro Focus Fortify Software Security
Center, the first thing you must do after installing it is connect to Fortify Software Security Center and
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open an application version.

If your server is behind a proxy, you must provide the proxy server and port as follows:

1. Select Fortify > Options.

2. Inthe Server URL box, type the URL for your Fortify Software Security Center server (for
example, http://my.domain.com:8080/ssc).

3. Type the proxy address and port number.

4. Click OK.

Note: The Fortify Software Security Center that you connect to from the Eclipse Remediation
Plugin must be running continuously during your work session in Eclipse.

To connect to Fortify Software Security Center and open an application in the Eclipse Remediation
Plugin:

1. Select Fortify > Connect to Software Security Center.

= Software Security Center Credentials

SSC URL: ‘ http://my.domain.com:8080/ssc |

Login Method: |Username/Password i

User: ‘ Jsmith |

Password: ‘ | |
oK Cancel

2. Fromthe Login Method list, select the login method set up for you on Fortify Software Security
Center.

Depending on the selected login method, do one of the following:

Login Method Procedure
Username/Password Type your Fortify Software Security Center user name and password.
Authentication Token In the Token box, specify the decoded value of a Fortify Software

Security Center authentication token of type ToolsConnectToken.

Note: For instructions about how to create an authentication
token from Fortify Software Security Center, see the Micro
Focus Fortify Software Security Center User Guide.

3. Click OK to connect to Fortify Software Security Center.
The Select Software Security Center Application Version dialog box opens and displays a tree of

Micro Focus Fortify Plugins for Eclipse (21.1.0) Page 122 of 130



User Guide
Chapter 3: Using the Eclipse Remediation Plugin

Fortify Software Security Center applications and application versions.
4, Select the application version you want to open, and then click OK.

The Eclipse Remediation Plugin downloads the application version content from Fortify Software
Security Center.

Viewing Analysis Results from Fortify Software
Security Center

The Eclipse Remediation Plugin provides the security issues related to an opened application version.
Issues are organized based on settings in Micro Focus Fortify Software Security Center.

The Remediation View displays all project issues, organized in folders (colored tabs). To the right of
the issues list are four tabs that provide information specific to a selected issue in the issues list on the
left.

: Rermeduation View

Lt

Group By: Category ¥ lIssues for: <All Users> ¥ Audit Recommendations Details History
. -
R iR 80 Mesiom @ Low 663) WIESH U
21 Command Inpection - (2 / 2] Analysis 3 w

3 Cross-Site Scripting: Persistent - [5 /9]

2 Cross-Site Senpting: Reflected - [41 7 44)

O Password Management: Hardooded Password - [1 /1)
CJ Race Condition: Singleton Member Field - [0/ 1]

—J SOL Injection - [43 / 43]

C XPath Injection - [1/ 1]

Issues List

Micro Focus Fortify Software Security Center organizes issues into folders (tabs) based on the filter
sets specified in the issue template. After you select an application version to open, the Eclipse
Remediation Plugin downloads the issues for that application version and displays the Remediation
View at the bottom of the Eclipse window.

The left portion of the Remediation View lists any issues assigned o you, grouped by issue category.
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«=| Tasks EF{er‘nediatiDn View &3

Group By: Category = | Issues for| <All Users> -

_ High (84) Medium (2) Low (663) Al (850)

» [ Command Injection - [2 /2]

+ [ Cross-Site Scripting: Persistent - [5 /9]

» [0 Cross-Site Scripting: Reflected - [41 / 44]

- [ Password Management: Hardcoded Password - [1 /1]
» [ Race Condition: Singleton Member Field - [0 /1]

» [ SQL Injection - [43 / 43]

« [ XPath Injection - [1 /1]

X =

The issues are grouped into the following color-coded folders (tabs):
o The Critical folder contains issues that have a high impact and a high likelihood of exploitation.
Remediate critical issues immediately.

o The High folder contains issues that have a high impact and a low likelihood of exploitation.
Remediate these issues with the next patch release.

o The Medium folder contains issues that have a low impact and a high likelihood of exploitation.
Remediate these issues as time permits.

+ TheLow folder contains issues that have a low impact and a low likelihood of exploitation. Remediate
these issues as time permits.

o The All folder lists all issues.

Within each color-coded folder, issues are grouped into subfolders. At the end of each folder name,
enclosed in brackets, is the number of audited issues and the total number of issues in the folder. For
example, Command Injection - [2 / 2] indicates that two out of two issues categorized as Command
Injection have been audited.

Grouping and Viewing Issues
To view and select project issues:

1. From the Group By list, select a value to use to sort issues in all visible folders into groups.
The default grouping is Category.

2. Fromthe Issues for list, select one of the following:
« <All Users>

o Your Fortify Software Security Center user name
¢ Possibly, additional Micro Focus Fortify Software Security Center user names

3. Click a folder (tab) to view the associated issues.
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The issue type subfolders listed on each folder (tab) are based on the Group By and Issues for
values you selected.

4. To view the list of issues in a subfolder, expand the subfolder.

The Eclipse Remediation Plugin retrieves the corresponding issues from Fortify Software Security
Center.

5. Select anissue.
In the Remediation View, the Issue Details tab displays information about the selected issue.

For information about how to search for issues, see "Searching for Issues" on page 74.

Customizing the Issues List

The filter sets, folders, tags, and filter settings that you see in the Remediation View are based on the
issue template assigned to the application version in Micro Focus Fortify Software Security Center. You
can control how the Eclipse Remediation Plugin displays issues by specifying which issue types (hidden,
suppressed, and removed) to list and which filter set to apply to issues.

To customize the issues list:

1. To list a specificissue type, at the top right of the Remediation View, click the View Menuicon
click Issue Visibility, and then select (or deselect) one of the following options:

o Todisplay all issues that are excluded from display by visibility filters in filter sets such as the
Quick View filter sets, select Show Hidden Issues.

o Todisplay all the issues that were uncovered in the previous scan but are no longer evident in
the most recent analysis results, select Show Removed Issues.

o Todisplay all issues marked as suppressed (either because they are not of high priority or of
immediate concern), select Show Suppressed Issues.

You can select or clear each of these three options.

2. To specify the filter set to apply to issues, click the View Menuicon 7, click Filter Set, and then
select a filter set.
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Audit Tab

Audit| Recommendations Details History

L4

User: v | * Online of k va, the method
invokes a SQL query built using unvalidated input. This call

Analysis: | Not Set I

could allow an attacker to modify the statement's meaning

or to execute arbitrary SQL commands.

#) ParameterParserjava:627 -
= ParameterParserjava:b27 -
# ParameterParserjava:638 -
#) ParameterParser.java:608 -
« ParameterParserjava:608 -

getParameterValues(return)
Assignment to values
Return values[0]
getRawParameter(return)
Return

#() BackDoorsjava:95 - getRawParameter(return)
= BackDoorsjava:9s - Assignment to userinput
= BackDoorsjava:98 - Assignment to userinput
#) BackDoorsjava:99 - split(this : return[])

= BackDoorsjava:99 - Assignment to arrSQL
+) BackDoorsjava:113 - executeQuery(0)

The Audit tab provides the following information for the selected issue:

¢ User assigned to the issue (if set)

¢ Analysis tag value

o Any custom tags defined for the application in Micro Focus Fortify Software Security Center

o Comments added for the issue (bottom left)

o Information (abstract) about the selected issue (top right)

o Analysis trace that the analyzer used to produce the results file (bottom right). For a description of

the analysis frace, see "Analysis Trace View" on page 51.

To update the audit results at any time with Fortify Software Security Center, click Refresh =

Assigning Users to Issues

To assign a user (or a different user) to an issue:

1. Fromtheissues list in the Remediation View, select an issue.
2. Fromthe User list on the Audit tab, select the username for the user to assign to the issue.

Assigning Tags to Issues
To assign tag values to an issue:

1. From afolderin the Remediation View, select an issue.

2. From the Analysis list on the Audit tab, select a value that reflects your assessment of this issue.
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3. If custom tags defined for the project exist, provide values for them.

For text-type custom fags, you can click Edit Text =/ fo see and edit long text strings. This tag
accepts up to 500 characters (HTML/XML tags and newlines are not allowed).

For date-type custom tags, you can click ~ to select a date from a calendar.

Adding Comments to Issues
The comments box below the Analysis list displays any comments submitted for the selected issue.
To add a commenft o an issue:

1. From afolder in the Remediation View, select an issue.

2. Atthe top right of the Remediation View, click Add Comment m
The Add Comment for Issue dialog box opens.
3. Type your comment in the text box, and then click OK.

Your comment is displayed in the box below the Analysis list and any other custom tags if they exist.
The Eclipse Remediation Plugin communicates with Micro Focus Fortify Software Security Center and
updates the application version on the server.

Recommendations Tab

The Recommendations tab provides suggestions and examples on how to secure a vulnerability or
remedy a bad practice. The following table describes the information on this tab.

Element Information Provided

Recommendations/Custom Recommendations for the selected issue type, and any custom
Recommendations recommendations defined by your organization.

Tips/Custom Tips Tips for selected issue type, and any custom tips defined by your
organization.

References/Custom Reference information, including any custom reference defined by
References your organization.
Details Tab

The Details tab provides an abstract of the issue, a detailed explanation, and examples. The following
table describes the information on this fab.
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Element

Abstract/Custom
Abstract

Explanation/Custom
Explanation

Instance ID
Primary Rule ID

Priority Metadata
Values

Legacy Priority
Metadata Values

Remediation Effort

History Tab

The History tab displays a complete list of audit actions, including details such as the time and date, and

Information Provided

Summary description of an issue, including custom abstracts defined by
your organization

Conditions in which the selected issue type occurs

Discussion of the vulnerability, the constructs typically associated with if,
ways in which attackers can exploit it, and the potential ramifications of an
atftack

Any custom explanations defined by your organization
Unique identifier for an issue
Primary rule used to uncover the issue

Priority metadata values for the issue

Legacy priority metadata values for the issue

Relative amount of effort required to fix and verify an issue

the name of the user who modified the issue.

Locating the Source Code Associated with Issues

You can use the Eclipse Remediation Plugin fo locate security-related issues in your code.

To jump to the line of source code that contains the issue selected in the Eclipse Remediation Plugin:

1. Make sure that you have the same application version open in both Eclipse and the Eclipse

Remediation Plugin.

Note: The name of the Eclipse project and the Micro Focus Fortify Software Security Center
application must be the same.

2. Select anissue in the issue tree or select a line in the analysis trace of the Remediation View.

Eclipse displays the associated line of code.
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Generating and Downloading Reports

You can generate reports on the Micro Focus Fortify Software Security Center from the Eclipse
Remediation Plugin. You can also download a report that has already been created from Fortify
Software Security Center.

To generate or download a report, you must be connected to Fortify Software Security Center and
have an application version opened. You are prompted to login to Fortify Software Security Center and
select an application version if you have not done so. For more information, see "Opening a Fortify
Software Security Center Application Version" on page 121.

Generating Reports
To generate areport:

1. Select Fortify > Generate Report.
2. If prompted, provide your Fortify Software Security Center credentials.
3. Select an application version and then click OK.
The Software Security Center Report Generation dialog box opens.
4, Select areport type from the list.
5. Select the template version and the options you want to include in the report.

Note: The template version and options vary depending on the report type selected.

6. To specify the file name for the report and select the report format (PDF, DOC, or XLS), click
Report details.

The default report format is PDF.
7. Click Generate.
8. Navigate to where you want to save the report and click Save.
The report is generated and saved in the format you selected.

Downloading Reports from Fortify Software Security Center

To download a report that has been created on Micro Focus Fortify Software Security Cenfter:

Select Fortify > Download Generated Report.
If prompted, provide your Fortify Software Security Center credentials.

Select the application version from which you want to download the report.

F NP

Select the report you want to download from the list of reports previously generated in Fortify
Software Security Cenfter.

5. Click Download Report.
6. Navigate to where you want to save the report and click Save.
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Send Documentation Feedback

If you have comments about this document, you can contact the documentation team by email.

Note: If you are experiencing a technical issue with our product, do not email the documentation
team. Instead, contact Micro Focus Fortify Customer Support at
https://www.microfocus.com/support so they can assist you.

If an email client is configured on this computer, click the link above to contact the documentation team
and an email window opens with the following information in the subject line:

Feedback on User Guide (Fortify Plugins for Eclipse 21.1.0)
Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and send
your feedback to FortifyDocTeam@microfocus.com.

We appreciate your feedback!
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