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Silk Central Help

Silk Central is a powerful, all-inclusive, software test-management tool. Silk Central builds quality and
productivity into your testing process, speeding the delivery of successful software projects while
minimizing the risks of application failures. It consolidates all the critical software-testing phases within a
single, scalable, Web-based testing system, enabling your local and distributed software-development
teams to share experiences, resources, and critical information.
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What's New In Silk Central 18.5

Silk Central 18.5 introduces significant enhancements and changes.

Administration

Local System Diagnostics Access

If Silk Central denies login or no longer responds due to overload, you can now still access the System
Diagnostics page locally on your front-end server machine (via http://localhost:19120/
systemdiagnostics) to gather valuable information for root cause analysis.

Execution Planning and Test Execution

Distributed Execution

Silk Central now supports the distributed execution of the assigned tests of one single execution plan, by
running the tests on all matching execution servers in parallel.

To prevent overload on your execution servers, you can now also configure the amount of Maximum
concurrent executions per execution server. This is the maximum amount of execution plans (with
disabled Exclusive execution setting) that are allowed to run concurrently on one specific execution
server.

An additional major benefit coming with distributed executions is the immediate visibility of execution
progress in the Activities and Current Runs grids for automated test executions. Previously, this
information was only available after the complete execution plan run was finished.

Execution Planning Attributes

Execution planning attributes are now considered in Silk Central's SOAP API. For detailed information,
refer to Silk Central's Javadoc.

Note: Execution planning attributes are not yet considered in Silk Central's bulk export/update
interface.

Tests

Shared Test Assets

Tests can now be shared by projects to be used in other projects, allowing an efficient central management
of reoccurring tests. Such tests reused in other projects will maintain a reference to their origin to receive
information on any update (test version), which can be accepted or skipped. Additionally, reused tests will
be assigned to existing requirements in their project, identical to the requirements assignment of their
origin.

10 | What's New in Silk Central 18.5



Extended Test Versions

Due to their vital role in test asset sharing, test versions now include parameters, attributes, properties,
success conditions, and inheritance information.

Displaying Custom Attributes in Tests Document View

Custom attributes can now be displayed in Tests > Document View. You can use attributes for filtering and
reporting purposes.

Copying Test Assets with Read-Only Rights

Test assets can now be copied by users who have read-only rights for a project. They can then be pasted
into projects where that user has write privileges.

Issue Manager Enhancements

Issue Manager, Silk Central's built-in issue tracking solution, has been significantly enhanced in Silk
Central 18.5.

Seamless Integration

Issue Manager takes a further step in the direction of seamless integration by optionally reusing the
already existing user context to login to a local Issue Manager instance.

Updated User Interface

The Issue Details page has been redesigned to provide relevant information about an issue at a glance,
and to more efficiently work with issues.

i Mew Issue Edit | Reassign | Fixed | CannoctFix | AsDesigned | W More Go to [ssue #

#6 - Check-out sum incorrect

Severity: 1: Severe Bug | Inbox: admin | 5State: Dev-Ready | Reason Code: --- | Action Release: --- | ¥ 0 | &4 g
Issue Type: BUG Platform: General
Product: Demo Product Compaonent: Charging Unit
Release: 31352 Created By: dbrauer

Description  History  Custormers  Traceability  Custom

Integrations
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Integrated Mobile Center Support

Silk Central 18.5 now integrates with Mobile Center for executing your automated functional tests on mobile
devices and to additionally provide those mobile devices to Silk Test for automated functional test creation
and execution.

Specifying a Branch in Git Source Control Profiles

You can now define a specific branch in your Git source control profile, which will be checked out for all
execution plans that use this profile. You can still use a different branch for a specific execution plan by
specifying the branch name in the Source Control Label field of the respective execution plan.

12 | What's New in Silk Central 18.5



Getting Started

Silk Central promotes product quality throughout the development cycle.

Today's e-business systems are increasingly complex, and reliability is more important than ever.
Therefore, assuring product quality throughout the development cycle is an important key to success. The
best way to check a product’s quality over time is to perform key tests on a daily basis. Silk Central helps in
this regard by automating test executions that follow freely configurable schedules, both during product
development and after deployment. By providing reports with different levels of detail, checking the status
of products in development is as straightforward as checking an HTML report in a Web browser.

With complex software projects, thorough testing of new builds is critically important. Silk Central saves
time and man hours by automating this process.

Installing and Licensing Silk Central

For information regarding the installation and licensing of Silk Central, refer to the Silk Central Installation
Help, which is also available from both the Silk Central installation DVD and the Silk Central download site.

Silk Central Concepts

This section explains the basic concepts of Silk Central, including the basic workflow, the available assets,
and what they are used for.

Workflow

Silk Central's test management workflow consists of four major activities: Defining requirements, designing
tests, execution planning and executing tests, tracking and analyzing test results.

Requirements Execution Planning & Results Analysis

01 03 04

Defining requirements

Tk
Designing tests

e Execution planning and executing tests

mTracking and analyzing test results
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Requirements

A requirement is a condition or capability that a user needs to achieve a specific task, which must be met by the
application under test (AUT). Associate your requirements and tests to enable measuring how well your software
covers the specified requirements. Multiple tests can cover a single requirement and multiple requirements can
be covered by a single test. For additional information, see page 45.

Tests

A test, or test case, is a set of input values, execution preconditions, expected results and execution
postconditions, developed for a particular objective or test condition, such as to exercise a particular program
path or to verify compliance with a specific requirement [after IEEE 610]. Silk Central supports various test types,
and tests can be structured in several ways. For additional information, see page 94.

Test types

=

HET

Manual tests are step-by-step instructions for testers. Silk Central provides a Ul to efficiently execute manual
tests, including the option to record videos and capture screen images during test execution. If desired, manual
tests can later be converted to automated tests. For additional information, see page 137.

A keyword-driven test is an executable collection of keywords. A keyword-driven test can be played back just like
any other test. Silk Central and Silk Test support the keyword-driven testing methodology and allow a very close
collaboration between automation engineers and business analysts by having automation engineers develop a
maintainable automation framework consisting of shared assets in the form of keywords in Silk Test. These
keywords can then be used by business analysts either in Silk Test to create new keyword-driven tests or in Silk
Central to convert their existing manual test assets to automated tests or to create new keyword-driven tests. For
additional information, see page 144.

Unified Functional Testing (UFT) software, formerly known as HP QuickTest Professional (QTP), provides
functional and regression test automation for software applications and environments. For additional information,
see page 155.

JUnit is a unit testing framework for the Java programming language. Use this test type for JUnit, Silk4J, and
Selenium tests. For additional information, see page 156.

NUnit is a unit testing framework for the Microsoft .NET programming language. For additional information, see
page 159.

MSTest is a command line utility from Microsoft that executes unit tests created in Visual Studio. Use this test
type for MSTest and Silk4NET tests. For additional information, see page 158.

The ProcessExecutor test type can be used to execute any command line. For additional information, see page
160.

The Silk Performer .NET Explorer test type is used to execute .NET Explorer scripts or a specific test case of a
script. For additional information, see page 161.

Silk Performer projects can be integrated into Silk Central tests and directly executed through Silk Central. This
allows for powerful test-result analysis and reporting. It also enables unattended testing, which means tests are
run automatically by Silk Central based on pre-configured schedules. For additional information, see page 162.

Silk Test Workbench is an automated testing tool that accelerates the functional testing of complex applications.
Silk Test Workbench provides support for testing applications developed in a wide variety of development tools
including Java, .NET, browser-based web applications, and COM components, including both ActiveX controls
and automation objects. For additional information, see page 164.

Silk Central’s Silk Test Classic interface offers a reliable means of automating Silk Test Classic users. Each test
case of a Silk Test Classic script executes within its own test execution and produces its own results. For
additional information, see page 162.



= The Silk Test Classic Plan test type is used for Silk Test Classic test plans. A test plan usually is a hierarchically-
structured document that describes the test requirements and contains the statements, 4Test scripts, and test
cases that implement the test requirements. For additional information, see page 162.

. TestPartner is a Micro Focus product that tests Web- and Microsoft Windows-based applications that use
Microsoft technologies. For additional information, see page 166.

Test structure

7 Test containers are used to structure your test assets at the top level. Silk Central associates a defined source
control profile and a product per container, which impacts what you can do with tests within a specific container.
For additional information, see page 131.

[ Use folders to structure your tests within a container. For additional information, see page 133.

J4; Test packages provide support for the structure of third-party test types in Silk Central, and consist of a package
root as well as an arbitrary hierarchy of suite nodes and test nodes. For additional information, see page 134.

Execution Planning

The Execution Planning area enables you to maintain control over test executions during development
and testing. This includes activities like configuring execution plans, scheduling execution plans, assigning
tests to execution plans, setting up execution plan dependencies, configuring execution-server deployment,
and configuring dynamic hardware-provisioning with keywords.

# An execution plan is a collection of assigned tests that are stored in a single test container. An execution plan
can be run at configurable schedules and deployed on specified execution servers. For additional information,
see page 256.

] Configuration testing is the process of testing a system with each of the supported software and hardware
configurations. You can create configuration suites with a set of assigned tests, and all execution plans that you
add to the configuration suite will also have the set of tests assigned. For additional information, see page 251.

fm Atesting cycle is a defined period in time consisting of a start date, an end date, and a list of manual testers.
Create testing cycles to plan and execute specific sets of manual tests. For additional information, see page
226.

£z Use folders to structure your execution plans, configuration suites, and testing cycles. You can also nest folders
within folders. For additional information, see page 256.

User Interface

This section provides an overview of the Silk Central user interface.

Tour of the Ul

This topic provides an overview of the Silk Central user interface.

Silk Central [ Tests | Execution Planning | Tracking | lssues | Reports |[DRINY
> o) B B #7 | <NoFilter> [x] L b
Requirements * | | Properties | Attachments || Assigned Tests | Coverage | History

4 8] Project 'Demo Project’
General Requiremente.. Project Name Demo Project
Safety Regulations Changed Project ID 0 |
Toalbar lcons Description This is a project for demonstration purposes
Easy to use - MSWI Created On Tue, Aug 22, 2006 - 9:56:23 AM
Optimally align to target-business - MSWI Created By admin
Changed On Sun, May 12, 2013 - 5:22:16 PM

Changed By admin
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Basic Ul Structure
The Ul of Silk Central includes:

* The Menu: Placed across the top of the user interface. It gives you quick access to the functional units
of Silk Central.

* The Workspace: In this example, the Workspace is the tabbed region showing the functional work area
of the currently selected Silk Central unit. This view changes based on the unit you are working in.

The Units of Silk Central

The Menu gives you quick access to the functional units of Silk Central. It includes the following major
sections:

Home

Displays the dashboard, which is your personal starting area. You can customize the dashboard by adding
and arranging various panels, which give you the information you need for your daily work.

Requirements

Displays and enables you to maintain control over your project's requirements during development. You can
perform the following tasks:

« Create, modify, and delete requirements.

» Associate tests with requirements.

» Track the change history of requirements.
« Generate test plans from requirement lists.

You can additionally access and manage the following:

* Properties of the requirements.

* Integrated external requirement-management tools.

« Requirement filters.

* Notifications that inform you about changes to the requirements.

Tests

Enables you to create and manage automated and manual tests. You can additionally access and manage
the following:

« Libraries, out of which commonly-used manual tests, test steps, and keywords can be reused.
« Properties of the individual test steps for manual tests.

* Properties of keywords for keyword-driven tests.

« Test attributes.

* The data sources that can be used for tests.

« Source control profiles, in which these tests are stored.

» Test filters.

* Notifications that inform you about changes to the tests.

« Version and build of the product that is tested with a specific test.

Execution Planning

Displays and allows you to manage the executions that execute the tests. You can perform the following
tasks:

« Configure execution plans.
» Assign tests to execution plans.
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» Set-up execution plan dependencies.

« Configure execution-server deployment, including the execution servers on which the tests are
executed.

« Plan and manage the manual execution of tests.
You can additionally access and manage the following:

» Execution filters.

» Execution schedules.

« Version and build of the product that is tested with a specific execution of a test.
« Notifications that inform you about changes concerning the execution process.

Tracking

Displays the Activities page, the Cross-Project Activities page, the Project Overview Report, and
Quality Goals.

The Activities page displays the activity for recently-executed, current, and upcoming execution plans on a
per-project basis.

Issues
Displays and enables you to manage the issues that are related to the active project.
You can additionally access and manage the following:

* Projects in Issue Manager, when issues reside in Issue Manager.
« External issue tracking profiles, in which issues may possibly reside.

Reports

Displays and enables you to manage the reports which provide you with information on the requirements,
tests, and execution plans. You can perform the following tasks:

« Generate reports.

« Download report templates.

« Edit report parameters.

« Create new reports based on pre-installed templates.

Additionally provides access to code analysis functionality information, with which you can evaluate the
degree to which the code in your Application Under Test (AUT) is covered by test cases. You can then
make informed estimates regarding effort, cost, and risk associated with specific code changes.

Global Search

The Search field allows you to perform a search across several assets in Silk Central. The following assets
are considered when submitting a global search:

« Requirements and their properties

« Tests, folders, test containers and their attribute values, properties, and parameters
« Test steps and their properties

< Execution plans, configuration suites, testing cycles, folders and their parameters

e Library folders, steps, and shared steps

» Issues (searched by synopsis and description)

Note: The search index is updated in the background on a regular basis. The search results may
occasionally be slightly outdated.

Search rules:

Getting Started | 17



* The search is case-insensitive.

« All entered words are searched for separately. tems match the search if at least one word is found, and
the more words match the query, the higher the rating of the match is.

« Prefix words that must match the query with a +. For example "+test +type" will only return results
that match both "test" and "type".

» Prefix words that may not match the query with a -. For example "test -copy" will return results that
match "test", but not "copy of test".

« To search for an exact match, put your search words inside quotes, for example ""customer account
management".

< To limit the search to the item's name, or to the description, prefix the search word with name: or
description:, respectively. For example name:test will only return results where the item's name
contains the word test.

« Common English words like 'a’, 'the’, ‘and' are ignored.
Example:
name:""test item" -description:closed

This will return items where the name contains the phrase "test item" and the description does not
contain the word "closed".

Projects

Displays and enables you to manage all projects in your Silk Central installation from a high-level test-
manager’s view. Additionally enables you to switch between projects, and manage project settings.

User
Displays and enables you to manage user settings. Additionally enables the following:

« Log out of Silk Central.
e Print the current Silk Central page.

« Bookmark the current Silk Central page. This is especially useful for bookmarking reports, where the
current parameters are saved in the book-marked URL.

Administration

Displays and enables you to manage the administration settings. For additional information, see the
Administration topics in this Help.

Help
Click to view context-sensitive help for the current page. Additionally provides access to the following:

* The Silk Central documentation.
« Tools that are shipped with Silk Central.
* About. Shows version and license information.

Context Menu Commands

Silk Central supports Windows-style context menus across many test management elements, for example
tests, requirements, execution plans, folders, containers, reports, and more. Available through right mouse-
click, context menu commands typically include those commands that are available from each unit's
toolbar. For elements listed in tree views, context menus offer commands for expanding and collapsing tree
view elements. Commands that are not available to selected elements are disabled.
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Dashboard

The dashboard in Silk Central is your personal starting area. You can customize it by adding and arranging
various panels, which give you the information you need for your daily work.

When you log in to Silk Central for the first time, the dashboard shows just the Introduction panel. On the
top, your last login date and time is displayed. You can quickly Resume where you left off by clicking this
link.

Click the buttons on the top, to perform the following actions:

* Click Add Panel to add further panels to the dashboard.

* Click Change Layout to change the layout of the dashboard.

* Click Reset Dashboard to set the dashboard to the default view. All the panels you added and your
customized settings are removed.

To arrange your panels, click on the header of a panel and drag it to the desired position. Resize your
panels by dragging a panel's footer (only panels with lists are resizeable).

Click the buttons in the header of a panel to perform the following actions:

Click Esf to remove the panel from the dashboard.

Click B to configure the settings of the panel.

click IFl to save the content of the panel as a PDF.
* Click [=lto print the content of the panel.

You need certain permissions to view or edit the content of the different panels.

Adding Panels to the Dashboard

To add a panel to the dashboard:

1. In the menu, click Home > My Dashboard.

2. Click Add Panel on the top left. The Add Panel dialog box appears, listing the available panels along
with a short description for each panel.

3. Select a panel.
4. Click OK.

5. If required, select a Project and a Time Span for the panel. Select <Use current project> for the panel
to always display the data of the currently active project.

6. Click OK.

For most panels, you need to configure a project, as the panel will only show data for a certain project. You
can add several panels to show appropriate data for other projects side-by-side, or configure <Use current

project> for the panel to always display the data of the currently active project. Click -] (Configure) in the
header of a panel to configure a different project. You need certain permissions to view or edit the content
of the different panels.

Dashboard Panels

For most panels, you need to configure a project, as the panel will only show data for a certain project. You
can add several panels to show appropriate data for other projects side-by-side, or configure <Use current

project> for the panel to always display the data of the currently active project. Click = (Configure) in the
header of a panel to configure a different project. You need certain permissions to view or edit the content
of the different panels.

You can add the following panels to your dashboard:
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Panel

Description
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Assigned Issues

Custom Information

Introduction

Issue Life Cycle

Issues Created per
Tester

Manual Tests
Assigned to Me

Offline Manual
Testing Overview

Planned vs. Actual
Execution Time

Quality Goal
Progress

Report Subscription

This panel shows all issues (that are assigned to a test) of the selected project. If you click
the external ID, the issue opens in the external issue tracking system.

This panel shows customizable information about a certain project. Users with the Manage
projects permission can add content like text, images or hyperlinks to the panel. Click Edit
Content to open the HTML editor. Users without the Manage projects permission will just
see the content. The panel can be used to show news, descriptions or any other kind of
information relevant to the project.

This panel gives you a quick introduction to Silk Central. Click the links under What's New?
to get additional information about the latest features of Silk Central. You can also join the
Micro Focus Community or contact the Micro Focus SupportLine.

This panel shows the number of Open, Fixed, Verified, Closed and Deferred issues for a
defined issue tracking profile. Select a Product from the list. To define an issue tracking
profile, click Issues in the menu, click Issue Tracking Integrations and click New Profile.
The panel will only show data, if there is a profile defined.

This panel shows the number of issues created by testers as a bar graph. When printed or
downloaded as a PDF, the numbers will be shown in a table as well.

This panel shows all tests of the selected project that were assigned to you.

If the manual test execution is organized with the help of testing cycles, the list also includes
all tests that are assigned to No specific tester on the Manual Execution Planning page.
However, this is only true for testing cycles you are assigned to as a tester. It is a typical
teamwork scenario that testers decide on their own which test to execute.

If the manual test execution is organized with the help of execution plans, the list also
includes the tests from all execution plans that have no tester assigned.

Click EF (Continue Manual Test) to open the Manual Testing window.

Click &= (View Manual Test Results) to open the view and see all data and attachments
about the test.

Click ' to get detailed information about the Test, the Execution Plan or the Execution
Plan Parent.

W
Right click a test and click =~ to download a manual test (in Excel format) to execute it
offline (multiple tests can be selected with Ctrl+Click or Shift+Click). After you execute the
test, click the Upload Offline Manual Test Results button to upload the results.

If you start a testing cycle (on the Manual Execution Planning page) before its start date,
the tests of this testing cycle already display in the panel. You can make those tests invisible

in the panel until the start date is reached: Click H in the header of the panel and check
Hide future testing cycles.

This panel shows the tests that are downloaded by testers and allows the Test Manager to
abort offline executions to free the license.

This panel shows if the testers of a testing cycle are on schedule with the test execution. If
the actually used time plus the remaining planned time is greater than the capacity, the
testing cycle is on risk to be not finished on time.

This panel shows a graph with two bars for each value of the selected quality goal. The
upper bar shows the number of tests that must be executed to meet the quality goal. The
lower bar shows the number of the Passed, Failed, Not Executed, and N/A (not available)
tests with that quality goal value. If the lower bar is shorter than the upper bar, too few tests
are assigned to execution plans. This means that the quality goal cannot be reached. Select
a Quality Goal from the list.

This panel displays the results of a report subscription. The report subscription must already
be defined and you need to select Provide for dashboard and external access from the
Edit Subscription dialog box to make it available.




Panel

Description

Requirements
Coverage Status

Silk Central Connect

Silk Performer
Performance Trends

Status of Currently
Running Manual
Tests

Testbook

Testing Cycle
Progress

Testing Cycle Result
Summary

Testing Cycle
Timeline

Testing Progress
Across Testing
Cycles

Volatile Tests

This panel shows the requirement coverage of the selected project, broken down into

Passed, Failed, Not Executed, and Not Covered requirements. Click |7/ to go to the
Requirements Document View.

Silk Central Connect combines aspects of test execution management and configuration
testing into an easy to use interface, providing the following advantages:

« Simple execution of all your automated unit tests on a variety of configurations, which are
combinations of operating systems and Web browsers.

» Leverages the advantages of the Amazon Web Services, enabling you to easily access a
variety of configurations without any upfront investment.

« Tight integration between Silk Central Connect and Silk4J for easy test creation,
maintenance, and execution.

» Side-by-side result analysis, enabling you to compare all of your tests across the different
configurations.

For detailed information, see Silk Central Connect.

The Silk Performer Performance Trends panel displays the current status of the selected
Silk Performer load test and its available results, including trend information over the last
runs.

This panel shows the status of all currently running manual tests in the specified project.
Test managers are able to see which tests are currently blocked and they can monitor the
status of already executed tests in running executions.

This panel shows you real-time updates about all activities that take place during manual
testing. Activities that are logged in the Testbook are starting and finishing tests and editing
running testing cycles. For more information, see Testbook.

This panel shows a burn-up chart of Passed, Failed, In Progress, and Not Executed tests
for the defined testing cycle. It also shows the milestones (as diamonds), if you have
specified any. Select a Testing Cycle from the list.

This panel shows the status of the selected testing cycle and the progress status of the
individual testers that are assigned to the testing cycle. The bars show in the following order:
the number of Tests failed, Tests remaining, and Tests passed. The tester with the most
failed tests displays on the top of the list. The nhumbers to the right of the bars show the
Tests completed (left number) and the Tests assigned (right number). No specific tester

is treated and ordered like all other testers. Click .7/ to go to the Test Assignment view of
the Manual Execution Planning page.

This panel shows all testing cycles of the selected project as bars on a timeline. When you
click on a bar, you are directed to the Manual Execution Planning page. The bars have
different colors, depending on the current status of the testing cycle: blue (in progress),
orange (not yet started), gray (finished). Move your mouse over the bars to get detailed
information about the testing cycle.

This panel shows the time in hours for the Planned tests (visualized by a line) and for the In
Progress and the Completed tests (both visualized by stacked areas). The panel helps a
test manager to predict if the testing team will be able to finish the tests in time. The start
date of the chart is the start date of the first testing cycle. The end date of the chart is the
end date of the last testing cycle. The panel does not show how long it actually took the
testing team to execute the tests.

This panel shows how often tests changed their status within an execution plan. Tests
without status changes and test packages do not display in the panel. Tests display
according to the selected project and time span. The panel makes test managers aware of
such volatile tests, which indicate either an unstable test or a tested area where bugs occur
frequently.
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Silk Central Connect

Silk Central Connect combines aspects of test execution management and configuration testing into an
easy to use interface, providing the following advantages:

« Simple execution of all your automated unit tests on a variety of configurations, which are combinations
of operating systems and Web browsers.

» Leverages the advantages of the Amazon Web Services, enabling you to easily access a variety of
configurations without any upfront investment.

» Tight integration between Silk Central Connect and Silk4J for easy test creation, maintenance, and
execution.

« Side-by-side result analysis, enabling you to compare all of your tests across the different
configurations.

Overview

Silk Central Connect offers a new way to harness the power of the cloud to test Web applications across
desktop and mobile Web browsers without the pain of setup or configuration. Silk Central Connect:

* Reduces the time and effort required for cross browser testing by up to 80%
« Lowers total cost of ownership by eliminating the need to setup hardware for different browsers
» Resolves issues faster by visually identifying where applications fail on different browsers

For information about Silk4J, refer to the Silk4J User Guide.

For information about configuring your test environment, see Setting Up Execution Servers.

Silk Central Connect Architecture

Silk Central Connect is based on Silk Central's architecture. Additionally, it allows you to use cloud-based
execution servers. If you are testing an internal Web application on your intranet using cloud-based
execution servers, you can configure the tunnel settings for local intranet website testing. With this setting,
the Silk Central application server opens a tunnel to cloud-based execution servers and acts as a proxy to
allow testing a website in your local intranet. Note that this option is slower than a direct connection, so
only select it if needed.
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Prerequisites
To work with Silk Central Connect, the following prerequisites are required:

« Silk Central needs to be installed in your environment.
« Silk4J, the Silk Test plug-in for Eclipse, needs to be installed in your environment.

Configuring Source Control

To enable Silk Central Connect to store end execute tests, you have to integrate Silk Central Connect with
your Subversion (SVN) source control system.

1. On the Silk Central Connect panel, click Configure Subversion Source Control.

2. Type the URL of your Subversion repository into the URL field. If no SVN repository is configured, Silk
Central Connect automatically configures a file-based repository.

A Important: A file-based repository is for evaluation purposes only and should not be used in
*~ production. Also, this repository can only be accessed on the local machine, and Silk4J must also
be installed on this computer.

For example, if the location of your Subversion server is http://svn.mycompany.com, and the repository
is located under TestAutomation/trunk, type http://svn.mycompany.com/
TestAutomation/trunk into the URL field.
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3.

4.

Configure Subversion Source Control x

URL: http://svn.mycompany.com/TestAutomation,/ trunk
sername: admin
Password: sersnsas
Save Cancel

Type a valid Username and Password. These credentials will be used to access your repository for all
projects. If you are using a file-based repository, no Username and Password is required.

Click Save.

Creating your Web Application Tests

Directly after installing Silk Central Connect and configuring Subversion, you can create a new project for
your Web application. Then you can use the built-in verification run to take a first screenshot of the Web
application in each of the browsers that are available on your local machine.

1.
2.

o g s~ w

7.
8.
9.

On the Silk Central Connect panel, click New Project. The New Project dialog box displays.

If you are using Silk Central Connect in a full Silk Central environment, you can choose to add your new
Silk4J project to an existing Silk Central project or to create a new Silk Central project.

If you are creating a new project, type a name for the new project into the Project Name field.
Type the URL of the test application into the URL field.
Click OK.

Optional: If you are testing an internal Web application on your intranet using cloud-based execution
servers, click Tunnel Settings and select Local intranet website. With this setting, the Silk Central
application server opens a tunnel to cloud-based execution servers and acts as a proxy to allow testing
a website in your local intranet. Note that this option is slower than a direct connection, so only select it
if needed.

Click Run Tests.

Select all available configurations.

Click Run Tests.

10.Click Refresh to see if the execution is finished.
11.When the execution is finished, click on the start time link. You can see the test result for every

configuration. The default test case is called validateAppearance.

12.Click on the test result of the first configuration. You can see details for the test result, including a

screenshot of the test application. You can click on the screenshot to enlarge it.

13.Click through the results to see how the application looks on all configurations.
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Customizing Your Web Application Tests
To perform the actions described in this topic, the following prerequisites are required:

» To be able to record tests with Silk4J, a current version of Internet Explorer needs to be installed on
your system. For a list of the supported versions, refer to the Release Notes.

« For a list of the supported browsers for replay, refer to the Silk Test Release Notes.

« To test against mobile browsers, you need to install an emulator on your system or connect a mobile
device to your system. For additional information on testing mobile Web applications, refer to the Mobile
Testing Tutorial.

After you have created a project for a Web application, you can add additional tests or enhance the existing
tests to test additional functionality of the Web application.

1. To open a project in Eclipse, perform one of the following:

¢ On the Silk Central Connect panel, click Open with Silk4J in the Action column that corresponds to
the project.

* On the overview page of the project, click Open with Silk4J.

When creating a Silk Central Connect project, an Eclipse project template is committed to your specified
source control, containing the following assets:

* src folder: The location where new tests are stored

< Lib folder: To use additional java libraries in your Silk4J project, add them to this folder. Silk Central
Connect adds all jar files that are located in this folder to the classpath when executing the tests.

e build.xml: A preconfigured ANT build file that Silk Central Connect uses to build the tests before
execution.

e Other Eclipse-related files

2. Record additional tests in Silk4J.
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a)
b)

c)
d)

e)

f)

)
h)
i)

In the Package Explorer, select the project to which you want to add the new test.
On the toolbar, click Record Actions.

< If a Silk4J test class is open in Eclipse, the recorded actions are recorded into this file.

« If no Silk4J test class is open in Eclipse, the recorded actions are recorded into a new Silk4J test
class file.

The Web application and the Recording window open. Silk4J creates a base state and starts
recording.

Perform the steps that you want to record against the AUT.
Click Stop Recording. The Record Complete dialog box opens.

EI} Record Complete P

Select the location where the recorded steps should be inserted:

Select ...

Source felder TestBorlandHomepage/src
Package (optional):
Test class: TestResources

Test method: OpenWhitePapersPage -

[ ok || caned |

The Source folder field is automatically populated with the source file location for the project that
you selected. To use a different source folder, click Select and navigate to the folder that you want to
use.

Optional: In the Package field, specify the package name.

To use an existing package, click Select and select the package that you want to use.
In the Test class field, specify the name for the test class.

In the Test method field, specify a name for the test method.

Click OK.

For information about Silk4J, refer to the Silk4J User Guide.

a)
b)

. Ensure that the test works as expected in Silk4J.

On the Silk4J toolbar, click Run selected Silk4J test(s).
On the Select Browser dialog box, select the browser on which you want to replay the test.
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¢) Click Run.

If the test passes and the test results look as expected, you can add the test to the test set for the
project in Silk Central Connect.

4. On the Silk4J toolbar, click Commit to commit the changes in the project to the repository.

5. Back on the overview page of the project in Silk Central Connect, click Run Tests to execute all tests in
the project.

6. Select the configurations.

Run Tests *

Run tests on the fellowing configurations:

Chrome 31 -
Firefax 21
Internet Explorer 10

Run Tests Cancel

7. Click Run Tests.

8. When the execution is finished, click on the start time link. You can see the test result for every test and
every configuration.
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If all tests have run as expected on all configurations, you can further enhance the test set or schedule the
project for repeated execution.

Running Your Web Application Tests on Multiple Browsers in Parallel

When you have verified that the Web application looks as expected on all available browsers on your local
machine, you can add additional execution servers to your testing environment to execute the tests for your
Web application on multiple browsers in parallel.

To test your Web application on additional browsers, you have the following three options:

1. Install additional browsers on the existing execution servers.
This option enables you to test additional browsers, but it increases the time required to run the test set
against your application under test, because the browsers are tested sequentially on the execution
servers.

2. Add additional execution servers to your testing environment.
This choice enables you to test additional browsers without significantly increasing the execution time of
your test set. The tests are distributed between the execution servers based on the available browsers
on each server. However, this option increases your hardware requirements. For additional information
on adding an execution server to your testing environment, see Configuring Physical Execution Servers.

3. Connect to the cloud.

i Note: To be able to execute your tests in the cloud, you need a cloud provider account.

This option enables you to test a great variety of browsers without increasing the execution time of your
test set and without requiring additional hardware. The additional cost is directly related to your testing
effort, which means the frequency at which you are executing your test set and the size of your test set.

For information about configuring your test environment, see Setting Up Execution Servers.

For information on running keyword-driven tests across multiple browsers, see Cross-Browser Testing with
Keyword-Driven Tests

Analyzing Test Results

After running a test, you can review the test results.
1. On the Silk Central Connect panel, you can see the status of the last test run of all your projects.

Status Last Run -

4, Thu Mow14, 2013 - 11:20:14 AM
Fri Oct 25, 2013 - 2:53:00 PM
Thu Oct 24, 2013 - 3:09:32 PM
Thu Oct 24, 2013 - 9:26:22 AM

Wed Oct 23, 2013 - 1:24:21 PM

=]
(2]
(2] (2]
]
-

3 Wed Oct 23, 2013 - 10:42:04 AM
2. To see the results of all tests and all test runs for a specific project, click on the name of the project.
The project overview page opens.
Test Results

= start Time: [ Thu Nov 14, 2013 - 11:20:14 AM

#  Chrome Oh1lm 54=
#  Firefox 20 P 0hlmiss
#  Internet Explorer 10 Pl 0h2més
#  Internet Explorer 9 P 0hlm 27s

28 | Getting Started


http://documentation.microfocus.com:8080/help/index.jsp?topic=%2Fcom.microfocus.sctm.doc%2FSCTM-8D632EEB-SETTINGUPEXECUTIONSERVERS-CON.html
http://documentation.microfocus.com:8080/help/index.jsp?topic=%2Fcom.microfocus.sctm.doc%2FGUID-81041900-6AD7-46FE-9E85-A3DA0809A052.html
http://documentation.microfocus.com:8080/help/index.jsp?topic=%2Fcom.microfocus.sctm.doc%2FGUID-81041900-6AD7-46FE-9E85-A3DA0809A052.html

3. On the Test Results page, click on the status of a specific test result to see the result of the test run for
every configuration.

nteimes Exphoser
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4. On the Test Results page, click on the status of a test to view detailed information, including error logs
and TrueLog files.
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Scheduling Your Tests for Continuous Execution
You can schedule your projects to execute all the tests in the project at the same time each day.

Note: If you are using Silk Central Connect within a full Silk Central environment, you can use the
more advanced scheduling features in Execution Planning > Details View > Schedule

instead.

1. On the Silk Central Connect panel, click on the name of the project, which you want to schedule for
daily execution.

2. On the overview page of the project, click Schedule Tests.
3. Onthe Schedule Tests dialog box, specify the time when the test execution should start each day.
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Schedule Tests *

Specify the time when tests should be started each
day:

1 [=]: 40[=] Pm[=]

Run tests on the fellowing configurations:

Save Cancel

4. From the list of available configurations, select the configurations on which the tests should be
executed.

If you have already executed the tests in the project, the configurations that were used for the last run
are pre-selected. If you have not executed the tests, all configurations are pre-selected.

5. Click Save.

All tests in the project will be executed on the selected configurations and at the specified time each day.
The scheduled time is displayed in the overview page of the project. You can remove the schedule by
clicking the remove button next to the schedule.

Frequently Asked Questions

This section provides answers to frequently asked questions about Silk Central Connect.

Why Do My Silk4J Tests Fail?

If executing Silk4J tests from Silk Central Connect does not work, the connection between Silk Central
Connect and Silk4J might not work. You can try the following to establish the connection: If Silk4J was
installed prior to Silk Central Connect, restart Eclipse or the Open Agent.

Dashboard Panel Permissions

To view or edit the content of a certain dashboard panel, you need the following permissions:

Panel Required permission
Assigned Issues View tests and executions.
Custom Information Manage projects required for editing.

No permission required for viewing.

Introduction No permission required.
Issue Life Cycle View project settings.
Issues Created per Tester View tests and executions.

Manual Tests Assigned to Me  Execute tests.

Planned vs. Actual Execution  View testing cycles and configurations.
Time

Quality Goal Progress View quality goals.
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Panel Required permission

Report Subscription No permission required.

Requirements Coverage View requirements.

Status

Silk Central Connect View tests and executions required to display information in the panel. Additional
permissions required to access other areas of Silk Central from the panel.

Silk Performer Performance View tests and executions

Trends

Status of Currently Running View tests and executions
Manual Tests

Testbook No permission required.

Testing Cycle Progress View testing cycles and configurations.
Testing Cycle Result Summary View testing cycles and configurations.
Testing Cycle Timeline View testing cycles and configurations.

Testing Progress Across View testing cycles and configurations.
Testing Cycles

Volatile Tests View tests and executions.

Adding a Report to a Dashboard Panel

Using any report available in the Reports unit, the Report Subscription panel of your dashboard allows
you to display an existing report. First, create and configure your report, and then add the panel to your
dashboard.

1. Inthe menu, click Reports > Details View.

Select a report in the Reports tree.

Click the Subscriptions tab.

Click Add Subscription. The Edit Subscription dialog box opens.
Give your subscription a name in the Name field.

To modify the subscription parameters, click Edit Parameters. The Edit Parameter dialog box opens.
Change the Value and click OK.

7. Select a schedule from the Schedule list. If the schedule you want does not exist, you need to create it.
You can also select no schedule, for example for subscriptions that will only be triggered based on the
outcome of a test execution.

8. Click Provide for dashboard and external access to make the report available in a dashboard panel.
9. Click OK. The new subscription is listed in the Subscriptions list.
10.In the menu, click Home > My Dashboard.

11.Click Add Panel on the top left. The Add Panel dialog box appears, listing the available panels along
with a short description for each panel.

12.Select Report Subscription. The Configure Panel dialog box appears, listing all available report
subscriptions.

13.Select a report subscription from the list and click OK. The panel is added to your Dashboard.

S

Browser Settings

To optimize the functionality and performance of Silk Central, adjust the following settings in your browser:

* Make sure that you enabled the cache of your browser.
< If you have problems accessing Silk Central through the browser, add the Silk Central server to the list
of trusted sites in your browser.
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For a list of supported browsers, refer to the Release Notes. In the menu, click Help > Documentation .
Click Silk Central 18.5 Release Notes.

Login and Logout

The procedures in this section explain how to log in to and out of Silk Central.

Logging in to Silk Central
To log in to Silk Central:

1. Navigate to the URL of your Silk Central installation.

2. On the Silk Central login page, enter your user name in the form <cl ient>\<username> and your
password.

When you login to Silk Central with a user of the default client, you do not need to enter the client name.
Just enter your user name.
Log in as Super User with the following default credentials:

e username: admin
e password: admin

3. If you check the Remember login check box, you will stay logged in until you close the browser tab.
The next time you access Silk Central, you will automatically be logged in again.

4. Click Login.

You will be directed to your personal Dashboard. You can quickly Continue working in your last visited
area by clicking this link on the top of the Dashboard page.

Logging out from Silk Central
To log out from Silk Central:

1. Inthe menu, go to User:<Username>.
2. Click Log out.

ick Start Tasks

Quick start tasks are high-level overviews of the main tasks that you will likely need to perform with Silk
Central. These tasks can serve as tutorials in guiding you step-by-step through the best practice usage of
the core functionality of Silk Central. For in-depth information, see the related sections in this help:
Requirements, Tests, Execution Planning, and Issue Tracking and Results Analysis.

Configuring Required Assets - Quick Start Task

Before you can start building up your testing framework, you need to at least configure a project and a
product and, if you plan to create automated tests, also a source control profile. You may also need to
configure certain other settings, like filters, properties, attributes, etc. You need SuperUser, administrator,
or project manager privileges to perform these tasks.

To configure the required assets, you will need to perform the following tasks.

Adding Projects
Silk Central manages requirements, tests, their execution and the results in the context of a project.
Therefore the first thing you have to do is to create a project.

To create a project:



1. Inthe menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

Click New Project. The Project Settings page displays.

Type a Project name and Description.

Select the Project Owner.

Optional: Enter Tags for your project. If you have many projects, project tags can help you filter them,

using the Tags column on the Project List page.

6. Optional: To create a project based on the Agile project template, choose Agile Project Template from
the Project Template list box.

7. To initialize the project as an Issue Manager project, click Initialize new project or Reuse existing

project. For more information, see Initializing Projects as Issue Manager Projects.

8. In the Shared Tests section, define whether the project is a repository project or not. Select one of the
following options:

ok~ wnN

* No test sharing: This project does not consume tests from other projects and its tests cannot be
used by other projects.

* Sharing tests: This project is configured as a repository project, so that other projects can use the
tests of this project.

* Consuming shared tests from: Select a repository project from which this project consumes
shared tests.

9. The Groups section includes lists of available and assigned groups. Assign the groups as required. Use
Ctrl+Click or Shift+Click to select multiple groups. You can also import groups from an LDAP server by
clicking Import LDAP Group. For detailed information, see Importing Groups from LDAP Servers. If no
user groups exist, you may assign them later after you have created them. You can also configure the
group/project assignment on the Group Settings page. Privileges vary based on user roles. For
information about user privileges, see User Roles and Permissions.

10.The Locations section includes lists of available and assigned locations. Assign the locations as
required. Use Ctrl+Click or Shift+Click to select multiple locations. If no locations exist, you may
assign them later after you have created them. You can also configure the location/project assignment
on the Location Settings page. For detailed information, see Managing Locations.

11.Click Save to save your settings. You are returned to the Project List page where the new project is
listed.

Adding Products

Silk Central tracks results of test executions in the context of versions and builds of one specific product.
Therefore a Product needs to be defined before tests can be created.

To add a new product:

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click New Product. The New Product dialog box displays.

Type a name for the new product in the Name field.

Type a description for the product in the Description field.

Check the Active check box to make this product available for association with tests.
Click OK to save the product.

No ok wbdhE

Note: When creating a product, Silk Central automatically creates a new default version 1.0 and a
new default build 1 for the new product.

Configuring Source Control Profiles

For automated tests, another requirement for test creation is a Source Control Profile. Automated tests in
Silk Central actually represent test scripts that are located in source control systems, which are accessed
via such source control profiles.
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For detailed information about source control profile configuration, see Source Control Profiles.

Defining Requirements - Quick Start Task

Manage your requirements so you can associate them with your tests to enable measuring how well your
software covers the specified requirements. Integrating external requirements management enables you to
coordinate the requirements management features of Silk Central with other tools you may already be
working with.

To manage your requirements, you will need to perform some or all of the following tasks.

Creating Requirements
Associate your requirements and tests to enable measuring how well your software covers the specified
requirements.

To create a new requirement:

1. Inthe menu, click Requirements > Details View .

2. In the Requirements tree, select a requirement or the root node.

3. ., . . . .
Click == (New Requirement) on the toolbar to create a new requirement on the same hierarchical
level, or L (New Child Requirement) to create it hierarchically beneath the selected requirement. The
New Requirement dialog box appears.

4. Type a Name and a Description for the requirement.

Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
description fields.

5. Optional: Uncheck the Inherit from parent check boxes. In this case the child requirement will not
inherit the properties from the parent requirement. By default, all check boxes are checked.

Note: In the Details View on the Properties page and in the Document View, inherited
properties are marked with asterisks (*).

6. Select the appropriate Priority, Risk, and Reviewed status from the lists.

7. If custom requirements were defined, they are listed below the Reviewed list. Type in the corresponding
field any custom property data that you want to track with this requirement. This is disabled for inherited
properties. For details regarding creating, editing, and deleting custom requirement properties, see
Custom Requirement Properties.

8. To finish creating a new requirement:

» Click OK to create the requirement and to close the dialog box.

* Click OK and New Requirement to create the requirement and to keep the dialog box open to enter
data for another requirement.

* Click OK and New Child Requirement to create the requirement and to keep the dialog box open to
enter data for a child requirement.

Generating Tests from Requirements

You can generate tests directly out of the Requirements tree and assign tests to specific requirements.
The Requirements tree serves as a template for the test folder/test structure of the new Tests tree.

To generate a new test from the Details View:

1. In the menu, click Requirements > Details View .

2. Right-click the requirement or project node that you want to convert into a test and select Generate
Tests. The Generate Tests from Requirements dialog box appears. This dialog box enables you to
specify whether the leaves, which means the lowest-level nodes, of the selected requirements sub-tree
should be converted into tests or test folders and whether the tree should be generated into a new test
container or an existing container.
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3. Enter a name for the new test container in the Enter Name field and select a product from the Select
Product list to create the container within the active Silk Central project.

The Select Product list is populated with the products that are configured by a project manager. For
detailed information, see Managing Products or ask your project manager.

4. If you have defined a source control profile, select the source control profile you want to use for
managing the test sources from the Select Source Control Profile list.

For detailed information on source control profiles, see Source Control Profiles or ask your Silk Central
administrator.

5. To include all child requirements of the selected requirement in the test, check the Include Child
Requirements check box.

The check box is checked by default.

6. To have the new tests automatically assigned to the requirements from which they are created, check
the Assign newly generated tests to Requirements check box.

If this option is not selected, tests must be manually associated with requirements.
Note: This option is not available when checking Generate test folders from requirement tree
leaves.
7. Click OK to create the test.
The new test has the same structure as the Requirements tree.

8. A message box displays. Click Yes to view the test in the Tests area, or click No to remain in the
Requirements area.

Integrating External Requirements Management Tools
Integrating external requirements management enables you to coordinate the requirements management
features of Silk Central with other tools you may already be working with.

For detailed information about integrating external requirements management tools, see Requirements
Management Tools.

Designing Tests - Quick Start Task

Design your tests to cover all related features with useful tests.

To design your tests, you will need to perform some or all of the following tasks.

Structuring Your Test Assets

Silk Central tracks results of test executions in the context of versions and builds of one specific product.
Therefore a Product needs to be defined before tests can be created. For automated tests, another
requirement for test creation is a Source Control Profile. Automated tests in Silk Central actually
represent test scripts that are located in source control systems, which are accessed via such source
control profiles. Both product and source control profile information are specified on Test Container level,
which therefore represents the top-hierarchy node of a test assets structure.

To get started, we'll simply create one container:
1. Inthe menu, click Tests > Details View .
2. In the Tests tree, select the root node to which you want to add the new container as a sub-node.

f Note: Containers cannot be nested, but you can add sub-folders to containers.

3. Click “@ on the toolbar or right-click on the node and choose New Test Container.

You can also right-click on the node and choose New Test Container.
A new container root node is added to the Tests tree and the New Test Container dialog box displays.
4. Type a Name and Description for the container.
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Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

5. Select any predefined Product that is to be associated with this test container from the list box. For
details on adding a product profile, see Adding Products.

6. Select a predefined source control profile from the Source Control profile list box.

If you do not intend to check out any test sources for the test container, for example if you only have
manual tests, select -—-.

Note: The Silk Central execution servers retrieve the program sources for the tests included in the
container from the defined source control profile. Depending on the specified path in your source
control profile, you can specify to use a sub-node in the Root node field of the test container.

7. Optional: Check the Clear working folder before a test is executed check box.
If checked, files that have been removed from the source control will also be removed from the working
folder. Default is checked.

8. To specify the default root path where the container is to be saved, click Browse... and navigate to the
location.

9. Optional: When Silk Central is integrated with Silk Performer, you can define the Custom data
directory and Custom include directory.

In Silk Performer, the Include directory is divided into a System Include directory and a Custom
Include directory. The Data directory is divided into a System Data directory and a Custom Data
directory. For additional information, refer to the Silk Performer documentation.

10.The Hidden Test Properties portion of the dialog box allows you to specify the test property types that
are to be displayed on the test container’'s Properties page, and the Properties pages of all test folders
within the container.

These settings do not affect the display of individual tests.
11.Click Edit to adjust the hidden test property settings. The Hidden Test Properties dialog box displays.
12.Uncheck the check boxes of all test types for which you want to have properties displayed.
13.Click OK to save your settings and close the Hidden Test Properties dialog box.
14.Click Save to save your settings.

Creating Tests
Create a test to test a specific feature of your software.

Silk Central supports several test types out-of-the-box. See Managing Tests and select the test type that
you want to create, then follow the instructions in the referenced topics.

Assigning Requirements to Tests
Associate your requirements and tests to enable measuring how well your software covers the specified
requirements.

To manually assign requirements to tests:

1. Inthe menu, click Tests > Details View .

2. In the Tests tree, select the test to which you want to assign requirements.

3. Click the Assigned Requirements tab.
Note: If you have created a requirements filter, you can select it from the filter list above the
Requirements tree. To create a new requirements filter, click Requirements > Details View in the
menu and click " on the toolbar.

All requirements that are available for assignment are displayed in the Requirements tree.
4. Select the requirements that you want to assign.

You can use your keyboard's Ctrl and Shift keys to select multiple requirements using standard browser
multi-select functions.



5. Click Assign All Filtered to assign all filtered requirements to the selected test, or drag your selection
and drop it into the Assigned Requirements area, or click « to the left of any requirement. Assigning
all filtered requirements is only enabled if a filter is selected and if you have either Manage
requirements or Manage assets permission.

Note: Newly generated tests can automatically be assigned to the requirements from which they
are generated by checking the Assign newly generated tests to requirements check box on the
Generate Tests from Requirements dialog box. This is the default behavior.

Execution Planning and Executing Tests - Quick Start
Task

To plan and execute your tests, you will need to perform some or all of the following tasks.

Planning and Executing Automated Tests
Create an execution plan to execute related tests together.

Creating Execution Plans
Create an execution plan to execute related tests together.

1. In the menu, click Execution Planning > Details View.
2. Select a folder or the project node in the Execution Plans tree.

3. Click @ (New Child Execution Plan) on the toolbar or right-click the folder, testing cycle, or node and
click New Child Execution Plan. The New Execution Plan dialog box appears.

4. Type a name and description for the execution plan.

Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

5. Select a test container from the Test Container list.

Note: You can assign only one test container to an execution plan. Only tests from this test
container can be executed.

The latest version and build that are defined within the product that the container belongs to are
populated automatically in the Version and Build lists.

6. Select a product Version and Build from the lists.

These are used when a new run of this execution plan is started. Alternatively, you can check the Read
from Build Information File check box. In this case the version and build are read from the build
information file on the application server at the beginning of each run. If a build information file is
available on the execution server, this file is used by default for the test run, overriding the settings on
the New Execution Plan dialog box.

7. Select a Priority for the execution plan from the list.

For automated execution plans, when more than one execution plan is queued but only one execution
server is available, the Priority determines which execution plan is executed first. The same is true if
execution servers are available but multiple execution plans require an unavailable mobile device.

8. In the Source Control Label field you can optionally specify that the execution plan is of an earlier
version than the latest version. The label must refer to a version in the source control system that the
test container is associated with. If this field is left blank, the latest version of the execution plan will be
fetched. The Source Control Label property is only enabled if the associated test container uses a
source control profile that supports versioning. Make sure to have enough free disk space on the
execution server or servers when working with multiple versions of source files. Each version will be
saved in its own folder on every execution server.
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9.

| Tip: If you want to check out a specific branch of your repository for a specific execution plan,

~ specify the branch name in the Source Control Label field of the respective execution plan.

Click OK to update the Execution tree with the newly created execution plan.

Manually Assigning Tests to Execution Plans
Manually assign a test to an execution plan to add it to the included tests.

Hpw DN

In the menu, click Execution Planning > Details View.
Select the execution plan to which you want to assign the selected tests.
Click the Assigned Tests tab.

Click the Manual assignment option. All tests of the test container which is associated with the
selected execution are displayed in the Tests tree. If you have created a test filter, you can select it from

the filter list above the Tests tree. To create a new test filter, click Tests in the menu and click - (New
Filter) in the toolbar.

Select the tests that you want to assign.

You can use your keyboard's Ctrl and Shift keys to select multiple tests using standard browser multi-
select functions.

Drag your selection and drop it into the Assigned Tests area, or click + left of any test.
Assigning a folder or the top-level container assigns all child tests of that parent to the selected
execution plan.

i Tip: Right-click a node to expand and collapse it.
(2]

Starting Execution Plans
Execute individual execution plans to run them independent of a schedule.

In the menu, click Execution Planning > Details View.

In the Execution Plans tree, select the project, execution plan, folder, or configuration suite that you
want to execute, or use Ctrl+Click or Shift+Click to select multiple elements.

Click 4 (Run) on the toolbar. This is disabled for testing cycles, execution plans within testing cycles,
and unassigned tests. The Run dialog box appears.

Define which tests you want to execute in the Run dialog box.

Check the Go to Activities page check box to advance to the Activities page after you define tests for
execution.

Planning and Executing Manual Tests

This walkthrough shows you features of Manual Execution Planning using an example. The assumptions
for the example include:

The requirements are fully documented and categorized according to a Risk property.

575 manual tests are fully documented, assigned to requirements, and categorized according to an
Importance attribute which defines the necessity for executing a specific test.

Quality goals, which are also called project exit criteria, have been defined based on the requirements
property Risk and the test attribute Importance. These quality goals specify the levels of testing
required.

The only tests to plan are the ones that best fulfill the quality goals.

Overview

The Manual Execution Planning page consists of four areas presented on two screens. On the first
screen, the Test Selection screen, you can select and schedule your tests for a testing cycle. On the
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second screen, the Test Assignment screen, you can assign the tests of the selected testing cycle to the
testers who will execute them.

The Test Selection screen is divided into three areas:

* The Filter Criteria area on the left side. With the filter capabilities, you can narrow down the tests
shown in the next area.
* The Matching Tests area in the middle. This list shows all available tests. When you apply filters, just
the filtered tests are shown.
* The Testing Cycles area on the right side. Here you can assign tests from the list in the middle to a
certain testing cycle, which is a defined time period.

Filter Criteria

Filter Summary
No filters applied,

Tests Filter
7 | <N Filter> 7 R
Quality Goals/Assignment Progress
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To access the Test Assignment screen, click Test Assignment >>> on the top right. This screen is
divided into two areas:

* The Testing Cycles area on the left side. This is the same area as on the Test Selection screen, it is
shown on both screens.
* The Assigned Tests area on the right side. This list shows the tests, which have been added to the
currently selected testing cycle. Here you can drag the tests from the list to the Testing Cycles area
and drop them on a tester.
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Getting Started | 39



Creating a Testing Cycle

The first step is to create a testing cycle. A testing cycle is a defined period in time consisting of a start
date, an end date, and a list of manual testers. We will name our testing cycle Week 21 - Team A.

1. In the menu, click Execution Planning > Manual Execution Planning.

2. In the Testing Cycles area on the right side, click New Testing Cycle. The New Testing Cycle box
appears.

3. Enter a name for the testing cycle, in our case Week 21 - Team A.

4. Optionally enter a description.

5. Click [/ next to Start date to set the start date of the testing cycle.

6. Click 7 next to End date to set the end date of the testing cycle.

7. In hh-mm format, enter the amount of time that you want to provide for this testing cycle (Capacity), in
our case, we entered 35:00.

8. Click OK.

Our testing cycle now appears in the Testing Cycles area. It shows that currently no testers are assigned.
The next step is to assign testers.

MNew Testing Cycle X

MName: Week 21 - Team A
el BIUASAYEES @@ EE B
This is the testing cycle of week 21 for team A.
Start date: Aug 07, 2017 [
End date: Aug 11, 2017 [
Capacity [hh:mm]: 35:00
oK Cancel

Adding Manual Testers

The next step is to add manual testers to our testing cycle. We are also going to define the capacity each
manual tester has for this testing cycle.

1. In the header of our testing cycle Week 21 - Team A, click ... > Edit Assigned Testers. The Edit
Assigned Testers dialog box appears.

Click Add/Remove Testers. The Add/Remove Testers dialog box appears.
Select a user group from the Available list.

Select one or more users from the user group in the Available list.

Click Add or Add All to add users to the Selected list.

o~ WD
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6. Click OK. The users are now added to the list in the Edit Assigned Testers dialog box.

7. For each user that was added, provide a capacity for the testing cycle in the Capacity field using the
hh:mm format.

8. Click Close.
Now our testing cycle shows the available resources, both for the whole testing cycle as well as for each
manual tester. A burn-down chart displays the assigned tests that are not yet completed. After we have

created our testing cycle and added manual testers, we can determine which tests need to be done in the
next step.

Add/Remove Testers *x

Available Selected
Testing Team v Adam Anderson
bpeterssen dbrauer

jallen Add » gmazzuchelli
kchang htanaka

mrajan Add All »>

mrichardson

smiller < Rermove

ssolomen

<< Remowve All

8] 4 Cancel

Selecting Tests and Scheduling

This topic describes how to assign tests to our testing cycle. The goal is to select those tests that best
cover the defined quality goals. One of the quality goals is based on the requirement risk. The typical
practice is to test things with high risk first.

1. In the Filter Criteria area on the left side, under Quality Goals, check the Requirement Risk check
box. The list of Matching Tests is narrowed down to the tests that are critical.

2. In the Matching Tests area, open a column header's context menu to sort, filter or group tests. That
helps to select the tests that should be scheduled.

3. Select one or more tests, drag them to the Testing Cycle area on the right side and drop them to our
testing cycle. When adding tests to a testing cycle, the indicator for already used resources is updated.
Move the mouse over this indicator for detailed information about the overall capacity, the planned time,
and the time left.

4. After scheduling all tests with a critical risk, schedule those with a high risk. After that, schedule those
with a medium risk, and so on.

The tests assigned to our testing cycle have moved to the No specific tester row. In the next step, we will
assign tests to manual testers.
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Q 7] Check Out Process - Final Order Summ,,, 0045 v BT
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Tests Filter a 7] Check Out Process - Final Order Summ,,, 0045 v
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Medium (50 ! a 2| Check Out Process - Final Crder Summ,,  00:30 v dbrauer 00
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Assigning Tests to Manual Testers

Now we are going to assign the tests in our testing cycle to manual testers.

1.
2.

Click Test Assignment >>> on the top right. The Test Assignment screen appears.
In the Testing Cycles area on the left side, click on the No specific tester row in our testing cycle. All

tests that are not assigned to a tester appear in the Assigned Tests area on the right side.

left.

tests.

When the testing cycle is started, each manual tester is informed through email about the tests that are
assigned. You can add a test inbox, (Manual Tests Assigned to Me), to your personal dashboard. All the

tests that are assigned to you are listed there.

Select one or more tests, drag them to the Testing Cycles area on the left side and drop them to a
manual tester. When assigning tests to a manual tester, the resource indicator is updated. Move the
mouse over this indicator to see detailed information about the capacity, the planned time, and the time

When you are finished assigning tests to manual testers, click ... > Start Testing Cycle to start the

Silk Central

<<« Test Selection

i TS TS P

stues Reports

Test Assignment - Who executes the selected tests?

of 1

7] Check Out Process -
7] Check Out Process -
7] Check Out Process -
7] Check Out Process -
7] Check Out Process -

7] Order Management -

7] Order Management

New Testing Cycle | | Show/Hide Testing Cycles P RO e
Y 1
< *
% [ 2
Bl Week 21 - Team A
% @ 3
Aug 07 Not Started Aug1i  Resources Completed % @ A
16:00 o8 x @ g
% [ 5
4 4 Tester(s) assigned m « 7
Tester Resources Complated —y 8
No specific tester P 08

Adam Anderson ]} 00

dbrauer EEE oo

gmazzuchelli 00

htanaka 08:00 o—
7] Testing Cycle 5 - Future Testing Cycle
Jan03 Not Started Jan09  Resources Completed
NA o0 <
N Page 1

Final Order S,
Final Order S,
Final Order S,
Final Order S,
Final Order S,

Refundmen

- Refundmen.

7] Shoppthg Cart - Acceptance Test

. 0030
. 0030

00:15
00:15
00:15
00:30
00:30

05:00

& Rows perpage (50 |v

Q, Search.

Demo Project  admin  Administration  Help

Testing Cycles Assigned Tests - Week 21 - Team A - No specific tester

Planned Time [hhimm]  Status

Status Rezson  Blocked Configuration  Product
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D Not E - Demo Prod
D Not E - Demo Prod
D Not E - Demo Prod
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D Not Execut.. - - Demo Prod

>

Displaying rows 1 - 8 of 8

Executing Manual Tests

Now that you have started your execution plan, you are ready to execute your manual test(s) using the

Manual Testing window.



To open the Manual Testing window, click Home > My Dashboard in the menu, and then click =k
(Continue Manual Test) in the panel Manual Tests Assigned to Me. If this panel does not display on
your dashboard, you have to add it. For more information on the dashboard and on panels, see Dashboard.

The Manual Testing window is intuitive to use, but if you require more information on manual testing, see
Manual Testing.

Tracking and Analyzing Test Results - Quick Start Task

There are several ways to analyze test results in Silk Central, depending on the information you are looking
for and also on the test types you are executing.

To find out more about Silk Central's results analysis features, including reporting and issue and activity
tracking, see Issue Tracking and Results Analysis.

Analyzing Automated Test Results

The Test Results view and the Run Comparison view provide an easy to read results overview with full
drill-down capabilities. All information is included, like result files, thumbnail screenshots, messages, and
stacktraces. This allows you to quickly analyze the root cause of failed test runs, especially because you
can also compare the results of multiple runs side-by-side.

For example, you may be interested in performing the following tasks:

* Analyze the runs of all configurations within a configuration suite or within execution plans which
represent configurations

« Compare runs of the same execution plan, for example to find out if any test statuses have changed

« Show all failed tests of an execution plan at once

To analyze the results of automated test runs:

1. Inthe execution Runs grid or the Activities > Last Executions grid, select one or more executions.

2. Click the View automated test results icon to analyze the results of a single execution, or right-click
your selection and choose Compare Automated Test Results to compare multiple executions.

3. Click the icon at the top of the page or a specific status icon to access detailed information like result
files, thumbnail screenshots, messages, and stacktraces.

i Tip: Use the Show failed tests only check box to narrow down the displayed results.
(2]

Analyzing Manual Test Results

When you have a test run in either a finished or unfinished context, use the Manual Test Results view to
provide an easy to read result view for manual tests including all information like attached issues and
attachments. All of this information is immediately visible. You can print and download a PDF version as
well.

The Manual Test Results view contains a tree view on the left and a details view on the right. The tree
view is based on context of the selection in which the result view was opened. For example, if you selected
a test cycle, you could see all the assigned testers and their tests. Selecting a specific node updates the
details view with the appropriate information of the selection.

To open the Manual Test Results view, click the View Manual Test Results icon (i) of a test in nearly all
contexts where you view manual tests. This includes manual execution planning, dashboard panels,
activities pages, and the execution Runs grid and test Runs grid.

Dashboard Panels
The dashboard in Silk Central is your personal starting area. You can customize it by adding and arranging
various panels, which give you the information you need for your daily work.

For detailed information about dashboard panels, see Dashboard.
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Reports

For detailed information about reports, see Reports.
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Requirements

This section explains how to manage requirements in Silk Central.

A requirement is a condition or capability that a user needs to achieve a specific task, which must be met
by the application under test (AUT). Associate your requirements and tests to enable measuring how well
your software covers the specified requirements. Multiple tests can cover a single requirement and multiple
requirements can be covered by a single test. Integrating external requirements management enables you
to coordinate the requirements management features of Silk Central with other tools you may already be
working with. The Requirements area enables you to manage and control the system requirements during
development. You can create, modify, and delete requirements, associate tests with requirements, track the
changes in the history, and generate tests directly from requirement lists.

Configuring Requirement Settings and Integrations

If you plan to manage your requirements in Silk Central, you can configure requirement properties, filters
and change notification settings. If you are managing your requirements in another system, you can
integrate it with Silk Central to make use of the requirements-management features of Silk Central, like
requirement and test coverage. You need SuperUser, administrator, or project manager privileges to
perform these tasks.

Requirement Properties

The following sections describe the two types of requirement properties that are available.

Requirement Properties Page
Project:<Project Name> > Project Settings > Requirement Properties

The Requirement Properties page lists the custom requirement properties and the calculated properties
that are available for the active project.

Calculated Properties

Column Description
Actions Available actions that can be performed on the calculated property.
Name Name of the calculated property.

Click the Edit icon to edit the calculated property.

Formula Contains the actual formula of the calculated property.
Classification Lists the classifications for the calculated property.
Created On When the property was created.

Created By User who created the property.

Changed On When the property was most recently modified.
Changed By User who most recently modified the property.
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Custom Properties

Column Description
Actions Available actions that can be performed on the custom property.
Name Name of the requirement property.

Click the Edit icon to edit the requirement property.

Type Property type. See the Test Attribute and Requirement Property Types topic for
descriptions of each type of attribute.

Created On When the property was created.

Created By User who created the property.

Changed On When the property was most recently modified.

Changed By User who most recently modified the property.

Calculated Properties

Calculated properties are used to create a single value based on a user-defined formula derived from the
values of internal or custom properties. This value is then put into a labelled range called a classification.
The goal of a calculated property is to be able to view the classification Name in grids. The value of a
calculated property is shown everywhere where the values of custom properties are shown (Document
view, for example). Calculated properties can also be used in filters and quality goals like other internal or
custom requirement properties.

Every calculated property has a default classification without a lower bound. All other classifications must
have a lower bound. The classification allows you to set a name and range for the value of the calculated
property. The name of the classification is how the value will display in the grids. If one or more property
values used in the formula are not set, or evaluating the formula on a particular requirement fails (for
example, division by zero), —-- will appear as the value of the calculated property.

You can use any internal or custom property from within a project in the formula for a calculated property.
The internal or custom property must be of type Number, Text, or List with single selection. You can use
the following operators in the formula: + - * / ()

Restriction: You can have up to five calculated properties per project. Calculated properties cannot
be used within other calculated properties.

Creating a Calculated Property

Calculated properties are used to create a property that is based on a range of values. This procedure will
walk you through creating a calculated property named Custom Risk with three classifications: Low,
Medium, and High. We will use the internal property Risk and a custom property named Impact of type
Number (you should create this one in advance).

1. Click Requirements > Requirement Properties .

Click New Calculated Property.

In the Name field, type Custom Risk.

In the Description field, type Calculated property using Risk and Impact (L, M, H).

o~ WD

Select Business Impact from the Insert Property list. ${Business Impact} is added to the
Formula field.

Select * from the Insert Operator list. ${Business Impact}* is added to the Formula field.

7. Select Business Risk from the Insert Property list. ${Business Impact}*${Business Risk}
is added to the Formula field.

8. On the default row of the Classification grid, rename the entry to Low. Since all calculated properties
must contain a default classification without a lower bound, this one will be used.

o
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9. Click Add Classification. A new row is added to the Classification grid.
10.Name the classification Medium and add a Lower Bound of 10.
11.Click Add Classification. A new row is added to the Classification grid.
12.Name the classification High and add a Lower Bound of 20.

13.Click OK.

A calculated property is now created that will be populated with Low, Medium, or High when both the
Impact and Risk properties are set for a requirement.

Calculated Property Page

The Calculated Property page is used to add or to edit a calculated property to a project. To access this
page click Requirements > Requirement Properties and then click an existing calculated property or
New Calculated Property.

Name Contains the name of your calculated property.

Description Enter a meaningful description of your calculated property perhaps referencing the
formula or classification.

Formula Contains the formula for your calculated property. You can manually type in the
formula or use the Insert Property and Insert Operator lists to do this. If you
manually type in the formula, the field names should be contained within the
following structure: ${}. Operators go between this structure.

Insert Property Place your cursor where you want the property to appear in the Formula field and
select one of the system or custom properties from the list to add it.

Insert Operator Place your cursor where you want the operator to appear in the Formula field and
select an operator.

Classifications The Classifications grid is used to set varying ranges for the values of your

Grid calculated properties. Click Add Classification to create a new row in the grid. Use
the Name field to identify the classification and the Lower Bound field to determine
the lowest value for calculated property. The important thing to know about
classifications is that the Name of the classification is what will appear in grids, not
the values of calculated properties. For example if your classification Name is
Medium with a Lower Bound of 5 and your calculated property value is 7, as long
as your next classification lower bound value is greater than 7, the calculated value
will appear as Medium.

Internal Property Values

The values of several internal properties can be used in the formulas for calculated properties. The values
for supported properties are noted below.

Risk

Value Name Internal Value

Low 1
Medium 2
High 3

4

Critical

Requirements
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Priority

Value Name Internal Value
Low 1
Medium 2
High 3
Critical 4
Reviewed
Value Name Internal Value
No 0
Yes 1

Custom Requirement Properties

You can add custom property fields across all requirements in the selected project in Requirements >
Requirement Properties. Custom properties can subsequently be edited alongside the default properties
on the Edit Requirements dialog box. Custom properties are displayed in Requirements > Details View
> Properties. If the only value of a property is a URL, Silk Central automatically displays it as a link, which
enables direct access to other web applications from within Silk Central.

Creating a Custom Requirement Property

To create a new custom requirement property:

In the menu, click Project:<Project Name> > Project Settings .

Click the Requirement Properties tab.

Click New Requirement Property to display the New Requirement Property dialog box.
Type a name for the new property in the Name field.

Select the data Type of the new property from the Type list. See the Test Attribute and Requirement
Property Types topic for descriptions of each type of attribute.

6. Click OK.

o s~ w DN

Your custom property is available to all requirements in the active project.

Custom Attribute and Requirement Property Types

Silk Central supports the following types of attributes and requirement properties:

Date The Date type supports date values.

List The List type supports single select or multi-select lists. It has the following controls:

* New Item: Allows you to create entries in the list. Click to show the New Item dialog box.
Enter the Name and Numeric Weight for the list item and click OK.

Note: The value of the Numeric Weight field is used during filtering when the filter

criteria uses any of the following operators: >, >=, <, or <=. When the filter criteria

uses the = or not operators, the value from the Name field is used for comparisons.
* Order: Use the fields in this column to sort your attributes.

* Allow multi-select: Click this check box to allow users to select more than one values from
the list.
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Note: You can update an existing single-select list to be a multi-select list. A multi-
select list cannot be changed to being a single-select list though.

* Actions: Use the icons in this row to delete or to edit each item in the list.

Number The Number type supports integer or decimal numeric values. It has the following fields:

* Minimum value: represents the smallest value that you can enter into the field.
* Maximum value: represents the largest value that you can enter into the field.

» Decimal places: used to define how many values to the right of the decimal point are valid.
Select O for an integer value or 1, 2, 3, or 4 for a decimal value.

Note: Custom attributes and requirement properties display their current value if an
update is made to their definition (for example, changes to Minimum value or Maximum
value). In order to apply the new definition, open and save the asset.

Text The Text type supports any alphanumeric value. It has the following fields:
* Maximum length: represents the maximum number of characters that can be entered into
the field. Enter O or leave this field empty for unrestricted length (for requirement properties
only).

Editing Custom Requirement Properties

To edit a previously created custom requirement property:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Requirement Properties tab.

3. Click the name of the property you want to edit. The Edit Requirement Property dialog box displays.
4. Edit the name of the property in the Name field.

When the property is available for use, the name will display in lists for filters and requirements.
Properties can be used in global filters for filtering by requirement properties and can be applied to
requirements.

5. Edit the Description of the property.

6. See the Test Attribute and Requirement Property Types topic for descriptions of each type of
requirement property. You have different editing options depending on the property data type.

7. Click OK to save your changes.

Deleting Custom Requirement Properties

To delete a previously created custom requirement property:

1. Inthe menu, click Project:<Project Name> > Project Settings .
. Click the Requirement Properties tab.

2
3. Click . A confirmation dialog box appears.
4. Click Yes to confirm the deletion.

Requirements Management Tools Integration

/1+, Important: Before upgrading from Silk Central 15.0 or earlier to the current version, perform a
*~ Synchronize All to synchronize all your requirements with your integrated requirements management
tools.

Integrating external requirements management enables you to coordinate the requirements management
features of Silk Central with other tools you may already be working with. Integration is configured on the
Requirements Management page in Project:<Project Name> > Project Settings.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.

Silk Central supports integration with external requirements management systems (RMS) through its open
interface. Creating a plug-in and integrating it into Silk Central allows integrating any RMS. Refer to the Silk
Central API Help for information about the interfaces that enable proper integration of external RMS.

Synchronizing Requirements

Enabling synchronization of requirements between Silk Central and an external RMS enables Silk Central
to receive changes that occur in the external RMS whenever a synchronization is executed. If a project has
external RMS integration enabled, the master system for requirements is automatically the external
system. This means that synchronization is always from the external RMS tool to Silk Central.
Requirements can no longer be edited in Silk Central. An exception are newly created requirements that
don't exist in the external tool, which are uploaded to the external (master) system only if the option Enable
upload of requirements is enabled in Settings > Requirements Management .

Property mapping functionality allows you to map property fields between Silk Central and external
requirement tools. For example, a custom field in Silk Central called User might be equivalent to a property
field in Caliber called Field_2. The property mapping feature ensures that changes to requirement-
property fields are accurately refreshed between projects. If you don't use the property mapping feature,
only the name and the description of the requirements are mapped. For more information, see Editing
Property Mapping.

Requirements can be synchronized in one of several ways:

Manual Click Synchronize Changes at the root folder level on the Properties page to

synchronization synchronize only requirements that have changed since the last synchronization.
This option is not available for IBM Rational RequisitePro.

Forced manual Click Synchronize All at the root folder level on the Properties page to force

synchronization synchronization of all requirements.

Automatic Based on globally defined Silk Central schedules.

scheduled

synchronization

Automatic online Changes to requirements are automatically propagated between tools. This option

synchronization is available for Caliber only. It requires Caliber client installation on the application

server and MPX enabled on the Caliber Server (refer to the Caliber Installation
Guide for detailed information on enabling MPX). To enable automatic
synchronization between Caliber and Silk Central, add the file ss. jar to the
application server at Program Files\Silk\Silk Central <version>\lib
and restart the application server. Contact customer care to obtain the file.
Requirement data is automatically updated in Silk Central when changes are
made in Caliber and traces in Caliber are updated when test assignment changes
are performed in Silk Central. This type of online synchronization is only available
when projects are configured with the current baseline.

Automatic synchronization of requirements between Silk Central and external requirements management
tools can be configured to occur based on global schedules. For details on configuring global schedules,
see the Administration topics in this Help.

Note: The Open Caliber buttons open whatever program is registered as the default program for
opening files of extension .crm. On some machines, this may be the requirement viewer, rather than
Caliber. This behavior can be changed by your administrator. The client program is called
caliberrm_exe. When properly configured, the program opens to the requirement that is selected
in Silk Central.



The binder icon on the project node of the Requirements tree indicates the status of RM integration for the
project:

No configuration RM integration is not available.

Manual configuration Requirement import, upload, and synchronization can be done only by clicking

the corresponding buttons on the project node in Requirements > = >
Properties.

At the project level, the Properties page includes the following properties:

Property Description

System The external tool with which integration has been enabled.

Status Whether or not integration has been enabled.

Project Name The name of the external project that the Silk Central project is associated with.
Requirement Types The requirement types that are shared between projects.

Last Synchronization Date and time of the last synchronization.

Last Synchronization Status The status of the last synchronization including the number of created, updated, and

deleted items.

Note: When integration between Caliber and Silk Central with automatic online synchronization has
been enabled, the project node displays the current status of the online requirements change listener.
The three possible statuses for such projects are: Connected (synchronized), Reconnected
(synchronization recommended), and Disconnected.

Synchronizing Requirements Across Tools

Note: Use the property mapping feature to map property fields. If you don't use the property mapping
feature, only the name and the description of the requirements are mapped. For more information,
see Editing Property Mapping.

To synchronize requirements between Silk Central and an externally configured requirements management
tool

In the menu, click Requirements > Details View .

Select the Project node in the Requirements tree.

Click the Properties tab. The Properties page displays the properties of the selected tree-element.
Click Synchronize Changes.

Click Yes on the Synchronize Requirements confirmation dialog box to begin synchronization. A
dialog box opens when synchronization is complete, displaying synchronization statistics, including the
number of requirements that have been created, updated, and deleted.

6. Click OK to complete the synchronization. Any updates that were made to mapped requirements in your
externally configured requirements management tool are now reflected in the Requirements tree.
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Synchronizing Requirements based on Schedules

You can configure global schedules to automatically synchronize requirements between Silk Central and an
external requirements management tool. To enable automatic synchronization between Caliber and Silk
Central, add the file ss. jar to the application server at Program Files\Silk\Silk Central
<version>\l1ib and restart the application server. To obtain the file, contact customer care.

To synchronize requirements based on globally defined schedules:

1. Inthe menu, click Project:<Project Name> > Project Settings .
2. Click the Requirements Management tab.

Requirements
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3. Click Edit Schedules. The Edit Schedules dialog box opens.

4. Select a predefined global schedule from the Synchronize changes list to define when changes in the
external system should be synchronized with Silk Central.

5. Select a predefined global schedule from the Synchronize all list to define when all requirements in the
external system should be synchronized with Silk Central.

6. Click OK.

For information on creating global schedules, see Adding Global Schedules.

Defining Email Notification for Automatic Synchronization Events

You can define an email notification to alert users when errors occur during automated synchronization of
requirements between Silk Central and external requirements management tools. All notification recipients
receive copies of the synchronization log files.

To define an email notification for automatic synchronization events:

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click Edit Notification. The Edit Notification dialog box displays.
Check the Enable notification check box.

Select a user name from the Username list box.

If required, add additional email addresses for other recipients in the Other email addresses field. Use
semicolons to separate multiple email addresses.

7. Click OK.

S A

Atlassian JIRA Agile Integration

Silk Central offers a requirements integration with Atlassian JIRA Agile, which is based on the project and
issue tracking system JIRA. All issue types (the generic object type in JIRA) can be synchronized. Since
Atlassian JIRA Agile offers the creation of custom issue types, you can specify a list of Atlassian JIRA Agile
issue types in Silk Central that you want to synchronize, such as for example Bug or Improvement.

Atlassian JIRA Agile versions that are currently supported for integration with Silk Central: Atlassian JIRA
6,7

Limitations: Synchronizing JIRA requirements only works for requirements of the configured JIRA project. If
requirements are linked to requirements (epics) which are located in a different JIRA project, these
requirements will not be synchronized.

Enabling Integration with Atlassian JIRA Agile

To enable integration with Atlassian JIRA Agile:

In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.

The New Integration dialog box opens.



6. Select Atlassian JIRA Agile from the list and click Next. The Edit Configuration dialog box opens.
7. Type a Name for the new profile.

This is the name that is displayed in lists where the profiles are available for selection.
8. Enter the URL of your JIRA Agile server.

9. Type valid Username and Password credentials for JIRA Agile. The username needs to be a valid
JIRA user profile name.

10.In the Issue Types field, specify the issue types that you want to synchronize, separated by semicolons
()
All issue types (the generic object type in JIRA) can be synchronized. Since Atlassian JIRA Agile offers

the creation of custom issue types, you can specify a list of Atlassian JIRA Agile issue types in Silk
Central that you want to synchronize, such as for example Bug or Improvement.

11.Optional: To limit the amount of requirements that are being synchronized, you can use the Custom
JQL field to pre-filter requirements before they are being synchronized. Create a query using JIRA
Query Language (JQL) within your JIRA Agile system, then copy and paste the string into the Custom
JQL field. For more information on JQL, visit Atlassian's Advanced Searching Documentation.

3y Tip:
(2]
e Do notinclude ORDER BY statements in your JQL query.
e The JQL string may not exceed 128 characters.
« The JQL query is used additionally to your configured project and issue types, it does not
overrule those settings.

12.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.

f Note: Consult your system administrator if you are not able to establish a connection.

13.Click Load. The Project list is populated with all the projects in JIRA Agile that you have permissions
for.

14.From the Project list, select the external project with which the Silk Central project is to be integrated.
15.Click OK to save your settings.

Atlassian JIRA Agile Property Mappings
The following properties have a default mapping between JIRA Agile and Silk Central:

» User stories that are in JIRA Agile's Backlog are reflected in Silk Central by having the Sprint
property value set to Backlog. This enables you to easily search for them by creating a filter.

e The default Priority values of JIRA Agile's user stories are mapped to Silk Central's Priority
property. If you are not using JIRA Agile's default Priority values, you can customize this mapping.

Viewing JIRA Agile Backlog Stories in Silk Central

1. Inthe menu, click Requirements > Details View.
2. Create a new filter with the following criteria:

* Selection Criteria: External Custom Attributes
e Property: Sprint
¢ Value: Backlog
3. Click Apply to apply the filter immediately or Save and apply to save the filter for future reuse.

Mapping JIRA Agile Priority values to Silk Central's Priority

The default Priority values of JIRA Agile's user stories are mapped to Silk Central's Priority property
as follows:
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» Blocker=SC_Priority_Critical
» Critical=SC_Priority_High

* Major=SC_Priority_Medium
e Minor=SC_Priority Low

e Trivial=SC_Priority_Low

If you are not using JIRA Agile's default Priority values, or if you want to customize the mapping, your
Silk Central administrator should customize the settings as follows:

1. Stop the application server.

2. Open the file propertyMappings.properties with a text editor. This file is located in the JIRA Agile
plugin-file J1IRAAgi le.zip on the application server in the plugins folder.

3. Search for SC_Priority=Priority, beneath which you can customize the mapping of JIRA Agile's
Priority values to Silk Central's Priority.

f Note: Silk Central Priority values require the prefix SC_Priority_.

4. Save and close the file
5. Re-start the application server.

CA Agile Central Integration

Integrating the project management tool CA Agile Central enables you to define user stories which you can
then use as requirements in Silk Central. You can then create tests in Silk Central to cover these
requirements. To update the tests you have created with any changes to the corresponding user stories in
CA Agile Central, synchronize the requirements.

A mashup is shipped with Silk Central, that enables you to display user-story related test-coverage
information from Silk Central in CA Agile Central. You can link each test in Silk Central to one or more user
stories in CA Agile Central. To link tests to a user story, assign an attribute with the value of the formatted
user-story ID in CA Agile Central to each test.

The following user story properties are always synchronized from the CA Agile Central REST Service.
Custom fields are also synchronized if they are specified in the integration configuration. You can use these
properties to help filter and categorize the user stories.:

Property Description
Name The name of the user story in CA Agile Central.

CA Agile Central ID  The identifier of the user story in CA Agile Central. This property is the External
ID of the requirement in Silk Central.

Description The description of the user story in CA Agile Central.

Iteration The iteration in CA Agile Central in which the user story is included.

Project The project in CA Agile Central in which the user story is included.

Release The project release in which the user story is included.

State The state of progress of the user story in CA Agile Central. The following states
are available:
« Defined

« In-Progress
« Completed
» Accepted

Plan Estimate (Story The estimated time in CA Agile Central for the user story to be completed. The
Points) time is estimated in story points.



Enabling Integration with CA Agile Central

To enable integration with CA Agile Central:

In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.

o wDh e

Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk

Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.
The New Integration dialog box opens.
6. Select CA Agile Central from the list and click Next. The Edit Configuration dialog box opens.
7. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
8. Type the URL.

9. Type valid Username and Password credentials for CA Agile Central, or type a valid API Key instead.

An API Key can be used to access your CA Agile Central subscription data without using your

username and password. For more information about CA Agile Central API Keys, refer to the CA Agile

Central Application Manager page.

10.Optional: If direct access to the Internet is restricted, and the CA Agile Central REST service is located
in a machine outside the scope of the internal network, use the Proxy Host and Proxy Port fields to

specify a proxy through which Silk Central can connect to CA Agile Central.

Note: To connect to CA Agile Central by using a proxy, you need to fill out both fields, Proxy Host

and Proxy Port.

11.Optional: If you want to synchronize custom fields, type their names into the Custom Fields field,
separated by commas. The internal field names must be used, not the display names.

12.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.

i Note: Consult your system administrator if you are not able to establish a connection.

13.Click OK.

14.Click Load. The Project list box is populated with all the projects from all workspaces in CA Agile
Central that you have permissions for.

15.From the Project list box, select the external project with which the Silk Central project is to be
integrated.

16.Click OK to save your settings.

Creating a Custom HTML App in CA Agile Central

Create a custom app in CA Agile Central using HTML or Javascript to display user-story related test-
coverage information.

To create a custom HTML app:

Navigate to the tab in CA Agile Central where your custom app should reside.
Click Customize Page and click Add App. The App Catalog displays.

Click Custom HTML under Custom and click Add This App.

Enter a title and switch to Silk Central.
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In the menu, click Help > Tools .

Click CA Agile Central Iteration Status Mashup and copy the HTML code.
Switch back to CA Agile Central and paste the HTML code into the HTML field.
Configure the script in the field to match your Silk Central environment:
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« Check if the valid script source is set, for example <script type=""text/javascript"
src=""http://localhost:19120/silkroot/script/sctm-toolkit. js"></script>.

e Check if the valid URL for Silk Central is set, for example var SCTM_URL = "http://
localhost:19120/".

* Check if a valid Silk Central project ID is set, for example var SCTM_PROJECT_ID = O.

« Check if a valid attribute name is set, for example var SCTM_ATTRIBUTE_FOR_RALLY_US =
"rallyattr™.

* Make sure usage of the FormattedID from CA Agile Central is enabled, var
USE_FORMATTED_ID = true.

9. Click Save. Your custom HTML app in CA Agile Central is created.

Linking User Stories from CA Agile Central to Tests

To link CA Agile Central user stories to Silk Central tests:

1. Select the project in Silk Central that contains the tests you want to link the CA Agile Central user
stories to.

In the menu, click Project:<Project Name> > Project Settings .

Click the Attributes tab.

Click New Attribute. The New Attribute dialog box displays.

Type ral lyattr in the Name field.

Select Text from the Type list.

Click OK to create the new attribute.

Assign the new attribute to each test that you want to link user stories from CA Agile Central to.

Set the value of the attribute to be the value of the FormattedID of the appropriate CA Agile Central
user story for each test. If you assign multiple stories to a single test, separate the IDs with a comma
and put no whitespace characters between them. For example, US10,US12,US14.
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Caliber Integration
This section describes how to integrate Caliber with Silk Central.

Before you can configure Caliber integration, you must install the Caliber client on the Silk Central
application server and on the front-end server. Additionally, make sure that MPX support is enabled in
Caliber. Configuring integration with Caliber requires the definition of Caliber login credentials. Whenever
requirements are synchronized between Silk Central and Caliber, these credentials are used to login to Silk
Central, thus checking out a Silk Central license. The license is set free as soon as the synchronization
process has completed. We recommend creating a dedicated Silk Central user for synchronization
purposes, which should be used by all Silk Central requirements integrations. This ensures that only a
single Caliber license is used for the process of synchronization.

Caliber versions that are currently supported for integration with Silk Central: Caliber 11.4, 11.5

Note: Caliber user defined attribute Multiple selection user list and Multiple selection group list
must be mapped to the Silk Central text attribute type and not list type.

Enabling Integration with Caliber

To enable integration with Caliber:
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In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.
The New Integration dialog box opens.
6. Select Caliber from the list and click Next. The Edit Configuration dialog box opens.
7. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
8. Type the Hostname of the machine where the external server is installed.
9. Type valid Username and Password credentials for the requirements management server.
10.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.

y Note: Consult your system administrator if you are not able to establish a connection.

11.Click OK.

12.From the Project list box, select the external project with which the Silk Central project is to be
integrated. The requirement types that are available with the selected project are automatically
populated into the Requirement Types field. The baselines that are available with the selected project
are automatically populated into the Baseline field.

13.Select a Baseline from the external project that should be integrated with the Silk Central project.
Your selections are displayed on the Edit Configuration dialog box.

14.Click OK.

15.Select one or more requirement types from the external project that should be integrated with the Silk
Central project.

Use Ctrl+Click to select multiple requirement types.
16.Click OK to save your settings.

Baseline Support for Caliber Integration

You can select the current baseline or existing user-defined baselines for Caliber integration. You cannot
import modified baselined requirements into Silk Central. Requirements that are not of the current baseline
can only be changed in Caliber if the version of the requirement that is used for the baseline is changed.
Such changes are only updated within Silk Central requirements when a manual or scheduled
synchronization is performed.

You can change a baseline after you import it into Silk Central. You can change the configured baseline to
a different user-defined baseline or the current baseline. After such a change, the next synchronization of
the baseline, either manual or scheduled, will update the Silk Central project and update, create, or delete
requirements as required. When a baseline is changed, a message displays that states that the changes
will take effect after the next synchronization.

Handling Test Assignments in Caliber

Assigned tests are displayed, managed, and created as traces (“Trace to0”) of synchronized requirements in
Caliber.
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The External Traceability for Silk Central must be enabled for a Caliber project within the Caliber
Administrator and the correct Silk Central front-end server must be configured. Click Edit for the Silk
Central External Traceability for correct project within the Caliber Administrator.

When a project is synchronized with a Silk Central project, the assigned tests of the synchronized Silk
Central requirements will display as traces ("Trace To") of the Caliber requirement. If you edit these
assignments in Silk Central, the changes will be reflected immediately in Caliber.

Copying Caliber-Integrated Projects

To manage Caliber baselines when copying Silk Central projects:

1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Requirements Management tab.

3. Verify that the baseline you want to save is selected.
Note: If a baseline is changed, you must perform a synchronization to update the project
requirements with the baseline changes, before you can copy an associated Silk Central project.
The integration configuration is only copied if you select a baseline other than the current baseline.

If you select the current baseline, you need to specify if you want to keep the integration
configuration in the original project or move it to the copied project.

4. If the baseline that you want to save is not selected, click Edit Configuration. The Edit Configuration
dialog box displays.

5. Click Browse next to the Project name field. The Browse Projects dialog box opens.

6. Select the baseline you want to save, then confirm your selection.

7. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

8. Click @ in the Actions column of the project you want to copy.

f Note: For full details on copying a project, see the Administration topics in this Help.

The Copy Project dialog box displays.
9. Select the items you want to copy into the new project, then confirm your selection.
10.Apply the baseline that you want to continue working with to the Silk Central project.

Note: After copying a project, the original project and the copy are identical. Define on which you
will continue working on by applying the corresponding baseline.

Creating a Baseline for a Caliber-Integrated Project

To create a baseline of a Caliber-integrated Silk Central project:

1. Create a baseline of the Silk Central project. A Silk Central message box displays during the process,
asking if you want to enable the Caliber integration for the new baseline.

2. Click Yes. When the new baseline is created, the Baseline Project - Adapt Project Settings dialog
box opens.

3. Click Edit to change the requirements integration settings.

The Edit Configuration dialog box opens.

Click Browse next to the Project name field. The Browse Projects dialog box opens.
Select a Caliber project, a baseline, and the requirement type for synchronization.
Click Ok to close the Browse Projects dialog box.

Click Ok to close the Edit Configuration dialog box.

Click Finish to close the Baseline Project - Adapt Project Settings dialog box.
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Generating Tests from Scenarios and Simulations
Generate tests from the Caliber objects Scenario and Simulation.

To generate tests from the Caliber objects Scenario and Simulation:

1. Establish integration with Caliber.

For additional information, see Enabling Integration with Caliber.

Select the Scenario or Simulation in the Requirements tree from which you wish to generate tests.
On the Properties tab, click Generate Tests. The Generate Tests dialog box displays.

Use Ctrl+Click or Shift+Click to select the tests that you want to generate.

Click Generate All to generate all tests, or click Generate Selected to generate the selected tests. The
Tests tree displays.

6. Select the folder to which you want to add the generated tests.
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Note: Tests that already exist in the selected destination folder are not created, but updated. No
tests in the folder are deleted.

7. Click OK.

IBM Rational DOORS Integration

This section describes how to integrate Silk Central and IBM Rational DOORS. Silk Central 18.5 offers out-
of-the-box support for IBM Rational DOORS, without the need to customize anything in your DOORS
installation. If you are upgrading from Silk Central 15.5 or earlier though, and using customized dx1 files,
you will need to overwrite the dx1 files in the Iib\dx1 folder within your Silk Central installation folder with
your customized dx1 files.

IBM Rational DOORS versions that are currently supported for integration with Silk Central: IBM Rational
DOORS 9.5, 9.6

Enabling Integration with IBM Rational DOORS

To integrate Silk Central and DOORS, install the DOORS client on the Silk Central front-end server
machine. If you use more than one front-end server machines, you must install the DOORS client on each
front-end server that you have configured for integration with DOORS.

To enable integration with DOORS:

In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.
The New Integration dialog box opens.
6. Select IBM Rational DOORS from the list and click Next. The Edit Configuration dialog box opens.
7. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
8. In the RM service URL field, type the URL of the Silk Central DOORS requirement Web Service.

The default value should point to the correct location already. For example http://MySCTMHost:
19120/services/doorsrequirementsmanagement.
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9. Type valid Username and Password credentials for the requirements management server.

10.The default DOORS client installation path is displayed in the DOORS Installation Path field. If this
path is not correct, enter the correct destination within the front-end server directory structure.

11.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.

f Note: Consult your system administrator if you are not able to establish a connection.

12.Click Browse next to the Project name field to open the Browse Requirement Types dialog box. From
the Project field, select the external project with which the Silk Central project is to be synchronized.

The requirement types that are available with the selected project are automatically populated into the
Requirement types field. Select the requirement types that are to be synchronized and click OK. Use
Ctrl+Click to select multiple requirement types.
Your selections are now displayed on the Edit Configuration dialog box.

13.Click OK to save your settings.

/1, Caution: As the DOORS application object is used for communication, and this object does not
“*= support login data, but rather requires a running DOORS client, Silk Central starts each DOORS
client process with the provided login data and then uses that same data for all subsequent

application objects. Therefore only one set of DOORS login credentials is supported for
communication at one time. It is recommended that you use the same DOORS credentials for all
configurations so that integration tasks can be performed on the front-end server for all projects at
the same time. When a second set of credentials is used, the second set only works after all
sessions using of the first set of credentials have timed out.

IBM Rational DOORS Next Generation Integration

This section describes how to integrate Silk Central and IBM Rational DOORS Next Generation. Silk
Central 18.5 offers out-of-the-box support for IBM Rational DOORS Next Generation, without the need to
customize anything in your DOORS installation.

Note: All artifacts of the project are synchronized, except the DOORS collection artifacts Module and
Collection themselves.

IBM Rational DOORS Next Generation versions that are currently supported for integration with Silk
Central: IBM Rational DOORS Next Generation 6.0

Enabling Integration with IBM Rational DOORS Next Generation
To enable integration with IBM Rational DOORS Next Generation:

1. In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.

The New Integration dialog box opens.

6. Select IBM Rational DOORS Next Generation from the list and click Next. The Edit Configuration
dialog box opens.

7. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.



8. In the DOORS Next Generation URL field, type the fully qualified URL of the IBM Rational DOORS
Next Generation server, for example https://MyDOORSHost.MyDomain.com:9443/rm.

9. In the Authentication URL field, type the fully qualified URL of the IBM Rational Jazz Team Server, for
example https://MyDOORSHost.MyDomain.com:9443/jts.
Note: The new IBM Rational Authentication Server is not supported for authentication, only the
IBM Rational Jazz Team Server.
10.Type valid Username and Password credentials for the IBM Rational DOORS Next Generation server.
11.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.

y Note: Consult your system administrator if you are not able to establish a connection.

12.Click Load next to the Project name list to populate the list with the available DOORS projects. Select
the external project with which the Silk Central project is to be synchronized.

13.Click OK to save your settings.

IBM Rational RequisitePro Integration
The topics in this section describe the integration between IBM Rational RequisitePro and Silk Central.

Before you can configure the IBM Rational RequisitePro integration, you must install the IBM Rational
RequisitePro client on the Silk Central front-end server.

IBM Rational RequisitePro versions that are currently supported for integration with Silk Central: IBM
Rational RequisitePro 7.1.3, 7.1.4

Enabling Integration with IBM Rational RequisitePro

f Note: You can only configure one IBM Rational RequisitePro integration per project.

To enable integration with IBM Rational RequisitePro:

In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click New Integration.
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Note: You can enable creating, editing and deleting requirements through Silk Central, rather than
only allowing modifications through the integrated tool. You can allow modifications directly in Silk
Central's Ul, and/or through Silk Central's web services by checking the respective Allow
requirement create, edit, and delete... check boxes.

The New Integration dialog box opens.

6. Select IBM Rational RequisitePro from the list and click Next. The Edit Configuration dialog box
opens.

7. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
8. Type the Project path (UNC) to the machine where the external server is installed.

9. Type valid UNC username and UNC password credentials for the machine where the external server
is installed.

10.Type valid Username and Password credentials for the requirements management server.
11.Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.
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i Note: Consult your system administrator if you are not able to establish a connection.

12.Click Edit Packages and Requirement Types.
Your selections are then displayed on the Edit Configuration dialog.

Note: Only requirements of explicitly selected packages will be synchronized. Selecting a parent
package does not select the child packages of the parent.

The Browse Packages & Requirement Types dialog box opens. The packages and requirement types
that are available with the selected project are automatically populated into the Packages and
Requirement Types list boxes.

13.From the Packages list box, select one or more packages from the external project that should be
integrated with the Silk Central project.

Use Ctrl+Click to select multiple packages.

14.From the Requirement types list box, select one or more requirement types from the external project
that should be integrated with the Silk Central project.

Use Ctrl+Click to select multiple requirement types.
15.Click OK. The Browse Packages & Requirement Types dialog box closes.
16.Click OK to save your settings.

SAP Solution Manager Integration
To purchase the SAP Solution Manager Plug-In, please contact your sales representative.

SAP Solution Manager facilitates technical support for distributed systems, covering solution deployment,
operation, and continuous improvement. SAP Solution Manager is a centralized, robust application
management and administration solution, that combines tools, content, and direct access to SAP to
increase the reliability of solutions and lower total cost of ownership. For additional information on the SAP
Solution Manager, refer to the SAP Solution Manager documentation.

The integration between Silk Central and SAP Solution Manager allows for the synchronization of SAP
Solution Manager business processes and incidents as Silk Central requirements and issues.

System Requirements for SAP Solution Manager Integration
The following are the system requirements for the SAP Solution Manager integration plugin:

« Silk Central 12.1 or later
e SAP Solution Manager 7.1
« The Silk Central Integration Hub for SAP Solution Manager must be installed in SAP Solution Manager.

Configuring SAP Solution Manager
Configure SAP Solution Manager to enable the integration with Silk Central.

For additional information, see

Configuration_Guide_SilkCentral Integration_Hub_ for_SAP.pdf and
User_Guide_SilkCentral Integration_Hub_for_ SAP.pdf, which are included in the SAP
Solution Manager plug-in.

For this integration to get valid links from SAP Solution Manager to Silk Central, the front-end server
machine of Silk Central must have a valid fully qualified name.

Adding SAP Solution Manager Issue Tracking Profiles

To add a SAP Solution Manager issue tracking profile:

1. In the menu, click Project:<Project Name> > Project Settings .



2. Click the Issue Tracking tab. The Issue Tracking page opens, listing all of the issue tracking profiles
that have been created for the system.

3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select SAP Solution Manager from the Type list box.
7. Type avalid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the URL of the Z-SCTM_ADAPTER web service of SAP Solution Manager.

9. Click Load Project to load all projects from the server and populate the Project list box, then select a
project from the Project list box.

10.Click Load Default Incident Type to load all possible incident types and populate the Default Incident
Type list box.

11.Select an incident type from the Default Incident Type list box. If you are creating links to existing
incidents in SAP Solution Manager and you do not specify the incident type, this type will be used for it.

12.Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

13.1f the trial connection is successful, a confirmation dialog box displays, asking you if you want to map
internal issue states to the states of the newly defined profile.

* Click Yes to proceed with the related Mapping Issue States procedure.
« Click No to map issue states later.

Enabling Requirements Integration with SAP Solution Manager

In the menu, click Projects > Project List.

Select the project to which you want to establish integration.

In the menu, click Project:<Project Name> > Project Settings .

Click the Requirements Management tab.

In the SAP Solution Manager section, click Configure.

Enter the URL of the Z_SCTM_ADAPTER web service of SAP Solution Manager.
Enter the Username and Password.

Click Test Connection to confirm that the host and user credentials are correct. If the settings are
correct, a Test connection was successful message displays.

9. Click Load to load all available projects and select the correct one.

10.Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Silk Central projects that are configured for integration.

11.Click OK to confirm and close the dialog.
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Working with External Properties

This section explains how to work with external properties in Silk Central.

Editing External Properties

To edit external properties:
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In the menu, click Requirements > Details View .

Select the requirement for which you intend to edit external properties.

Click the Properties tab. The Properties page displays the properties of the selected tree-element.
Click Edit External Properties.

The Edit External Properties dialog box displays. All properties of the external requirement are
displayed here. Edit all properties as required.
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Note: Editable properties on this dialog box offer input fields and controls with which you can edit
the properties. If a mapping rule exists for an attribute, the attribute will be tagged with a trailing
asterisk (*).

5. Click OK to save your changes and close the dialog box.

Viewing External Properties

To view external properties:

In the menu, click Requirements > Details View .
Select the requirement.
Click the Properties tab. The Properties page displays the properties of the selected tree-element.

Click View External Properties. The View External Properties dialog box displays. All properties of
the external requirement are displayed here.

5. Close the dialog box.
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Editing Property Mapping

The property mapping functionality allows you to map property fields between Silk Central and external
requirements management tools. For example, a custom requirement property in Silk Central called User
might be equivalent to a custom property in Caliber called User__1D. The property mapping feature
ensures that requirement property fields are accurately populated between projects during requirement
uploading and importing. If there are multiple requirement types, you must map each type separately.

Note: If you don't use the property mapping feature, only the name and the description of the
requirements are mapped.
To edit property mapping:

Note: The following applies for synchronizing properties with boolean values: since Silk Central does
not support the boolean data type, you need to create a single select list with the following two list
items:

* Name = Yes, Numeric Weight =1
* Name = No, Numeric Weight =0

Note: When you map lists, requirement properties from both products need to have the same named
options for each list item, and they are case sensitive.

Select the project.
In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click Edit Property Mapping for the configured external tool. The Edit Property Mapping dialog box
opens.

5. Select an external requirement type from the Requirement types list. All custom requirements of that
type are then displayed below in the selection box.

6. Select the custom requirement property for which you are establishing mapping.

7. From the list box on the right, select the Silk Central custom property to establish mapping to the
external custom property you have selected.
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8. Click Add Mapping to map the requirements. The results are displayed in the Custom property
mapping box.

9. The System property mapping box displays the two pre-configured mappings for requirement name
and description, which cannot be removed.

10.Click OK to save your changes.

Deleting Property-Mapping Value Pairs

To delete a property-mapping value pair:

Select the project.
In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click Edit Property Mapping for the configured external tool. The Edit Property Mapping dialog box
opens.

5. Select the property-mapping value pair in the Custom property mapping select box.
6. Click Remove Mapping.
7. Click OK to save your changes.

e

Disabling Requirements Management Integration

To disable requirements management integration configuration:

Select the project.
In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click the Disable Configuration button of the requirements management tool for which you want to
disable integration.
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All integration data and functionality is disabled, but not deleted from the project.

Removing Requirements Management Integration

To remove requirements management integration:

Select the project.
In the menu, click Project:<Project Name> > Project Settings .
Click the Requirements Management tab.

Click Remove Configuration of the requirements management tool for which you want to remove
integration.

This button is only enabled if the configuration is disabled.
The Remove External Association dialog box displays.
5. Click Yes.
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All related data is removed from the database.

Filters

Filters provide an efficient means of finding exactly the information you need, while excluding extraneous
detail. Filters highlight only those elements that are relevant to your needs, and enable you to quickly sort
through requirements, test elements, and execution plans. By defining global filters, you can create
complex filter criteria that are available throughout Silk Central without defining filter criteria each time you
need to filter a list.
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Based on your needs, you can create new filters, edit existing filters, select filters, delete filters, or turn
filtering off at the project level. Projects do not contain default filters. You can access and edit filters from
the toolbars in the Silk Central units and from the Project Settings unit.

Note: Filters are not applied to reports. The Recent Changes filter enables you to view project-wide
changes and additions that other users have made to tests since your last change acknowledgement.
The Show Changes/Show All toggle button and the Acknowledge button in the Tests area help you

to find out what changes other users have made. Your system administrator can configure email
notifications that alert you to changes that are made to test settings. Email alerts include links that
take you directly to a view of recent changes.

Creating Filters

To create a filter:

In the menu, click Project:<Project Name> > Project Settings .

Click the Filters tab to view the list of available filters.

Click New Filter. The New Filter dialog box appears.

Type a Name for the new filter.

This name will be displayed in list boxes when the filter becomes available.

5. Select a Category from the list to make the filter available in the Requirements, Tests, or Execution
Planning area of Silk Central.

6. Optional: Type a Description for the new filter.
7. Optional: Check the Visible to other users check box to allow other users to see the filter.
8. Optional: Check the Editable by other users check box to allow other users to edit the filter.
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Note: If Visible to other users and Editable by other users are checked, the filter is public. To
delete non-public (private) filters, you have to be the owner of the filter or you need the Delete
private filters of other users permission.

9. Select a category of filter criteria from the Selection criteria list. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Filter or Nested Requirement Filter.
Selecting one of these categories allows you to include an existing filter in your new filter.
10.Select a Property, Operator, and Value for the filter from the respective lists.

Property Available properties depend on the filter category that you have selected in the previous

step. Defines the property for which you are defining a filter setting. If you have selected an

attribute category, the property list includes custom attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the
following operators are available:

Operator Description

= The string equals the defined value.

not The string is different than the defined value.

contains The string contains the defined value.

not contains The string does not contain the defined value.
Value Enter the value that you want to filter out. Depending on the property type that you have

selected, values will either be strings that you can enter into the field, or a selection of
predefined values that you can select from the list box. Allowed wildcards for strings are *
(any amount of characters) and ? (exactly one character).



11.0Optional: Click More if you want to add more than one filter category to the new filter. Repeat this
procedure to define new categories.

Note: If you define more than one filter category, you must define whether the categories need to
be fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when
one of the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter
category relationship. You cannot define nested AND, OR relationships.

12.0Optional: To remove filter categories, click Fewer. This removes the last filter category.
13.Click OK to save the new filter, or click Cancel to abort the operation.

Creating Advanced Filters

Advanced custom filters enable you to combine simple filters to create complex filters that apply multiple
filter criteria simultaneously.

To create an advanced custom filter:

. In the menu, select the appropriate area: Requirements, Tests, or Execution Planning.

in

1

2. Click K (New Filter) in the toolbar. The New Filter dialog box appears.
3. If necessary, click Advanced to show the whole dialog box.
4

. Click More to display a second set of filter-parameter fields with which you can define a second set of
filter parameters.

5. Select a logical operator for the application of the filtering queries. For example, with the operator and
filtered elements must meet both sets of criteria and with the operator or filtered elements must meet
one, but not both, of the criteria sets.

To delete a filter-parameter string, click X .

7. To display additional filter-parameter fields and create additional filter queries, click More. To remove
excess filter-parameter sets, click Fewer.

Editing Filters
To edit a filter:

In the menu, click Project:<Project Name> > Project Settings .

Click the Filters tab to view the list of available filters.

Click the name of the filter you want to edit. The Edit Filter dialog box displays.
Edit the Name and Description of the filter.

Select a category of filter criteria from the Selection criteria list. The available categories depend on
the general filter category you have selected.
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Note: You can combine filters by selecting Nested Test Filter or Nested Requirement Filter.
Selecting one of these categories allows you to include an existing filter in your new filter.

6. Select a Property, Operator, and Value for the filter from the respective lists.

Property Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected an
attribute category, the property list includes custom attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the
following operators are available:

Operator Description

= The string equals the defined value.
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7.

Operator Description

not The string is different than the defined value.

contains The string contains the defined value.

not contains The string does not contain the defined value.
Value Enter the value that you want to filter out. Depending on the property type that you have

selected, values will either be strings that you can enter into the field, or a selection of
predefined values that you can select from the list box. Allowed wildcards for strings are *
(any amount of characters) and ? (exactly one character).

Click OK to save the edited filter definition.

Copying Filters

Create a new filter by copying an existing one and changing the settings.
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In the menu, select the appropriate area: Requirements, Tests, or Execution Planning.
In the toolbar of the selected area, select a filter from the list box.

Click . The Edit Filter dialog box opens with the settings of the original filter.
Edit the properties of the filter and click OK.

Deleting Filters

To delete a filter:

1.
2.
3.

4.

In the menu, click Project:<Project Name> > Project Settings .
Click the Filters tab to view the list of available filters.

Click Delete Filter for the filter that you want to delete. A confirmation dialog box displays, asking you
you to confirm the deletion.

Click Yes to delete the selected filter or No to abort the operation. If you click Yes, you will be returned
to the filters list and the deleted filter is no longer displayed.

Global Filter Details

Global filters allow you to quickly sort through elements in a Silk Central area, highlighting only those that
are relevant to your needs.

To view the details of a global filter, click Project:<Project Name> > Project Settings > Filters in the
menu, and click on the name of the filter.

The specific Silk Central area in which a new filter is available is defined by selecting the general filter
category.

Each global filter has to have a property, an operator, and a value from the respective list boxes:

Property Available properties depend on the filter category. It defines the property for which you are

defining a filter setting. If you selected an attribute category, the property list includes custom
attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type. For example, if you

select a property that is based on a string field type, the available operators are = (equals
defined value), not (differs from the defined value), contains (contains the defined value
somewhere in the string), and does not contain (does not contain the defined value in the
string).



Value The value that you want to filter out. Depending on the property type that you have selected,
values will either be strings that you can enter into the field, or a selection of predefined values
that you can select from the list box.

Recent Changes

The Recent Changes filter enables you to efficiently view and acknowledge changes and additions that
other users have made to requirements, tests, or execution plans project-wide since your last change
acknowledgement.

The two buttons at the far-right of the toolbar, the Show Changes/Show All toggle button and the
Acknowledge button, help you to find out what changes other users have made.

Note: Your system administrator can configure email notifications that alert you to changes that are
made to test settings. Email alerts include links that take you directly to a view of recent changes.

Applying Filters

After you have created and stored a custom filter, you can apply that filter to the selected tree. Custom
filters can be applied for requirements, tests and execution plans. Only elements that meet applied filter
criteria are displayed in the tree.

Note: Filtered requirements are returned in read-only form and can not be edited. The Edit
Properties button is disabled for filtered requirements.

To apply a stored filter:

1. Inthe menu, select the appropriate area: Requirements, Tests, or Execution Planning.
2. Select the desired filter from the Filter list box on the toolbar.
3. All elements that meet the filter’s criteria are displayed.

Note: To remove filtering and display all elements, select <No Filter> from the Filter list box on the
toolbar.

Change Notification

Silk Central can notify you by email when requirements or tests are changed by other users. Each user has
the option of activating change-notification. Once notification has been enabled, perform an initial
acknowledgment. From then on, you can view and acknowledge changes that have occurred since your
last acknowledgment. To avoid numerous notifications, only a single email alert is sent to you when a
change is made, regardless of how many changes other users may have made since your last
acknowledgment. Email alerts include links that take you directly to a view of recent changes.

Before you can activate change notification for requirements or tests, you must configure your email
address in the user settings of Silk Central.

Note: Change notification only works if an email server has been configured by your administrator. If
change notification has not been enabled, please contact your Silk Central administrator.

Enabling Change Notification

To enable change notification:

In the menu, click Project:<Project Name> > Project Settings .
Click the Notifications tab.
Click Configure Email Notification to open the Configure Email Notification dialog box.

If you want to be notified by email when changes are made to requirements in the currently selected
project, check the Changes on Requirements check box.
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5. If you want to be notified by email when changes are made to tests within the currently selected project,
check the Changes on Tests check box.

6. Click OK to save the notification settings, or click Cancel to abort the operation without saving changes.

You will be notified by email about changes for which you have activated notification.

Disabling Change Notification
To disable change notification:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Notifications tab.

3. Click Configure Email Notification to open the Configure Email Notification dialog box.
4

. If you do not want to be notified by email when changes are made to requirements in the currently
selected project, uncheck the Changes on Requirements check box.

5. If you do not want to be notified by email when changes are made to tests in the currently selected
project, uncheck the Changes on Tests check box.

6. Click OK to save the natification settings or click Cancel to abort the operation without saving changes.

Changes Triggering Change Notification

When you have activated change notification to inform you of changes that are made to requirements or
tests an email alert is sent to you, following your logout. The email alert is sent to you if one or more of the
following settings are changed:

Area Changes

Requirements « Arequirement is created or deleted.

e The name or description of a requirement is edited.

« A system property is edited.

* Arequirement is set as obsolete.

« Arequirement is recovered.

* Atestis assigned to or removed from a requirement.

* A custom property of a requirement is created, edited, or deleted.

Tests « A container is created or edited.

e A product is edited.

* A source control profile is edited.

» "Clear working folder" is edited.

» The root node is edited.

« The custom data directory is edited.

e The include directory is edited.

» The hidden test properties are edited.

» The Silk Test Classic interface is edited.
» Atestfolder is created, edited, or deleted.
*« Atestis created, edited, or deleted.

* The planned time is edited.

» Atest step is added or edited.

Notifications Page
Project:<Project Name> > Project Settings > Notifications

The Notifications page lists the notification events for the active project. For each notification event, the
Notifications page displays the following columns:
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Column Description

Notification Events Name of the natification event that has been set up for
the active project.

Status Status of the notification event. Active or inactive.

Click the Configure... button in each section to edit the values.

Email

When an email notification event is activated, a notification email is sent to the user that activated the
event, the first time one of the specified settings is changed.

f Note: You must have specified an email address to be able to receive email notifications.

Requirement Flagging

You can configure notifications differently for internal and external requirements. All requirement flagging is
enabled by default. For more information, see the Flags topic.

Managing Requirements

Add or edit requirements to establish and maintain agreement between customer and developer on both
technical and non-technical requirements.

Creating Requirements

To create a new requirement:

1. In the menu, click Requirements > Details View .
2. In the Requirements tree, select a requirement or the root node.

3. ., . . . :
Click =1 (New Requirement) on the toolbar to create a new requirement on the same hierarchical

level, or el (New Child Requirement) to create it hierarchically beneath the selected requirement. The
New Requirement dialog box appears.
4. Type a Name and a Description for the requirement.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
description fields.
5. Optional: Uncheck the Inherit from parent check boxes. In this case the child requirement will not
inherit the properties from the parent requirement. By default, all check boxes are checked.
Note: In the Details View on the Properties page and in the Document View, inherited
properties are marked with asterisks (*).
6. Select the appropriate Priority, Risk, and Reviewed status from the lists.

7. If custom requirements were defined, they are listed below the Reviewed list. Type in the corresponding
field any custom property data that you want to track with this requirement. This is disabled for inherited
properties. For details regarding creating, editing, and deleting custom requirement properties, see
Custom Requirement Properties.

8. To finish creating a new requirement:

» Click OK to create the requirement and to close the dialog box.
* Click OK and New Requirement to create the requirement and to keep the dialog box open to enter
data for another requirement.
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* Click OK and New Child Requirement to create the requirement and to keep the dialog box open to
enter data for a child requirement.

Editing Requirements
To edit the properties of a requirement:

1. Inthe menu, click Requirements > Details View .
2. In the Requirements tree, select a requirement.

3 Click [T (Edit) in the toolbar.

You can also right-click a requirement and click Edit or click the Properties tab and click Edit
Properties.

The Edit Requirement dialog box appears.
4. Type a Name and a Description for the requirement.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
description fields.
5. Optional: Uncheck the Inherit from parent check boxes. In this case the child requirement will not
inherit the properties from the parent requirement. By default, all check boxes are checked.
Note: In the Details View on the Properties page and in the Document View, inherited
properties are marked with asterisks (*).
6. Select the appropriate Priority, Risk, and Reviewed status from the lists.

7. If custom requirements were defined, they are listed below the Reviewed list. Type in the corresponding
field any custom property data that you want to track with this requirement. This is disabled for inherited
properties. For details regarding creating, editing, and deleting custom requirement properties, see
Custom Requirement Properties.

8. Click OK to save your changes.

Marking Requirements as Obsolete

Deleting requirements destroys them permanently. Sometimes it is preferable to mark requirements as
obsolete. Obsolete requirements can be hidden, shown, and recovered.

To mark a requirement as obsolete:
1. Inthe menu, click Requirements > Details View .
. In the Requirements tree, select a requirement.

2
3. Click % (Delete) in the toolbar or right-click the requirement and click Delete. A dialog box appears.
4. Click Yes.

f Note: The Destroy permanently check box is unchecked by default.

y Note: Obsolete requirements are displayed in italics in the Requirements tree.

To show obsolete requirements, right-click any requirement in the Requirements tree and click Show
Obsolete Requirements.

To hide obsolete requirements, right-click any requirement in the Requirements tree and click Hide
Obsolete Requirements.

Recovering Obsolete Requirements

To recover an obsolete requirement:



1. Inthe menu, click Requirements > Details View .

2. If the obsolete requirements are hidden, right-click any requirement in the Requirements tree and click
Show Obsolete Requirements.

3. Right-click on the obsolete requirement in the Requirements tree and click Recover.

y Note: Obsolete requirements are displayed in italics in the Requirements tree.

To hide the obsolete requirements again, right-click any requirement in the Requirements tree and click
Hide Obsolete Requirements.

Permanently Deleting Obsolete Requirements
To permanently delete an obsolete requirement:

1. Inthe menu, click Requirements > Details View .

2. If the obsolete requirements are hidden, right-click any requirement in the Requirements tree and click
Show Obsolete Requirements.

3. Inthe Requirements tree, select an obsolete requirement.

4. Click % (Delete) in the toolbar or right-click the requirement and click Delete. A dialog box appears.

5. Click Yes to permanently delete the requirement.

y Note: Obsolete requirements are displayed in italics in the Requirements tree.

To hide the obsolete requirements again, right-click any requirement in the Requirements tree and click
Hide Obsolete Requirements.

Requirements Reports

Requirements reports detail the status of functional requirements, for example compatibility requirements,
GUI requirements, or feature requirements, which must be met during development.

Requirements may also relate to product management objectives such as reliability, scalability, and
performance. The requirement-management reports help managers to determine if adequate test coverage
is established to verify that system requirements are met during development. When a report references a
requirement that includes HTML-formatted content, that content is rendered in the report.

Status Reports

The following status reports are available for the Requirements area:

Requirements Represents a grouped summary of all requirements by current requirement

Status Overview coverage. Coverage is expressed by the statuses Passed, Fai led, Not
Executed, and Not Covered.

Top-Level Represents a listing of all top-level requirements. For each requirement the

Requirement number of child requirements, that are covered and not-covered by tests, is

Coverage displayed.

Status of Represents a summary of all requirements by current requirement coverage. The

Requirements with  returned group of requirements is restricted by the Priority parameter, which

Priority Higher than specifies the lowest requirement priority that is considered in the data.
IXI

Requirement Displays the test details grouped by the execution plan that is associated to the
Impact Analysis requirement. This report allows the user to gain insight into testing assets that may
Report be impacted by a change to the requirement. The report contains the name,
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status, date/time of last execution, manual testers, planned time, and issues of
each test. The following statuses are used:

Passed The test passed.

Failed The test failed.

N/A The test is associated to a requirement but is not submitted for
execution.

Not Executed The test is associated to a requirement and is submitted for
execution but not executed yet.

Project Displays all requirements in a project along with their associated tests and issues.
Requirement The following statuses are used:
Traceability Report
Passed The test passed.
Failed The test failed.
N/A The test is associated to a requirement but is not submitted for
execution.

Not Executed The test is associated to a requirement and is submitted for
execution but not executed yet.

Progress Reports
The following progress reports are available for the Requirements area:

Requirements Coverage Across Represents a summary of all requirements by current requirement

Builds 'X"and 'Y’ coverage. The returned group of requirements is restricted by the
Priority parameter, which specifies the lowest requirement
priority that is considered in the data.

Requirements Coverage Over Represents a trend in requirements coverage by considering overall
the Past 'X' Days requirements coverage over 'X' days.

Specific Requirements Coverage Represents a trend in requirements coverage by considering specific
Over the Past 'X' Days requirements coverage over 'X' days.

Document Reports

The following document reports are available for requirements:

All Requirements All requirements are represented with full requirement information.
Requirement with Child The selected requirement is shown with its requirement ID. Full details
Requirements regarding the child requirements of the requirement are displayed.

All Related Issues Report

The All Related Issues report provides a detailed list of all issues related to the assigned tests for a
requirement, and explains the relationship between requirements, the assigned tests, and issues that have
occurred. The input parameter for the All Related Issues report is the identifier of the requirement.

Coverage

This section describes how to cover your requirements with tests.



Coverage Modes

Silk Central provides two modes for coverage. Full coverage and direct coverage. The status of a
requirement in the full coverage mode considers the status of the child requirements and offers a
cumulative view of the tests that cover the requirement. If one or more child requirements have the status
Not Covered, then the full coverage status of the selected requirement is also Not Covered, even if the
coverage status of the requirement is Covered. The full coverage mode enables easy evaluation of
whether or not requirements are covered by tests.

The status of a requirement in the direct coverage mode is calculated based only on the status of the tests
that are directly assigned to the requirement. Child requirements are not considered in calculations.

Switching Between Coverage Modes
To switch between full- and direct-coverage modes:
1. Inthe menu, click Requirements > Details View .

2. Click ©/# to respectively view direct coverage or full coverage.

Coverage Page
Requirements > Details View > Coverage

The Coverage page, which you can only access in Details View, displays basic properties of the selected
requirement or project. It also displays the status of all tests that are assigned to the requirement, including
the number and percentage of Passed, Failed, Not Executed, and Not Covered tests. A summary
of all assigned tests is listed under Total. Requirements that are not covered by tests are listed as Not
Covered.

The Details View page displays the same coverage status information in a “heat field” chart.

To view the status of all tests that are assigned to child requirements of the selected requirement in
addition to all tests that are directly assigned to the requirement, check the Full coverage check box.

Note: In both Details View and the Coverage page, test totals accumulate to the parent level. For
example, requirement totals include tests from child requirements and project totals include tests from
all requirements.

The Coverage page displays the following properties for each selected requirement or project:

Property Description

Requirement Name Name of the selected requirement or project.

Project Name

Priority Priority that has been assigned to the selected requirement.
Risk Risk that has been assigned to the selected requirement.
# Requirements (Calc.) Total number of all covered requirements. Not included in this number are

uncovered requirements and folders that do not have a test assigned to
them. For example folders that inherit the coverage of their child
requirements but are not actually a requirement themselves.

# Requirements (Total) Total number of all requirements beneath the selected entity, including
folders.

Requirement Status Status of the selected requirement or project.

Project Status » Passed
+ Failed
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Property Description

« Not Executed
« Not Covered

# Requirements Passed Total and percentage of requirements in the project that have tests that have
passed.

# Requirements Failed Total and percentage of requirements in the project that have tests that have
failed.

# Requirements Not Executed Total and percentage of requirements in the project that have tests that have
not been executed.

# Requirements Not Covered Total and percentage of requirements in the project that are not covered by
tests.

Total Total number of requirements in the project.

Flags

Flags indicate that a requirement has changed or needs to be reviewed. Requirements with flags appear in
the requirements tree with flag icons. There is also a section in the requirement properties to view flag
information.

You can add and remove flags as needed and others will see the flag when they look at the requirement.
You can also flag a requirement and all of its children. There can only be one flag on an item at a time and
setting a flag on an item that already has a flag will overwrite the flag. Changes to the requirement flag are
maintained in the requirements change history.

If you are integrating with an external requirements management tool, you will also see flags from new or
updated external requirements. The following are scenarios about how flags are applied for integrated
requirements:

» If you add a requirement to the requirements management tool after initial synchronization, then a
subsequent synchronization is performed, when the new requirement is added to Silk Central, it will
display with an added flag to indicate it was created during an update.

» If you edit a requirement that has been synchronized to Silk Central, the requirement in Silk Central will
be flagged with a updated flag to indicate it was updated.

Setting a Flag
Set a flag on a requirement to indicate to others that the requirement has changed or needs to be
reviewed.

To set a flag on a requirement:

1. Inthe menu, click Requirements > Details View .

Select the requirement in the Requirements tree.

Right click the requirement and choose Flag > Set Flag . The Set Flag dialog box opens.
Type a comment for the flag in the Comment field.

To set the flag for all children of the currently selected requirement, click the Set flag on child
requirements check box.

6. Click Ok.

f Note: The flag information is available on the Properties page of the requirement.
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Clearing a Flag

Clear a flag from a requirement when all changes are acknowledged or the requirement is reviewed.




To clear a flag from a requirement:

In the menu, click Requirements > Details View .
Select the requirement in the Requirements tree.
To clear a single flag: Right click the requirement and choose Flag > Clear Flag .

To clear the flag for all children of the selected requirement: Right click the requirement and choose
Flag > Clear Flag - Include Children . The flag information is removed from the Properties page of
the requirement.
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y Note: You can also clear the flag by clicking Clear Flag on the Properties page of the requirement.

Creating a Filter for Flagged Requirements
Create a filter for flagged requirements to see only the requirements in the Requirements tree that apply
to the filter condition.

To create a filter for flagged requirements:

In the menu, click Requirements > Details View .

Click New Filter. The New Filter dialog box opens.

Select Requirements Property from the Selection Criteria list.
Select Requirement State from the Property list.

Select = from the Operator list.
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Select one of the following values from the Value list:

None No flag is selected
Flagged Manual User manual added a flag to a requirement.
Flagged New Requirement was created.
Flagged Updated Requirement was updated.
Obsolete Requirement is marked as obsolete.
7. Click Save and Apply.

Note: If child requirements are flagged, but one or more parent requirements are not flagged, the
full path to the flagged child requirements will display, but with the parent requirements disabled.
You cannot set or clear the flag for parent requirements that are in this state.

Configuring Requirement Properties

Configure requirement properties, attachments, flags, and coverage.

Besides the given default properties, you can also create your own requirement properties in Silk Central.
These custom properties can be edited in the Edit Requirement dialog box just like the default properties.

To create custom properties for the active project, click Requirements > Requirement Properties in the
menu and click New Requirement Property.

Custom properties are displayed in the Requirements Details View on the Properties page and in the
Requirements Document View.

For additional information on custom requirement properties, see Custom Requirement Properties.

Replacing Requirement Properties

To replace the property value of one or more requirements:
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1. Inthe menu, click Requirements > Details View .

2. Click % (Replace) in the toolbar or right-click a requirement and click Replace. The Replace dialog
box appears.

3. Select a requirement property from the Find in list.
This list contains all default and custom properties.

4. In the Find what area, define your search criteria.

The Ul controls of the Find what area vary, based on the selected property. For example: If you select
the property Risk two lists appear, if you select the property Description a text field and two check
boxes appear.

5. In the Replace with area, enter the value that shall replace the identified data.
6. Optional: Check the Case sensitive check box to consider uppercase and lowercase letters.

7. Optional: Check the Match whole word only check box to include just complete standalone instances
of the string.

8. Click OK. The first requirement that meets the search criteria is highlighted in the Requirements tree.
9. Click one of the following:

* Replace: Replaces the property value of the highlighted requirement.

* Replace All: Replaces the property value of all requirements that contain the defined value.
* Find Next: Highlights the next requirement that contains the defined value.

* Find Previous: Highlights the previous requirement that contains the defined value.

* New Replace: Opens the Replace dialog box again, where you can set new values.

* Close: Closes the dialog box.

Note: If you click Replace all, all inherited properties will be overwritten. Child requirements also

lose their inheritance setting in this case. Use Replace only on a parent requirement if you want
the child requirements to inherit the new value.

Finding Requirement Properties

In the Requirements area, you can locate requirements that meet certain search criteria with the Find
command. You can also replace identified property data with alternate data that you specify with the
Replace command. Both commands offer Find Next and Find Previous functions that allow you to step
through all identified properties.

To find a requirement:

1. In the menu, click Requirements > Details View .
2. select & on the toolbar to open the Find dialog box.

f Note: This command can also be executed by right-clicking a requirement and selecting Find.

3. Select a requirement property from the Find in list.
This list contains all default and custom properties.
4. In the Find what area, define your search criteria.

The Ul controls of the Find what area vary, based on the selected property. For example: If you select
the property Risk two lists appear, if you select the property Description a text field and two check
boxes appear.

5. Click OK to begin your search. The first requirement that meets the search criteria will be highlighted in
the tree view. The first requirement that meets the search criteria will be highlighted in the tree view.

6. Click Find Next on the Find dialog box to advance to the next requirement in the list that meets your
search criteria. Click Find Previous on the Find dialog box to return to the previous requirement in the
list that meets your search criteria.



Note: When you reach the last or first requirement that meets the search criteria and respectively
click Find Next or Find Previous, the search starts from the beginning.

Requirement Properties Page

Requirements > Details View > Properties

The Requirement Properties page displays high-level information about the selected requirement or

project.

When requirements are synchronized with an external requirements management system, items are
sometimes marked with an exclamation mark (). This means that the marked field is not mapped to the
external requirements management system. Use the property mapping feature to map property fields. If
you don't use the property mapping feature, only the name and the description of the requirements are
mapped. For more information, see Editing Property Mapping.

Item values that are marked with an asterisk (*) are values that are inherited from the parent requirement.

Click Edit Requirement Properties to edit the displayed properties.

The following table only applies to requirements that have a flag set.

Item Description

Flagged By Indicates who set the flag and when the flag was set.
Comment Indicates the comments for the flag.

Clear Flag Click to remove the flag.

Properties page.

The following table lists the properties of the selected requirement or project that are displayed on the

Property

Description

Requirement Name
Requirement ID
Description

Priority

Risk

Reviewed

Custom Properties

Document

Created On
Created By
Changed On
Changed By

Name of the requirement.

Identifier of the requirement.

Description of the requirement.

Priority that has been configured for the requirement.
Risk that has been configured for the requirement.
Current review status of the requirement. Yes or No.

If custom properties have been configured for the
requirement, they are listed here.

Source document (if any) from which this requirement
was derived.

Date on which this requirement was created.
Name of the user who created this requirement.
Date on which this requirement was last updated.

Name of the user who last updated this requirement.

Requirement Attachments

You can upload multiple files or links as attachments to requirements or delete attachments. When you cut
and paste requirements that have attachments, the attachments are automatically included with the copies.

The following attachment types are available:
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Uploaded Files
References to UNC paths
References to URLS, including StarTeam URLs

Attaching Files to Requirements

To attach a file to a requirement:

1.
2.
3.

N o o &

In the menu, click Requirements > Details View .

Select the requirement in the Requirements tree.

Click the Attachments tab.

When requirements management integration has been enabled between a Silk Central project and a

Caliber project, the Attachments page includes an Open Caliber button, which enables you to manage
requirement attachments directly in Caliber.

Click Upload File. The Upload File dialog box appears.

Click Choose File and select the file that you want to attach from your local file system.

Type a Description for the attachment.

Click OK. The attachment is uploaded to the server and associated with the selected requirement.

Attaching Links to Requirements

To attach a link to a requirement

1.
2.
3.

N o o A

In the menu, click Requirements > Details View .

Select the requirement in the Requirements tree.

Click the Attachments tab.

When requirements management integration has been enabled between a Silk Central project and a

Caliber project, the Attachments page includes an Open Caliber button, which enables you to manage
requirement attachments directly in Caliber.

Click Attach Link. The Attach Link dialog box appears.

Type the URL in the Link field.

Type a Description for the attached link.

Click OK. The link is associated with the selected requirement.

Viewing Requirement Attachments

To view a requirement attachment:

1.
. Select the requirement in the Requirements tree.

In the menu, click Requirements > Details View .

Click the Attachments tab.

When requirements management integration has been enabled between a Silk Central project and a
Caliber project, the Attachments page includes an Open Caliber button, which enables you to manage
requirement attachments directly in Caliber.

A list of all attachments that are associated with the requirement opens. Each attachment name serves as
a link. File-attachment links open Save As dialog boxes, enabling you to download attachments to your
local file system. Link-attachments link directly to link destinations in newly spawned browser windows.

Downloading Files from Requirements

To download all files from a requirement:



1. Inthe menu, click Requirements > Details View .
2. Select the requirement in the Requirements tree.
3. Click the Attachments tab.

When requirements management integration has been enabled between a Silk Central project and a
Caliber project, the Attachments page includes an Open Caliber button, which enables you to manage
requirement attachments directly in Caliber.

4. In the Attachments section, click Download All Files. All attached files are downloaded to your local
disk as a zip archive, depending on how you configured your browser's download settings.

Note: To prevent from excessive downloads, Download All Files is disabled if Include Child
Attachments is checked.

Deleting Attachments from Requirements
To delete a requirement attachment:
1. In the menu, click Requirements > Details View .

2. Select the requirement in the Requirements tree.
3. Click the Attachments tab.

When requirements management integration has been enabled between a Silk Central project and a
Caliber project, the Attachments page includes an Open Caliber button, which enables you to manage
requirement attachments directly in Caliber.

4. click % in the Actions column of the attachment that you want to delete.
5. Click Yes on the confirmation dialog to delete the attachment from the project.

f Note: Only one attachment at a time can be deleted.

Requirement Attachments Page
Requirements > Details View > Attachments

The Attachments page lists files and links that are attached to the selected requirement. The attachments
are displayed in the order in which they are uploaded, though the list of attachments can be sorted by
Name, Created On, and Created By properties.

Note: To display any attachments that are associated with child requirements of the selected
requirement, check the Include Child Attachments check box.

Note: The file icons indicate whether documents are directly attached to the selected requirement, or
whether they are attached to a child requirement of the selected requirement.

Single icon The file is directly attached to the selected requirement.

Double icon  The file is attached to a child requirement of the selected requirement.

The Attachments page displays the following columns for each listed attachment:

Column Description

Actions Click ¢ to delete the attachment.
Attachment Icon Depends on the type of the attachment.
Name Name of the attachment.

Size Size of the attachment.

Description Description of the attachment.
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Column Description

Created On When the attachment was created.

Created By User who created the attachment.

Associating Tests with Requirements
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Associate your requirements and tests to enable measuring how well your software covers the specified
requirements.

Assigning Tests from Grid View to Requirements
To assign one or more tests from the test area Grid View to one or more requirements:

1. In the menu, click Tests > Details View .

2. Click [# on the toolbar.
3. Select the tests that you want to assign to requirements.

You can use your keyboard's Ctrl and Shift keys to select multiple tests using standard browser multi-
select functions.

Right-click the selected tests and select Save Selection.

In the menu, click Requirements > Details View .

Select the requirement to which you want to assign the selected tests.
Click the Assigned Tests tab.

Click Assign Saved Selection.

© N o oA

Note: Only tests that reside in the requirements test container are assigned. You can assign the
selected tests to more than one requirement but you cannot assign them into requirements in a
different project. The selection persists until you make a different selection or close Silk Central.

Assigning Tests to Requirements Manually
To manually assign tests to a requirement:

1. Inthe menu, click Requirements > Details View .
2. Select the requirement in the Requirements tree.

3. Click the Assigned Tests tab. All tests that are available for assignment are displayed in the Test
window.

4. If you have created a test filter, you can select it from the filter list above the Test window.
To create a new test filter, navigate to the Tests area and click New Filter on the toolbar.

5. Select the tests that you want to assign.
You can use your keyboard's Ctrl and Shift keys to select multiple tests using standard browser multi-
select functions.

6. Drag your selection and drop it into the Assigned Tests area, or click + left of any test.
Assigning a test container or test folder assigns all tests that are located in those containers or folders
to the selected requirement. Tests that are located within sub-folders of those containers and folders are
also assigned.

) Tip: Right-click a node to expand and collapse it.
(2]




Locating Assigned Tests in the Tests Tree
To locate an assigned test in the Tests tree:

In the menu, click Requirements > Details View .

Click =l in the toolbar.
Select a requirement in the Requirements tree that has at least one test assigned to it.
Click the Assigned Tests tab.

In the Actions column of a test, click % to find out in which test folder or container the test is stored in.
The corresponding test folder or container is highlighted in the Tests window.

o~ w D PRE

Removing Test Assignments
To remove a test assignment:

In the menu, click Requirements > Details View .

Click [l in the toolbar.
Select a requirement in the Requirements tree that has at least one test assigned to it.

A w Dd R

In the Actions column of the assigned test you want to remove, click X, or use Ctrl+Click or Shift
+Click to select multiple tests and press Del.

i Note: To remove all test assignments from the selected requirement, click Remove All.

Generating Tests from Requirements Details View

You can generate tests directly out of the Requirements tree and assign tests to specific requirements.
The Requirements tree serves as a template for the test folder/test structure of the new Tests tree.

To generate a new test from the Details View:

1. In the menu, click Requirements > Details View .

2. Right-click the requirement or project node that you want to convert into a test and select Generate
Tests. The Generate Tests from Requirements dialog box appears. This dialog box enables you to
specify whether the leaves, which means the lowest-level nodes, of the selected requirements sub-tree
should be converted into tests or test folders and whether the tree should be generated into a new test
container or an existing container.

3. Enter a name for the new test container in the Enter Name field and select a product from the Select
Product list to create the container within the active Silk Central project.

The Select Product list is populated with the products that are configured by a project manager. For
detailed information, see Managing Products or ask your project manager.

4. If you have defined a source control profile, select the source control profile you want to use for
managing the test sources from the Select Source Control Profile list.

For detailed information on source control profiles, see Source Control Profiles or ask your Silk Central
administrator.

5. To include all child requirements of the selected requirement in the test, check the Include Child
Requirements check box.

The check box is checked by default.

6. To have the new tests automatically assigned to the requirements from which they are created, check

the Assign newly generated tests to Requirements check box.

If this option is not selected, tests must be manually associated with requirements.
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Note: This option is not available when checking Generate test folders from requirement tree
leaves.

7. Click OK to create the test.
The new test has the same structure as the Requirements tree.

8. A message box displays. Click Yes to view the test in the Tests area, or click No to remain in the
Requirements area.

Assigned Tests Page

Requirements > Details View > Assigned Tests

The Assigned Tests page lists all tests that are assigned to the selected requirement. If a test is assigned
to more than one execution plan and the Display in Execution Context check box is checked, the test is
displayed in a separate line of the grid for each execution plan.

All tests that are available for assignment are displayed in the right-hand Tests tree. To assign a test to the
selected requirement, double-click on the entry in the tree or click « to the left of the entry.

If you have created a test filter, you can select it from the filter list above the Tests tree. To create a new
test filter, navigate to the Tests area and click New Filter on the toolbar.

To automatically assign newly generated tests to the requirements from which they are generated, check
the Assign newly generated Tests to Requirements check box on the Generate Test from
Requirements dialog box.

The default view displays only those tests that are assigned directly to the selected requirement. Check the
Full Coverage check box to additionally display all tests that are assigned to child requirements of the
selected requirement. When Full Coverage is checked, tests that are not assigned to the selected
requirement, but are assigned to a child of the requirement, are displayed with an overlay over the test-type
icon.

If you have copied a set of tests from Tests > Grid View to the clipboard, click Assign Saved Selection to
assign the entire set to the selected requirement. Click Remove All to remove all assigned tests from the
requirement.

To assign existing issues to one or more tests directly in the grid, right-click a test and click Assign
Existing Issues. You can select multiple tests with Ctrl+Click or Shift+Click.

The Assigned Tests page displays the following columns for each listed test:

Column Description

Actions You can perform the following actions on an assigned test:

Click ¢ to remove the assigned test from the requirement.
¢ Click « to locate the assigned test in the right-hand Tests tree.

Test Name of the assigned test. Click to view and edit the test. For configuration testing, the
test is separately listed for each configuration.

Execution Plan This column is only displayed if the Display in Execution Context check box is
checked. Name of the execution plan that includes the assigned test. For configuration
testing.

Execution Plan Parent The configuration suite, folder, or testing cycle in the context of which the execution

plan is executed. Click to access the suite or folder in the Execution Plans tree. If the
execution plan is not included in a configuration suite or folder, nothing is displayed.

Status Status of the assigned test in each execution plan to which the test is assigned. To
display the status of all runs of the displayed tests in each execution plan, check the
Display in Execution Context check box.
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Column Description

e Passed

e Failed

¢ Not Executed
« N/A

For tests or test packages that are included in a configuration suite, the status is an
aggregation of all statuses of all configurations within the suite:

« If the test is assigned only to the configuration suite, the status is Passed only if it
is passed in all configurations. If the status is not Passed in all configurations, the
status of the worst run is propagated, with the following top-down priority:

N/A

Not Executed
Failed
Passed

PN PE

The status of a requirement that is assigned to the test is Fai led if the test fails
in one or more of the configurations.

* We do not recommend assigning the test to a configuration suite and one or more
simple execution plans. However, in this case, the aggregate of the configuration
statuses is one status, and the last statuses of the execution plans are other
statuses. The status that was executed last determines the last status of the test.

« If the test is assigned to a simple execution plan only, the status is updated in
response to the status of the last test run.

Last Execution Time and date of the last execution of the test.

Issues This column is only displayed if the Display in Execution Context check box is not
checked. Issues that are associated with this test.

Requirements Import

Silk Central enables you to import requirements from Microsoft Word and Excel. You can import a
requirement into the Requirements area and then maintain all included requirements in Silk Central. The
import is a one-time event.

Importing Requirements from a Word File

Before you can import requirements, you need to create a requirements file in Word. For more information,
see Word Requirements File.

Silk Central uses the information stored in the Word file and in a mapping file to determine what data to
store and captures only the information that is mapped with certain styles. Silk Central uses a mapping file
to map the requirements in the Word file to the Silk Central requirements. A default mapping file named
RequirementsPropertiesDefaul tMapping.xml is preselected for the import. You can choose your
own customized mapping file to map your requirements.

docx functionality: The functionality for docx is the same as for doc with the following improvements:

« Images and any other embedded object (OLE) (for example: PDF, Excel) are detected and imported as
an attachment to a requirement.
« Descriptions may contain hyperlinks.

To import requirements from a Word file into the Requirements unit:
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1. Inthe menu, click Requirements > Details View .
2. Right-click the requirement that you want to use as the parent node of the imported requirements and
choose Import from Word.... The Import Requirements from Word File dialog box opens.

3. Select the mapping file from the Choose Mapping File list box. The default mapping file is
RequirementsPropertiesDefaultMapping.xml.

Optional: Click i) to edit the mapping file. Click X to delete the mapping file. For more information,
see Word Requirements File.

Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.

5. Check the One-Time Import check box if this is a one-time bulk import of requirements, which will only
be maintained in Silk Central after the import. Selecting this option imports the requirements directly
under the selected node without creating a common root folder. You cannot use the Update from
Word... option to update the imported requirements afterwards.

6. Either type the fully qualified path of the requirements file into the Requirements File field or click
Choose File to search for the requirements file.

7. Click OK. A message informs you if the import was successful. Click OK to close the message.

Updating Requirements from a Word File

Silk Central enables you to update requirements that were imported from Microsoft Word. You can change
the requirements in the Word document and then update them in the Requirements area. You can also
change the mapping file to change the mapping of the requirements in the Requirements area.

Note: You can only update a requirement for which a unique external ID is defined in the Word file
that has previously been imported. Silk Central requires this ID to identify which requirement needs to
be updated.

1. Inthe menu, click Requirements > Details View .

2. Right-click the parent node of the previously imported requirements (for example Imported from
file "RequirementExample.docx®) and choose Update from Word.... The Update
Requirements from Word File dialog box opens.

3. Select the mapping file from the Choose Mapping File list box. The default mapping file is
RequirementsPropertiesDefaultMapping.xml.

Optional: Click K| to edit the mapping file. Click X to delete the mapping file. For more information,
see Word Requirements File.

Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.
5. Either type the fully qualified path of the requirements file into the Requirements File field or click
Browse to search for the requirements file.

6. Click OK. A message informs you if the update was successful. Click OK to close the message.

Word Requirements File

Create a requirements file in Word to import requirements into Silk Central or to update them. In the
requirements file, define requirements and their hierarchy, along with their priorities, risks, review status,
and custom properties.

To map the requirements in your requirements file to the requirements in Silk Central, use an XML mapping
file. The mapping file maps the styles in the Word document to the requirement properties in Silk Central.
You can name the Word styles as you want, as long as you map them appropriately in your mapping file.
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If you want to be able to update the requirements, you must define a style for the external ID and assign a
unigue external ID to each of the requirements in the requirement file. The following example shows a
sample requirement, two subrequirements, and the corresponding external IDs:

Word file Applied styles

Customer Account Management - Basics Formatted with Word style "Heading 1"
iID_1 Formatted with Word style "ExternallD"
As user of the web shop 1 want to be Formatted with Word style

able to ... "Description”

Medium Formatted with Word style "Priority”
High Formatted with Word style "Risk™

No Formatted with Word style "Reviewed"
Customer Account Management - Formatted with Word style "Heading 2"
Personal Details Formatted with Word style "ExternallD"
ID 1.1 Formatted with Word style

As user of the web shop 1 want to be "Description”

able to ... Formatted with Word style "Priority"
Medium Formatted with Word style "Risk™
Medium Formatted with Word style "Reviewed"
No

Formatted with Word style "Heading 2"
Formatted with Word style "ExternallD"
Formatted with Word style

Customer Account Management -
Shipping Details

ID 1.2 "Description”

As user of the web shop 1 want to be Formatted with Word style "Priority"
able to ... Formatted with Word style "Risk™
Medium Formatted with Word style "Reviewed"
Medium

No

Optionally, change the name of the mapping file in the Save as field. This file is saved on the application
server in <Silk Central data directory>\OfficelmportMappingFiles\requirements
\<client I1D>, for example C:\ProgramData\Si lkCentral\instance_<instance
number>_<instance name>\OfficelmportMappingFiles.

Importing Requirements from an Excel File

Before you can import requirements, you need to create a requirements file in Excel. For more information,
see Excel Requirements and Mapping File.

Silk Central uses the information stored in the Excel file and in a mapping file to determine what data to
store and captures only the information that is mapped with certain column names. Silk Central uses a
mapping file to map the requirements in the Excel file to the Silk Central requirements. A default mapping
file named RequirementPropertiesXlsxDefaultMapping.xml is preselected for the import. You
can choose your own customized mapping file to map your requirements.

f Note: Importing attachments (images, graphs) is not supported.

To import requirements from an Excel file into the Requirements unit:

1. Inthe menu, click Requirements > Details View .
2. Right-click the requirement that you want to use as the parent node of the imported requirements and
choose Import from Excel.... The Import Requirements from Excel File dialog box opens.

3. Select the mapping file from the Choose Mapping File list box. The default mapping file is
RequirementPropertiesXlsxDefaultMapping.xml.

Optional: Click ) to edit the mapping file. Click X to delete the mapping file. For more information,
see Excel Requirements and Mapping File.
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Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.

5. Check the One-Time Import check box if this is a one-time bulk import of requirements, which will only
be maintained in Silk Central after the import. Selecting this option imports the requirements directly
under the selected node without creating a common root folder. You cannot use the Update from
Excel... option to update the imported requirements afterwards.

6. Either type the fully qualified path of the requirements file into the Requirements File field or click
Choose File to search for the requirements file.

7. Click OK. A message informs you if the import was successful. Click OK to close the message.

Updating Requirements from an Excel File

Silk Central enables you to update requirements that were imported from Microsoft Excel. You can change
the requirements in the Excel document and then update them in the Requirements area. You can also
change the mapping file to change the mapping of the requirements in the Requirements area.

Note: You can only update a requirement for which a unique external ID is defined in the Excel file
that has previously been imported. Silk Central requires this ID to identify which requirement needs to
be updated.

1. In the menu, click Requirements > Details View .

2. Right-click the parent node of the previously imported requirements (for example Imported from
file "RequirementExample.xslx") and choose Update from Excel.... The Update
Requirements from Excel File dialog box opens.

3. Select the mapping file from the Choose Mapping File list box. The default mapping file is
RequirementPropertiesXlsxDefaultMapping.xml.

Optional: Click i) to edit the mapping file. Click X to delete the mapping file. For more information,
see Excel Requirements and Mapping File.

Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.
5. Either type the fully qualified path of the requirements file into the Requirements File field or click
Browse to search for the requirements file.

6. Click OK. A message informs you if the update was successful. Click OK to close the message.

Excel Requirements and Mapping File

Create a requirements file in Excel to import requirements into Silk Central or to update them. In the
requirements file, define requirements and their hierarchy, along with their priorities, risks, review status,
and custom properties.

To map the requirements in your requirements file to the requirements in Silk Central, use an XML mapping
file. The mapping file maps the columns in the Excel document to the requirement properties in Silk
Central. You need the Modify Office import mapping files permission to edit the mapping file.

Property Mappings

Click Edit Mapping on the Import Requirements from Excel File or Update Requirements from Excel
File dialog to map the requirements in your Excel file to Silk Central as follows:

* Header Row: Specify the row in your Excel requirements file which contains the column names to be
used for mapping the properties.

* First Data Row: Specify the row that contains the first requirement. This row and all rows below are
interpreted as requirements.

* Separator Characters: Specify the characters that should be interpreted as separators within property
values. This is used for multi-list properties.



* Name, Description: Specify the column names in the header row that are mapped to requirement
name and description, respectively.

» External GUID: Specify the column name in the header row that contains the unique ID within your
requirements file for each requirement. These IDs can be used in External Parent GUID to create a
hierarchy of your requirements.

« External Parent GUID: Specify the column name in the header row that contains the parent of a
requirement. In your requirements file, enter the parent's External GUID to specify the parent of a
requirement. If this cell does not contain data, the requirement is added directly to the generated root
requirement. The following rules apply:

< If a requirement has no parent ID set, it is added as a child to the generated root requirement

« If arequirement has an invalid parent ID, it is added as a child to the generated root requirement

« If a requirement has its own external ID set as parent ID, it is added as child to the generated root
requirement

< If two or more requirements have a circular dependency through their parent IDs, they are not
imported into Silk Central

* Priority, Risk, Reviewed: Specify the column names in the header row that are mapped to the
localized values for these properties.

» If you have defined custom properties, specify the column names in the header row for each of them to
be mapped correctly.

* Save as: Specify the name of the file to be saved with your mapping information. This file is saved on
the application server in <Silk Central data directory>\OfficelmportMappingFiles
\requirements\xIsx\<client ID>, for example C:\ProgramData\SilkCentral
\instance_<instance number>_<instance name>\OfficelmportMappingFiles
\requirements\xIsx\1.

Sample Excel Requirements File

The following example shows a sample requirement, two subrequirements, and the corresponding external
IDs. This sample Excel requirements file matches the default property mappings.

1 RequirementName RequirementDescription ID ParentID  Priority Risk Revie
wed

2 Customer Account As user of the web shop ! ID_1 Medium High No
Management - Basics want to be able to ...

3 Customer Account As user of the web shop! ID_1.1 ID_1 Medium Medium No
Management - Personal want to be able to ...
Details

4 Customer Account As user of the web shop! ID_1.2 1ID_1 Medium Medium No
Management - Shipping want to be able to ...
Details

Requirement Views

Silk Central offers several views and tools to manage your requirements.

Requirements Tree

Requirements are displayed, organized, and maintained through a hierarchical tree structure, the
Requirements tree. Each node in the Requirements tree represents a requirement. Each requirement
can have any number of child requirements associated with it. The Requirements tree enables you to
organize requirements in any number of hierarchical levels.
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Note: When the Requirements tree includes more elements than can be displayed at once without
impacting response time, elements are displayed in increments. Page number links at the bottom of
the tab allow you to browse through the elements included in the tree one page at a time. To display
all elements as a single list, select the [All] link.

Keyboard Functions (Requirements)

The following actions can be performed on the selected nodes:

Keys Action

Up Move selection up

Down Move selection down

Right Expand element

Left Collapse element

F2 Edit element

Ctrl+C Copy element

Ctrl+X Cut element

Ctrl+V Paste element

Del Delete element

Ctrl+Up Move element up

Ctrl+Down Move element down

Click Select an element and remember it as the current element.

Ctrl+Click Toggle the selection status of the clicked element and add/remove additional elements with further
clicks.

Shift+Click Select the span from the currently-selected element to a newly selected element.

Shift+Up Select element above.

Shift+Down Select element below.

Enter Assign element (only in assignment tree)

Collapsing or Expanding the Requirements Tree

To collapse or expand the Requirements tree:

1. Inthe menu, click Requirements > Details View .
2. Select the requirement folder in the Requirements tree and continue with one of the following options:

* Click * to the left of the name of the requirement folder to expand the folder.
* Click 4 to the left of the name of the requirement folder to collapse the folder.
* Right-click on the folder and select Expand or Collapse. You can expand two, three, or all levels at
once by using the command in the context menu
Filtering the Requirements Tree

If you filter a subtree, only the selected node and the child nodes are shown. All other nodes are
temporarily hidden. This can be useful if you want to generate a PDF with a subset of all requirements.

To filter a subtree of the Requirements tree:

1. In the menu, click Requirements > Details View .
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2. Right-click a requirement in the Requirements tree and click Filter Subtree.
i Note: This automatically creates a custom filter in the filter list, which is placed in the toolbar. You

can save this filter by clicking v (Edit Filter), clicking Advanced, and entering a name for the
filter.

3. To disable the filter, select <No Filter> from the filter list in the toolbar.

Requirements Toolbar Functions

Requirements > Details View
Requirements > Document View
The requirements toolbar provides important commands for managing your requirements.

Note: Some commands in the requirements toolbar are also available through context menus in the
Requirements tree.

The following commands are included in the requirements toolbar:

Command Icon Description

Details View = Displays the Details View, which enables you to drill deeply into the
properties of a single requirement.

Document View & Displays the Document View, which shows selected properties of all
requirements in a single view.

New Requirement i Adds a new requirement to the active project.

New Child Requirement # Adds a new child requirement to the selected requirement.

Edit Eif Edits the selected requirement.

Delete % Marks the selected requirement as obsolete or destroys it permanently.
Obsolete requirements can be hidden, shown, and recovered.

Cut 4 Cuts a requirement from the Requirements tree and saves it to the
clipboard.

Copy EE) Copys a requirement from the Requirements tree to the clipboard.

Paste ) Pastes a requirement from the clipboard to the Requirements tree.

Paste as Child iy Pastes a requirement from the clipboard as a child requirement to the
currently selected requirement.

Move Up E 5 Moves a requirement up within the Requirements tree.

Move Down E B Moves a requirement down within the Requirements tree.

Find S Searches through all requirements in the active project based on
configurable parameters.

Replace s Replaces instances of found values with a new value.

New Filter 7 Creates a new filter for the Requirements tree.

Filters Lists the available filters for the Requirements tree.

Edit Filter R Edits the selected filter.
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Command Icon Description

Delete Filter W% Deletes the selected filter.

Copy Filter B Copys the selected filter.

Show Changes E Shows recent changes to the requirements and their properties.
Acknowledge g Acknowledges changes to the requirements and their properties.

Show Direct Coverage 0 Toggles between direct and full coverage modes. This button is disabled in

the Details View.

Show Full Coverage ga
3
Download as PDF ot Generates and downloads a PDF with all currently visible nodes of the
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Requirements tree. This button is disabled in the Details View.

Requirements Document View

Requirements > Document View

The Document View displays the status of all tests that are assigned to the active project, including the
number and percentage of Passed, Failed, Not Executed, and Not Covered tests. The Document
View displays this coverage status information in a “heat field” chart, with the following colors:

Color Description

Green Passed tests.

Red Failed tests.

Orange Tests that are not executed yet.
Gray Test with other status.

Requirements that are not covered by tests are listed as Not Covered.
The Document View displays all custom requirement properties as columns.

Note: Test totals accumulate to the parent level, for all currently displayed tests. If you apply a filter to
the Requirements tree, the test totals are based on the filtered requirements only. For example, the
requirement totals include tests from all child requirements that are selected with the filter, and the
project totals include tests from all requirements that are selected with the filter.

The Document View individually saves the display settings for each user and each project.

Requirement History

Silk Central provides a complete history of all changes that are made to requirements. History information
is read-only, and cannot be edited or permanently deleted.

The Recent Changes filter, which you can access by clicking “& on the toolbar, enables you to efficiently
view and acknowledge the latest changes and additions that have been made to requirements.

Note: When you delete a requirement with the Destroy permanently option, you delete a
requirement that is marked as obsolete, or if you acknowledge all recent changes, a change history
entry is added to the history file of the project, to which the requirements belong.

Viewing Recent Changes

To view recent changes to requirements:



In the menu, click Requirements > Details View .

Click "2 to filter out all requirements except those that have been changed since your last change
acknowledgement.

i Note: The recent changes filter is selected automatically in the Filter list box.

When you have reviewed the changes, you can accept them by clicking "
The acknowledge function resets the recent changes filter.

Click " again to remove filtering and see all requirements.

Tracking the History of a Requirement

To view a requirement’s history:
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In the menu, click Requirements > Details View .
Select the requirement in the Requirements tree.
Click the History tab.

Optional: When requirements management integration between a Silk Central project and a Caliber
project is enabled, you can click Open Caliber in the History page to view the history of synchronized
requirements directly in Caliber.

The properties of all revisions that have been logged by Silk Central are displayed in tabular format.

Requirement History Page

Requirements > Details View > <Requirement> > History

The History page details the revision history of the selected requirement or project. The following actions
generate requirement history entries:

Adding a new requirement

Editing a requirement

Marking a requirement as obsolete

Adding an attachment to a requirement

Deleting an attachment from a requirement

Importing or updating a requirement through MS Word or MS Excel

For each change, the page displays the following columns:

Column Description

Rev. Revision number. 1-n.

Changed On Date and time of the change.

Changed By User that made the change.

Notes Automatically generated description of the change. For
example, “deleted” or “created”.

Note: When the page includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Use the navigation toolbar at the bottom of the
page to browse through the elements.

Requirements
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This section explains how to manage tests in Silk Central.

A test, or test case, is a set of input values, execution preconditions, expected results and execution
postconditions, developed for a particular objective or test condition, such as to exercise a particular
program path or to verify compliance with a specific requirement [after IEEE 610]. Silk Central supports
various test types, and tests can be structured in several ways. The Tests area enables you to maintain
control over tests across the system development life-cycle. You can create, schedule, and manage both
automated tests and manual tests. You can upload and associate files and links as attachments to test
containers and tests. You can easily associate found issues with the tests that led to their discovery. You
can also track the full change history of the test in the area.

Configuring Test Settings and Integrations

Before you can start building up your testing framework, you need to at least configure a project and a
product and, if you plan to create automated tests, also a source control profile. You may also need to
configure certain other settings, like filters, properties, attributes, etc. You need SuperUser, administrator,
or project manager privileges to perform these tasks.

Managing Products, Components, Versions, and Builds

Silk Central enables you to create and organize products, product components, versions of products, and
build numbers of product versions. Product specifications can then be associated with tests, versions and
builds can be associated with execution plans. You can even import products and components that were
defined previously in Issue Manager.

e Components are discrete product elements that are tracked separately for testing purposes.
» Versions are product releases that are tracked separately for development and testing purposes.
« Builds are iterations of versions that are tracked separately for development and testing purposes.

Silk Central also enables you to set up platform designations for tests, for example operating systems. As
with product, version, and build setup, platforms can be assigned names, descriptions, and active/inactive
status.

Managing Products

Describes how to configure products in Silk Central.

Adding Products

To add a new product:

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click New Product. The New Product dialog box displays.

Type a name for the new product in the Name field.

Type a description for the product in the Description field.

Check the Active check box to make this product available for association with tests.
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Click OK to save the product.



Note: When creating a product, Silk Central automatically creates a new default version 1.0 and a
new default build 1 for the new product.

Editing Products

To edit an existing product:

1. Inthe menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. In the Actions column of the product that you want to edit, click ‘. The Edit Product dialog box
displays.

4. Make all required changes to the Name, Description, and Active status of the selected product, then
click OK.

Activating and Deactivating Products
To activate or deactivate an existing product:
1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click the Status icon associated with the product you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

4. Confirm the message to toggle the product status to active or inactive.

Sorting the Products List

To move a product up or down in the list or sort the products list alphabetically by name:
In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

In the Actions column of the item you want to move, click & or &
To sort the list alphabetically by name, click Sort by Name.
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Deleting Products

To delete an existing product:

1. Inthe menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Deactivate the product you want to delete.
For additional information, see Activating and Deactivating Products.

4. In the Actions column of the product that you want to delete, click X . A confirmation dialog box
displays.
5. Click Yes to continue with the deletion or click No to abort the deletion.

Product Configuration Page
Administration > Products, Versions, and Builds > Products
Use this page to configure products, components, versions, and builds.

Click New Product to create a new product. Click Sort by Name to sort the products alphabetically by
name.

For each listed product, the page displays the following columns:

Tests
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Column

Description

Actions

Name

Description

Status

Created On

Created By

You can perform the following actions on a product:

2 Moves the product up one row in the list.
E Moves the product down one row in the list.
[¢ Edit the name, description, and status of the product.

% Deletes the product permanently. Products need to be inactive before you can delete them,
and deletion is not allowed if a product is already associated to a test.

The name of the product as it displays in the GUI and in reports. Click the name of a product to
modify the product's components, versions, and builds.

A textual description of the product.

The status of the product, Active or Inactive. Click the status to toggle between Active and

Inactive.
Date when the product was created.

The user who created the product.

For a selected product, the page displays the details of the included components, versions, and builds.

The page displays the following columns for the components of the product:

Column Description

Actions You can delete the component in this column.

Name The name of the component. Click to open the Edit Component dialog box.
Description The description of the component.

Created On Date when the component was created.

Created By The user who created the component.

Status The status of the component. Active or Inactive. Click to toggle the status.

Click New Component to create a new component. Click Sort by Name to sort the components
alphabetically by name. Click Update to update the components list.

The page displays the following items for the versions of the product:

Item Description

Actions You can delete the version in this column, or move the version up or down in the list.
Name The name of the version. Click to open the Edit Version dialog box.

Description The description of the version.

Created On Date when the version was created.

Created By The user who created the version.

Status The status of the version. Active or Inactive. Click to toggle the status.

Click New Version to create a new version. Click Sort by Name to sort the versions alphabetically by

name.

The page displays the following items for the builds of the product:




Item Description

Actions You can delete the build or tag the build.

Name The name of the build. Click to open the Edit Build dialog box.
Description The description of the build.

Created On Date when the build was created.

Created By The user who created the build.

Status The status of the build. Active or Inactive. Click to toggle the status.

Click New Build to create a new build. Click Sort by Name to sort the builds list alphabetically by name.
Click Update to update the components list.

i Note: You have to select a specific version in the Builds list box to enable these buttons.

Click Back to return to the product list.

Managing Components

Components are discrete product elements that are tracked separately for testing purposes.

Adding Components

To add a new component to a product:

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

Click a product name. The Product Detail page for the product opens.

Click New Component. The New Component dialog box displays.

Type a name for the new component in the Name field.

Type a description for the component in the Description field.

Select the Type of the component.

Available values are Software and Documentation.

Check the Active check box to make this component available for association with products.
9. Click OK to save the component, or click Cancel to abort the operation.
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Editing Components

To edit an existing component within a product:

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

Select the component you want to edit.

The Edit Component dialog box displays, detailing the Name, Description, and Active status of the
selected component. Make all required changes, then click OK.
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Note: The type of a component can only be edited if you deactivate the component first. For
additional information, see Activating and Deactivating Components.

Activating and Deactivating Components

To activate or deactivate an existing component:
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In the menu, click Administration > Products, Versions and Builds .
Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

Click the Status icon associated with the component you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

Confirm the message to toggle the component status to active or inactive.

Sorting the Components List

To move a component up or down in the list or sort the components list alphabetically by name:
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In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

Click a product name. The Product Detail page for the product opens.

In the Component Type list box, select the component type for which you want to see the components.

In the Actions column of the item you want to move, click = or &
To sort the list alphabetically by name, click Sort by Name.

Deleting Components

To delete an existing component from a product:
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In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.
Deactivate the component you want to delete.

For additional information, see Activating and Deactivating Components.

- In the actions column of the component, click X . A confirmation dialog box displays.
6.

Click Yes to continue with the deletion or click No to abort the deletion.

Managing Versions

Versions are product releases that are tracked separately for development and testing purposes.

Adding Versions

To add a new version to a product:
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In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

Click a product name. The Product Detail page for the product opens.

Click New Version. The New Version dialog box displays.

Type a name for the new version in the Name field.

Type a description for the version in the Description field.

Check the Active check box to make this version available for association with products.
Click OK to save the version, or click Cancel to abort the operation.

Editing Versions

To edit an existing version within a product:

1.
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Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.
Select the version you want to edit. The Edit Version dialog box displays.

Make all required changes to the Name, Description, and Active status of the selected version, then
click OK.

Activating and Deactivating Products

To activate or deactivate an existing product:

1.
2.
3.

4.

In the menu, click Administration > Products, Versions and Builds .
Click the Products tab. The Products page displays, listing all existing products.

Click the Status icon associated with the product you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

Confirm the message to toggle the product status to active or inactive.

Sorting the Versions List

To move a version up or down in the list or sort the versions list alphabetically by name:
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In the menu, click Administration > Products, Versions and Builds .
Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

In the Actions column of the item you want to move, click = or &
To sort the list alphabetically by name, click Sort by Name.

Deleting Versions

To delete an existing version from a product:

Hwbdh e

6.

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

Click a product name. The Product Detail page for the product opens.

Deactivate the version you want to delete.

For additional information, see Activating and Deactivating Versions.

In the Actions column of the product that you want to delete, click X . A confirmation dialog box
displays.

Click Yes to continue with the deletion or click No to abort the deletion.

Managing Builds

Builds are iterations of versions that are tracked separately for development and testing purposes.

Adding Builds

To add a new build to a version:
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In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

In the Builds for Version list box, select the version for which you want to add a build.
Click New Build. The New Build dialog box displays.
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Type a name for the new build in the Name field.

Type a description for the build in the Description field.

Check the Active check box to make this build available for association with versions.
Click OK to save the build, or click Cancel to abort the operation.
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Editing Builds

To edit an existing build within a version:

In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

Select the build you want to edit.

The Edit Build dialog box displays, detailing the Name, Description, and Active status of the selected
build. Make all required changes, then click OK.

6. Check the Tagged check box to tag the build.
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Activating and Deactivating Builds

To activate or deactivate an existing build:

In the menu, click Administration > Products, Versions and Builds .
Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

Click the Status icon associated with the build you want to activate or deactivate. A confirmation dialog
box displays, asking you if you are sure about the activation or deactivation.

5. Confirm the message to toggle the build status to active or inactive.
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Sorting the Builds List

To move a build up or down in the list or sort the builds list alphabetically by name:
In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.

Click a product name. The Product Detail page for the product opens.
In the Builds for Version list box, select the version for which you want to see the builds.

In the Actions column of the item you want to move, click = or &
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To sort the list alphabetically by name, click Sort by Name.

Tagging Builds

You can delete runs of tagged builds. If the selection of the runs that you are trying to delete contains
tagged builds, then you get a warning and you have to confirm the action. Tagged builds will not get deleted
if you perform a bulk delete (all or for a specific time span) by right clicking on the execution node.

To tag an existing build:

In the menu, click Administration > Products, Versions and Builds .
Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.

In the Builds section, click = in the Actions column of the build that you want to tag. A confirmation
dialog box displays.
5. Click Yes to continue with the tagging or click No to abort the tagging.
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Deleting Builds

To delete an existing build from a version:
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In the menu, click Administration > Products, Versions and Builds .

Click the Products tab. The Products page displays, listing all existing products.
Click a product name. The Product Detail page for the product opens.
Deactivate the build you want to delete.

For additional information, see Activating and Deactivating Builds.

5. In the actions column of the build, click *< . A confirmation dialog box displays.

6.

Click Yes to continue with the deletion or click No to abort the deletion.

Managing Platforms

Set up platform designations for tests, for example operating systems. As with product, version, and build

setup, platforms can be assigned names, descriptions, and active or inactive status.

Adding Platforms

To add a new platform:
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In the menu, click Administration > Products, Versions and Builds .

Click the Platforms tab. The Platforms page displays, listing all existing platforms.
Click New Platform. The New Platform dialog box displays.

Type a name for the new platform in the Name field.

Type a description for the platform in the Description field.

Check the Active check box to make this platform available for association with tests.
Click OK to save the platform.

Editing Platforms

To edit an existing platform:
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In the menu, click Administration > Products, Versions and Builds .
Click the Platforms tab. The Platforms page displays, listing all existing platforms.

In the Actions column of the platform that you want to edit, click ES

The Edit Platform dialog box displays, detailing the Name, Description, and Active status of the
selected platform. Make all required changes, then click OK.

Activating and Deactivating Platforms

f Note: Platforms that are associated with a test cannot be deactivated.

To activate or deactivate an existing platform:

1.
2.
3.

4.

In the menu, click Administration > Products, Versions and Builds .
Click the Platforms tab. The Platforms page displays, listing all existing platforms.

Click the Status icon associated with the platform you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

Confirm the message to toggle the platform status to active or inactive.

Sorting the Platforms List

To move a platform up or down in the list or sort the platforms list alphabetically by name:
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In the menu, click Administration > Products, Versions and Builds .
Click the Platforms tab. The Platforms page displays, listing all existing platforms.

In the Actions column of the item you want to move, click & or &,
To sort the platforms list alphabetically by name, click Sort by Name.

Deleting Platforms

To delete an existing platform:

1.
. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

In the menu, click Administration > Products, Versions and Builds .

Deactivate the platform you want to delete.

For additional information, see Activating and Deactivating Platforms.

In the Actions column of the platform that you want to delete, click X . A confirmation dialog box
displays.

Click Yes to continue with the deletion or click No to abort the deletion.

Platform Configuration Page

Administration > Platforms

Use this page to configure platforms.

To create a new platform, click New Platform. For additional information, see Adding Platforms.

To sort the platforms list alphabetically by name, click Sort by Name. For additional information, see
Sorting the Platforms List.

For each listed platform, the page displays the following columns:

Columns Description

Actions The user can perform the following actions on a platform:

2 Moves the platform up one row in the list.
[Z.  Moves the platform down one row in the list.

% Deletes the platform permanently. Platforms need to be inactive before you can delete
them, and deletion is not allowed if a platform is already associated to a test.

Name The name of the platform as it displays in the GUI and in reports. Click the name of a platform to

modify the name, description, and status of the platform.

Description A textual description of the platform.

Status The status of the platform, Active or Inactive. Click the status to toggle between Active

and Inactive.

Created On Date when the platform was created.

Created By The user who created the platform.

Source Control Profiles

Source control profiles enable Silk Central to integrate with external source control systems. Defining
source control profiles allows you to define where Silk Central’'s execution servers should retrieve program
sources for test execution.




You need double the amount of free disk space on the execution server to accommodate the source files
because Silk Central checks out the source control tree and then generates a working directory with the
executable source files.

Additional source control systems can be configured by installing a custom plug-in. For detailed
information, refer to the Silk Central APl Help. The following source control systems are currently
supported by Silk Central “out of the box”:

AccuRev
This section describes how to configure AccuRev source control profiles.

AccuReyv is a software configuration management tool which addresses complex parallel and distributed
development environments with its stream-based architecture, to accelerate your development process and
improve asset reuse.

AccuRev versions that are currently supported for integration with Silk Central: AccuRev 6.2

Adding AccuRev Source Control Profiles

To create a AccuRev source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select AccuRev from the Source control system list box.
6. Type a valid AccuRev Username and Password, if required.

7. Type the AccuRev server name of the AccuRev server you want to access. If you are not using
AccuReV's default port, type <server name>:<port number>.

8. Type the name of the AccuRev Stream, for example backing stream.

9. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.
1+, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“*= folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

10.Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

11.Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing AccuRev Source Control Profiles

To modify a AccuRev source control profile:
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1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.

This is the name that is displayed in lists where profiles are available for selection.
5. Edit the Username and Password.

These credentials are used to access your repository.

6. Edit the AccuRev server hame of the AccuRev server you want to access. If you are not using
AccuRev's default port, type <server name>:<port number>.

7. Edit the name of the AccuRev Stream, for example backing stream.

8. Optional: Edit the Common working folder to which the Silk Central execution server copies the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

9. Edit the Project path you want this profile to use.
10.Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Apache Commons Virtual File System
This section describes how to configure Virtual File System (VFS) source control profiles.

A VFS is an abstraction layer on top of a more concrete file system. The purpose of a VFS is to allow client
applications to access different types of concrete file systems in a uniform way. Apache Commons VFS
provides a single API for accessing various file systems. It presents a uniform view of the files from various
sources. The protocols that are currently supported for VFS by Silk Central are:

Protocol Description

http Copies the given file. This protocol type is also supported for copying and unpacking ZIP, JAR,
or other zipped files. It is required to specify a .zip file on a http server. For example,
zip:http://myTestServer/myTests.zip. The .zip file will be extracted on the execution
server.

ftp Copies the given file. This protocol type is also supported for copying and unpacking ZIP, JAR,
or other zipped files.

smb Server Message Block (smb) copies all files and folders. This protocol can be used instead of a
UNC profile. For example, the VFS smb path smb://server-name/shared-resource-
path is equivalent to the UNC path \\server-name\shared-resource-path.

Note: When you create a new ProcessExecutor test that uses VFS for source control, you need to
specify the complete path to the executable in the Executable Name field.
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Adding VFS Source Control Profiles

To create a VFS source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.

4. Type a Name for the new profile.

This is the name that is displayed in lists where the profiles are available for selection.
5. Select VFS from the Source control system list box.
6. Type the URL of the VFS Repository you want to access. This field is case sensitive.
Specify the appropriate protocol type in the URL:
FTP Ttp://<FTP server URL>
HTTP http://<HTTP server URL>
SMB smb://<Samba server URL>
Note: HTTP, FTP and SMB are also supported for zipped files. In order to point to a zipped file the
URL must be adjusted to <zipped file type>:<protocol>://<server URL pointing
to zipped file>toinclude the type of the zipped file. For example, zip:http://
193.80.200.135/<path>/archive.zip or jar:-http://193.80.200.135/<path>/
archive.jar.

7. Type avalid VFS Username and Password.

These credentials will be used to access your VFS repository. The SMB protocol allows including the
domain name in the username in the following form: domain/username.

8. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.

/1, Warning: Itis recommended to leave this field empty and let Silk Central use a temporary working

“* folder instead. Specifying a static working folder can lead to unexpected results when running
parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root _dir.

9. Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

10.Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing VFS Source Control Profiles

To modify a VFS source control profile:

1.
2.

In the menu, click Project:<Project Name> > Project Settings .

Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.
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4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
5. Edit the URL of the VFS Repository you want to access.

f Note: This field is case sensitive.

6. Edit the Username and Password.
These credentials are used to access your repository.

7. Optional: Edit the Common working folder to which the Silk Central execution server copies the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

8. Edit the Project path you want this profile to use.
9. Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Git

This section describes how to configure Git source control profiles.

Git is a distributed revision control and source code management (SCM) system with an emphasis on

speed. Every Git working directory is a full-fledged repository with complete history and full version tracking
capabilities, not dependent on network access or a central server.

Adding Git Source Control Profiles

To create a Git source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select Git from the Source control system list box.
6. Type the URL of the Git Repository you want to access.

y Note: This field is case sensitive.

7. Type avalid Git Username and Password, if required.

8. Optional: Specify a Branch to check out a specific branch. Leave this field empty to check out the
master branch.

9. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.



A Warning: It is recommended to leave this field empty and let Silk Central use a temporary working

~*~ folder instead. Specifying a static working folder can lead to unexpected results when running
parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

10.Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

11.Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

3 Tip: If you want to check out a specific branch of your repository for a specific execution plan, specify
~  the branch name in the Source Control Label field of the respective execution plan. See Creating
Execution Plans for detailed information. This will overwrite the specified Branch in the Git source
control profile.

Editing Git Source Control Profiles

To modify a Git source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
5. Type the URL of the Git Repository you want to access.

f Note: This field is case sensitive.

6. Edit the Username and Password.
These credentials are used to access your repository.

7. Optional: Specify a Branch to check out a specific branch. Leave this field empty to check out the
master branch.

8. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.

A Warning: It is recommended to leave this field empty and let Silk Central use a temporary working

“*= folder instead. Specifying a static working folder can lead to unexpected results when running
parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root _dir.

9. Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

10.Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
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If the trial connection is successful, you are returned to the Source Control page.

i 3 Tip: If you want to check out a specific branch of your repository for a specific execution plan, specify

= the branch name in the Source Control Label field of the respective execution plan. See Creating
Execution Plans for detailed information. This will overwrite the specified Branch in the Git source
control profile.

Microsoft Team Foundation Server
This section describes how to configure Team Foundation Server (TFS) source control profiles.

TFS versions that are currently supported for integration with Silk Central: Team Foundation Server 2012,
2013, 2015

Note: To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere
2015 command-line client (English version) needs to be installed on the front-end server and every
execution server on which you want to use the source control profile. You can download the CLC from
the Microsoft Download Center. You must run Team Explorer Everywhere and accept the license
agreement to make the integration work. For more information, refer to this knowledge base article.

Adding TFS Source Control Profiles

To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2015
command-line client (English version) needs to be installed on the front-end server and every execution
server on which you want to use the source control profile. You can download the CLC from the Microsoft
Download Center. You must run Team Explorer Everywhere and accept the license agreement to make the
integration work. For more information, refer to this knowledge base article.

To create a TFS source control profile:

1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select Team Foundation Server from the Source control system list box.
6. Enter the URL of your TFS installation.
For example, http://tfsserver:8080/tfs.
7. Type the Domain of the TFS user.
8. Type a valid Username and Password.
These credentials will be used to access your repository.

9. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.

A Warning: It is recommended to leave this field empty and let Silk Central use a temporary working

“* folder instead. Specifying a static working folder can lead to unexpected results when running
parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

10.Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

11.Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing TFS Source Control Profiles

To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2015
command-line client (English version) needs to be installed on the front-end server and every execution
server on which you want to use the source control profile. You can download the CLC from the Microsoft
Download Center. You must run Team Explorer Everywhere and accept the license agreement to make the
integration work. For more information, refer to this knowledge base article.

To modify a TFS source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.

This is the name that is displayed in lists where profiles are available for selection.
5. Edit the URL of the TFS Repository you want to access.
6. Edit the Username and Password.

These credentials are used to access your repository.

7. Optional: Edit the Common working folder to which the Silk Central execution server copies the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

8. Edit the Project path you want this profile to use.
9. Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Silk Test Workbench

This section describes how to configure Silk Test Workbench source control profiles.

Silk Test Workbench is an automated testing tool that accelerates the functional testing of complex
applications. Silk Test Workbench provides support for testing applications developed in a wide variety of
development tools including Java, .NET, browser-based web applications, and COM components, including
both ActiveX controls and automation objects. With Silk Test Workbench, you can record user sessions
with your applications to create tests, enhance the test by adding validation and test logic, and play back
tests to ensure that the applications work as expected.

Note: To add a Silk Test Workbench source control profile, the Silk Test Workbench client needs to be
installed on every execution server on which you want to use the source control profile.
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Adding Silk Test Workbench Source Control Profiles

To create a Silk Test Workbench source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select Silk Test Workbench Test from the Source control system list box.
6. Select a database type from the Database type list box, either SQL Server or Oracle.
Note: The Microsoft Office Access database type is not supported. When connecting to a Silk Test

Workbench Oracle database, there is a Silk Test Workbench requirement that the TNS name must
be the same as the host server name.

7. Enter the name of the Silk Test Workbench database server in the Database server field.
8. Enter the name of the Silk Test Workbench database in the Database name field.
9. Enter the port number of the Silk Test Workbench database server in the Database port field.

10.Enter the Silk Test Workbench database schema or owner name in the Database schema/owner
name field.

11.Enter the name of the database user in the Database user field.
12.Enter the password for the database user in the Database password field.

13.0Optional: Enter the name and password of a valid Silk Test Workbench user in the Silk Test
Workbench User name and Silk Test Workbench password fields. If these fields are left empty, the
Windows user that runs the execution server service is used.

14.Click Retrieve. All projects are listed in the Projects list.
15.Select one or more projects.
16.Click OK.

Editing Silk Test Workbench Source Control Profiles

To modify a Silk Test Workbench source control profile:

1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
5. Edit the Silk Test Workbench Database type.

y Note: The Microsoft Office Access database type is not supported.

6. Edit the other settings as required.
7. Click OK.

StarTeam

This section describes how to configure StarTeam source control profiles.

StarTeam promotes team communication and collaboration through centralized control of all project assets.
Protected yet flexible access ensures that team members can work whenever and wherever they like



through an extensive choice of Web, desktop, IDE, and command-line clients. StarTeam offers a uniquely
comprehensive solution that includes integrated requirements management, change management, defect
tracking, file versioning, threaded discussions, and project and task management.

StarTeam versions that are currently supported for integration with Silk Central: StarTeam 15.x, 16.x

Adding StarTeam Source Control Profiles

To create a StarTeam source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select StarTeam from the Source control system list box.
6. Type the Hostname of your StarTeam server.
7. Type the Port that is to be used to connect to the StarTeam server.
If the port is not changed, use the default port 49201.
8. Type avalid Username and Password.
These credentials will be used to access your repository.
9. Specify if the profile supports Encryption.

10.Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root _dir.

11.Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

12.Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing StarTeam Source Control Profiles

To modify a StarTeam source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
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5. Choose from the following options:

« Edit the Hostname of your StarTeam server.
« Edit the port that is to be used to connect to the StarTeam server. If the port is not changed, use the
default port 49201.

» Specify if the profile supports Encryption.
6. Edit the Project path you want this profile to use.
7. Edit the Username and Password.
These credentials are used to access your repository.

8. Optional: Edit the Common working folder to which the Silk Central execution server copies the
source files.

The working folder must be a local path. For example, C:\TempSources\.
1+, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“*= folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root _dir.

9. Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Subversion
This section describes how to configure Subversion (SVN) source control profiles.

Subversion (SVN) is the successor to the Concurrent Versions System (CVS). Subversion manages
versions using transaction numbers. With each commit, the transaction number is incrementally increased.

What other source control systems call labels, Subversion refers to as tags. These tags are encoded in the
Subversion URL. For example, http://MyHost/svn/MyApp/trunk is a Subversion URL and http://
MyHost/svn/MyApp/tags/bui ld1012 is a Subversion tag.

Silk Central supports Subversion tags. If a Subversion URL contains the trunk directory, you can define a
label tags/bui1d1012. This label replaces trunk in the Subversion URL.

i Note: If a Subversion URL does not contain trunk and you define a label, Silk Central throws an
error.

Adding Subversion Source Control Profiles

To create a Subversion source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Choose Subversion from the Source control system list box.
6. Type the URL of the Subversion Repository you want to access.

If you do not know the URL of the repository, consult your Subversion administrator.



i Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.

7. Type a valid Username and Password.
These credentials will be used to access your repository.
8. Type avalid SSH username and SSH password or SSH keyfile.

These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password field empty. If you use a keyfile, the path to the keyfile must be
valid on every execution server that uses the source control profile.

9. Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

10.Type the Project path you want this profile to use. Click Browse to display the Select Project Path
dialog box. The Select Project Path dialog box opens. Select the desired project path in the tree view
and click OK. Leaving this field empty sets the project path to the root directory.

11.Click OK.
Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing Subversion Source Control Profiles

To modify a Subversion source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
5. Edit the URL of the Subversion repository you want to access.
If you do not know the URL of the repository, please consult your Subversion administrator.
Note: If you cannot check out files, when editing the URL of the Subversion Repository, delete

the source control mirrors directory on your execution server. For example, C:\ProgramData
\SilkCentral\SrcCtriMirrors.

i Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.

6. Edit the Username and Password.
These credentials are used to access your repository.
7. Type avalid SSH username and SSH password or SSH keyfile.

These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password field empty. If you use a keyfile, the path to the keyfile must be
valid on every execution server that uses the source control profile.
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8. Optional: Edit the Common working folder to which the Silk Central execution server copies the
source files.

The working folder must be a local path. For example, C:\TempSources\.
/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running

parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir.

9. Edit the Project path you want this profile to use.
10.Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Silk TestPartner

This section describes how to configure TestPartner source control profiles.

TestPartner is a Micro Focus product that tests Web- and Microsoft Windows-based applications that use
Microsoft technologies. TestPartner records user actions to quickly produce powerful tests. Each recorded
test displays as a series of actions in clear, concise steps that can be easily understood by all testers, from
novice to expert. You can record user sessions with the application, add validation functions, and replay the
sessions later to ensure that the application works as expected.

Note: To add a TestPartner source control profile, the TestPartner client needs to be installed on
every execution server on which you want to use the source control profile.

Adding TestPartner Source Control Profiles

To create a TestPartner source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select TestPartner from the Source control system list box.
Note: When connecting to a TestPartner Oracle database, there is a TestPartner requirement that
the TNS name must be the same as the host server name.
Select a database type from the Database type list box, either SQL Server or Oracle.
Type the name of the database server in the Database server field.
Type the name of the database in the Database name field.
Type the port number of the database server in the Database port field.
10.Type the database schema or owner name in the Database schema/owner name field.
11.Type the name of the database user in the Database user field.
12.Type the password for the database user in the Database password field.
13.Type a valid Username and Password.
These credentials will be used to access your repository.

14.Use the Project path field to filter which scripts from the database are available to use as tests. Click
Browse to display the Select Project Path dialog box.
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The Select Project Path dialog box provides a tree of three levels that you can choose from:

First level The entire TestPartner database. Note that if you select this level, the Project path field
will remain blank.

Second level The TestPartner project.

Third level  The script type within a specified TestPartner project.

Select one of the preceeding options and click OK. The path will be added to the Project Path field.
15.Click OK.

Editing TestPartner Source Control Profiles

To modify a TestPartner source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

4. Edit the Name of the profile.
This is the name that is displayed in lists where profiles are available for selection.
5. Choose from the following options:

« Edit the TestPartner Database type.
« Edit the TestPartner Database server.
« Edit the TestPartner Database name.
« Edit the TestPartner number of the TestPartner database server.
« Edit the TestPartner Database schema/owner name.
« Edit the TestPartner Database user.
« Edit the TestPartner Database password.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Project path you want this profile to use.
8. Click OK.

Universal Naming Convention
This section describes how to configure Universal Naming Convention (UNC) source control profiles.

Short for Universal Naming Convention or Uniform Naming Convention, UNC is a PC format for specifying
the location of resources on a local area network (LAN). UNC uses the following format: \\server-name
\shared-resource-pathname.

For example, to access the file test.txt in the directory examples on the shared server silo, you
would write: \\si lo\examples\test._txt.

You can also use UNC to identify shared peripheral devices, such as printers. The idea behind UNC is to
provide a format so that each shared resource can be identified with a unique address.

UNC is only supported on Microsoft Windows operating systems. If you plan to use a non-Windows
execution server you can use the Apache Commons VFS source control profile instead.

Adding UNC Source Control Profiles

To create a UNC source control profile:
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In the menu, click Project:<Project Name> > Project Settings .

Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

Click New Profile to open the New Source Control Profile dialog box.

Type a Name for the new profile.

This is the name that is displayed in lists where the profiles are available for selection.
Select UNC from the Source control system list box.

Type the UNC path that you want to access.

This is the path to the location where your test sources are located.

| Tip: To avoid checking out unnecessary files, specify the folder at a hierarchy level where the

= sources reside that are actually required for test execution.

Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.

A Warning: It is recommended to leave this field empty and let Silk Central use a temporary working

—* folder instead. Specifying a static working folder can lead to unexpected results when running
parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir. If you do require a static working folder, make sure that it is not
located within the specified UNC path, as this will lead to recursive checkouts.

Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Editing UNC Source Control Profiles

To modify a UNC source control profile:

1.
2.

In the menu, click Project:<Project Name> > Project Settings .

Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

Click on the name of the source control profile that you want to modify. The Edit Source Control
Profile dialog box opens.

Edit the Name of the profile.

This is the name that is displayed in lists where profiles are available for selection.
Type the UNC path that you want to access.

This is the path to the location where your test sources are located.

y Tip: To avoid checking out unnecessary files, specify the folder at a hierarchy level where the

“  sources reside that are actually required for test execution.

Optional: Type the Common working folder to which the Silk Central execution server should copy the
source files.

The working folder must be a local path. For example, C:\TempSources\.

/1, Warning: It is recommended to leave this field empty and let Silk Central use a temporary working
“* folder instead. Specifying a static working folder can lead to unexpected results when running



parallel executions. The temporary location can be queried from the predefined parameter
#sctm_source_root_dir. If you do require a static working folder, make sure that it is not
located within the specified UNC path, as this will lead to recursive checkouts.

7. Edit the UNC username and UNC password.
These credentials are required to access your configuration file’s UNC path.
8. Click OK.

Silk Central attempts a trial connection to the external system using the information you have provided.

Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

If the trial connection is successful, you are returned to the Source Control page.

Deleting Source Control Profiles

To remove a source control profile:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Source Control tab. The Source Control page opens, listing all of the source control profiles
that have been created for the system.

3. In the Actions column of the issue tracking profile you wish to delete, click Delete source control
profile .... A confirmation dialog box displays.

4. Click Yes. You are returned to the Source Control page.

Source Control Profiles Page
Project:<Project Name> > Project Settings > Source Control

Use this page to configure profiles to integrate external source control systems with Silk Central. Click New
Profile to create a new source control profile. For each source control profile, the page displays the
following columns:

Item Description

Name The name of the profile as it displays in the Silk Central
GUI and in reports. Click the name to edit a profile.

Type The external source control system.

Working Folder Local or mapped working folder to which temporary
sources are checked out to.

Created On Date when the source control profile was created.
Created By The user who created the source control profile.
Changed On Date when the source control profile was last modified.
Changed By The user who last modified the source control profile.
Actions Delete source control profile

Step Properties

Use step properties to extend a manual test step with additional properties. Add a custom step property to
a project in Projects:<Project Name> > Project Settings to add the property to all manual test steps in
the project. Add a custom step property to a library in the Libraries tree to add a custom step property to
all manual test steps in the library. Step properties can subsequently be edited alongside the default
properties on the Edit Manual Test Step dialog box.

Tests

117



118

Tests

Creating Step Properties

To create a new step property:

1. In the menu, click Project:<Project Name> > Project Settings .
. Click the Step Properties tab.

2
3. Click New Property. The New Step Property dialog box opens.
4. Enter a name for the new property in the Name field.

y Note: Step property fields are always declared as type string.

5. Click OK to make your property available to all manual test steps in the selected Silk Central project.

Note: To create a step property for a library, select the library node in the Libraries tree and
continue with the second step.

Editing Step Properties
To edit a previously created step property

1. In the menu, click Project:<Project Name> > Project Settings .

Click the Step Properties tab.

Click on the name of the property that you want to edit. The Edit Step Property dialog opens.
Edit the name of the property in the Name field.

Click OK to save your changes, or click Cancel to abort the operation without saving.

ST S A

Deleting Step Properties
To delete a previously created step property
1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Step Properties tab.

3. Click Delete Property in the Actions column of the property that you want to delete. A confirmation
dialog box displays, asking you to confirm the deletion.

4. Click Yes to complete the operation, or No to abort.
Step Properties Page

Project:<Project Name> > Project Settings > Step Properties

The Step Properties page lists all properties that can be populated into manual test steps across the
active project. For each custom step property, the Step Properties page displays the following columns:

Column Description
Name Name of the step property.
Actions The following actions can be performed on a property:

* Delete Property
* Move Up
* Move Down

Attributes

You can use custom attributes to customize the information for tests and execution plans. While some
attributes are made available by the integrated functionality of Silk Central, such as priority, components,



and platforms, you may want to define custom attributes to categorize tests and execution plans to your
needs, or to make tests compatible with specific test cases.

Creating Custom Attributes
To create a custom attribute:
In the menu, click Project:<Project Name> > Project Settings .

Click the Attributes tab to view the list of current attributes.
Click New Attribute. The New Attribute dialog box displays.
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available for use.

o

Type a Description for the new attribute.
6. Select the attribute Type. See the Custom Attribute and Requirement Property Types topic for
descriptions of each type of attribute.

7. Click OK.

Custom Attribute and Requirement Property Types

Silk Central supports the following types of attributes and requirement properties:

Date The Date type supports date values.

List The List type supports single select or multi-select lists. It has the following controls:

* New Item: Allows you to create entries in the list. Click to show the New Item dialog box.
Enter the Name and Numeric Weight for the list item and click OK.

Note: The value of the Numeric Weight field is used during filtering when the filter
criteria uses any of the following operators: >, >=, <, or <=. When the filter criteria
uses the = or not operators, the value from the Name field is used for comparisons.

* Order: Use the fields in this column to sort your attributes.

* Allow multi-select: Click this check box to allow users to select more than one values from
the list.

Note: You can update an existing single-select list to be a multi-select list. A multi-
select list cannot be changed to being a single-select list though.

» Actions: Use the icons in this row to delete or to edit each item in the list.

Number The Number type supports integer or decimal numeric values. It has the following fields:

* Minimum value: represents the smallest value that you can enter into the field.
*  Maximum value: represents the largest value that you can enter into the field.

» Decimal places: used to define how many values to the right of the decimal point are valid.
Select O for an integer value or 1, 2, 3, or 4 for a decimal value.

Note: Custom attributes and requirement properties display their current value if an
update is made to their definition (for example, changes to Minimum value or Maximum
value). In order to apply the new definition, open and save the asset.

Text The Text type supports any alphanumeric value. It has the following fields:

* Maximum length: represents the maximum number of characters that can be entered into
the field. Enter O or leave this field empty for unrestricted length (for requirement properties

only).

Type a Name for the new attribute. This name will be displayed in list boxes when the attribute becomes
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Editing Custom Attributes

To edit a custom attribute:
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7.

In the menu, click Project:<Project Name> > Project Settings .

Click the Attributes tab to view the list of current attributes.

Click the name of the attribute that you want to edit. The Edit Attribute dialog box displays.
Edit the Name of the attribute.

When the attribute is available for use, the name will display in list boxes for filters, execution plans, and
tests. Attributes can be used in global filters for filtering by attributes and can be applied to tests and
execution plans.

Edit the Description of the attribute.

See the Custom Attribute and Requirement Property Types topic for descriptions of each type of
attribute. You have different editing options depending on the attribute data type.

Click OK. You are returned to the Attributes list.

Deleting Custom Attributes

To delete a custom attribute:

1.
2.
3.

In the menu, click Project:<Project Name> > Project Settings .
Click the Attributes tab to view the list of current attributes.

Before you can delete an attribute, you must first deactivate it. In the Status column, click the Active
link or icon and then click Yes on the confirmation dialog box to deactivate the attribute.

Once the attribute is inactive, click Delete Attribute to remove it. A confirmation dialog box displays,
asking you to confirm the deletion.

Click Yes to remove the selected attribute; or click No to abort the operation. If you click Yes you will be
returned to the Attributes page, where the removed attribute is no longer displayed.

If an error displays, ensure that the selected attribute is not applied to any tests or execution plans, or
used in any global filters. You can only delete unused attributes.

Attributes Page

Project:<Project Name> > Project Settings > Attributes

The Attributes page lists the attributes that have been created for the current project. For each attribute,
the Attributes page displays the following columns:

Column Description
Actions Available actions that can be performed on the attribute.
Name Name of the attribute. When the attribute is available for use, the name will display

in list boxes for filters, execution plans, and tests. Attributes can be used in global
filters for filtering by attributes and can be applied to tests and execution plans.

Click the Edit icon to edit the name of the attribute.

Type Attribute type. See the Custom Attribute and Requirement Property Types topic for
descriptions of each type of attribute.

Status Status of the attribute, active or inactive.

Reporting Column The column name of the attribute in the LQM Reporting table. Use this column

name to query the selected attribute within the LQM Reporting table. See the
database model documentation for detailed information.




Column Description

Created On When the attribute was created.

Created By User who created the attribute.

Changed On When the attribute was most recently modified.
Changed By User who most recently modified the attribute.

Data Sources for Data-Driven Tests

Data-driven tests are tests that are derived from values in an existing data source, such as a spreadsheet
or a database. The data sources are managed in a project-specific scope.

) Tip: To acknowledge changes in your data source to Silk Central, you must synchronize your data

= source profile with your data source whenever your data source is updated or changed.

Data Source Limits
Data sources have specific limits to prevent Silk Central from getting into an unstable state due to
excessive data generation.

Atomic vs. Non-Atomic Tests

For detailed information on the data-driven test types that are available in Silk Central, see Atomic and
Non-Atomic Data-Driven Tests.

Limits
Data sources for data-driven tests have the following default limits:

» 100 rows for non-atomic tests

» 1000 rows for atomic tests

e 20000 rows+cells for XLSX data sources (20000 is the amount of rows + the amount of cells. For
example: If you have 3000 rows with 6 columns, the calculated amount is 3000 + (3000 * 6) =
21000, so the limit is exceeded.)

e 220 characters for data set names (Excel sheet names/table names)

e 220 characters for column key names

* The concatenated length of all primary keys may not exceed 255 characters in length for JDBC, Excel,
and CSV data sources

* 2000 characters per cell (longer strings will be truncated). Note that data-driven Silk Test Classic tests
only accept data source strings in quotation marks. If the string length in a cell exceeds 2000
characters, the string is truncated and the trailing quotation mark is missing, which leads to an error.

Modifying the Default Limits

The default limits can be modified, if required. Modify these values with care though to avoid excessive
data generation. Before attempting to modify these values, stop the application server and restart it again
after you have saved your changes.

The row limits for atomic and non-atomic tests can be configured in the TmAppServerHomeConf.xml file.
The default path for this file is C:\Program Files (x86)\Silk\Silk Central
18_5\instance_<instance number>_<instance name>\Conf\AppServer on the application
server. Modify the values of the Config/DataDriven/MaxRowsAtomic and Config/DataDriven/
MaxRows XML tags, respectively.

The XLSX cell limit can be configured in the configuration.properties file in the Excel data source
plugin (DS-Excel . zip). The default path for this file is C:\Program Files (x86)\Silk\Silk
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Central 18.5\instance_<instance number>_<instance name>\Plugins on the application
server. Modify the value of the excel . importcelllimit property accordingly.

Configuring JDBC Data Sources

/1», Caution: The concatenated length of all primary keys may not exceed 255 characters in length for
“*- JDBC data sources.

To configure a JDBC data source:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have
been created for the system.

3. Click New Data Source to open the New Data Source dialog box.
4. Type a Name for the data source.
5. From the Data source type list box, select JDBC.

Note: If you are setting up an ODBC data source, you need to manually insert your ODBC Driver
class and URL. For example, Driver class: sun. jdbc.odbc.JdbcOdbcDriver, URL:
Jdbc:odbc:MyDatabaseName. You must also set up an ODBC data source in MS Windows in
the Administrative Tools. For more information, refer to Microsoft Windows Help. If you have your
front-end server and your application server on different machines, make sure that the name of
your system data source set-up in Microsoft Windows is the same as the ODBC data source.
These names are case-sensitive.

6. If you select JDBC as the Data source type, the Driver class field is populated automatically. In the
URL field, replace the host name value, <hostname>, with the name of the computer that is hosting the
data source and replace the database name value, <databasename>, with the name of the target
database.

7. In the Username and Password fields, enter valid database credentials.

8. Optional: If you are working with a database that includes multiple tables, and you want to narrow down
the data source to specific tables, you can browse to and select specific tables for inclusion:

1. Click [...] next to the Table filter field.

2. The Select Table Filter dialog box displays. Select the tables that you want included as your data
source.

3. Click OK.

9. Optional: Key column selection is used by tests to define which worksheet columns within a data
source are used as primary key. This is helpful if your data source will undergo edits, for example when
you add or remove rows within a worksheet. Even if your data source is edited, tests will still be able to
identify which columns or rows should be used. Tests created from data-driven data sources use key
column values in their names, rather than column numbers.

To configure a key column:

1. Click [...] next to the Key column field.

2. The Select Key Column dialog box displays. Select a column from the column list that is to act as a
key column.

3. Click OK.
10.Click OK on the New Data Source dialog box.

Configuring Microsoft Excel or CSV Data Sources

1+, Caution: Excel worksheets using password protection can not be configured as data sources for Silk
*~ Central. Turn off a worksheet's password protection to use it as data source for data-driven testing.
The concatenated length of all primary keys may not exceed 255 characters in length for Excel and
CSV.
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To configure a Microsoft Excel or CSV data source:

In the menu, click Project:<Project Name> > Project Settings .

Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have
been created for the system.

Click New Data Source to open the New Data Source dialog box.

Type a Name for the data source.

From the Data source type list box, select MS Excel to configure a Microsoft Excel data source, or
select CSV to configure a CSV data source.

From the Source control profile list box, select the pre-configured source control profile that hosts your
data file. For detailed information regarding the configuration of source control profiles, see Source
Control Profiles.

Click Browse to open the Select Source Control Path dialog box. Browse to and select a data source
file of the selected type in your source control path.
Optional: MS Excel only. If you are working with an Excel spreadsheet that includes multiple

worksheets, and you want to narrow down the data source to specific worksheets, you can browse to
and select specific worksheets for inclusion. To do this:

1. Click [...] next to the Worksheet filter field.

2. The Select Worksheet Filter dialog box displays. Select the worksheets that you want included as
your data source.

3. Click OK.

Optional: Key column selection is used by tests to define which worksheet columns within a data

source are used as primary key. This is helpful if your data source will undergo edits, for example when

you add or remove rows within a worksheet. Even if your data source is edited, tests will still be able to

identify which columns or rows should be used. Tests created from data-driven data sources use key

column values in their names, rather than column numbers.

Note: MS Excel only: If the data source includes multiple worksheets, only columns with identical
names are available to be defined as key columns.

To configure a key column:

1. Click [...] next to the Key column field.
2. The Select Key Column dialog box displays. Select a column from the column list that is to act as a
key column.

3. Click OK.

10.Click OK on the New Data Source dialog box.

Downloading Excel Files from a Data Source
f Note: Files can not be downloaded from JDBC and ODBC data sources.

To download an Excel file from a data source:

1.

In the menu, click Project:<Project Name> > Project Settings .

2. Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have

been created for the system.

Click the Download icon in the Actions column of the data source you want to download from. The File
Download dialog box displays.

Click Open to open the file immediately, or click Save to specify where on your local system you want to
save the file to.
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Synchronizing Data Sources

You must synchronize a data source each time it is changed or updated, if you want to make Silk Central
aware of the changes. Synchronizing a data source propagates recent changes to associated tests.

To synchronize an updated data source:

1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have
been created for the system.

3. Click the Synchronize icon in the Actions column that corresponds to your data source to propagate
the updated file to the associated tests.

4. A confirmation dialog box displays, asking you to confirm the synchronization. Click Yes to synchronize
all tests with the updated data source, or click No to abort the synchronization.
1+, Caution: When you synchronize a data source, all running executions depending on this data
source are aborted. Results of incomplete tests within these executions are lost.
5. Click OK on the success message dialog box.

Uploading Updated Excel Files to a Data Source
i Note: Files can not be uploaded to JDBC and ODBC data sources.

To upload an updated Excel file to a data source:

1. Inthe menu, click Project:<Project Name> > Project Settings .

Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have
been created for the system.

Click the Upload icon in the Actions column of the data source you want to download from.

Click Browse... on the Upload File dialog box.

Select the updated Excel file that you want to replace the currently uploaded Excel file with. Click Open.
Click OK on the Upload File dialog box.

A confirmation dialog box displays, asking you to confirm the overwriting of the existing file. Click Yes to
continue.

8. After uploading the updated data source file, another dialog box displays, asking you if you want to
synchronize the tests with the updated data source. Click Yes to synchronize immediately, or click No if
you want to synchronize later.

n
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Note: After uploading an updated data source file, you must synchronize the data source so that
associated tests are updated.

Deleting Data Sources

f Note: Data sources that are being used by tests can not be deleted.

To delete a data source:

1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Data Sources tab. The Data Sources page displays, listing all of the data sources that have
been created for the system.

3. Click the Delete icon in the Actions column of the data source that you want to delete.

4. A confirmation dialog box displays. Click Yes to remove the data source, or click No to abort the
deletion.



Data Sources Configuration Page
Project:<Project Name> > Project Settings > Data Sources

The Data Sources page lists all data sources that are configured for the integration of data-driven tests
into Silk Central. Click New Data Source to create a new data source. For each data source, the page
displays the following columns:

Column Description

Name The name of the data source as it displays in the Silk
Central GUI and in reports. Click the name to modify the
data source settings.

Type Data source type:
¢ CSV
« JDBC
¢ MS Excel
File Name The name of the file that is used as data source, for

example datasource.xlIsx.

Source Control Profile The name of the source control profile that hosts the data
file.
Created On Date when the data source was created.
Created By User who created the data source.
Changed On Date when the data source was last modified.
Changed By User who last modified the data source.
Actions You can perform the following actions on a data source:
* Delete
* Download
¢ Upload

* Synchronize

Filters

Filters provide an efficient means of finding exactly the information you need, while excluding extraneous
detail. Filters highlight only those elements that are relevant to your needs, and enable you to quickly sort
through requirements, test elements, and execution plans. By defining global filters, you can create
complex filter criteria that are available throughout Silk Central without defining filter criteria each time you
need to filter a list.

Based on your needs, you can create new filters, edit existing filters, select filters, delete filters, or turn
filtering off at the project level. Projects do not contain default filters. You can access and edit filters from
the toolbars in the Silk Central units and from the Project Settings unit.

Note: Filters are not applied to reports. The Recent Changes filter enables you to view project-wide
changes and additions that other users have made to tests since your last change acknowledgement.
The Show Changes/Show All toggle button and the Acknowledge button in the Tests area help you
to find out what changes other users have made. Your system administrator can configure email
notifications that alert you to changes that are made to test settings. Email alerts include links that
take you directly to a view of recent changes.
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Creating Filters

To create a filter:

In the menu, click Project:<Project Name> > Project Settings .

Click the Filters tab to view the list of available filters.

Click New Filter. The New Filter dialog box appears.

Type a Name for the new filter.

This name will be displayed in list boxes when the filter becomes available.

5. Select a Category from the list to make the filter available in the Requirements, Tests, or Execution
Planning area of Silk Central.

6. Optional: Type a Description for the new filter.
7. Optional: Check the Visible to other users check box to allow other users to see the filter.
8. Optional: Check the Editable by other users check box to allow other users to edit the filter.
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Note: If Visible to other users and Editable by other users are checked, the filter is public. To
delete non-public (private) filters, you have to be the owner of the filter or you need the Delete
private filters of other users permission.

9. Select a category of filter criteria from the Selection criteria list. The available categories depend on
the general filter category you have selected.

Note: You can combine filters by selecting Nested Test Filter or Nested Requirement Filter.
Selecting one of these categories allows you to include an existing filter in your new filter.

10.Select a Property, Operator, and Value for the filter from the respective lists.

Property Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected an
attribute category, the property list includes custom attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the
following operators are available:

Operator Description

= The string equals the defined value.

not The string is different than the defined value.

contains The string contains the defined value.

not contains The string does not contain the defined value.
Value Enter the value that you want to filter out. Depending on the property type that you have

selected, values will either be strings that you can enter into the field, or a selection of
predefined values that you can select from the list box. Allowed wildcards for strings are *
(any amount of characters) and ? (exactly one character).

11.0Optional: Click More if you want to add more than one filter category to the new filter. Repeat this
procedure to define new categories.

Note: If you define more than one filter category, you must define whether the categories need to
be fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when
one of the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter
category relationship. You cannot define nested AND, OR relationships.

12.0Optional: To remove filter categories, click Fewer. This removes the last filter category.
13.Click OK to save the new filter, or click Cancel to abort the operation.
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Creating Advanced Filters

Advanced custom filters enable you to combine simple filters to create complex filters that apply multiple
filter criteria simultaneously.

To create an advanced custom filter:
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In the menu, select the appropriate area: Requirements, Tests, or Execution Planning.

Click K (New Filter) in the toolbar. The New Filter dialog box appears.
If necessary, click Advanced to show the whole dialog box.

Click More to display a second set of filter-parameter fields with which you can define a second set of
filter parameters.

Select a logical operator for the application of the filtering queries. For example, with the operator and
filtered elements must meet both sets of criteria and with the operator or filtered elements must meet
one, but not both, of the criteria sets.

To delete a filter-parameter string, click X .

To display additional filter-parameter fields and create additional filter queries, click More. To remove
excess filter-parameter sets, click Fewer.

Editing Filters

To edit a filter:
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In the menu, click Project:<Project Name> > Project Settings .
Click the Filters tab to view the list of available filters.
Click the name of the filter you want to edit. The Edit Filter dialog box displays.
Edit the Name and Description of the filter.
Select a category of filter criteria from the Selection criteria list. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Filter or Nested Requirement Filter.
Selecting one of these categories allows you to include an existing filter in your new filter.
Select a Property, Operator, and Value for the filter from the respective lists.

Property Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected an
attribute category, the property list includes custom attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the
following operators are available:

Operator Description

= The string equals the defined value.

not The string is different than the defined value.

contains The string contains the defined value.

not contains The string does not contain the defined value.
Value Enter the value that you want to filter out. Depending on the property type that you have

selected, values will either be strings that you can enter into the field, or a selection of
predefined values that you can select from the list box. Allowed wildcards for strings are *
(any amount of characters) and ? (exactly one character).
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7. Click OK to save the edited filter definition.

Copying Filters

Create a new filter by copying an existing one and changing the settings.

In the menu, select the appropriate area: Requirements, Tests, or Execution Planning.
In the toolbar of the selected area, select a filter from the list box.

Click ¥ The Edit Filter dialog box opens with the settings of the original filter.
Edit the properties of the filter and click OK.
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Deleting Filters

To delete a filter:

1. In the menu, click Project:<Project Name> > Project Settings .

2. Click the Filters tab to view the list of available filters.

3. Click Delete Filter for the filter that you want to delete. A confirmation dialog box displays, asking you
you to confirm the deletion.

4. Click Yes to delete the selected filter or No to abort the operation. If you click Yes, you will be returned
to the filters list and the deleted filter is no longer displayed.

Global Filter Details

Global filters allow you to quickly sort through elements in a Silk Central area, highlighting only those that
are relevant to your needs.

To view the details of a global filter, click Project:<Project Name> > Project Settings > Filters in the
menu, and click on the name of the filter.

The specific Silk Central area in which a new filter is available is defined by selecting the general filter
category.

Each global filter has to have a property, an operator, and a value from the respective list boxes:

Property Available properties depend on the filter category. It defines the property for which you are
defining a filter setting. If you selected an attribute category, the property list includes custom
attributes to query against.

Operator Specifies the filter operator. The operator depends on the property type. For example, if you
select a property that is based on a string field type, the available operators are = (equals
defined value), not (differs from the defined value), contains (contains the defined value
somewhere in the string), and does not contain (does not contain the defined value in the
string).

Value The value that you want to filter out. Depending on the property type that you have selected,
values will either be strings that you can enter into the field, or a selection of predefined values
that you can select from the list box.

Recent Changes

The Recent Changes filter enables you to efficiently view and acknowledge changes and additions that
other users have made to requirements, tests, or execution plans project-wide since your last change
acknowledgement.

The two buttons at the far-right of the toolbar, the Show Changes/Show All toggle button and the
Acknowledge button, help you to find out what changes other users have made.
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Note: Your system administrator can configure email notifications that alert you to changes that are
made to test settings. Email alerts include links that take you directly to a view of recent changes.

Applying Filters

After you have created and stored a custom filter, you can apply that filter to the selected tree. Custom
filters can be applied for requirements, tests and execution plans. Only elements that meet applied filter
criteria are displayed in the tree.

Note: Filtered requirements are returned in read-only form and can not be edited. The Edit
Properties button is disabled for filtered requirements.

To apply a stored filter:

1. Inthe menu, select the appropriate area: Requirements, Tests, or Execution Planning.
2. Select the desired filter from the Filter list box on the toolbar.
3. All elements that meet the filter’s criteria are displayed.

Note: To remove filtering and display all elements, select <No Filter> from the Filter list box on the
toolbar.

Change Notification

Silk Central can notify you by email when requirements or tests are changed by other users. Each user has
the option of activating change-notification. Once notification has been enabled, perform an initial
acknowledgment. From then on, you can view and acknowledge changes that have occurred since your
last acknowledgment. To avoid numerous notifications, only a single email alert is sent to you when a
change is made, regardless of how many changes other users may have made since your last
acknowledgment. Email alerts include links that take you directly to a view of recent changes.

Before you can activate change notification for requirements or tests, you must configure your email
address in the user settings of Silk Central.

Note: Change notification only works if an email server has been configured by your administrator. If
change notification has not been enabled, please contact your Silk Central administrator.

Enabling Change Notification

To enable change notification:

In the menu, click Project:<Project Name> > Project Settings .
Click the Notifications tab.
Click Configure Email Notification to open the Configure Email Notification dialog box.

If you want to be notified by email when changes are made to requirements in the currently selected
project, check the Changes on Requirements check box.

5. If you want to be notified by email when changes are made to tests within the currently selected project,
check the Changes on Tests check box.

6. Click OK to save the notification settings, or click Cancel to abort the operation without saving changes.

Hwbn e

You will be notified by email about changes for which you have activated notification.

Disabling Change Notification
To disable change notification:
1. Inthe menu, click Project:<Project Name> > Project Settings .

2. Click the Notifications tab.
3. Click Configure Email Notification to open the Configure Email Notification dialog box.
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4. If you do not want to be notified by email when changes are made to requirements in the currently
selected project, uncheck the Changes on Requirements check box.

5. If you do not want to be notified by email when changes are made to tests in the currently selected
project, uncheck the Changes on Tests check box.

6. Click OK to save the notification settings or click Cancel to abort the operation without saving changes.

Changes Triggering Change Notification

When you have activated change notification to inform you of changes that are made to requirements or
tests an email alert is sent to you, following your logout. The email alert is sent to you if one or more of the
following settings are changed:

Area Changes

Requirements + Arequirement is created or deleted.

e The name or description of a requirement is edited.
* A system property is edited.
« Arequirement is set as obsolete.
* Arequirement is recovered.
» Atestis assigned to or removed from a requirement.
* A custom property of a requirement is created, edited, or deleted.
Tests « A container is created or edited.
e A product is edited.
» A source control profile is edited.
» "Clear working folder" is edited.
* The root node is edited.
e The custom data directory is edited.
e The include directory is edited.
e The hidden test properties are edited.
» The Silk Test Classic interface is edited.
* Atest folder is created, edited, or deleted.
» Atestis created, edited, or deleted.
* The planned time is edited.
» Atest step is added or edited.

Notifications Page
Project:<Project Name> > Project Settings > Notifications

The Notifications page lists the notification events for the active project. For each notification event, the
Notifications page displays the following columns:

Column Description

Notification Events Name of the notification event that has been set up for
the active project.

Status Status of the notification event. Active or inactive.

Click the Configure... button in each section to edit the values.

Email

When an email notification event is activated, a notification email is sent to the user that activated the
event, the first time one of the specified settings is changed.




i Note: You must have specified an email address to be able to receive email notifications.

Requirement Flagging

You can configure notifications differently for internal and external requirements. All requirement flagging is
enabled by default. For more information, see the Flags topic.

Structuring Your Test Assets

Silk Central tracks results of test executions in the context of versions and builds of one specific product.
Therefore a Product needs to be defined before tests can be created.

For automated tests, another requirement for test creation is a Source Control Profile. Automated tests in
Silk Central actually represent test scripts that are located in source control systems, which are accessed
via such source control profiles. Both product and source control profile information are specified on Test
Container level, which therefore represents the top-hierarchy node of a test assets structure. Within a test
container you can then use folders to structure your test assets according to your testing needs and your
process.

Remember that although you can have multiple test containers, one execution plan can execute tests of
only one test container due to the test result/build/version relation. Therefore, design your test asset
structure according to which tests you want to execute together within one execution plan.

Test Containers

Test containers are used to structure your test assets at the top level. Silk Central associates a defined
source control profile and a product per container, which impacts what you can do with tests within a
specific container.

When you reach the stage of planning your test executions, only the tests of one specific container are
available, so you may consider keeping the amount of specified containers as low as possible.

Adding Test Containers

Note: We recommend to use test containers with caution, because they bind the product to the
source control profile.

To add a new test container:

1. In the menu, click Tests > Details View .
2. In the Tests tree, select the root node to which you want to add the new container as a sub-node.

f Note: Containers cannot be nested, but you can add sub-folders to containers.

3. Click “@ on the toolbar or right-click on the node and choose New Test Container.

You can also right-click on the node and choose New Test Container.
A new container root node is added to the Tests tree and the New Test Container dialog box displays.
4. Type a Name and Description for the container.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

5. Select any predefined Product that is to be associated with this test container from the list box. For
details on adding a product profile, see Adding Products.

6. Select a predefined source control profile from the Source Control profile list box.

If you do not intend to check out any test sources for the test container, for example if you only have
manual tests, select -—-.
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Note: The Silk Central execution servers retrieve the program sources for the tests included in the
container from the defined source control profile. Depending on the specified path in your source
control profile, you can specify to use a sub-node in the Root node field of the test container.

7. Optional: Check the Clear working folder before a test is executed check box.
If checked, files that have been removed from the source control will also be removed from the working
folder. Default is checked.

8. To specify the default root path where the container is to be saved, click Browse... and navigate to the
location.

9. Optional: When Silk Central is integrated with Silk Performer, you can define the Custom data
directory and Custom include directory.

In Silk Performer, the Include directory is divided into a System Include directory and a Custom
Include directory. The Data directory is divided into a System Data directory and a Custom Data
directory. For additional information, refer to the Silk Performer documentation.

10.The Hidden Test Properties portion of the dialog box allows you to specify the test property types that
are to be displayed on the test container’'s Properties page, and the Properties pages of all test folders
within the container.

These settings do not affect the display of individual tests.
11.Click Edit to adjust the hidden test property settings. The Hidden Test Properties dialog box displays.
12.Uncheck the check boxes of all test types for which you want to have properties displayed.
13.Click OK to save your settings and close the Hidden Test Properties dialog box.
14.Click Save to save your settings.

The new container is added to the Tests tree.

Adding Links to Containers

In the Tests tree, you can add a link to a test container in the same project. Linked test containers are
displayed in read-only mode at the position in the tree where the link is inserted.

To add a link to a test container:

1. In the menu, click Tests > Details View .
2. Right-click the node in the Tests tree under which you want the linked test container to display.

3. Choose New Link if you want to link the test container at the hierarchy level of the selected node, or
choose New Child Link to link the test container one level below the selected node. The Select Test
Container For Linking dialog box displays.

4. Select the test container that you want to reference.
Note: If the referenced test container and the container in which you add the link use different
source-control profiles, a confirmation dialog box displays, asking you if you really want to create
the link. Linking inside a test container to another test container with a different source-control
profile can lead to problems when you download or execute a test within the linked container. Click

No if you want to change the custom include directory of one of the containers first, or click Yes to
create the link anyway.

5. Click OK to confirm your selection.

The linked container is placed within the selected container as a read-only entity. Any changes to the
original test container will be reflected in the linked container.

Editing Test Containers

To edit the properties of a test container:

1. In the menu, click Tests > Details View .



2. Inthe Tests tree, select the test container that you want to edit.

Click 1 in the toolbar.

You can also right-click on the test container and select Edit.
The Edit Test Container dialog box displays.

4. Edit the properties of the test container.

5. Click OK to apply your changes.

Test Folders

Use folders to structure your tests within a container.

Adding Test Folders

To add a new test folder:

1. In the menu, click Tests > Details View .
2. In the Tests tree, select the test element after which you want to add the new folder.

3. Click @ on the toolbar.

You can also right-click on the element and choose New Test Folder to add the new folder after the
selected element or choose New Child Test Folder as a sub-node to the selected element.

f Note: For test containers you can add test folders only as sub-nodes.

A new folder node is appended to the Tests tree and the New Folder dialog box displays.
4. Provide a name and description for the folder.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. Click OK to save your settings.

The new folder is added to the Tests tree.

Editing Test Folders

To modify test folder properties:

1. In the menu, click Tests > Details View .
2. Select the folder in the tree.

3. Click .ﬁ; in the toolbar.

You can also right-click on the test folder and select Edit.
The Edit Test Folder dialog box displays.
4., Edit the name and description of the folder as required.
5. Click OK to accept your changes.

Sorting Test Folders

To move a folder up or down within the Tests tree:
1. Inthe menu, click Tests > Details View .

2. Select the folder in the tree.

3. click I on the toolbar to move the folder one step up in the tree or & to move the folder one step
down.
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Test Packages

Test packages provide support for the structure of third-party test types in Silk Central, and consist of a
package root as well as an arbitrary hierarchy of suite nodes and test nodes.

Test packages also provide users with detailed information about a test execution run. Test packages, suite
nodes, and test nodes can be individually assigned, along with their issues and attachments, to
requirements. This functionality is similar to the functionality of every other test. After a third-party test is
converted into a test package, all tests contained in the package can be run individually. Test nodes and
suite nodes contained in a test package are provided with an additional property, the External ID.

An advantage of test packages is that the structure can be maintained automatically with every test
execution. The structure of a test package can be updated according to the results of its runs. The file
<Silk Central installation folder>\wwwroot\silkroot\xsl\output.xsd contains an XML
schema for the structure of the output XML files of test packages.

Test packages enable the entire functionality of the individual tests, with the following exceptions:

« Test containers that contain test packages cannot be linked.
« Test packages cannot be data-driven because they do not possess data-driven properties.
« All success conditions except the execution time-out are disabled and hidden for test package nodes.

Note: Silk Performer tests, Silk Test Classic tests, and manual tests cannot be converted to test
packages, as the structure of these tests is supported in Silk Central by default.

The information that provides the internal structure of a test package is specific, and is no longer consistent
when you copy the test package. To reuse a test package, you have to copy the test package, revert the
copied package into the parent test, apply the test to your needs, and then convert the changed test to a
test package.

Creating a Test Package
To create a new test package out of a third-party test:

1. Run the test once to create the output.xml file, which contains the structure of the test package.
For additional information on executing a test, see Executing a Trial Run of a Test.
2. Inthe menu, click Tests > Details View .

3. In the Tests tree, right-click the test and choose Convert to Test Package. The selected test is
converted to a hierarchy representing the structure of the last execution result.

Using External IDs

You can use External IDs to uniquely identify test nodes and suite nodes in test packages. An External 1D
is provided as a property for each test node and each suite node. The automatically generated External ID
identifies a unique test method by the fully qualified name of the class and the method with an "~"
prepended.

For JUnit tests, the following schema is used for the automatically generated External ID: ~<package
name>._<class name>#<method name>.

When refactoring JUnit test classes, the automatic generation of the External ID is not applicable, because
the result information of tests previous to the refactoring will be lost when creating a new test. In this case
the External ID for the test must be manually defined. The refactored method is re-identifiable, because
the External ID remains unchanged while moving a JUnit test or changing its name. The External ID can
be manually set in the source code as an annotation.

The following code example shows such an annotation for JUnit tests:

import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;



@Retention(RetentionPolicy.RUNTIME)

public @interface Externalld {
String externalld();

}

The annotation can be used in a JUnit test to annotate classes and test methods as shown:

import static org.junit._Assert.*;
import org.junit.Test;

import com.borland.runner_Externalld;

@External ld(externalld="JUnit4test")
public class JUnit4test {

@Test
@External ld(external 1d="MyExtld1™)
public void testli() {

}

@Test
@External ld(external 1d="MyExtl1d2"™)
public void test2() {

}
}

Be aware that using External IDs with JUnit runner 'org.junit.runners.Parameterized' is not supported for
test methods, because the External ID is not unique for repeated runs of a method with different
parameters. As a work around an External ID could be specified on class level, but must be omitted on
method level. An example follows:

@RunWith(Parameterized.class)
@Externalld(external ld="parameterizedWithExtld™)
public class TestCaseParameterizedWithExternalld {

@Parameters
public static Collection<Object[]> parameterFeeder() {
return Arrays.asList(new Object[][] {

{ "param_namel™, "param_valuel' }, // set of parameters per run, type
matching constructor must exist!

{ "param_name3", "‘param_value3" },

{ "param_name2", "‘param_value2"™ 3},

}
)
}

private String paramName;
private String paramValue;

public TestCaseParameterizedWithExternalld(String paramName, String
paramValue) {
this.paramName = paramName;
this.paramvValue = paramValue;

}

@Test
public void testWithParams() {
System.out.printIn(String.format('run with parameter: name="%s",
value="%s"", paramName, paramValue));

}
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i Note: The setting of the External ID for a JUnit test is only possible for tests using JUnit 4.4 or higher.

Reusing a Test Package

The information that provides the internal structure of a test package is specific, and is no longer consistent
when you copy the test package. To reuse a test package, you have to copy the test package, revert the
copied package into the parent test, apply the test to your needs, and then convert the changed test to a
test package.

To reuse the information in a test package:

In the menu, click Tests > Details View .
Right-click the test package that you want to reuse in the Tests tree and select Copy.
Select the node in the Tests tree to which you want to add the copied test package.

Right-click the selected node and select Paste, to add the copied package to the same level in the tree,
or select Paste as Child to add the copied test package as a sub-node to the selected node.
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/- Caution: The information now contained in the copied test package is not consistent.

5. Right-click the copied package and select Revert Package to Test. The package information is
removed from the parent test.

6. Edit the test to apply it to your needs.
For additional information, see Editing Tests.
7. Right-click on the edited test and select Convert to Test Package.

You now have a copy of the original test package with different properties.

Reverting a Test Package to the Test
Revert a test package to the original test to create a different test package out of the parent node.

Note: Reverting a test package to a test hides run result information at the test level. However, you
can still see this information in the timeline view or a result file.

To revert a test package to the original test:

1. Inthe menu, click Tests > Details View .
2. Right-click the test package in the Tests tree.
3. Click Revert Package to Test.

The test package is reverted to the original test.

Cleaning Up a Test Package

To clean up a test package:

1. In the menu, click Tests > Details View .
2. Right-click the test package in the Tests tree.
3. Click Clean Up Test Package.

All tests that were not executed during the last execution of the test package are removed from the test
package.

Managing Tests

Add a new test to your testing framework or configure existing tests.
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Test Types

Silk Central supports the following test types out-of-the-box:

Manual Tests

Manual tests are step-by-step instructions for testers. Silk Central provides a Ul to efficiently execute
manual tests, including the option to record videos and capture screen images during test execution. If
desired, manual tests can later be converted to automated tests.

Creating or Editing Manual Tests

To create or edit a manual test:

1.
2.

In the menu, click Tests > Details View .

Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click £ (Edit).

The New Test/Edit Test dialog box appears.
Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
If you are creating a new test, select Manual Test from the Type list box.
In the Planned time field, type the expected amount of time for this manual test to execute.
Click Finish.

Adding or Editing Manual Test Steps

Add or edit manual test steps of a test or a shared object in the Steps page.

To add or edit a manual test step:

1.

For a shared object, click Tests > Libraries in the menu. For a test, click Tests > Details View in the
menu.

Select the node for which you want to add or edit steps in the Tests or Libraries tree.

Click the Steps tab.

Click on the test step that you want to edit, or use the icons on the Steps toolbar to insert a new step.
The details of the test step are shown in the Edit Step view.

Edit the name, action description, expected results, and step properties of the test step in the
corresponding fields.

You can insert values from data sources into manual test steps in the form of parameters (see Adding a
Data Source Value to a Manual Test Step). Parameters use the syntax ${<name>}%}, for example $
{username}. When converting a manual test to a keyword-driven test, these parameters are
automatically added to the generated keyword.

Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
Perform one of the following actions to finish editing the test step:

* Click OK and New Step to save your changes and add a new step after the current one.
* Click OK to save your changes.
* Click Cancel to revert your changes.
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Using External Tools to Create Manual Tests

You can use the open interface of Silk Central to create manual tests outside of Silk Central’s user
interface. You can create your own solutions and automatically create manual tests by using Silk Central’s
Web Service calls.

The following calls in the tmplanning Web Service assist you in creating manual tests:

« getTestContainers

» addManualTest

¢ getCustomStepPropertyNames
« getChildNodes

» getNodeDetails

» addNode

e updateNode

e startExecution

For a detailed explanation of these Web Service calls, see Available Web Services.

Converting Manual Tests to Automated Tests

You can convert a manual test to one of the supported automated test types, for example keyword-driven,
Silk Performer, Silk Test Classic, NUnit, JUnit, and all installed plug-ins. The process carries manual test
parameters over to the automated test, and adds automated parameters to the new automated test.

The manual test parameters that are carried over to automated tests are:

« Name

» Description

» Assigned requirements

« Assigned execution plans
e Assigned issues

« Attachments

» Test steps

To convert a manual test to an automated test:

1. In the menu, click Tests > Details View .

2. Right-click the manual test in the Tests tree and select Automate with....

3. Select the automated test type from the context menu.

4. For information on filling out the dialog, see the appropriate topic in Creating Tests.

Converting Automated Tests to Manual Tests

You can convert an automated test to a manual test. This is useful for example if you have an automated
test that you want to convert to another test type, for instance from Silk Test Classic to Silk4J. In this case
you would convert the Silk Test Classic test to a manual test, and then automate it with Silk4J.

Note: Limitations: Automated to manual test conversion only works for standard automated tests,
which excludes package nodes, data-driven nodes, and linked nodes.

1. In the menu, click Tests > Details View .
2. Right-click the test in the Tests tree and select Convert to Manual Test.
3. Confirm the message.

/1», Caution: Test type-specific properties are discarded. If an automated test is currently running, test
*~ results are discarded after the test run completes.
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Steps Page
Tests > Details View > <Manual Test> > Steps
Tests > Libraries > <Shared Object> > Steps

The Steps page lists all manual test steps that are included in the selected test or shared object. The page
supports standard Windows Explorer style multi-select functionality.

To create a new shared object, select the steps you want to share and click =,

The page includes the following toolbar items:

Toolba Description

r ltem

=] Add a new test step to the end of the list.

= Insert a new test step before the selected step.

= Add a call to a shared object to the end of the list.

o= Add a call to shared steps from a library before the selected step.

b4 Delete the selected test steps from the list.

¥ Cut the selected test step from the list and move it to the clipboard.

By Copy the selected test steps to the clipboard.

Ay Paste a copy of the test steps held on the clipboard to the row above the selected in the list.

E 3 Move the selected test step one position up in the list.

E N Moves the selected test step one position down in the list.

[im] Opens the Attachments dialog box, where you can perform the following actions:

Upload File Upload and attach a file to the selected test step.
Attach Link Attach a link to the selected test step.

Download All Files Download all attached files from the selected test step.
Delete Delete the file or link.

B When steps of the test or shared object call a shared object in a library, click here to view the original steps.
The resolved steps are marked with an arrow, and you can access them by clicking on their name. You
cannot edit steps while this view is enabled.

=N View steps called from a shared object in a library as a single step. Enable this view to edit test steps.

5 Create a shared object out of the selected steps.

e Extract calls from other shared objects. Copies all steps in the calls you have selected in the grid into the
manual test or shared object.

Keys Action

- Move up

+ Move down

Ctrl+A Select all

Tests

139



140

Tests

Keys Action

Ctrl+C Copy
Ctrl+X Cut
Ctrl+V Paste
Ins Insert
Del Delete

The Steps page supports the following keyboard functions (shortcuts) for test elements:

The steps are displayed in a grid with the following columns:

Column Description

Order Number of the step in the execution sequence.

Name Name of the test step.

Action Action you must perform to execute the test step.
Description

Expected Expected result of the test step.

Results

Attachments Amount of links or files that are attached to the test step.

The Edit Step view shows the details of the selected test step and allows you to edit the name, action
description, expected results, and step properties of the test step.

The following buttons are available in the Edit Step view:

Button Description

OK and New  Click when you are finished with editing the current step and you wish to save your changes and
Step add a new step after the current.

OK Click when you are finished with editing the current step and you wish to save your changes.

Reset Click to revert your changes.

Test Export, Update, and Import
The Silk Central/Excel integration allows you two distinct options for modifying your tests. These include:

» Export and update: this option allows you to create your tests in Silk Central, export to Excel to make
the changes, and then update them back into Silk Central.

» Import: this options allows you to create tests in Excel and then import them into Silk Central.

In both scenarios, you will need to a mapping file to synchronize the columns between the two products.
Note: Currently, Silk Central supports only .xslx files for import, and the import is limited to manual
tests.

Export, Update, and Import Rules

The following business rules apply during the export-update and import processes:

General Rules

« |If atest row in Excel does not have a TestlD or a Path, then it is considered to be a new test and is
created in a new folder under the test container from which the import functionality was executed.




* You can add existing TestIDs to update tests on update, and you can add existing SharedStepIDs to
add new shared steps on import/update.

« New automated tests are not imported and updated.

« Inherited attribute values are not exported.

« |If atestis moved to a different folder hierarchy in Excel, the move is ignored during update.

« If atestis missing in Excel (it was deleted), the test is not deleted during update.

¢ Import uses the Path column for (new) folder names.

e You cannot use A-Z as a customized column name. These are reserved for Excel's A-Z, which can be
used in mapping.

Shared Steps

* Are added for import and update.

« Are deleted and reordered for update.

« Will not be updated.

« If the Excel SharedSteplD does not exist in Silk Central, an error is reported.

Data-Driven Tests

« Non-atomic data-driven child tests are not exported.

« All tests can be imported, but their data-driven properties cannot be exported to or imported from Excel.

« Update from Excel is only supported if the target folder does not contain data-driven tests.

Test Export and Update
This section describes how to export and to update tests from Microsoft Excel into Silk Central.
Use the export-update to Excel functionality if you want to perform bulk edits on existing tests.

f Note: The following fields are not editable in Excel: Status, TestType, StepID, and StepOrder.

Export and Update Overview
The following is a high level overview for exporting and updating:

» Select the container or folder.
« Export to Excel.

* Make changes in Excel.

» Verify/create the mapping file.
« Update back into Silk Central.

Exporting a Test to Excel

1. Inthe menu, click Tests > Details View .
2. Right click a test container or test folder that includes the tests that you want to export.
3. Select Export to Excel... The Export Tests to Excel File dialog box displays.
4. Select the mapping file from the Choose Mapping File list box.
The default mapping file is TestPropertiesDefaultMapping.xml. For information about creating
customized mapping files, see Editing the Test Mapping File.
S Optional: Click K| to edit the mapping file. Click X to delete the mapping file.
Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.
6. Click OK.
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Test information is saved into the Excel file for you to edit.

Updating a Test from Excel

Before you can update a test from Excel, you first need to export the test from Silk Central.

In the menu, click Tests > Details View .

Right click a test container or folder that includes the tests that you want to update.
Select Update from Excel... The Update Tests from Excel File dialog box opens.
Select the mapping file from the Choose Mapping File list box.

The default mapping file is TestPropertiesDefaultMapping.xml. For information about creating
customized mapping files, see Editing the Test Mapping File.

oD R

Optional: Click i) to edit the mapping file. Click X to delete the mapping file.
Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.

6. Select the Excel file in the Test File (.xIsx) field.

7. Click OK.

Test Import
This section describes how to import tests from Microsoft Excel into Silk Central.

Silk Central enables you to import tests from Microsoft Excel (Excel) into any container or folder in the
Tests area and then maintain and execute all included tests in Silk Central. The import is a one-time event.

Before you can import tests, you need to create a test file in Excel. For more information, see Test File.

Silk Central uses the information stored in the Excel file and in a mapping file to determine what data to
store. Silk Central uses a mapping file to map the tests in the Excel file to the tests in the Tests area. A
default mapping file named TestPropertiesDefaultMapping.xml is preselected for the import. You
can choose your own customized mapping file to map your tests. For more information about mapping files,
see Editing the Test Mapping File.

Importing a Test from an Excel File

To import a test from an Excel file into the Tests area:

1. In the menu, click Tests > Details View .

2. In the Tests tree, right-click the folder or container that you want to use as the parent node of the
imported test and choose Import from Excel File. The Import Test from Excel File dialog box opens.

3. Select the mapping file from the Choose Mapping File list box.

The default mapping file is TestPropertiesDefaultMapping.xml. For information about creating
customized mapping files, see Editing the Test Mapping File.

Optional: Click ) to edit the mapping file. Click X to delete the mapping file.
Note: These actions require the permissions Modify Office import mapping files/Delete Office
import mapping files, respectively.

5. Check the One-Time Import check box to import the tests directly under the selected node without
creating a common root folder.

6. Either type the fully qualified path of the test file into the Test File field or click Choose File to search
for the test file.

7. Click OK.



Test File

You can create a test file in Excel to import tests into Silk Central. In the test file, you can define all tests
and test steps, along with their properties, attributes, and parameters.

To map the tests in your test file to the tests in Silk Central, use an XML mapping file. The mapping file
defines the location of the elements in your test file to Silk Central. You can give the items included in the
test file any name you like, as long as you map them appropriately in your mapping file. For more
information about mapping files, see Editing the Test Mapping File.

Note: Currently, Silk Central supports only .xslx files for import, and the import is limited to manual
tests.

Property Mappings

Click Edit Mapping on the Import Tests from Excel File or Update Tests from Excel File dialog to map
the tests in your Excel file to Silk Central as follows:

» Header Row: Specify the row in your Excel file which contains the column names to be used for
mapping the properties.

» First Data Row: Specify the row that contains the first test. This row and all rows below are interpreted
as tests.

» Separator Characters: Specify the characters that should be interpreted as separators within property
values. This is used for multi-list properties.

* Name, Description: Specify the column names in the header row that are mapped to test name and
description, respectively.

* Planned Time: The expected amount of time for this manual test to execute.

» Step properties: The name, action description, and expected result of the test step.

« Assigned Requirement IDs: If requirements should be assigned to the test, specify the ID's of those
requirements as comma-separated list. Make sure that this column is formatted as "Text" in Excel,
otherwise the assignment may not work.

Mapping File

The mapping file is used during the update process of export-update and during the import process when
data is coming into Silk Central from Excel.

Editing the Test Mapping File
You need the Modify Office import mapping files permission to edit the mapping file:

1. In the menu, click Tests > Details View .

2. In the Tests tree, right-click the folder or container that you want to use as the parent node of the
imported test and choose Import from Excel File. The Import Test from Excel File dialog box opens.

3. Click Edit Mapping. The Edit Mapping dialog box opens.
4. Edit the variables of the test file in the fields.

f Note: For information on the variables included in the test file, see Test File.

5. Optional: Edit the name of the mapping file.
6. Click OK to save your changes or click Cancel to cancel your changes.

Test Versioning
Silk Central creates new versions of tests during the import and update processes.

When you perform an update from Excel into Silk Central, two new versions of the test tree are created.
The versioning process will record a snapshot before and after the update process.
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Export-Update

Tests will contain default comments to note that they were updated from excel if they are added or
modified.

Import

Tests will contain default comments of Created.

Keyword-Driven Tests

Keyword-driven testing is a software testing methodology that separates test design from test development
and therefore allows the involvement of additional professional groups, for example business analysts, in
the test automation process. Silk Central and Silk Test support the keyword-driven testing methodology and
allow a very close collaboration between automation engineers and business analysts by having
automation engineers develop a maintainable automation framework consisting of shared assets in the
form of keywords in Silk Test. These keywords can then be used by business analysts either in Silk Test to
create new keyword-driven tests or in Silk Central to convert their existing manual test assets to automated
tests or to create new keyword-driven tests.

« A keyword-driven test is an executable collection of keywords. A keyword-driven test can be played back
just like any other test.

« A keyword sequence is a keyword that is a combination of other keywords. Keyword sequences bundle
often encountered combinations of keywords into a single keyword, enabling you to reduce
maintenance effort and to keep your tests well-arranged.

* A keyword is a defined combination of one or more actions on a test object. The implementation of a
keyword can be done with various tools and programming languages, for example Java or .NET.

Keyword-driven test 1

T — > Keyword 1
- — _— _ 1 -
e —
T
T » Keyword 2
Keyword 3 » y
| -
\_ Y,
> Keyword 3
Keyword sequence 1
Keyword-driven test 2
rd ™, |_ Keyword 1 j
.
_____ il |— Keyword 2 ]
|— T _'J > Keyword 4

There are two phases required to create keyword-driven tests:

1. Designing the test.
2. Implementing the keywords.

Advantages of Keyword-Driven Testing
The advantages of using the keyword-driven testing methodology are the following:

« Keyword-driven testing separates test automation from test case design, which allows for better division
of labor and collaboration between test engineers implementing keywords and subject matter experts
designing test cases.

» Tests can be developed early, without requiring access to the application under test, and the keywords
can be implemented later.

» Tests can be developed without programming knowledge.



« Keyword-driven tests require less maintenance in the long run. You need to maintain the keywords, and
all keyword-driven tests using these keywords are automatically updated.

» Test cases are concise.

« Test cases are easier to read and to understand for a non-technical audience.

» Test cases are easy to modify.

* New test cases can reuse existing keywords, which amongst else makes it easier to achieve a greater
test coverage.

* The internal complexity of the keyword implementation is not visible to a user that needs to create or
execute a keyword-driven test.

Keywords

A keyword is a defined combination of one or more actions on a test object. The implementation of a
keyword can be done with various tools and programming languages, for example Java or .NET. In Silk
Test, a keyword is an annotated test method (@Keyword). Keywords are saved as keyword assets.

Keyword-driven tests and the associated keywords can be designed and managed in Silk Central, while the
actual implementation is done in a functional testing tool. Silk Central and Silk Test support the keyword-
driven testing methodology and allow a very close collaboration between automation engineers and
business analysts by having automation engineers develop a maintainable automation framework
consisting of shared assets in the form of keywords in Silk Test. These keywords can then be used by
business analysts either in Silk Test to create new keyword-driven tests or in Silk Central to convert their
existing manual test assets to automated tests or to create new keyword-driven tests.

A keyword sequence is a keyword that is a combination of other keywords. Keyword sequences bundle
often encountered combinations of keywords into a single keyword, enabling you to reduce maintenance
effort and to keep your tests well-arranged.

Test Automation Overview

Test automation is the process of using software to control the execution of tests by using verifications to
compare the actual outcomes of the execution with the expected outcomes.

A test automation framework is an integrated system that sets the rules of automation of a specific product.
This system integrates the tests, the test data sources, the object details, and various reusable modules.
These components need to be assembled to represent a business process. The framework provides the
basis of test automation and simplifies the automation effort.

Creating a Keyword-Driven Test in Silk Central

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click 4 (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. Select the test type Keyword-Driven Test from the Type list.
6. Select the Library which contains the keywords that you want to use.
The library is required to store the set of keywords that the keyword-driven test uses.
7. Click Finish.

Creating a Keyword-Driven Test by Automating a Manual Test
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To convert a manual test to a keyword-driven test in Silk Central:

1. In the menu, click Tests > Details View .

2. Right-click the manual test in the Tests tree and select Automate with... > Keyword-Driven Test from
the context menu. The Keyword-Driven Test Properties dialog box appears.

3. Select the Library which contains the keywords that you want to use.
The library is required to store the set of keywords that the keyword-driven test uses.
4. Click Finish.

Automating a manual test as keyword-driven test generates the following:

* The manual test is converted to an automated keyword-driven test, containing a draft keyword for each
test step. These keywords are added to the library that has been selected for this test.

« |If the test contains calls to shared steps that already exist as keyword sequences, these keyword
sequences are referenced.

« If the test contains calls to shared steps that don't exist as keyword sequences, these shared steps
objects are referenced and enhanced to also be keyword sequences, containing a draft keyword for
each test step. This also applies to nested shared steps (shared steps that reference other shared
steps). If the hierarchy of nested shared steps is more than 30 levels deep, draft keywords for calls to
shared steps below that level are created.

« If the test contains calls to shared steps that are in a different library, draft keywords for these steps are
created and referenced.

If your test steps contain parameters that you want to access in the generated keywords, the Action
Description of a test step must use the correct syntax. Parameters use the syntax ${<name>}, for
example ${username}. When converting a manual test to a keyword-driven test, these parameters are
automatically added to the generated keyword.

Managing Keywords in a Test
Tests > Details View > <Test> > Keywords

The Keywords page enables you to manage the keywords of the selected keyword-driven test. The
following actions are possible:

Task Steps

Opening a test or keyword Click Open with Silk Test to open the selected test or keyword sequence in Silk
sequence in Silk Test Test.

Adding a keyword 1. Click New Keyword at the bottom of the keywords list, or right-click a

keyword and select Insert Keyword Above from the context menu.

Note: You can let Silk Central recommend keywords based on their
usage. Toggle the recommendations on or off with Enable
Recommendations or Disable Recommendations in the context
menu. For additional information, see Which Keywords Does Silk
Central Recommend?.

2. Select a keyword from the list of available keywords or type a new name to

create a new keyword.
3. Click Save.

Alternatively, double click an existing keyword in the All Keywords pane on the
right or drag and drop it.

Tip: You can select multiple keywords with Ctrl+Click. When dropping
= them, they will be sorted in the order that you selected them in.




Task

Steps

Deleting a keyword

Click X in the Actions column of the keyword that you want to delete. Click
Save.

Changing the order of keywords

Drag and drop a keyword to the desired position. Click Save.

Creating a keyword sequence (a
keyword consisting of other
keywords)

1. Select the keywords that you want to combine in the keywords list. Use Ctrl
+Click or Shift+Click on the row number column to select multiple keywords.

2. Right-click your selection and click Combine.
3. Specify a Name and Description for the new keyword sequence.

Extracting keywords from a
keyword sequence

Right-click a keyword sequence and click Extract keywords. The original
keyword sequence is then replaced by the keywords that it contained, but it is not
removed from the library. Click Save.

Copying and pasting keywords
into tests or keyword sequences

1. Select the keywords that you want to copy in the keywords list. Use Ctrl
+Click or Shift+Click on the row number column to select multiple keywords.

2. Press Ctrl+C to copy your selection, or Ctrl+X if you want to move the
keywords.

3. Open the test or keyword sequence that you want to copy the keywords to
and select the row above which the keywords will be inserted.

4. Press Ctrl+V.

( % Tip: You can also paste your selected keywords into Excel, and copy and
= paste them from there into your tests or keyword sequences.

Defining parameters for a
keyword sequence

1. Click Parameters above the keywords list. The Parameters dialog box
appears.

2. Click Add Parameter.

3. Specify a Name for the new parameter. If the parameter is an outgoing
parameter (delivers a value, instead of requiring an input value), check the
Output checkbox.

4. Click OK.

5. Click Save.

Editing a draft keyword

Click =" in the Actions column of the draft keyword that you want to edit.

2. Select a Group or specify a new group for the keyword.

3. Type a Description for the keyword. This information is valuable for the
engineer who will implement the keyword.

4. Click OK.

5. Optional: Click into a parameter field to add parameters for the keyword. If the
keyword is implemented with Silk Test, these parameters will appear in the
generated code stub.

6. Click Save.

Searching for a keyword

Use the search field in the All Keywords pane on the right to find a specific
keyword. When you enter alphanumeric characters, the list is dynamically
updated with all existing matches. Tips for searching:

« The search is case-insensitive: doAction will find doaction and
DOAction.
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Task Steps

« Enter only capital letters to perform a so-called CamelCase search: ECD will
find Enter Car Details, Enter Contact Details and
EnterContactDetails.

» Keyword and group names are considered: test will find all keywords that
contain test and all keywords in groups where the group name contains
test.

« ?replaces 0-1 characters: user?test will find userTest and
usersTest.

« *replaces 0-n characters: my*keyword will find myKeyword,
myNewKeyword and my_other_keyword.

¢ <string>. only searches in group names: group . will find all keywords
in groups where the group name contains group.

« .<string> only searches in keyword names: . keyword will find all
keywords that contain keyword.

« <string>.<string> searches for a keyword in a specific group:
group .word will find myKeyword in the group myGroup.

« Use quotes to search for an exact match: *Keyword* will find Keyword
and MyKeyword, but not keyword.

Finding draft keywords in the If you want to switch to the library that contains the draft keywords of your
library selected test or keyword sequence, click Draft keywords in the top right of the
editor page.

Managing Keywords in a Library

The Keywords page offers two different views in Tests > Libraries , depending on the selected object.

Library

If your selected object is a library, all keywords and keyword sequences within this library are listed.

Libraries that contain uploaded keyword libraries are displayed with the symbol #. The following actions
are possible:

Task Steps

Implementing a keyword Prerequisites: If your keyword contains parameters, you need to specify a value for each
(adding code to be able parameter before you implement the keyword.
to actually run the

keyword in a test) L

Click & (Implement with Silk Test) in the Actions column of the keyword that you
want to implement.

Note: If your browser reports a security warning for opening an external
application, confirm the message.
2. The Silk Test client opens. Refer to the Silk Test client documentation for detailed
information.
3. After having implemented a keyword, upload it back to Silk Central.

iti i 57]
Editing ar] |m.plemented Click @™ (Open with Silk Test) to open the keyword in the Silk Test client. Refer to the Silk
keyword in Silk Test Test client documentation for detailed information.




Task

Steps

Converting a draft
keyword to a keyword
sequence (a keyword
consisting of other
keywords)

Click 4 in the Actions column of the keyword that you want to convert to a keyword
sequence. The original keyword is then replaced by a keyword sequence with the same
name and the keyword editor opens.

Converting a keyword
sequence to a draft
keyword

If you accidentally created a keyword sequence, you may want to convert it back to a draft

keyword. Click ¥ (Convert to draft keyword) in the Actions column of the keyword
sequence that you want to convert.

Note: Converting a keyword sequence to a draft will delete the sequence and all
contained keywords. This action cannot be undone.

Editing a keyword
sequence

Click |/ to open the keyword sequence in the keyword editor.

Grouping keywords

To better structure the keywords in a library, you can group them:

« Silk Central keyword sequences can be placed in sub-folders. The folder names are
reflected as group names and your keywords are grouped accordingly in the list.

« Keyword groups of implemented keywords are defined in the implemented code. These
group names are used by Silk Central and your keywords are grouped accordingly in
the list.

Viewing tests and

keyword sequences that

reference a specific
keyword or keyword
sequence

To view all tests and keyword sequences that reference a specific keyword or keyword
sequence, select the appropriate entry in the keyword list and the Referenced By list will
display all referencing keyword-driven tests and keyword sequences. Simply click the name
to jump to the respective reference.

Replacing keywords in
referencing tests and
keyword sequences

To replace references to the selected keyword or keyword sequence with another one,
select the appropriate entry in the keyword list and use the Referenced By list to select the
objects in which you want to replace the reference.

1. Select the keyword or keyword sequence that you want to replace.

2. Inthe Referenced By list, use Ctrl+Click or Shift+Click to select the objects in which
you want to replace the reference.

3. Right-click the selection and choose Replace keyword in selected reference(s). The
Replace References dialog box appears.

4. Select the keyword that you want to replace the current keyword with.

5. If the selected keyword contains parameters, click Next, otherwise click OK and you are
done.

6. The parameters of the selected keyword are listed. For each parameter, select the
matching parameter of the previous keyword, or enter a value.

7. Click OK.

Keyword Sequence

If your selected object is a keyword sequence (a keyword consisting of other keywords), the Keywords
page displays the keyword editor, which enables you to manage the keywords of the selected keyword
sequence. The following actions are possible:

Task

Steps

Opening a test or keyword sequence in Silk Test

Click Open with Silk Test to open the selected test or
keyword sequence in Silk Test.
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Task

Steps

Adding a keyword

1. Click New Keyword at the bottom of the keywords
list, or right-click a keyword and select Insert
Keyword Above from the context menu.

Note: You can let Silk Central recommend
keywords based on their usage. Toggle the
recommendations on or off with Enable
Recommendations or Disable
Recommendations in the context menu. For
additional information, see Which Keywords
Does Silk Central Recommend?.

2. Select a keyword from the list of available keywords or

type a new name to create a new keyword.

3. Click Save.

Alternatively, double click an existing keyword in the All
Keywords pane on the right or drag and drop it.

( 3 Tip: You can select multiple keywords with Ctrl
= +Click. When dropping them, they will be sorted
in the order that you selected them in.

Deleting a keyword

Click X in the Actions column of the keyword that you
want to delete. Click Save.

Changing the order of keywords

Drag and drop a keyword to the desired position. Click
Save.

Creating a keyword sequence (a keyword consisting of
other keywords)

1. Select the keywords that you want to combine in the
keywords list. Use Ctrl+Click or Shift+Click on the
row number column to select multiple keywords.

2. Right-click your selection and click Combine.

3. Specify a Name and Description for the new keyword
sequence.

Extracting keywords from a keyword sequence

Right-click a keyword sequence and click Extract
keywords. The original keyword sequence is then
replaced by the keywords that it contained, but it is not
removed from the library. Click Save.

Defining parameters for a keyword sequence

1. Click Parameters above the keywords list. The
Parameters dialog box appears.

2. Click Add Parameter.

3. Specify a Name for the new parameter. If the
parameter is an outgoing parameter (delivers a value,
instead of requiring an input value), check the Output
checkbox.

4. Click OK.

5. Click Save.

Editing a draft keyword

Click =" in the Actions column of the draft keyword
that you want to edit.




Task Steps

2. Select a Group or specify a new group for the
keyword.

3. Type a Description for the keyword. This information
is valuable for the engineer who will implement the
keyword.

4. Click OK.

5. Optional: Click into a parameter field to add
parameters for the keyword. If the keyword is
implemented with Silk Test, these parameters will
appear in the generated code stub.

6. Click Save.

Searching for a keyword

Use the search field in the All Keywords pane on the
right to find a specific keyword. When you enter
alphanumeric characters, the list is dynamically updated
with all existing matches. Tips for searching:

The search is case-insensitive: doAction will find
doaction and DOAction.

Enter only capital letters to perform a so-called
CamelCase search: ECD will find Enter Car
Details, Enter Contact Details and
EnterContactDetails.

Keyword and group names are considered: test will
find all keywords that contain test and all keywords
in groups where the group name contains test.

? replaces 0-1 characters: user?test will find
userTest and usersTest.

* replaces 0-n characters: my*keyword will find
myKeyword, myNewKeyword and
my_other_keyword.

<string>. only searches in group names:

group - will find all keywords in groups where the
group name contains group.

-<string> only searches in keyword

names: - keyword will find all keywords that contain
keyword.

<string>.<string> searches for a keyword in a
specific group: group .word will find myKeyword
in the group myGroup.

Use quotes to search for an exact match:
"Keyword" will find Keyword and MyKeyword,
but not keyword.

Finding draft keywords in the library

If you want to switch to the library that contains the draft
keywords of your selected test or keyword sequence, click
Draft keywords in the top right of the editor page.
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Cross-Browser Testing with Keyword-Driven Tests

Keyword-driven tests that are implemented with Silk Test and contain a BrowserBaseState can be
parameterized in Silk Central so that you can run these tests across multiple browsers. To configure the
browsers that you want to test:

1. Create a configuration suite and assign the keyword-driven tests that you want to run across multiple
browsers. For detailed information about creating a configuration suite, see Creating a Configuration
Suite.

2. On the Configurations tab, click Add/Remove Parameters and create a new parameter with the name
silktest.configurationName.

3. Click New Configuration to add the configurations that you want to test. For each configuration, specify
the browser that you want to test by entering one of the following values for the
silktest.configurationName parameter:

« Internet Explorer
* Firefox
e Chrome

4. Run the configuration suite.

Building a Keyword-Driven Library Using Java

Build an external keyword-driven library with Java to upload it to Silk Central. This enables you to easily
integrate your existing test framework into Silk Central, for example if you already have existing Selenium
tests.

1. Select Help > Tools and download the Java Keyword Library Tool.

2. Add the downloaded com.borland.silk.keyworddriven. jar to the classpath of your Java
project.

3. Create a Java class that will contain your Keywords.

4. Annotate the Java methods that you want to use as keywords. The following sample outlines a class
that contains one keyword:

import com.borland.silk.keyworddriven.annotations.Argument;
import com.borland.silk.keyworddriven.annotations.Keyword;

public class Keywords {

@Keyword("'My Keyword'™)
public void myKeyword(@Argument(‘'Username™) String name) {
System.out.printin(name);

}
}

5. Compile your sources and create a Java archive (jar).
6. Call the command line tool that is contained in the downloaded jar file with the following arguments:

« java
« —jar com.borland.silk_keyworddriven._jar
o« -build

e Library name to be generated.
e Library type, only Java is currently supported.

e Binaries path where your keyword library jar file resides and if applicable, any other required
libraries.
« Name of the output library package (zip archive) to be generated.

The following example outlines the command line to build a keyword library:

java -jar com.borland.silk.keyworddriven.jar -build
MyLibrary Java ./output "_./output/library.zip"
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Select Tests > Libraries > <Library> > Properties . The generated zip archive can be uploaded to Silk
Central with the command line tool or in the Keyword Library section.

Uploading a Keyword Library from the Command Line
Upload an external keyword library from a Java-based command line to integrate Silk Central and your
keyword-driven tests into your continuous integration build system, for example Jenkins.

To upload your keyword library from a Java-based command line:

1.
2.

Select Help > Tools and download the Java Keyword Library Tool.

Call the command line tool that is contained in the downloaded jar file with the following arguments:

« Java

« —jar com.borland.silk.keyworddriven.jar

« -upload

* Library name of the library in Silk Central to be updated, or created if it does not yet exist.
« Package name of the library package (zip archive) to be uploaded.

* Hostname:port of the Silk Central front-end server.

* Username of the Silk Central user.

« Password of the Silk Central user.

« Update information, describing the changes that were applied to the library, in quotes.

« [-allowUsedKeywordDeletion], an optional flag to allow the deletion of keywords that are used

in a test or keyword sequence. By default, an error is raised if used keywords are attempted to be
deleted.

The following example outlines the command line to upload a library to Silk Central:
jJava -jar com.borland.silk.keyworddriven.jar -upload

"My library"™ "./output/library.zip"” silkcentral:19120 scLogin
scPassword ""Build xy: Implemented missing keywords"

Executing Silk4J/Silk4ANET Keyword-Driven Tests Without Uploading a Library

If you have an existing test automation framework consisting of Silk4J or Silk4ANET keyword-driven tests
and you want to execute them from Silk Central, you can do this by using Silk Central's JUnit and test
package functionality. To do so, follow the steps below:

1.

Create a source control profile that points to the artifacts of your Silk Test project (see Source Control
Profiles).

Create a test container that uses this source control profile (see Adding Test Containers).
Create a JUnit test (see Creating Tests) and configure the following:

» For keyword-driven tests that are implemented in Silk4J:

« Specify the classpath. If you are using the default Silk Test build structure, specify .\output.
« The _kdt files need to be in the folder that you specified as classpath, either packaged into
a - jar file or within a folder in the classpath.
« For keyword-driven tests that are implemented in Silk4NET:

» Specify ./Keyword Driven Tests as classpath.

* Create a parameter for the test container of your tests (see Creating Custom Parameters) called
silktest._keyworddriven.dotnetassembly with a relative path to the .Net Assembly, for
example \bin\Release\Silk4NETProject.dll.

« The Silk Test folder called Keyword Driven Tests containing the . kdt files has to reside in
the root folder of the source control.

Assign the test to an execution plan (see Assigned Tests).
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5. Optional: Once executed, you can right-click the test and select Convert to Test Package to get a
package structure (see Creating a Test Package).

Example: Keywords with Parameters
This topic provides an example of how you can use keywords with parameters.

As a first step, create a keyword-driven test which contains the keywords that you want to use. You can do
this by recording an entire keyword-driven test, or by creating a new keyword-driven test and by adding the
keywords in the keyword-driven test editor.

In this example, the keyword-driven test includes the following keywords:
Start application This is the standard keyword that starts the AUT and sets the base state.

Login This keyword logs into the AUT with a specific user, identified by a user name and a
password.

GetCurrentUser This keyword returns the name of the user that is currently logged in to the AUT.
AssertEquals This keyword compares two values.

Logout This keyword logs the user out from the AUT.

The next step is to add the parameters to the keywords. To do this, open the test scripts of the keywords
and add the parameters to the methods.

To add the input parameters UserName and Password to the keyword Login, change

@Keyword(*'Login')
public void login(Q) {

}

to

@Keyword(*'Login')
public void login(String UserName, String Password) {

}

To add the output parameter UserName to the keyword GetCurrentUser, change

@Keyword('GetCurrentUser'™)
public void getCurrentUser() {

}

to

@Keyword("'GetCurrentUser™)
public void getCurrentUser(OutParameter CurrentUser) {

-

The keyword-driven test in the Keyword-Driven Test Editor should look similar to the following:

Keyword Parameters
Start application

Login

GetCurrentUser

AssertEquals

X X X X ¥
el &l el el &l

Logout
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Now you can specify actual values for the input parameters in the Keyword-Driven Test Editor. To retrieve
the value of the output parameter UserName of the keyword GetCurrentUser, provide a variable, for
example ${current user}. You can then pass the value that is stored in the variable to subsequent keywords.

Keyword Parameters
# [ Start application
# [ Login
< [z GetCurrentUser Heurrent user}
< [z AssertEquals John Smith Heurrent user}
x (= Logout

Which Keywords Does Silk Central Recommend?

When you add keywords to a keyword-driven test or a keyword sequence in the Keyword-Driven Test

Editor, Silk Central recommends existing keywords which you might want to use as the next keyword in
your test. The recommended keywords are listed on top of the keywords list, and are indicated by a bar
graph, with the filled-out portion of the graph corresponding to how much Silk Central recommends the

keyword.

Silk Central recommends the keywords based on the following:

« When you add the first keyword to a keyword-driven test or a keyword sequence, Silk Central searches
for similar keywords that are used as the first keyword in other keyword-driven tests or keyword
sequences. The keywords that are used most frequently are recommended higher.

* When you add additional keywords to a keyword-driven test or a keyword sequence, which already
includes other keywords, Silk Central recommends keywords as follows:

« If there are keywords before the position in the keyword-driven test or the keyword sequence, to
which you add a new keyword, Silk Central compares the preceding keywords with keyword
combinations in all other keyword-driven tests and keyword sequences and recommends the
keywords that most frequently follow the preceding combination of keywords.

« If there are no keywords before the position in the keyword-driven test or the keyword sequence, but
there are keywords after the current position, then Silk Central compares the succeeding keywords
with keyword combinations in all other keyword-driven tests and keyword sequences and
recommends the keywords that most frequently precede the succeeding combination of keywords.

< Additionally, Silk Central takes into account how similar the found keywords are. For example, if both the
name and group of two keywords match, then Silk Central recommends these keywords higher in
comparison to two keywords for which only the name matches.

Unified Functional Testing (UFT) Tests

Unified Functional Testing (UFT) software, formerly known as HP QuickTest Professional (QTP), provides
functional and regression test automation for software applications and environments.

Creating or Editing Unified Functional Testing (UFT) Tests

To execute UFT tests, the Unified Functional Testing software must be installed on the same computer on
which Silk Central execution servers are installed.

To create or edit a UFT test:

1. In the menu, click Tests > Details View .
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2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click E| (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Unified Functional Testing Test from the Type list box. Click
Next.
The Unified Functional Testing Test Properties dialog box appears.
6. In the Test field, select the source control location of the UFT test to be executed.

y Tip: You can select the test (. tsp) itself, or the folder where the test is located.
id

7. Optional: Check the Validate HPE UFT add-ins option to validate all specified add-ins of the selected
UFT test.

8. Optional: Check the Show HPE UFT application option to display the application under test during test
execution.

9. Optional: Check the Log debug messages option to log debug messages in the test run results.
10.Optional: Use the Inherit from parent check boxes to inherit the settings from the parent UFT test.
11.Click Finish.

Note: Parameters are passed to the UFT test by defining parameters with the same name as the test

parameters that are defined in the UFT test itself.

The original UFT result files, run_results._xml and run_results_html, are available in the Files tab
of the test run results.

JUnit Tests

JUnit is a unit testing framework for the Java programming language. Use this test type for JUnit, Silk4J,
and Selenium tests.

Creating or Editing JUnit Tests

To create or edit a JUnit test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click 4 (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select JUnit Test from the Type list box. Click Next.

The JUnit Test Properties dialog box appears.
6. Specify a valid Java Classpath to use on the execution server.
We recommend to use a relative classpath. The relative classpath is then expanded to the full classpath

on the execution server. By using a relative classpath, changes on the location of the source control
profile do not require additional changes to the classpath.



The relative classpath must point to the root node of the test container containing the JUnit test, for
example JUnit_tests. The relative classpath on the execution server is then expanded to include the
working folder of the source control profile, for example C:\temp, and the test file names, for example
tests. jar. For example, if your tests are packaged in a jar file called tests. jar and additional jar
files that are needed for the execution are stored in a sub folder 1'ib, your classpath would be ./
tests.jar;./lib/*.

You can also use a fully qualified classpath. The fully qualified classpath must point to the archive or
folder in which the test classes reside.

7. Optional: In the Test class field, type the fully qualified name of the JUnit test class. If the field is left
blank, all tests in the classpath will be executed, but only if the jar file that contains your tests is explicitly
configured in the Classpath.

8. Optional: In the Test method field, type the name of the appropriate test method.

The method must be available in the test class. If the Test method field is left blank, all tests that are
included in the suite will be executed.

9. Optional: Set the Java home directory to the installation path of the Java Runtime Environment (JRE).
The path must be valid on the execution server on which the test runs.

Note: JUnit tests can be executed in JRE 1.5 and newer. If you use an older JRE, messages
containing java. lang.UnsupportedClassVersionError or Unrecognized option: -
Javaagent will display in the Messages tab.

10.Optional: In the JVM options field, you can specify the command-line options. You can specify multiple
options, but you have to type them in the right order. For example, to use the client VM and set the
maximum size of the heap to 512MB, type -client -Xmx512m. You can also use environment
variables, for example -Xmx${MY_MEMORY}.

11.Check the Record external AUT coverage only check box to get only the code coverage for the
application under test that is defined for the execution plan in the Code Analysis Settings portion of
Silk Central > Execution Planning > Code Analysis .
If the check box is not checked, then the code coverage from the virtual machine that executes the test
is recorded too.

12.0Optional: In the Test coverage path field, type the JAR libraries or the specific class files to monitor for
code coverage information. Note that the coverage path of the JUnit test is specified here, not the path
of the application under test.

We recommend using the relative coverage path from the test container root node, which is then
expanded on the execution server. You can also use a fully qualified path. Use semicolons to separate
multiple jar files, as the following examples show:

o tests.jar;C:\tests\testutils._jar
o ${testenv}\tests.jar;${testenv}\testutils._jar

Note: The coverage path setting is disregarded if the Record external AUT Coverage check box
is checked.

13.Click Finish.

Note: Parameters are passed to the Java process as system properties, for example -
Dhost_under_test=10.5.2.133. Use the System.getProperty() method to access the
system properties. For example, to access the previously passed host_under_test, use
System.getProperty(““host_under_test™);.

Accessing Silk Central Parameters through Java System Properties

Any JUnit test class can access a test parameter of the underlying test as a Java system property; the
launcher passes these parameters to the executing machine using the "-D" VM argument.

In addition to the customer-defined parameters , you can always call the following Java system properties
from a JUnit test:
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Parameter

#sctm_execdef _name

#sctm_execdef _id

#sctm_product

#sctm_version

#sctm_build

#sctm_keywords

#sctm_test results_dir

#sctm_test_name

#sctm_test id

#sctm_source_root_dir

#external_id

#is_test package_root

#sctm_data_driven_parent_test _name

#sctm_data_driven_parent_test _id

MSTest Tests

Description

The name of the execution plan that is currently executed. If
the execution was triggered from the Tests area, the
parameter has the value Unassigned Tests.

The numeric identifier (database key) of the execution plan that
is currently executed.

The name of the product as defined in the executed test
container.

The name of the version to which the results of the execution
are associated.

The name of the version to which the results of the execution
are associated.

A comma separated list which contains the keywords that are
defined for this execution plan.

The path of the directory where the result files of the test
reside.

The name of the Silk Central test being executed.

The numeric identifier (database key) of the test being
executed.

The local path of the test container's root directory, where all
files under version-control reside.

The unique identifier of a test case in a test package to be
executed. You can use this as a filter if only specific test cases
in a test package should be executed.

If true, the test being executed is the root node of the test
package (default). If False, only specific test cases in a test
package specified by #external _id are executed

The name of the parent test, if the executed test is a data
driven row.

The numeric identifier (database key) of the parent test, if the
executed test is a data driven row.

MSTest is a command line utility from Microsoft that executes unit tests created in Visual Studio. Use this

test type for MSTest and Silk4NET tests.

Creating or Editing MSTest Tests
i Note: The MSTest plugin supports the test type unit tests only. Results of other test types are ignored.

To create or edit an MSTest test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click I (New Child Test) on the toolbar, or click E| (Edit).
The New Test/Edit Test dialog box appears.
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4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

5. If you are creating a new test, select MSTest Test from the Type list box. Click Next.

The MSTest Test Properties dialog box appears.
6. You can run a test container, a test list, a test class, or a single test method:

¢ To run a test container, click Browse next to the Test file field and select a .dl1 file. You can
constrain the run by typing in just a Test class or both a Test class and a Test method.

* Torun atest list, click Browse next to the Test file field and select a .vsmdi file (Visual Studio Test
Meta Data). Type a name in the Test list name field. You can constrain the run by typing in both a
Test class and a Test method.

7. Click Finish.

Note: To run MSTest on an execution server, a Visual Studio distribution or the Visual Studio Test
Agent have to be installed. Add the folder that contains MSTest . exe to your path variable and restart
the execution server. The default path is: C:\Program Files (x86)\Microsoft Visual
Studio <version>\Common7\IDE. Currently MSTest distributed with Microsoft Visual Studio/
Visual Studio Test Agent 2012, 2013, 2015 is supported.

NUnNit Tests

NUnit is a unit testing framework for the Microsoft .NET programming language.

Creating or Editing NUnit Tests

Note: We recommend that you add the .\bin folder of your NUnit installation to the system path.
Click Start > Control Panel > System > Advanced > Environment Variables to add a path like C:
\Program Files\NUnit 2.2\bin to the system environment variable PATH.

To create or edit an NUnit test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click | (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select NUnit Test from the Type list. Click Next.

The NUnit Test Properties dialog box appears.
6. Click Browse to locate and select the NUnit assembly from which you want to pull a test.
7. Type the working directory in the NUnit Directory field.
For NUnit 2, this directory is the local path to the file nunit-console.exe, such as C:\Program

Files\NUnit 2.2\bin. For NUnit 3, this directory is the full path to the file nunit3-console.exe,
such as C:\Program Files (x86)\NUnit.org\nunit-console\nunit3-console._exe.

8. In the NUnit Options field, type one or more NUnit console command-line options to specify how NUnit
tests are specified.

For example, to define that the Flex4TestApp NUnit test, located in Si lkTest_Ntf._Test.Flex,
should be executed, set the run option as follows:
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For NUnit 2:
/run:SilkTest.Ntf.Test.Flex.Flex4TestApp

For NUnit 3:
/test:SilkTest Ntf.Test.Flex.Flex4TestApp

Note: When you add multiple options, you have to separate the options by writing one option in
each line in the field.

9. Click Finish.

ProcessExecutor Tests
The ProcessExecutor test type can be used to execute any command line.

Creating or Editing ProcessExecutor Tests

To create or edit a ProcessExecutor test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click E| (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

5. If you are creating a new test, select ProcessExecutor Test from the Type list box. Click Next. The
ProcessExecutor Test Properties dialog box appears.

6. In the Executable Name field, type the fully qualified name of the executable.
7. In the Argument List field, type all arguments of the process executor test method.

i Note: Multiple arguments must be on separate lines in the field.

8. Set the Working Folder. This is the folder where the executable is executed.

9. If the executed command produces JUnit test result files, for example an Ant or Maven JUnit execution,
you can specify a folder pattern that is scanned for JUnit result xml files. The folder location is relative to
the working directory, for example test-results. The root folder where the search starts is the
Working Folder, in which all JUnit output files where the path contains the entered pattern are
retrieved.

During execution of the executable the following two environment variables can be used:

Environment Variable Description

SCTM_EXEC RESULTSFOLDER Allfiles in this folder are saved as result files in Silk Central. If an
output.xml file is created during execution in this directory, it is
processed by Silk Central.

SCTM_EXEC _SOURCESFOLDER This is the folder where all source files used during the execution are
located.

Example

The following example contains a ProcessExecutor test type that runs the Windows
Script Host from the command line with the /¢ switch and two parameters:



ProcessExecutor Test Properties bt

Inherit from parent

Executable Name: cmd.exe
Argurnent List: /e gscript parareadwrite js %5CTM EXEC_RESULTSFOLDER:
Working Folder: chwaorking

JUnit result directory test-results
pattern:

< Back Mext = Finizh Cancel

e /c - command that specifies that the command line should terminate after execution.

e cscript - Windows Script Host.

e parareadwrite. js - the jscript file named parareadwrite. js

e %SCTM_EXEC_RESULTSFOLDER% - the Silk Central variable that contains the
location of the Resul t folder on the execution server machine. Files stored in this
location are automatically uploaded to Silk Central and available in the Files tab of
the Test Run. In this example, the parareadwrite. js script produces an
output.xml file that is written to the Result folder and uploaded back to Silk
Central.

Silk Performer .NET Explorer Tests
The Silk Performer .NET Explorer test type is used to execute .NET Explorer scripts or a specific test case
of a script.

Creating or Editing Silk Performer .NET Explorer Tests

To create or edit a .NET Explorer test:

1.
2.

In the menu, click Tests > Details View .

Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click 4 (Edit).

The New Test/Edit Test dialog box appears.

Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

If you are creating a new test, select Silk Performer .NET Explorer Test from the Type list box. Click

Next.

The .NET Explorer Test Properties dialog box opens.

Browse to and select the .NET Explorer script to apply to the test.

The scriptis a -nef file.

Enter the path to the NetExplorer .exe executable on the execution server.

For example C:\Program Files\MyCustomSPFolder\DotNET Explorer\NetExplorer.exe.
You can also define an environment variable on your execution servers and refer it, for example $
{SP_HOME}\NetExplorer.exe.
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8. In the Test case field, type the name of the .NET Explorer test case to execute. If this field is left blank,
all test cases within the script are executed. It is not possible to specify multiple test cases.

f Note: The test cases InitTestCase and EndTestCase are always executed.

9. Click Finish.
Silk Performer Tests

Creating or Editing Silk Performer Tests

To create or edit a Silk Performer test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click 1 (New Child Test) on the toolbar, or click | (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Silk Performer Test from the Type list box. Click Next.

The Silk Performer Test Properties - Select Project dialog box appears.
6. Click Browse to select a Silk Performer project that has been saved to your file system and click Next.
7. Select one of the workload profiles that has been defined for the project from the Workload list.
8. Click Finish to create the test case.

Silk Test Classic Tests
Silk Central’s Silk Test Classic interface offers a reliable means of automating Silk Test Classic users. Each
test case of a Silk Test Classic script executes within its own test execution and produces its own results.

The Silk Test Classic Plan test type is used for Silk Test Classic test plans. A test plan usually is a
hierarchically-structured document that describes the test requirements and contains the statements, 4Test
scripts, and test cases that implement the test requirements.

When you observe running Silk Test Classic executions on the Activities page, the currently running
execution plan offers a hyperlink that opens a Details View. This view allows you to closely monitor the
state of the currently running execution plan. For Silk Test Classic test executions, the center component of
this view consists of two parts: The upper part shows general information about the test, script, test case,
and test data. The lower part shows all output messages generated by Silk Test Classic, along with their
severity.

In previous versions of Silk Central, Silk Test Classic invocation was implemented through a command-line
interface. The new interface works using interprocess communication. You can specify whether or not Silk
Central’s Silk Test Classic interface should be used by configuring test-container settings.

For all Silk Test Classic test parameters that are not defined through Silk Test Classic test properties in the
Silk Central GUI, the Silk Test Classic default settings are used, for example from partner.ini.

Creating or Editing Silk Test Classic Tests

To create or edit a Silk Test Classic test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.



Click I (New Child Test) on the toolbar, or click E| (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.

Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Silk Test Classic Test from the Type list box. To import multiple

Silk Test Classic test cases at the same time, select Silk Test Classic Multi-testcase import. Click
Next.

TheTest Properties - Select Test Script dialog box appears.

6. Click Browse and select the test script file from either the defined Silk Test Classic project or the source
control directory.

The test script, with file extension .t or .g.t, is defined relative to the test container’s root node in the
source control profile. For example /<Silk Test Classic project>/MyScript.t.

7. Click Next.
The Test Properties - Select Testcase dialog box appears.

Note: If the Silk Test Classic script is a data-driven .g. t file, for example
SilkTestScriptl.g.t, then data sources are completely controlled within the script file and
not through the data-driven properties of Silk Central. The Data-driven check box is checked by
default when you use a data-driven script file. For more information about data-driven Silk Test
Classic tests, refer to the Silk Test Classic documentation.

8. Select a test case from the available test cases in the defined script file or specify a custom test case.
When the custom test case field is already populated, the Silk Test Classic test was automatically
created, using the export functionality within Silk Test Classic. When you use the custom field to specify
the test case, you can terminate the test case name with a parenthesis "()". Inside the parenthesis, you
can specify test data, including parameters. Specifying data in the custom field will override the values
of the Test data property.

9. Optional: Type additional execution arguments into the Test data field.

These arguments are processed by Silk Test Classic during the execution of the test. If several
arguments are passed to Silk Test Classic, they have to be separated by a comma (,). If a String
argument is passed to Silk Test Classic, the argument must be set in quotation marks (). When test
data is more complex, we recommend that you use parameters in the test data, for example $
{ParameterName}. Parameters are replaced automatically within test executions.

f Note: This field has a maximum length of 2000 characters.

10.Define whether the test should provide a TrueLog.

;. Tip: When running your tests with the Open Agent, this setting must be turned on both in Silk
Central and in Silk Test, otherwise no TrueLog will be provided. Default execution mode for data-
driven tests is plan-based. When you use script-based execution mode for a data driven test,
change the DataDrivenScriptMode setting in the Silk Test Classic element of
SccExecServerBootConf.xml. For more information, refer to the Silk Test Classic
documentation.

11.1f required, specify an option set file. By default, Silk Central closes all open Silk Test Classic option set
files. To specify an option set file, specify the file name relative to the test container’s root node in the
source control profile.

12.Click Finish to create the Silk Test Classic test.

Note: If you possess Silk Test Classic test cases that require more than one hour to complete,
adjust the time-out settings for Silk Central. Otherwise, Silk Central assumes an error has occurred
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and terminates the execution. For details about time-out settings, see the Administration topics in
this Help.

Creating or Editing Silk Test Classic Plan Tests

To create or edit a Silk Test Classic plan test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click Ei| (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Silk Test Classic Plan from the Type list box. Click Next.

ThePlan Properties dialog box appears.
6. In the Plan file field, type the fully qualified name of the test plan file (. pIn) to be executed.
Click Browse to browse for the file.
7. In the Project file field, type the name of the Silk Test Classic project containing the file and
environmental settings.
Click Browse to browse for the project file.
8. In the Option set field, type the fully qualified name of the option set file containing environmental
settings.
Click Browse to browse for the option set file.
9. In the Data file for attributes and queries field, type the default path of the test plan initialization file.
Click Browse to browse for the test plan initialization file.
10.In the Test plan query name field, type the fully qualified name of the saved test plan query.
11.Click Finish.

To maintain the structure of your Silk Test Classic plan test in Silk Central, execute a trial run. Once the trial
run has completed successfully, the output.xml file is added to the result files of your execution plan run.
This allows you to convert your test to a test package, giving you full control over the test's structure.

Silk Test Workbench Tests

Silk Test Workbench is an automated testing tool that accelerates the functional testing of complex
applications. Silk Test Workbench provides support for testing applications developed in a wide variety of
development tools including Java, .NET, browser-based web applications, and COM components, including
both ActiveX controls and automation objects.

Prerequisites to Run STW.EXE with Silk Central

To run STW.EXE with a Silk Central execution server and to successfully connect to a Silk Test Workbench
database, the following prerequisites are required:

1. Run the Silk Central execution server as a process, and not as a service.

2. Use database authentication to connect to the Silk Test Workbench database. Silk Test Workbench can
use Windows authentication or database authentication when connecting to a Silk Test Workbench SQL
Server database.

3. Configure the database server instance to use a static port.

If these prerequisites are not met, Silk Test Workbench might return the following error when trying to run
STW.EXE with a Silk Central execution server:



Error 3: DSN, username, or password incorrect.

Creating or Editing Silk Test Workbench Tests

To create or edit a Silk Test Workbench test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click £ (Edit).

The New Test/Edit Test dialog box appears.
4. Type a hame and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Silk Test Workbench Test from the Type list box. Click Next.

The Silk Test Workbench Test Properties - Select Tests dialog box appears.
6. Select one or more scripts from the Silk Test Workbench Test list box.
7. In the Playback Options field, type in the name of a predefined Silk Test Workbench playback option or
leave the default value of System Defaults.
Note: A playback option must be set for a Silk Test Workbench test. The delete option on a Silk
Test Workbench test will reset the playback option to the default value of System Defaults.

8. Click Finish.

Opening Silk Test Workbench in the Context of the Result File

In the menu, click Execution Planning.
Select your execution plan.
Click the Runs tab.

In the Test Runs grid at the bottom, click the Run ID of the test for which you want to see details. The
Test Run Results dialog box opens.

Click the Files tab.
6. Click the result.stwx file to open Silk Test Workbench in context of the result file.

oD R

o

Note: Silk Test Workbench must be installed on the machine on which you are trying to open the
file.

Viewing the Execution Result Files for a Visual Test

In the menu, click Execution Planning.
Select your execution plan.
Click the Runs tab.

In the Last Executions area, click the Run ID of the relevant execution plan to view test-execution
results.

5. The Actions column displays all icons and links for Silk Test Workbench:

A wnh e

e detail.htm - Silk Test Workbench detailed steps file.
e result_stwx - Click to open the result in Silk Test Workbench .
e error.png - Click to go to a screen shot of the last error.
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Test Parameters Page - Silk Test Workbench

Tests > Details View > <Test Element> > Data Set

When passing parameters from a Silk Central test to a Silk Test Workbench test, these parameters must be
defined as input parameters in the Silk Test Workbench script and they must have the same name in Silk
Central as in the script. The following data types should be used:

Silk Central Silk Test Workbench
String Text

Number Number (Long)
Number Number (Long Long)
Number Enumeration

Float Number (Double)
Boolean Boolean (True/False)

Silk TestPartner Tests

TestPartner is a Micro Focus product that tests Web- and Microsoft Windows-based applications that use
Microsoft technologies.

Creating or Editing Silk TestPartner Tests

To create or edit a TestPartner test:

1.
2.

In the menu, click Tests > Details View .

Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click (New Child Test) on the toolbar, or click 4 (Edit).

The New Test/Edit Test dialog box appears.

Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.

If you are creating a new test, select Silk TestPartner Test from the Type list box. Click Next.

The Test Properties - Select Test Script dialog box appears.

Click Browse.

The Choose File dialog box opens. The assets available in this dialog box are based on the Project
Path defined in the associated TestPartner source control profile.

Select a script from the list and click OK.

y Note: To add multiple TestPartner tests, see Adding Multiple TestPartner Tests.

In the Playback Options field, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.

Click Finish.

Adding Multiple TestPartner Tests

To add multiple TestPartner tests, you must first follow the steps described in Creating Silk TestPartner
Tests.

To add multiple TestPartner tests:



1. On the New Test dialog box, select TestPartner Test from the Type list box.
2. Click Next. The Test Properties - Select Test Script dialog box opens.
3. Click Browse.
The Choose File dialog box opens. The assets available in this dialog box are based on the Project
Path defined in the associated TestPartner source control profile.
4. In the Playback Options field, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.
Note: The import gives the defined playback option to all imported scripts. If you need to change
the playback option for any scripts, edit the test after the import.
5. Click Next.

The Test Properties - Select Scripts dialog box opens.
6. Inthe TestPartner Scripts field, select the scripts to import by clicking Ctrl+Click.
7. Click Finish.

Windows Script Host Tests

Windows Script Host (WSH) is part of the Windows platform and creates an environment for hosting
scripts. When a script is to be run at the execution server, WSH plays the role of host. It makes objects and
services available for the script and provides a set of guidelines within which the script is executed. Among
other things, WSH manages security and invokes the appropriate script engine.

Creating or Editing Windows Script Host (WSH) Tests

To create or edit a WSH test:

1. In the menu, click Tests > Details View .

2. Select a container or folder node in the Tests tree where you want to insert a new test, or select the test
that you want to edit.

Click I (New Child Test) on the toolbar, or click E| (Edit).

The New Test/Edit Test dialog box appears.
4. Type a name and description for the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
5. If you are creating a new test, select Windows Script Host Test from the Type list box. Click Next.

The Windows Scripting Test Properties dialog box appears.
6. Click Browse and select a Windows scripting test script.
7. Specify the location of any required additional parameters in the Switches field.
Note: You may add other switches to be passed to the script. For more details on the switches that
can be used, see WSH Test Properties and refer to the MS Scripting Host documentation.
8. Click Finish.

Supported Script Languages

WSH is language-independent for WSH-compliant scripting engines. Natively, the Windows platform
supports Visual Basic Scripts, with file extension .vbs, and scripts written in the Java Script language, with
file extension . js.

For other scripting languages, a dedicated script interpreter must be installed on the execution server. For
example, if you install a Perl interpreter on an execution server, this will register a Perl scripting engine at
the WSH environment for the extension . pls. Whenever a file with extension .pls is passed to the WSH
tool, with the executable cscript.exe, it will invoke the appropriate interpreter because of the file
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extension. So the client of WSH, in this case the Silk Central Execution Server, does not need to know
about the installation of the Perl interpreter.

Note: After installing a script interpreter, for example Active Perl, try to execute a script locally on the
execution server by calling the WSH command line tool with a sample script before executing the
script in Silk Central. To do so, open a command shell on the execution server and type cscript
<somescript>, where <somescript> is the path to a script of your choice that is available on your
execution server. This is exactly what Silk Central will call when executing a WSH test on an execution
server. If the script is executed, then the scripting engine has been registered successfully.

The following scripting languages are WSH compatible:

Scripting Language File Extension
Perl -pls

Python -py, -pyw
REXX -REXX

TCL -tcl

WSH Test Properties

Property Description

Script You can define any file where a script engine is registered for the script language the file
contains. Script files under source control are deployed automatically to execution servers,
comparable to test sources for other test types.

Switches You can enter and pass the following settings to cscript.exe during the execution of the
test:
1IB Batch mode suppresses all non-command-line console Ul requests from the

script. We recommended that you use this option to prevent a script from
waiting for user input during unattended executions at the execution server.

/U We recommend to that you use unicode for redirected 1/O from the console.

/IT:nn Time-out, in seconds. The maximum time the script can run, by default = no
limit. This option is used to prevent excessive execution of scripts. It sets a
timer. When execution time exceeds the specified value, Cscript interrupts
the script engine using the 1ActiveScript:: InterruptThread
method and terminates the process. There is a callback hook. If the time-out
is invoked, the ONnTimeOut function is called to permit cleanup. Although it
is possible to create infinite loops using this feature, it is more useful than
harmful.

/llogo Displays an execution banner at execution time that is visible at the
beginning of the 10g . txt log file. This is the default setting.

/Inologo Prevents display of the execution banner at execution time.
1D Enables active debugging.

/IE:engine Use the engine to execute a script.

/1Job:xxxx Execute a WSF job.

11X Execute the script in debugger.

Using Parameters in WSH Tests

Parameters that are defined for a WSH test automatically add a name and value pair to the command line
as an additional argument and set the parameters as environment variables for the called process. This
functionality allows you to access all parameters defined for your test within the WSH script.



For example a WSH test is defined with myscript. js as script and //B as switch. Additionally the test
requires a parameter called 1PAddress with the value 192.168.1.5 and another parameter called Port
with the value 1492. The resulting command line for the WSH execution in this example is:

csript myscript.js //B 1PAddress=192.168.1.5 Port=1492

Viewing Information Returned from WSH

To collect results of a WSH execution, the WSH script must generate a file called output.xml in the
current working directory of the WSH test. All files residing in this directory are stored in the database and
are downloadable through the list of files for the test execution. Files are excluded from storage when their
extensions are defined under the file extensions to ignore in results property in the Projects area.

Note: The current working directory is dynamically created for each WSH execution. Do not use an
absolute path when creating the file. Any relative path used will correctly refer to the current working
directory.

Any information that a script writes to the WSH standard output goes into the 1og.txt text file that resides
in the current working directory. This file is stored in the database and can be viewed as it is included in the
file list of the test execution.

The following example shows how to print log information from a script:

WScript.Echo "This info will be written to the log.-txt file"

The XML structure of output.xml begins with an element ResultElement that defines an attribute named
Testltem, which specifies the name of the ResultElement.

The ResultElement must contain an element named ErrorCount, optionally an element named
WarningCount, and a list of Incident elements.

The ErrorCount and WarningCount elements must contain a positive number or zero. The ErrorCount and
WarningCount of the top-level ResultElement are used for evaluating success conditions, which determine
if a test has passed or failed. The XML file might contain additional elements that are not visible in the Silk
Central GUI. The output.xml file is however stored in the database and is viewable as it is included in
the file list of the executed test.

The Incident element represents an event that happened during the execution of the WSH test. Message
and Severity are shown in the messages list of test executions in the Silk Central GUI. An Incident element
must contain a Message and a Severity element.

The Severity element must hold one of the following values:

e Info

*  Warning

« Error (or Exception)
* Failure

You can store additional information in the result file. The ResultElement may contain any number of sub-
ResultElements, so information can be easily grouped. Sub-ResultElements make the result file easier to
read. For compatibility reasons related to unit tests, JUnit and NUnit, ResultElement can be named
TestSuite or Test.

The ResultElement may contain the following additional elements:

« FailureCount, which is treated the same way as error count
¢ RunCount, if a test is run multiple times

e Timer, for example for the duration of the test

* WasSuccess, for compatibility with NUnit result files

» Asserts, for compatibility with NUnit result files

The Incident element may contain a list of Detail elements.
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The Detail element represents detailed information about an Incident. It must define a TestName element
and an Info element. The TestName is used to give detailed information about where the Incident
happened. The Info element holds detailed information about the Incident, for example a stack trace.

Note: Up through Silk Central 8.1, the value of the Message and Info elements had to be URL
encoded (ISO-8859-1). Since version 8.1.1, URL encoding is no longer allowed.

Sample Result File

<ResultElement Testltem="WshOutputTest">
<ErrorCount>1</ErrorCount>
<WarningCount>1</WarningCount>
<Incident>
<Message>some unexpected result</Message>
<Severity>Error</Severity>
<Detail>
<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
<Incident>
<Message>some warning message</Message>
<Severity>Warning</Severity>
<Detail>
<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
</ResultElement>

Java Script Sample

The following script was used to generate the sample result file. To try this script save it
with the extension _ js.

function dumpOutput(dumpFile)

dumpFile.WriteLine(''<ResultElement Testltem=\""WshOutputTest
\ll>ll ;
dumpFile . WriteLine("™ <ErrorCount>1</ErrorCount>");
dumpFile.WriteLine("® <WarningCount>1</WarningCount>'");
dumpFile WriteLine("™ <Incident>");

dumpFile.WriteLine(" <Message>some unexpected result</
Message>"");

dumpFile.WriteLine(" <Severity>Error</Severity>");

dumpFile_WriteLine(" <Detail>");

dumpFile._WriteLine(" <TestName>function main()</
TestName>'");

dumpFile_WriteLine(™ <Info>some additional info; eg.
stacktrace</Info>");

dumpFile.WriteLine(" </Detail>");

dumpFile._WriteLine(" </Incident>");
dumpFile WriteLine(" <Incident>");

dumpFile.WriteLine(" <Message>some warning message</
Message>'");

dumpFile_WriteLine(" <Severity>Warning</Severity>");

dumpFile.WriteLine(" <Detail>");

dumpFile_WriteLine(" <TestName>function main()</
TestName>');

dumpFile_WriteLine(™ <Info>some additional info; eg.

stacktrace</Info>");
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dumpFile._WriteLine(" </Detail>");
dumpFile_WriteLine(" </Incident>");
dumpFile_WriteLine('</ResultElement>"");

}

function main()
{
var outFile;
var fso;
fso = WScript.CreateObject("'Scripting.FileSystemObject');
outFile = fso.CreateTextFile("output.xml', true, true);
outFile._WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\""?
>'l ?
dumpOutput(outFile);
outFile.Close();
WScript.Echo("'Test is completed™);
}

main();
WScript.Quit(0);

Visual Basic Script Sample

The following Visual Basic script also generates the sample result file, and saves it as
Output.xml. To try this script save it with the extension .vbs.

WScript.Echo "'starting”

Dim outFile
Dim errCnt
Dim warningCnt

outFile = "output.xml"
errCnt = 1 " retrieve that from your test results
warningCnt = 1 " retrieve that from your test results

Set FSO = CreateObject("Scripting.FileSystemObject')
Set oTX FSO.OpenTextFile(outFile, 2, True, -1) " args: file,
8=append/2=overwrite, create, ASCII

oTX.WriteLine("'<?xml version=""1.0"" encoding="""UTF-16"""?>"")
oTX.WriteLine("'<ResultElement Testltem=""PerlTest"">"
oTX.WriteLine(™ <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine(™ <WarningCount>" & warningCnt & "</
WarningCount>"")

oTX.WriteLine(" <Incident>")

oTX.WriteLine(" <Message>some unexpected result</Message>"")
oTX.WriteLine(" <Severity>Error</Severity>")
oTX_WriteLine(" <Detail>")

oTX.WriteLine(" <TestName>function main()</TestName>")
oTX.WriteLine(" <Info>some additional info; eg.
stacktrace</Info>")

oTX.WriteLine(" </Detail>")

oTX_WriteLine(™ </Incident>")
oTX._WriteLine(" <Incident>")

oTX.WriteLine(" <Message>some warning message</Message>'")
oTX.WriteLine(" <Severity>Warning</Severity>")
oTX.WriteLine(" <Detail>")

oTX.WriteLine(" <TestName>function main()</TestName>'")
oTX_WriteLine(" <Info>some additional info; eg.

stacktrace</Info>")
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oTX.WriteLine(" </Detail>")
oTX_WriteLine(™ </Incident>")
oTX_WriteLine('</ResultElement>"")

Shared Test Assets

Common test assets and their assigned requirements that are managed in a repository project can be
reused in destination projects.

If your project is configured to consume assets from a specific repository project (see Adding Projects), you
can reuse these assets by pasting them into the destination project.

Reusing Test Assets From Repository Projects
Maintain common test assets in a repository project and reuse them in your consuming projects.

If your project is configured to consume assets from a specific repository project (see Adding Projects), you
can reuse these assets by pasting them into the destination project.

To reuse test assets from a repository project:

In the menu, click Projects > Project List.
Select the repository project.
In the menu, click Tests > Details View .

Click "3 to copy the element to the clipboard.
In the menu, click Projects > Project List.
Select the destination project.

Select the destination container and folder.
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Click . The test properties of the reused test display a link to the original test under Shared Test
Reference.

Note: Copying a test from a consuming project to the repository project also creates a link to the test
in the repository project, and makes that test available for reuse in other consuming projects. If you
copy a test multiple times, the link points to the last copy that was created.

When reusing test assets from a repository project, note the following:

« The consuming project must be configured to reuse assets from the repository project, otherwise the
copy and paste action has no reference to the original asset.

* You can only paste assets into an existing test container.

« To retain assigned requirements, the consuming project must have the same requirements system
configured as the repository project.

» Data-driven children, test package children, and linked test containers cannot be reused.

« Inherited test properties, parameters, and attributes are not considered in reused tests. Note that
accepting changes from the original asset can lead to properties, parameters, and attributes being
removed in reused tests if inheritance is being used.

» Assigned issues are not copied to reused tests.

« If you use test attributes, they must have the same name and type in both projects.

* When copying or baselining a project, the references to the repository project are retained. The
references are deleted when exporting a project though.

« The bulk export/update interface and the web services do not yet consider links to original assets.

* You can also copy and paste folders, including their complete hierarchy.

Maintaining Versions of Shared Tests

Maintaining common tests in a central repository project and reusing them in your consuming projects
saves you the time of maintaining test assets in multiple projects. Whenever a new version of a test is



created in the repository project, this test gets flagged as Updated (marked with blue arrow pointing up).

Right-click such a test in your consuming project and select Shared Test Changes > Accept Changes to

update the test to the latest version, or select Skip Changes to keep the current version and remove the
update flag. The test will get flagged again when a new version is created later in the repository project.

You may also face the scenario where you update a reused test within a consuming project, and you then

want to promote those changes to the original test asset in the repository project. To do so, click Push
Changes to Shared Test in the History tab of your test in the consuming project. This creates a new

version of your test in the consuming project, a restore point in the repository project's shared test, and a
new version of the shared test with your latest changes. Other projects that reuse this test will then receive

an update notification.

Editing Tests

To edit a test:

1. Inthe menu, click Tests > Details View .
2. Select the test or the test package that you want to edit.

3 Glick 1 (Edit) on the toolbar.

You can also click the Properties tab and click Edit or right-click the test or test package and select
Edit.
The Edit Test dialog box appears.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for
Description fields.
4. Edit the name and description of the selected test.

If the selected test is a test package, the Update Package Structure on Result check box is available.
Check the Update Package Structure on Result check box if you want to update the structure of the

test package according to the results of the test execution run.

5. Configure the properties of the test or the test package according to the test type as described in
Configuring Test Properties.

Printing Tests
To print tests:

In the menu, click Tests > Grid View .

Use Ctrl+Click or Shift+Click to select the tests that you want to print.

Right-click the selection and choose Print Test Details. The Test Details dialog box appears.
Click Print or Download as PDF.
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| Tip: You can also select tests or folders in the Tests tree and select Print Test Details.
id

Test Runs Page

Tests > Details View > <Test> > Runs

The Runs page is available on test nodes in Details View and offers a listing of test execution results for

the selected test.

The data grid representation of the Runs page facilitates the filtering, sorting, and grouping of large
numbers of test runs.

For each run, the page displays the following columns:
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Column

Description

Actions

Status

Status Reason

Run ID

Run Type

Start Time

Duration

Execution Plan

Executed By

Issues Found

Errors
Warnings
Version
Build

Execution Plan
Parent

Run Comment

Actions that you can perform on the test run.

New Issue Click to open the New Issue dialog box and create a new issue for

the test.

Assign Existing
Issues

Assign issues from an externally-configured issue-tracking system
to the test.

Status of the execution. For tests that are part of a running execution plan, the status is
updated in response to the current status of the test run. If the current run is aborted, the
status is reset to the status before the run.

The reason why a specific test run has the status Passed, Failed or Not Executed.

The ID of the test run. Click to open the Test Run Results dialog box. If the test is running,
click to view details of the execution.

The Run Type column shows the test type during each run. The test type might change
between two runs, for example when you convert the test from manual to automated.

Time the run started. If the test is a manual test and currently running, Silk Central adds
(Running) to the date and time.

Duration of the test run in h/mm/ss.

The name of the assigned execution plan, or Unassigned Tests if the execution was a
trial run or results were uploaded. Click to open the execution plan.

The execution server from which the test was run.

Displays the amount of issues that are assigned to the test run. When no issues are
assigned to the test run, the column is empty. Click on the link to access the issue in the
Issues page of Tests > Details View.

Number of errors that were generated during the run.
Number of warnings that were generated during the run.
Version that the test was run against.

Build number that the test was run against.

The configuration suite, folder, or testing cycle in the context of which the execution plan is
executed. Click to access the suite or folder in the Execution Plans tree. If the execution
plan is not included in a configuration suite or folder, nothing is displayed.

For Silk Performer test runs, Silk Performer uses this column to add information to the test
run when uploading results. For all other test types, you can use this column to add
information to the run.

To compare two or more test runs, use Ctrl or Shift to select runs. Right click on your selection and click
Compare Automated Test Results or Reports > Test Run Comparison .

Test Issues Page

Tests > Details View > <Test Element> > Issues

The Issues page enables you to enter and track issues related to the selected test, container, or folder.

New Issue

Click to assign new issues to the selected test. This button is only displayed if the
currently selected object is a test.




Assign Existing Click to assign issues from an external issue tracking system to the selected test.

Issues This button is only displayed if the currently selected object is a test.
Update Issue Click to update issues states.
States

For each issue, the page displays the following columns:

Column Description

Actions . . 4
Actions that can be performed on the issue. Click to

delete the issue. External issues will not be deleted.

Issue ID ID that has been automatically assigned to the issue.
Click to edit the issue.

Assigned Test Test that has been assigned to the issue. This column is
only displayed if the currently selected object is a
container or a folder.

Synopsis Synopsis of the issue.
Status Status of the issue.
External ID Indicates if the issue is tracked by an external issue

tracking system. Click an external issue number to link
directly to the external issue tracking system.

Priority The priority of the issue as defined in the external issue
tracking system. The following issue tracking systems
support this feature: Atlassian JIRA, Bugzilla, Silk Central
Issue Manager, and StarTeam.

Test Run The ID of the test run that the issue is assigned to. Click
on the ID to access the Details page of the Test Run
Results dialog box in the Executions area.

Created On When the issue was created.
Created By User who created the issue.
Profile Name of the issue tracking profile, as defined in Silk

Central > Settings > Issue Tracking .

Versions

Versions can be created for shared objects (steps and keywords) and tests. A version is a revision of an
element in a certain state. Data sets and inherited test properties, parameters, and attributes are not
included in test versions.

You can manually create versions of shared objects and tests, or revert to previous versions. All versions of
a shared object or a test are listed on the History page of the element. When you copy a project, the
versions are also copied. If you are working with shared tests, see also Maintaining Versions of Shared
Tests.

Creating a Version

To be able to revert a set of changes you want to apply to a shared object or a test, create a version of the
element.

To create a version of a shared object or a test:
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1. For a shared object, click Tests > Libraries in the menu. For a test, click Tests > Details View in the
menu.

2. Select the shared object in the Libraries tree, or the test in the Tests tree.

3. Click [ in the toolbar.
This action is only enabled if the shared object or the test was changed.
The Create Version dialog box appears.

4. Optional: Enter a comment on the version in the Comment field.

5. Click Ok. The new version is shown in the History page.

Viewing a Version

To see if a specific version of a shared object or a test applies to your testing needs, view the details of the
version.

To view the details of a version of a shared object or a test:

1. For a shared object, click Tests > Libraries in the menu. For a test, click Tests > Details View in the
menu.

Select the shared object in the Libraries tree, or the test in the Tests tree.
Click the History tab.

Right click on the version of which you want to see the details.

Click View version <ID>.

The View Version dialog box opens. If the version includes attachments, you can view the attachments
by clicking on their number in the Attachments column of the Steps section.
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i Note: Use the arrows to change the version number and view additional versions.

Comparing Versions
To view the differences between two versions of a shared object or a test, compare the versions.

To compare two versions of a shared object or a test:

1. For a shared object, click Tests > Libraries in the menu. For a test, click Tests > Details View in the
menu.

Select the shared object in the Libraries tree, or the test in the Tests tree.
Click the History tab.

Select the two versions you want to compare with Ctrl+Click.

Right click on the selection.

Select Compare Version <x> and <y>. The Compare Versions dialog box opens, displaying all the
added, changed, and removed content.

S

/ Note: Use the arrows to change the version numbers and compare additional versions.

Reverting to a Previous Version

To undo changes to a shared object or a test, revert to a previous version. Note the following special cases
when reverting to a previous version:

« If the value of an inherited attribute has changed compared to the current version, the most current
value is again inherited in the reverted version.

» If the type of an attribute has changed compared to the current version, the attribute is ignored in the
reverted version.
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« If the value of a list-type attribute no longer exists in the current version, the original value is added to
the attribute again and used in the reverted version.

To revert a shared object or a test to a previous version:

1. For a shared object, click Tests > Libraries in the menu. For a test, click Tests > Details View in the
menu.

Select the shared object in the Libraries tree, or the test in the Tests tree.

Click the History tab.

Right-click on the version to which you want to revert the shared object or test to.
Click Revert to Version <ID>.

The shared object or test is reverted to the selected version and a new version is created in the History
page. Attachments and data sets are not reverted for tests.
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Viewing Recent Changes
To view recent changes to tests:

1. In the menu, click Tests > Details View .

2. Click ‘& to filter out all test elements except those that have been changed since your last change
acknowledgement.

y Note: The recent changes filter is selected automatically in the Filter list box.

3. When you have reviewed the changes, you can accept them by clicking .
The acknowledge function resets the recent changes filter.

4. Click "4 again to remove filtering and see all tests.

f Note: All test changes generate time-stamped entries in the test history.

Tracking the History of a Test

Silk Central provides a complete history of all changes that are made to tests. History information is read-
only, and cannot be edited or permanently deleted.

To track a test element’s history:

1. In the menu, click Tests > Details View .
2. Select the test in the Tests tree.
3. Click the History tab.

The properties of the test are displayed in tabular format.

Test History Page
Tests > Details View > <Test Element> > History

The History page details the revision history of the selected test, test container, folder, or project. It also
includes an entry for every project baseline that includes the selected element, with links to the baseline
and the corresponding element in the baseline. If the selected element was created as part of a project
baseline, the first entry in the History page includes links to the original project and the corresponding
element in the original project. You can use the links only to access active projects or baselines. For more
information on project baselines, see the Administration topics in this Help.

The History page additionally includes an entry for each version of the selected test, and allows you to
create new versions, revert to a previous version, and view the changes between two selected versions.

For each change, the page displays the following columns:
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Column Description

Actions Only for version entries. The actions you can perform are
View Version, Revert to Version and Delete Version.

Version Only for version entries. The version of the test.

Comment A comment on the changes.

Created On Date and time of the change.

Created By User that made the change.

Note: When the page includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Use the navigation toolbar at the bottom of the
page to browse through the elements.

Configuring Test Properties

Configure test properties like attributes, parameters, attachments, and success conditions.

Test Properties

Tests > Details View > Properties

The Properties page offers detail on all properties and relevant information for the selected test, test
folder, test package, or test container. You have the option of expanding and collapsing the information in
each section on this page. This enables you to customize the information you see to your specific needs.
For test nodes, the following properties are configured when tests are created:

Property Description

1.
2.
3.
4.

Test Name  Name of the test.
Test ID Database identifier of the test.
Description Description of the test.
Note: Silk Central supports HTML formatting and cutting and pasting of HTML content for

Description fields.

Status For tests or test packages that are included in a configuration suite, the status is an aggregation of all
statuses of all configurations within the suite:

« If the test is assigned only to the configuration suite, the status is Passed only if it is passed in all
configurations. If the status is not Passed in all configurations, the status of the worst run is
propagated, with the following top-down priority:

N/A

Not Executed
Failed
Passed

The status of a requirement that is assigned to the test is Fai led if the test fails in one or more of
the configurations.

* We do not recommend assigning the test to a configuration suite and one or more simple
execution plans. However, in this case, the aggregate of the configuration statuses is one status,
and the last statuses of the execution plans are other statuses. The status that was executed last
determines the last status of the test.




Property Description

« If the test is assigned to a simple execution plan only, the status is updated in response to the
status of the last test run.

Last Last time this test was executed. For tests that are part of a running execution plan, the last execution
Execution is updated based on the current test run.

Assigned Lists all execution plans that the selected test is assigned to. For each execution plan in the list, the
Executions  grid displays the following columns:

Column Description
Execution Name of the execution plan. Click to view or edit the execution plan.
Status The status of the last run of the test in the execution plan. The status is Not

Executed, if the test was not executed in the last run of the execution plan. For
data-driven tests or test packages, the status of all last runs is displayed in a bar
graph.

Last Execution Last time the test was executed as part of the execution plan.

Execution Plan The configuration suite, folder, or testing cycle in the context of which the
Parent execution plan is executed. Click to access the suite or folder in the Execution
Plans tree. If the execution plan is not included in a configuration suite or folder,
nothing is displayed.
Created On Date and time the test was created.
Created By Name of the user who created the test.

Changed On Date and time the test was last changed.

Changed By Name of the user who last changed the test.

Planned Planned execution time of the test. Only for manual tests.

Time

[hh:mm]

Test Test properties that are specific to the test type.

Properties

Success All success conditions that have been configured for the test. For test package nodes, all success

Conditions  conditions except the execution time-out are disabled and hidden.

Integration  Shows the name of the default container or folder, where tests from external planning tools are
Default created. For detailed information, see Setting a Test Node as Integration Default for External Agile
Folder Planning Tools.

Test Attributes

Attributes are freely definable characteristics that can be applied to tests. You can filter the Tests area for
the tests with a specific attribute and assign all such tests to execution plans. Examples include a platform
attribute that can be applied to product components and a priority attribute that can be applied to tests.

Note: Inheritance of attributes is similar to inheritance of properties and success conditions. Attributes
that are assigned to a parent node are inherited throughout all sub-folders and child tests.

Assigning Attributes to Tests

To assign an attribute to a test:

1. In the menu, click Tests > Details View .
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5.

Select the test to which you want to assign an attribute.
In the Attributes section, click Add Attribute. The Add Attributes dialog box appears.

Click =r in the Add column of the attribute that you want to assign. Based on the attribute type you
have selected, an Edit Attribute dialog box appears, where you can specify which of the available
attribute values you want to assign to the test.

Select an attribute value and click OK to assign the attribute to the test.

Editing Test Attributes

To edit a test attribute:

1.
2.
3.

4.

In the menu, click Tests > Details View .
Select the test for which you want to edit an assigned attribute.

In the Attributes section, click the Edit icon of the attribute you want to edit. The Edit Attribute dialog
box displays. The available options in the Edit Attribute dialog box vary depending on the attribute type
that you have selected.

Select the required value and click OK to save your settings.

Deleting Attributes from Tests

To delete an attribute from a test:

1.
2.
3.

4.

In the menu, click Tests > Details View .
Select the test from which you want to delete an assigned attribute.

In the Attributes section, click the Delete icon of the attribute you want to delete. The Delete Attribute
confirmation dialog box displays.

Click Yes to delete the attribute.
f Note: Inherited attributes cannot be deleted.

Test Parameters

Parameters are freely configurable input values that can be assigned to different test types and used in a
variety of ways. They help to define tests by defining test data.

Test parameters that are contained within a property of a test, for example test-data for Silk Test Classic
tests, are listed at the top. Unused parameters are appended to the bottom of the list and grayed out,
analogous to a disabled state.

Silk Performer These tests use predefined parameters that represent the project attributes that are

defined in a selected Silk Performer test.

JUnit, Silk4J Any JUnit and Silk4J test class can access a custom parameter of the underlying test

as a Java system property; the launcher passes these parameters to the executing
virtual machine using the -D VM argument. Within the test the values of the parameter
can be accessed using System.getProperty(''myParam™).

NUnit, For NUnit and Silk4NET each parameter will be set as an environment variable. Within

SilkANET the test the value of the parameter can be accessed using
Environment.GetEnvironmentVariable("'myParam').

Silk Test Parameters can be passed to Silk Test Classic by specifying them in the Test Data field

Classic in the Test Properties of the Silk Test Classic test in Silk Central. For example, if you

want to pass the values of your Silk Central parameters Name and Password to Silk
Test Classic, specify "${Name}", "${Password}" in the Test Data field in the Test
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Properties. Your Silk Test Classic script also requires two parameters, which will
receive the specified values.

Example:

[-] testcase ProcessParams(STRING name, STRING password)
[ 1 Print(name)
[ 1 Print(password)

For any test type where the execution takes place in an external process (WSH,
Process Executor, NUnit, JUnit, MSTest, DotNetExplorer), each parameter will be set as
an environment variable for the process. This is also the case if the parameter name
matches the name of an operating system variable, so that the value of the system
variable will be replaced by the parameter value, except when the parameter value is an
empty string.

The parameter needs to be defined with the same name in the Silk Test Workbench
test, to be set when being executed in Silk Central.

You can override the test parameters in an execution plan. For additional information,
see Execution Plan Parameters.

For details on custom test types, refer to the Silk Central API Help.

Predefined Parameters
Silk Central provides information on execution plan run properties during test executions as parameters.

These parameters can be read by your test automation tool as environment variables (see Test
Parameters). Additionally, any JUnit test class can access a test parameter of the underlying test as a Java
system property (see Accessing Silk Central Parameters through Java System Properties). Use the
AttributeGet methods to read these parameters in a Silk Performer script.

These parameter values can also be referenced in placeholders, as described in Parameter-Token
Replacement Upon Execution.

The following predefined parameters can be accessed:

Parameter Description

#sctm_execdef_name The name of the execution plan that is currently executed. If
the execution was triggered from the Tests area, the
parameter has the