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Introduction

€ Who Should Read This Guide
& Related Publications

¢ World Wide Web Information
¢ Cetting Help

Who Should Read This Guide

This guide is intended for administrators who are installing or Configur-
ing TestPartner; it does not contain reference or usage information. You
can find that information in your product’s online help facility and
documentation set.

Compuware assumes that you are familiar with basic Microsoft Windows
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Related Publications

The TestPartner installation documentation set includes:

¢ The TestPartner Installation and Configuration Guide, which contains
system requirements and instructions for installing TestPartner.

¢ The License Installation Guide, which contains instructions for licens-
ing your QACenter product.

All of these books are provided in PDF format only. You can access the
online versions of these books from the installation bookshelf (as
described below) or from Compuware’s FrontLine customer support Web
site at http://frontline.compuware.com


http://frontline.compuware.com

Viewing and Printing Online Books
To access these online books:

1 Insert the QACenter CD into the CD-ROM drive. If the CD browser
does not automatically start, navigate to the CD’s root directory and
run setup.exe.

2 Click View QACenter Documentation. The documentation book-
shelf opens in Acrobat Reader. (If necessary, Acrobat Reader can be
installed from the QACenter CD by clicking Install 3rd Party Soft-
ware, then clicking Install Adobe Acrobat Reader.)

3 From the bookshelf, select the installation guide that you wish to
view.

Because PDF is based on PostScript, a PostScript printer is the most
reliable way to print online books. In most cases, you can also print .pdf
files to PCL printers. If you cannot print the .pdf files to your printer,
refer to Adobe’s Web site at http://www.adobe.com for troubleshooting
information.

World Wide Web Information

To access Compuware Corporation’s site on the World Wide Web, point
your browser at http://www.compuware.com. The Compuware site
provides a variety of product and support information.

FrontLine Support Web Site: You can access online customer support for
Compuware products via the FrontLine support web site. FrontLine
provides fast access to critical information about your QACenter product.
You can read or download documentation, frequently asked questions,
and product fixes, or e-mail your questions or comments. To access
FrontLine, follow these steps:

1 Open a web browser and go to: http://frontline.compuware.com
The Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and
click the Login button.
Note: If you are a first-time visitor, click the Register button to receive your
free password to access FrontLine. After you complete the registra-

tion form, your login ID and password will be e-mailed to you and
your account will be activated.
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Getting Help

3

From the drop-down list in the center of the page, select a product

and click the Go button. You will see the product’s FrontLine home
page, where you can access documentation, technical information,
fixes, and other support items.

At Compuware, we strive to make our products and documentation the
best in the industry. Feedback from our customers helps us maintain our
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support
hotline:

2

The name, release (version), and build number of the QACenter prod
uct. This information is displayed when you select the About com-
mand from your product’s Help menu. The name and release are also
on the covers of the product documentation.

Installation information, including installed options, whether the
product uses local or network databases, whether it is installed in the
default directories, whether it is a standalone or network installation,
and whether it is a client or server installation.

Environment information, such as the operating system and release
on which the product is installed, memory, hardware/network speci-
fications, and the names and releases of other applications that were
running.

The location of the problem in the QACenter product software, and
the actions taken before the problem occurred.

The exact product error message, if any.

The exact application, licensing, or operating system error messages,
if any.

Your Compuware client, office, or site number, if available
Compuware Customer support

Compuware Corporation
One Campus Martius
Detroit MI 48226-5099
1-800-538-7822

Introduction 7
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Chapter 1

Getting Started

¢ Overview of QACenter
& |Installation Types
& Before Installation

Overview of QACenter

QACenter is a suite of automated software quality products for enterprise
and e-business applications. QACenter offers a comprehensive solution
for IT organizations concerned with assuring quality and performance,
while keeping pace with faster development cycles. QACenter includes:

Compuware Central: An HTML-based component that provides a Web
framework for managing and performing testing efforts from the begin-
ning to the end of a project. Compuware Central supports a complete,
seamless testing process from requirements management to test execu-
tion to results analysis and defect tracking. Because it is Web-based,
Compuware Central supports remote testing for those organizations
whose testing and development teams are not in the same geographic
location. Compuware Central’s flexibility allows small to large compa-
nies to customize it according to their needs.

QADirector: Coordinates the entire testing process by organizing, track-
ing, and executing automated and manual tests. QADirector integrates
with Compuware’s testing, program analysis, defect tracking, and
requirements management tools.

QAHiperstation+: Works with mainframe QAHiperstation to test host-
based applications directly from your Windows desktop. This integrated,
workstation-based interface tool uses 32-bit code that provides improved
performance and better stability on 32-bit Windows platforms.



QARun: Tests enterprise client/server applications. QARun creates and
runs test scripts that support a wide variety of development tools and the
diverse components of today's corporate environments. QARun couples
advanced verification facilities with error-recovery mechanisms to
reliably test local and remote applications.

Reconcile: Helps create and control project requirements. It stores the
project requirements in a relational database. You can view the require-
ments through Microsoft Word, a reporting view (grid), and the Web.
Reconcile is fully integrated with QADirector and TrackRecord. Working
together, these products help you manage project development from
conception through delivery.

TestPartner: Tests Web- and Windows-based applications that use
Microsoft technologies. You can record user sessions with the applica-
tion, add validation functions, and replay the sessions later to ensure
that the application works as expected. TestPartner’s scripting language is
Visual Basic for Applications (VBA); it supports testing of Java, Visual
Basic, and Visual C++ applications; browser-based Web applications; and
COM components including both ActiveX controls and automation
objects.

TrackRecord: Records and reports information about products being
developed or supported. Information on team members, testers, sched-
ules, and defect reports is recorded in an object-oriented database; it can
be retrieved using TrackRecord's query and reporting features.

WebCheck: Checks the quality of even the largest web sites. WebCheck
automatically scans a web site for more than 50 potential types of
problems and provides 19 HTML reports. WebCheck is integrated with
QARun and QADirector and can be used as a stand-alone product.

In addition to the QACenter suite of products, the QACenter CD includes
Adobe Acrobat Reader, Microsoft Internet Explorer, Java 2 Runtime
Environment, and Microsoft Virtual Machine installation programs. To
install one or more of these products from the QACenter CD, click Install
3rd Party Software, then click on the product installation you would
like to perform.

Installation Types

10

Before you begin, determine the type of installation you need to perform:

Initial Installation: An initial installation is the first-time installation of a
product on your computer. See the installation chapter for each product
for instructions.
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Modify: A modification of the product installation occurs when you add
or remove one or more of a product’s components, but not all of them.
See the maintenance chapter for instructions.

Repair: A repair installation may be necessary due to a corruption of a
program or the inadvertent deletion of the product. See the maintenance
chapter for instructions.

Remove: A remove or uninstallation removes all the components of a
product. See the maintenance chapter for instructions.

Upgrade: Normally, an upgrade to a new release of a product does not
require that you uninstall the current release first. Special concerns
regarding TestPartner upgrades are explained in Chapter 3, “Maintaining
the Installation”.

Before Installation

To access the Release
Notes from the
QACenter CD, follow
these steps:

Before installing any QACenter product, you should carefully review the
following information:

System Requirements

Review the system requirements to ensure that you meet the prerequi-
sites for the successful installation and operation of the product. System
requirements are listed in the Release Notes as well as in this book.

Release Notes

Review the Release Notes for information about new features, technical
notes, and known issues that may enhance or impact your product’s
performance. Release Notes contain recent changes that may not be
included in your QACenter product documentation.

Release Notes can be viewed from the QACenter CD or on FrontLine,
Compuware’s product support web site. The Release Notes on FrontLine
are periodically updated as new information becomes available.

1 Insert the QACenter CD into the CD-ROM drive. If the CD browser
does not start automatically, navigate to the CD’s root directory and
run setup.exe.

2 Click View QACenter Release Notes. The Release Notes open in your
default web browser.

3 Read the Release Notes online, or print the document.
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4 After reading and/or printing the Release Notes, close the document
to return to the CD browser.

To access the Release 1T Open a web browser and go to: http://frontline.compuware.com
Notes on FrontLine, The Welcome to FrontLine page appears.

follow these steps: 2 On the right side of the page, enter your login ID and password and

click the Login button.

Note: If you are a first-time visitor, click the Register button to receive your
free password to access FrontLine. After you complete the registra-
tion form, your login ID and password will be e-mailed to you and
your account will be activated.

3 From the drop-down list in the center of the page, select a product
and click the Go button. You will see the product’s FrontLine home

page.

4 On the left side of the product’s homepage, select the Documenta-
tion link. You will see the product’s documentation page, which
includes links to Release Notes and other documentation types.

5 Click the HTML or PDF icons to view documents.
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Chapter 2
Installing TestPartner

System Requirements

Installing TestPartner

Setting Up a SQL Server or MSDE Database with TestPartner
Setting Up an Oracle Database with TestPartner

L 2K R 2R N 2

Setting Up SQL Server or Oracle for TestPartner without a
Domain

*

Creating a Data Source Name

& Migrating TestPartner Objects from a Standard Character Set
to UTF8 (for Unicode)

System Requirements

TestPartner has the following minimum system requirements:
For English:

¢ Microsoft Windows XP Professional with Service Pack 1a and Service
Pack 2, Windows 2000 with Service Pack 1, 2, 3, or 4, or Windows
Server 2003 (formerly named .NET server 2003) including Standard
Edition (32 bit) and Enterprise Edition (32 bit).

For Japanese:

¢ Microsoft Windows XP Professional with Service Pack 1a and Service
Pack 2, Windows 2000 with Service Pack 3 or 4, or Windows Server
2003 (formerly named .NET server 2003) including Standard Edition
(32 bit) and Enterprise Edition (32 bit).

13



For Korean, Simplified Chinese, and Traditional Chinese:

¢ Microsoft Windows XP Professional with Service Pack 1a and Service
Pack 2, Windows 2000 with Service Pack 4, or Windows Server 2003
(formerly named .NET server 2003) including Standard Edition (32
bit) and Enterprise Edition (32 bit).

Mid-level Pentium III PC with 256 MB of RAM.
200 MB of available disk space.
800 x 600 or higher screen resolution.

Microsoft Visual Basic for Applications (VBA) 6.2 (6.0.8714), 6.2x
(6.0.8967), 6.3 (6.0.9108), or 6.4 (6.4.9969, 6.4.9971, or 6.4.9972).
TestPartner installs VBA 6.2 (6.0.8714).

¢ Microsoft Internet Explorer 5.01 (build 5.00.2919.6307) or later. You
can install Internet Explorer 5.01 from the QACenter CD.

* 6 o o

¢ Microsoft SQL Server v2000, Oracle v9.0.1 or 8.1.7 database on a
Microsoft platform. For SQL Server v2000, MDAC 2.6 SP2
(2.62.7400.1) is required for establishing an ODBC connection.
Microsoft MSDE database can be used for up to 5 users. TestPartner
also supports Microsoft Access 2000 as a single-user database.

¢ Adobe Acrobat or Acrobat Reader (provided on the QACenter CD) to
view the online books in PDF format.

¢ Additional resources may be required for testing tools and the appli-
cation under test.

Input Method Editor (IME) Support
TestPartner supports the following IMEs for the listed input systems.

Legend X = Supported

Japanese Input

System:
- Windows Windows Windows
DEsaipLet) 2000 XP 2003
MS-IME2000 imejp.ime X X X
MS-IME2002 imjp81.ime X X
MS-IME2003 imjp9.ime X X
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Korean Input System:

Simplified Chinese
Input System:

Traditional Chinese
Input System:

Description Wizn(;jo%ws Win)zjrf)ws Wizn(;jo%ws
MS-IME98 imekr98u.ime X

IME 2002 imekr61.ime X X

IME 2003 imekr.ime X X

Description Wizn(;alo%ws Win)g:)ws Wizn(;alo%ws
QuanPin winpy.ime X X X
MS-PinYin98 pintignt.ime X X

MS-PinYin 3.0 pintlgnt.ime X X
NeiMa wingb.ime X X

ZhengMa winzm.ime X X X
ShuangPin winsp.ime X X X
WuBi86 winwb86.ime X* X* X*
WuBi98 winwb98.ime X* X* X*
Enhanced Unicode  surime.ime X* X*

* Only appears with Windows XP and Windows Server 2003 with Office
XP Multilingual Support complete install.

Description

Windows
2003

Windows Windows
2000 XP

Alphanumeric romanime.ime X X X
Unicode unicdime.ime X X X
Quick quick.ime X X X
Phonetic phon.ime X X X
New Phonetic tintlgnt.ime X X X
New Changlie cintlgnt.ime X X X

Chapter 2 @ Installing TestPartner
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Windows Windows Windows

Description 2000 XP 2003
DaYi dayi.ime X X X
Changlie chajie.ime X X X
Big5 Code winime.ime X X X
Array winar30.ime X X X

Notes: IMEs not listed above are not supported.

Text Services FrameWork (TSF) and the Rich Edit control (version 4.1)
are not supported for recording. This does not affect playback.

Office 2003 IMEs are only supported for the Japanese Input System.

Installing TestPartner
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This section explains the installation process for TestPartner. Please
review “System Requirements” on page 13 to ensure that TestPartner will
install and operate properly on your computer.

Before proceeding with the TestPartner installation, Compuware recom-
mends that you review the TestPartner Release Notes which includes
information about new features, technical notes, and known issues. The
Release Notes also document recent changes that might not be included
in TestPartner documentation. Please review this information carefully;
the Release Notes document is updated as new product information
becomes available. To review the Release Notes prior to installation, refer
to the “Before Installation” section of the “Getting Started” chapter.

Required: Compuware recommends that you exit all non-essential Windows
programs before running this setup program. Some Windows
programs may interfere with the installation process.

If TestPartner version 5.0.4 or earlier is installed on your computer,
or if you have any beta version installed, Compuware recommends
that you back up your data and uninstall TestPartner before install-
ing the new version. Failure to do so may cause problems.

TestPartner Installation and Configuration Guide



To install TestPartner, follow these steps:

1

10

If you are installing TestPartner on Windows NT, Windows 2000, or
Windows XP Professional, log on as a user with administrator permis-
sions (user must have full administrator permissions in order to both
install and use TestPartner).

Insert the Compuware CD into the CD-ROM drive. The CD browser
should automatically appear. If it does not, open the Run option
from the Start menu. Click the Browse button to navigate to the
setup.exe file on the CD-ROM disk.

Click Install QACenter Products.

Click Install TestPartner. The Choose Setup Language dialog box
appears.

Select the language for which you want TestPartner installed from the
list and click Next.

An installation setup screen appears, then the Welcome dialog box
appears.

Read the welcome screen and click Next. The License Agreement dia-
log box appears.

Read the license agreement and click Yes to accept the terms of the
agreement. The Customer Information dialog box appears.

Type your name and company in the User Name and Company
Name fields. Click Next. The Choose Destination Location dialog
box appears.

Select a location for the TestPartner installation.

¢ By default, TestPartner installs in the folder x:\Program
Files\Compuware\TestPartner where x is the drive where Win-
dows resides on your computer.

¢ To specify a different path, click the Browse button and select an
existing folder or type the path name in the Path field. Click OK.

Click Next. The Select Components dialog box appears. This dialog
box allows you to select or clear components for installation. High-
light a component to view a brief description.

Chapter 2 @ Installing TestPartner 17



11 Select the components you want to install:

¢ Active Object Recognition: Lets you define support for Java con-
trols that may not be recognized by TestPartner out of the box.
The Active Object Recognition (AOR) utility includes a collection
of core Java classes and lets you add custom Helper classes and
metadata based on your application and requirements. This com-
ponent is typically used by advanced Java users.

& SAP eCATT Integration: Configures TestPartner for proper inte-
gration with SAP eCATT, the online SAP testing tool for the SAP
Web Application Server 6.20. This allows for storage/retrieval of
TestPartner data from the eCATT repository and full integration
for external testing from eCATT.

Make your selection(s) and click Next. The Select Program Folder
dialog box appears.

12 Specify a location for the TestPartner program shortcuts. You may
type a new folder name, or select one from the existing folders list.
Click Next. The Start Copying Files dialog box appears.

13 Review the summary of the settings that you specified and click Next
to start copying the program files. The Setup Status dialog box dis-
plays the progress of the installation.

14 After the installation completes, the Setup Complete dialog box
appears. Depending on the circumstances, you will see one of the fol-
lowing dialog boxes:

¢ Display Release Notes and/or Register for FrontLine.

— Display Release Notes: Select this check box to review the
information in the Release Notes. This file contains
information about new features, technical notes, and known
issues that may enhance or impact TestPartner’s performance.
Release Notes contain recent changes that may not be
included in your TestPartner product documentation.

— Register for FrontLine: Select this check box to register for
the FrontLine customer support site. The first time you access
FrontLine, you are required to register and obtain a password.
FrontLine provides fast access to critical information such as
documentation, frequently asked questions, and product
fixes.

¢ Restart Your Computer: You may be prompted to restart your
computer. If you are prompted to restart your computer, you may
choose to restart it now (recommended) or to restart it later.

15 Click Finish to complete the installation of TestPartner.
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Where To Go Next

¢ The evaluation license (CompuLock) supplied with your QACenter
product allows you to install the product and run it for a specific time
period without first installing a license. During this trial period, you
will be informed of how much evaluation time remains.

At any time during the evaluation period, you can obtain and install
a permanent license. When the evaluation period expires, you must
obtain a license and install it before you can successfully run this
product. See the License Installation Guide for instructions on install-
ing a license. To access this online book:

a Insert the QACenter CD into the CD-ROM drive. If the CD
browser does not automatically start, navigate to the CD’s root
directory and run setup.exe.

b Click View QACenter Documentation.
From the bookshelf, select the License Installation Guide.

¢ If Adobe Acrobat or Acrobat Reader is not installed on your com-
puter, click Install 3rd Party Software, then Install Adobe Acrobat
Reader from QACenter’s CD browser. Adobe Acrobat or Acrobat
Reader is required to view the online books in PDF format.

¢ TestPartner automatically configures an ODBC data source when
installed using an Access Database. Before use TestPartner with other
databases, you must create and configure an ODBC data source and
an ODBC database. Continue to the following sections for instruc-
tions:

¢ “Setting Up a SQL Server or MSDE Database with TestPartner” on
page 20

“Setting Up an Oracle Database with TestPartner” on page 27

“Setting Up SQL Server or Oracle for TestPartner without a
Domain” on page 38.

¢ After you have created and configured your database resources, you
are ready to begin using TestPartner. Refer to the TestPartner Getting
Started Guide for more information about the tasks and activities asso-
ciated with preparing for, planning, building, and running test
projects. You can access this book by clicking the taskbar’s Start but-
ton and choosing Programs>Compuware>TestPartner>Documen-
tation>Getting Started Guide.

Chapter 2 @ Installing TestPartner 19



Setting Up a SQL Server or MSDE Database with TestPartner

TestPartner accesses scripts and other assets stored in the TestPartner
database. This section describes how to configure a SQL Server or MSDE
database for use with TestPartner.

Note: Compuware recommends that a database administrator or a person
with general knowledge of database administration performs the
database setup and configuration.

SQL Server/MSDE Database Connection Requirements

Each client machine uses an ODBC data source to connect to the
database. As a result, connecting to the TestPartner database has the
following requirements:

¢ FEach machine running TestPartner must be able to access the
machine where the database resides.

¢ TestPartner must be installed on all machines accessing the database.

Creating a New SQL Server Database

This section describes how to create a SQL Server database using SQL
Server Enterprise Manager. In addition to the following procedures, you
must also populate the database with TestPartner tables using the
Database Maintenance utility, which is described in “Preparing the SQL
Server TestPartner Database” on page 25.

Create a SQL Server database on the server machine by following these
steps:
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1 From the SQL Server Enterprise Manager, expand the navigation tree
until the Databases folder is visible.

2 Right-click the Databases folder and choose New Database. The
Database Properties window appears.
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Lok iuesy s e i pee e R e e
[ oo o Toos || = = (Blm|x X RAREF [N LOIRG HAE
Ties | Duisbases 6 lhoms T
= e — W @ @ W W
= 4 50U Server Group riveter mods esch Hovthind pusts
= % SHETERWER [ifincoss M)
# H :m Il ]
o () ATass v [,
1o
I g
Iy
[

-

5 Lovke
Servei ke
4 ;g:nuvl‘ilrvrn
¥ Rencte Servers
F-) Support Services
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3 In the Database Properties window, enter a name for the database
and in the Name field and click OK.

Creating a New SQL Server Admin User

You need to create a SQL Server user with system administrator rights to

perform subsequent setup steps. To create a SQL Server admin user,
follow these steps:

Chapter 2 @ Installing TestPartner 21



1

In SQL Server Enterprise Manager, navigate to the Security folder and
expand it. Right-click on the Logins icon and choose New Login.
The SQL Server Login Properties dialog box appears.

S0L Server Login Properties - New Login

Genesal ] Sesver Floks | Database docas: |
&? Mama: I __]

1 Windows Authentication

Domain -

Secuiily sccess:

¥ Grart access

" Deny acoess
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asseord.

Specify the default language 2nd database fos thiz login

master 2
<Detaul» i

[ o ]

Diatabass:

Language:

Concel | Hew |

On the General tab, enter a user ID in the Name field and select SQL
Server Authentication.

Click the Server Roles tab. Select System Administrators.

Click the Database Access tab. Select your TestPartner database and
select db_owner in the database roles list that appears below. Click
OK.

Setting Up Users in SQL Server

The following procedure should be performed on the database server
machine for each user who needs to connect to the SQL Server database.

Required: You must create users within a Windows NT domain. Refer to your

Microsoft Windows documentation for more information about
using a Windows domain.
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1 Click Start>Programs>Microsoft SQL Server>Enterprise Manager.
The SQL Server Enterprise Manager dialog box appears:

" SQL Server Enterprise Manager - [Console Root\Microsoft SOL ServerstS0L Server Group\,S0L2000B0X (Windows NI

=]
% Console  Window  Help | =181
| o wew ook || & = @@ XS BB @[]0 ®mG
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g N G @ @ W B 6
=] Microsoft SQL Servers
B saL Datahases Data Management  Replication Security Support Meta Data
Y- Transforma. . Services Services

2 In the left pane, navigate to the database to which you would like to
add users.

3 Click Tools>Wizards... or click the Run a Wizard button on the tool-
bar. This is the button with an image of a wand. The Select Wizard
dialog box appears:

Select Wizard |

Fleaze zelect the Wizard you wizh to uze;

Create Database Wizard

Teate Index Wizard

reate Login ‘Wizard

Teate Stored Procedure ‘Wizard
- Create Yiew Wizard

+- Data Transformation Services

[ Management

ezl Replication

oK I Cancel |

4 Click Database and select Create Login Wizard. Click OK. The Cre-
ate Login Wizard dialog box appears.
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5 Click Next.

Required: Currently, TestPartner only supports Windows NT Authentication.
Microsoft suggests that Windows NT Authentication is more secure
because Windows NT's security features are more robust than SQL
Server's security features.

6 Select the Windows account information I use to logon to my
computer (Windows authentication) option and click Next.

Authentication with Windows
“windows Authentication iz determined by the *Windows Account [D. g)

windows account: rmydonmain®jef

[dormain namehaccount]

Security acce

% Grant access ta the server

" Deny access to the server

< Back I Mext = I Cancel I

7 Type the domain name and user ID or group name for the user or
group you would like to add.

Select the Grant access to the server option. Click Next.
9 Click Next again.

10 Select the check box for the database(s) to which the users will have
access. Click Next.

11 Click Finish.

12 In the left pane, navigate to the database to which you added users
with the Create Login Wizard. Click Users.

13 In the right pane, right-click the user ID or group you added with the
wizard in the steps above and choose Properties. The Database User
Properties dialog box appears.

14 Select the db_datareader and db_datawriter check boxes. Click OK.
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Creating a New Data Source

You must create a new data source to SQL Server from the workstation
that has TestPartner installed. See “Creating a Data Source Name for a
SQL Server Database” on page 45 for detailed instructions.

Preparing the SQL Server TestPartner Database

You must prepare your new SQL Server database for use with TestPartner.
This section describes how to use the Database Maintenance utility to
populate the database with TestPartner tables.

Required: SQL Server Authentication Mode must be set to: SQL Server and
Windows (Mixed Mode) to allow connection to the SQL Server
database through the Database Maintenance utility. This setting
can be changed after any database maintenance tasks are
performed.

1 Start TestPartner’s Database Maintenance utility.

2 Click File>New Database>SQL Server. The SQL Server Data Source
Connection dialog box appears.

5QL Server Data Source Connection E

SOL Server Data Source

Browsze... |

Cwter I Enter the uzer
details bo connect
User |0 I to SOL Server.
Password: I
o Enter a brief
Deseription: I description for
the DISH.

[Lreate I Cancel |

3 Type the name of the new SQL Server data source or click the Browse
button and select a data source name from the Select ODBC Data
Source dialog box. Type the name of the database Owner, User ID,
and Password. Click the Create button.
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Note: A table called TP_DSNSCHEMA must exist in the dbo schema. If the
table does not already exist in the dbo schema, a System Login
dialog box appears, requiring the password for dbo. Type the
password, and click OK. The table is created.

Only one schema can be associated with a DSN name (ODBC connec-
tion). If the chosen DSN name is already associated with a schema, a
Database Maintenance dialog box appears:

Database Maintenance i s

The DSH [TP-SOLSERVER] is associated with schema [SCOTT].
Urdess pou iz the D5M, the exising association wil be raplaced.

#isr [ Repace | Cancn |

4 Click the Replace button to change the association of the DSN name
from its current schema to the new schema (users will no longer be
able to access TestPartner tables in the old schema), or click the Alias
button to create an alias for the DSN name, a DSN Alias Creation dia-
log box appears:

2

Enler am ahat for SN [TPSOLSERVER] Thie
dlizzed DSM will be szociatad with schema
[dbea}

DS dbas: I

5 Type an alias name for the DSN, this alias will be associated with the
current schema. Click OK.

The Data Source Creation Status dialog box appears and displays the
progress of the database creation.
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Log on to TestPartner

To test your setup, start TestPartner and log on. The TestPartner welcome
screen appears.

Figure 2-1. TestPartner Welcome Screen

Welcome

TestPartner’

from Compuware

T

Record a Script Using:

The Code \Window,
Record, write and modify scripts directly in
Microsoft® Yisual Basic@® for Applications

The Yisual Mavigaton
Quiickly record, design and build tests using a
visuzl representation of script camponents

Bun the Tutorial
Learn about and interactively Tl
explore TestPariner features i

Project and User Management

COnlite Documentation

[ Do not show this dialog in the future

Setting Up an Oracle Database with TestPartner

This section describes how to configure an Oracle database with TestPart-

ner.

Note: The following instructions assume familiarity with the Oracle
database management system. Compuware recommends that a
database administrator or a person with general knowledge of
database administration performs database setup and configuration.

Oracle Database Connection Requirements

Each client machine requires a data source to connect to the database. As
a result, connecting to an Oracle database for TestPartner has the follow-
ing requirements:

¢ Each machine running TestPartner must be able to access the
machine where the database resides.

¢ TestPartner must be installed on all machines that access the data-
base.
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¢ The appropriate database client connectivity software must be
installed on any machine that runs TestPartner.

Creating a New Oracle Database

Create a new Oracle database with character set UTF8 (and National
Character Set UTEFS for Oracle 8i). Consult your Oracle documentation if
creating an Oracle database is unfamiliar.

Setting Up Oracle OS Authentication

28

On the server where the database is located, perform the following steps:

1 Locate the Oracle Initialization file in the directory where Oracle was
installed.
Note: In Oracle versions below 9i, this file is called INIT.ORA. However, in

Oracle 9i and later, initialization parameters can be set differently,
please refer to Oracle documentation for details on initialization.

2 In the Oracle Initialization file, set values for the following parame-
ters:

Note: If any of these parameters and values do not exist, add them.
remote_login_passwordfile = none
remote_os_authent = true

T

0os_authent_prefix =

3 Locate the SQLNET.ORA file in the directory where Oracle was
installed. The file should be located in ORACLE_HOME\Network\Admin
directory under the main Oracle installation directory where
ORACLE_HOME is the name assigned for the Oracle home during
installation.

4 Open SQLNET.ORA and set the value of the following parameter to
(NTS):

Note: If this parameter does not exist, add it.
sglnet.authentication_services = (NTS)

Required: Ensure this parameter is not commented out with a # at the begin-
ning of the line.

5 Click Start>Run. The Run dialog box appears.

6 In the Open field, type regedit. Click OK. The Registry Editor dia-
log box appears.
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In the path HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (where n

is the number associated with the Oracle installation), right-click on
HOMEn and choose New>String Value. A new string value appears in
the right pane of the registry editor.

Replace the default name, New Value #1, with
OSAUTH_PREFIX_DOMATIN.

Double-click the string value you just created. The Edit String dialog
box appears:

Edit String EHE

Walue name;
IDSAUTH_PHEFIX_DDMAIN

Walue data:
|TRUE

oK I Cancel |

10 In the Value data field, type TRUE. Click OK.

Setting Up the Oracle Client

On the client machine from which you will connect, follow these steps:

1

Locate the SQLNET.ORA file in the directory where Oracle was
installed. The file should be located in ORACLE_HOME\Network\Admin
directory under the main Oracle installation directory where
ORACLE_HOME is the name assigned for the Oracle home during
installation.

Open SQLNET.ORA and set the value of the
sqlnet.authentication_services as follows:

Note: If this parameter does not exist, add it.

sglnet.authentication_services = (NTS)

Required: Ensure this parameter is not commented out with a # at the begin-

ning of the line.

3

Open the TNSNAMES.ORA file in the directory where Oracle was
installed. This file should be located in ORACLE_HOME\Network\Admin
directory.
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4 Copy the server’s database entry to the TNSNAMES. ORA file on the cli-
ent machine. For example:
ORACLE_SID.DOMAIN.COM=
(DESCRIPTION=
ADDRESS_LIST=
ADDRESS=(PROTOCOL=TCP) (HOST=SERVERNAME) (PORT=1521))

(

(

)
(CONNECT_DATA=
(SERVICE_NAME=ORACLE_SID)
)
)

Preparing the Oracle Database for Client Connectivity
Use the following procedure to prepare an Oracle database for client
connectivity.

Note: This procedure is only necessary if you are using an Oracle client to
set up the TestPartner database.

Required: You must be logged on using an ID with administrator privileges
to perform this task.

You must create users within a Windows NT domain. Refer to your
Microsoft Windows documentation for more information about
using a Windows domain.

These procedures are for the Windows 2000 operating system. To

set up users in another operating system, consult your Windows
documentation.

1T On the machine that has User Manager for Domains, click Start>Set-
tings>Control Panel.

2 Select Administrative Tools.
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Creating the
ORA_DBA group:

Creating Server
Access For Users

3 Select Computer Management. The Computer Management utility

appears:

=) Computer Management

] Actior VoW |I‘1- s 33IEE||Q|E§

Tree]

= Syskern Tools
(8- {f] Event Viewer
System Information

B+

£

[ Users J
e

= g Skorage

| _] Disk Management

@ Disk Defragmenter

=3 Logical Drives

+ ﬁ‘ Removable Storags
[-El8 Services and Apglications

Performance Logs and Alerts

&) Shared Folders
i Devi r
~T=- 4 Local Users and Groops--.
1 1

Mame

5 system Tools
Eslaage

[H8services and Applications

| R

4 In the tree view, click Local Users and Groups.

5 Click Groups.

If Oracle is installed, you should see a group named ORA_DBA. If not,
add it using the following procedure:

1 In the tree view of the Computer Management utility, right click
Groups and choose New Group. The New Group dialog box appears.

2 In the Group Name field, type ORA_DBA.

3 Click Create.
4 Click Close.

You are now ready to create server access for users.

To create individual user accounts:

1 In the tree view of the Computer Management utility, click Local

Users and Groups.
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2 Click Groups.

3

E Computer Management

=10 x|
J&ction Yiew |J¢'-’||X ||§
Tree I Mame | Description |
@ Computer Management: (Local) gndministrators Administrators have complete and ...
E'ﬁ% System Tools gBackup Operators Backup Operatars can override secu...
[]..@ Event Viewer gGuests Guests have the same access as me...
[]...% Syskem Information gpower Users Power Users possess most administr. ..
[]---ﬁ Performance Logs and Alerts gReplicator Supports file replication in a domain
[#-§4] Shared Folders gUsers Users are prevented From making ac...
Device Manager RA_DEA
g_vmware_ WMware User Group

EI& Skorage

----- (2] Disk Management

----- e Disk Defragmenter
=3 Logical Drives
[]--@ Removable Storage
[]--& Services and Applications

In the right pane, double click ORA_DBA. The ORA_DBA Properties
dialog box appears:

ORA_DBA Propetties 2| x|

General |

@ ORA_DBA

Description: ||

Members:

Add... | Bemove I
Cloze I Canczel Lpply
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4  Click the Add button. The Select Users or Groups dialog box appears:

Lookin: [ FHODO2RED =

| Name | In Folder | -
!ﬁ Everyone

@Authenticated Users —
€5 ANONYMOUS LOGON

€TEATCH

€T CREATOR OWwWNER

¢TI CREATOR GROUP

T DIALUP =

sdd | Check Names

mydomaintjeff

()3 I Cancel |

e |

5 In the Name field, browse for the user’s ID, select it, and click Add.
Or, click in the text area under the Add button and type:
domain namel\user ID

Where:
domain name: The name of the domain where the user is
located.
user ID: The network ID of the user you want to give
access to.

6 Click OK to save the user information and return to the ORA_DBA
Properties dialog box.

7 Repeat step 4-6 to create any additional user accounts.

8 When you are finished, click OK in the Users Properties dialog box to
return to the Computer Management utility.
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Setting Up Users for TestPartner in Oracle

Users must be created in such a way that Oracle knows they are authenti-
cated via a DOMAIN controller.

Required: When setting up users for TestPartner in Oracle, a schema must be
also created to house the actual tables in addition to the remotely
authenticated users. The schema is not domain authenticated, but
is password authenticated. See “Creating the Password Authenti-
cated Schema” on page 35 for instructions.

Users must be created within a Windows NT domain. Refer to your
Microsoft Windows documentation for more information about

using a Windows domain.

Users must be added to the ORA_DBA group.

Use SQL*Plus to create users. If you are not familiar with SQL*Plus,
consult your Oracle documentation.

The user performing these steps must be a member of the ORA_DBA group
and have SYSDBA privileges. To specify users that can access the Oracle
database, follow these steps:

1 Click Start>Programs>Oracle>Database Administration>SQL Plus.
2 Logon as SYSTEM and connect as SYSDBA.

3 Type commands to create each user as "DOMAIN\USERNAME" IDEN-
TIFIED EXTERNALLY, and grant connection rights for each user as
"DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and
between double quotation marks, where DOMAIN\USERNAME is each
user’s domain and user name. For example:

SQL> create user "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "NT-DOMAIN\JEFF";

Note: In the case of an Oracle 9 instance, SELECT_CATALOG_ROLE must

also be granted to the user. For example:

SQL> grant select_catalog_role to "NT-DOMAIN\JEFF";

Required: Microsoft operating systems return the DOMAIN\USERNAME when
the user is queried. If this does not match what is defined in the
database, NTS authentication will fail with ORA-1017.

4 Grant rights to access the V_$SESSION view to individual users or to
all users as a public group.
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Remotely Granting
Access for Individual
Users

Remotely Granting
Access for All Users
(PUBLIC)

Required: All TestPartner users will need rights to access the V_$SESSION

view. To grant these rights, you must be logged on as a user with
administrative rights, e.g., SYSDBA.

When connecting remotely, use the server name or its alias from the
TNSNAMES . ORA file with the password.

If typing the command to remotely grant access for individual users,
type DOMAIN\USERNAME in uppercase and between double quotation
marks, where DOMAIN\USERNAME is the user name within the domain
of each user.

The following shows examples of the commands that are typed for
remotely granting access for individual users, and remotely granting
access for all users.

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO “NT-DOMAINNJEFF”;

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO PUBLIC;

Note: If you receive any errors that indicate you cannot grant these rights,

or that the V_$SESSION table cannot be found, you are not logged
on appropriately.

Test that Windows NT Authentication is set up correctly by connect-
ing to the database via SQL*Plus. Type a "/" for the user name.
Leave the Password field blank, and enter the host string appropri-
ately. Click OK. If you are able to log on, Windows NT authentication
is working properly.

Note: In the future, you do not need to create another Oracle TestPartner

database to add users. You do not have to perform the procedures
“Creating a New Data Source” and “Creating the Oracle TestPartner
Database”.

Creating the Password Authenticated Schema

Perform the following steps to set up the password authenticated schema
into which the TestPartner tables are stored.

Note: The password authenticated schema should not be more than five

characters in length because of Oracle character limitations in SQL
series.
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1 If SQL*Plus is not started, start it by click Start>Programs>Ora-
cle>Database Administration>SQL Plus.

2 If you are not properly logged on, log on as SYSTEM and connect as
SYSDBA.

3 Type commands to create each user as "DOMAIN\USERNAME" IDEN-
TIFIED EXTERNALLY, and grant connection rights for each user as
"DOMAIN\USERNAME" . Type DOMAIN\USERNAME in uppercase and
between double quotation marks, where DOMAIN\USERNAME is each
user’s domain and user name. For example:

SQL> create user "NT-DOMAIN\NJEFF" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "NT-DOMAIN\JEFF";

Creating a New Data Source

You must create a new data source to Oracle. See “Creating a Data Source
Name for an Oracle Database” on page 49 for detailed instructions.

Creating the Oracle TestPartner Database
1 Start the Database Maintenance utility.

2 Click File>New Database>Oracle. The Oracle Data Source Connec-
tion dialog box appears.

Oracle Data Source Connection E
Oracle Data Source Mame :

Browsze. .. |

Enter the uzer
Schema I details bo connect
to Oracle.
Uszer ID: I
Password: I
Enter a brief
Description: I dezcription for the
D5,

LCreate I Cancel
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3 Type the name of the new Oracle data source or click the Browse but-
ton and select a data source name from the Select ODBC Data Source
dialog box. Type a User ID, Password, and a brief description of the
DSN (the Schema field is filled in automatically with the same infor-
mation as the User ID). Click the Create button.

Note: A table called TP_DSNSCHEMA must exist in the SYSTEM schema. If
the table does not already exist in the SYSTEM schema, a System
Login dialog box appears, requiring the password for SYSTEM. Type
the password, and click OK. The table is created.

Only one schema can be associated with a particular DSN name
(ODBC connection). If the chosen DSN name is already associated
with a schema, a Database Maintenance dialog box appears:

24

The DSH [TPORACLER 7] iz associsted with schema [SCOTT],
Uirdeess you afias the DSH, the existing association will b replaced.

g || Peglace | concel |

Click the Replace button to change the association of the DSN name
from its current schema to the new schema (users will no longer be
able to access TestPartner tables in the old schema), or click the Alias
button to create an alias for the DSN name, a DSN Alias Creation
dialog box appears:

2

Enler an abas for DSN [TPORACLEE 7] The
alizzed DS wil be aszociabad with schema
[dbal

DSM dbas |

Type an alias name for the DSN, this alias will be associated with the
current schema. Click OK.

The Data Source Creation Status dialog box appears and displays the
progress of the database creation.
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Log on to TestPartner

To test your setup, start TestPartner and attempt to log on. If you are
successful, you will see the TestPartner welcome screen.

Figure 2-2. TestPartner Welcome Screen

Welcome
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COnlite Documentation

[ Do not show this dialog in the future

Setting Up SQL Server or Oracle for TestPartner without a
Domain

Compuware strongly recommends that you use authentication within a
domain when setting up an Oracle or SQL Server database with TestPart-
ner. However, if you are not on a domain, it is still possible to set up
these databases.

Required: To begin, you must create a user on both the client and the server
machines.
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To create a user, follow these procedures:
1 Click Start>Settings>Control Panel.

2 Double-click Users and Passwords. The Users and Passwords dialog
box appears:

Users and Passwords 7| x|

Users | Advanced I

Use the list below to grant or deny users access to your
computer, and ko change passwords and other settings,

IV Users rust enter a user name and password ko use this computer,

Users For this computer:

User Mame | Group |
lg_\fmware_user_ __vImware__

gndministrator Administrators

gGuest Guests

ﬁPFHJHWD ORA_DBA; Administrators

Remove | Properties |

—Password for Administrator

Ta change the password For Administrator, click Set
Password,

Set Password, .. |

OF | Cancel | Apply |

3 On the Users tab, click Add. The Add New User dialog box appears:

Add New User x|

Enter the basic information For the new user,

User name: I LUSER1

Full name: I

Description: I

To continue, click Mext,

= Back I Mext = I Cancel |

4 Type a valid user name in the User name field. Click the Next but-
ton.

5 Type a valid password in both the Password and Confirm password
fields. Click the Next button.

6 Select the level of access for the user and click the Finish button.
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7 On the Users and Passwords dialog box, click OK.
8 Repeat these steps on each client machine using the username and
password.

Setting Up SQL Server for TestPartner without a Domain

To set up SQL Server for TestPartner without a domain, follow these steps:
1 On the server machine, click Start>Settings>Control Panel.

2 Select Administrative Tools.

3 Select Computer Management. The Computer Management utility
appears:

E Computer Management

. =
m |2 |
Mame
mSystem Tools
Storage

]--@ Event Yiewer &Services and Applications
-3 System Information
H--&#] Performance Logs and Alerts

-] Shared Folders
----- _.5..'.;; Device Manager

J Action  Wiew |J = = |

-

EI& Skorage

----- (2] Disk Management

----- e Disk Defragmenter
=3 Logical Drives
[]--@ Removable Storage
[]--& Services and Applications

4 In the tree view, click Local Users and Groups.
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Click Groups.

E Computer Management

J Action  Wiew |J L=

I [=[ 3

ElRS=a=N

Tree I Mame | Drescription |
@ Computer Management (Local) gndministrators Administrators have complete and ...
E'ﬁ% System Tools gBackup Operators Backup Operatars can override secu...
[]..@ Event Yiewer gGuests Guests have the same access as me...
[]...% Syskem Information gpower Users Power Lsers possess most administr. ..
[]---ﬁ Performance Logs and Alerts gReplicator Supports file replication in a domain
-G Shared Falders Users Users are prevented from making ac.,.
2 Device Manager ¥ ORA_DEA
- Local Users and Groups g_vmware_

WMware User Group

D Users

EI& Skorage

----- (2] Disk Management
e Disk Defragmenter
=3 Logical Drives
[]--@ Removable Storage
[]--& Services and Applications

In the right pane, double click Users. The Users Properties dialog box
appears:

Users Properties ﬂll

General |

@ Users

Description:

Members:

€ NT AUTHORITY \Authenticated Users
€T NT AUTHORITYUNTERACTIVE
€7 FRODTI\Damain Users

Add... | Eemove |

QK I Cancel Lpply
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7  Click the Add button. The Select Users or Groups dialog box appears.

i Select Users or Groups ﬂ E

Lok ir: |_ FHODOZRED =

| Name | In Folder | -
!ﬁ Everyone
@Authenticated Users
€5 ANONYMOUS LOGON
€TEATCH

€T CREATOR OWwWNER
¢TI CREATOR GROUP

T DIALUP =

sdd | Check Names

USER1

()3 I Cancel |

A

8 In the Name field, browse for the user’s ID, select it, and click Add.
Or, click in the text area under the Add button and type:
Luser ID],
where [user ID] is the user you want to give access to.

9 Click OK to save the user information and return to the Users Proper-
ties dialog box.

10 Repeat step 7-9 to create any additional user accounts.

11 When you are finished, click OK in the Users Properties dialog box to
return to the Computer Management utility.

12 Close the Computer Management utility.
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Setting Up Oracle for TestPartner without a Domain

To set up Oracle for TestPartner without a domain, follow the procedures
for “Creating Server Access For Users” on page 31 with the following
exceptions:

Substitute the user name you created under, “Setting Up SQL Server or
Oracle for TestPartner without a Domain” on page 38 as shown in step 1
below:

Figure 2-3. Select Users or Groups Dialog Box

i Select Users or Groups ﬂ E

Lok ir: EFHDDMRED =

| Name | In Folder | -
!ﬁ Everyone
@Authenticated Users
€5 ANONYMOUS LOGON
€TEATCH

€T CREATOR OWwWNER
¢TI CREATOR GROUP

T DIALUP =

sdd | Check Names

USER1

()3 I Cancel |
#

1 Click in the text area under the Add button (Figure 2-3) and type
[user name] instead of [domain name]\[user ID] or [domain
name] \ [group name].

In addition, when using SQL*Plus to create users see step 3 on page 34,
substitute COMPUTERNAME\ USERNAME for DOMAIN\ USERNAME as shown
below:

2 Create the user as "[COMPUTERNAME J\USERNAME" TIDENTIFIED EXTER-
NALLY, entering the COMPUTERNAME\ USERNAME in uppercase and
between "' like the following example:

SQL> create user "FHOOO2RED\USERI"™ IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "FHOOO2RED\USER1";

3 Click Start>Programs>Compuware>TestPartner>Utilities>Data-
base Maintenance.
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4  Grant rights to access the V_$SESSION view to individual users or to
all users as a public group.
Open Oracle’s SQL*Plus Worksheet. Login as SYSTEM and connect as
SYSDBA. You can grant the access rights by entering the commands
shown below.

Required: All TestPartner users will need rights to access the V_$SESSION
view. To grant these rights, you must be logged on as a user with
administrative rights, e.g., SYSDBA.

Granting Access for SQL>CONNECT SYSTEM/password AS SYSDBA:
Individual Users SQL>GRANT SELECT ON “V_$SESSION” TO “COMPUTER NAMENJEFF”;
Granting Access for All SQL>CONNECT SYSTEM/password AS SYSDBA:
Users (PUBLIC) SQL>GRANT SELECT ON “V_$SESSION” TO PUBLIC;

Note: If you receive any errors that indicate you cannot grant these rights,
or that the V_$SESSION table cannot be found, you are not logged
on appropriately.

Creating a Data Source Name

On each machine that is connecting to the TestPartner SQL Server,
MSDE, Access or Oracle database, you must create a data source name
(DSN) using the ODBC utility.

The ODBC utility can be accessed from the Windows Control Panel.

Required: These procedures are for the Windows 2000 operating system. To
set up users in another operating system, consult your Windows
documentation.

Creating a Data Source Name for an Access Database

On each client machine connecting to an Access database, perform the
following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data
Sources (ODBC). The ODBC Data Source Administrator dialog box
appears.
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2 Click the System DSN tab, then click the Add button. The Create
New Data Source dialog box appears:

Create New Data Source ﬂ

Select a driver for which pou want to zet up a data source.

Mame | W -
Diriver da Microzoft para arquivos testo [k=t; *csv) 4.
Diriver do Microzoft Access [*.mdb) 4
Diriver do Microzoft dB aze [*.dbf) 4
Diriver do Microzoft Excel[* =1z 47
Diriver do Microzoft Paradox [*.db ] 4,

E.

4.
Microzoft Access-Treiber [ mdb) 4,
Microzoft dB aze Driver [*.dbf] 4, -
:n':,nmn ARt 20a WER Migivsar 1% AR _;:I_I

< Back I Finizh I Cancel |

This dialog box lists the available ODBC drivers.

3 From the list of drivers, select the Microsoft Access Driver and click
the Finish button. The ODBC Microsoft Access Setup dialog box
appears.

4 In the Data Source Name field, type the data source name. Since this
name appears as the database name in TestPartner’s logon screen, it is
recommended you enter a logical name in this field.

5 In the Description field, type a description for the data source. For
example, Connection to TestPartner Access database.

6 Click the Select button and browse for your Access database.
7 On the ODBC Microsoft Access Setup dialog box, click OK.
8 Click OK on the ODBC Administrator dialog box.

Creating a Data Source Name for a SQL Server Database
On each client machine, perform the following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data
Sources (ODBC). The ODBC Data Source Administrator dialog box

appears.
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2 Click the System DSN tab, then click the Add button. The Create

New Data Source dialog box appears:

Create New Data Source ﬂ
Select a driver for which pou want to zet up a data source.
Mame | W ;I

Microsoft ODBLC for Oracle
Microzoft Paradox Driver [*.db ]
Microzoft Parados-Treiber [*.db ]
Microzoft Test Driver [*.tat; * cav]
Microzoft Test-Treiber (% tat; * cav]
Microsoft Visual FoxPro Driver
Microsoft Visual FouPro-Treiber
BC Drriver

2
4.
4.
4.
4.
£
E.
a
2

< Back I Finizh I Cancel |

This dialog box lists the available ODBC drivers.

From the list of drivers, select SQL Server and click the Finish but-
ton. The Create a New Data Source to SQL Server dialog box appears.

In the Name field, enter the data source name. Since this name
appears as the database name in TestPartner’s logon screen, it is rec-
ommended you enter a logical name in this field.

In the Description field, enter a description for the data source. For
example, Connection to TestPartner SQL database.

In the Server field, enter the server name or select it from the drop-
down list. If you do not know the server name, consult your database
administrator.

Click the Next button. The Create a New Data Source to SQL Server
dialog box appears.

Select the With Windows NT authentication using the network
login ID option.
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9 Click the Client Configuration button. The Add Network Library
Configuration dialog box appears:

Server glias:

— Metwork libraries
" Named Pipes
* TCRAP
" Multiprotocal
= Nwilink IPX/SPX
" &ppleTalk
" Banyan ¥INES
oy
" Other

Add Network Library Configuration x
ISQL2DDDBox
— Connection p
Server name: ISQL2DDDBox

v Dynamically determine port

Fart number:

|1433

o]

Cancel | Help |

Ensure that the appropriate network library protocol is selected. If
necessary, consult your network administrator to verify the correct

network protocol.

10 Click OK to exit. You are returned to the Create a New Data Source to
SQL Server dialog box.

11 Click Next.

12 Select the Change the default database to check box, then select
your TestPartner database name from the drop-down list.

13 Accept all the other entries and click the Next button until the last
panel in the wizard appears.

14 Accept the defaults and click the Finish button. The ODBC Microsoft
SQL Server Setup window appears.
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Testing the Connection

Once the connection to the database is established, use the following
procedure to test the connection:

1 In the ODBC Microsoft SQL Server Setup window, click the Test Data
Source button. You should see the following:

SOL Server ODBC Data Source Tesk X
 Test Result

Microsoft SOL Server ODBC Driver Version 03.80.0380 ;I
Running connectivity tests. .

Attempting connection

Connection established

erifying option settings

Dizconnecting from server

TESTS COMPLETED SUCCESSFULLY!

2 Click OK. The ODBC Microsoft SQL Server Setup window displays.
Note: If your test results fail, you need to check your setup steps again.

3 Click OK. The ODBC Data Source Administrator window displays.
The newly created data source appears in the System Data Sources
list.

4 Click OK to close the ODBC utility.
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Creating a Data Source Name for an MSDE Database

Follow the same steps under “Creating a Data Source Name for a SQL
Server Database” on page 45, with the following exceptions:

¢ In step 3, select (local) for the server name.

Figure 2-4. Create a New Data Source to SQL Server

Create a New Data Source to S0L Server il

Thiz wizard will help you create an ODBL data source that you can use to
connect to SOL Server.

‘what name do you want to use to refer to the data source?

MName: [MyMSDE

How do you want to describe the data source?

Description: I

‘whhich SOL Server do you want to connect to?

Server: IE j

Finizh I Mest » | Cancel | Help |

¢ In step 6, a list of databases will be available for selection. However,
only the default databases from the MSDE installation will appear in
the drop-down list. If you wish to create your own database for
MSDE, you must use a front-end interface such as Enterprise Man-
ager.

Creating a Data Source Name for an Oracle Database

On each client machine connecting to an Oracle database, perform the
following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data
Sources (ODBC). The ODBC Data Source Administrator dialog box
appears.
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2 Click the System DSN tab, then click the Add button. The Create
New Data Source dialog box appears:

Create New Data Source il

Select a driver for which you want to set up a data source.

Marne lv =]

Microzoft ODEC for Oracle 2
Microzoft Paradox Diniver [*.db ) 4.
Microzoft Paradox-Treiber [*.db | 4.
Microzoft Text Diriver [* st * cav) 4.
Microzoft Text-Treiber [* tat; * cav) 4.
Microzoft Yisual FouPro Driver g
Microgoft Yisual FosPro-Treiber £
Oracle in OraHaormeS0 EN
SOL Sereer 2
IEN IE— '

< Back I Finish I Cancel |

3 From the list of drivers, select the Oracle in OraHome90 (not the
Microsoft ODBC for Oracle driver) and click the Finish button.

Note: For Oracle 8.1.7, select the Oracle ODBC Driver (not the Microsoft
ODBC for Oracle driver) and click the Finish button.

The Oracle ODBC Driver Configuration dialog box appears. The
following shows this dialog box for Oracle 9.0.1.

Dracle ODBC Driver Configuration

Data Source Mame IDracIe 9

C |
Description I ance |
Hel,
TNS Service Name | BATEAMS =] |
I Test Cannection |

Uszer 1D

Application I Oracle | “orkarounds | SALS erver Migration | Translation Options |

Enable Result Sets ¥ Enable Quem Timeout [¥  Read-Only Connection

Enable Closing Cursors I~ Enable Thread Safety ¥  SOLGetData Extensions [

Batch Autacommit kMade I Commit anly if all statements succeed j

4 In the Data Source Name field, type the data source name. Since this
name appears as the database name in TestPartner’s logon screen, it is
recommended you enter a logical name in this field.
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Oracle 9.0.1

Oracle 8.1.7

5

In the Description field, type a description for the data source. For
example, Connection to TestPartner Oracle database.

In the TNS Service Name field, type the service name for the data-
base you would like to connect to in the format
ORACLE_SID.DOMAIN, where ORACLE_SID is the Oracle SID you
assigned to the database upon creation and domain is the domain
that you are connecting to.

If you are using creating a Data Source name for an Oracle
9.0.1database, test the connection. See “Testing the Connection”
below. Otherwise, click OK.

Testing the Connection

1

1

On the Oracle ODBC Driver Configuration dialog box, click the Test
Connection button.

A message box appears stating the connection was successful.

Click OK to close the message box.
The Data Source name creation is complete.

Click Start>Programs>Oracle>Network Administration>Oracle
ODBC Test. The Oracle ODBC 32Bit Test - QUERY 1 dialog box
appears.

Click the Connect button. The Select Data Source dialog box appears:

selectpatasowee g
File Data Source  Machine Data Source |
[rata Source Mame | Type | Description ;I
DeluxeCD Uszer
Excel Files Uszer
FoxPro Files - word Uszer
M5 Access Database Uszer
TPOracle System
TPSOL Sustem
‘isual FoxPro D atabase Uszer
“isual FoxPro Tables Uszer -
«| | B

Mew..

A Machine Data Source iz specific to thiz machine, and cannot be shared.
"Uszer" data sources are specific to a uger on thiz machine. "System' data
zources can be uged by all uzers on this machine, or by a system-wide service.

QK I Cancel | Help |

3 Click the Machine Data Source tab and select the appropriate DSN

you created in the procedure described above.
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4  Click OK. You are returned to the Oracle ODBC 32Bit Test - QUERY 1
dialog box.

5 Click the All Tables button. If data appears in the QUERY 1 section
of the dialog box, your setup is complete.

Migrating TestPartner Objects from a Standard Character Set to
UTF8 (for Unicode)

52

It is recommended that an Oracle DBA or someone familiar with Oracle
export and import utilities perform the following task. For databases
larger than 2GB, the DBA should select appropriate parameters based on
the size of the database.

TestPartner only supports databases with a UTF8 (Unicode) character set.
Access stores strings in TEXT and MEMO fields, which are already
Unicode, so no schema changes are needed. SQL Server uses the NCHAR,
NVARCHAR, and NTEXT data types to store Unicode characters, so no
schema changes are needed. However, in Oracle 8.x, the NCHAR family
of data types is not Unicode, which means that any Oracle database
character set must be converted to UTFS.

Note: In Oracle 9.x, the NCHAR data type is redefined to UTF16, but
because TestPartner must support both 8.1.7 and 9.x, the 8.1.7
migration approach will be used in both instances, eliminating the
need for two separate schemas.

In order to support a TestPartner database previously created in an Oracle
instance with a standard character set, the database must be exported
from the standard database and imported into an Oracle instance created
with a UTF8 character set.

Caution: If the schema from which the TestPartner objects are being
exported contains more than just TestPartner objects, it is recommended
(required if the schema is SYSTEM) that the TestPartner objects be trans-
ferred to a new schema using the TestPartner Database Maintenance
Utility 05.02.00 (or older) Oracle-to-Oracle Copy Utility. The objects can
be then exported from the new schema.
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To perform the Migration:

1

Start a command prompt and change the directory to
$ORACLE_HOME/bin. This directory should contain both exp.exe
and imp.exe. Exp.exe will be used to perform the export, imp.exe will
be used to perform the import.

Caution: Before exporting, be sure there is sufficient disk space. If there
is not enough space, export will end in a write failure.

2

Type SET ORACLE_SID=MYSID into the command prompt, where
MYSID is the SID of the Oracle instance, and press Enter.

Type EXP USERNAME/PASSWORD FILE=EXPORT.DMP
LOG=EXPORT.LOG CONSISTENT=Y into the command prompt,
where USERNAME is the name of the schema to export and PASS-
WORD is the password for the schema. Press Enter to start the
export.

Note: To perform the export without knowing the user’s password, instead

execute it as the system user. Type EXP SYSTEM/PASSWORD
FILE=EXPORT.DMP LOG=EXPORT.LOG CONSISTENT=Y
OWNER=USERI into the command prompt, where PASSWORD in the
system user password and USERT is the owner of the schema to
export.

Create a new Oracle database with character set UTF8 (and National
Character Set UTEFS for Oracle 8i). Consult your Oracle documenta-
tion if creating an Oracle database is unfamiliar.

Create a new user in the new Oracle instance and grant them CON-
NECT, RESOURCE, and SELECT_CATALOG_ROLES privileges.

Click Start>Programs>Compuware>TestPartner>Utilities>Data-
base Maintenance from the Windows Start menu to start the
TestPartner Database Maintenance Utility.

Click Tools>Create UTF8 Migration Database, the Oracle Data
source Connection dialog displays.

Browse to the new Oracle instance with the UTF8 character set for

the Oracle Data Source Name field and fill in the User ID and Pass-
word fields with the new schema (the Description field is optional).
Click OK (steps identical to the steps in Creating the Oracle TestPart-
ner Database may have to be followed in order to complete this step).

Return to the command prompt and type SET ORACLE_SID=MYSID,
where MYSID is the SID of the UTFS8 Oracle instance, and press Enter.
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10 Type IMP USERNAME/PASSWORD FILE=EXPORT.DMP
LOG=IMPORT.LOG IGNORE=Y into the command prompt, where
USERNAME is the name of the schema to import into and PASS-
WORD is the password for the schema. Press Enter to start the
import.

Note: To perform the import without knowing the user’s password, instead
execute it as the system user. Type IMP SYSTEM/PASSWORD
FILE=EXPORT.DMP LOG=IMPORT.LOG FROMUSER=USER1
TOUSER=USER1 IGNORE=Y into the command prompt, where
PASSWORD in the system user password and USER1 is the owner of
the schema that was exported and FROMUSER and TOUSER are
identical.
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Chapter 3
Maintaining the Installation

# Accessing Maintenance Mode
4 Modifying an Installation

4 Repairing an Installation

4 Removing a Product

Note: TestPartner releases before 5.1.0 do not employ these maintenance
procedures. If you need to modify or repair a TestPartner installation
on releases before 5.1.0, you must uninstall it, then reinstall it. See
the “Installing TestPartner” chapter for instructions on removing
TestPartner from your machine.

Accessing Maintenance Mode

There are two methods for accessing a QACenter product’s maintenance
mode: from the QACenter CD or from the Windows Control Panel.

Required: Compuware recommends that you exit all non-essential Windows
programs before running this setup program. Some Windows
programs may interfere with the installation process.

Accessing Maintenance Mode from the Windows Control
Panel

1 Click the Windows Start button and choose Settings>Control Panel.
The Control Panel window appears.

2  Windows 9x/NT: Choose the Add/Remove Programs icon. The
Add/Remove Programs Properties dialog box appears. Select the
QACenter product to maintain and click Add/Remove.

55



Windows 2000, Windows XP Professional: Choose the Add/
Remove Programs icon. The Add/Remove Programs dialog box
appears. Select the QACenter product to maintain and click Change/
Remove.

You are presented with the three maintenance mode options: modify,
repair, and remove. For more information about these options, see the
appropriate section in this chapter.

Accessing Maintenance Mode from the QACenter CD

1 In the CD-ROM drive, insert the QACenter CD containing the same
version of the product that you have installed. The QACenter CD
browser should automatically appear. If it does not, navigate to the
root directory and run the setup.exe file.

2 Click Install QACenter Products.

3 Click Install product name (where product name is the name of
the product that you want to maintain).

You are presented with three maintenance mode options: modify, repair,
and remove.

Modifying an Installation

56

For products with optional components, you may want to add or remove
a component.

Rather than uninstall and re-install the product, you can modify your
installation.

Modifying Products With Optional Components

1 Access maintenance mode using one of the two methods described at
the beginning of this chapter.

2 Select the Modify option. Click Next. The Select Components dialog
box appears allowing you to add or remove components.

3 Click Next. Setup will add or remove the appropriate components.

4 After modifying, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.
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Repairing an Installation

There may be times when you will need to repair a damaged QACenter
product installation. This could be due to an inadvertent deletion or
corruption of the program. To repair your QACenter product, follow
these steps:

1

Access maintenance mode using one of the two methods described in
“Accessing Maintenance Mode” at the beginning of this chapter.

Select the Repair option. Click Next. Setup will repair the specified
QACenter product.

After repairing, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

Click Finish to complete the maintenance.

Removing a Product

If you want to remove a QACenter product from a PC, follow these steps:

1

Access maintenance mode using one of two methods described at the
beginning of this chapter.

Select the Remove option. Click Next. The Confirm File Deletion
dialog box appeatrs.

Click OK. Setup will remove the specified QACenter product from
your PC. If your product uses a database repository, you have the
option to either save or delete it. Do not delete it if you need to retain
the data in the database, as in the case of a product upgrade.

After uninstalling, you may be prompted to restart your computer. If
you are prompted to restart your computer, you may choose to restart
it now (recommended) or to restart it later.

Click Finish to complete the maintenance.
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