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C H A P T E R 1

Introduction

Who Should Read This Guide
The TestPartner Installation Guide is intended for administrators who are installing TestPartner.
For reference and usage information, refer to the TestPartner Help, which is installed with the
product.

How to Use This Guide
The TestPartner Installation Guide includes system requirements and instructions for installing
the TestPartner application.

Related Publications
The TestPartner documentation set includes the following publications:

TestPartner Installation Guide
Provides system requirements and instructions for installing TestPartner. It also details
basic setup and how to create, configure, and connect to a TestPartner database.

TestPartner Release Notes
Contains information about the latest product features, as well as information about any
known issues or other technical information about TestPartner.

TestPartner Help
Provides TestPartner product usage information, tutorials, and the TestPartner language
reference.

Distributed License Management Installation Guide
Provides instructions for licensing TestPartner.
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Getting Help
If ever you have any problems or you would like additional technical information or advice,
there are several sources. In some countries, product support from Micro Focus may be available
only to customers who have maintenance agreements.
If you obtained this product directly from Micro Focus, contact us as described below. If you
obtained it from another source, such as an authorized distributor, contact them for help first.
If they are unable to help, contact us as described below.
However you contact us, please try to include the information below, if you have it. The more
information you can give, the better Customer Care can help you. But if you don't know all the
answers, or you think some are irrelevant to your problem, please give whatever information
you have.

• The name, release (version), and build number of the product.

• Installation information, including installed options, whether the product uses local or network
databases, whether it is installed in the default directories, whether it is a standalone or
network installation, and whether it is a client or server installation.

• Environment information, such as the operating system and release on which the product is
installed, memory, hardware/network specifications, and the names and releases of other
applications that were running.

• The location of the problem in the product software, and the actions taken before the problem
occurred.

• The exact product error message, if any.

• The exact application, licensing, or operating system error messages, if any.

• Your Micro Focus client, office, or site number, if available.

Contact

Our web site gives up-to-date details of contact numbers and addresses. To connect, enter
www.microfocus.com in your browser to go to the Micro Focus home page, or go to
http://supportline.microfocus.com.

TestPartner Installation Guide6
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C H A P T E R 2

Getting Started

Installation Types
Before you begin, determine the type of installation you need to perform:

Initial Installation
A first-time installation of a product on your computer.

Upgrade
You can upgrade a currently installed TestPartner 6.1 or 6.2 release. For earlier versions
of TestPartner, you must uninstall, and then perform an initial installation.

Modify
A modification of the product installation occurs when you add or remove one or more
of a product’s components, but not all of them.

Repair
A repair installation may be necessary due to a corruption of a program or the inadvertent
deletion of the product.For more information, see Repairing a TestPartner Installation
[p. 43].

Remove
A remove or uninstall removes all the components of a product.For more information,
see Removing a TestPartner Installation [p. 44].

Before Installing
Prior to installation, carefully review the following information:

Release Notes

Review the Release Notes for information about new features, technical notes, and known issues
that may enhance or impact your product’s performance. Release Notes contain recent changes
that may not be included in the product documentation.
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Release Notes can be viewed from the installation media or on SupportLine
(http://supportline.microfocus.com), the Micro Focus Customer Care web site. The Release
Notes on SupportLine are periodically updated as new information becomes available.

System Requirements

Review the system requirements to ensure that the system meets the prerequisites for the
successful installation and operation of the product. System requirements are listed in the Release
Notes as well as in the Installation Guide. For more information, see System Requirements
[p. 8].

System Requirements
Hardware

• Pentium 4 processor equivalent or higher (recommended)

• Minimum of 512 MB of RAM

• 300 MB of hard disk space on the system disk (the disk on which the operating system
is installed), and an additional 220 MB when installing SQL Server 2005 Express as
the default TestPartner database

• Optimized for 1024 x 768 or higher screen resolution

Operating System
• Microsoft Windows 7 Professional, Enterprise, and Ultimate (32-bit & 64-bit) Editions

• Microsoft Windows Vista Business, Enterprise, and Ultimate SP1, SP2 (32-bit) Editions

• Microsoft Windows XP Professional SP3 (32-bit)

• Microsoft Windows Server 2008 Standard and Enterprise SP1, SP2, and R2 (32-bit
& 64-bit) Editions

• Microsoft Windows Server 2003 Standard and Enterprise SP1, SP2, and R2 (32-bit)
Editions

Browser
• Microsoft Internet Explorer 8.0

• Microsoft Internet Explorer 7.0

• Microsoft Internet Explorer 6.0 SP3

• Mozilla Firefox 3.5

• Mozilla Firefox 3.0

Database
• Microsoft SQL Server 2008 SP1; Prerequisites include MDAC 2.8 (2.80.1022.3),

.NET Framework 2.0, Windows Installer 3.1

• Microsoft SQL Server 2008 Express Edition SP1 (for up to 5 users); Prerequisites
include MDAC 2.8 (2.80.1022.3), .NET Framework 2.0, Windows Installer 3.1

TestPartner Installation Guide8
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• Microsoft SQL Server 2005 SP3; Prerequisites include MDAC 2.8 (2.80.1022.3),
.NET Framework 2.0, Windows Installer 3.1

• Microsoft SQL Server 2005 Express Edition SP3 (for up to 5 users); Prerequisites
include MDAC 2.8 (2.80.1022.3), .NET Framework 2.0, Windows Installer 3.1

• Microsoft Access 2000 (as a single-user database)

• Oracle 11.1, 10.2, or 10.1 RDBMS database on Microsoft or Unix/Linux platforms

Other Software
• Microsoft Visual Basic for Applications (6.5.1048, 6.5.1040, 6.5.1032); TestPartner

installs 6.5.1032.

• Adobe Acrobat or Acrobat Reader to view the documentation provided in PDF format
(the Acrobat Reader setup file is available from Adobe's Web site: www.adobe.com)

• Additional resources may be required for testing tools and the application under test

Integrated Products Requirements
• QADirector 5.3.1, 6.0, 6.0.1, 6.1

• QALoad 5.7, 5.8, 5.9

• QARun 4.9.1 SP2

Input Method Editor (IME) Support

TestPartner supports the following IMEs for the listed input systems.

Table 1. Japanese Input System

Windows VistaWindows 2003
Server

Windows XPFile NameDescription

XXimejp81.imeMS-IME 2002

XXimejp9.imeMS-IME 2003

XN/AMS-IME
(10.0.6000.0)

Table 2. Korean Input System

Windows VistaWindows 2003
Server

Windows XPFile NameDescription

XXimekr61.imeIME 2000

XXimekr.imeMS-IME 2002

XXimekr70.imeMS-IME 2003

XN/AMS-IME
(8.0.6000.0)
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Table 3. Simplified Chinese Input System

Windows VistaWindows 2003
Server

Windows XPFile NameDescription

XXpintlgnt.imeMS-PinYin 3.0

XN/AMS-Pinyin IME
(10.0.6000.0)

Table 4. Traditional Chinese Input System

Windows VistaWindows 2003
Server

Windows XPFile NameDescription

XXtintlgnt.imeMS-New
Phonetic IME

XXb5pinyin.imeMS Big5 Code
IME

XN/AMS-Pinyin IME
(10.0.6000.0)

Installing a License
A trial license is supplied with your product. At any time during the evaluation period, you can
obtain and install a permanent license. When the evaluation period expires, you must obtain a
license and install it before you can successfully run this product.
There are two types of TestPartner licenses:

TestPartner_Developer
Enables full TestPartner functionality.

TestPartner_Runtime
Enables only playback functionality from the TestPartner command line utility (TP.EXE)
or from QADirector.

For instructions on installing and configuring a license, refer to the Distributed License
Management Installation Guide, which you can access from the Micro Focus installation media.
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C H A P T E R 3

Installing TestPartner

Installation Overview
This section explains the installation process for TestPartner. Before proceeding with the
TestPartner installation, please review the system requirements to ensure that TestPartner installs
and operates properly on your computer. For more information, see System Requirements
[p. 8].
Micro Focus recommends that you review the TestPartner Release Notes which includes
information about new features, technical notes, and known issues. The Release Notes also
document recent changes that might not be included in TestPartner documentation. Please review
this information carefully; the Release Notes document is updated as new product information
becomes available. For more information, see Before Installing [p. 7].

IMPORTANT
Micro Focus recommends that you exit all non-essential Windows programs before running
this setup program. Some Windows programs may interfere with the installation process. If you
have a TestPartner release prior to 6.1 installed, you must back up your data and uninstall
TestPartner before installing the new version. You must have administrator permissions to
install and use TestPartner.

Installing TestPartner
To install TestPartner, perform the following steps:

1. From the Micro Focus installation media, select the TestPartner installation link. The
installation wizard appears.

2. Read the welcome page and click Next. The License Agreement page appears.
3. Read the license agreement. If you consent with the agreement, select the option to accept

the terms, and then click Yes. The Customer Information page appears.
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4. Type your name and company in the User Name and Company Name fields. Click Next.
The Choose Destination Location page appears.

5. Select a folder in which to install TestPartner or use the default location.
• By default, TestPartner installs in <INSTALL_DIR>:\Program Files\Micro

Focus\TestPartner (where <INSTALL_DIR> is the drive on which your operating
system is installed).

• To specify a different folder, click the Browse button and select the desired folder.
Click OK.

6. Click Next. The Select Features page appears. This page allows you to select additional
features to install. Highlight a feature to view a brief description

7. Select any additional features to install, and then click Next. Choose from the following
features:
• NOTE

If you are upgrading a TestPartner release and have previously installed any additional
features, you must reinstall these features to use them with the current release.

SAP eCATT Integration
Configures TestPartner for proper integration with SAP’s eCATT testing tool.
This allows for storage and retrieval of TestPartner data from the eCATT
repository and full integration for external testing from eCATT.

NOTE
You must have the SAP GUI for Windows 6.20, 6.40 or 7.10 installed to enable
the eCatt integration feature. For more information about configuring SAP for
use with TestPartner, refer to the Release Notes.

Visual Studio Integration
There are two selections for Visual Studio Integration. Microsoft Visual Studio
2005 Team Suite must be installed to install these features.

◦ Visual Studio Team Suite Integration: This option installs TestPartner’s
integration with Microsoft Visual Studio 2005 Team Suite. This integration
allows you to use TestPartner as the testing solution for Visual Studio 2005
test projects. With the option installed, you can create TestPartner functional
test suites, run TestPartner scripts, analyze test runs, and launch TestPartner
from within Visual Studio 2005. You must install the Testing Tools
subcomponent of the Team Developer and Tester Tools component for Visual
Studio 2005 Team Suite to install this feature.

◦ Visual Studio Team Test Load Agent Integration: This option installs
TestPartner’s remote testing integration with Visual Studio 2005. This
integration allows TestPartner scripts to run on remote computers through
the Microsoft Visual Studio 2005 Team Test Load Agent. You must install
the Microsoft Visual Studio 2005 Team Test Load Agent and the Visual
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Studio 2005 Team Test Load Controller on the same computer to install this
feature.

NOTE
To start TestPartner functional testing in Visual Studio 2005 Team Suite, start
Visual Studio 2005 Team Suite after installing TestPartner and click
Project>Add New Test or Test>New Test. When the Add New Test dialog
box appears, select the Micro Focus Functional Test template and click OK.

SQL Server 2005 Express Edition
Installs SQL Server 2005 Express as the default TestPartner database. This
feature is selected by default. If you do not want to install SQL Server 2005
Express Edition, clear the check box. TestPartner will install Microsoft Access
2000 as the default TestPartner database.

8. Click Next. The Setup Status page appears and displays an installation progress bar to
inform you of the current progress of the installation. When the installation completes, the
InstallShield Wizard Complete page appears.

9. Click Finish to complete the installation of TestPartner. Optionally, select the Visit Micro
Focus SupportLine for Product News and Technical Alert box to open a browser and
display the SupportLine home page.

After the installation completes, you may be prompted to restart your computer.

Where to Go Next
A trial license is supplied with your product. At any time during the evaluation period, you can
obtain and install a permanent license. When the evaluation period expires, you must obtain a
license and install it before you can successfully run this product.
There are two types of TestPartner licenses:

TestPartner_Developer
Enables full TestPartner functionality.

TestPartner_Runtime
Enables only playback functionality from the TestPartner command line utility (TP.EXE)
or from QADirector.

For instructions on installing and configuring a license, refer to the Distributed License
Management Installation Guide, which you can access from the Micro Focus installation media.

Configuring a TestPartner Database

TestPartner automatically configures an ODBC data source when installed with a SQL Server
2005 Express or Access database. Before using TestPartner with other databases, you must
create and configure an ODBC data source and an ODBC database.
Additionally, to use SQL Server 2005 Express in a multi-user environment, there are other
configuration requirements.
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After you have created and configured your database resources, you are ready to begin using
TestPartner. Refer to the TestPartner Help for more information about the tasks and activities
associated with preparing for, planning, building, and running test projects.

Silent Installation Overview
You can perform an unattended installation of TestPartner, in which setup screen entries are
made automatically from the command line. An unattended installation can be convenient if
you want to perform several installations of TestPartner with identical configurations on different
computers from a remote location.

IMPORTANT
Software distribution management software, such as Microsoft Systems Management Server
(SMS), is required to install TestPartner remotely.

Silent Installation Prerequisites
Before performing a silent installation of TestPartner, you must install the following prerequisites
on each target installation computer. The installation commands to run each executable from
the Micro Focus installation media are provided after each prerequisite:

NOTE
Depending on the operating system of the target installation computer, some or all of the
following installation prerequisites may already be installed. When using Microsoft Access
2000 as the default TestPartner database, the only installation prerequisite is VBA 6.5. When
installing TestPartner on Windows Vista, you must be logged in as an administrator. For Windows
7, you must be logged in using the built-in Administrator Account.

VBA 6.5 (6.5.1032)
//Install Visual Basic for Applications (Core, Components & Merge Modules)

msiexec.exe /i "<SRCDIR>\requirements\vba\Visual Basic for Applications SDK.msi"

/q ADDLOCAL="VBASDK_Core_Release,VBASDK_Components,VBASDK_MergeModules"

REBOOT=ReallySupress

//Install Visual Basic for Applications (Multi-Language)

msiexec.exe /i <SRCDIR>\requirements\vba\ProgramFilesFolder\VBA6SDK\VBA\Release\

VBAOF11.msi /q REBOOT=ReallySupress

//Install Visual Basic for Applications (English)

msiexec.exe /i <SRCDIR>\requirements\vba\ProgramFilesFolder\VBA6SDK\VBA\Release\

1033\VBAOF11I.msi /q REBOOT=ReallySupress

.NET 2.0 Framework
<INSTALL_DIR>\requirements\dotnetfx.exe /Q /c:"install /l /q"

MDAC 2.8 (2.80.1022.3)
<INSTALL_DIR>\requirements\mdac_typ.exe /Q /c:"dasetup.exe /q /n"

Windows Installer 3.1 or 4.0
<INSTALL_DIR>\requirements\WindowsInstaller-KB893803-v2-x86.exe /quiet

/norestart
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NOTE
To install Windows Installer 3.1, use the above command. Windows Installer 4.0 is
shipped with Windows Vista. There is no redistributable for installing Windows Installer
4.0 on other operating systems.

SQL Server 2005 Express with database instance
<INSTALL_DIR>\requirements\SQLEXPR32.EXE /qn ADDLOCAL=SQL_Data_Files

INSTANCENAME=QACInst SECURITYMODE=SQL SAPWD=qacenter SQLBROWSERAUTOSTART=1

DISABLENETWORKPROTOCOLS=2

SQL Server Management Studio Express (optional)
msiexec.exe /i <INSTALL_DIR>\requirements\SQLServer2005_SSMSEE.msi /q

SQL Native Client (optional - 2005 version)
msiexec.exe /i <INSTALL_DIR>\requirements\sqlncli.msi /q

REBOOT=ReallySupress APPGUID={279FBA4C-035F-4B82-82E3-C670B26D2D15}

Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)
<INSTALL_DIR>\requirements\vcredist_x86.exe /q:a

NOTE
The Visual C++ 2005 Redistributable Package is only required when you are upgrading
from TestPartner 6.1 or TestPartner 6.2 on Windows Vista or Windows Server 2008. For
more information, refer to the Microsoft Download Center.

Performing a Silent Installation
1. Run TestPartner.msi from a command line prompt.
2. Specify the desired installation options and properties.

NOTE
For a complete list of options and properties, consult the Windows Installer SDK
documentation. Public properties customized for TestPartner installation are listed later in
this section.

Silent Install Command Example

As an example, the command for a basic, silent installation of TestPartner is as follows:
C:\TestPartner\msi>msiexec /i TestPartner.msi /qn

In this example, the display option /qn is used to set the user interface level to “none”. The user
is never prompted to supply information and never sees any messages. In addition to setting the
display option, you can also set other options, such as whether to restart a computer after
installation, display a log file, or uninstall a previous TestPartner installation. TestPartner also
provides customized public properties that you can use to specify additional installation features.
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Customized Public Properties for Silent Installations
TestPartner provides the following customized public properties from which you can use to
silently install additional TestPartner features.

INSTALLLEVEL
Specifies installation features by level. Each feature is assigned a value. A feature is
installed only if the value of the feature is equal or less than the INSTALLLEVEL value.
The available TestPartner features and values are:

• Core = 1

• SQL_Server_2k5_Exp_Ed = 50

• SAP_eCATT_Integration = 175

• VSTS_Client_Integration = 200

• VSTS_Remote_Integration = 225

“Core” specifies a base installation of TestPartner with Access 2000 installed as the
default database. “SQL_Server_2k5_Exp_Ed” installs a SQL Server 2005 Express database
as the default TestPartner database. You must install the SQL Server 2005 Express
prerequisites prior to specifying this feature.
As an example, to install the SAP eCatt integration, a SQL Server 2005 Express database,
and the base installation features:
msiexec /i msi\TestPartner.msi /qn INSTALLLEVEL=175

To install all features:
msiexec /i msi\TestPartner.msi /qn INSTALLLEVEL=225

ADDLOCAL
Specifies installation features by name. Each feature is assigned a name. A feature is
installed only if its name is specified.
The available TestPartner features listed by name are:

• Core

• SQL_Server_2k5_Exp_Ed

• SAP_eCATT_Integration

• VSTS_Client_Integration

• VSTS_Remote_Integration

“Core” specifies a base installation of TestPartner with Access 2000 installed as the
default database. “SQL_Server_2k5_Exp_Ed” installs a SQL Server 2005 Express database
as the default TestPartner database. You must install the SQL Server 2005 Express
prerequisites prior to specifying this feature.
As an example, to install the SAP eCatt integration in addition to the base installation
features:
msiexec /i msi\TestPartner.msi /qn ADDLOCAL=”Core, SAP_eCATT_Integration”

To install all features:
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msiexec /i msi\TestPartner.msi /qn ADDLOCAL=”Core, SQL_Server_2k5_Exp_Ed,

SAP_eCATT_Integration, VSTS_Client_Integration, VSTS_Remote_Integration

Unsupported Windows Installer Options

For unattended installations, TestPartner does not support the following Windows installer
options:

/a - Administrative installation option
This option installs a product on the network.

/j - Advertising option
This option advertises a product.

/c - New instance advertising option
This option advertises a new instance of a product.
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C H A P T E R 4

Configuring a TestPartner Database

Configuring a SQL Server Database Overview
IMPORTANT
Micro Focus recommends that a database administrator or person with general knowledge of
database administration performs the database setup and configuration.

TestPartner accesses test assets stored in the TestPartner database. This section describes how
to configure the following SQL Server databases to use as a TestPartner database:

• SQL Server 2008

• SQL Server 2005

• SQL Server 2005 Express

A SQL Server database configured for use with TestPartner has the following requirements:

• Each computer running TestPartner must be able to access the computer where the SQL
Server database resides and have a new data source configured. For more information, see
Creating a Data Source Name for a SQL Server Database [p. 36]. .

• TestPartner must be installed on all computers accessing the database.

• The database connection must be configured for use with TestPartner. For more information,
see Configuring a TestPartner Database Connection [p. 40].

For SQL Server 2005 Express, the following configuration requirements are automatically
performed by the TestPartner installer:

• SQL Server 2005 Express database with instance “QACInst” and strong password “qacenter”.

• User with admin rights “TestPartnerAdmin” with strong password “TestPartnerAdmin”.
General user “TestPartnerUser” with strong password “TestPartnerUser”.

• Data source name (DSN) “TestPartner_SQL”.
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• Database owner/schema “TestPartnerDB”.

For more information about maintaining the default TestPartner SQL Server 2005 Express
database, refer to TestPartner Help topic “Opening a SQL Server Database”.

Creating a New SQL Server Database
This section describes how to create a SQL Server 2005/2008 database using SQL Server
Management Studio. In addition to the following procedures, you must also populate the database
with TestPartner tables using the TestPartner Database Maintenance utility.

1. In the Object Explorer of SQL Server Management Studio, right-click theDatabases folder
and choose New Database. The New Database dialog box appears.

2. Enter a name for the database in the Database name box.
3. Click OK.

Creating a New SQL Server Admin User
A SQL Server user with system administrator rights is required to perform subsequent setup
steps.

NOTE
For SQL Server 2005 Express, TestPartner automatically creates a user with admin rights
“TestPartnerAdmin” and strong password “TestPartnerAdmin”.
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1. In the Object Explorer of SQL Server Management Studio, navigate to the Security folder
and expand it. Right-click the Logins icon and choose New Login. The Login -New dialog
box appears.

2. Select the General page, and then enter a name for the database in the Login name box.
3. Select SQL Server Authentication and enter a password. Select the default database

from the Default database list.
4. Select the Server Roles page, and then select sysadmin from the Server roles list.
5. Select the User Mapping page.
6. In the Map column, select the check box for the database that your login can access. By

default, the login name appears in the User column. Leave this value.
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7. In the Database role membership for list, select db_owner.
8. Click OK.
9. In the Object Explorer, right-click the Schema folder and choose New Schema. Create a

new Schema. The new schema name must match the name of the previously created user
with system admin rights.

10. Assign the new user with system administrator rights as the owner of the schema.
11. Click OK.
12. Select the newly created user and set the default schema to the newly created schema.

Setting Up Users in SQL Server
The following procedure should be performed on the database server computer for each user
who needs to connect to the SQL Server database

1. In the Object Explorer of SQL Server Management Studio, navigate to the Security folder
and expand it. Right-click the Logins icon and choose New Login. The Login -New dialog
box appears.
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2. Select the General page, and then enter a name for the database in the Login name box.
3. Select either Windows Authentication or SQL Server Authentication.
4. Select the default database from the Default database list.
5. Select the User Mapping page.
6. In the Map column, select the check box for the database that your login can access. By

default, the login name appears in the User column. Leave this value.
7. In the Default Schema column, enter the default schema. For use with TestPartner, the

default schema must match the schema of the previously created user with system admin
rights.

8. In the Database role membership for list, leave the default option public selected. Select
the db_datareader and db_datawriter check boxes.

9. Click OK.

IMPORTANT
To use SQL Server 2005 Express with multiple users, each SQL Server 2005 Express installation
must be enabled for remote connectivity. To enable SQL Server 2005 Express for remote
connectivity, refer to the Microsoft support article "How to configure SQL Server 2005 to allow
remote connections".

Preparing the SQL Server TestPartner Database
You must prepare your new SQL Server database for use with TestPartner. This section describes
how to use the Database Maintenance utility to populate the database with TestPartner tables.
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NOTE
SQL Server Authentication Mode must be set to: SQL Server and Windows (Mixed Mode) to
allow connection to the SQL Server database through the Database Maintenance utility. This
setting can be changed after any database maintenance tasks are performed.

1. Click Start>Programs>Micro Focus>Utilities>Database Maintenance to start
TestPartner’s Database Maintenance utility.

2. Click File>New Database>SQL Server. The SQL Server Data Source Connection
dialog box appears.

3. Type the name of the new SQL Server data source or click the Browse button and select
a data source name from the Select ODBC Data Source dialog box.

4. In the appropriate boxes, type the name of the database owner, the SQL Server user ID,
and password, and then click the Create button

NOTE
Only one schema can be associated with a DSN name (ODBC connection). If the chosen
DSN name is already associated with a schema, Click the Replace button to change the
association of the DSN name from its current schema to the new schema (users will no
longer be able to access TestPartner tables in the old schema), or click the Alias button to
create an alias for the DSN name.

You are now ready to start TestPartner and log on. For more information, see Starting TestPartner
Overview [p. 39].

TestPartner Installation Guide24

Chapter 4 ∙ Configuring a TestPartner Database



Configuring an Oracle Database Overview
This section describes how to set up an Oracle database with TestPartner.

NOTE
The following instructions assume familiarity with the Oracle database management system.
Micro Focus recommends that a database administrator or a person with general knowledge of
database administration performs database setup and configuration.

Each client computer requires an ODBC data source to connect to the database. As a result,
connecting to an Oracle database for TestPartner has the following requirements:

• Each computer running TestPartner must be able to access the computer where the database
resides and have a new data source configured. For more information, see Creating a Data
Source Name for an Oracle Database [p. 37].

• TestPartner must be installed on all computers that access the database.

• The appropriate database client connectivity software must be installed on any computer
that runs TestPartner.

• The database connection must be configured for use with TestPartner. For more information,
see Configuring a TestPartner Database Connection [p. 40].

Selecting an Authentication Method
TestPartner supports the use of either Oracle OS authentication (Windows NT) or Oracle database
authentication. There are additional installation procedures required when using Oracle OS
authentication. For more information, see Setting Up Oracle Authentication [p. 25], and Preparing
the Oracle Database for Client Connectivity [p. 27].

Creating a New Oracle Database
Create a new Oracle database with character set UTF8. For more information, refer to the Oracle
product documentation.

Setting Up Oracle Authentication
NOTE
This procedure is only necessary if using Oracle OS authentication. If using Oracle database
authentication, you must set up the Oracle client.

1. On the server where the database is located locate the Oracle Initialization file in the directory
where Oracle was installed.

2. In the Oracle Initialization file, set values for the following parameters:
• remote_login_passwordfile = none

• remote_os_authent = true

• os_authent_prefix = ““
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NOTE
If any of the parameters and values do not exist, you must add them. In Oracle 11g, the
remote_os_authent and os_authent_prefix parameters are set by default.

3. Locate the SQLNET.ORA file in the directory where Oracle was installed. The file should be
located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.

4. Open SQLNET.ORA and set the value of the following parameter as follows:
sqlnet.authentication_services = (NTS)

NOTE
Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.

5. Access the Run dialog box from the Start menu.
6. In the Open field, type regedit. Click OK. The Registry Editor dialog box appears.
7. In the path HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (where n is the number

associated with the Oracle installation), right-click HOMEn and choose New>String Value.
A new string value appears in the right pane of the registry editor.

8. Replace the default name, New Value #1, with OSAUTH_PREFIX_DOMAIN.
9. Double-click the string value you just created. The Edit String dialog box appears

10. In the Value data box, type TRUE. Click OK.

Setting Up the Oracle Client
On the client computer from which you will connect:

1. Locate the SQLNET.ORA file in the directory where Oracle was installed. The file should be
located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.

2. Open SQLNET.ORA and set the value of the following parameter as follows:
sqlnet.authentication_services = (NTS)

NOTE
Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.
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3. Open the TNSNAMES.ORA file in the directory where Oracle was installed. This file should
be located in ORACLE_HOME\Network\Admin directory.

4. Copy the server’s database entry to the TNSNAMES.ORA file on the client computer. For
example:
ORACLE_SID.DOMAIN.COM=

(DESCRIPTION=

(ADDRESS_LIST=

(ADDRESS=(PROTOCOL=TCP)(HOST=SERVERNAME)(PORT=1521))

)

(CONNECT_DATA=

(SERVICE_NAME=ORACLE_SID)

)

)

Preparing the Oracle Database for Client Connectivity
NOTE
This procedure is only necessary if you are using Oracle OS authentication and an Oracle client
to set up the TestPartner database. If you are using Oracle database authentication, you can
begin to set up users. For more information, see Setting Up Users for TestPartner [p. 29].

1. On the computer that has User Manager for Domains, access the Control Panel.
2. Select Administrative Tools.
3. Select Computer Management. The Computer Management dialog box appears.
4. In the tree view, click Local Users and Groups.
5. Click Groups.

If Oracle is installed, you should see a group named ORA_DBA. If not, you must add it. For
more information, see Creating the ORA_DBA group [p. 27].

Next, you need to create server access for users.

Creating the ORA_DBA group

1. In the tree view of the Computer Management utility, right click Groups and choose
New Group. The New Group dialog box appears.

2. In the Group Name box, type ORA_DBA.
3. Click Create.
4. Click Close.

Creating Server Access for Users
To create individual user accounts:

1. In the tree view of the Computer Management utility, click Local Users and Groups.
2. Click Groups.
3. In the right pane, double clickORA_DBA. TheORA_DBAProperties dialog box appears:
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4. Click the Add button. The Select Users, Computers, or Groups dialog box appears:

5. Click Advanced, then use the Common Queries tab to search for users, click Find Now
and select users from the list. Alternatively, click in the Enter the object names to select
field and type the following:
domain name\user ID
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Where domain name is the name of the domain where the user is located and user ID is
the network ID of the user you want to give access to.

6. Click OK to save the user information and return to the ORA_DBA Properties dialog
box.
Repeat steps 4–6 to create any additional user accounts.

7. When you are finished, click OK in the Users Properties dialog box to return to the
Computer Management utility.

Setting Up Users for TestPartner
This section provides instructions for creating users and granting connection rights for users.
This procedure is necessary when using either Oracle OS authentication or Oracle database
authentication. Separate instructions are provided for each type of authentication. For more
information, see Oracle OS Authentication [p. 29], and Oracle Database Authentication [p. 30].

Oracle OS Authentication
This topic provides instructions for creating users and granting connection rights when using
Oracle OS authentication. Prior to performing these steps, consider the following:

• You must be a member of the ORA_DBA group and have SYSDBA privileges.

• Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN
controller.

• Use SQL*Plus or SQL*Plus Worksheet to create users. If you are not familiar with SQL*Plus,
consult your Oracle documentation.

• Users must be created within a Windows NT domain and added to the ORA_DBA group. Refer
to your Microsoft Windows documentation for more information about using a Windows
domain.

• When setting up users for TestPartner in Oracle, a schema must be also created to house the
actual tables in addition to the remotely authenticated users. The schema is not domain
authenticated, but is password authenticated. For more information, see Creating the Password
Authenticated Schema [p. 30].

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "DOMAIN\USERNAME" IDENTIFIED EXTERNALLY,

and grant connection rights and system privileges as shown in the following example. For
each user as "DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and between double
quotation marks, where DOMAIN\USERNAME is each user’s domain and user name. For
example:
CREATE USER "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;

GRANT SELECT ANY SEQUENCE TO "NT-DOMAIN\JEFF";

GRANT UNLIMITED TABLESPACE TO "NT-DOMAIN\JEFF";

GRANT "CONNECT" TO "NT-DOMAIN\JEFF";
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GRANT "RESOURCE" TO "NT-DOMAIN\JEFF";

GRANT "SELECT_CATALOG_ROLE" TO "NT-DOMAIN\JEFF";

IMPORTANT
Microsoft operating systems return the DOMAIN\USERNAME when the user is queried.
If this does not match what is defined in the database, Oracle OS authentication will fail
with ORA-1017.

4. Test that Oracle OS authentication is set up correctly by connecting to the database via
SQL*Plus. Type a "/" for the user name. Leave the Password box blank, and enter the host
string appropriately. Click OK. If you are able to log on, Oracle OS authentication is
working properly.

Oracle Database Authentication
This topic provides instructions for creating users and granting connection rights when using
Oracle database authentication. Prior to performing these steps, consider the following:

• You must be a member of the ORA_DBA group and have SYSDBA privileges.

• Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN
controller.

• Use SQL*Plus or SQL*Plus Worksheet to create users. If you are not familiar with SQL*Plus,
consult your Oracle documentation.

• Users must be created within a Windows NT domain and added to the ORA_DBA group. Refer
to your Microsoft Windows documentation for more information about using a Windows
domain.

• When setting up users for TestPartner in Oracle, a schema must be also created to house the
actual tables in addition to the remotely authenticated users. The schema is not domain
authenticated, but is password authenticated. For more information, see Creating the Password
Authenticated Schema [p. 30].

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED BY “ORACLEPASSWORD”,

and grant connection rights and system privileges as shown in the following example. For
each user as "USERNAME". Type USERNAME in uppercase and between double quotation
marks, where DOMAIN\USERNAME is each user’s user name. For example:
CREATE USER "JEFF" IDENTIFIED BY “ORACLEPASSWORD”;

GRANT SELECT ANY SEQUENCE TO "JEFF"

GRANT UNLIMITED TABLESPACE TO "JEFF"

GRANT "CONNECT" TO "JEFF";

GRANT "RESOURCE" TO "JEFF";

GRANT "SELECT_CATALOG_ROLE" TO "JEFF";

Creating the Password Authenticated Schema
To set up the password authenticated schema into which the TestPartner tables are stored,
perform the following steps:
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NOTE
The password authenticated schema should not be more than five characters in length because
of Oracle character limitations in SQL series.

1. Start SQL*Plus or SQL*Plus Worksheet if it is not started.
2. If you are not properly logged on, log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED AS "ORACLEPASSWORD",

and grant connection rights for each user as "USERNAME". Type USERNAME in uppercase and
between double quotation marks, where USERNAME is each user’s user name. For example:
SQL> create user "TOM" IDENTIFIED AS "ORACLEPASSWORD";

SQL> grant connect, resource to "TOM";

Preparing the Oracle TestPartner Database
You must prepare your new Oracle database for use with TestPartner. This section describes
how to use the Database Maintenance utility to populate the database with TestPartner tables.

1. Click Start>Programs>Micro Focus>Utilities>Database Maintenance to start
TestPartner’s Database Maintenance utility.

2. Click File>New Database>Oracle. The Oracle Data Source Connection dialog box
appears.

3. Type the name of the new Oracle data source or click the Browse button and select a data
source name from the Select ODBC Data Source dialog box.

4. In the appropriate boxes, type the name of the Oracle user ID, and password, and then click
the Create button. The Schema box is filled in automatically with the same information
as the User ID.
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You are now ready to start TestPartner and log on. For more information, see Starting TestPartner
Overview [p. 39].

Setting Up a SQL Server or Oracle Database Without a
Domain

Micro Focus strongly recommends that you use authentication within a domain when setting
up an Oracle or SQL Server database with TestPartner. However, if you are not on a domain,
it is still possible to set up these databases.
This section provides specific instructions for setting up a SQL Server or Oracle database with
a domain.

Creating Users Without a Domain
To set up a SQL Server or Oracle database without a domain, you must first create a user account
on both the client and server computers.

NOTE
This procedure only applies when using Windows NT authentication.

1. Access the Windows Control Panel, and then select Administrative Tools>Computer
Management
The Computer Management utility appears.

2. In the left pane, click Local Users and Groups.
3. Under Local Users and Groups, right-click the Users folder and select New User.

The New User dialog box appears:
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4. Type a valid user name in the User name box, and the corresponding user’s full name in
the Full Name box.

5. Type a valid password in both the Password and Confirm password boxes, and then click
the Create button.

6. Repeat these steps on each client computer using the username and password.

Setting Up SQL Server Without a Domain
To set up SQL Server without a domain:

1. Access the Windows Control Panel, and then select Administrative Tools>Computer
Management.
The Computer Management utility appears.

2. In the left pane, expand Local Users and Groups, and then click Groups.
3. In the right pane, double click Users.

The Users Properties dialog box appears.

33TestPartner Installation Guide

Chapter 4 ∙ Configuring a TestPartner Database



4. Click the Add button.
The Select Users, Computers, or Groups dialog box appears.

5. Click Advanced, then use the Common Queries tab to search for users, click Find Now,
and then select users from the list. Alternatively, click in the Enter the object names to
select box and enter the [user ID] of the user you want to give access.[user ID],:

6. Click OK to save the user information and return to the Users Properties dialog box.
7. Optionally, repeat the previous steps to create additional user accounts.
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8. Click OK to close the dialog box and complete the process.

Setting Up an Oracle Database Without a Domain
To set up Oracle for TestPartner without a domain, follow the procedure for creating server
access for individual user accounts; however, substitute the user name you created in the
procedure for creating users without a domain. For more information, see Creating Server Access
for Users [p. 27].

1. In the Enter the object names to select box, enter the [user name] instead of [domain
name]\[user ID] or [domain name]\[group name].
The Computer Management utility appears.

2. Set up users for TestPartner . For more information, see Setting Up Users for TestPartner
[p. 29].When using SQL*Plus to create users, substitute [computer name\user name]

for [domain name\user name] as shown in the following example.
SQL> create user "FH0002RED\USER1" IDENTIFIED EXTERNALLY;

SQL> grant connect, resource to "FH0002RED\USER1";

NOTE
For the [computer name\user name], use uppercase and enclose in quotes.

Creating a Data Source Name Overview
On each computer that is connecting to the TestPartner SQL Server, Access, or Oracle database,
you must create a data source name (DSN) using the ODBC utility if the TestPartner.

NOTE
This does apply to default SQL Server 2005 Express and Access databases installed by the
TestPartner installer. For these databases, a data source name is automatically created.
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Creating a Data Source Name for an Access Database
On each client computer connecting to an Access database, perform the following steps to set
up a DSN:

1. Access the Control Panel, and then select Administrative Tools>Data Sources (ODBC).
The ODBC Data Source Administrator dialog box appears.

2. Click the SystemDSN tab, then click theAdd button. TheCreate NewData Source dialog
box appears. This dialog box lists the available ODBC drivers.

3. From the list of drivers, select the Microsoft Access Driver and click the Finish button.
The ODBCMicrosoft Access Setup dialog box appears.

4. In the Data Source Name box, type the data source name.
Enter a logical name as this name appears as the database name in TestPartner’s logon
screen.

5. In the Description box, type a description for the data source. For example, Connection
to TestPartner Access database.

6. Click the Select button and browse for your Access database.
7. On the ODBCMicrosoft Access Setup dialog box, click OK.
8. On the ODBC Administrator dialog box, click OK to complete the process.

Creating a Data Source Name for a SQL Server Database
On each client computer connecting to a SQL Server database, perform the following steps to
set up a DSN:

1. Access the Control Panel, and then select Administrative Tools>Data Sources (ODBC).
The ODBC Data Source Administrator dialog box appears.

2. Click the SystemDSN tab, then click theAdd button. TheCreate NewData Source dialog
box appears. This dialog box lists the available ODBC drivers.

3. From the list of drivers, select the SQL Native Client and click the Finish button. The
Create a New Data Source to SQL Server dialog box appears.

4. In the Name box, type the data source name.
Enter a logical name as this name appears as the database name in TestPartner’s logon
screen.

5. In the Description box, type a description for the data source. For example, Connection
to TestPartner SQL Server database.

6. In the Server box, enter the server name or select it from the drop-down list.
7. Click the Next button.
8. Perform one of the following:

• If user(s) using the DSN to access the SQL Server database are connecting with
non-native credentials, select the With Windows authentication using the network
login ID option.

• If user(s) using the DSN to access the SQL Server database are connecting with native
authentication, select the With SQL Server authentication using a login ID and
password entered by the user option. Make sure the Connect to SQL Server to
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obtain the default settings for the additional configuration options check box is
selected. Type the users native SQL Server logon credentials in the Login ID and
Password boxes.

9. Click the Next button.
10. Select the Change the default database to box, and then select your TestPartner database

name from the list.
11. Accept all the other entries and click the Next button until the last panel in the wizard

appears.
12. Accept the defaults and click the Finish button.
13. To test the connection, click the Test Data Source button.

The SQL Server ODBC Data Source Test dialog box appears.

14. Click OK to dismiss the dialog box.
The ODBC Data Source Administrator dialog box reappears. The newly created data
source appears in the System Data Sources list.

15. Click OK to complete the process.

Creating a Data Source Name for an Oracle Database
On each client computer connecting to a SQL Server database, perform the following steps to
set up a DSN:

1. Access the Control Panel, and then select Administrative Tools>Data Sources (ODBC).
The ODBC Data Source Administrator dialog box appears.

2. Click the SystemDSN tab, then click theAdd button. TheCreate NewData Source dialog
box appears. This dialog box lists the available ODBC drivers.
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3. From the list of drivers, select the appropriate Oracle ODBC driver for the version of Oracle
database being used (not the Microsoft ODBC for Oracle driver), and then click the Finish
button. The Create a New Data Source to SQL Server dialog box appears.
The Oracle ODBC Driver Configuration dialog box appears. The following shows the
dialog box for Oracle 10.2.0

4. In the Oracle Data Source Name box, type the data source name.
Enter a logical name as this name appears as the database name in TestPartner’s logon
screen.

5. In the Description box, type a description for the data source. For example, Connection
to TestPartner Oracle database.

6. In the TNS Service Name box, select the service name for the database you would like to
connect to in the format ORACLE_SID.DOMAIN, where ORACLE_SID is the Oracle SID you
assigned to the database upon creation and domain is the domain to which you are
connecting.

7. If using Oracle authentication, type a valid user ID for the database being connected to in
the User ID box. Otherwise, leave the User ID box blank.

8. To test the connection, click the Test Connection button.

NOTE
When using Oracle database authentication, type a username, and then a password. For
Oracle OS authentication, do not specify a username.

A message box appears stating the connection was successful.

9. Click OK to close the message box and complete the Data Source Name creation process.
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C H A P T E R 5

Starting TestPartner

Starting TestPartner Overview
After installing TestPartner and configuring a database, you are ready to start and log on to
TestPartner. This section describes the steps required to set up the login credentials and create
a TestPartner database connection, which defines the relationship between a TestPartner database
and the local TestPartner installation.

Starting and Logging On to TestPartner
To start and log on to TestPartner, perform the following steps:

1. Select TestPartner from the Start menu. The TestPartner splash screen appears, followed
by the TestPartner Logon dialog box.

2. Type a user name in the User Name text box and a password in the Password text box.
If using TestPartner for the first time, an administrative user name and password may be
required. The default user name is Admin and the default password is admin. Change this
password after logging on to prevent unauthorized access.

TIP
Select Tools>Change Password to change your own TestPartner logon password at any
time.

3. Select the TestPartner database to use from the Database list.
For a database to appear in theDatabase list, you must first configure its database connection
for use with TestPartner. To configure a database connection, click the Configure button
on theTestPartner Logon dialog box. For more information, see Configuring a TestPartner
Database Connection [p. 40].

4. Click OK to log on. The TestPartner Start Screen appears.
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Configuring a TestPartner Database Connection
Before you can use a database with TestPartner, you must configure its database connection.
The configuration process consists of using the Configure Database Connection dialog box
to perform the following tasks:

• Specify the database connection data required to initiate the database connection.

• Verify the connection to the database.

• Save the database connection data.

All configured database connections appear in the Database list that is located on the
TestPartner Logon dialog box.
You can also use the Configure Database Connection dialog box to view, edit, and remove
any existing configured database connections.

NOTE
Before configuring a database connection for use with TestPartner, a database instance and
ODBC Data Source Name (DSN) must exist or be created. For more information, refer to the
TestPartner Installation and Configuration Guide.

1. Click theConfigure button on theTestPartner Logon dialog box. TheConfigureDatabase
Connection dialog box appears.
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Figure 1. Configure Database Connection Dialog Box

2. In the Data Source Type field, select the type of data source.
3. From the Select Data Source list, select from the list of available DSNs.
4. Select the Use as a TestPartner database check box to add the selected DSN to the list

of configured database connections that appear in theDatabase list onTestPartner Logon
dialog box. You must select this check box when configuring a database connection for
the first time. For existing configured database connections, clearing the Use as a
TestPartner database check box and clicking theApply button removes the selected DSN
from the Database list on the TestPartner Logon dialog box. TestPartner does not retain
the associated database connection data.

5. Under Database Settings, specify the appropriate information for the selected DSN. For
Access, the Database field is read-only and displays the location of the database file. This
value is read directly from the ODBC DSN. The other Database Settings fields are not
applicable for Access and are disabled. BB For Oracle, the Server text box is read-only
and displays only the database name. This value is read directly from the ODBC DSN. In
the Schema text box, type the appropriate value. CC For SQL Server/MSDE, theDatabase
text box is modifiable and allows you to type the appropriate database name. In the Owner
text box, type the appropriate value.

6. Select a type of authentication. The Authentication field determines the method of
authentication being used and only applies to Oracle or SQL Server/MSDE databases. You
can choose to use either Windows NT authentication or authenticate using the database’s
native authentication capabilities. When selecting database authentication, you must provide
the user name and password in the appropriate fields.
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7. Click Validate to verify that you can connect to the database using the specified database
connection data.

8. Click Apply to save the database connection data.
9. Click Close.
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C H A P T E R 6

Maintaining the Installation

Accessing Maintenance Mode
IMPORTANT
Micro Focus recommends that you exit all non-essential Windows programs before running
this setup program. Some Windows programs may interfere with the installation and maintenance
processes.

To access Maintenance Mode:

1. Access the Windows Control Panel.
2. Depending on your operating system, select Add/Remove Programs or Programs and

Features.
3. Select Micro Focus TestPartner, and then click the Change button. The TestPartner

installation wizard appears and displays the Welcome page.
4. Click Next. The Program Maintenance page appears.

From this page of the wizard, you can access the three maintenance mode options: Modify,
Repair, and Remove.

Repairing a TestPartner Installation
There may be times when you need to repair a damaged TestPartner installation. This could be
due to an inadvertent deletion or corruption of the program. To repair a TestPartner installation:
To repair a TestPartner installation:

1. Access Maintenance Mode. For more information, see Accessing Maintenance Mode
[p. 43].

2. Select the Repair option. Click Next. Setup repairs the TestPartner installation.

43TestPartner Installation Guide



3. After repairing, you may be prompted to restart your computer. If you are prompted to
restart the computer, you can choose to restart it now (recommended) or to restart it later.

4. Click Finish to complete the maintenance.

Removing a TestPartner Installation
To remove a TestPartner installation:

1. Access Maintenance Mode. For more information, see Accessing Maintenance Mode
[p. 43].

2. Select the Remove option. Click Next. The Remove the Program page appears.
3. After removing an installation, you may be prompted to restart your computer. If you are

prompted to restart the computer, you can choose to restart it now (recommended) or to
restart it later.

4. Click Finish to complete the maintenance.
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